Riyad-us-Saliheen - Index

Riyad-us-Saliheen

Compiled By
Al-Imam Abu Zakariya Yahya bin Sharaf An-Nawawi Ad-Dimashqi

  • The book of Miscellany
  • Book One- The Book of Good Manners
  • Book Two- The Book about the Etiquette of Eating
  • Book Three- The Book of Dress
  • Book Four- The Book of the Etiquette of Sleeping, Lying and Sitting, etc.
  • Book Five- The book of Greetings
  • Book Six- The Book of Visiting the Sick
  • Book Seven- The Book of Etiquette of Traveling
  • Book Eight- The Book of Virtues
  • Book Nine- The Book of I'tikaf
  • Book Ten- The Book of Hajj
  • Book Eleven- The Book of Jihad
  • Book Twelve- The Book of Knowledge
  • Book Thirteen- The Book of Praise and Gratitude to Allah
  • Book Fourteen- The Book of Supplicating Allah to Exalt the Mention of Allah's Messenger (phuh)
  • Book Fifteen- The Book of the Remembrance of Allah
  • Book Sixteen- The Book of Du'a (Supplications)
  • Book Seventeen- The Book of the Prohibited Actions
  • Book Eighteen- The Book of Miscellaneous Adadith of Significant values
  • Book Nineteen- The Book of Forgiveness


The book of Miscellany

  • Chapter 1 : Sincerity and Significance of Intentions and all Actions, Apparent and Hidden
  • Chapter 2 : Repentance
  • Chapter 3 : Patience and Perseverance
  • Chapter 4 : Truthfulness
  • Chapter 5 : Watchfulness
  • Chapter 6 : Piety
  • Chapter 7 : Firm Belief and Perfect Reliance on Allah
  • Chapter 8 : Uprightness and Steadfastness
  • Chapter 9 : Pondering over the Great Creation of Allah, The passing away of Life of the World, the Horrors of the Day of Requital and Laxity of One's Nafs
  • Chapter 10 : Hastening to do Good Deeds
  • Chapter 11 : The Struggle (in the Cause of Allah)
  • Chapter 12 : Urging towards increasing Good Actions in later part of Life
  • Chapter 13 : Numerous ways of doing Good
  • Chapter 14 : Moderation in Worship
  • Chapter 15 : The Righteous conduct on Regular base
  • Chapter 16 : Observing the Sunnah and the manners of its obedience
  • Chapter 17 : Obedience to the command of Allah is an obligatory duty
  • Chapter 18 : Prohibition of heresies in religion
  • Chapter 19 : Heretics doing desirable or undesirable deeds
  • Chapter 20 : Calling to right guidance and forbidding depravity
  • Chapter 21 : Assistance towards righteousness and piety
  • Chapter 22 : Giving Counsel
  • Chapter 23 : Enjoining Good and forbidding Evil
  • Chapter 24 : Chastisement for one who enjoins good and forbids evil but acts otherwise
  • Chapter 25 : Discharging the Trusts
  • Chapter 26 : Unlawfulness of Oppression and Restoring Others Rights
  • Chapter 27 : Reverence towards the Sanctity of the Muslims
  • Chapter 28 : Covering Faults of the Muslims
  • Chapter 29 : Fulfillment of the needs of the Muslims
  • Chapter 30 : Intercession
  • Chapter 31 : Making Peace among People
  • Chapter 32 : Superiority of Poor, Weak and unrenowned Muslims
  • Chapter 33 : Benevolent Treatment towards Orphans, Girls, the Weak, the Poor and the Humble Persons
  • Chapter 34 : Recommendations with regard to Women
  • Chapter 35 : Husband's rights concerning his Wife
  • Chapter 36 : Sustentation of the Members of the Family
  • Chapter 37 : Spending favorite things for Allah's sake
  • Chapter 38 : Urging one's kith and kin to Obey Allah and refrain from evils
  • Chapter 39 : Rights of Neighbors
  • Chapter 40 : Kind Treatment towards Parents and establishment of the ties of Blood Relationship
  • Chapter 41 : Prohibition of Disobeying Parents and severance of Relations
  • Chapter 42 : Excellence in doing Good to the Friends of Parents and other Relatives
  • Chapter 43 : Showing reverence to the Family of Allah's Messenger (pbuh)
  • Chapter 44 : Revering the Scholars and Elders, Preferring them to others and raising their Status
  • Chapter 45 : Visiting the Pious Persons, loving them and adoption of their company
  • Chapter 46 : Excellence and Etiquette of Sincere love for the sake of Allah
  • Chapter 47 : Signs of Allah's love for His slaves and the efforts for its Achievement
  • Chapter 48 : Warning against persecution of the Pious, the Weak and the Indigent
  • Chapter 49 : Making Judgment of people keeping in view their evident actions and leaving their hidden Actions to Allah (swt)
  • Chapter 50 : Fear (of Allah)
  • Chapter 51 : Hope in Allah's Mercy
  • Chapter 52 : Excellence of Good Hopes
  • Chapter 53 : Combining Hope and Fear (of Allah)
  • Chapter 54 : Excellence of Weeping out of Fear from Allah (swt)
  • Chapter 55 : Excellence of Leading an Ascetic Life, and Virtues of Simple Life
  • Chapter 56 : Excellence of Simple Living and being Content with Little
  • Chapter 57 : Contentment and Self-esteem and avoidance of unnecessary begging of People
  • Chapter 58 : Permissibility of Assistance without Greed
  • Chapter 59 : Encouraging Livelihood by (working with) Hands and Abstaining from Begging
  • Chapter 60 : Excellence of Generosity and Spending in a Good cause with Reliance on Allah
  • Chapter 61 : Prohibition of Miserliness
  • Chapter 62 : Selflessness and Sympathy
  • Chapter 63 : Competition in matters of the Hereafter
  • Chapter 64 : Excellence of a Grateful Rich Man
  • Chapter 65 : Remembrance of Death and Restraint of Wishes
  • Chapter 66 : Desirability of visiting the Graves for men, and that they should say
  • Chapter 67 : Abomination of longing for Death
  • Chapter 68 : Leading an Abstemious Life and refraining from the Doubtful
  • Chapter 69 : Desirability of Seclusion at times of corruption committed by the people of the World
  • Chapter 70 : Excellence of mixing with People and attending their social activities
  • Chapter 71 : Modesty and Courtesy towards the Believers
  • Chapter 72 : Condemnation of Pride and Self-Conceit
  • Chapter 73 : Good Conduct
  • Chapter 74 : Clemency, Tolerance and Gentleness
  • Chapter 75 : Forgiveness of the Ignorant
  • Chapter 76 : Endurance of Afflictions
  • Chapter 77 : Indignation against the Transgression of Divine Laws
  • Chapter 78 : Obligation of Rulers to show Kindness to their Subjects
  • Chapter 79 : The Just Ruler
  • Chapter 80 : Obligation of Obedience to the Ruler in what is Lawful and Prohibition of Obeying them in what is Unlawful
  • Chapter 81 : Undesirability of Aspiring for Office
  • Chapter 82 : Appointment of Pious Governors, Advisors and Judges
  • Chapter 83 : Prohibition of Appointing an Aspirant Person to a Public Office of Authority


Sincerity and Significance of Intentions and all Actions, Apparent and Hidden

Chapter 1
Sincerity and Significance of Intentions and all Actions, Apparent and Hidden

Allah, the Exalted, says:

"And they were commanded not, but that they should worship Allah, and worship none but Him Alone (abstaining from ascribing partners to Him), and perform As-Salat (Iqamat-as-Salat) and give Zakat, and that is the right religion.'' (98:5)

"It is neither their meat nor their blood that reaches Allah, but it is piety from you that reaches Him.'' (22:37)

"Say (O Muhammad (PBUH) ): Whether you hide what is in your breasts or reveal it, Allah knows it". (3:29)

1. Narrated 'Umar bin Al-Khattab (May Allah be pleased with him), reported: Messenger of Allah (PBUH) said, "The deeds are considered by the intentions, and a person will get the reward according to his intention. So whoever emigrated for Allah and His Messenger, his emigration will be for Allah and His Messenger; and whoever emigrated for worldly benefits or for a woman to marry, his emigration would be for what he emigrated for".
[Al-Bukhari and Muslim].

Commentary: According to some Ahadith, the reason for this Hadith is that a person sent a proposal of marriage to a woman named Umm Qais, which she turned down saying that he should have to emigrate to Al-Madinah for it. Accordingly, he did it for this specific purpose, and the two were married there. On account of this event, the man came to be known among the Companions as Muhajir Umm Qais.

On the basis of this Hadith, 'Ulama' are of the unanimous opinion that the real basis of one's actions is Niyyah (intention) and everyone will be requited according to his Niyyah. It is true that Niyyah is founded in one's heart, that is to say, one has first to make up one's mind for what he intends to do and he should not express it verbally. In fact, the latter is a Bid`ah (innovation in religion) because no proof of it is found in Shariah.

The point which becomes evident from this Hadith is that Ikhlas (sincerity) is a must for every action. In other words, in every righteous deed, one should seek only the Pleasure of Allah; otherwise, it will not be accepted by Allah.

2. Narrated 'A`ishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "An army will raid the Ka`bah and when it reaches a desert land, all of them will be swallowed up by the earth.'' She asked; "O Messenger of Allah! Why all of them?'' He answered, "All of them will be swallowed by the earth but they will be raised for Judgement according to their intentions.''
[Al-Bukhari and Muslim].

Commentary: Everyone will be rewarded or punished according to his aim and intention. This Hadith also proves that the company of depraved persons is extremely dangerous. Whose army would it be, which has been referred to in the Hadith, and when will it invade Ka`bah, is a matter known to Allah Alone. Such prophecies are a part of the Unseen world. Since they come in the category of the miracles of the Prophet (PBUH), it is necessary to believe in their veracity and occurrence. Believing in such prophesies is also essential because they were revealed by Allah).

3. A`ishah (May Allah be pleased with her) narrated that the Prophet (PBUH) said, "There is no emigration after the conquest (of Makkah) but only Jihad [(striving and fighting in the cause of Allah) will continue] and good intention.* So if you are summoned to fight, go forth.''
[Al-Bukhari and Muslim].

*. Intention according to An-Nawawi: It means that goodness which ceased to continue by the cessation of emigration can still be obtained by Jihad and by intending accomplishing good deeds.

Commentary. When a country or a region is regarded as Dar-ul-Islam (land of Islam), it is not necessary to migrate from it to some other place. It is, however, obligatory to emigrate from such regions which are Dar-ul-Kufr (land of infidels) and where it is difficult to adhere to Islamic injunctions. It is also evident from this Hadith that when it is not necessary to migrate from one Islamic country to another then it is also not permitted by the Shari`ah to leave an Islamic country to settle permanently in Dar-ul-Kufr only for the reason that the latter has plenty of wealth and social welfare. Unfortunately, Muslims today are afflicted with this disease. The transfer of their capital and talent to Dar-ul-Kufr is indeed very disturbing because on one side these two factors are lending support to the economy of Bilad-ul-Kufr (countries of infidels) and on the other, obscenity and indecency that are common in such countries, are becoming increasingly common among the Muslims too.

Another highly important reason for the prohibition of migration of Muslims to Dar-ul-Kufr is that it goes against the spirit as well as their readiness for Jihad fi sabilillah (striving and fighting in the way of Allah). This spirit and readiness must be kept always alive so that the Muslims may respond at once to the call of Jihad whenever the need for it arises anywhere.

4. Jabir bin Abdullah Al-Ansari (May Allah be pleasedwith them) reported: We accompanied the Prophet (PBUH) in an expedition when he said, "There are some men in Al-Madinah who are with you wherever you march and whichever valley you cross. They have not joined you in person because of their illness.'' In another version he said: "They share the reward with you.''
[Muslim].

It is narrated by Bukhari from Anas bin Malik (May Allah be pleased with him): We were coming back from the battle of Tabuk with the Prophet (PBUH) when he remarked, "There are people whom we left behind in Al-Madinah who accompanied us in spirit in every pass and valley we crossed. They remained behind for a valid excuse.''

Commentary: What we learn from this Hadith is that if the intention and spirit of Jihad are present in the heart of a Muslim but physically he is unable to take part in it for valid reasons, he will get the reward of Jihad without even his actual participation in it.

5. Ma`n bin Yazid bin Akhnas (May Allah be pleased with them) (he, his father and his grandfather, all were Companions) reported: My father set aside some dinars for charity and gave them to a man in the mosque. I went to that man and took back those dinars. He said: "I had not intended you to be given.'' So we went to Messenger of Allah (PBUH), and put forth the matter before him. He said to my father, "Yazid, you have been rewarded for what you intended.'' And he said to me, "Ma`n, you are entitled to what you have taken.''
[Al-Bukhari].

Commentary:
1. This Hadith leads us to the conclusion that if Sadaqah (charity), goes to a needy son of a Muslim, there is no need to take it back from him for the reason that the father had intended to give it to a deserving person. The former gets the reward for it on account of his Niyyah (intention). This however, will be reckoned as Nafli Sadaqah (voluntary charity) because the obligatory Zakat (Sadaqah) cannot be given to the donor's own dependents.

2. It is permissible in Shari`ah to make someone a Wakil (attorney or agent) for Sadaqah.

3. It does not amount to disobedience on the part of a son to take his father to a competent authority or scholar to know the legal position on any issue, in the same way, as mutual discussion and debate on matters of Shari`ah does not amount to insolence. (Fath Al-Bari, chapter on Zakat).

6. Abu Ishaq Sa`d bin Abu Waqqas (May Allah be pleased with him) (one of the ten who had been given the glad tidings of entry into Jannah) narrated: Messenger of Allah (PBUH) visited me in my illness which became severe in the year of Hajjat-ul-Wada` (Farewell Pilgrimage). I said, "O Messenger of Allah, you can see the pain which I am suffering and I am a man of means and there is none to inherit from me except one daughter. Should I give two-thirds of my property in charity?'' He (PBUH) said, "No". I asked him, "Then half?'' He said, "No". Then I asked, "Can I give away one-third". He said, "Give away one-third, and that is still too much. It is better to leave your heirs well-off than to leave them poor, begging people. You will not expend a thing in charity for the sake of Allah, but you will be rewarded for it; even the morsel of food which you feed your wife''. I said, "O Messenger of Allah, would I survive my companions?'' He said, "If you survive others and accomplish a thing for the sake of Allah, you would gain higher ranking and standing. You will survive them ... your survival will be beneficial to people (the Muslim) and harmful to others (the enemies of Islam). You will survive others till the people will derive benefit from you, and others would be harmed by you.'' Messenger of Allah (PBUH) further said, "O Allah, complete for my Companions their emigration and do not cause them to retract.'' Sa`d bin Khaulah was unfortunate. Messenger of Allah (PBUH) lamented his death as he died in Makkah.
[Al-Bukhari and Muslim].

Commentary: In spite of all their love for it, the Companions of the Prophet (PBUH) did not like to die in a city from which they emigrated for the sake of Allah. For this reason Sa`d (May Allah be pleased with him) was afraid of dying in Makkah. The Prophet (PBUH) prayed for the accomplishment of Sa`d's emigration and expressed regret over the misfortune of Sa`d bin Khaulah. The latter died in Makkah.

Conclusion:
1. The Hadith lays down that in the course of a disease which seems to prove fatal, one cannot give more than one-third of the property in charity.

2. It is also emphasized that one gets reward even for what he spends on his wife and children.

3. One can report to others his ailment or to seek treatment and ask them to supplicate from him.

4. In the matter of Sadaqah (charity), which one gives to seek the Pleasure of Allah, his closest relatives. should always have priority and preference over others.

7. Abu Hurairah (May Allah be pleased with him) narrated: Messenger of Allah (PBUH) said, "Allah does not look at your figures, nor at your attire but He looks at your hearts and accomplishments".
[Muslim].

Commentary: This Hadith highlights the importance of sincerity and good intention. It is, therefore, essential that every noble action should be based on these two virtues; and heart should be free from all such things that destroy noble deeds. Hypocrisy, ostentation, greed for wealth, riches and other wordly things fall in the category of such evils. Since the true condition of heart is known to Allah alone, the true position of one's actions will be known on the Day of Resurrection when one will be requited for them by Alah. In this world, one will be treated according to his apparent condition while his insight will be left to Allah.

8. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported that Messenger of Allah (PBUH) was asked about who fights in the battlefield out of valour, or out of zeal, or out of hypocrisy, which of this is considered as fighting in the cause of Allah? He said: "He who fights in order that the Word of Allah remains the supreme, is considered as fighting in the cause of Allah".
[Al-Bukhari and Muslim].

Commentary: Since one's action will be evaluated in terms of intention, so he alone would be a Mujahid (warrior in the cause of Deen) who fights to glorify the Name of Allah.

9. Abu Bakrah Ath-Thaqafi (May Allah be pleased with him) reported: The Prophet (PBUH) said: "When two Muslims are engaged in a combat against each other with their sword's and one is killed, both are doomed to Hell". I said, "O Messenger of Allah! As to the one who kills, it is understandable, but why the slain one?" He (PBUH) replied: "He was eager to kill his opponent".
[Al-Bukhari and Muslim].

Commentary: This Hadith leads to the conclusion that one would be punished for such sinful intention for which he has made a firm determination, and for the commitment of which he has adopted necessary measures, even if he does not succeed in committing it because of certain obstruction. Thus determination is different from a suggestion of the devil. The latter is excusable while one is accountable for his determination. However, what is mentioned in the Hadith will happen when Muslims fight among themselves for worldly honour and prejudices, and no religious issue would be the cause of their conflict, because in the latter case, it is possible that both might be depending on their own Ijtihad (exercise of opinion) for which they may be excused.

10. Abu Hurairah (May Allah be pleased with him) reported that: The Messenger of Allah (PBUH) said: "The reward for Salat performed by a person in congregation is more than 20 times greater than that of the Salat performed in one's house or shop. When one performs Wudu' perfectly and then proceeds to the mosque with the sole intention of performing Salat, then for every step he takes towards the mosque, he is upgraded one degree in reward and one of his sins is eliminated until he enters the mosque, and when he enters the mosque, he is considered as performing Salat as long as it is the Salat which prevents him (from leaving the mosque); and the angels keep on supplicating Allah for him as long as he remains in his place of prayer. They say: 'O Allah! have mercy on him; O Allah! forgive his sins; O Allah! accept his repentance'. This will carry on as long as he does not pass wind".
[Al-Bukhari and Muslim].

Commentary: This Hadith shows that although it is permissible to perform Salat individually in market places and houses, but its collective performance in the mosque is 25, 26, or 27 times more meritorious, as mentioned in other Ahadith.

11. `Abdullah bin `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said that Allah, the Glorious, said: "Verily, Allah (SWT) has ordered that the good and the bad deeds be written down. Then He explained it clearly how (to write): He who intends to do a good deed but he does not do it, then Allah records it for him as a full good deed, but if he carries out his intention, then Allah the Exalted, writes it down for him as from ten to seven hundred folds, and even more. But if he intends to do an evil act and has not done it, then Allah writes it down with Him as a full good deed, but if he intends it and has done it, Allah writes it down as one bad deed".
[Al-Bukhari and Muslim].

Commentary: What the Prophet (PBUH) relates to Allah is called Hadith Qudsi (Sacred Tradition). Such Hadith is revealed to the Prophet (PBUH) by means of Ilham (inspiration). This Hadith mentions the magnitude of Divine blessings which He bestows upon His faithful slaves on the Day of Resurrection.

12. `Abdullah bin `Umar bin Al-Khattab (May Allah be pleased with them) narrated that: He heard Messenger of Allah (PBUH) as saying: "Three men, amongst those who came before you, set out until night came and they reached a cave, so they entered it. A rock fell down from the mountain and blocked the entrance of the cave. They said: `Nothing will save you from this unless you supplicate to Allah by virtue of a righteous deed you have done.' Thereupon, one of them said: `O Allah! I had parents who were old, and I used to offer them milk before any of my children or slaves. One day, I went far away in search of grazing and could not come back until they had slept. When I milked as usual and brought the drink I found them both asleep. I hated to disturb them and also disliked to give milk to my children before them. My children were crying out of hunger at my feet but I awaited with the bowl in my hand for them to wake up. When they awoke at dawn, they drank milk. O Allah! If I did so to seek Your Pleasure, then deliver us from the distress caused by the rock'. The rock moved slightly but they were unable to escape. The next said: `O Allah! I had a cousin whom I loved more than any one else (in another version he said: as a man can love a woman). I wanted to have sexual intercourse with her but she refused. Hard pressed in a year of famine, she approached me. I gave her one hundred and twenty dinars on condition that she would yield herself to me. She agreed and when we got together (for sexual intercourse), she said: Fear Allah and do not break the seal unlawfully. I moved away from her in spite of the fact that I loved her most passionately; and I let her keep the money I had given her. O Allah! If I did that to seek Your Pleasure, then, remove the distress in which we are.' The rock moved aside a bit further but they were still unable to get out. The third one said: `O Allah! I hired some labourers and paid them their wages except one of them departed without taking his due. I invested his money in business and the business prospered greatly. After a long time, he came to me and said: O slave of Allah! Pay me my dues. I said: All that you see is yours - camels, cattle, goats and slaves. He said: O slave of Allah! Do not mock at me. I assured him that I was not joking. So he took all the things and went away. He spared nothing. O Allah! If I did so seeking Your Pleasure, then relieve us of our distress.' The rock slipped aside and they got out walking freely".
[Al-Bukhari and Muslim].

Commentary:
1. It is permissible to pray through our virtuous deeds. But to make someone a medium for it, is an innovation in Deen which should be avoided for two major reasons. Firstly, there is no evidence in Shari`ah to support this. Secondly, it is against the practice of Khair-ul-Qurun, the best of generations. (This term is used for the first three generations of Muslims, the one in which the Prophet (PBUH) lived and the two following).

2. Preference should be given to the service of parents, even over the service of one's own wife and children.

3. To abstain from sins out of fear of Allah is a highly meritorious act.

4. Labourers should always be treated fairly. If someone has paid to a labourer less than his due, it should be paid to him in a decent manner.

5. Any supplication which is made sincerely, and with real sense of humbleness is granted by Allah.

6. Allah sometimes helps His pious men even in an unusual manner, which is termed as Karamat (wonder or marvel). Thus, like the miracles of the Prophets, wonders of the righteous people are also true. But miracles and wonders both appear with the Will of Allah.


Repentance

Chapter 2
Repentance

Scholars said: It is necessary to repent from every sin. If the offense involves the Right of Allah, not a human, then there are three condition to be met in order that repentance be accepted by Allah:

1- To desist from committing it.

2- To feel sorry for committing it.

3- To decide not to recommit it.

Any repentance failing to meet any of these three conditions, would not be sound.

But if the sin involves a human's right, it requires a fourth condition, i.e., to absolve onself from such right. If it is a property, he should return it to its rightful owner. If it is slandering or backbiting, one should ask the pardon of the offended.

One should also repent from all sins. If he repents from some, his repentance would still be sound according to the people of sound knowledge. He should, however, repent from the rest. Scriptural proofs from the Book and the Sunnah and the consensus of the scholars support the incumbency of repentance.

Allah, the, Exalted says:

"And all of you beg Allah to forgive you, O believers, that you may be successful". (24:31)

"Seek the forgiveness of your Rubb, and turn to Him in repentance". (11:3)

"O you who believe! Turn to Allah with sincere repentance!". (66:8)

13. Abu Hurairah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying: "By Allah, I seek Allah's forgiveness and repent to Him more than seventy times a day.''
[Al-Bukhari].

Commentary:
1. It is an inducement for seeking pardon and forgiveness. The Prophet (PBUH), whose past and future sins were forgiven, asked Allah's forigveness - then how about us, who commit sins on regular basis, not to seek pardon and forgiveness from Allah?

2. Sincere and ceaseless prayer for pardon is essential so that sins committed by us unintentionally are also forgiven. The above Hadith lays great emphasis on seeking pardon.

14. Al-Agharr bin Yasar Al-Muzani (May Allah be pleased with him) narrated that: The Messenger of Allah (PBUH) said: "Turn you people in repentance to Allah and beg pardon of Him. I turn to Him in repentance a hundred times a day".
[Muslim].

15 Anas bin Malik Al-Ansari (MayAllah be pleased with him) the servant of the Messenger of Allah narrated: Messenger of Allah (PBUH) said, "Verily, Allah is more delighted with the repentance of His slave than a person who lost his camel in a desert land and then finds it (unexpectedly)".
[Al-Bukhari and Muslim].

In another version of Muslim, he said: "Verily, Allah is more pleased with the repentance of His slave than a person who has his camel in a waterless desert carrying his provision of food and drink and it is lost. He, having lost all hopes (to get that back), lies down in shade and is disappointed about his camel; when all of a sudden he finds that camel standing before him. He takes hold of its reins and then out of boundless joy blurts out: 'O Allah, You are my slave and I am Your Rubb'.He commits this mistake out of extreme joy".

Commentary:
1. This Hadith also deals with the inducement and merit of repentance and pardon for sins. Allah is highly pleased with repentance.

2 One will not have to account for a mistake made without any purpose and intention.

3. It is permissible to take an oath to stress on one's pardon.

4. One can quote an instance for the purpose of understanding and elaboration.

16. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Prophet (PBUH) said: "Allah, the Exalted, will continue to stretch out His Hand in the night so that the sinners of the day may repent, and continue to stretch His Hand in the daytime so that the sinners of the night may repent, until the sun rises from the west".
[Muslim].

Commentary: This Hadith confirms an essential Attribute of Allah, i.e., the Hand which He stretches out anytime He wishes without drawing similarity to it, nor interpretation. Such was the attitude of the pious predecessors with regards to all of the essential Attributes of Allah. It is deduced from this Hadith that if one commits a sin during any hour of day or night, he should immediately seek the forgiveness of Allah as a result.

17. Abu Hurairah (May Allah be pleased with him) narrated: Messenger of Allah (PBUH) said, "He who repents before the sun rises from the west, Allah will forgive him".
[Muslim].

Commentary: Taubah means returning to Allah from sins. When a person commits a sin, he goes away from Allah. When he repents, he returns to Allah and desires for being pardoned by Him, and getting near Him. This returning towards Him is Taubah. When it is said that `Allah turns towards him', it means that Allah accepts his repentance.

18. `Abdullah bin `Umar bin Al-Khattab (May Allah be pleased with them) reported that: The Prophet (PBUH) said, "Allah accepts a slave's repentance as long as the latter is not on his death bed (that is, before the soul of the dying person reaches the throat)".
[At-Tirmidhi, who categorised it as Hadith Hasan].

Commentary: The word Ghargharah means the stage when soul is about to leave the body and reaches the throat. In other words, the time when one suffers the agony of death.

Hadith Hasan means that Hadith the authenticity of which is connected without any technical defect. Their narrators, however, are next to those of Hadith Sahih. In the opinion of Muhaddithin (Hadith scholars), Hadith Hasan is also reliable as Hadith Sahih.

19. Zirr bin Hubaish reported: I went to Safwan bin `Assal (May Allah be pleased with him) to inquire about wiping with wet hands over light boots while performing Wudu'. He asked me, "What brings you here, Zirr?'' I answered: "Search for knowledge". He said, "Angels spread their wings for the seeker of knowledge out of joy for what he seeks". I told him, "I have some doubts in my mind regarding wiping of wet hands over light boots in the course of performing Wudu' after defecation or urinating. Now since you are one of the Companions of the Prophet (PBUH), I have come to ask you whether you heard any saying of the Prophet (PBUH) concerning it?". He replied in the affirmative and said, "He (PBUH) instructed us that during a journey we need not take off our light boots for washing the feet up to three days and nights, except in case of major impurity (after sexual intercourse). In other cases such as sleeping, relieving oneself or urinating, the wiping of wet hands over light boots will suffice.'' I, then, questioned him, "Did you hear him say anything about love and affection?'' He replied, "We accompanied the Messenger of Allah (PBUH) in a journey when a bedouin called out in a loud voice, `O Muhammad.' The Messenger of Allah (PBUH) replied him in the same tone, `Here I am.' I said to him (the bedouin), `Woe to you, lower your voice in his presence, because you are not allowed to do so.' He said, `By Allah! I will not lower my voice,' and then addressing the Prophet (PBUH) he said, `What about a person who loves people but has not found himself in their company.' Messenger of Allah (PBUH) replied, `On the Day of Resurrection, a person will be in the company of those whom he loves.' The Messenger of Allah then kept on talking to us and in the course of his talk, he mentioned a gateway in the heaven, the width of which could be crossed by a rider in forty or seventy years".

Sufyan, one of the narrators of this tradition, said: "This gateway is in the direction of Syria. Allah created it on the day He created the heavens and the earth. It is open for repentance and will not be shut until the sun rises from that direction (i.e., the West) (on Doomsday)".
[At-Tirmidhi, who categorised it as Hadith Hasan Sahih]

Commentary:
1. We learn from this Hadith that in ablution, it is permissible to wipe over light boots rather than washing the feet. It is called Mash. The period, in which Mash is intact, in case of travellers it is three days and three nights; while for the residents, it is one day and one night only. A precondition for it is that light boots should be clean and worn after full Wudu'. Ankles should also be covered. In case of breach of ablution, the wiping over the socks is sufficient, and there is no need for washing the feet. Wudu' is invalidated by sleeping, call of nature and passing of wind. This is called Hadath Asghar. In the case of Hadath Akbar, which occurs because of coitus, menses and wet dream, washing of the whole body becomes obligatory. It means that the privilege of wiping over the light boots is also finished in this case, in the same way as it does after the expiry of period specified for it.

2. One should associate himself with the pious people so that he is counted among them. One also comes to know many other points from this Hadith which every intelligent person can understand with a little effort.

20. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Prophet of Allah (PBUH) said: "There was a man from among a nation before you who killed ninety-nine people and then made an inquiry about the most learned person on the earth. He was directed to a monk. He came to him and told him that he had killed ninety-nine people and asked him if there was any chance for his repentance to be accepted. He replied in the negative and the man killed him also completing one hundred. He then asked about the most learned man in the earth. He was directed to a scholar. He told him that he had killed one hundred people and asked him if there was any chance for his repentance to be accepted. He replied in the affirmative and asked, `Who stands between you and repentance? Go to such and such land; there (you will find) people devoted to prayer and worship of Allah, join them in worship, and do not come back to your land because it is an evil place.' So he went away and hardly had he covered half the distance when death overtook him; and there was a dispute between the angels of mercy and the angels of torment. The angels of mercy pleaded, 'This man has come with a repenting heart to Allah,' and the angels of punishment argued, 'He never did a virtuous deed in his life.' Then there appeared another angel in the form of a human being and the contending angels agreed to make him arbiter between them. He said, `Measure the distance between the two lands. He will be considered belonging to the land to which he is nearer.' They measured and found him closer to the land (land of piety) where he intended to go, and so the angels of mercy collected his soul".
[Al-Bukhari and Muslim].

In another version: "He was found to be nearer to the locality of the pious by a cubit and was thus included among them". Another version says: "Allah commanded (the land which he wanted to leave) to move away and commanded the other land (his destination) to draw nearer and then He said: "Now measure the distance between them.' It was found that he was nearer to his goal by a hand's span and was thus forgiven". It is also narrated that he drew closer by a slight movement on his chest.

Commentary:
1. One comes to know from this Hadith that the gate of Taubah is open even for the worst of the sinners; and Allah forgives everyone provided he repents sincerely, the conditions for such repentance have already been discussed.

2. It is the duty of a religious scholar that while discussing a problem, he should keep in mind the psychological aspects of the questioner and adopt a policy which neither causes a change in the Injunction of Allah nor make the sinner reckless in his sins out of frustration.

3. When a situation warrants, angels appear in the form of men on Orders of Allah.

21. Abdullah bin Ka`b, who served as the guide of Ka`b bin Malik (May Allah be pleased with him) when he became blind, narrated: I heard Ka`b bin Malik (May Allah be pleased with him) narrating the story of his remaining behind instead of joining Messenger of Allah (PBUH) when he left for the battle of Tabuk. Ka`b said: "I accompanied Messenger of Allah (PBUH) in every expedition which he undertook excepting the battle of Tabuk and the battle of Badr. As for the battle of Badr, nobody was blamed for remaining behind as Messenger of Allah (PBUH) and the Muslims, when they set out, had in mind only to intercept the caravan of the Quraish. Allah made them confront their enemies unexpectedly. I had the honour of being with Messenger of Allah (PBUH) on the night of `Aqabah when we pledged our allegiance to Islam and it was dearer to me than participating in the battle of Badr, although Badr was more well-known among the people than that. And this is the account of my staying behind from the battle of Tabuk. I never had better means and more favourable circumstances than at the time of this expedition. And by Allah, I had never before possessed two riding-camels as I did during the time of this expedition. Whenever Messenger of Allah (PBUH) decided to go on a campaign, he would not disclose his real destination till the last moment (of departure). But on this expedition, he set out in extremely hot weather; the journey was long and the terrain was waterless desert; and he had to face a strong army, so he informed the Muslims about the actual position so that they should make full preparation for the campaign. And the Muslims who accompanied Messenger of Allah (PBUH) at that time were in large number but no proper record of them was maintained.'' Ka`b (further) said: "Few were the persons who chose to remain absent believing that they could easily hide themselves (and thus remain undetected) unless Revelation from Allah, the Exalted, and Glorious (revealed relating to them). And Messenger of Allah (PBUH) set out on this expedition when the fruit were ripe and their shade was sought. I had a weakness for them and it was during this season that Messenger of Allah (PBUH) and the Muslims made preparations. I also would set out in the morning to make preparations along with them but would come back having done nothing and said to myself: 'I have means enough (to make preparations) as soon as I like'. And I went on doing this (postponing my preparations) till the time of departure came and it was in the morning that Messenger of Allah (PBUH) set out along with the Muslims, but I had made no preparations. I would go early in the morning and come back, but with no decision. I went on doing so until they (the Muslims) hastened and covered a good deal of distance. Then I wished to march on and join them. Would that I had done that! But perhaps it was not destined for me. After the departure of Messenger of Allah (PBUH) whenever I went out, I was grieved to find no good example to follow but confirmed hypocrites or weak people whom Allah had exempted (from marching forth for Jihad). Messenger of Allah (PBUH) made no mention of me until he reached Tabuk. While he was sitting with the people in Tabuk, he said, `What happened to Ka`b bin Malik?' A person from Banu Salimah said: "O Messenger of Allah, the (beauty) of his cloak and an appreciation of his finery have detained him.' Upon this Mu`adh bin Jabal (MatAllah be pleased with him) admonished him and said to Messenger of Allah (PBUH): "By Allah, we know nothing about him but good.' Messenger of Allah (PBUH), however, kept quiet. At that time he (the Prophet (PBUH)) saw a person dressed in white and said, `Be Abu Khaithamah.' And was Abu Khaithamah Al-Ansari was the person who had contributed a Sa` of dates and was ridiculed by the hypocrites.'' Ka`b bin Malik further said: "When the news reached me that Messenger of Allah (PBUH) was on his way back from Tabuk, I was greatly distressed. I thought of fabricating an excuse and asked myself how I would save myself from his anger the next day. In this connection, I sought the counsels of every prudent member of my family. When I was told that Messenger of Allah (PBUH) was about to arrive, all the wicked ideas vanished (from my mind) and I came to the conclusion that nothing but the truth could save me. So I decided to tell him the truth. It was in the morning that Messenger of Allah (PBUH) arrived in Al-Madinah. It was his habit that whenever he came back from a journey, he would first go to the mosque and perform two Rak`ah (of optional prayer) and would then sit with the people. When he sat, those who had remained behind him began to put forward their excuses and take an oath before him. They were more than eighty in number. Messenger of Allah (PBUH) accepted their excuses on the very face of them and accepted their allegiance and sought forgiveness for them and left their insights to Allah, until I appeared before him. I greeted him and he smiled and there was a tinge of anger in that. He then said to me, 'Come forward'. I went forward and I sat in front of him. He said to me, `What kept you back? Could you not afford to go in for a ride?' I said, 'O Messenger of Allah, by Allah, if I were to sit before anybody else, a man of the world, I would have definitely saved myself from his anger on one pretext or the other and I have a gifted skill in argumentation, but, by Allah, I am fully aware that if I were to put forward before you a lame excuse to please you, Allah would definitely provoke your wrath upon me. In case, I speak the truth, you may be angry with me, but I hope that Allah would be pleased with me (and accept my repentance). By Allah, there is no valid excuse for me. By Allah, I never possessed so good means, and I never had such favourable conditions for me as I had when I stayed behind.' Thereupon, Messenger of Allah (PBUH) said, 'This man spoke the truth, so get up (and wait) until Allah gives a decision about you.' I left and some people of Banu Salimah followed me. They said to me, `By Allah, we do not know that you committed a sin before. You, however, showed inability to put forward an excuse before Messenger of Allah (PBUH) like those who stayed behind him. It would have been enough for the forgiveness of your sin that Messenger of Allah (PBUH) would have sought forgiveness for you.' By Allah, they kept on reproaching me until I thought of going back to Messenger of Allah (PBUH) and retract my confession. Then I said to them, 'Has anyone else met the same fate?' They said, 'Yes, two persons have met the same fate. They made the same statement as you did and the same verdict was delivered in their case.' I asked, `Who are they?' They said, 'Murarah bin Ar-Rabi` Al-`Amri and Hilal bin Umaiyyah Al-Waqifi.' They mentioned these two pious men who had taken part in the battle of Badr and there was an example for me in them. I was confirmed in my original resolve. Messenger of Allah (PBUH) prohibited the Muslims to talk to the three of us from amongst those who had stayed behind. The people began to avoid us and their attitude towards us changed and it seemed as if the whole atmosphere had turned against us, and it was in fact the same atmosphere of which I was fully aware and in which I had lived (for a fairly long time). We spent fifty nights in this very state and my two friends confined themselves within their houses and spent (most of their) time weeping. As I was the youngest and the strongest, I would leave my house, attend the congregational Salat, move about in the bazaars, but none would speak to me. I would come to Messenger of Allah (PBUH) as he sat amongst (people) after the Salat, greet him and would ask myself whether or not his lips moved in response to my greetings. Then I would perform Salat near him and look at him stealthily. When I finish my Salat, he would look at me and when I would cast a glance at him he would turn away his eyes from me. When the harsh treatment of the Muslims to me continued for a (considerable) length of time, I walked and I climbed upon the wall of the garden of Abu Qatadah, who was my cousin, and I had a great love for him. I greeted him but, by Allah, he did not answer to my greeting. I said to him, `O Abu Qatadah, I adjure you in the Name of Allah, are you not aware that I love Allah and His Messenger (PBUH)?' I asked him the same question again but he remained silent. I again adjured him, whereupon he said, `Allah and His Messenger (PBUH) know better.' My eyes were filled with tears, and I came back climbing down the wall.

As I was walking in the bazaars of Al-Madinah, a man from the Syrian peasants, who had come to sell food grains in Al-Madinah, asked people to direct him to Ka`b bin Malik. People pointed towards me. He came to me and delivered a letter from the King of Ghassan, and as I was a scribe, I read that letter whose purport was: `It has been conveyed to us that your friend (the Prophet (PBUH)) was treating you harshly. Allah has not created you for a place where you are to be degraded and where you cannot find your right place; so come to us and we shall receive you graciously.' As I read that letter I said: 'This is too a trial,' so I put it to fire in an oven. When forty days had elapsed and Messenger of Allah (PBUH) received no Revelation, there came to me a messenger of the Messenger of Allah and said, `Verily, Messenger of Allah (PBUH) has commanded you to keep away from your wife.' I said, `Should I divorce her or what else should I do?' He said, `No, but only keep away from her and don't have sexual contact with her.' The same message was sent to my companions. So, I said to my wife: 'You better go to your parents and stay there with them until Allah gives the decision in my case.' The wife of Hilal bin Umaiyyah came to Messenger of Allah (PBUH) and said: 'O Messenger of Allah, Hilal bin Umaiyyah is a senile person and has no servant. Do you disapprove if I serve him?' He said, `No, but don't let him have any sexual contact with you.' She said, 'By Allah, he has no such desire left in him. By Allah, he has been in tears since (this calamity) struck him.' Members of my family said to me, `You should have sought permission from Messenger of Allah (PBUH) in regard to your wife. He has allowed the wife of Hilal bin Umaiyyah to serve him.' I said, 'I would not seek permission from Messenger of Allah (PBUH) for I do not know what Messenger of Allah might say in response to that, as I am a young man'. It was in this state that I spent ten more nights and thus fifty days had passed since people boycotted us and gave up talking to us. After I had offered my Fajr prayer on the early morning of the fiftieth day of this boycott on the roof of one of our houses, and had sat in the very state which Allah described as: `The earth seemed constrained for me despite its vastness', I heard the voice of a proclaimer from the peak of the hill Sal` shouting at the top of his voice: 'O Ka`b bin Malik, rejoice.' I fell down in prostration and came to know that there was (a message of) relief for me. Messenger of Allah (PBUH) had informed the people about the acceptance of our repentance by Allah after he had offered the Fajr prayer. So the people went on to give us glad tidings and some of them went to my companions in order to give them the glad tidings. A man spurred his horse towards me (to give the good news), and another one from the tribe of Aslam came running for the same purpose and, as he approached the mount, I received the good news which reached me before the rider did. When the one whose voice I had heard came to me to congratulate me, I took off my garments and gave them to him for the good news he brought to me. By Allah, I possessed nothing else (in the form of clothes) except these garments, at that time. Then I borrowed two garments, dressed myself and came to Messenger of Allah (PBUH) On my way, I met groups of people who greeted me for (the acceptance of) repentance and they said: 'Congratulations for acceptance of your repentance.' I reached the mosque where Messenger of Allah (PBUH) was sitting amidst people. Talhah bin `Ubaidullah got up and rushed towards me, shook hands with me and greeted me. By Allah, no person stood up (to greet me) from amongst the Muhajirun besides him.'' Ka`b said that he never forgot (this good gesture of) Talhah. Ka`b further said: "I greeted Messenger of Allah (PBUH) with `As-salamu `alaikum' and his face was beaming with pleasure. He (PBUH) said, `Rejoice with the best day you have ever seen since your mother gave you birth. 'I said: `O Messenger of Allah! Is this (good news) from you or from Allah?' He said, `No, it is from Allah.' And it was common with Messenger of Allah (PBUH) that when ever he was happy, his face would glow as if it were a part of the moon and it was from this that we recognized it (his delight). As I sat before him, I said, I have placed a condition upon myself that if Allah accepts my Taubah, I would give up all of my property in charity for the sake of Allah and His Messenger (PBUH)!' Thereupon Messenger of Allah (PBUH) said, `Keep some property with you, as it is better for you.' I said, 'I shall keep with me that portion which is in Khaibar'. I added: 'O Messenger of Allah! Verily, Allah has granted me salvation because of my truthfulness, and therefore, repentance obliges me to speak nothing but the truth as long as I am alive.'' Ka`b added: "By Allah, I do not know anyone among the Muslims who has been granted truthfulness better than me since I said this to the Prophet (PBUH). By Allah! Since the time I made a pledge of this to Messenger of Allah (PBUH), I have never intended to tell a lie, and I hope that Allah would protect me (against telling lies) for the rest of my life. Allah, the Exalted, the Glorious, revealed these Verses:

'Allah has forgiven the Prophet (PBUH), the Muhajirun (Muslim Emigrants who left their homes and came to Al-Madinah) and the Ansar (Muslims of Al-Madinah) who followed him (Muhammad (PBUH)) in the time of distress (Tabuk expedition), after the hearts of a party of them had nearly deviated (from the Right Path), but He accepted their repentance. Certainly, He is unto them full of kindness, Most Merciful. And (He did forgive also) the three who did not join [the Tabuk expedition and whose case was deferred (by the Prophet (PBUH)) for Allah's Decision] till for them the earth, vast as it is, was straitened and their ownselves were straitened to them, and they perceived that there is no fleeing from Allah, and no refuge but with Him. Then, He forgave them (accepted their repentance), that they might beg for His Pardon [repent (unto Him)]. Verily, Allah is the One Who forgives and accepts repentance, Most Merciful. O you who believe! Be afraid of Allah, and be with those who are true (in word and deeds).'' (9:117,118).

Ka`b said: "By Allah, since Allah guided me to Islam, there has been no blessing more significant for me than this truth of mine which I spoke to Messenger of Allah (PBUH), and if I were to tell a lie I would have been ruined as were ruined those who had told lies, for Allah described those who told lies with the worst description He ever attributed to anybody else, as He sent down the Revelation:

They will swear by Allah to you (Muslims) when you return to them, that you may turn away from them. So turn away from them. Surely, they are Rijsun [i.e., Najasun (impure) because of their evil deeds], and Hell is their dwelling place - a recompense for that which they used to earn. They (the hypocrites) swear to you (Muslims) that you may be pleased with them, but if you are pleased with them, certainly Allah is not pleased with the people who are Al-Fa'siqun (rebellious, disobedient to Allah)". (9:95,96)

Ka`b further added: "The matter of the three of us remained pending for decision apart from the case of those who had made excuses on oath before Messenger of Allah (PBUH) and he accepted those, took fresh oaths of allegiance from them and supplicated for their forgiveness. The Prophet (PBUH) kept our matter pending till Allah decided it. The three whose matter was deferred have been shown mercy. The reference here is not to our staying back from the expedition but to his delaying our matter and keeping it pending beyond the matter of those who made their excuses on oath which he accepted".
[Al-Bukhari and Muslim]

Another version adds: "Messenger of Allah (PBUH) set out for Tabuk on Thursday. He used to prefer to set out on journey on Thursday.'' Another version says: "Messenger of Allah (PBUH) used to come back from a journey in the early forenoon and went straight to the mosque where he would perform two Rak`ah prayer. Afterwards he would seat himself there".

Commentary: This Hadith contains many aspects of warnings and advices, some of which are given below:

1. A Muslim should always speak the truth even if he has to face troubles and turmoil for it because the Pleasure of Allah lies in truth.

2. One must avoid at all costs the attitude of hypocrites because eventually one is ruined by it.

3. In spite of hardship and stringency, one must take part in Jihad.

4. For the admonition and exhortation of others, it gives justification for the economic boycott of even sincere Muslims who adopt wrong methods.

5. One must face with forbearance the difficulties which come in the way of Deen.

6. It is not praiseworthy that one gives in charity all the property he has. One must keep what is needed for the lawful needs.

7. It is lawful to give something by way of gift and reward to a person who congratulates in the events of happiness.

8.The ability to seek pardon is a gift from Allah for which one must express gratitude to Him.

9.Any promise that one makes must be kept, etc. etc.

22. Imran bin Al-Husain Al-Khuza`i (May Allah be pleased with him) reported: A woman from the tribe Juhainah came to Messenger of Allah (PBUH) while she was pregnant from (Zina) adultery and said to him: "O Messenger of Allah! I have committed an offense liable to Hadd (prescribed punishment), so exact the execution of the sentence.'' Messenger of Allah (PBUH) called her guardian and said to him, "Treat her kindly. Bring her to me after the delivery of the child.'' That man complied with the orders. At last the Prophet (PBUH) commanded to carry out the sentence. Her clothes were secured around her and she was stoned to death. The Prophet (PBUH) led her funeral prayers. `Umar submitted: "O Messenger of Allah! She committed Zina and you have performed funeral prayer for her?'' He replied, "Verily, she made repentance which would suffice for seventy of the people of Al-Madinah if it is divided among them. Can there be any higher degree of repentance than that she sacrificed her life voluntarily to win the Pleasure of Allah, the Exalted?''.
[Muslim].

Commentary: This Hadith highlights the following five points:

1. It confirms the validity of the punishment of Rajm for the adulterer, that is to say that he should be stoned to death.

2. The merit of sincere pardon.

3.The description of fear of Allah as well as of accountability on the Day of Resurrection by the Prophet's Companions, and their preference for punishment of sins in this world rather than in the Hereafter.

4. It is permissible to perform the funeral prayer of one who has been guilty of major sins, provided he has not been taking them as lawful because in that case there is danger of disbelief..

5. A pregnant woman cannot be punished with Rajm until she gives birth to the child and the period specified for suckling the baby is completed.

23. Ibn 'Abbas and Anas bin Malik (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "If a son of Adam were to own a valley full of gold, he would desire to have two. Nothing can fill his mouth except the earth (of the grave). Allah turns with mercy to him who turns to Him in repentance".
[Al-Bukhari and Muslim].

Commentary: This Hadith deals with man's greed and his lust for material wealth. Only the person who has a perfect Faith can save himself from it.

24. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah, the Exalted, smiles at two men, one of them killed the other and both will enter Jannah. The first is killed by the other while he is fighting in the Cause of Allah, and thereafter Allah will turn in mercy to the second and guide him to accept Islam and then he dies as a Shaheed (martyr) fighting in the Cause of Allah.''
[Al-Bukhari and Muslim]

Commentary: Even the greatest sins, including those which one has committed before embracing Islam, are forgiven by repentance.

Smiling is also one of the Attributes of Allah, although we are unaware of the nature of it.


Patience and Perseverance

Chapter 3
Patience and Perseverance

Allah, the Exalted, says:

"O you who believe! Endure and be more patient..". (3:200)

"And certainly, We shall test you with something of fear, hunger, loss of wealth, lives and fruits, but give glad tidings to As-Sabirun (the patient)". (2:155)

"Only those who are patient shall receive their reward in full, without reckoning.'' (39:10)

"And verily, whosoever shows patience and forgives, that would truly be from the things recommended by Allah.'' (42:43)

"Seek help in patience and As-Salat (the prayer). Truly, Allah is with As-Sabirun (the patient).'' (2:153)

"And surely, We shall try you till We test those who strive hard (for the Cause of Allah) and As-Sabirun (the patient)'' (47:31)

There are numerous Verses of the Noble Qur'an inculcating patience and extolling it.

25. Abu Malik Al-Harith bin Asim Al-Ash`ar (May Allah be pleased with him) reported that: The Messenger of Allah (PBUH) said: "Wudu' is half of Salah; the utterance of (Al-hamdu lillah - all praise belongs to Allah) fills the Scales of good actions; the utterance of (Subhan Allah wa Al-hamdu lillah) (Allah is far removed from every imperfection and all praise belongs to Allah) fills the space between the heavens and the earth, and Salat (prayer) is light; and charity is the proof of Faith; and endurance is light, and the Qur'an is a plea in your favour or against you. Every person departs; he either ransoms it or puts it into perdition".
[Muslim].

Commentary:
1. Piety in all forms is meritorious. And Faith means Faith in its perfect form. Some people are of the opinion that here Faith means Salat. Purification is essential for Salat and this is the reason it is regarded as half of Salat.

2. Excellence of the remembrance of Allah.

3. Inducement for concentration on Salat because it is a light which provides guidance to a Muslim at every step and prevents him from obscenity and unlawful actions.

4. Sadaqah signifies a Muslim's sincerity and devotion.

5. The praiseworthiness of patience. It is a strong weapon of a Muslim which provides him with steadfastness.

6. The Qur'an is a means of salvation as well as destruction for a Muslim. If one acts upon its orders, it becomes a means of his salvation; if he shuns them, it ruins him.

7. One should not leave oneself idle but keep it busy - busy in some noble work, otherwise it would tend to evil which will eventually ruin him.

8. One should spend this transitory earthly life in the obedience of Allah.

26. Abu Sa'id Al-Khudri (May Allah be pleased with him) reported that: Certain people of the Ansar asked the Messenger of Allah (PBUH) and he gave them; then they again asked him and he gave them until all what he possessed was exhausted. Then the Prophet (PBUH) said, "Whatever wealth I have, I will not withhold from you. Whosoever would be chaste and modest; Allah will keep him chaste and modest and whosoever would seek self-sufficiency, Allah will make him self-sufficient; and whosoever would be patient, Allah will give him patience, and no one is granted a gift better and more comprehensive than patience".
[Al-Bukhari and Muslim].

Commentary: Besides describing generosity, kindness, munificence and nobility of the Prophet (PBUH), he has been ordained by Allah to adopt patience, contentment and self-respect and to avoid anyone's favour.

27. Abu Yahya Suhaib bin Sinan (May Allah be pleased with him) reported that: The Messenger of Allah (PBUH) said, "How wonderful is the case of a believer; there is good for him in everything and this applies only to a believer. If prosperity attends him, he expresses gratitude to Allah and that is good for him; and if adversity befalls him, he endures it patiently and that is better for him".
[Muslim].

Commentary: A Muslim is required to behave in poverty and prosperity, affluence and hardship, in the manner stated in this Hadith. It means that to forget Allah in prosperity, rather than being thankful to Him for His Favour is defiance of His Orders. Similarly, it is unbecoming of a Muslim that in troubles and turmoil, rather being patient, he tends to weeping and crying, grousing and grieving against the Will of Allah.

28. Anas (May Allah be pleased with him) reported: When the last illness of Messenger of Allah (PBUH) made him unconscious, Fatimah (May Allah be pleased with her) exclaimed: "Ah, the distress of my dear father.'' He (PBUH) said, "There will be no distress for your father after today". When he died she said: "My father, Allah has called you back and you have responded to His Call. O father! Garden of Firdaus is your abode. O father! We announce to Jibril your death.'' When he was buried, she said: "Are you satisfied now that you put earth over (the grave of) Messenger of Allah (PBUH)?''
[Al-Bukhari]

Commentary: This Hadith shows that it is permissible to express the trouble and restlessness which one feels at the time of death. Similarly, expression of pain and grief in a natural way in the event of someone's death is also permissible. To remember the virtues of the deceased is also permitted but it is to be free from wailing and moaning, lamentation and crying, and tearing off clothes, etc. The last words of Fatimah (May Allah be pleased with her) are also a way of expressing grief and sadness and not a criticism on the burial of the Prophet (PBUH) because such criticism is prohibited by Shari`ah and no one is exempted from it.

29. Usamah bin Zaid (May Allah be pleased with them) narrated: The daughter of the Prophet (PBUH) sent for him as her child was dying, but the Prophet (PBUH) returned the messenger and sent her good wishes saying, "Whatever Allah takes away or gives, belongs to Him, and everything with Him has a limited fixed term (in this world), and so she should be patient and anticipate Allah's reward.'' She again sent for him adjuring him for the sake of Allah to come. The Messenger of Allah, accompanied with Sa`d bin `Ubadah, Mu`adh bin Jabal, Ubayy bin Ka`b, Zaid bin Thabit and some other men went to see her. The child was lifted up to the Messenger of Allah while his breath was disturbed in his chest. On seeing that, the eyes of the Prophet (PBUH) streamed with tears. Sa`d said, "O Messenger of Allah! What is this?'' He replied, "It is compassion which Allah has placed in the hearts of His slaves, Allah is Compassionate only to those among His slaves who are compassionate (to others)".

Another version says: Messenger of Allah (PBUH) said, "Allah shows compassion only to those among His slaves who are compassionate".
[Al-Bukhari and Muslim].

Commentary:
1. Gathering of all the relatives is not necessary at the time of someone's death. However, their participation in the funeral prayer is Mustahab Fard Kifayah (a desirable collective duty upon all Muslims; but which is sufficient or equivalent to all having performed it if it is performed by only some of them).

2. The desire of the relatives that at the time of someone's death some pious people should be present is quite genuine so that the agonizing process of death is made easy by their prayers.

3. It is lawful that a trustworthy person is made to take an oath and it is essential for the trustee to fulfill it as it increases the mutual trust and love.

4. To shed tears on someone's death, and to advice the relatives of the deceased for patience and accountability are permissible acts.

5. Expression of kindness and love is a gift from Allah and means to gain His Compassion, while deprivation from it is callousness.

30. Suhaib (May Allah be pleased with him) reported that the Messenger of Allah (PBUH) said, "There lived a king before you and he had a court magician. As he (the magician) grew old, he said to the king: `I have grown old, so send me a young boy in order to teach him magic.' The king sent him a young boy to serve the purpose. And on his way (to the magician) the young boy met a monk to whom he listened to and liked it. It became his habit that on his way to the magician, he would meet the monk and sit there and would come to the magician (late). The magician used to beat him because of this delay. He complained about this to the monk who said to him: 'When you feel afraid of the magician, say: Members of my family detained me. And when you fear your family, say: The magician detained me.' It so happened that there came a huge beast and it blocked the way of the people, and the young boy said: 'I will know today whether the magician or the monk is better.' He picked up a stone and said: `O Allah, if the way of the monk is dearer to You than the way of the magician, bring about death to the animal so that the people be able to move about freely.' He threw that stone at it and killed it and the people began to move about freely. He then came to the monk and told him the story. The monk said: `Son, today you are superior to me. You have come to a stage where I feel that you would be soon put to a trial, and in case you are put to a trial, do not reveal me.' That young boy began to heal those born blind and the lepers and he, in fact, began to cure people from all kinds of illnesses. When a courtier of the king who had gone blind heard about him, he came to him with numerous gifts and said, `If you cure me, all these things will be yours.' He said, `I myself do not cure anyone. It is Allah, the Exalted, Alone Who cures; and if you affirm faith in Allah, I shall also supplicate to Allah to cure you.' This courtier affirmed his faith in Allah and Allah cured him. He came to the king and sat by his side as he used to sit before. The king said to him, `Who restored your eyesight?' He said, `My Rubb.' Thereupon he said, 'Do you have another lord besides me?' He said, `My Rubb and your Rubb is Allah.' So the king kept torturing him untill he revealed the young boy. The young boy was thus summoned and the king said to him, 'O boy, it has been conveyed to me that you have become so much proficient in your magic that you cure the blind and the lepers and you do such and such.' Thereupon he said, `I do not cure anyone; it is Allah Alone Who cures,' and the king took hold of him and began to torture him until he revealed of the monk. The monk was summoned and it was said to him: `You should turn back from your religion.' But he refused. The king sent for a saw, placed it in the middle of his head and cut him into two parts that fell down. Then the courtier of the king was brought forward and it was said to him: `Turn back from your religion.' He, too, refused, and the saw was placed in the midst of his head and he was torn into two parts. Then the boy was sent for and it was said to him: `Turn back from your religion.' He refused. The king then handed him over to a group of his courtiers, and said to them: `Take him to such and such mountain; make him climb up that mountain and when you reach its peak ask him to renounce his Faith. If he refuses to do so, push him to his death.' So they took him and made him climb up the mountain and he said: `O Allah, save me from them in any way you like,' and the mountain began to shake and they all fell down (dead) and that young boy came walking to the king. The king said to him, `What happened to your companions?' He said, `Allah has saved me from them.' He again handed him to some of his courtiers and said: `Take him and carry him in a boat and when you reach the middle of the sea, ask him to renounce his religion. If he does not renounce his religion throw him (into the water).' So they took him and he said: `O Allah, save me from them.' The boat turned upside down and they all drowned except the young boy who came walking to the king. The king said to him, `What happened to your companions?' He said, `Allah has saved me from them,' and he said to the king: `You cannot kill me until you do what I command you to do.' The king asked, `What is that?' He said, `Gather all people in one place and tie me up to the trunk of a tree, then take an arrow from my quiver and say: With the Name of Allah, the Rubb of the boy; then shoot me. If you do that you will be able to kill me.' `The king called the people in an open field and tied the young boy to the trunk of a tree. He took out an arrow from his quiver, fixed in the bow and said, `With the Name of Allah, the Rubb of the young boy,' he then shot the arrow and it hit the boy's temple. The young boy placed his hand upon the temple where the arrow had hit him and died. The people then said: `We believe in the Rubb of this young boy.' The king was told: `Do you see what you were afraid of, by Allah it has taken place; all people have believed.' The king then commanded that trenches be dug and fire lit in them, and said: `He who would not turn back from his (the young boy's) religion, throw him in the fire' or `he would be ordered to jump into it.' They did so till a woman came with her child. She felt hesitant in jumping into the fire. The child said to her: `O mother! Endure (this ordeal) for you are on the Right Path".
[Muslim].

Commentary:
1. The most important lesson of this Hadith is that whatever difficulties one has to face on the path of Deen, he should endure it with patience and determination; and if interest of the Deen requires, one should sacrifice his life for it.

2. The wonders displayed by righteous people are true. When Allah's Will and Wisdom requires, He manifests these wonders through His slaves.

3. It is a proof of the truth of the Qur'an that it has retold the great historical event like Ashab-ul-Ukhdud which, buried in the dust of ages, had long been forgotten.

4. It is not possible to explain and interpret the Qur'an without the help of Ahadith. The event of Ashsb-ul-Ukhdud mentioned in the Qur'an is an instance in point. It is the Hadith that has brought into light the details of the event and clarified its ambiguity.

5. Such incidents are a source of strength for the faith of true believers.

31. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) passed by a woman who was crying over a grave and said, "Fear Allah and be patient.'' She said, "Away from me! My calamity has not befallen you and you are not aware of it.'' The woman was later told that it was the Prophet (PBUH) (who had advised her). She came to his door where she found no doorkeeper. She said, "(I am sorry) I did not know you.'' Messenger of Allah (PBUH) said, "Patience is (becoming) only at the first (stroke) of grief".
[Al-Bukhari and Muslim].

Another narration in Muslim says: The woman was crying over her son.

Commentary: This Hadith indicates the excellence of the Prophet's character. The woman whom he advised to have patience did not behave properly, but the Prophet (PBUH) was neither annoyed nor did he reproach her. When she appeared before him for the second time, he again repeated his advice for patience. This Hadith has a great lesson for those who call people to the Right Path. Our scholars and preachers should follow this excellent example.

32. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Allah, the Exalted, says: 'I have no reward other than Jannah for a believing slave of Mine who remains patient for My sake when I take away his beloved one from among the inhabitants of the world".
[Al-Bukhari].

Commentary: Child, wife and parents, etc., are the dearest people to everyone. It is a great sign of Faith to accept their death as the Will of Allah, to bear their loss with patience. Wailing and saying nonsense things show weakness of Faith. The reward of patience on such tragedies is Jannah while the result of impatience is displeasure of Allah.

33. `Aishah (May Allah be pleased with her) reported: I asked the Messenger of Allah (PBUH) about pestilence and he said, "It is a punishment which Allah sends upon whomsoever He wills, but Allah has made it as a mercy to the believers. Anyone who remains in a town which is plagued with pestilence maintaining patience expecting the reward from Allah, and knowing that nothing will befall him other than what Allah has foreordained for him, he would receive a reward of Shaheed".
[Al-Bukhari].

Commentary: To endure patiently in a city where one resides when it is affected by plague or such other epidemics, and not to flee from it, elevates a Muslim to the level of Shahadah in the way of Allah, as is the case in certain other circumstances, like death by drowning or in maternity, etc. This order is based on the consideration that the epidemic should not spread to other cities. On the other hand, residents of other cities are ordered to refrain from visiting the affected city. The Hadith clearly shows that it does not go against faith in Allah to take steps necessary for prevention and cure. Similarly, patience in the event of sickness is a proof of one's perfect faith in the Will of Allah.

34. Anas (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "Allah, the Glorious and Exalted said: `When I afflict my slave in his two dear things (i.e., his eyes), and he endures patiently, I shall compensate him for them with Jannah.".
[Al-Bukhari].

Commentary: Blindness is the greatest deprivation in the world and Allah grants its reward according to His Pleasure. For this reason patience in this case is highly meritorious. Its reward is Jannah provided the blind is enormously rich in Faith.

35. `Ata' bin Abu Rabah reported: Ibn `Abbas (May Allah be pleased with them) asked him whether he would like that he should show him a woman who is from the people Jannah. When he replied that he certainly would, he said, "This black woman, who came to the Prophet (PBUH) and said, `I suffer from epilepsy and during fits my body is exposed, so make supplication to Allah for me.' He (PBUH) replied: 'If you wish you endure it patiently and you be rewarded with Jannah, or if you wish, I shall make supplication to Allah to cure you?' She said, 'I shall endure it.' Then she added: `But my body is exposed, so pray to Allah that it may not happen.' He (Prophet (PBUH)) then supplicated for her".
[Al-Bukhari and Muslim].

Commentary: While continuing medical treatment, one should not ignore his prayer to Allah because both have importance and utility of their own.

36. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: I can still recall as if I am seeing the Messenger of Allah (PBUH) resembling one of the Prophets whose people scourged him and shed his blood, while he wiped blood from his face, he said: "O Allah! Forgive my people, because they certainly do not know".
[Al-Bukhari and Muslim].

Commentary: It mentions the refined character and compassion of the Prophets which has an important lesson for those who preach righteousness. They should be always prepared to face hardships involved in inviting people to the right path and, instead of retaliation, forgive their audience and pray for their guidance. These noble qualities are extremely important for those who are devoted to preach religion.

37. Abu Sa`id and Abu Hurairah (May Allah be pleased with him) reported that the Prophet (PBUH) said: "Never a believer is stricken with a discomfort, an illness, an anxiety, a grief or mental worry or even the pricking of a thorn but Allah will expiate his sins on account of his patience".
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions the special Grace and Mercy of Allah for the Muslims. It relates how Allah turns the hardships and troubles suffered by a Muslim into a means of expiation for his sins. But this is only possible if the believer exercises patience. However, if he starts wailing instead of showing patience then beside suffering hardships, he would be deprived of the reward which lies in bearing them patiently. Thus, he shall have to take the burden of additional sins also.

38. Ibn Mas`ud (May Allah be pleased with him) reported: I visited the Prophet (PBUH) when he was suffering fever. I said, "You seem to be suffering greatly, O Messenger of Allah.'' The Prophet (PBUH) replied, "Yes, I suffer as much as two persons.'' I said, "Is that because you have a double reward?'' He replied that that was so and then said, "No Muslim is afflicted by a harm, be it the pricking of a thorn or something more (painful than that), but Allah thereby causes his sins to fall away just as a tree sheds its leaves".
[Al-Bukhari and Muslim].

Commentary: Prophets have to face more than ordinary troubles and for that reason their reward to bear them is also increased. Thus, the excess of hardships and grief is a sign of perfect Faith and not a sign of Allah's displeasure.

39. Abu Hurairah (May Allah be pleased with him) reported that: The Messenger of Allah (PBUH) said: "He whom Allah intends good, He makes him to suffer from some affliction".
[Al-Bukhari].

Commentary: Troubles of this world like grief, calamity, disease, poverty, loss of life and property, etc., have a benign aspect for a Muslim in the sense that on account of them he turns towards Allah and begs mercy and compassion from Him because of which his sins are forgiven. Thus, in these troubles there is a blessing for him in the Hereafter.

40. Anas (May Allah be pleased with him) reported that: The Messenger of Allah (PBUH) said, "Let not one of you wish for death because of a misfortune which befalls him. If he cannot help doing so, he should say: 'O Allah, keep me alive as long as You know that life is better for me, and make me die when death is better for me".
[Al-Bukhari and Muslim].

Commentary: Since man has no knowledge of his future, whether it is good or bad, so one should never desire for one's own death in consequence of frustration created by troubles and turmoil for two reasons. Firstly, desire for death is sheer impatience. Secondly, it is quite possible that remaining part of his life may be good for his religious and worldly life. So, it is prohibited to desire death. It is, however, permissible to desire for Shahadah or death in Makkah or Al-Madinah but it is a subject quite different from the one under discussion. However, if one has to express wish for his own death, he should do so in the words quoted in the Hadith concerned.

41. Khabbab bin Al-Aratt (May Allah be pleased with him) reported: We complained to the Messenger of Allah (PBUH) regarding the persecution inflicted upon us by the disbelievers while he was lying in the shade of the Ka`bah, having made a pillow of his cloak. We submitted: "Why do you not supplicate for our prevalence (over the opponents)?''. He (PBUH) replied, "Among those people before you, a man would be seized and held in a pit dug for him in the ground and he would be sawed into two halves from his head, and his flesh torn away from his bones with an iron comb; but, in spite of this, he would not wean away from his Faith. By Allah, Allah will bring this matter to its consummation until a rider will travel from San`a' to Hadramout fearing none except Allah, and except the wolf for his sheep, but you are in too much of a hurry".
[Al-Bukhari].

Another narration is: He (PBUH) had placed his cloak under his head and we had been tortured by the polytheists.

Commentary:
1. Difficulties in the path of Faith do not come in any particular period. People devoted to their Deen have passed through trials and tribulations everywhere and in every age and have emerged purified as does the gold after passing through the furnace. So, it is unbecoming for a Muslim to be disturbed by hardships.

2. The glad tidings about domination of religion and peace and security were given in the early period of Islam which were subsequently witnessed by the people. Even now wherever Islam is practised in true sense, peace and security are distinctive features of the system of that country.

42. Ibn Mas`ud (May Allah be pleased with him) reported: After the battle of Hunain, Messenger of Allah (PBUH) favoured some people in the distribution of spoils (for consolation). He gave Al-Aqra` bin Habis and `Uyainah bin Hisn a hundred camels each and showed favour also to some more honourable persons among the Arabs. Someone said: "This division is not based on justice and it was not intended to win the Pleasure of Allah.'' I said to myself: "By Allah! I will inform Messenger of Allah (PBUH) of this.'' I went to him and informed him. His face became red and he said, "Who will do justice if Allah and His Messenger do not?'' Then he said, "May Allah have mercy on (Prophet) Musa (Moses); he was caused more distress than this but he remained patient.'' Having heard this I said to myself: "I shall never convey anything of this kind to him in future".
[Al-Bukhari and Muslim].

Commentary: This Hadith leads to the conclusion that the leader of the people or the calipha has a right, if situation demands, to give to the new Muslims and other influential and respectable people of the society more than others for their satisfaction and encouragement. The man who raised objection on the distribution of booty by the Prophet (PBUH) was a hypocrite. Devout Muslims could never think that the Prophet (PBUH) could be unjust to anyone. This incident also goes to prove that the Prophet (PBUH) also felt as much as others did, the things which infuriated or pleased others, because he was a man and not a superhuman being.

43. Anas (May Allah be pleased with him) reported that: The Messenger of Allah (PBUH) said, "When Allah intends good for His slave, He punishes him in this world, but when He intends an evil for His slave, He does not hasten to take him to task but calls him to account on the Day of Resurrection.''
[At-Tirmidhi].

Commentary: This Hadith shows that, for a Muslim, trials are also a blessing in this world because his sins are forgiven in proportion to the trials he has to face and his reward is increased with the Will of Allah. Thus, a Muslim should always be patient and contented in the event of trial because without these qualities he will not have the privilege associated with them. In fact, his impatience would increase his sins even further.

44. Anas (May Allah be pleased with him) reported: One of the sons of Abu Talhah (May Allah be pleased with him) was ailing. Abu Talhah went out and the boy died in his absence. When he came back, he inquired, "How is the boy?''. Umm Sulaim, the mother of the boy, replied, "Better than before". Then she placed his evening meal before him and he ate it; and thereafter slept with her. At last, she said to him: "Arrange for the burial of the boy". In the morning, Abu Talhah went to Messenger of Allah (PBUH) and informed him of the event. He enquired, "Did you sleep together last night?'' Abu Talhah replied in the affirmative, on which the Prophet (PBUH) supplicated, "O Allah bless them.'' Thereafter, she gave birth to a boy. Abu Talhah said to me: "Take up the boy and carry him to the Prophet (PBUH)''; and he sent some dates with him. The Prophet (PBUH) enquired, "Is there anything with him?'' He said; "Yes, some dates". The Prophet (PBUH) took a date, chewed it and put it in the mouth of the baby and rubbed the chewed date around the baby's gum and named him `Abdullah.
[Al-Bukhari and Muslim].

The narration in Bukhari adds: Ibn `Uyainah relates that a man from the Ansar told him that he had seen nine sons of this `Abdullah, every one of whom had committed the Noble Qur'an to memory.

The narration of Muslim says: The son of Abu Talhah (May Allah be pleased with him) who was born of Umm Sulaim died. She (Umm Sulaim) said to the members of the family: "Do not tell Abu Talhah about his son until I mention it to him myself.'' Abu Talhah came (home) and she gave him supper. He ate and drank. She then beautified herself the best way she ever did and he slept with her. When she saw that he was satisfied after sexual intercourse with her, she said, "O Abu Talhah! If some people borrow something from another family and then (the members of the family) ask for its return, would they refuse to give it back to them.'' He said, "No". She said, "Then hope reward for your son". Abu Talhah got angry, and said; "You left me uninformed until I stained myself (with sexual intercourse) and then you told me about my son. "He went to Messenger of Allah (PBUH) and informed him about the matter. Thereupon Messenger of Allah (PBUH) said, "May Allah bless the night you spent together!'' He (the narrator) said: She conceived. (One day) Messenger of Allah (PBUH) was in the course of a journey and she was along with him. When Messenger of Allah (PBUH) used to come back to Al-Madinah from a journey, he would not enter it (during the night). When the people came near Al-Madinah, she felt labour pains. He (Abu Talhah) remained with her and Messenger of Allah (PBUH) proceeded on. Abu Talhah said: "O Rubb, You know that I love to go along with Messenger of Allah (PBUH) when he goes out and enter along with him when he enters, and I have been detained as You see.'' Umm Sulaim then said: "O Abu Talhah, I do not feel (so much pain) as I was feeling earlier, so we better proceed on. So we proceeded on and she felt the labour of delivery as they reached (Al-Madinah). She gave birth to a male child. My mother said to me: "O Anas, none should suckle him until you go to Messenger of Allah (PBUH) tomorrow morning.'' The next morning I carried the baby with me to Messenger of Allah (PBUH), and narrated the rest of the story.
[Al-Bukhari and Muslim].

Commentary: This Hadith has many lessons for our social life. For instance:
1. The character of a woman of great patience and gratitude is mentioned here. In spite of the death of her child she neither wept and cried nor did she moan and mourn. She was patient to the extent that when her husband came home she looked after all his needs like a loving and obedient wife does and then broke the sad news of the death of their child in a noble manner. Thus, this Hadith holds the lesson that it is the foremost duty of a wife that she should serve her husband well and provide comfort and peace of mind to him.

2. It is meritorious for a wife to beautify herself at home for her husband.

3. One who in his trouble is contented with the Will of Allah, certainly gets a reward for it from Him.

4. Women can also take part with men in Jihad and within the prescribed limits render to Mujahidun (warriors in the cause of religion) the services such as dressing of the wounded, welfare of the patients, supply of food, etc.

45. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The strong man is not one who is good at wrestling, but the strong man is one who controls himself in a fit of rage.''
[Al-Bukhari and Muslim].

Commentary: This Hadith instructs oneself to keep in control in order to overcome his rage.

46. Sulaiman bin Surad (May Allah be pleased with him) reported: I was sitting with the Prophet (PBUH) when two men began to quarrel and curse each other and the face of one of them turned red and the veins of his neck were swollen (from rage). Messenger of Allah (PBUH) said, "I know of a word, if he were to utter that, his rage would vanish and that is: A`udhu billahi minash-Shaitan nir-rajim (I seek refuge with Allah from Satan, the accursed).'' So they (Companions) said to him: "The Prophet (PBUH) tells you to utter: 'I seek refuge with Allah from Satan, the accursed".
[Al-Bukhariand Muslim].

Commentary: In the event of rage if a person becomes conscious that what he is feeling is a suggestion from Satan, he should prevent himself from it; this consciousness is the best remedy to overcome the rage. Those who are easily infuriated could make use of this prescription.

47. Mu`adh bin Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The one who suppresses anger and has the power to give effect to it, will be called out by Allah, the Exalted, to the forefront of the creatures on the Day of Resurrection and he will be asked to choose any of the virgins (Hur) of his liking".
[Abu Dawud and At-Tirmidhi].

Commentary: The word `Hur' is the plural of `Haura', an extremely beautiful woman of fair complexion. The word "Ein" is the plural of "Aina", woman with large eyes. Both the words stand for the most beautiful women who will be awarded to Muslims in Jannah. This Hadith mentions the distinction and reward of self-control of a man who, in spite of being powerful and having the means to avenge, suppresses his rage and does not exercise his power.

48. Abu Hurairah (May Allah be pleased with him) reported: A man asked the Prophet (PBUH) for an advice and he (PBUH) said, "Do not get angry". The man repeated that several times and he replied, "Do not get angry".
[Al-Bukhari].

Commentary:
1. Rage which is declared objectionable is the one which concerns worldly affairs but that which is for Allah and His religion, that is to say, which occurs on the violation of the Injunctions of Allah, is meritorious and essential.

2. Anyone who gets furious quickly should be advised again and again to control his anger so that he becomes conscious of this weakness and tries to overcome it.

3. Rage is a means of fulfillment of satanic aims; so it is a great evil and people are advised to make every effort to prevent themselves from this satanic device.

49. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "A Muslim, male or female, continues to remain under trial in respect of his life, property and offspring until he faces Allah, the Exalted, with no sin record".
[At-Tirmidhi].

Commentary: We come to know from this Hadith that Muslims are special targets of trials, but a redeeming feature of these trials is that Muslims' sins are pardoned through them provided they remain firm in their Faith and patience.

50. Ibn `Abbas (May Allah be pleased with them) reported: 'Uyainah bin Hisn came to Al-Madinah and stayed with his nephew Hurr bin Qais who was among those whom Umar (May Allah be pleased with him) showed favour to. The knowledgeable people (Qurra'), whether they were old or young, had the privilege of joining Umar's council and he used to consult them. 'Uyainah said to Hurr: "My nephew, the Leader of the Believers shows favour to you. Will you obtain permission for me to sit with him?'' Hurr asked `Umar and he accorded permission. When `Uyainah came into the presence of `Umar, he addressed him thus: "O son of Khattab, you neither bestow much on us nor deal with us justly.'' `Umar (May Allah be pleased with him) got angry and was about to beat him up when Hurr said: ``O Leader of the Believers, Allah said to His Prophet (PBUH): ' Show forgiveness, enjoin what is good, and turn away from the foolish (i.e., don't punish them).' (7:199) This one is from the ignorants. When Hurr recited this, `Umar became quite motionless in his seat. He always adhered strictly to the Book of Allah.
[Al-Bukhari].

Commentary:
1. In this Hadith, the word `Qurra' does not stand for the kind of the `Qurra' (reciters) of the present age who are only professional in the art of reciting the Qur'an and have a melodious voice, but what it really meant was the class of scholars who were well-versed in its meanings and implications and who could thoroughly distinguish between the lawful and the unlawful, fair and foul. Such men used to be the companions of the early noble caliphs. It leads to the conclusion that rulers should choose their advisors from religious scholars and not from those who are given to the world and whose sole aim in life is to amass wealth rather than care about the welfare of the people and whose advice is based on selfish motives and vested interests.

2. Since scholarship and piousness are the foremost qualifications for counsellors and advisors, there is no restriction of age for them.

3. The ruler should always be very considerate and tolerant.

4. The ruler should never hesitate from accepting truth and righteousness.

51. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "You will see after me favouritism and things which you will disapprove of.'' They submitted: "What do you order us to do (under such circumstances)?'' He replied, "Discharge your obligations and ask your rights from Allah".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells that if you have rulers who deny your rights and give themselves and their relatives preference over you then patience is a better recourse. Rather than revolting against them, you should seek pardon and forgiveness from Allah and pray for His Protection against the mischief and tyranny of the rulers provided they do not show outright disbelief.

52. Usaid bin Hudhair (May Allah be pleased with him) reported that: A person from among the Ansar said, "O Messenger of Allah! You appointed such and such person and why do you not appoint me?'' Messenger of Allah (PBUH) said, "After me you will see others given preference to you, but you should remain patient till you meet me at the Haud (Al-Kauthar in Jannah)".
[Al-Bukhari and Muslim].

Commentary:
1. The prophecy of the Prophet (PBUH) came true, which is a miracle as well as an evidence of his truthfulness.

2. The Haud (pond) mentioned here is Haud Al-Kauthar which is granted to the Prophet (PBUH) in Jannah or in the field where people will be assembled on the Day of Resurrection. There he will offer his followers cups of pure drink with his own hands. It will be such that one who would take it will never feel thirst again.

3. Demand for an office is not a pleasant quality. It is, therefore, prohibited to give office to a person who demands it. It is, however, permissible only in case a person feels that he is more competent than others and there is no one else in view who is more intelligent, capable and pious.

53. `Abdullah bin Abu Aufa (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) at one time when he confronted the enemy, and was waiting for the sun to set, stood up and said, "O people! Do not long for encountering the enemy and supplicate to Allah to grant you security. But when you face the enemy, show patience and steadfastness; and keep it in mind that Jannah lies under the shade of the swords.'' Then he invoked Allah, saying, "O Allah, Revealer of the Book, Disperser of the clouds, Defeater of the Confederates, put our enemy to rout and help us in over-powering them".
[Al-Bukhari and Muslim].

Commentary:
1. Although great stress has been laid on full preparation and readiness for Jihad, it is prohibited to wish for war with enemy.

2. Patience is a great weapon of a Muslim. In the context of Jihad, it means steadfastness, fortitude and fearlessness of death in the battlefield.

3. Muslims are ordained not to rely entirely on weapons, material resources and their military prowess. They are advised to pray to Allah for victory over their enemy.


Truthfulness

Chapter 4
Truthfulness

Allah, the Exalted, says:

"O you who believe! Be afraid of Allah, and be with those who are true (in words and deeds)". (9:119)

"...the men and women who are truthful (in their speech and deeds)..". (33:35)

"...then if they had been true to Allah, it would have been better for them". (47:21)

54. Abdullah bin Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Truth leads to piety and piety leads to Jannah. A man persists in speaking the truth till he is enrolled with Allah as a truthful. Falsehood leads to vice and vice leads to the Fire (Hell), and a person persists on telling lies until he is enrolled as a liar".'
[Agreed upon].

Commentary: Siddiq (veracious) and Kadhdhab (liar) both are adjectives of intensive degree. That is to say, the words stand respectively for someone whose truth has become his second nature; and in the opposite case, one is a liar who is in the habit of telling lies. As one acquires a reputation in this world for his good or bad deeds similar is his position before Allah. One who is ranked among the truthful with Him is entitled to reward, and if one is a liar, he has to suffer retribution for it. This Hadith provides incentive for truthfulness because it is a source of every good deed and contains a warning against lying as it gives rise to all kinds of mischief.

55. Hasan bin `Ali (May Allah be pleased with them) said: I remember (these words) from Messenger of Allah (PBUH): "Give up what is doubtful to you for that which is not doubtful; for truth is peace of mind and falsehood is doubt".
[At-Tirmidhi].

Commentary: This Hadith leads us to the conclusion that one must always avoid doubtful things so that he does not do anything unlawful. This message is repeated in another Hadith which says that he who has saved himself from doubts has in fact saved his Faith and honour.

56. Abu Sufyan (May Allah be pleased with him) reported, in course of his detailed narration about Heraclius when the latter questioned him about the teachings of the Prophet (PBUH) He said that: He (PBUH) told (us): "Worship Allah Alone and do not associate a thing with Him; and give up all that your ancestors said. "He also commands us to perform Salat (prayers), to speak the truth, to observe modesty and to strengthen the ties of kinship.
[Al-Bukhari and Muslim].

Commentary: In this Hadith an enemy of the Prophet (PBUH) acknowledges the veracity of the Prophet's teaching, because Abu Sufyan (May Allah be pleased with him) made this admission when he was a pagan. This Hadith is mentioned in detail in Sahih Al-Bukhari.

57. Abu Thabit from Sahl bin Hunaif (May Allah be pleased with him) said: The Prophet (PBUH) said: "He who asks Allah for martyrdom, Allah will raise him to the high status of the martyrs, even if he dies on his bed".
[Muslim].

Commentary: This Hadith highlights the merit and importance of sincere intention which in fact is so great that by virtue of it Allah raises a person's status to that of a martyr. On the contrary, persons of foul intention will be consigned to Hell by Allah even if they die in Jihad.

58. Abu Hurairah (May Allah be pleased with him) reported that the Messenger of Allah (PBUH) said: "One of the earlier Prophets who was out on an expedition proclaimed among his people that no man should follow him who had married a woman with whom he wished to cohabit but had not yet done so, or who had built houses on which he had not yet put the roofs, or who had bought sheep or pregnant she-camels and was expecting them to produce young. He, then, went on the expedition and approached the town at the time of the 'Asr prayer or little before it. He then told the sun that both it and he were under command and prayed Allah to hold it back for them, so it was held back till Allah gave him victory. He collected the spoils and it (meaning fire) came to devour these, but did not. He said that among the people there was a man who stole from the booty. He told them that a man from every tribe must swear allegiance to him, and when a man's hand stuck to his, he said: "There is thief among you and every individual of your tribe must swear allegiance to me". (In course of swearing of allegiance,) hands of two or three persons stuck to his hand. He said: "The thief is among you". They brought him a head of gold like a cow's head and when he laid it down, the fire came and devoured the spoils. Spoils were not allowed to anyone before us, then Allah allowed spoils to us as He saw our weakness and incapacity and allowed them to us".
[Al-Bukhari and Muslim].

Commentary:
1. In the opinion of Imam As-Suyuti, the Prophet (PBUH) referred to in this Hadith was Prophet Yusha` bin Nun (Joshua). His conduct shows that it is necessary to make suitable arrangements for the worldly needs of those who are engaged in the Cause of Allah so that they can concentrate on their struggle without any distraction.

2. The lawfulness of the booty of war fought in the way of Allah is a specialty of the Muslim Ummah. Before the advent of Islam (the Shar'iah of Prophet Muhammad (PBUH)), the booty of war which was free from dishonesty used to be consumed by fire. This Hadith also confirms the miracle of the Prophet Yusha' (Joshua) in which the movement of the sun was stopped until he had conquered the village.

59. Hakim bin Hizam (May Allah be pleased with him) reported that: Messenger of Allah (PBUH) said: "Both parties in a business transaction have a right to annul it so long as they have not separated; and if they tell the truth and make everything clear to each other (i.e., the seller and the buyer speak the truth, the seller with regard to what is purchased, and the buyer with regard to the money) they will be blessed in their transaction, but if they conceal anything and lie, the blessing on their transaction will be eliminated.''
[Al-Bukhari and Muslim].

Commentary: Here, the two persons engaged in business are seller and buyer. The word 'right' here means that so far both of them are present at the spot where business is being transacted they have a right to cancel their bargain. In other words, even after the mutual acceptance of the terms of the bargain so long as they are present at the spot they are entitled to cancel the deal until the time they separate from each other. Generally, people do not think it permissible to cancel the bargain after it has been settled even though both parties are present there, but this is not correct. Their view is contradicted by the Hadith.Truthfulness is a means of blessings in the business while falsehood and hiding of any defect of the merchandise detract from its blessings.


Watchfulness

Chapter 5
Watchfulness

Allah, the Exalted, says:

"Who sees you (O Muhammad (PBUH)) when you stand up (alone at night for Tahajjud prayers). And your movements among those who fall prostrate (to Allah in the five compulsory congregational prayers)". (26:218,219)

"And He is with you (by His Knowledge) wheresoever you may be". (57:4)

"Truly, nothing is hidden from Allah, in the earth or in the heaven". (3:5)

"Verily, your Rubb is Ever Watchful (over them)". (89:14)

"Allah knows the fraud of the eyes, and all that the breasts conceal". (40:19)

60. 'Umar bin Al-Khattab (May Allah be pleased with them) said: Once we were sitting in the company of Messenger of Allah (PBUH) when there appeared a man dressed in very white clothes and having extraordinary black hair. No signs of fatigue of journey appeared on him and he was known to none of us. He sat down facing the Prophet (PBUH) leaning his knees against the knees of the Prophet (PBUH) and placing both of his palms over his two thighs and said, "O Muhammad (PBUH)! Tell me about Islam". He (PBUH)replied, "Islam is to testify that none has the right to be worshipped but Allah, and that Muhammad (PBUH) is the Messenger of Allah; that you observe Salat (prayers), pay Zakat, observe Saum (fasting) of Ramadan and perform Hajj (pilgrimage) of the House, provided you have resources of making journey to it.'' He replied: "You have spoken the truth". We were surprised to see that he had asked him and confirmed the correctness of the answers. He then enquired: "Tell me about Iman". He (PBUH) said. "It is to believe in Allah, and His Books, and His Messengers and the Last Day and that you believe in foreordainment, its bad and good consequences.'' He said, "You have spoken the truth.'' He then enquired: "Tell me about Ihsan.'' He (PBUH) said, "It is to worship Allah as if you are seeing Him; and although you do not see Him, He sees you". He enquired: "Inform me about the Hour (i.e., the Day of Resurrection)". He (PBUH) replied, "I have no more knowledge thereof than you". He said, "Inform me about some of its signs". He (PBUH) said, "They are - that a bondswoman gives birth to her own master, and that you will find the barefooted, naked, poor shepherds competing one another in the construction of higher buildings". Then he departed. The Messenger of Allah kept silent for a while then he said to me, "O `Umar! Do you know who the questioner was?'' I replied, "Allah and His Messenger know better". The Prophet (PBUH) said, "He was Jibril (Gabriel); he came to you to teach you your religion".
[Muslim].

Commentary: This Hadith is known as 'Hadith Jibril'. It mentions the basics of Islam the details of which are known to every Muslim. Al-Qadr (Divine foreordainment) means that Allah already knows and had recorded everything that will happen until the Day of Resurrection. Now whatever happens is in accordance with that knowledge and writing. What is meant by its good and bad consequences can be illustrated by saying that tranquillity, prosperity and abundance of crops come in the category of good consequences. Famine, calamities and troubles, etc., fall in the list as evil consequences. But we regard them good or bad according to our own understanding; otherwise, every action of Allah has some wisdom and expedience which are known to Him Alone.

61. Abu Dharr and Mu`adh bin Jabal (May Allah be pleased with them) reported that: Messenger of Allah (PBUH) said, "Fear Allah wherever you are, do good deeds after doing bad ones, the former will wipe out the latter, and behave decently towards people".
[At-Tirmidhi].

Commentary: Virtue obliterates vice means that virtue becomes an atonement for sin. But this applies to minor sins only because major ones will not be forgiven without sincere repentance. Similar is the case of encroachment on public rights which will not be forgiven without their compensation.

62 Ibn Abbas (May Allah be pleased with them) said: One day, I was riding behind the Prophet (PBUH) when he said, "O boy! I will instruct you in some matters. Be watchful of Allah (Commandments of Allah), He will preserve you. Safeguard His Rights, He will be ever with you. If you beg, beg of Him Alone; and if you need assistance, supplicate to Allah Alone for help. And remember that if all the people gather to benefit you, they will not be able to benefit you except that which Allah had foreordained (for you); and if all of them gather to do harm to you, they will not be able to afflict you with anything other than that which Allah had pre-destined against you. The pens had been lifted and the ink had dried up".
[At-Tirmidhi].

Another narration is: Messenger of Allah (PBUH) said, "Safeguard the Commandments of Allah, you will find Him before you. Remember Him in prosperity and He will remember you in adversity. Be sure that which you miss, was not to hit you; and what hits you, was never to miss you. Remember that the Help of Allah is obtained with patience, and relief emerges after distress, prosperity follows adversity, and hardship is followed by ease".

Commentary:
1. No one has the power to change the Decision of Allah.

2. Whatever trouble one has to suffer in this world, it does not last for ever. Every trouble is followed by prosperity, pleasure and happiness.

3. One should never ask other than Allah anyone's help in supernatural way because it amounts to ascribing partnership with Allah. If a person is mindful of the Rights of Allah, then Allah, in return takes care of his needs and helps him.

63. Anas (May Allah be pleased with him) said: You indulge in (bad) actions which are more insignificant to you than a hair while we considered them at the time of Messenger of Allah (PBUH) to be great destroying sins".
[Al-Bukhari].

Commentary: The less fear of Allah, one has the more disobedient he becomes to Him. As the fear of Allah decreases, one becomes more bold in committing sins. As the Companions of the Prophet (PBUH) were intensely fearful of Allah, they were afraid of committing even very minor sins.

64. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, 'Verily, 'Allah, the Exalted, becomes angry, and His Anger is provoked when a person does what Allah has declared unlawful".
[Al-Bukhari and Muslim].

Commentary: Commitment of unlawful acts calls for the displeasure and Wrath of Allah.

65. Abu Hurairah (May Allah be pleased with him) said that: He heard the Prophet (PBUH) said: "There were three men among the Banu Israel, one leper, one bald and one blind. Allah wanted to test them. He therefore, sent to them an angel who came to the leper and asked him what he would like best. He replied: "A good colour, a good skin and to be rid of what makes me loathsome to people". He (the angel) rubbed him and his loathsomeness vanished and he was given a good colour and a good skin. He then asked him what type of property he would like best. The leper replied that he would like camels - [or perhaps he said cattle, for Ishaq (one of the subnarrator of the Hadith) was uncertain, either said: 'Camels,' or: 'Cattle']. He was given a pregnant she-camel. The angel invoked for Allah's Blessing on it. The angel then went to the bald man and asked him what he would like best and he replied: "Good hair and to be rid of what makes me loathsome to people". The angel ran his hand over him and he was given good hair. He then asked him what property he would like best. He replied that he would like cattle, so he was given a pregnant cow. The angel invoked Allah's Blessing on it. The angel then went to the blind man and asked him what he would like best, and he replied: "I wish that Allah restore my sight to me so that I may see people.'' Thereupon the angel ran his hand over him and Allah restored his sight. The angel then asked what property he would like best. He replied that he would like sheep, so he was given a pregnant ewe. Flocks and herds were produced for the three men, the first having a valley full of camels, the second one, a valley full of cows and the third one full of sheep. Then the angel came in the form of a leper, to the one who had been a leper, and said: "I am a poor man and my resources have been exhausted in my journey, and my only means of reaching my destination are dependent on Allah and then on you, so I ask you by Him Who gave you the good colour, the good skin and the property, for a camel by which I may get to my destination". He replied: "I have many dues to pay.'' The angel then said: "I think I recognize you. Were you not a leper whom people found loathsome and a poor man to whom Allah gave property?'' He replied: "I inherited this property through generations". The angel said: "If you are telling a lie, may Allah return you to your former condition". The angel went in the form of a bald man to the one who had been bald, and said the same as he had said to the former and received a similar reply. So he said: "If you are telling a lie, may Allah return you to your former condition". The angel then went to the one who had been blind and said: "I am a poor traveller and my resources have been exhausted in my journey. My only means of reaching my destination are dependant on Allah and then on you, so I ask you by Him Who restored your eyesight for a sheep by which I may get to the end of my journey". He replied: "Yes, I was blind. Allah restored my eyesight, so take what you wish and leave what you wish. I swear by Allah that I shall not argue with you today to return anything you take, as I give it for Allah's sake". The angel said: "Keep your property. You have all simply been put to a test, and Allah is pleased with you and displeased with both of your companions".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that abundance of property and wealth is also a trial. He alone succeeds in this trial who in the midst of his riches does not forget about Allah's Status and his own status. Rather than becoming proud of his wealth, he takes pleasure in spending it in fulfilling the needs of people and expresses gratitude to Him in practical terms. Those who take an opposite course are regarded unsuccessful because on account of their wrong attitude, they tend to falsehood, pride and miserliness which cause the displeasure of Allah.

66. Shaddad bin Aus (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A wise man is the one who calls himself to account (and refrains from doing evil deeds) and does noble deeds to benefit him after death; and the foolish person is the one who subdues himself to his temptations and desires and seeks from Allah the fulfillment of his vain desires".
[At-Tirmidhi].

Commentary: This Hadith highlights the importance of the accountability of one's self. Mere desires which are not coupled with practical efforts are of no avail because Allah grants reward on good deeds and not on yearnings and desires which are not supported by noble actions.

67. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "It is from the excellence of (a believer's) Islam that he should shun that which is of no concern to him".
[At-Tirmidhi].

Commentary: This Hadith lays down a very important principle that one should avoid senseless talk and actions. If one acts upon this principle, he can save himself from many sins and evils.

68. `Umar (May Allah be pleased with him) reported that: The Prophet (PBUH) said, "No man shall be asked for the reason of beating his wife".
[Abu Dawud].

Commentary: This Hadith is also reported by Ibn Majah and Ahmad. Sheikh Al-Albani* has classified this Hadith as `weak' since its narration is not authenticated, therefore its contents are also not valid. Islam has not given the husbands absolute right over their wives and that they will not be questioned in the Hereafter or that they should not be questioned for their action and misbehaviour with the wives. On the contrary, Islam has stressed upon them to be lenient and tender in relation with wives; and this means that they will be taken to task for any wrong and injustice done by them to their wives.

* Sh. Al-Albani is the leading authority in the science of Hadith.


Piety

Chapter 6
Piety

Allah, the Exalted, says:

"O you who believe! Fear Allah as He should be feared". (3:102)

"So, keep your duty to Allah and fear Him as much as you can...'' (64:16)

This second Verse explains the meaning of the first one.

"O you who believe! Keep your duty to Allah and fear Him, and speak (always) the truth". (33:70)

"... And whosoever fears Allah and keeps his duty to Him, He will make a way for him to get out (from every difficulty). And He will provide him from (sources) he never could imagine...'' (65:2,3)

"If you obey and fear Allah, He will grant you Furqan [(a criterion to judge between right and wrong), or (Makhraj, i.e., a way for you to get out from every difficulty)], and will expiate for you your sins, and forgive you; and Allah is the Owner of the great bounty". (8:29)

69. Abu Hurairah (May Allah be pleased with him) reported: It was asked, "O Messenger of Allah! Who is the most honourable amongst mankind?'' He (PBUH) said, "The most honourable of them is one who is the most pious of them.'' They said, "We are not asking about this". He said, "Then, the most honourable of men was Yusuf (Joseph), the Prophet of Allah, the son of Allah's Prophet, who was the son of the Prophet of Allah, who was the son of the Khalil of Allah (i.e., Ibrahim (PBUH))' They said, "We are not asking you about this.'' He enquired, "Are you then asking me about the classes of the Arabs? The best of them in the Pre-Islamic Period of Ignorance are the best of them in Islam, provided they comprehend the religious knowledge".
[Al-Bukhari and Muslim].

Commentary: We come to know from this Hadith that the families which enjoyed popularity and prestige for their eminent qualities (like generosity, chivalry, honesty, etc.) in the pre-Islamic period were also credited for these values after their acceptance of Islam. But now their respect was qualified with their religious knowledge and practice. Their capabilities, self-respect and other qualities were turned towards a different direction. These qualities which were previously used for paganism were now devoted for Islam.

70. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The life of the world is sweet and green. Allah makes you generations succeeding one another so that He may try you in respect of your actions. So beware of the beguilements of the world and those of women. The first trial of Banu Israel was through women".
[Muslim].

Commentary: Wealth and property of this world are favourites of everyone like the fresh fruit which is sweet, delicious and attractive for all. Everyone likes them and is attracted towards them. The most delicious fruit of this world is woman but at the same time it is the most baneful. One who inclines towards wealth and women and ignores the Islamic legal injunctions, has at stake both his Deen and Faith; and one who benefits from them keeping oneself within the bounds of Islam, would be safe from their ruinous effects.

71. `Abdullah bin Mas`ud (May Allah be pleased with him) reported that the Prophet (PBUH) used to say: "Allahumma inni as'alukal-huda wat-tuqa wal-`afafa wal-ghina (O Allah! I ask You for guidance, piety, chastity and self-sufficiency)".
[Muslim].

Commentary: This Hadith contains four words, the meanings and implications of which constitute its essence. These words are guidance, piety (fear of Allah), chastity and sufficiency. Guidance here means guidance at every turn of life and steadfastness on the path of truth. Fear of Allah is the greatest means of piety and strongest defense against sins. Chastity is the state of being free from what is unlawful. Self-sufficiency is the antonym of poverty and here it means the self-contentment. What it implies is that one should not care for what people possess. In view of all these qualities, the prayer of the Prophet (PBUH) mentioned in this Hadith is very comprehensive and valuable.

72. `Adi bin Hatim At-Ta'i (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) say: "He who has taken an oath (to do something) but found something else better than that (which brings him closer to Allah), then he should do that which is better in piety (and he should expiate for the breaking of oath)".
[Muslim].

Commentary: This Hadith emphasizes the importance of having the fear of Allah. So much so that if somebody has made a vow to commit some sin he should break it, arrange for its expiation and keep himself away from that sin or any other act that contravenes the fear of Allah.

73. Abu Umamah (May Allah be pleased with him) said: I heard Messenger of Allah (PBUH) during the sermon of the Farewell Pilgrimage saying, "Be mindful of your duty to Allah; perform your five daily Salat, observe Saum during the month (of Ramadan) , pay the Zakat on your properties and obey your leaders; (if you do so) you will enter the Jannah of your Rubb".
[At-Tirmidhi].

Commentary: The word Wada`, means to say farewell. The Farewell Pilgrimage was the last pilgrimage, the Prophet (PBUH) performed, and on this occasion he bade farewell to the people and for this reason it came to be known as Hajjat-ul-Wada`. Obedience of the rulers is stressed but it is conditional, that is to say, they are to be obeyed only if their orders are not against the injunctions of Allah. Similarly, their obedience is obligatory till such time that they do not do anything which amounts to open disbelief. If any of these two things occurs, then no obedience would be due to them.


Firm Belief and Perfect Reliance on Allah

Chapter 7
Firm Belief and Perfect Reliance on Allah

Allah, the Exalted, says:

"And when the believers saw Al-Ahzab (the Confederates), they said: 'This is what Allah and His Messenger (Muhammad (PBUH)) had promised us, and Allah and His Messenger (Muhammad (PBUH)) had spoken the truth, and it only added to their Faith and to their submissiveness (to Allah)". (33:22)

"Those (i.e., believers) unto whom the people (hypocrites) said, `Verily, the people (pagans) have gathered against you (a great army), therefore, fear them.' But it (only) increased them in Faith, and they said: `Allah (Alone) is Sufficient for us, and He is the Best Disposer of affairs (for us)'. So they returned with grace and bounty from Allah. No harm touched them; and they followed the good Pleasure of Allah. And Allah is the Owner of great bounty". (3:173,174)

"And put your trust (O Muhammad (PBUH)) in the Ever Living One Who dies not.'' (25:58)

"And in Allah (Alone) let the believers, put their trust.'' (14:11)

"... Then when you have taken a decision, put your trust in Allah...'' (3:159)

"And whosoever puts his trust in Allah, then He will suffice him". (65:3)

"The believers are only those who, when Allah is mentioned, feel a fear in their hearts; and when His Verses (this Qur'an) are recited unto them, they (i.e., the Verses) increase their Faith; and they put their trust in their Rubb (Alone).'' (8:2)

74. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "I was shown the past nations. I saw a Prophet who had a very small group (less than ten in total) with him, another Prophet who was accompanied by only one or two men and some did not have even one. Suddenly I was shown a huge crowd and I thought that they were my Ummah, but I was told: 'This is Musa (Moses) and his people, but look towards the other side.' I looked and beheld a great assemblage. I was told: 'These are your people and amongst them there are seventy thousand who shall enter Jannah without being taken to account or torment". Then the Prophet (PBUH) stood up and went into his apartment, and the Companions began to guess who may be those people who would enter Jannah without any accounting or torment. Some said: "Probably, they are the ones who kept company with Messenger of Allah (PBUH)". Others said: "Probably, they are the ones who have been born as Muslims and have never associated anyone with Allah in worship". Then Messenger of Allah (PBUH) came out and asked, "What are you discussing?'' So they told him. He then said, "They are those who do not make Ruqyah (blowing over themselves after reciting the Qur'an or some prayers and supplications the Prophet (PBUH) used to say) nor seek it, nor perceive omens (i.e., they are not pessimistic) but keep trust in their Rubb (Allah).'' On this 'Ukashah bin Mihsan stood up and asked: "Pray to Allah to make me one of them.'' The Prophet (PBUH) said, "You are one of them.'' Then another man stood up and asked the same thing. The Prophet (PBUH) answered, "'Ukashah has surpassed you".
[Al-Bukhari and Mulsim].

Commentary:
1. This Hadith mentions the importance of faith in Allah, inducement for having trust in Him and the distinction of people who have these qualities.

2. Although the practice of blowing over someone after reciting the Qur'an or supplications of the Prophet (PBUH) and medical treatment are permissible but they who avoid them because of their extreme trust in Allah and save themselves from bad omen, enjoy a distinguished position.

3. These conditions of various communities were shown to the Prophet (PBUH) in dreams for the dreams of the Prophets reflect the truth, or by means of Revelation, or he had witnessed them in the event of Isra (the Night Journey) of the Prophet (PBUH).

4. The followers of the Prophet (PBUH) exceed the followers of other Prophets in number.

75. Ibn `Abbas (May Allah be pleased with them) reported that the Messenger of Allah (PBUH) used to supplicate: "O Allah! To You I have submitted, and in You do I believe, and in You I put my trust, to You do I turn, and for You I argued. O Allah, I seek refuge with You through Your Power; there is none worthy of worship except You Alone; that You safeguard me against going astray. You are the Ever Living, the One Who sustains and protects all that exists; the One Who never dies, whereas human beings and jinn will all die".
[Al-Bukhari and Muslim].

76. Ibn `Abbas (May Allah be pleased with them) said: When (Prophet) Ibrahim (Abraham) was thrown into the fire, he said: "Allah (Alone) is sufficient for us, and, He is the Best Disposer of affairs.'' So did Messenger of Allah Muhammad (PBUH) when he was told: "A great army of the pagans had gathered against him, so fear them". But this (warning) only increased him and the Muslims in Faith and they said: "Allah (Alone) is sufficient for us, and He is the Best Disposer of affairs (for us)".
[Al-Bukhari].

Commentary: Even in the worst circumstances one should always have faith and trust in Allah.

77. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A group of people (both men and women) whose hearts will be like the hearts of birds, will enter Jannah".
[Muslim].

It has been interpreted that such people are those who put their trust in Allah; another interpretation is that these people are tender-hearted.

Commentary:
1. Excellence of trust in Allah and kindness of heart are most valuable qualities because both of them are means to enter Jannah.

2. One should not worry much about one's food and means of subsistence. In fact, people should have the heart like birds who do not collect to keep in reserve anything and go out every morning in search of food and return to their nests fully satiated. This advice is repeated in another Hadith to the effect that when birds leave their nests in the morning they are hungry but when they come back, their stomachs are full and they do not need any more food.

78. Jabir (May Allah be pleased with him) reported: I went in an expedition along with the Prophet (PBUH) in the direction of Najd. When Messenger of Allah (PBUH) returned, I also returned with him. Then the mid-day sleep overtook us in a valley full of prickly shrubs. Messenger of Allah (PBUH) got down and the people scattered around seeking shade under the trees. Messenger of Allah (PBUH) hang up his sword on the branch of a tree. We were enjoying a sleep when Messenger of Allah (PBUH) called us, and lo! There was a desert Arab bedouin near him. He (PBUH) said, "This man brandished my sword over me while I was asleep. I woke up and saw it in his hand unsheathed. He asked: `Who will protect you from me?' I replied: 'Allah' - thrice". He did not punish him and sat down.
[Al-Bukhari and Muslim].

In another narration, Jabir (May Allah be pleased with him) said: We accompanied Messenger of Allah (PBUH) in the campaign of Dhat-ur-Riqa`. We left Messenger of Allah (PBUH) to take rest under a shady tree. One of the polytheists came to him. The sword of Messenger of Allah (PBUH) was hanging on a tree. He drew it and said: "Are you afraid of me?'' Messenger of Allah (PBUH) said, "No". Then he said: "Who will then protect you from me?'' Messenger of Allah (PBUH) replied, "Allah".

And in a narration of Abu Bakr Al-Isma`ili, the polytheist asked: "Who will protect you from me?'' Messenger of Allah (PBUH) replied, "Allah.'' As soon as he said this, the sword fell down from his hand and Messenger of Allah (PBUH) catching the sword, asked him, "Who will protect you from me.'' He said, "Please forgive me.'' Messenger of Allah (PBUH) said, "On condition you testify that there is none worthy of worship but Allah and that I am His Messenger.'' He said, "No, but I promise you that I shall not fight against you, nor shall I be with those who fight with you". The Prophet (PBUH) let him go. He then went back to his companions and said: "I have come to you from one of the best of mankind".

Commentary: Besides the Prophet's habit of pardoning, and gracious attitude, this Hadith mentions his utmost trust in Allah. It tells that one who has trust in Allah is helped by Him. Later on, the bedouin mentioned in the Hadith embraced Islam. In the battle of Dhat-ur-Riqa` which took place in the sixth year of the Hijra, due to intense heat and lack of footwear, the Companions of the Prophet (PBUH) wrapped their feet with pieces of cloth and for this reason it was called "War of patches of cloth (Dhat-ur-Riqa`)''. Some scholars have also given a different reason for this name.

79. `Umar (May Allah be pleased with him) said: I heard Messenger of Allah (PBUH) saying: "If you all depend on Allah with due reliance, He would certainly give you provision as He gives it to birds who go forth hungry in the morning and return with full belly at dusk".
[At-Tirmidhi].

Commentary: Trust in Allah does not mean that one should not give any importance to material resources. What it really means is that along with their due importance, one should have full trust in Allah. Without His Will, material resources are of no avail. But nevertheless it is necessary to have material resources because their procurement is also ordained by Him. Birds do not keep sitting in their nests for food but fly out in search of it.

80. Al-Bara' bin `Azib (May Allah be pleased with them) said: Messenger of Allah (PBUH) asked me to recite whenever I go to bed: "Allahumma aslamtu nafsi ilaika, wa wajjahtu wajhi ilaika, wa fawwadtu amri ilaika, wal-ja'tu zahri ilaika, raghbatan wa rahbatan ilaika, la malja wa la manja minka illa ilaika. Amantu bikitabikal-ladhi anzalta, wa nabiyyikal-ladhi arsalta (O Allah! I have submitted myself to You, I have turned my face to You, entrusted my affairs to You; and committed my back to You out of desire for You and fear of You; expecting Your reward and fearing Your punishment). There is no refuge and no place of safety from You but with You. I believe in the Book You have revealed and in the Prophet You have sent.'' Messenger of Allah (PBUH) said that if anyone recited these words and died that night, he would die in the true religion. In case he remains alive till morning, he will obtain good.
[Al-Bukhari and Muslim].

In another narration: He reported Messenger of Allah (PBUH) as saying: "If you go to bed, perform the Salat Wudu', lie down on your right side and say [the above Du`a (supplication)] and let these words be your last".

Commentary: It is better to make Wudu' before going to sleep. Similarly, it is also meritorious to recite the invocation mentioned in the Hadith before one goes to bed, because it is a prayer for the renewal of Islam and Faith and request for grant of peace and security.

81. Abu Bakr As-Siddiq (May Allah bepleased with him) said: When Messenger of Allah (PBUH) and I were in the cave of Thaur and I saw the feet of the polytheists who were above us at the mouth of the cave (on the eve of the Emigration), I submitted: "O Messenger of Allah! If one of them were to look down below his feet, he would see us". He (PBUH) said, "O Abu Bakr! What do you think of two whose third is Allah".
[Al-Bukhari and Muslim].

Commentary: This incident occurred when the Prophet (PBUH) was emigrating from Makkah to Al-Madinah with Abu Bakr As-Siddiq (May Allah be pleased with him) The disbelievers had announced a huge reward for their arrest for which people were searching them wildly. In the course of their search, some of them reached the mouth of the cave of Thaur where the Prophet (PBUH) and Abu Bakr (May Allah be pleased with him) were staying for refuge and rest. This Hadith describes the valour, fearlessness and unlimited confidence and trust of the Prophet (PBUH) in Allah; it also indicates how Allah helps His favourites. See Verse (40:51) of the Qur'an in this regard.

82. Umm Salamah (May Allah be pleased with her) reported: Whenever the Prophet (PBUH) stepped out of his house, he would say, "Bismillah, tawakkaltu `alallah. Allahumma inni a`udhu bika an adilla aw udalla, aw azilla aw uzalla, aw azlima aw uzlama, aw ajhala aw yujhala `alayya". "[I go forth. (I begin with the Name of Allah, I trust in Allah; O Allah! I seek refuge in You from leaving or being led astray, or against slipping or being caused to slip; or doing injustice or being done injustice; or doing wrong or having wrong done to me)]".
[Abu Dawud and At-Tirmidhi reported it. According to At-Tirmidhi, this Hadith is classified as Hasan Sahih. Its wording is from Abu Dawud].

83. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whoever says (upon leaving his house): `Bismillah, tawakkaltu `alallah, wa la hawla wa la quwwata illa billah [I begin with the Name of Allah; I trust in Allah; there is no altering of conditions but by the Power of Allah],' it will be said to him: 'You are guided, defended and protected.' The devil will go far away from him".
[Abu Dawud, At-Tirmidhi and An-Nasa'i].

Abu Dawud reported it with this addition: "One devil will say to another: 'How can you deal with a man who has been guided, defended and protected?".

Commentary: The prayer quoted in this Hadith shows the importance of confidence and trust in Allah and request for security against the mischief of Satan.

84. Anas (May Allah be pleased with him) reported: There were two brothers in the days of the Prophet (PBUH). One of them used to attend the Prophet's circle (to acquire knowledge) and the other used to earn their living). Once the latter complained to the Prophet (PBUH) against the former (for not earning his living). He (PBUH) replied, "Perhaps you are being provided because of him".
[At-Tirmidhi].

Commentary: This Hadith evidently shows that it is permissible and desirable to devote oneself or make someone else to devote himself for religious knowledge. Such students of religious knowledge should not be considered a burden. Similarly, one should also not ignore those students and scholars who are devoted to such knowledge because Allah makes their help a means of increasing the donor's sources of subsistence.


Uprightness and Steadfastness

Chapter 8
Uprightness and Steadfastness

Allah, the Exalted, says:

"So stand (ask Allah to make) you (Muhammad (PBUH)) firm and straight (on the religion of Islamic Monotheism) as you are commanded...'' (11:112)

"Verily, those who say: `Our Rubb is Allah (Alone),' and then they stand firm, on them the angels will descend (at the time of their death) (saying): 'Fear not, nor grieve! But receive the glad tidings of Jannah which you have been promised! We have been your friends in the life of this world and are (so) in the Hereafter. Therein you shall have (all) that your inner-selves desire, and therein you shall have (all) for which you ask. An entertainment from (Allah), the Oft-Forgiving, Most Merciful.''' (41:30-32)

"Verily, those who say: `Our Rubb is (only) Allah,' and thereafter stand firm and straight (on the Islamic Faith of Monotheism), on them shall be no fear, nor shall they grieve. Such shall be the dwellers of Jannah, abiding therein (forever), - a reward for what they used to do.'' (46:13,14)

85. Sufyan bin `Abdullah (May Allah be pleased with him) reported: I said, "O Messenger of Allah, tell me something of Islam which I will not ask anyone else about it.'' He (PBUH) said, "Say, `I believe in Allah' and then be steadfast".
[Muslim].

Commentary: Steadfastness means adhering firmly to the injunctions of Islam, to act upon what is ordained and avoid what is prohibited, to perform dutifully orders in respect of obligations and what is regarded desirable and avoid what is unlawful. Faith is not a mere expression of Shahadah. The real Faith is one which is coupled with its actual practice because practice of religion is in fact the fruit of Faith. A tree which does not bear any fruit, has no value, similarly; faith becomes meaningless without practice. Steadfastness is the mark of perfect Faith.

86. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Follow the Right Path of Faith strictly, and be steadfast; and keep in mind that none of you can achieve salvation through his (good) actions.'' Someone asked, "Not even you, O Messenger of Allah?'' He (PBUH) said, "Not even me, unless Allah grants me His Mercy and Grace".
[Muslim].

Commentary: This Hadith tells us that although the importance of Faith and its practice is beyond any shadow of doubt, because this is the only way to attain His Favours and Blessings, but one should not entirely depend upon practice only because any shortcoming (which one does not even know) can ruin a good deed. It is, therefore, essential that we also pray that our good deeds are accepted by Allah and that He grants us His Infinite Mercy and sincerity because even the greatest noble deed is invalid without it.


Pondering over the Great Creation of Allah, The passing away of Life of the World, the Horrors of the Day of Requital and Laxity of One's Nafs

Chapter 9
Pondering over the Great Creation of Allah, The passing away of Life of the World, the Horrors of the Day of Requital and Laxity of One's Nafs

Allah, the Exalted, says:

"I exhort you to one (thing) only: that you stand up for Allah's sake in pairs and singly, - and reflect (within yourselves the life history of the Prophet (PBUH))". (34:46)

"Verily! in the creation of the heavens and the earth, and in the alternation of night and day, there are indeed signs for men of understanding. Those who remember Allah (always, and in prayers) standing, sitting, and lying down on their sides, and think deeply about the creation of the heavens and the earth, (saying): 'Our Rubb! You have not created (all) this without purpose, glory to You! (Exalted be You above all that they associate with You as partners)". (3:190,191)

"Do they not look at the camels, how they are created? And at the heaven, how it is raised? And at the mountains, how they are rooted (and fixed firm)? And at the earth, how it is spread out? So remind them (O Muhammad (PBUH)), you are only a one who reminds". (88:17-21)

"Have they not travelled through the earth, and seen..". (47:10)

Ayat of the Qur'an and Ahadith on the subject are many. See for example Hadith No. 66 mentioned before.


Hastening to do Good Deeds

Chapter 10
Hastening to do Good Deeds

Allah, the Exalted, says:

"So hasten towards all that is good". (2:148)

"And march forth in the way (which leads to) forgiveness from your Rubb, and for Jannah as wide as are the heavens and the earth, prepared for Al-Muttaqun (the pious)". (3:133)

87. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Be prompt in doing good deeds (before you are overtaken) by turbulence which would be like a part of the dark night. A man would be a believer in the morning and turn to disbelief in the evening, or he would be a believer in the evening and turn disbeliever in the morning, and would sell his Faith for worldly goods.''
[Muslim].

Commentary: This Hadith tells that the Day of Resurrection will be preceded by a long chain of calamities. Because of the rush of these calamities, religion and Faith will loose their value in people. There will be a race for wealth, so much so that people would not hesitate to compromise their religion and Faith to acquire wealth. People will rapidly change their faces. This is what actually happening. In this situation true believers are exhorted to adhere strictly to Faith and perform noble deeds without delay.

88. `Uqbah bin Al-Harith (May Allah be pleased with him) said: Once I performed the 'Asr prayer in Al-Madinah behind the Prophet (PBUH). He (PBUH) got up quickly after finishing the prayer with Taslim, and stepping over the people, went to one of the rooms of his wives. The people were startled at his haste, and when he came out and saw their astonishment at his urgency he said, "I recalled that there was left with me some gold which was meant for charity; I did not like to keep it any longer, so I gave orders that it should be distributed".
[Al-Bukhari].

In another narration, Messenger of Allah said, "I had left some gold for Sadaqah in the house, and did not wish to keep it overnight".

Commentary:
1. A person should not keep such a thing because of which his attention is diverted from Allah (SWT) towards that thing.

2. Although it is undesirable to jump over the neck of people in ordinary circumstances but it is permissible when special conditions warrant it.

89. Jabir (May Allah be pleased with him) reported: A man, said to the Prophet (PBUH) during the battle of Uhud: "Tell me where I shall be if I am killed". When he (PBUH) replied that he would be in Jannah, the man threw away some dates which he had in his hand and fought until he was killed.
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions the passion of the Companions of the Prophet (PBUH) for Jihad and its reward which is Jannah. It also says that if a person heartily desires martyrdom, Allah certainly grants him this distinction and honour.

90. Abu Hurairah (May Allah be pleased with him) said: There came a man to the Prophet (PBUH) and said, "O Messenger of Allah, which charity is the most rewardable?'' He (PBUH) said, "That you should give charity (in a state when you are) healthy and stingy and fear poverty, hoping to become rich (charity in such a state of health and mind is the best). And you must not defer (charity to such a length) that you are about to die and would be saying: 'This is for so-and-so, and this for so-and-so.' Lo! It has already come into (the possession of) so-and-so".
[Al-Bukhari and Muslim].

Commentary: Charity in the real sense is that which a person gives when he is healthy. If a person gives charity when he is facing death, it does not have much value before Allah. Moreover, in that condition he cannot give more than one-third of his property in charity because then it becomes the property of his successors, which cannot be spent even in the way of Allah. For this reason Allah has prescribed a limit in this respect, according to which if a person going through a mortal disease wants to give his property in charity or donate it for some charitable purpose, he cannot spend more than one-third of it on this account. This injunction is an inducement for people to hurry in doing good deeds, especially in the matter of alms and charity. In fact, he should do it without delay.

91. Anas (May Allah be pleased with him) said: Messenger of Allah (PBUH) took up a sword on the day of the battle of Uhud and said, "Who will take this sword from me?'' Everyone stretched forth his hand saying: "I will take it; I will take it". He (the Prophet (PBUH)) said, "Who will take it with its full responsibility (i.e., to use it to fight Allah's enemies with it)?'' The Companions hesitated. Abu Dujanah (May Allah be pleased with him) said: "I shall take it;'' and with it he cracked the skulls of the pagans.
[Muslim].

Commentary: This Hadith mentions the chivalry and distinction of Abu Dujanah (May Allah be pleased with him) but it should not be taken to mean that other Companions of the Prophet (PBUH) showed cowardice on that occasion. The latter had in fact hesitated to get the honour and reward attached with the Prophet's sword. It is evident from the fact that when the Prophet (PBUH) offered it without any condition everyone stretched his hand to take it.

92. Az-Zubair bin `Adi said: We went to Anas bin Malik (May Allah be pleased with him) and complained to him of suffering at the hands of Al-Hajjaj. He replied: "Show endurance, for no time will come but will be followed by one worse (than the present one) till you meet your Rubb. I heard this from your Prophet (PBUH)".
[Al-Bukhari].

Commentary: This Hadith contains the prediction that with the passage of time, conditions will become from bad to worse with the result that rulers would become more and more cruel. In such circumstances, the remedy suggested here is that rather than making any effort to reform the rulers, one should try to reform oneself and worry to make one's own life in the Hereafter, and endure patiently the tyrannies perpetrated by the rulers.

93. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Hasten to do good deeds before you are overtaken by one of the seven afflictions.'' Then (giving a warning) he said, "Are you waiting for such poverty which will make you unmindful of devotion; or prosperity which will make you corrupt, or disease as will disable you, or such senility as will make you mentally unstable, or sudden death, or Ad-Dajjal who is the worst expected absent, or the Hour, and the Hour will be most grievous and most bitter".
[At-Tirmidhi].

Commentary: The purpose of this Hadith is that before overcoming of the obstructions, one should do one's best to improve his Hereafter by means of good deeds lest one is deprived of good deeds by some obstruction.

94. Abu Hurairah (May Allah be pleased with him) reported: On the day of the battle of Khaibar, Messenger of Allah (PBUH) said, "I shall hand over this banner to one who loves Allah and His Messenger, and Allah will give us victory through him.'' `Umar (May Allah be pleased with him) said: "I had never longed for leadership but that day I expected that I might be called for. However, Messenger of Allah (PBUH) called `Ali bin Abu Talib (May Allah be pleased with him) and handed the banner to him and said, "Go forth and do not turn around till Allah bestows victory upon you". (On hearing this) `Ali proceeded a little and then halted and without turning around inquired in a loud voice: "O Messenger of Allah, for what shall I fight them?'' He (PBUH) replied, "Go on fighting till they affirm that none has the right to be worshiped but Allah and that Muhammad is the Messenger of Allah. If they admit that, their lives and their properties will be secured, subject to their obligations according to Islam, and they will be answerable to Allah".
[Muslim].

Commentary:
1. This Hadith refers to prominence, special distinction and greatness of `Ali (May Allah be pleased with him).

2. It mentions the miracle of the Prophet (PBUH) in the form of his prophecy about the conquest of Khaibar which came true.

3. Islamic sanctions would be applied on the apparent conduct of the people. Thus, a person who would announce his acceptance of Islam, will be considered a Muslim. What is hidden in his heart will be left to Allah. He will, however, be punished with retaliation (Qisas) in case of unjust murder and execution for apostasy.


The Struggle (in the Cause of Allah)

Chapter 11
The Struggle (in the Cause of Allah)

Allah, the Exalted, says:

"As for those who strive hard in Us (Our Cause), We will surely, guide them to Our paths (i.e., Allah's religion - Islamic Monotheism). And verily, Allah is with the Muhsinun (gooddoers)". (29:69)

"And worship your Rubb until there comes unto you the certainty (i.e., death)". (15:99)

"And remember the Name of your Rubb and devote yourself to Him with a complete devotion.'' (73:8)

"So whosoever does good equal to the weight of an atom (or a small ant), shall see it". (99:7)

"And whatever good you send before you for yourselves (i.e., Nawafil - non-obligatory acts of worship: prayers, charity, fasting, Hajj and Umrah, etc.), you will certainly find it with Allah, better and greater in reward.'' (73:20)

"And whatever you spend in good, surely, Allah knows it well.'' (2:273)

95. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah the Exalted has said: 'I will declare war against him who shows hostility to a pious worshipper of Mine. And the most beloved thing with which My slave comes nearer to Me is what I have enjoined upon him; and My slave keeps on coming closer to Me through performing Nawafil (prayer or doing extra deeds besides what is obligatory) till I love him. When I love him I become his hearing with which he hears, his seeing with which he sees, his hand with which he strikes, and his leg with which he walks; and if he asks (something) from Me, I give him, and if he asks My Protection (refuge), I protect him".
[Al-Bukhari].

Commentary:
1. Those who make innovations in religion and associate partners with Allah (such as Hululi - who believe in the indwelling light in the soul of man, Wujudi - who believe in the physical form of Allah, and pagans who worship other than Allah) interpret this Hadith in support of their beliefs and thus seek support of one wrong from another although the meaning and interpretation of the Hadith is not at all what they describe. The Hadith means that when a person adds voluntary prayers to the obligatory ones, he becomes a favourite slave of Allah and on account of it, he receives special help from Allah. Then he is protected by Allah to the extent that He supervises every organ of his body. Thus, he is saved from disobedience of Allah. He bears what is liked by Allah, sees what is liked by Him, handles what pleases Him. When he attains that lofty position of love and obedience of Allah, then Allah in return also grants prayers of His obedient and loyal slaves.

2. A saint is not one who has a peculiar attire and appearance, or who occupies the seat of a righteous as his successor, or a person who is lost in meditation, or a half-mad, or one who has invented his own style of remembrance and worship of Allah, but it is one who strictly fulfills the obligations imposed by Islam, is fond of voluntary prayers and adheres to Divine injunctions in every walk of life.

3. The love of such righteous is a means to attain the Pleasure of Allah, and enmity (hatred and repulsion) with them is a cause of His serious displeasure and wrath.

4. Voluntary prayer is certainly a means of attaining the Pleasure of Allah, but it must be preceded by the fulfillment of obligatory prayers. The former is of no value if the latter is neglected. The desire to attain nearness of Allah without strict observance of the obligatory prayers is fallacious and meaningless.

96. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah says: ' When a slave of Mine draws near to Me a span, I draw near to him a cubit; and if he draws near to Me a cubit, I draw near to him a fathom. And if he comes to Me walking, I go to him running.'''.
[Al-Bukhari].

Commentary: This Hadith mentions infinite benevolence, generosity, kindness and regard of Allah for His slaves, which is evident from the reward that He gives to His slaves even on their minor good deeds.

97. Ibn Abbas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "There are two blessings in which many people incur loss. (They are) health and free time (for doing good)".
[Al-Bukhari]

Commentary:
1. Al-Ghabn in Arabic means loss. What it really signifies is to sell something of one's own on less than its due price, or to buy something on its double or triple price. In both cases one is a loser. When a person comes to know about such a loss, he repents and feels sorry for it. This loss coupled with regret is called Al-Ghabn. In Ahadith, man has been compared with trader, and health and leisure enjoyed by him with merchandise. One who uses his merchandise with care, gains profit while he who wastes it, that is to say, uses it carelessly, will be a loser on the Day of Resurrection.

2. The majority of people do not take proper care of both these things, with the result that one wastes the time in useless activities and spends the physical strength and energy in the disobedience of Allah. One will have to face severe consequences of it on the Day of Resurrection when he will be brought into account for everything.

98. `Aishah (May Allah be pleased with her) said: The Prophet (PBUH) would stand (in prayer) so long that the skin of his feet would crack. I asked him, "Why do you do this while your past and future sins have been forgiven?'' He said, "Should I not be a grateful slave of Allah?''
[Al-Bukhari and Muslim].

Commentary:
1. All the Prophets were free from major sins. However, some religious scholars justify some of their minor sins with plausible reasons but the majority of them maintain that they are free from all sins because of their innocence. In this situation, it does not make any sense to speak of their sins. But the fact of the matter is quite different. Anything short of excellent done by them is counted as a sin.

2. The more one is rewarded by Allah, the greater the proportion of one's gratitude of Allah for His Benevolence should be. The best form of doing so is that one should not only be highly obedient and dutiful in the performance of the obligations but also add maximum voluntary prayers to them.

99. `Aishah (May Allah be pleased with her) said: With the start of the last ten days of Ramadan, Messenger of Allah (PBUH) would pray all the night, and would keep his family awake for the prayers. He tied his lower garment (i.e., avoided sleeping with his wives) and devoted himself entirely to prayer and supplication.
[Al-Bukhari and Muslim].

Commentary: One should try to do more good deeds in the blessed hours and times, as was the practice of the Prophet (PBUH) during the last ten days of the month of Ramadan every year.

100. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "A strong believer is better and dearer to Allah than a weak one, and both are good. Adhere to that which is beneficial for you. Keep asking Allah for help and do not refrain from it. If you are afflicted in any way, do not say: `If I had taken this or that step, it would have resulted into such and such,' but say only: `Allah so determined and did as He willed.' The word `if' opens the gates of satanic thoughts".
[Muslim].

Commentary:
1. In this Hadith, goodness is acknowledged in weak as well as strong because the real Faith is a common feature of both. The one who is stronger is, however, better with Allah for the reason that he is more active and energetic in the matter of noble deeds and performance of ritual prayers, obligatory as well as voluntary.

2. This Hadith ordains that in case of trouble, one should exercise patience and show submission and obedience rather than saying `ifs' and `buts' about it, because it provides Satan with a chance to mislead the sufferer.

101. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said. "The (Hell) Fire is surrounded with all kinds of desires and passions, while Jannah is surrounded with adversities.''
[Al-Bukhari and Muslim].

Commentary: The way to Hell is littered with these evils. When a person crosses them, it is an indication that he has entered into Hell. On the other side exists a series of griefs and calamities, Islamic injunctions and obligations (the compliance with which is often irksome for man) impede his way to Jannah. When a person endures them with patience he, in fact, overcomes those obstacles and becomes eligible for Jannah.

102. Hudhaifah (May Allah be pleased with him) reported: I offered Salat (Tahajjud - optional night prayer) with the Prophet (PBUH) one night, and he started reciting (Surat) Al-Baqarah. I thought that he would bow at the end of one hundred Verses, but he continued reciting; I, then, thought that he would perhaps recite the whole (Surah) in a Rak`ah, but he proceeded on, and I thought he would perhaps bow on completing (this Surah); he then started (reciting Surat) An-Nisa'; he then started (Surat) Al-`Imran and his recitation was unhurried. And when he recited the Verses which referred to the Glory of Allah, he glorified Him (by saying Subhan Allah - My Rubb, the Supreme is far removed from every imperfection), the Great, and when he recited the Verses that mention supplication, he supplicated, and when he recited the Verses that mention seeking Refuge of the Rubb, he sought (His) Refuge. Then he bowed and said: "My Rubb, the Supreme is far removed from every imperfection (Subhana Rabbiyal-Azim);'' his bowing lasted about the same length of time as his standing (and then on returning to the standing posture after Ruku`) he said: "Allah listened to him who praised Him (Sami` Allahu liman hamidah, Rabbana wa lakal hamd).'' Then he stood about the same length of time as he had spent in bowing. He then prostrated himself and said: "My Rubb, the Supreme is far removed from every imperfection (Subhana Rabbiyal-A`la),'' and his prostration lasted nearly the same length of time as his standing.
[Muslim].

Commentary: This Hadith makes the following three points clear:

Firstly, optional Salat can also be performed in congregation.

Secondly, as is commonly believed, it is not essential that in Salat, the Ayat of Qur'an are recited according to their sequence in the Book. It is permissible to recite them regardless of their sequence in the Qur'an.

Thirdly, it is commendable to relatively prolong the optional prayers.

103. Ibn Mas`ud (May Allah be pleased with him) said: One night I joined the Prophet (PBUH) in his (optional) Salat. He prolonged the standing so much that I thought of doing something evil. He was asked: "What did you intend to do?'' He replied: "To sit down and leave him".
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith makes it evident that opposition of Imam (one who leads the prayer) is an evil act because one is ordered to follow him in the prayers.

2. It is permissible to ask clarification of something which is ambiguous or abstruse.

104. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Three follow a dead body: members of his family, his possessions and his deeds. Two of them return and one remains with him. His family and his possessions return; his deeds remain with him".
[Al-Bukhari and Muslim].

Commentary: This Hadith induces one to perform such deeds which always remain with him in the grave, where every being and thing leaves one and he is all alone in the grave. What is left is his good deeds which become the means of refuge and salvation.

105. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Jannah is nearer to anyone of you than your shoe-lace, and so is the (Hell) Fire".
[Al-Bukhari].

Commentary: Going to Jannah or Hell is the result of one's own actions, both are close to everyone. One will be admitted into Jannah if he does good deeds, and will be consigned to Hell if he does evil. After death, one's entitlement for Jannah or Hell will be decided.

106. Rabi`ah bin Ka`b Al-Aslami (May Allah be pleased with him (a servant of the Messenger of Allah and also one of the people of As-Suffah) said: I used to spend my night in the company of Messenger of Allah (PBUH) and used to put up water for his ablutions. One day he said to me, "Ask something of me.'' I said: "I request for your companionship in Jannah". He inquired, "Is there anything else?'' I said, "That is all.'' He said, "Then help me in your request by multiplying your prostrations".
[Muslim].

Commentary: There was a terrace at the end of the Prophet's Mosque which is called As-Suffah in Arabic. People of poor means who were taught by him used to live there. This Hadith evidently shows the importance of good actions and faithful following of the practice of the Prophet (PBUH). Leave others alone, in the absence of these two, even such people will not be close to the Prophet (PBUH) who used to be all the time with him. It is not difficult to visualize the fate of those who neither perform good deeds nor follow in the footsteps of the Prophet (PBUH).

107. Thauban (May Allah be pleased with him) said: I heard Messenger of Allah (PBUH) saying, "Perform Salah more often. For every prostration that you perform before Allah will raise your position one degree and will remit one of your sins".
[Muslim].

Commentary: Abundance of prostrations means strict observance of Salat and performance of obligatory and optional and voluntary prayers, it is a means for atonement of sins and the elevation of one's status in this life and the Hereafter.

108. `Abdullah bin Busr Al-Aslami (May Allah be pleased with him) said: Messenger of Allah (PBUH) said, "The best of people is one whose life is long and his conduct is good".
[At-Tirmidhi].

Commentary:
1. Longevity of life is a blessing, provided it is accompanied by Faith and good deeds; otherwise, the longer life one has, the greater will be the number of sins. Such a long life is disastrous.

2. Those who do not realize the blessings of longevity of life will be losers.

109. Anas (May Allah be pleased with him) said: My uncle Anas bin An-Nadr (May Allah be pleased with him) was absent from the battle of Badr and he said: "O Messenger of Allah! I was absent from the first battle you fought against the pagans, and if Allah let me participate in a battle against the pagans, Allah will see what I do.'' So he encountered the day of Uhud Battle. The Muslims left the positions (the Prophet (PBUH) told them to keep) and were defeated, he said: "O Allah! excuse these people (i.e., the Muslims) for what they have done, and I am clear from what the pagans have done". Then he went forward with his sword and met Sa`d bin Mu`adh (fleeing) and said to him: "By the Rubb of the Ka`bah! I can smell the fragrance of Jannah from a place closer than Uhud Mount". Sa`d said: "O Messenger of Allah, what he did was beyond my power". Anas said: "We saw over eighty wounds on his body caused by stabbing, striking and shooting of arrows and spears. We found that he was killed, and mutilated by the polytheists. Nobody was able to recognize him except his sister who recognized him by the tips of his fingers.'' Anas (May Allah be pleased with him) said: "We believe that the Ayah `Among the believers are men who have been true to their covenant with Allah [i.e., they have gone out for Jihad (holy fighting), and showed not their backs to the disbelievers]...' (33:23), refers to him and his like".
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith brings into prominence the exemplary life of the Companions of the Prophet (PBUH) for martyrdom and Jannah.

2. It also shows the enthusiasm of the believers for dedicating their lives to good deeds and their fervent supplication for their acceptance by Allah.

110. Abu Mas`ud `Uqbah bin `Amr Al-Ansari (May Allah be pleased with him) said: When the Ayah enjoining Sadaqah (charity) was revealed,* we used to carry loads on our backs to earn something that we could give away in charity. One person presented a considerable amount for charity and the hypocrites said: "He has done it to show off.'' Another one gave away a few Sa` of dates and they said: "Allah does not stand in need of this person's dates". Thereupon, it was revealed:

"Those who defame such of the believers who give charity (in Allah's Cause) voluntarily, and such who could not find to give charity (in Allah's Cause) except what is available to them...'' (9:79)
[Al-Bukhari and Muslim].

* This is the A°yah in which Allah says! "Take Sadaqah (alms) from their wealth in order to purify them and sanctify them with it, and suppliate Allah for them...'' (9:103)

Commentary: This Hadith shows that everyone can give charitable donation according to one's means. It can be more or less as one likes. To regard those as showy and criticize those who pay less to withhold them from alms amounts to hypocrisy. Believers must ignore such criticism of the hypocrites and refrain from such things in their dealings.

111. Abu Dharr (May Allah be pleased with him) said: The Prophet (PBUH) said, "Allah, the Exalted, and Glorious, said; 'O My slaves, I have prohibited Myself injustice; and have made oppression unlawful for you, so do not oppress one another. O My slaves, all of you are liable to err except the one whom I guide on the Right Path, so seek guidance from Me so that I will guide you to the Right Path. O My slaves, all of you are hungry except the one whom I feed, so ask food from Me, I will feed you. O My slaves, all of you are naked except those whom I clothe, so ask clothing of Me and I shall clothe you. O My slaves, you commit sins night and day and I forgive all sins, so seek My forgiveness and I shall forgive you. O My slaves, you can neither do Me any harm nor can you do Me any good. O My slaves, were the first of you and the last of you, the human of you and jinn of you to be as pious as the most pious heart of any man of you, that would not increase My domain a thing. O My slaves, were the first of you, and the last of you, the human of you and the jinn of you to be as wicked as the most wicked heart of any man of you, that would not decrease My domain in a thing. O My slaves, were the first of you and the last of you, the human of you and the jinn of you to stand in one place and make a request of Me, and were I to give everyone what he requested, that would not decrease what I have, any more than a needle decrease the sea if put into it. O My slaves, it is but your deeds that I reckon for you and then recompense you for, so let him who finds good (i.e., in the Hereafter) praise Allah and let him who finds other than that blame no one but himself.'''.
[Muslim].

Commentary: This Hadith mentions the Power and Majesty of Allah and stresses that one should supplicate Allah for everything that one needs. From guidance to sustenance, the treasures of everything are with Him - the treasures which are unlimited and any withdrawal from them does not make any reduction in them. Similar is the case of His Sovereignty; it is not affected even if the whole universe supports or opposes them. Thus, it is in the interest of man that he should dedicate himself entirely to Allah and beg all his needs from Him and Him Alone.


Urging towards increasing Good Actions in later part of Life

Chapter 12
Urging towards increasing Good Actions in later part of Life

Allah, the Exalted, says:

"Did We not give you lives long enough, so that whosoever would receive admonition, - could receive it? And the warner came to you.'' (35:37)

Ibn `Abbas and others said that "long enough'' in the Verse means sixty years. The Hadith which follows supports this. Others said it means eighteen years; Al-Hasan Al-Basri, Al-Kalbi and Masruq said it means forty years, it has also been reported by Ibn Abbas and others that whenever the people of Al-Madinah turned forty years of age, they would devote themselves completely to worship. "Long enough'' in the Verse has also been interpreted to mean the age of puberty. Ibn `Abbas and the majority of Muslim scholars said that the "warner'' in the Verse refers to the Prophet (PBUH). `Ikrimah bin `Umaiyyah and others interpreted this word as the grayness or whiteness of hair". Allah knows better.

112. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah excuses and grants forgiveness to a person until he attains the age of sixty years".
[Al-Bukhari].

Commentary:
1. This Hadith makes it evident that Allah does not punish any individual or nation without warning them first.

2. The second point is that a person who is given sixty years of life and yet he neglects the obligations of Faith, will have no excuse.

3. After the age of sixty years, one must not neglect his religious obligations because then one is closer to death. Although one may die even at a young age, in youth one is still hopeful of life. After crossing the age of sixty, to hope for longer age, while leading a sinful life and defying Divine injunctions constitute a disastrous conduct. May Allah save us from doing so.

113. Ibn `Abbas (May Allah be pleased with them) said: `Umar (May Allah be pleased with him) used to make me sit with the noble elderly men who had participated in the battle of Badr. Some of them disliked it and said to `Umar: "Why do you bring in this boy to sit with us when we have sons like him?'' `Umar replied: "Because of the status he has, which you already know about (i.e., belongs to the source of knowledge and the house of the Prophet (PBUH)).'' One day, `Umar called me and seated me in the gathering of those people; and I think that he called me just to show them (of my religious knowledge). `Umar then questioned them (in my presence). "How do you interpret the ayah of Allah: `When there comes the Help of Allah (to you, O Muhammad (PBUH) against your enemies) and the Conquest (of Makkah).''' Someone said that when Allah's Help and the Conquest (of Makkah) came to us, we were called upon to celebrate the Praise of Allah and ask for His forgiveness. Some others remained silent and did not utter a word. Thereupon `Umar asked me: "Ibn `Abbas! Do you say the same.'' I replied: "No". He said: "What do you say then?'' I replied: "That is the sign of the Prophet's death about which he had been informed. Allah, the Exalted, says:

'When there comes the help of Allah (to you, O Muhammad (PBUH) against your enemies) and the Conquest (of Makkah)'.

So declare the remoteness of your Rubb from every imperfection, and ask for His forgiveness. Verily, He is the One Who accepts the repentance and Who forgives".

On that `Umar (May Allah be pleased with him) said: "I do not know anything about it other than what you have said".
[Al-Bukhari]

Commentary:
1. This value of man does not go with the length of age but with that of intellect, intelligence, knowledge and consciousness. For this reason, a young boy can have precedence and preference over the elders due to his clear understanding and vast knowledge.

2. When a person gets closer to death, he must devote himself more and more to the praise and glorification of Allah and beg pardon from Him.

114. ' Aishah (May Allah be pleased with her) said: After the revelation of (the Surah) "When the Help of Allah comes (to you, O Muhammad (PBUH) against your enemies) and the Conquest (of Makkah)'' (110:1), Messenger of Allah (PBUH) used to recite in every prayer: "Subhanaka Rabbana wa bihamdika, Allahum-maghfir li (Far removed You are from every imperfection, our Rubb, and all praise is for You, forgive me, O Allah)".
[Al-Bukhari and Muslim].

Another narration is: Messenger of Allah (PBUH) recited frequently in bowing and prostration: "Subhanaka Rabbana wa bihamdika, Allahum-maghfir li. (Far removed You are from every imperfection, our Rubb, and all praise is for You, forgive me, O Allah)". He elucidated that it has been commanded in the Noble Qur'an to recite: "So glorify the Praises of your Rubb, and ask for His forgiveness. Verily, He is the One Who accepts the repentance and Who forgives". (V.110:1) And he (the Messenger of Allah) acted upon it.

According to the narration in Muslim, Messenger of Allah (PBUH) frequently recited these words just before he passed away: "Subhanaka Rabbana wa bihamdika. Astaghfiruka wa atubu ilaika.'' I (`Aishah (May Allah be pleased with her) asked him: "O Messenger of Allah! What are these new words which I hear from you repeatedly.'' He replied, "A sign has been appointed for me relating to my people that I should repeat these words at the sight of that sign". Then he recited Surat An-Nasr.

Another narration in Muslim related from `Aishah (May Allah be pleased with her) is: Messenger of Allah (PBUH) often recited, "Glory be to Allah and praise be to Him; I seek forgiveness of Allah and turn to Him in repentance.'' I said to him: "O Messenger of Allah, I hear you recite frequently: `O Allah, You are free from every imperfection our Rubb and all praise is for You; I seek forgiveness of Allah and turn to Him in repentance.''' He replied, "My Rubb has informed me that I would soon see a sign regarding my people, whenever I see it, I repeat this statement more often (of His Glorification and Praise and beg pardon of Him and turn to Him). Now I have witnessed the sign. The revelation of Surat An-Nasr and the victory is the conquest of Makkah.''

"When there comes the Help of Allah (to you, O Muhammad (PBUH) against your enemies) and the Conquest (of Makkah). And you see that the people enter Allah's religion (Islam) in crowds. So glorify the Praises of your Rubb, and ask His forgiveness. Verily, He is the One Who accepts the repentance and Who forgives.'' (110:1-3)

Commentary:
1. Acceptance and approval of reciting the words `Subhanaka Rabbana wa bihamdika, Allahum-maghfirli' in Ruku` and Sujud respectively, instead of the words `Subhana Rabbiyal-Azim' and `Subhana Rabbiyal-A`la'.

2. One must express his gratitude to Allah whenever he receives a blessing from Him.

115. Anas (May Allah be pleased with him) said: Allah the Rubb of honour and glory sent Revelation to His Messenger (PBUH) more frequently before his death than at any other time.
[Al-Bukhari and Muslim].

Commentary: During the last days of the Prophet (PBUH) the abundance of Wahy (Revelation) was an indication that he was about to leave this world.

116. Jabir (May Allah be pleased with him) said: The Prophet (PBUH) said, "Every one will be raised in the condition in which he dies".
[Muslim].

Commentary: This Hadith has a meaning similar to the one quoted at another place which signifies that if a person dies performing good deeds, he will have a good end; and the one who dies in misdeeds, he will come to a bad end. It is, therefore, necessary that one should always avoid disobedience of Divine injunctions, especially in old age and illness because one may fall in the clutches of death at any time .


Numerous ways of doing Good

Chapter 13
Numerous ways of doing Good

Allah, the Exalted, says:

"... and whatever you do of good deeds, truly, Allah knows it well.'' (2:215)

"And whatever good you do, (be sure) Allah knows it.'' (2:197)

"So whosoever does good equal to the weight of an atom (or a small ant), shall see it.'' (99:7)

"Whosoever does a good deed, it is for his ownself...'' (45:15)

117. Abu Dharr (May Allah be pleased with him) reported: I asked: "O Messenger of Allah! Which action is the best?'' He (PBUH) said, "Faith in Allah and Jihad in the way of Allah.'' I asked: "Which neck (slave) is best (for emancipation)?'' He said, "That which is dearest of them in price and most valuable of them to its masters". I asked: "If I cannot afford (it)?'' He said, "Then help a labourer or work for one who is disabled". I asked: "If I cannot do (it)?'' He said, "You should restrain yourself from doing wrong to people, because it (serves as) charity which you bestow upon yourself".
[Al-Bukhari and Muslim].

Commentary: This Hadith shows the excellence of Jihad and emancipation of slaves. It also highlights the importance of co-operation and sympathy with others. Similarly, one who refrains from putting others into trouble, his reward for it is no less than that of propitiatory offering and kindness. It also tells that faith in Allah is the basis for the acceptance of good deeds. In fact, conduct is the fruit of one's Faith. Without Faith nothing will be acceptable by Allah.

118. Abu Dharr (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When you get up in the morning, charity is due from every one of your joints. There is charity in every ascription of glory to Allah; there is charity in every declaration of His Greatness; there is charity in every utterance of praise of Him; there is charity in every declaration that He is the only true God (worthy of worship); there is charity in enjoining good; there is charity in forbidding evil. Two Rak`ah of Duha (Forenoon prayer) is equal to all this (in reward)".
[Muslim].

Commentary: There are three hundred and sixty joints in a human body. It is these joints which enable him to work and make all kinds of movements. If man's body did not have these joints it would have been impossible for him to sit, stand, lie, move and make use of different organs of his body. Thus every joint is a blessing for which one must express gratitude to Allah. It is yet another Blessing of Allah that He has also told man a very easy way of thanksgiving which can be practised even by the poorest man in the world. This means of thanksgiving is recitation of Tasbih (Subhan Allah), Tahmid (Al-hamdu lillah), Takbir (Allahu Akbar), Tahlil (La ilaha illallah), and to preach virtue and forbid wrong/ unlawful, etc. If one is unable to do even this, then he should perform two Rak`ah prayer at any time between sunrise and sunset. If one wants to enlarge their number, he can increase them to eight with the condition that the eight are divided into four couplets.

119. Abu Dharr (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The deeds of my people, good and bad, were presented before me, and I found the removal of harmful objects from the road among their good deeds, and phlegm which might be in a mosque left unburied among their evil deeds".
[Muslim].

Commentary:
1. Allah has listed in virtue even the good deed which is for the benefit of people or can save them from loss. What is its opposite, however small it may be, is reckoned as mischief. This Hadith induces one to do good deeds to attain the Pleasure of Allah and prevents one from evil deeds so that one is saved from the displeasure of Allah.

2. The Hadith enjoins cleanliness of mosques and forbids throwing of anything there which violates its sacredness, i.e., spitting. If any such dirty thing is found there, it must be removed immediately.

120. Abu Dharr (May Allah be pleased with him) reported: Some people said to Messenger of Allah (PBUH): "O Messenger of Allah, the rich have taken away (all the) reward. They observe Salat (prayers) as we do; and give Sadaqah (charity) out of their surplus wealth.'' Upon this he (the Prophet (PBUH)) said, "Has Allah not prescribed for you (a course) following which you can (also) give Sadaqah? In every declaration of the glorification of Allah (i.e., saying Subhan Allah) there is a Sadaqah, and in every Takbir (i.e., saying Allahu Akbar) is a Sadaqah, and in every celebration of praise (saying Al-hamdu lillah) is a Sadaqah, and in every declaration that He is One (La ilaha illallah) is a Sadaqah, and in enjoining of good is a Sadaqah, and in forbidding evil is a Sadaqah, and in man's sexual intercourse (with his wife) there is a Sadaqah.'' They (the Companions) said: "O Messenger of Allah, is there reward for him who satisfies his sexual need among us?'' He said, "You see, if he were to satisfy it with something forbidden, would it not be a sin on his part? Similarly, if he were to satisfy it legally, he should be rewarded".
[Muslim].

Commentary: This Hadith highlights two important points. Firstly, the enthusiasm of the Companions of the Prophet (PBUH) for surpassing each other in good actions. Secondly, it tells that virtue has a vast meaning in Islam and it includes every action which is done with good intention, provided it does not involve disobedience of Allah. So much so that it covers even natural activities of man which fall in the category of Mubah (that which is permissible and may be omitted without fear of sin) and one is rewarded for them. Not only that, one is rewarded even for abstaining from a sin on the condition that the abstention is for the obedience of Allah. Then abstention rises to the level of an act of obedience and is rewarded likewise.

121. Abu Dharr (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Do not belittle any good deed, even meeting your brother (Muslim) with a cheerful face".
[Muslim].

Commentary: We learn from this Hadith that meeting somebody cheerfully is also a virtue for two reasons. Firstly, it is a sign of good manners. Secondly, it creates affection and friendship among the Muslims which is a meritorious act.

122. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Every day the sun rises charity (Sadaqah) is due on every joint of a person: you administer justice between two men is a charity; and assisting a man to mount his beast, or helping him load his luggage on it is a charity; and a good word is a charity; and every step that you take (towards the mosque) for Salat (prayer) is a charity and removing harmful things from the road is a charity".
[Al-Bukhari and Muslim].

In Muslim, it is reported on the authority of `Aishah (May Allah be pleased with her) that Messenger of Allah (PBUH) said, "Everyone of the children of Adam has been created with three hundred and sixty joints; so he who declares the Glory of Allah (i.e., saying Allahu Akbar), praises Allah (i.e., Al-hamdu lillah), declares Allah to be One (i.e., La ilaha illallah), glorifies Allah, and seeks forgiveness from Allah (i.e., Astaghfirullah), and removes stone, or thorn, or bone from people's path, and enjoins good and forbids evil, to the number of those three hundred and sixty, will walk that day having rescued himself from Hell".

Commentary: This Hadith also tells that even a person who does not have the capacity to pay Sadaqah (charity, alms, propitiatory offerings, etc.) can also pay it in the manner prescribed above and earn its reward. Moreover, he can also pay alms for the joints in his body.

123. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who goes to the mosque at dawn or dusk (for Salat), Allah prepares a hospitable abode for him in Jannah, every time when he walks to it or comes back from it".
[Al-Bukhari and Muslim].

Commentary: This Hadith induces us to go to the mosque and perform Salat in congregation.

124. Abu Hurairah (May Allah be pleased with him) reported: O Muslim women, never belittle any gift you give your neighbour even if it is a hoof of a sheep".

[Al-Bukhari and Muslim].

Commentary: This Hadith enjoins that any gift presented sincerely by a neighbour should not be treated as humble, however ordinary it may be, because in spite of being of small worth it has a high value with Allah.

125. Abu Hurairah (May Allah be pleased with him): The Prophet (PBUH) said, "Iman has over seventy branches, the uppermost of which is the declaration: `None has the right to be worshipped but Allah'; and the least of which is the removal of harmful object from the road, and modesty is a branch of Iman.''
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith tells us that from the standpoint of practice, Faith has several stages. It also tells that Faith and practice are inseparable.

2. It also makes evident the importance and excellence of bashfulness because it induces a person to good deeds and deters him from evils.

126. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "While a man was walking on his way he became extremely thirsty. He found a well, he went down into it to drink water. Upon leaving it, he saw a dog which was panting out of thirst. His tongue was lolling out and he was eating moist earth from extreme thirst. The man thought to himself: `This dog is extremely thirsty as I was.' So he descended into the well, filled up his leather sock with water, and holding it in his teeth, climbed up and quenched the thirst of the dog. Allah appreciated his action and forgave his sins". The Companions asked: "Shall we be rewarded for showing kindness to the animals also?'' He (PBUH) said, "A reward is given in connection with every living creature".
[Al-Bukhari and Muslim].

In the narration of Al-Bukhari, the Prophet (PBUH) is reported to have said: "Allah forgave him in appreciation of this act and admitted him to Jannah".

Another narration says: "Once a dog was going round the well and was about to die out of thirst. A prostitute of Banu Israel happened to see it. So she took off her leather sock and lowered it into the well. She drew out some water and gave the dog to drink. She was forgiven on account of her action".

Commentary:
1. This Hadith emphasizes the importance of kindness to every creature, even animals, because Allah is pleased with such kindness.

2. Allah's Quality of mercy and forgiveness is immensely vast. If He wants He may forgive a person even on a minor good action done by him.

127. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "I saw a man going about in Jannah (and enjoying himself) as a reward for cutting from the middle of the road, a tree which was causing inconvenience to the Muslims".
[Muslim].

Another narration says: "A man who passed by a branch of a tree leaning over a road and decided to remove it, saying to himself, `By Allah! I will remove from the way of Muslims so that it would not harm them.' On account of this he was admitted to Jannah".

According to the narration in Al-Bukhari and Muslim: Messenger of Allah (PBUH) said, "While a man was walking, he saw a thorny branch on the road, so he removed it and Allah appreciated his action and forgave him".
Commentary: The act of saving people from harm and loss is greatly liked by Allah, no matter how small it is. Allah is greatly pleased if a person removes from the passage something that causes harm to people. On the contrary, persons who restrict or obstruct passages and thereby create inconvenience for the passers-by, as is usually done with great audacity on marriage parties, or create trouble for people by encroachment, do in fact incur Allah's displeasure. But our moral sense has been so blunted that rather than feeling any compunction, we do such things boastfully forgetting that `Truly, to Allah we belong and truly, to Him we shall return.' We have now become so low that we take pride in going against our religious teachings and practices thus incurring Allah's displeasure. Is there any further stage of moral turpitude and revolt against Him?.

128. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who performs his Wudu' perfectly and comes to Jumu`ah prayer and listens (to the Khutbah) silently, the sins which he has committed since the previous Friday plus three more days (i.e., 10 days) will be forgiven for him. One who distracts himself with pebbles during the Khutbah will not get the (Jumu`ah) reward".
[Muslim].

Commentary: This Hadith brings into prominence the following five important points:

1. It induces one to take full care in ablutions, that is to say, it should be strictly performed according to Sunnah.

2. The excellence of Jumu`ah (Friday prayer), which is obligatory for every sane, adult, healthy and resident Muslim, whether he lives in a town or village. The Friday prayer is performed in the mosque in congregation. It has two Rak`ah at the time of noon prayer and is preceded by Khutbah of Imam (who leads the prayer). It is not performed individually at home.

3. Whoever does one good act will get ten-times reward in return. According to this principle, one who performs a Friday prayer, his minor sins relating the Rights of Allah which are committed by him in ten days are forgiven.

4. Silence during the Khutbah is a must, otherwise, one loses the reward of Jumu`ah prayer.

5. It is also necessary for a Khatib to deliver a brief Khutbah.

129. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a Muslim or a believer washes his face (in the course of Wudu'), every sin he has committed with his eyes is washed away from his face along with water, or with the last drop of water; when he washes his hands, every sin they wrought is erased from his hands with the water, or with the last drop of water; and when he washes his feet, every sin towards which his feet walked is washed away with water, or with the last drop of water, with the result that he comes out cleansed of all sins".
[Muslim].

Commentary: This Hadith mentions the excellence of Wudu'. Obviously a person who performs Wudu' five times daily would be free from sins. Thus, Wudu' is a means of both outward and inward cleanliness.

130. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The five (daily) Salat (prayers), and from one Jumu`ah prayer to the (next) Jumu`ah prayer, and from Ramadan to Ramadan are expiations for the (sins) committed in between (their intervals); provided the major sins are not committed".
[Muslim].

Commentary: If a Muslim saves himself from major sins and does not neglect his obligations to people, then he remains free from sins by means of the `Ibadah (worship) stated above.

131. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Should I not direct you to something by which Allah obliterates the sins and elevates (your) ranks.'' They said: "Yes, O Messenger of Allah". He said, "Performing Wudu' properly, even in difficulty, frequently going to the mosque, and waiting eagerly for the next Salat (prayer) after a Salat is over; indeed, that is Ar-Ribat".
[Muslim].

Commentary: Ribat means staying on the frontier of an Islamic country, for security and defense purposes. Thus, it is a continuous process of Jihad. Continuous good deeds and `Ibadah have been compared with Ribat. Performing full ablution in Makarih (where severe unpleasantness and hard labour is involved) is quite difficult. For instance, in winter it is very cumbersome to properly wash all the organs of the body but a Muslim does it to please Allah. Thus, its reward will be more in proportion to the labour. Similarly, the nearness of a mosque is in many respect very useful but its being far from the house is better in this respect that the greater distance one has to cover for going to the mosque, the higher the reward for going there will be. Those who live close to the mosque do not have this credit.

132. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who observes the Fajr and `Asr (prayers) will enter Jannah.''
[Al-Bukhari and Muslim].

Commentary: Muslims are enjoined to take special care of two of the five prescribed Salat, namely Fajr and `Asr because they occur during very comfortable hours. Their excellence, and inducement on them, have been mentioned here for the reason that there is greater possibility of laziness and negligence in these two Salat. It is very difficult indeed to rise for Salat-ul-Fajr (the dawn prayer). Similar is the case of Salat-ul-`Asr (the afternoon prayer). It is the time when a person is very busy in winding up his daily affairs and thus there is serious risk of losing this Salat on this account. One who observes these two at their stated time, can easily secure the other three without much effort. This endeavour on his part to secure Salat will be a very effective means for him to enter Jannah.

133. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a slave of Allah suffers from illness or sets on a journey, he is credited with the equal of whatever good works he used to do when he was healthy or at home".
[Al-Bukhari].

Commentary: This Hadith refers to the actions which a Muslim should take to gain the Blessings of Allah and acceptance of his prayers by Him, because one is duty-bound to fulfil all his obligations in all circumstances.

134. Jabir (May Allah be pleased with him) reported that he heard Messenger of Allah (PBUH) saying, "Every good deed is charity".
[Al-Bukhari].

Muslim has reported the same on the authority of Hudhaifah (May Allah be pleased with him).

Commentary: We come to know from this Hadith that whatever good action and deed is done by a Muslim, he gets a reward of Sadaqah on it. The word Ma`ruf stands here for every virtue and noble deed. Renunciation of evils is also a virtue (Mar`uf).

135. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a Muslim plants a tree, whatever is eaten from it is charity from him and whatever is stolen is charity and whatever is subtracted from it is charity".
[Muslim].

Another narration says: "If a Muslim plants a tree, or sows a field and men and beasts and birds eat from it, all of it is charity from him".

Commentary: This Hadith highlights the importance of gardening and agriculture. It is also one of the merits of these two occupations that if someone patiently bears the loss that he suffers due to pilferage or theft of their produce, he is rewarded for it.

136. Jabir (May Allah be pleased with him) reported: The tribe Banu Salimah wanted to move nearer to the mosque. On learning this Messenger of Allah (PBUH) said to them, "I heard that you intend to move nearer to the mosque". They said, "That is so, O Messenger of Allah, we do want to do that". He said, "O Banu Salimah, keep to your homes, your steps (to the mosque) are recorded".
[Muslim].

Another narration says: "There is for every step (towards the mosque) a degree (of reward) for you".
[Muslim].

Commentary:
1. The more labour a good deed involves, the greater the proportion of reward for it will be.

2. No matter how great the distance of the mosque from one's house may be, one must go to it to perform Salat with congregation.

137. Ubayy bin Ka`b (May Allah be pleased with him) reported: There was a man, and I do not know of any other man whose house was farther than his from the mosque, and he never missed Salat (in congregation). It was said to him (or I said to him): "If you buy a donkey you could ride it in the dark nights and in the burning sand.'' He said: "I do not like my house to be by the side of the mosque, for I (eagerly) desire that my steps towards the mosque and back from it should be recorded when I return to my family.'' Upon this Messenger of Allah (PBUH) said, "Allah has granted you all the rewards for you".
[Muslim].

Another narration says: "You will get the reward for what you have anticipated".

Commentary: This Hadith brings into focus the fervent zeal of the Companions of the Prophet (PBUH) for reward of good deeds in the Hereafter. It also tells that one gets reward for actions according to one's intentions. If we see the matter of Salat from this angle, we find that location of mosque at a long distance from a Muslim's house is a blessing for him.

138. Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "There are forty kinds of virtue; the uppermost of them is to lend a (milch) she-goat (to someone in order to benefit from it and then return it). He who practices any of these virtues expecting its reward and relying on the truthfulness of the promise made for it, shall enter Jannah.''
[Al-Bukhari].

Commentary: Loaning of anything to someone for temporary benefit, without loosing the right of its ownership, is a meritorious act.

139. `Adi bin Hatim (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "Protect yourself from (Hell) Fire, by giving of half of a date (in charity)".
[Al-Bukhari and Muslim].

In another narration `Adi bin Hatim (May Allah be pleased with him) reported Messenger of Allah (PBUH) as saying: "Allah will surely speak with everyone of you without an interpreter. He (the man) will look at his right side and will see nothing but (the deeds) which he had done before, and he will look to his left side and will see nothing but (the deeds) which he had done before. Then he will look in front of him and will find nothing but Hell-fire facing him. So protect (yourselves) from (Hell) Fire, by giving in charity even half a date; and if he does not finds it, then with a kind word".

Commentary: This Hadith brings into prominence the following three points:

1. The horror of the Day of Resurrection when one will have to stand before Allah to account for all his actions which will then be lying at his both hands.

2. Everyone should spend according to his capacity in the way of Allah in the form of Sadaqah and alms. In this way, good manners like polite conversation, etc., can also become a means of his salvation.

3. One's actions alone would help him on the Day of Resurrection.

140. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah will be pleased with His slave who praises Him (i.e., says Al-hamdu lillah) when he eats and praises Him when he drinks".
[Muslim].

Commentary: If a person expresses his gratitude to Allah for food, which besides being a source of nourishment is enjoyable for him, he gets a reward for it and thus even eating can become rewardable too.

141. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Giving in charity is an obligation upon every Muslim". It was said (to him): "What about one who does not find (the means) to do so?'' He (PBUH) said, "Let him work with his hands, thus doing benefit to himself and give in charity.'' It was said to him: "What if he does not have (the means) to do so?'' He (PBUH) said, "Then let him assist the needy, the aggrieved.'' It was said: "What about if he cannot even do this?'' He (PBUH) said, "Then he should enjoin good.'' He was asked: "What if he cannot do that?'' He (the Prophet (PBUH)) said, "He should then abstain from evil, for verily, that is a charity from him".
[Al-Bukhari and Muslim].

Commentary: This Hadهth emphasizes two things. Firstly, it induces one to work hard so that he can fulfill his own needs and also spend in the way of Allah. Secondly, it points out a great variety of virtues and good deeds so much so that even to abstain from sin also comes in the category of Sadaqah.


Moderation in Worship

Chapter 14
Moderation in Worship

Allah, the Exalted, says:

"Ta-Ha. We have not sent down the Qur'an unto you (O Muhammad (PBUH)) to cause you distress". (20:1,2)

"Allah intends for you ease, and He does not want to make things difficult for you". (2:185)

142. Aishah (May Allah be pleased with her) reported: The Prophet (PBUH) came in when a woman was sitting beside me. He asked me, "Who is she?'' I said: "She is the one whose performance of Salat (prayer) has become the talk of the town.'' Addressing her, he (PBUH) said, "(What is this!) You are required to take upon yourselves only what you can carry out easily. By Allah, Allah does not withhold His Mercy and forgiveness of you until you neglect and give up (good works). Allah likes the deeds best which a worshipper can carry out constantly".
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith prohibits `Ibadah (worship) beyond one's capacity lest one gets tired and stops it altogether. One should be, therefore, moderate in this respect.

2. Allah likes that good action which is done regularly, even if it is a small one. Any good deed which is done continuously, will also have an everlasting reward. On the contrary, a good deed which is done for a short period will have a short return.

143. Anas (May Allah be pleased with him) reported: Three men came to the houses of the wives of the Prophet (PBUH) to inquire about the worship of the Prophet (PBUH). When they were informed, they considered their worship insignificant and said: "Where are we in comparison with the Prophet (PBUH) while Allah has forgiven his past sins and future sins". One of them said: "As for me, I shall offer Salat all night long.'' Another said: "I shall observe Saum (fasting) continuously and shall not break it". Another said: "I shall abstain from women and shall never marry". The Prophet (PBUH) came to them and said, "Are you the people who said such and such things? By Allah, I fear Allah more than you do, and I am most obedient and dutiful among you to Him, but still I observe fast and break it; perform Salat and sleep at night and take wives. So whoever turns away from my Sunnah does not belong to me".
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith deals with the following five points:

a) Moderation in worship.

b) Obligation to marry.

c) Inducement for following in the Prophet's footsteps.

d) Prohibition from observing Saum (fasts) all the time.

e) Prohibition of keeping awake all the night for Nawafil prayers.

2. There is neither virtue nor reward for making innovations in religion. All the blessings and rewards lie only in the obedience and following the conduct of the Prophet (PBUH).

144. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Ruined are those who insist on hardship in matters of the Faith.'' He repeated this three times.
[Muslim]

Commentary: This Hadith shows disgust against exercises which many Sufis have introduced in religion which deviate from the conduct of the Prophet (PBUH) and encourage self-violence. Similarly, such people who are hypocritical and make unnecessary probe into religious matters also fall in this category and are usually far from the teachings and practice of the Prophet (PBUH).

145. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The religion (of Islam) is easy, and whoever makes the religion a rigour, it will overpower him. So, follow a middle course (in worship); if you can't do this, do something near to it and give glad tidings and seek help (of Allah) at morn and at dusk and some part of night".
[Al-Bukhari].

Commentary: Besides moderation in worship, this Hadith enjoins that such times should be fixed for worship when one is fresh so that one feels pleasure in performing it. But this principle is for optional and voluntary prayers only. Obligatory Salat are to be performed at the prescribed times only.

146. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) came into the mosque and noticed a rope stretched between two poles. He enquired, "What is this rope for?'' He was told: "This is Zainab's rope. When during her voluntary prayer, she begins to feel tired, she grasps it for support". The Prophet (PBUH) said, "Untie it. You should perform prayers so long as you feel active. When you feel tired, you should go to sleep".
[Al-Bukhari and Muslim].

Commentary: This Hadith deals with the following three points:

1. It forbids undue strictness and taking support of anything in the course of Salat.

2. If wrong can be corrected by hand, it must be stopped immediately.

3. One should be moderate in `Ibadah and select such times for optional and voluntary prayers when one feels real pleasure in them.

147. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "When one of you feels drowsy during prayer, let him lie down till drowsiness goes away from him, because when one of you performs prayers while feeling sleepy, he does not know whether he seeks forgiveness or abuses himself".
[Al-Bukhari and Muslim].

148. Jabir bin Samurah (May Allah be pleased with him) reported: I used to perform prayer with the Prophet (PBUH) and his Salat was of a moderate length and his Khutbah too was moderate in length.
[Muslim].

Commentary: This Hadith tells us that Imam should neither lengthen the Salat nor give a long Khutbah in the congregational Salat because both of these things are not according to the practice of the Prophet (PBUH).

149. Abu Juhaifah (May Allah be pleased with him) reported: The Prophet (PBUH) made a bond of brotherhood between Salman and Abud-Darda'. Salman paid a visit to Abud-Darda' and found Umm Darda' (his wife) dressed in shabby clothes and asked her why she was in that state. She replied: "Your brother Abud-Darda' is not interested in (the luxuries of) this world. In the meantime Abud-Darda' came in and prepared a meal for Salman. Salman requested Abud-Darda' to eat (with him) but Abud-Darda' said: "I am fasting.'' Salman said: "I am not going to eat unless you eat.'' So, Abud-Darda' ate (with Salman). When it was night and (a part of the night passed), Abud-Darda' got up (to offer the night prayer) but Salman asked him to sleep and Abud-Darda' slept. After some time Abud-Darda' again got up but Salman asked him to sleep. When it was the last hours of the night, Salman asked him to get up and both of them offered (Tahajjud) prayer. Then Salman told Abud-Darda': "You owe a duty to your Rubb, you owe a duty to your body; you owe a duty to your family; so you should give to every one his due. Abud-Darda' came to the Prophet (PBUH) and reported the whole story. Prophet (PBUH) said, "Salman is right".
[Al-Bukhari].

Commentary: This Hadith highlights the following points:

1. Although the performance of voluntary prayers (Nawafil) is highly meritorious, it should not be done at the cost of obligations for, in this case, they loose their merits and are disliked by Allah.

2. The right time for Tahajjud (optional prayers at night) is the last third part of the night. The reason being that in the first two portions of the night, one should take rest and perform his conjugal duties.

3. Voluntary fasting can be broken (for valid reasons) without any expiation.

4. It is permissible to establish fraternity on the basis of Deen, and when this is established, the families so affiliated can associate with each other.

5. Muslims must provide right guidance to each other.

6. In case of need, it is permissible to speak to an unknown woman while observing the teachings of the Prophet (PBUH) in this regard, such as lowering the gaze and be as brief as possible.

150. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: The Prophet (PBUH) was informed that I said that I would perform prayers the whole night and observe fasting every day as long as I live. Messenger of Allah (PBUH) said, "Is it you who said this?'' I said to him, "O Messenger of Allah! I ransom you with my parents, it is I who said that.'' Messenger of Allah (PBUH) said, "You will not be able to do that. Observe fast and break it; sleep and get up for prayer, and observe fast for three days during the month; for every good is multiplied ten times and that will be equal to fasting the whole year.'' I said, "O Messenger of Allah! I can do more than that.'' He said, "Observe fast one day and leave off the next two days.'' I said, "O Messenger of Allah! I have strength to do more than that.'' Messenger of Allah (PBUH) said, "Observe fast every other day, and that is the fasting of Dawud (PBUH) and that is the most moderate fasting".

According to another narration: Messenger of Allah (PBUH) said, "That is the best fasting.'' I said, "But I am capable of doing more than this". Thereupon, Messenger of Allah (PBUH) said, "There is nothing better than this.'' `Abdullah bin `Amr (May Allah be pleased with them) said (when he grew old): "Had I accepted the three days (fasting during every month) as the Messenger of Allah had said, it would have been dearer to me than my family and my property".

In another narration `Abdullah is reported to have said: Messenger of Allah (PBUH) said to me, "O `Abdullah! Have I not been informed that you observe fast during the day and offer prayer all the night.'' I replied, "Yes, O Messenger of Allah!'' Messenger of Allah (PBUH) said, "Don't do that. Observe fast for few days and then leave off for few days, perform prayers and also sleep at night, as your body has a right upon you, and your eyes have a right upon you; and your wife has a right upon you; your visitors have a right upon you. It is sufficient for you to observe fast three days in a month, as the reward of good deeds is multiplied ten times, so it will be like fasting the whole year.'' I insisted (on fasting) and so I was given a hard instruction. I said, "O Messenger of Allah! I have strength.'' Messenger of Allah (PBUH) said, "Observe fast like the fasting of Prophet Dawud (PBUH); and do not fast more than that.'' I said: "How was the fasting of Prophet Dawud?'' He (PBUH) said, "Half of the year (i.e., he used to fast on every alternate day).''

Afterwards when `Abdullah (May Allah be pleased with him) grew old, he used to say: "Would that I had availed myself of the concession granted to me by Messenger of Allah.''

In another narration `Abdullah is reported to have said: Messenger of Allah (PBUH) said, "I have been informed that you observe fast continuously and recite (the whole of the Qur'an) every night.'' I said, "Messenger of Allah! It is right, but I covet thereby nothing but good,'' whereupon he (PBUH) said, "Then observe fasts like the fasting of Prophet Dawud (PBUH) as he was the most ardent worshipper of Allah; recite the Qur'an once every month.'' I said, "O Prophet of Allah! I am capable of doing more than that.'' He said, "Then recite it (the complete Qur'an) in every twenty days.'' I said, "O Prophet of Allah I am capable of reciting more than that.'' He said, "Then recite it once in every ten days.'' I said, "O Prophet of Allah! I am capable of reciting more than that.'' He said, "Then recite it once in every seven days, but not recite more than that.'' The Prophet of Allah also said to me, "You do not know, you may have a longer life". When I grew old I wished I had availed myself of the concession (granted to me by) the Prophet of Allah.

In another narration `Abdullah is reported to have said: Messenger of Allah (PBUH) said, "The best fasting with Allah is that of (Prophet) Dawud, and the best prayer with Allah is that of Dawud (PBUH) for he would sleep half of the night and stand for prayer for the third of it and (then) would sleep sixth part of it; he observed fast one day and leave off the other. He would not flee on meeting the enemy".

In another narration `Abdullah is reported to have said: My father helped me marry a noble woman and he used to inquire of his daughter-in-law regarding her husband. She would say: "He is, indeed, a fine man. Since I have come to him, he has neither stepped on my bed nor he has had sexual intercourse with me". When this state of affairs lasted for some time, my father mentioned the matter to Messenger of Allah (PBUH) who directed my father saying, "Send him to me". I went to him accordingly. He asked me, "How often do you observe fast?'' I replied; "Daily". He asked me, "How long do you take in reading the Noble Qur'an completely.'' I said, "Once every night". Then he narrated the whole story. He (in his old age) would recite one seventh of his nightly recitation to some members of his family during the day to lighten his task at night. Whenever he wished to have a relief from his fast on alternate days, he would give up fasting for a few days and make up deficiency later by observing the number of fasts he had missed. He would not give up the number of fasts altogether because he did not like to abandon what he had settled with Messenger of Allah (PBUH).

Commentary: This Hadith brings the following two things into focus:

1. Besides mentioning the continence and ardour for worship of the Companions of the Prophet (PBUH), it tells us of the teachings of the Prophet of Allah to adopt moderation and fulfill the lawful needs of life as well as religion.

2. It also presents a model of the chastity, modesty and bashfulness of the Sahabiyat (women who embraced Islam and saw the Prophet (PBUH)). It tells how patiently they bore the indifference of their husbands. In the instance quoted in the above mentioned Hadith, the politeness with which the wife of Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) answered her father-in-law when he inquired her about the treatment of her husband is a model of decency and modesty.

151. Hanzalah Al-Usayyidi (May Allah be pleased with him) who was one of the scribes of Messenger of Allah (PBUH), reported: I met Abu Bakr (May Allah be pleased with him) he said: "How are you O Hanzalah?'' I said, "Hanzalah has become a hypocrite". He said, "Far removed is Allah from every imperfection, what are you saying?'' I said, "When we are in the company of Messenger of Allah (PBUH) and he reminds us of Hell-fire and Jannah, we feel as if we are seeing them with our very eyes, and when we are away from Messenger of Allah (PBUH), we attend to our wives, our children, our business, most of these things (pertaining to life hereafter) slip out of our minds.'' Abu Bakr (May Allah be pleased with him) said, "By Allah, I also experience the same thing". So Abu Bakr (May Allah be pleased with him) and I went to Messenger of Allah (PBUH) and I said to him, "O Messenger of Allah (PBUH), Hanzalah has turned hypocrite.'' Thereupon Messenger of Allah (PBUH) said, "What has happened to you?'' I said, "O Messenger of Allah, when we are in your company, and are reminded of Hell-fire and Jannah, we feel as if we are seeing them with our own eyes, but when we go away from you and attend to our wives, children and business, much of these things go out of our minds.'' Thereupon Messenger of Allah (PBUH) said, "By Him in Whose Hand is my life if your state of mind remains the same as it is in my presence and you are always busy in remembrance (of Allah), the angels will shake hands with you in your beds and in your roads; but Hanzalah, time should be devoted (to the worldly affairs) and time should be devoted (to prayer)". He (the Prophet (PBUH)) said this thrice.
[Muslim].

Commentary: This Hadith also tells us about the continence and piety of the Companions of the Prophet (PBUH) with reference to the natural instinct of man to think differently in different situations. This condition has nothing to do with Nifaq (hypocrisy). Islam is the Deen of Fitrah (pure nature) and takes the middle course in everything, and combines the benefits of this world and those of the Hereafter. It also satisfies the needs of the body as well as that of the soul.

152. Ibn `Abbas (May Allah be pleased with them) reported: While the Prophet (PBUH) was delivering Khutbah (religious talk), he noticed a man who was standing, so he asked about him and was told that he was Abu Israel who had taken a vow to remain standing and not sit, or go into the shade, or speak while observing fasting. Thereupon Messenger of Allah (PBUH) said, "Tell him to speak, to go into the shade, to sit and to complete his fast''.
[Al-Bukhari].

Commentary:
1. This Hadith makes it abundantly clear that one cannot attain the Pleasure of Allah by means of self-invented methods. It can only be achieved by ways and means prescribed in the Qur'an and Sunnah.

2. One should never vow for anything which is smeared with sin or which is not permitted by Deen. An instance of this is quoted in the above mentioned Hadith.

3. The majority of 'Ulama' (scholars) who do not think the expiation of such vows necessary, quote this Hadith in support of their view. They argue that the Prophet (PBUH) has not prescribed expiation in such cases as is evident from this Hadith.


The Righteous conduct on Regular base

Chapter 15
The Righteous conduct on Regular base

Allah, the Exalted, says:

"Has not the time come for the hearts of those who believe (in the Oneness of Allah - Islamic Monotheism) to be affected by Allah's Reminder (this Qur'an), and that which has been revealed of the truth, lest they become as those who received the Scripture [the Taurat (Torah) and the Injeel (Gospel)] before (i.e., Jews and Christians), and the term was prolonged for them and so their hearts were hardened?'' (57:16)

"And We sent `Isa (Jesus) - son of Maryam (Mary), and gave him the Injeel (Gospel). And We ordained in the hearts of those who followed him, compassion and mercy. But the monasticism which they invented for themselves, We did not prescribe for them, but (they sought it) only to please Allah therewith, but that they did not observe it with the right observance.'' (57:27)

"And be not like her who undoes the thread which she has spun, after it has become strong...'' (16:92)

"And worship your Rubb until there comes unto you the certainty (i.e., death).'' (15:99)

And there are Ahadith, one of them is narrated by `Aishah (May Allah be pleased with her): Messenger of Allah (PBUH) liked that act of worship most in the performance of which a person was regular and constant.
[Muslim].

153. `Umar bin Al-Khattab (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Should anyone fall asleep at night and fail to recite his portion of the Qur'an, or a part of it, if he recites it between the Fajr prayer and the Zuhr prayer, it will be recorded for him as though he had recited it during the night''.
[Muslim].

Commentary: The word `Hizb' originally means to take one's turn for getting water from a well. Subsequently, people started using it for daily round of recitation which one adopts on his own voluntarily. For instance, fixing a number of Nawafil (voluntary prayers), recital of a certain portion of the Noble Qur'an or performance of some other noble deed as one's daily routine. This Hadith stresses that one must adhere to such routine. It also tells that if for some reason one is unable to do it at the time fixed by him, he can do it later at the time closest to the one he has fixed for it. If one does so, he will be eligible to its full reward.

154. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said to me, "O Abdullah! Do not be like so-and-so. He used to get up at night for optional prayer but abandoned it later.''
[Al-Bukhari and Muslim].

Commentary: The excellence of manners demands that if someone has something reprehensible in his character, the person concerned should not be mentioned but the shortcoming must be indicated so that people refrain from it. The second point that we learn from this Hadith is that if one starts a good deed, he should try his best to do it perpetually because its perpetuation is liked by Allah.

155. `Aishah (May Allah be pleased with her) reported: When Messenger of Allah (PBUH) missed the optional night Salat (Tahajjud) due to pain or any other reason, he would perform twelve Rak`ah during the day time.
[Muslim].

Commentary: The Qada' of Nawafil (offering prayer to make up for having failed to offer it at their due time) is not binding. But it is Mustahab (desirable). The Prophet (PBUH) did it.


Observing the Sunnah and the manners of its obedience

Chapter 16
Observing the Sunnah and the manners of its obedience

Allah, the Exalted, says:

"And whatsoever the Messenger (Muhammad (PBUH)) gives you, take it; and whatsoever he forbids you, abstain (from it)". (59:7)

"Nor does he speak of (his own) desire. It is only a Revelation that is revealed.'' (53:3,4)

"Say (O Muhammad (PBUH) to mankind): `If you (really) love Allah then follow me (i.e., accept Islamic Monotheism, follow the Qur'an and the Sunnah), Allah will love you and forgive you of your sins". (3:31)

"Indeed in the Messenger of Allah (Muhammad (PBUH)) you have a good example to follow for him who hopes for (the Meeting with) Allah and the Last Day...'' (33:21)

"But no, by your Rubb, they can have no Faith, until they make you (O Muhammad (PBUH)) judge in all disputes between them, and find in themselves no resistance against your decisions, and accept (them) with full submission". (4:65)

"(And) if you differ in anything amongst yourselves, refer it to Allah and His Messenger (PBUH)". (4:59)

"He who obeys the Messenger (Muhammad (PBUH)), has indeed obeyed Allah.'' (4:80)

"And verily, you (O Muhammad (PBUH)) are indeed guiding (mankind) to the Straight Path (i.e., Allah's Deen of Islamic Monotheism):. (42:52)

"And let those who oppose the Messenger's (Muhammad (PBUH)) commandment (i.e., his Sunnah -- legal ways, orders, acts of worship, statements) (among the sects), beware, lest some Fitnah (disbelief, trials, afflictions, earthquakes, killing, overpowered by a tyrant) should befall them or a painful torment be inflicted on them.'' (24:63)

"And remember (O you the members of the Prophet's family, the Graces of your Rubb), that which is recited in your houses of the Verses of Allah and Al-Hikmah (i.e., Prophet's Sunnah -- legal ways, so give your thanks to Allah and glorify His Praises for this Qur'an and the Sunnah).'' (33:34)

156. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Do not ask me unnecessarily about the details of the things which I do not mention to you. Verily, the people before you were doomed because they were used to putting many questions to their Prophets and had differences about their Prophets. Refrain from what I forbid you and do what I command you to the best of your ability and capacity".
[Al-Bukhari and Muslim]

Commentary: To be unnecessarily inquisitive and create differences and confusion in the Injunctions of Allah and His Prophet (PBUH) leads to destruction. The safest course lies only in following the Orders of Allah and His Prophet (PBUH) without `ifs' and `buts.' Hairsplitting in religious issues falls in this category. It opens the door for chaos and conflict and paves the way for disunity and separation. May Allah give sense to the Muslim Ummah to abandon this road and take the Right Path which ensures peace and security. Let it be absolutely clear that the Right Path is one and one alone. There cannot be multiple right paths, it is one and singular. Once a community leaves the Straight Path, it is sure to go astray.

157. `Irbad bin Sariyah (May Allah be pleased with him) reported: One day Messenger of Allah (PBUH) delivered us a very eloquent Khutbah on account of which eyes shed tears and hearts were full of tears. A man said: "O Prophet of Allah, this is as if it were a parting advice. So advise us". He (PBUH) said, "I admonish you to fear Allah, to listen and obey even if an Abyssinian slave is appointed as your leader. Because whosoever among you shall live after me, will see much discord. So hold fast to my Sunnah and the examples of the Rightly-Guided Caliphs who will come after me. Adhere to them and hold to it fast. Beware of new things (in Deen) because every Bid`ah is a misguidance".
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith stresses piety, obedience to the leader, following in the footsteps of the Prophet (PBUH) and the first four noble caliphs. It strictly forbids innovation in Deen.

This Hadith also reveals the prediction of the Prophet (PBUH) that the Muslim Ummah will become a victim of dissension. He also prescribed the right means to counteract it. The remedy that he has proposed for this problem is that Muslims should never deviate from the path laid for them by him and his righteous successors. This is the touchstone for discovering the truth from the mess of different views. All the troubles of Muslims would come to an end if they accept this as the one singular criterion of right and wrong.

158. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Everyone of my Ummah will enter Jannah except those who refuse". He was asked: "Who will refuse?'' He (PBUH) said, "Whoever obeys me, shall enter Jannah, and whosoever disobeys me, refuses to (enter Jannah)".
[Al-Bukhari].

Commentary: The word Ummah here stands for the community which accepted the invitation of the Prophet (PBUH), that is to say, the people who on his call embraced Islam. Out of this community who follow him faithfully will go to Jannah.

159. Salamah bin Al-Akwa` (May Allah be pleased with him) reported: My father said that a person ate in the presence of Messenger of Allah (PBUH) with his left hand. He (PBUH) said, "Eat with your right hand". He said, "I cannot do that.'' Thereupon he (the Prophet) said, "May you never do that.'' It was pride that prevented him from doing it. And he could not raise it (the right hand) up to his mouth afterwards.
[Muslim].

Commentary:
1. To eat with the left hand without a valid reason, is a repulsive act. Besides eating, every other good action was done by the Prophet (PBUH) with his right hand.

2. To ignore the Injunctions of Allah and the practice of the Prophet (PBUH) out of pride is a serious offense and can endanger even the Faith of a Muslim.

160. Nu`man bin Bashir (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Straighten your rows (during Salat) or Allah would create dissension amongst you".
[Al-Bukhari and Muslim].

In another narration reported by Muslim, Nu`man bin Bashir (May Allah be pleased with them) narrated: Messenger of Allah (PBUH) used to straighten our rows (in Salat), as if he was straightening an arrow with their help until he saw that we had learnt it from him. One day he came out, stood up (for Salat) and was about to say: Allahu Akbar (Allah is the Greatest), (marking the beginning of the prayer) when he saw a man, whose chest was bulging out from the row. He said, "Slaves of Allah, you must straighten your rows or Allah would create dissension amongst you.''

Commentary: The real meaning of this saying is that Allah will create dissension and conflict among you. In any case, this Hadith makes abundantly clear the importance of setting the rows in congregational Salat to which the present-day Muslims do not pay much attention. Because of the lack of understanding of Islamic principles, no one pays heed to the proper formation of rows in mosques in congregational Salat.

161. Abu Musa (May Allah be pleased with him) reported: A house in Al-Madinah caught fire at night and the roof and walls

fell down upon the occupants. When this was reported to Messenger of Allah (PBUH) he said, "Fire is your enemy; so put it out before you go to bed".
[Al-Bukhari and Muslim].

Commentary: The order of the Prophet (PBUH) in this Hadith relates to the lamps which produced light by means of oil and wick which can cause fire. Such lamps were used in the time of the Prophet (PBUH). There is no such risk in electric bulbs which are being used in the present age.

162. Abu Musa (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The similitude of guidance and knowledge with which Allah has sent me is like a rain which has fallen on some ground. A fertile part of earth has absorbed water and brought forth much grass and herbs. Another part, which is solid, held the water and Allah benefits men thereby, who drank and gave others to drink, and used it for irrigation. But some of it has fallen on a portion of sandy land which neither retains the water nor produces herbage. Such is the likeness of the man who understands the religion of Allah and who gets benefit of what Allah has sent me with; he learns and teaches others. It is also the likeness of the man who neither raises his head on that account (meaning he does not benefit from what the Prophet (PBUH) was sent with) nor accepts Allah's Guidance with which I am sent".
[Al-Bukhari and Muslim].

Commentary: In this Hadith the guidance and knowledge which was sent to mankind through the Prophet (PBUH) is compared to the rain which is beneficial, because this knowledge resuscitates the dead hearts as does the rain to a barren land. One who makes use of this knowledge is likened to a good soil, and one who acquires this knowledge and imparts it to others but does not put it into practice is considered akin to a hard land which holds water and other people utilize it. A person who neither learns it nor acts upon it is like a desolate land which neither holds water nor produces anything. Such a person is the worst of all because he neither himself benefits from it nor lets others make use of it. This Hadith induces one to acquire knowledge, impart it to others, put it into actual practice and warns people from neglecting this duty.

163. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "My parable and that of yours is like a man who kindled a fire. When it has illuminated all around him, the moths and grasshoppers began to fall therein. He tried to push them away, but they overcame him and jumped into it. I am catching hold of your waists ties (to save you) from fire, but you slip away from my hands".
[Muslim].

Commentary: This Hadith mentions the extreme kindness which the Prophet (PBUH) had for the welfare of his followers. It also mentions the misfortune of those who would become the fuel of Hell for not accepting Islam in spite of the utmost affection and ardour of the Prophet (PBUH) to bring them in the fold of Islam. People who fail to accept Islam would fall in the Hell-fire in the same way moths fall in the fire.

164. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) commanded the licking of fingers (after eating) and the cleaning of the dish, saying: "You do not know in what portion the Blessing (of Allah) lies".
[Muslim].

In another narration, Jabir said: Messenger of Allah (PBUH) said, "When a morsel of any of you falls down, you should pick it up and remove any dirt or dust on it and then eat it; and don't leave it for Satan; and do not wipe your hand with the towel until you have licked your fingers, for you do not know in what portion of the food the Barakah* (of Allah) lies".

* Barakah is the abundance of goodness and its continuity.

Commentary: This Hadith enjoins Muslims to lick their fingers after meals, wipe off the food left in the utensils and eat morsels which fall down in the course of eating. All these things have many advantages:

1. May be that is the blessed portion of the food which sticks to the fingers or utensils.

2. This practice is a sign of humility and aversion from the style of proud and haughty people.

3. It saves one from being ungrateful to Allah.

4. By these means one defeats Satan.

In the light of these Islamic injunctions one can very well judge violation of Islamic teachings and ungratefulness to Allah which is evident from the large quantity of food which is thrown on the garbage.

165. Ibn `Abbas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection you will be assembled barefooted, naked and uncircumcised". He then recited: "As We began the first creation, We shall repeat it. (It is) a promise binding upon Us. Truly, We shall do it,'' and continued: "The first to be clothed on the Day of Resurrection will be (Prophet) Ibrahim. Then some of my Companions will be taken to the left, (i.e., towards Hell-fire) and when I will say, 'They belong to my Ummah, O my Rubb!' It would be said: 'You do not know what they invented after you had left them.' I shall then say as the righteous slave [i.e., `Isa (Jesus (PBUH)] said: 'And I was a witness over them while I was amongst them, when You took me up, You were the Watcher over them and You are a Witness to all things. If you punish them, they are Your slaves, and if You forgive them, verily, You, only You are the All-Mighty, the All-Wise.' I shall be told: 'They continued to turn on their heels since you parted from them".
[Al-Bukhari and Muslim].

Commentary:

1. We learn from this Hadith that the punishment of apostasy is Hell. For this reason, this crime is punishable by death in Islam.

2. We also learn from this Hadith that the Prophet (PBUH) had neither knowledge of the Unseen nor is he omnipresent and omniscient, as is falsely believed by deviated people. If he had the knowledge of the Unseen, or had he been omnipresent and omniscient, he would not have accepted such persons as his Companions and followers who were in fact apostates. This is the reason when he was informed of their real conduct through Wahy (Revelation), he disowned them in the same way as Prophet `Isa (Jesus) had disowned the people who had started worshipping him and his mother as God.

166. `Abdullah bin Mughaffal (May Allah be pleased with him) reported: Messenger of Allah (PBUH) prohibited flicking pebbles by the index finger and the thumb; and he said, "It does not kill a game animal nor does it inflict wound on the enemy, but breaks the tooth and gorges the eye".
[Al-Bukhari and Muslim].

In another narration it is said: A close relative of `Abdullah bin Mughaffal (May Allah be pleased with him) was hitting with pebbles using the index finger and the thumb; he said: "Messenger of Allah (PBUH) has forbidden it saying that it does not kill the game". He repeated the act and Ibn Mughaffal said to him: "I told you that the Prophet (PBUH) had prohibited it but you repeated it. I shall never talk to you.''

Commentary:
1. This Hadith exhorts us not to do anything which is likely to harm others.

2. It also tells us that it is permissible to sever connections and speech with the people who disobey the Injunctions of Allah and His Prophet (PBUH).

167. `Abis bin Rabi`ah (May Allah be pleased with him) reported: I saw `Umar bin Al-Khattab(May Allah be pleased with him) kissing the Black Stone (Al-Hajar Al-Aswad) and saying: "I know that you are just a stone and that you can neither do any harm nor give benefit. Had I not seen Messenger of Allah (PBUH) kissing you, I would not have kissed you".
[Al-Bukhari and Muslim].

Commentary:
1. The statement of `Umar (May Allah be pleased with him) quoted in this Hadith is highly significant in the sense that he wanted to make it absolutely clear to the illiterate and ignorant that Al-Hajar Al-Aswad (Black Stone of the Ka`bah) is not kissed for because stones are venerated in Islam, as was the practice in pre-Islamic period. What he wanted to emphasize was that kissing the Black Stone was in accordance with the Sunnah of the Prophet (PBUH).

2. Obedience of the Prophet (PBUH) in every affair is a must, whether one understands the wisdom behind it or not. By analogy, kissing of the Black Stone, some people think it is permissible to kiss and show respect to the tombs of saints. But this is not valid reason because kissing the Black Stone is an `Ibadah (act of worship), or a part of it, and every `Ibadah is Tauqifiyah (prescribed by Allah and the Prophet (PBUH)) and it can neither be increased nor diminished, nor can it be graded as something else.


Obedience to the command of Allah is an obligatory duty

Chapter 17
Obedience to the command of Allah is an obligatory duty

Allah, the Exalted, says:

"But no, by your Rubb, they can have no Faith, until they make you (O Muhammad (PBUH)) judge in all disputes between them, and find in themselves no resistance against your decisions, and accept (them) with full submission.'' (4:65)

"The only saying of the faithful believers, when they are called to Allah (His Words, the Qur'an) and His Messenger (PBUH), to judge between them, is that they say: `We hear and we obey.' And such are the successful (who will live forever in Jannah).'' (24:51)

168. Abu Hurairah (May Allah be pleased with him) reported: When it was revealed to Messenger of Allah (PBUH): "To Allah belongs all that is in the heavens and all that is on the earth, and whether you disclose what is in your own selves or conceal it, Allah will call you to account for it,'' the Companions of Messenger of Allah (PBUH) felt it hard and severe and they came to Messenger of Allah (PBUH) and sat down on their knees and said: "O Messenger of Allah, we were assigned some duties which were within our power to perform, such as Salat (prayer), Saum (fasting), Jihad (striving in the Cause of Allah), Sadaqah (charity). Then this (the above mentioned) Verse was revealed to you and it is beyond our power to live up to it.'' Messenger of Allah (PBUH) said, "Do you want to say what the people of two Books (Jews and Christians) said before you: 'We hear and disobey?' You should rather say: 'We hear and we obey, we seek forgiveness, our Rubb and unto You is the return.''' And they said: "We hear and we obey, (we seek) Your forgiveness, our Rubb! And unto You is the return.'' When the people recited it and it smoothly flowed on their tongues, then Allah revealed immediately afterwards: "The Messenger (Muhammad (PBUH)) believes in what has been sent down to him from his Rubb, and (so do) the believers. Each one believes in Allah, His Angels, His Books, and His Messengers. (They say), 'We make no distinction between one another of His Messengers' - and they say, 'We hear, and we obey. (We seek) Your forgiveness, our Rubb, and to You is the return (of all)". When they did that, Allah abrogated this (Ayah) and Allah the Great revealed: "Allah burdens not a person beyond his scope. He gets reward for that (good) which he has earned, and he is punished for that (evil) which he has earned.'' (The Prophet (PBUH) said): "Yes. 'Our Rubb! Lay not on us a burden like that which You did lay on those before us (Jews and Christians)". (The Prophet (PBUH) said): "Yes. 'Our Rubb! Put not on us a burden greater than we have strength to bear". (The Prophet (PBUH) said): "Yes. 'Pardon us and grant us forgiveness. Have mercy on us. You are our Maula (Patron, Supporter and Protector) and give us victory over the disbelieving people".

He (the Prophet (PBUH)) said: "Yes".
[Muslim].

Commentary: We learn from this Hadith that initially every person was answerable for thoughts and doubts even those which crossed his mind; something on which nobody had any control. The Companions of the Prophet (PBUH) were naturally disturbed on this situation. But when they heard and obeyed the orders of the Prophet (PBUH) then Almighty Allah revoked this order with the elaboration that He does not put anyone to trouble beyond his capacity. It is, therefore, essential for every Muslim to obey all the Injunctions of Allah because none of it is such that he is unable to carry out.


Prohibition of heresies in religion

Chapter 18
Prohibition of heresies in religion

Allah, the Exalted, says:

"So after the truth, what else can there be, save error?''. (10:32)

"We have neglected nothing in the Book". (6:38)

"(And) if you differ in anything amongst yourselves, refer it to Allah and His Messenger (PBUH)". (4:59)

"And verily, this is My straight path, so follow it, and follow not (other) paths, for they will separate you away from His path". (6:153)

"Say (O Muhammad (PBUH) to mankind): 'If you (really) love Allah then follow me (i.e., accept Islamic Monotheism, follow the Qur'an and the Sunnah), Allah will love you and forgive you your sins". (3:31)

169. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "If anyone introduces in our matter something which does not belong to it, will be rejected".
[Al-Bukhari and Muslim].

The narration in Muslim says: "If anybody introduces a practice which is not authenticated by me, it is to be rejected".

Commentary: This Hadith lays down a very important principle. Unfortunately, Muslims have not attached any importance to this Hadith and the principle given in it with the result that innovations in the Deen have become so common that they have been taken for true Deen; our people act upon them and are made to practice them. One reason for this is their lack of education and ignorance about Deen. The second reason is their lack of understanding of the principle prescribed in this Hadith although it is stated in very explicit terms.

The principle that we learn from this Hadith is that every such action or activity is innovation which is done as a virtue and to gain the Pleasure of Allah but is not consonant with the teachings of the Qur'an and Sunnah, or which does not agree with the interpretation of the Nuss (text) given by the Companions of the Prophet (PBUH) or their successors (Tabi`un). The reason being that the period of the Companions and the Tabi`un is the Khair-ul-Qurun (the best of all generations). Thus any action or activity that is deprived of the support of these generations falls in the category of heresies.

170. Jabir (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) delivered a Khutbah, his eyes would become red, his tone loud and he showed anger as if he were warning us against an army. He (PBUH) would say, "The enemy is about to attack you in the morning and the enemy is advancing against you in the evening". He would further say, "I am sent with the final Hour like these two fingers of mine.'' Messenger of Allah (PBUH) held up his index finger and the middle finger together to illustrate. He used to add: "To proceed, the best speech is the Book of Allah and the best guidance is the guidance of Muhammad (PBUH), the worst practice is the introduction of new practices in Islam and every Bid`ah is a misguidance". He would also say, "I am, in respect of rights, nearer to every believer than his own self. He who leaves an estate, it belongs to his heirs, and he who leaves a debt, it is my responsibility to pay it off.'' [Muslim]. Same Hadith as reported by `Irbad bin Sariyah (May Allah be pleased with him) has already been recorded in the previous chapter regarding safeguarding the Sunnah of the Prophet (PBUH).
(See Hadith number 158)

Commentary:
1. This Hadith mentions the style of the speech of the Prophet (PBUH). His auspicious presence is regarded in it as a sign of the nearness of the Day of Resurrection.

2. It emphasizes the importance of the Qur'an and the Sunnah and brings into focus the destruction caused by Bid`ah in Deen.

3. It clearly lays down that the orphans and the needy are the liability of the government/Bait-ul-Mal (public exchequer). The reason being that the caliphs were the successors of the Prophet (PBUH) and the work which was done by him in his lifetime was after him their responsibility.

4. The rightful owners of the deceased are their heirs and none else.


Heretics doing desirable or undesirable deeds

Chapter 19
Heretics doing desirable or undesirable deeds

Allah, the Exalted, says:

"And those who say: `Our Rubb! Bestow on us from our wives and our offspring the comfort of our eyes, and make us leaders of the Muttaqun (the pious)". (25:74)

"And We made them leaders, guiding (mankind) by Our Command". (21:73)

171. Jarir bin `Abdullah (May Allah be pleased with him) reported: We were with Messenger of Allah (PBUH) shortly after dawn when there came to him some people clad in woollen rags, or covered with sleeveless blankets; and with swords hanging down from their necks. Most of them rather, all of them, belonged to the Mudar tribe. The face of the Prophet (PBUH) changed when he saw them starving. Then he went into his house and came out; then he commanded Bilal (May Allah be pleased with him) to proclaim Adhan (call to prayers). So he proclaimed Adhan and recited Iqamah and the Prophet (PBUH) led the Salat. Then he delivered a Khutbah saying, "O mankind! Be dutiful to your Rubb, Who created you from a single person (Adam), and from him (Adam) He created his wife (Eve), and from them both He created many men and women; and fear Allah through Whom you demand your (natural) rights, and do not sever the relations of kinship. Surely, Allah is Ever an All-Watcher over you.'' (4:1) He also recited the Ayah which is in the end of Surat Al-Hashr: "O you who believe! Fear Allah and keep your duty to Him. And let every one look what he has sent forth for the tomorrow". (59:18). Thereafter, every man gave in charity Dinar, Dirham, clothes, measure-fulls of wheat and measure-fulls of dates till he said: "(Give in charity) be it half a date". Then a man of the Ansar came with a bag which was difficult for him to hold in his hand. Thereafter, the people came successively (with charity) till I saw two heaps of food and clothes. I noticed that the face of Messenger of Allah (PBUH) was glowing like that of the bright moon or glittering gold. Then he (PBUH) said, "Whosoever introduces a good practice in Islam, there is for him its reward and the reward of those who act upon it after him without anything being diminished from their rewards. And whosoever introduces an evil practice in Islam, will shoulder its sin and the sins of all those who will act upon it, without diminishing in any way their burden"
[Muslim].

Commentary:
1. Some people try to deduce a proof for good innovations from the words: "Mun sana' fi Al- islam sunah hasanah". Whosoever introduces a good practice in Islam.

Thus they classify innovations Bid`ah into two categories, namely good innovations and bad innovations. But this is wrong. No innovation can be good. It is always bad because it amounts to inventing Shar`iah which no one has the right to do. Constitution of Shar`iah is the exclusive Right of Allah Alone. It is He who constitutes the Shar`iah and it is on His behest that His Prophets convey it to the people. Not to speak of scholars and others.

2. What this Hadith makes abundantly clear is that anyone who tries to find new ways and means to preach and practice Islamic Shar`iah, which are later on adopted by other people also, would not only get the reward of doing so but he will also be rewarded for the endeavours of those who will after him continue them and perform good deeds. But anything of which we do not find any trace in Shar`iah is bad. It cannot be good in any case, no matter what means are adopted for this purpose.

3. Other benefits of this Hadith are self-evident and do not need further elaboration.

172. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The first son of Adam* takes a share of the guilt of every one who murders another wrongfully because he was the initiator of committing murder".
[Al-Bukhari and Muslim].

* The son of Adam in the Hadith is said to be Qabil. Allah tells us about his story in Surat Al-Ma'idah (The Table spread with Food). Verses 27-31.

Commentary: This Hadith gives us an idea how serious is the crime of initiating an evil which is followed by others. One who initiates an evil would be sinful for all those who follow him in that crime till the Day of Resurrection. The safest course, therefore, is that one should abstain from heresy and stick to obedience only.


Calling to right guidance and forbidding depravity

Chapter 20
Calling to right guidance and forbidding depravity

Allah, the Exalted, says:

"And invite (men) to (believe in) your Rubb [i.e., in the Oneness (Tauhid) of Allah - (1) Oneness of the Rububiyah of Allah; (2) Oneness of the worship of Allah; (3) Oneness of the Name and Qualities of Allah]. (28:87)

"Invite (mankind, O Muhammad (PBUH)) to the way of your Rubb (i.e., Islam) with wisdom (i.e., with the Divine Revelation and the Qur'an and fair preaching)".(16:125)

"Help you one another in Al-Birr and At-Taqwa (virtue, righteousness and piety)". (5:2)

"Let there arise out of you a group of people inviting to all that is good (Islam).'' (3:104)

173. Abu Mas`ud `Uqbah bin `Amr Al-Ansari Al-Badri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whoever guides someone to virtue will be rewarded equivalent to him who practices that good action".
[Muslim].

Commentary: The statement quoted in this Hadith was made by the Prophet (PBUH) when, on a certain occasion, someone requested him to give an animal for riding. The Prophet (PBUH) replied that he did not have any. A man who was present there said that he could show him the man who could help him in the matter. This is how the Prophet (PBUH) revealed the reward of directing people to good deeds, which is mentioned in this Hadith.

174. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "If anyone calls others to follow right guidance, his reward will be equivalent to those who follow him (in righteousness) without their reward being diminished in any respect, and if anyone invites others to follow error, the sin, will be equivalent to that of the people who follow him (in sinfulness) without their sins being diminished in any respect".
[Muslim].

Commentary: `Invitation' and `Call' stand to mean here that someone induces others to virtue or seduces to sin by means of his speech or action. We come to know from this Hadith that one who becomes a medium for either of them is given a reward or punishment respectively by Allah (SWT).

175. Sahl bin Sa`d (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said on the day of the Khaibar Battle, "I will give this banner to a person at whose hands Allah will grant victory; a man who loves Allah and His Messenger (PBUH), and Allah and His Messenger love him also.'' The people spent the night thinking as to whom it would be given. When it was morning, the people hastened to Messenger of Allah (PBUH). Every one of them was hoping that the banner would be given to him. He (the Prophet (PBUH)) asked, "Where is `Ali bin Abu Talib?'' They said: "O Messenger of Allah! His eyes are sore.'' He (PBUH) then sent for him and when he came, Messenger of Allah (PBUH) applied his saliva to his eyes and supplicated. `Ali (May Allah be pleased with him) recovered as if he had no ailment at all. He (PBUH) conferred upon him the banner. `Ali (May Allah be pleased with him) said: ``O Messenger of Allah, shall I fight against them until they are like us?'' Thereupon he (the Prophet (PBUH)) said, "Advance cautiously until you reach their open places; thereafter, invite them to Islam and inform them what is obligatory for them from the Rights of Allah, for, by Allah, if Allah guides even one person through you that is better for you than possessing a whole lot of red camels".
[Al-Bukhari and Muslim].

Commentary: Besides mentioning the excellence of `Ali (May Allah be pleased with him) and the miracle of the Prophet (PBUH), this Hadith tells about the procedure of Jihad. According to procedure, first of all, polytheists and infidels should be invited to Islam, and if they reject the invitation, then Jihad be made against them. Jihad is such an action that if at its initial stage, that is to say at the stage of invitation, some people accept the guidance, then the people who will participate in Jihad will get the reward of good deeds done by those who would join the fold of Islam.

176. Anas bin Malik (May Allah be pleased with him) reported: A young man from the tribe of Aslam said, "O Messenger of Allah (PBUH), I wish to fight (in the Cause of Allah) but I do not have anything to equip myself with (for fighting)". He (the Prophet (PBUH)) said, "Go to so-and-so, for he had equipped himself (for fighting) but he fell ill.'' So he (the young man) went to him and said, "Messenger of Allah (PBUH) sends you his greetings and says that you should give me the equipment that you have provided yourself with.'' The man said (to his wife or servant): "O so-and-so, give him the equipment I have collected for myself and do not withhold anything from him. By Allah, if you withhold anything from him, we will not be blessed therein".
[Muslim].

Commentary:
1. We learn from this Hadith that if a person has made preparations for doing some good deed but he is unable to do it due to illness or some other genuine reason, and he gives the material to be used for that purpose to someone else then he will also be equally eligible to the reward of that good deed.

2. Rather than spending wealth in the way of Allah, those who withhold it, displease Allah, and their wealth becomes deprived of His Blessing.


Assistance towards righteousness and piety

Chapter 21
Assistance towards righteousness and piety

Allah, the Exalted, says:

"Help you one another in Al-Birr and At-Taqwa (virtue, righteousness and piety)". (5:2)

"By Al-`Asr (the time). Verily, man is in loss. Except those who believe (in Islamic Monotheism) and do righteous good deeds, and recommend one another to the truth [i.e. order one another to perform all kinds of good deeds (Al-Ma`ruf) which Allah has ordained, and abstain from all kinds of sins and evil deeds (Al-Munkar) which Allah has forbidden], and recommend one another to patience (for the sufferings, harms, and injuries which one may encounter in Allah's Cause during preaching His religion of Islamic Monotheism or Jihad)". (103:1-3)

177. Khalid Al-Juhani (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who equips a warrior in the way of Allah (will get the reward of the one who has actually gone for Jihad); and he who looks after the family of a warrior in the way of Allah will get the reward of the one who has gone for Jihad".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells the mode which can make Jihad more effective and give the participants of Jihad equal share in its reward. Every society has many able-bodied young people who want to take part in Jihad but do not have the resources for it, and this is how a very useful segment of the society fails to make any contribution to it. On the other hand, there are people in the society who have plenty of resources but do not possess health, vigour and youth which are essential for Jihad. According to the method prescribed in this Hadith, not only the requisite manpower and resources essential for Jihad are combined but everyone gets an even share in its reward. It should be kept in mind that in the early period of Islam, Mujahidun (the Muslims who took part in Jihad) were neither professional soldiers nor were they paid regular salaries, the way they now constitute a regular, permanent and vast military institution. These Mujahidun used to take part in Jihad voluntarily as is being done nowadays under many organizations also.

178. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) sent a detachment to Banu Lahyan tribe and remarked, "Let one of every two men get ready to advance, and both will earn the same reward".
[Muslim].

179. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) came across a party of mounted men at Ar-Rauha and asked them, "Who are you?'' They answered: "We are Muslims, and who are you?'' He said, "I am the Messenger of Allah.'' A woman from among them lifted a boy up to him and asked: "Can this one go on Hajj?'' He (PBUH) said, "Yes, and you will have the reward.''
[Muslim].

Commentary:
1. We learn from this Hadith that in the matter of dress, style and appearance, the Prophet (PBUH) was so simple that ordinary people could not easily recognize him as a Prophet.

2. If a child is taken with his parents for Hajj, its reward will be given to his parents because at that age Hajj is not obligatory on him. After gaining maturity, if the child has the means to go for Hajj, then he is duty-bound to perform it. The Hajj performed by him in childhood is considered as Nafl only.

180. Abu Musa (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The honest Muslim trustee who carries out duties assigned to him (in another narration he said, "Who gives''), and he gives that in full, with his heart overflowing with cheerfulness, to whom he is ordered, he is one of the two givers of charity".
[Al-Bukhari and Muslim].

Commentary: This Hadith also mentions a very important principle to the effect that everyone must wholeheartedly perform the duty assigned to him by the state. If he is appointed custodian of the Bait-ul-Mal (public exchequer), he must fulfill his duty with utmost honesty. If he is not envious of anyone, nor harms anybody, nor behaves niggardly then he will be entitled to the same reward which will be due to the person who entrusted him that duty. Thus this Hadith enjoins every Muslim to perform his official duties wholeheartedly and to the best of his ability.


Giving Counsel

Chapter 22
Giving Counsel

Allah, the Exalted, says:

"The believers are nothing else than brothers (in Islamic religion)". (49:10)

"(Nuh said) I give sincere advice to you". (7:62)

"(And Hud said) And I am a trustworthy adviser (or well-wisher) for you". (7:68)

181. Tamim bin Aus Ad-Dari (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Ad-Deen is sincerity". We said: "For whom?'' He replied, "For Allah, His Book, His Messenger and for the leaders of the Muslims and their masses".
[Muslim].

Commentary: This Hadith stresses the importance and merits of general sincerity. Sincerity for Allah here means that one must have true faith in Him and He should be worshipped with full devotion and sincerity. Sincerity for the Qur'an means that one should confirm its truth with one's full heart and mind, recite it regularly, act upon the injunctions contained in it with meticulous care and strictly avoid its misinterpretation. Sincerity of the Prophet (PBUH) means sincere confirmation of his Prophethood, faithful obedience of his orders and adherence to his Sunnah. The goodwill of the Muslim rulers stands here for co-operating with them in their lawful orders and obedience of their such orders which are free from any trace of sin. If they deviate from the Straight Path they should be persuaded to turn to virtue. One should not revolt against them unless they commit infidelity. The goodwill of the Muslim masses means that one should work for the betterment of their life in this world and the Hereafter. They should be provided the right guidance, induced to perform good deeds and deterred from evils.

182. Jarir bin `Abdullah (May Allah be pleased with him) reported: I made my covenant with Messenger of Allah (PBUH) on the observance of Salat, payment of Zakat, and giving counsel to Muslim.''
[Al-Bukhari and Muslim].

Commentary: This Hadith emphasizes the importance of goodwill to all the Muslims to the extent that the Prophet (PBUH) would require his Companions to vow for their goodwill giving counsel to each other in the same way as he did in the case of most important obligations like Salat and Zakat.

183. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "No one of you becomes a true believer until he likes for his brother what he likes for himself".
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith about the importance and virtue of mutual love among the Muslims. If we act upon the injunctions mentioned in this Hadith, the Muslim societies will be immediately purged of the evils like exploitation, bribery, dishonesty, falsehood, cheating, forgery, etc., which are rampant in them at present. Islam has taught golden principles to its followers who have unfortunately neglected them and in consequence are leading a life of utter disgrace and moral turpitude. May Allah guide them to the Straight Path.


Enjoining Good and forbidding Evil

Chapter 23
Enjoining Good and forbidding Evil

Allah, the Exalted, says:

"Let there arise out of you a group of people inviting to all that is good (Islam), enjoining Al-Ma`ruf (i.e., Islamic Monotheism and all that Islam orders one to do) and forbidding Al-Munkar (polytheism and disbelief and all that Islam has forbidden). And it is they who are the successful.'' (3:104)

"You (true believers in Islamic Monotheism, and real followers of Prophet Muhammad (PBUH) and his Sunnah) are the best of peoples ever raised up for mankind; you enjoin Al-Ma`ruf (i.e., Islamic Monotheism and all that Islam has ordained) and forbid Al-Munkar (polytheism, disbelief and all that Islam has forbidden)''. (3:110)

"Show forgiveness, enjoin what is good, and turn away from the foolish (i.e., don't punish them).'' (7:199)

"The believers, men and women, are Auliya' (helpers, supporters, friends, protectors) of one another; they enjoin (on the people) Al-Ma`ruf (i.e., Islamic Monotheism and all that Islam orders one to do), and forbid (people) from Al-Munkar (i.e., polytheism and disbelief of all kinds, and all that Islam has forbidden)''. (9:71)

"Those among the Children of Israel who disbelieved were cursed by the tongue of Dawud (David) and `Isa (Jesus), son of Maryam (Mary). That was because they disobeyed (Allah and the Messengers) and were ever transgressing beyond bounds. They used not to forbid one another from the Munkar (wrong, evildoing, sins, polytheism, disbelief) which they committed. Vile indeed was what they used to do". (5:78,79)

"And say: `The truth is from your Rubb.' Then whosoever wills, let him believe; and whosoever wills, let him disbelieve". (18:29)

"Therefore proclaim openly (Allah's Message - Islamic Monotheism) that which you are commanded...'' (15:94)

"We rescued those who forbade evil, but with a severe torment. We seized those who did wrong because they used to rebel against Allah's Command (disobey Allah)". (7:165)

184. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whoever amongst you sees an evil, he must change it with his hand; if he is unable to do so, then with his tongue; and if he is unable to do so, then with his heart; and that is the weakest form of Faith".
[Muslim].

Commentary: This Hadith contains a very important prescription to prevent the Muslim society from all things which are forbidden in Islam. So long as Muslims adhered to it and ceaselessly and fearlessly performed their obligation of enjoining the right and forbidding the wrong, their society was largely safe from many evils and sins.

185. Abdullah bin Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Never a Prophet had been sent before me by Allah to his people but he had, among his people, (his) disciples and companions, who followed his ways and obeyed his command. Then there came after them their successors who proclaimed what they did not practise, and practised what they were not commanded to do. And (he) who strove against them with his hand is a believer; he who strove against them with his heart is a believer; and he who strove against them with his tongue is a believer ; and beyond that there is no grain of Faith".
[Muslim].

186. `Ubadah bin As-Samit (May Allah be pleased with him) reported: We swore allegiance to Messenger of Allah (PBUH) to hear and obey; in time of difficulty and in prosperity, in hardship and in ease, to endure being discriminated against and not to dispute about rule with those in power, except in case of evident infidelity regarding which there is a proof from Allah. We swore allegiance to Messenger of Allah (PBUH) to say what was right wherever we were, and not to fear from anyone's reproach.
[Al-Bukhari and Muslim].

Commentary: It has been emphasized in this Hadith that even if a Muslim ruler is sinful and cruel, one should not disobey him unless he orders to go against the Divine injunctions. In that case, such rulers should not be obeyed. Similarly, it is not permissible to revolt against them until they commit clear-cut infidelity because there is a greater danger of loss in revolt and rebellion. It should be noted once and for all that the expression of truth and compliance with religious injunctions have top priority on all occasions. This should be done regardless of what people say on this account.

187. Nu`man bin Bashir (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The likeness of the man who observes the limits prescribed by Allah and that of the man who transgresses them is like the people who get on board a ship after casting lots. Some of them are in its lower deck and some of them in its upper (deck). Those who are in its lower (deck), when they require water, go to the occupants of the upper deck, and say to them : `If we make a hole in the bottom of the ship, we shall not harm you.' If they (the occupants of the upper deck) leave them to carry out their design they all will be drowned. But if they do not let them go ahead (with their plan), all of them will remain safe".
[Al-Bukhari].

Commentary: We learn from this Hadith that the consequences of committing acts which are forbidden in Islam are not confined only to those persons who commit them, but the whole society has to suffer for them. It is, therefore, essential that the people who are in the habit of committing sinful acts and violate Divine injunctions, should be checked to save the whole society from destruction. If this is not done, the entire society will have to face the Divine punishment.

188. Umm Salamah (May Allah be pleased with her) reported: The Prophet (PBUH) said, "You will have rulers some of whom you approve and some of whom you will disapprove. He who dislikes them will be safe, and he who expresses disapproval will be safe, but he who is pleased and follows them (will be indeed sinful)". His audience asked: "Shall we not fight them?'' He replied, "No, as long as they establish Salat amongst you".
[Muslim].

Commentary:
1. By qualifying the obedience of Muslim rulers with Salat, it has been made clear that what actually distinguishes between Kufr and Islam is Salat.

2. If a person has the power to stop the rulers from committing evil deeds, he must use this power for it. If he is incapable of it, he should at least condemn their evil deeds in his heart. To join or acquiesce in the evil deeds of the rulers is an extremely dangerous trend. From this angle, participation in political parties is a dangerous affair because when these parties come into power, all their members have to endorse and pursue their good as well as bad policies.

189. Zainab (May Allah be pleased with her) reported: The Prophet (PBUH) came to visit me one day frightened and he ü said, "La ilaha illallah (There is no true God but Allah). Woe to the Arabs because of an evil which has drawn near! Today an opening of this size has been made in the barrier restraining Ya'juj and Ma'juj (Gog and Magog people).'' And he (PBUH) made a circle with his thumb and index finger. I said, ``O Messenger of Allah! Shall we perish while still there will be righteous people among us?'' He (PBUH) replied, ``Yes, when wickedness prevails".
[Al-Bukhari and Muslim].

Commentary: This Hadith also tells us about the ominous of sin. It says that when vice becomes common, then in spite of the presence of some virtuous persons, that community will be destroyed. But on the Day of Resurrection, those noble persons who had done their duty of preaching virtue and checking vice will stand apart from the sinners. Thus this Hadith induces one to keep away from sins.

190. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Beware of sitting on roads (ways).'' The people said: "We have but them as sitting places.'' Messenger of Allah (PBUH) said, "If you have to sit there, then observe the rights of the way". They asked, "What are the rights of the way?'' He (PBUH) said, "To lower your gaze (on seeing what is illegal to look at), and (removal of harmful objects), returning greetings, enjoining good and forbidding wrong".
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith tells us that it is improper to sit on roadsides and passages in such a way which causes inconvenience to men and women who pass by. It is really very unfortunate that now we do not care about such things at all.

2. If sitting on roadside is indispensable at all, then it is essential to observe the requirements mentioned in the Hadith to justify the needful.

3. Some other Islamic etiquette mentioned in this Hadith have also been stated in other Ahadith. For instance, politeness of speech, sharing of someone's burden, helping the oppressed and the troubled, guiding the wayward person to the right path, answering (in the prescribed manner) one who sneezes, etc.

191. `Abdullah bin `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) saw a man wearing a gold ring. So he (the Prophet (PBUH)) pulled it off and threw it away, saying, "One of you takes a live coal, and puts it on his hand.'' It was said to the man after Messenger of Allah (PBUH) had left: "Take your ring (of gold) and utilize it,'' whereupon he said: "No, by Allah, I would never take it when Messenger of Allah (PBUH) has thrown it away".
[Muslim].

Commentary:
1. We learn from this Hadith that wearing of gold ring is prohibited for men and so is wearing of golden ornament by them. It is very unfortunate indeed that nowadays it has become a popular fashion to present men gold ring on their marriage and they wear it with great pride. It is a very dangerous custom and must be altogether shunned for two reasons. Firstly, it is an unnecessary formality and burden to exchange presents and hold big feasts on betrothal ceremony. It is also open to objection in Islamic law. Secondly, to give and take unlawful things is all the more forbidden and is akin to building one sin over another.

2. The spirit of obedience mentioned in this Hadith is matchless.

192. Abu Sa`id Al-Hasan Basri reported: `Aidh bin `Amr (the Companion) (May Allah be pleased with him) visited `Ubaidullah bin Ziyad (the ruler) and said to him: "Son, I heard Messenger of Allah (PBUH) saying, `The worst shepherds (rulers) are those who deal harshly in respect of supervision. Beware, Don't be one of them!''' Ibn Ziyad said to him, "Sit down, you are but husk from among the Companions of the Prophet (PBUH).'' `Aidh bin `Amr (May Allah be pleased with him) retorted: "Was there any husk among them? Surely, husk came after them and among others than them".
[Muslim].

Commentary: This Hadith presents a model of courage and boldness of speaking the truth before a tyrant. It was displayed by `Aidh (May Allah be pleased with him) in the court of Ubaidullah bin Ziyad, governor of Basrah. The latter humiliated `Aidh (May Allah be pleased with him) for his straight forwardness and truth but he repeated his statement about the eminence of the Companions of the Prophet ü and said none of them could be called husk.

193. Hudhaifah (May Allah bepleased with him) reported: The Prophet (PBUH) said, "By Him in Whose Hand my life is, you either enjoin good and forbid evil, or Allah will certainly soon send His punishment to you. Then you will make supplication and it will not be accepted".
[At-Tirmidhi].

Commentary: To abandon the practice of enjoining virtue and forbidding vice is likely to incur the displeasure of Allah. This trend is indeed fraught with the danger of rejection of prayers and supplications by Him.

194. Abu Sa`id Al-Khudri (May Allah bepleased with him) reported: The Prophet (PBUH) said, "The best type of Jihad (striving in the way of Allah) is speaking a true word in the presence of a tyrant ruler.''
[Abu Dawud and At-Tirmidhi].

Commentary: Jihad has many degrees. Preaching of virtue is also Jihad. The most meritorious of all is the effort of communicating the Message of Allah to an unjust ruler. Similarly, if a society is so much given to a vice that no one can dare to utter a word against it, then to protest against it can also be reckoned as the best Jihad.

195. Abu `Abdullah Tariq bin Shihab (May Allah bepleased with him) reported: A person asked the Prophet (PBUH) (when he had just put his foot in the stirrup): "What is the highest form of Jihad?'' He (PBUH) said, "Speaking the truth in the presence of a tyrant ruler".
[An-Nasa'i].

196. `Abdullah bin Mas`ud (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "The first defect (in religion) which affected the Children of Israel in the way that man would meet another and say to him: `Fear Allah and abstain from what you are doing, for this is not lawful for you.' Then he would meet him the next day and find no change in him, but this would not prevent him from eating with him, drinking with him and sitting in his assemblies. When it came to this, Allah led their hearts into evil ways on account of their association with others.'' Then he (PBUH) recited, "Those among the Children of Israel who disbelieved were cursed by the tongue of Dawud (David) and `Isa (Jesus), son of Maryam (Mary). That was because they disobeyed (Allah and the Messengers) and were ever transgressing beyond bounds. They used not to forbid one another from the Munkar (wrong, evildoing, sins, polytheism, disbelief) which they committed. Vile indeed was what they used to do. You see many of them taking the disbelievers as their Auliya' (protectors and helpers). Evil indeed is that which their own selves have sent forward before them; for that (reason) Allah's wrath fell upon them and in torment will they abide. And had they believed in Allah and in the Prophet (Muhammad (PBUH)) and in what has been revealed to him, never would they have taken them (the disbelievers) as Auliya' (protectors and helpers); but many of them are the Fasiqun (rebellious, disobedient to Allah).'' (5:78-81)

Then he (PBUH) continued: "Nay, by Allah, you either enjoin good and forbid evil and catch hold of the hand of the oppressor and persuade him to act justly and stick to the truth, or, Allah will involve the hearts of some of you with the hearts of others and will curse you as He had cursed them".
[Abu Dawud and At-Tirmidhi].

The wording in At-Tirmidhi is: Messenger of Allah (PBUH) said, "When the Children of Israel became sinful, their learned men prohibited them but they would not turn back. Yet, the learned men associated with them and ate and drank with them. So, they were cursed at the tongues of Dawud and `Isa (Jesus), son of Maryam (Mary), because they were disobedient and were given to transgression.'' At this stage Messenger of Allah (PBUH) who was reclining on a pillow sat up and said, "No, By Him in Whose Hand my soul is, there is no escape for you but you persuade them to act justly.''

Commentary: This Hadith tells us that the duty of `Ulama' is to check the people from vice and if, in spite of all their efforts people do not abandon them, they should avoid associating with them because it is a matter of religious reverence and vanity. If they do not do it, they will also be cursed like the disobedient lot. May Allah save us from this negligence.

197. Abu Bakr As-Siddiq (May Allah bepleased with him) reported: "O you people! You recite this Verse: `O you who believe! Take care of your ownselves. If you follow the (right) guidance [and enjoin what is right (Islamic Monotheism and all that Islam orders one to do) and forbid what is wrong (polytheism, disbelief and all that Islam has forbidden)] no hurt can come to you from those who are in error.' (5:105) But I have heard Messenger of Allah (PBUH) saying: "When people see an oppressor but do not prevent him from (doing evil), it is likely that Allah will punish them all.''
[Abu Dawud and At-Tirmidhi].

Commentary: What Abu Bakr As-Siddiq (May Allah bepleased with him) had stated was that the Ayah mentioned in this Hadith was generally understood to mean that if a person is on the Straight Path then it is not necessary for him to preach virtue and forbid vice because in that case he neither has the fear of being harmed by the disobedience and sins of others nor is he answerable to Allah for their misdeeds. Thus, what it implies is that Muslim Ummah is not responsible for the enforcement of Islamic Shari`ah in the world and all it is concerned with is its own improvement only. By narrating this Hadith, Abu Bakr As-Siddiq (May Allah bepleased with him) refuted this interpretation of the Ayah and made it clear that it is the duty of the Ummah and each of its member to make best possible efforts to check the vices prevalent in the society. So much so that if a Muslim has the ability to check the vices by means of force or speech but he does not do it, his negligence in this regard will become a cause of Divine wrath and punishment. The true significance of this ayah is that if, in spite of the best efforts on the part of the pious ones there is no improvement, and people do not abstain from sins and disobedience of Allah, then the pious persons will not be held responsible for what the defaulters do, nor would they suffer on this account. This interpretation of the ¢yah removes the conflict that seems to exist between the meaning of the Ayah and the Hadith


Chastisement for one who enjoins good and forbids evil but acts otherwise

Chapter 24
Chastisement for one who enjoins good and forbids evil but acts otherwise

Allah, the Exalted, says:

"Enjoin you Al-Birr (piety and righteousness and every act of obedience to Allah) on the people and you forget (to practise it) yourselves, while you recite the Scripture [the Taurat (Torah)]! Have you then no sense?". (2:44)

"O you who believe! Why do you say that which you do not do? Most hateful it is with Allah that you say that which you do not do". (61:2,3)

"(Shu`aib said:) I wish not, in contradiction to you, to do that which I forbid you.'' (11:88)

198. Usamah bin Zaid (May Allah bepleased with them) reported: Messenger of Allah (PBUH) said, "A man will be brought on the Day of Resurrection and will be cast into Hell, and his intestines will pour forth and he will go round them as a donkey goes round a millstone. The inmates of Hell will gather round him and say: `What has happened to you, O so-and-so? Were you not enjoining us to do good and forbidding us to do evil?' He will reply: `I was enjoining you to do good, but was not doing it myself; and I was forbidding you to do evil, but was doing it myself".
[Al-Bukhari and Muslim].

Commentary: This Hadith serves a stern warning for such `Ulama', preachers and reformers of the Ummah whose own conduct is contrary to the sermons they give from the pulpit.


Discharging the Trusts

Chapter 25
Discharging the Trusts

Allah, the Exalted, says:

"Verily! Allah commands that you should render back the trusts to those to whom they are due.'' (4:58)

"Truly, We did offer Al-Amanah (the trust or moral responsibility or honesty and all the duties which Allah has ordained) to the heavens and the earth, and the mountains, but they declined to bear it and were afraid of it (i.e., afraid of Allah's torment). But man bore it. Verily, he was unjust (to himself) and ignorant (of its results)". (33:72)

199. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "There are three signs of a hypocrite: When he speaks, he lies; when he makes a promise, he breaks it; and when he is trusted, he betrays his trust."
[Al-Bukhari and Muslim].

Another narration adds the words: 'Even if he observes fasts, performs Salat and asserts that he is a Muslim".

Commentary: A hypocrite is the one who professes Islam before the Muslims but conceals hatred and animosity against them. This double-dealing is worse than Kufr. This is the reason the Noble Qur'an has declared about them that they will be in the lowest depths of the Hell. The hypocrites referred to here lived at the time of the Prophet (PBUH) and he was informed about them through Wahy (Revelation). It is very difficult to identify the class of hypocrites in this age. It is almost impossible to know the hypocrisy of Faith. The practical hypocrisy is, however, now very common among the Muslims. It can be identified on the strength of the traits which have been stated in the Ahadith about them. These traits are very common among many of the present-day Muslims. Their conduct bears the marks of hypocrisy. This practical hypocrisy is, however, not Kufr as is the case with the hypocrisy of Faith.

200. Hudhaifah bin Al-Yaman (May Allah bepleased with him) reported: Messenger of Allah (PBUH) foretold to us two Ahadith. I have seen one (being fulfilled), and I am waiting for the other. He (PBUH) told us, "Amanah (the trust) descended in the innermost (root) of the hearts of men (that is, it was in their heart innately, by Fitrah, or pure human nature). Then the Qur'an was revealed and they learnt from the Quran and they learned from the Sunnah.'' Then the (Prophet (PBUH)) told us about the removal of Amanah. He said, "The man would have some sleep, and Amanah would be taken away from his heart leaving the impression of a faint mark. He would again sleep, and Amanah would be taken away from his heart leaving an impression of a blister, as if you rolled down an ember on your foot and it was vesicled. He would see a swelling having nothing in it.'' He (the Prophet (PBUH)) then took up a pebble and rolled it over his foot and said, "The people would enter into transactions with one another and hardly a person would be left who would return (things) entrusted to him (and there would look like an honest person) till it would be said: `In such and such tribe there is a trustworthy man.' And they would also say about a person: `How prudent he is! How handsome he is and how intelligent he is!' whereas in his heart there would be no grain of Faith.'' Hudhaifah bin Al-Yaman (May Allah bepleased with him) added: I had a time when I did not care with whom amongst you I did business, I entered into a transaction, for if he were a Muslim, his Faith would compel him to discharge his obligation to me; and if he were a Christian or a Jew, his guardian (surety) would compel him to discharge his obligation to me. But today I would not enter into a transaction except with so-and-so.
[Al-Bukh ri and Muslim].

Commentary: The word `Amanah' (trust) is a very comprehensive term which includes everything like adherence to Islamic injunctions, fairness in dealing, giving everybody his due, etc. According to this Hadith, with decline in moral values the true sense of Amanah will gradually go on diminishing and eventually a stage will come which has been elucidated in the text of this Hadith.

201. Hudhaifah and Abu Hurairah (May Allah bepleased with them) reported that they heard Messenger of Allah (PBUH) saying, "Allah will assemble mankind, and the believers will stand till Jannah will be brought near them. They will then go to Adam (PBUH) and say, `O our father, ask (Allah (SWT), that Jannah may be opened for us, but he will reply: `There was nothing that put you out of Jannah except your father's sin. I am not the one to do that, go to my son Ibrahim (Abraham), the beloved man of Allah.' Then Ibrahim (PBUH) when approached, will say: `I am not the one to do that, for I was only a friend; and that is not a lofty status but ask Musa (Moses) to whom Allah spoke.' They will then go to Musa (PBUH) but he will say: `I am not the one to do that; go to `Isa (Jesus), Allah's Word and spirit.' `Isa (PBUH) will say: `I am not the one to do that.' So they will come to me; and I will stand and be given permission. Amanah and ties of relationship will be sent forth and will stand on the sides of the Sirat (that is, the Bridge set over Hell-fire) right and left, and the first of you will pass like lightning.'' I said (that is Abu Hurairah (May Allah bepleased with him)" :I ransom you with my father and mother, what is like the movement of lightning?'' The Messenger of Allah replied, "Have you not seen how the lightning goes and returns in the twinkling of an eye? Next (group will pass) like the passing of the breeze, next like the passing of a bird, and the next with the speed of a running man, according to the quality of their deeds. (During all this time) your Prophet (PBUH) will remain standing on the Bridge saying: `O my Rubb, keep (them) safe, keep (them) safe,' till men's deeds are so weak that a man comes who will be able only to crawl. On both sides of the Bridge pronged flesh hooks, placed under command will be hung and will seize those about whom they receive command, some people being lacerated and escaping and others being thrown violently into Hell.'' Abu Hurairah added: By Him in Whose Hand Abu Hurairah's soul is, the pit of Jahannam (Hell) is seventy years in depth.
[Muslim].

Commentary: This Hadith mentions the horrors of the Day of Resurrection which are evident from the fact that even Prophets will be fearful of Allah and making supplication to Him. Prophet Muhammad (PBUH) alone will be requesting Allah for bestowing His Mercy on humans. This Hadith also describes the grace of the Prophet (PBUH) who will then intercede for all.

202. Abu Khubaib `Abdullah bin Az-Zubair (May Allah bepleased with them) reported: When Az-Zubair, got ready to fight in the battle of Al-Jamal, he called me and said: "My son, whoever is killed today will be either a wrongdoer or a wronged one. I expect that I shall be the the wronged one today. I am much worried about my debt. Do you think that anything will be left over from our property after the payment of my debt? My son, sell our property and pay off my debt.'' Az-Zubair then willed one-third of that portion to his sons; namely `Abdullah's sons. He said, "One-third of the one-third. If any property is left after the payment of debts, one-third (of the one-third of what is left is to be given to your sons.'' (Hisham, a subnarrator added: "Some of the sons of `Abdullah were equal in age to the sons of Az-Zubair, e.g., Khubaib and Abbad. `Abdullah had nine sons and nine daughters at that time)". (The narrator `Abdullah added:) He kept on instructing me about his debts and then said: "My son, should you find yourself unable to pay any portion of my debt then beseech my Master for His help.'' By Allah, I did not understand what he meant and asked: "Father, who is your Master?'' He said: "Allah.'' By Allah! Whenever I faced a difficulty in discharging any portion of his debt; I would pray: "O Master of Zubair, discharge his debt,'' and He discharged it. Zubair was martyred. He left no money, but he left certain lands, one of them in Al-Ghabah, eleven houses in Al-Madinah, two in Basrah, one in Kufah and one in Egypt. The cause of his indebtedness was that a person would come to him asking him to keep some money of his in trust for him. Zubair would refuse to accept it as a trust, fearing it might be lost, but would take it as a loan. He never accepted a governorship, or revenue office, or any public office. He fought along with Messenger of Allah (PBUH) and Abu Bakr, `Umar and `Uthman (May Allah be pleased with them).

`Abdullah added: I prepared a statement of his debts and they amounted to two million and two hundred thousand! Hakim bin Hizam met me and asked me: "Nephew, how much is due from my brother as debt?'' I kept it as secret and said: "A hundred thousand.'' Hakim said: "By Allah! I do not think your assets are sufficient for the payment of these debts.'' I said: "What would you think if the amount were two million and two hundred thousand?'' He said: "I do not think that you would be able to clear off the debts. If you find it difficult let me know.''

Az-Zubair (May Allah bepleased with him) had purchased the land in Al-Ghabah for a hundred and seventy thousand. `Abdullah sold it for a million and six hundred thousand, and declared that whosoever had a claim against Az-Zubair (May Allah bepleased with him) should see him in Al-Ghabah. `Abdullah bin Ja`far (May Allah bepleased with him) came to him and said: "Az-Zubair (May Allah bepleased with him) owed me four hundred thousand, but I would remit the debt if you wish.'' `Abdullah (May Allah bepleased with him) said: "No.'' Ibn Ja`far said: ``If you would desire for postponement I would postpone the recovery of it.'' `Abdullah said: "No.'' Ibn Ja`far then said: "In that case, measure out a plot for me.'' `Abdullah marked out a plot. Thus he sold the land and discharged his father's debt. There remained out of the land four and a half shares. He then visited Mu`awiyah who had with him at the time `Amr bin `Uthman, Al-Mundhir bin Az-Zubair and Ibn Zam`ah (May Allah bepleased with them). Mu`awiyah (May Allah bepleased with him) said: "What price did you put on the land in Al-Ghabah?'' He said: "One hundred thousand for a each share. Mu`awiyah inquired: "How much of it is left?'' `Abdullah said: "Four and a half shares.'' Al-Mundhir bin Az-Zubair said: "I will buy one share for a hundred thousand". `Amr bin `Uthman said: "I will buy one share for a hundred thousand". Ibn Zam`ah said: "I will buy one share for a hundred thousand.'' Then Mu`awiyah asked: "How much of it is now left?'' `Abdullah said: "One and a half share. Mu`awiyah said: "I will take it for one hundred and fifty thousand.'' Later `Abdullah bin Ja`far sold his share to Mu`awiyah for six hundred thousand.

When `Abdullah bin Az-Zubair (May Allah bepleased with him) finished the debts, the heirs of Az-Zubair (May Allah bepleased with him) asked him to distribute the inheritance among them. He said: "I will not do that until I announce during four successive Hajj seasons: `Let he who has a claim against Az-Zubair come forward and we shall discharge it.''' He made this declaration on four Hajj seasons and then distributed the inheritance among the heirs of Az-Zubair (May Allah bepleased with him) according to his will. Az-Zubair (May Allah bepleased with him) had four wives. Each of them received a million and two hundred thousand. Thus Az-Zubair's total property was amounted to fifty million and two hundred thousand.
[Al-Bukhari]


Unlawfulness of Oppression and Restoring Others Rights

Chapter 26
Unlawfulness of Oppression and Restoring Others Rights

Allah, the Exalted, says:

"There will be no friend, nor an intercessor for the Zalimun (polytheists and the wrongdoers), who could be given heed to.'' (40:18)

"And for the Zalimun (wrongdoers, polytheists and disbelievers in the Oneness of Allah) there is no helper.'' (22:71)

203. Jabir bin `Abdullah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Beware of injustice, for oppression will be darkness on the Day of Resurrection; and beware of stinginess because it doomed those who were before you. It incited them to shed blood and treat the unlawful as lawful.''
[Muslim]

204. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "On the Resurrection Day, the rights will be paid to those to whom they are due so much so that a hornless sheep will be retaliated for by punishing the horned sheep which broke its horns".
[Muslim].

Commentary: This Hadith makes it abundantly clear that there will be utmost justice on the Day of Resurrection. So much so that Allah will redress even the grievance of the aggressed animals against the aggressors. Thus, this Hadith serves a severe warning for people. When animals, who are devoid of sense, will not be forgiven, how would mankind be, which is gifted with senses? The latter will not be pardoned if they are guilty of having been unjust to anyone without adequately compensating them.

205. Ibn `Umar (May Allah bepleased with them) reported: We were talking about the Farewell Pilgrimage without knowing what was it when Messenger of Allah (PBUH) was also present. He (PBUH) stood up and recited the Praise and Glorification of Allah. He then gave a detailed account of Ad-Dajjal and said, 'Every Prophet sent by Allah had warned his people against his mischief. Nuh (PBUH) )warned his nation and so did all the Prophets after him. If he (i.e., Ad-Dajjal) appears among you, his condition will not remain hidden from you. Your Rubb is not one-eyed, but Ad-Dajjal is. His right eye is protruding like a swollen grape. Listen, Allah has made your blood, and your properties as inviolable as of this day of yours (i.e., the Day of Sacrifice), in this city of yours (i.e., Makkah), in this month of yours (i.e., Dhul -Hijjah). Listen, have I conveyed Allah's Message to you?'' The people replied in affirmative. There upon he said, "O Allah, bear witness.'' And he repeated it thrice. He (PBUH) concluded: "Do not revert after me as infidels killing one another".
[Al-Bukhari].

Commentary: This Hadith brings out the following three points:

1. Some marks and signs of pseudo-Messiah (Al-Masih Ad-Dajjal) are mentioned to warn the believers against his mischief.

2. The lives and properties of Muslims are inviolable for each other. In other words, it means that each of them is a protector and guardian of the life, property and honour of the other.

3. Internal war among the Muslims is a great crime and can even lead to infidelity (Kufr). May Allah save us all from it.

206. `Aishah (May Allah bepleased with her) reported: Messenger of Allah (PBUH) said, "Whoever usurps unlawfully even a hand span of land a collar measuring seven times (this) land will be placed around his neck on the Day of Resurrection".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that even a minor injustice to anybody in this world can cause great trouble on the Day of Resurrection.

207. Abu Musa (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Verily, Allah gives respite to the oppressor. But when He seizes him, He does not let him escape.'' Then he (PBUH)) recited, "Such is the Seizure of your Rubb when He seizes the (population of) towns while they are doing wrong. Verily, His Seizure is painful (and) severe". (11:102).
[Al-Bukhari and Muslim].

Commentary: One should not take the respite for exemption because no one knows when respite granted by Him will come to an end and punishment will follow.

208. Mu`adh (May Allah bepleased with him) reported that Messenger of Allah (PBUH) sent me (as a governor of Yemen) and instructed me thus: "You will go to the people of the Book. First call them to testify that `there is no true god except Allah, that I am (Muhammad (PBUH)) the Messenger of Allah.' If they obey you, tell them that Allah has enjoined upon them five Salat (prayers) during the day and night; and if they obey you, inform them that Allah has made Zakat obligatory upon them; that it should be collected from their rich and distributed among their poor; and if they obey you refrain from picking up (as a share of Zakat) the best of their wealth. Beware of the supplication of the oppressed, for there is no barrier between it and Allah".
[Al-Bukhari and Muslim].

Commentary:
1. If it comes to Jihad against infidels, polytheists and the people of the Book (Ahl-ul-Kitab) then before waging war against them, they should be invited to Islam and told about the prescribed Salat (prayers), Zakat and other teachings of Islam.

2. The Zakat collected from the rich of a locality must be spent on the poor of that place. If some amount is left unspent only then it should be distributed among the deserving people of other areas.

3. The collectors of Zakat should refrain from aggression in its collection as in that case they will be invoking the curse of the people concerned and thereby invite the Wrath of Allah.

209. Abu Humaid bin Sa`d As-Sa`idi (May Allah bepleased with him) reported: The Prophet (PBUH) employed a man from the tribe of Al-Azd named Ibn Lutbiyyah as collector of Zakat. When the employee returned (with the collections) he said: "(O Prophet (PBUH)!) This is for you and this is mine because it was presented to me as gift.'' Messenger of Allah (PBUH) rose to the pulpit and praised Allah and extolled Him. Then he said, "I employ a man to do a job and he comes and says: `This is for you and this has been presented to me as gift'? Why did he not remain in the house of his father or the house of his mother and see whether gifts will be given to him or not? By Allah in Whose Hand is the life of Muhammad, if any one of you took anything wrongfully, he will bring it on the Day of Resurrection, carrying it on (his back), I will not recognize anyone of you, on the Day of Resurrection with a grunting camel, or a bellowing cow, or a bleating ewe.'' Then he raised his hands till we could see the whiteness of his armpits. Then he said thrice, ``O Allah ! have I conveyed (Your Commandments)''.
[Al-Bukhari and Muslim].

Commentary: There is a stern warning in this Hadith for the government functionaries. Nowadays official positions are very much misused and people have developed the habit of giving presents and gifts to them. According to this Hadith, all such presents and gifts which are given to the government employees due to their official position are unlawful and constitute bribery. The taking and accepting of bribery are both unlawful.

210. Abu Hurairah (May Allah bepleased with him) reported: The Prophet (PBUH) said, "He who has done a wrong affecting his brother's honour or anything else, let him ask his forgiveness today before the time (i.e., the Day of Resurrection) when he will have neither a dinar nor a dirham. If he has done some good deeds, a portion equal to his wrong doings will be subtracted from them; but if he has no good deeds, he will be burdened with the evil deeds of the one he had wronged in the same proportion".
[Al-Bukhari].

Commentary: This Hadith tells us that if one does not compensate a person who has been harmed by one and has not been pardoned for it, then it would have a serious consequence in the Hereafter. Its detail is mentioned in this Hadith. Thus, negligence in the case of public rights, which we take very lightly, is in fact ruinous.

211. `Abdullah bin `Amr bin Al-`as (May Allah bepleased with them) reported: The Prophet (PBUH) said, "A Muslim is the one from whose tongue and hands the Muslims are safe; and a Muhajir (Emigrant) is the one who refrains from what Allah has forbidden".
[Al-Bukhari and Muslim].

Commentary: The Hadith shows that a true Muslim is one who does not do any harm to others, overtly or covertly. Similarly, the true Muhajir is one who avoids disobeying Allah. Thus, if a person leaves his hearth and home to emigrate to some other place but does not save himself from sins, his emigration is of no avail.

212. `Abdullah bin `Amr bin Al-`as (May Allah bepleased with them) reported: A man named Kirkirah, who was in charge of the personal effects of Messenger of Allah (PBUH) passed away and the Prophet (PBUH) said, "He is in the (Hell) Fire.'' Some people went to his house looking for its cause and found there a cloak that he had stolen. [Al-Bukhari]

Commentary: The Hadith shows that stealing and breach of trust fall in the category of major sins for which one can be consigned to Hell.

213. Abu Bakrah (May Allah bepleased with him) reported: The Prophet (PBUH) said, "Time has completed its cycle and has come to the state of the day when Allah created the heavens and the earth. The year consists of twelve months of which four are inviolable; three of them consecutive - Dhul-Qa`dah, Dhul-Hijjah and Muharram and Rajab, the month of Mudar (tribe), which comes between Jumada and Sha`ban. What month is this?'' We said, "Allah and His Messenger (PBUH) know better". The Prophet (PBUH) remained silent for some time until we thought that he would give it a name other than its real name. Then asked, "Is it not (the month of) Dhul-Hijjah?''. We replied in the affirmative. He asked, "Which city is this?". We replied: "Allah and His Messenger know better". He remained silent until we thought that he would give it another name. He (PBUH) asked, "Is it not Al-Baldah (Makkah)?'' We said: "Yes". He (PBUH) asked, "What day is this?". We said: "Allah and His Messenger know better.'' He (PBUH) remained silent until we thought that he would give it another name. He asked, "Is it not the day of An-Nahr (the sacrifice)?". We replied in the affirmative. Thereupon he said, "Your blood, your property and your honour are inviolable to you all like the inviolablity of this day of yours, in this city of yours and in this month of yours. You will soon meet your Rubb and He will ask you about your deeds. So do not turn to disbelief after me by striking the necks of one another. Behold! Let him who is present here convey (this message ) to him who is absent; for many a person to whom a message is conveyed has more retentive memory than the one who hears it.'' He (PBUH) again said, "Have I conveyed the message to you? Behold! Have I conveyed the Commandments (of Allah) to you.'' We submitted: "Yes". He then said, "O Allah, bear witness (to this)".
[Al-Bukhari and Muslim].

Commentary:
1. The cycle of years and months (that is to say a month consists of 30 or 29 days and a year has 12 months) was completed at the time of creation of heavens and earth.

2. The Hadith mentions the sanctity of life, property, respect and honour of each Muslim for the other and lays stress upon the importance of this bond in them.

3. It reminds that everyone will be answerable for his actions on the Day of Requittal.

4. It urges that one should not just keep to oneself the Commandments of Allah and His Prophet's teachings but disseminate them among others also. It is quite possible that someone who remembers these teachings more adheres to them more in practice.

214. Abu Umamah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Allah decrees the (Hell) Fire and debars Jannah for the one who usurps the rights of a believer by taking a false oath.'' One man asked: "O Messenger of Allah! Even if it should be for an insignificant thing?'' He said, "Even if it be a stick of the Arak tree (i.e., the tree from which Miswak sticks are taken)".
[Muslim].

Commentary: The importance of rights of people is evident from the threat of severe punishment that this Hadith holds for the usurpers of these rights. Their case will depend entirely on the Will of Allah. Such defaulters may be forgiven even in the initial stage or they may be pardoned by Allah after some punishment.

215. `Adi bin `Umairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Whosoever among you is appointed by us to a position and he conceals from us even a needle or less, it will amount to misappropriation and he will be called upon to restore it on the Day of Resurrection". (`Adi bin `Umairah added:) A black man from the Ansar stood up - I can see him still - and said: "O Messenger of Allah, take back from me your assignment.'' He (the Prophet (PBUH)) said, "What has happened to you?'' The man replied: "I have heard you saying such and such.'' He (PBUH) said, "I say that even now: Whosoever from you is appointed by us to a position, he should render an account of everything, big or small, and whatever he is given therefrom, he should take and he should desist from taking what is unlawful".
[Muslim].

Commentary: Here again functionaries of government are warned to perform their duties with co-operation and integrity. If they neglect their duties or take undue advantage of their official position, they will be held guilty by Allah for dereliction of their duties and misuse of power, as has been stated in a Hadith quoted before. It also tells us that it is the duty of the superior officers to keep a strict watch on their subordinates and not to let them indulge in bribery and abuse; otherwise, their negligence or slackness or overlooking or shirking from their duty in this behalf will also be treated as crime. It is not difficult to imagine the fate of such officers who conspire in the loot and plunder as is the case in our society today.

216. `Umar bin Al-Khattab (May Allah bepleased with him) reported: On the day (of the battle) of Khaibar, some Companions of the Prophet (PBUH) came and remarked: "So-and-so is a martyr and so-and-so is a martyr". When they came to a man about whom they said: "So-and-so is a martyr,'' the Prophet (PBUH) declared, "No. I have seen him in Hell for a mantle (or cloak) which he has stolen".
[Muslim].

Commentary:
1. This Hadith tells us that the rights of people will not be forgiven even by martyrdom.

2. Misappropriation in the national exchequer is a horrible sin.

217. Abu Qatadah Al-Harith bin Rib`i (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Faith in Allah and striving in His Cause (Jihad) are the deeds of highest merit.'' A man stood up said: "O Messenger of Allah! Tell me if I am killed in the Cause of Allah, will all my sins be forgiven?'' He (PBUH) replied, "Yes, if you are killed in the Cause of Allah while you are patient, hopeful of your reward and marching forward not retreating." Then the Prophet (PBUH) said to him, "Repeat what you have said.'' The man said: "Tell me if I am killed in the Cause of Allah, will all my sins be remitted?". He replied, "Yes, if you are martyred while you are patient, hopeful of your reward and march forward without retreating, unless, if you owe any debt, that will not be remitted. Angel Jibril told me that".
[Muslim].

Commentary: This Hadith also shows the importance of rights of people and repayment of loan which will not be pardoned in any case. It is, therefore, essential that every Muslim should exercise utmost care to fulfill his obligations in these matters.

218. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Do you know who is the bankrupt?'' They said: "The bankrupt among us is one who has neither money with him nor any property". He said, "The real bankrupt of my Ummah would be he who would come on the Day of Resurrection with Salat, Saum and Sadaqah (charity), (but he will find himself bankrupt on that day as he will have exhausted the good deeds) because he reviled others, brought calumny against others, unlawfully devoured the wealth of others, shed the blood of others and beat others; so his good deeds would be credited to the account of those (who suffered at his hand). If his good deeds fall short to clear the account, their sins would be entered in his account and he would be thrown in the (Hell) Fire".
[Muslim].

Commentary: This Hadith tells us that a Muslim has to take strict care in the performance of obligations like prescribed Salat (prayers), Zakat, etc, but he has to take similar care in his dealings, manners and morals. Salvation lies in the proper fulfillment of all these requirements. Fulfillment of one at the cost of the other will not be sufficient for salvation.

219. Umm Salamah (May Allah bepleased with her) reported: Messenger of Allah (PBUH) said, "Verily, I am only a human and the claimants bring to me (their disputes); perhaps some of them are more eloquent than others. I judge according to what I hear from them). So, he whom I, by my judgment, (give the undue share) out of the right of a Muslim, I in fact give him a portion of (Hell) Fire".
[Al-Bukhari and Muslim].

Commentary:
1. The Prophet (PBUH) has explained through this Hadith that he, too, was a man like others and was thus liable to judging by what he hears by the facile tongue, cleverness and eloquence of people. But it does not detract from his innocence as a Prophet because it has no concern with his duty as a preacher and Prophet, the responsibility of protection of which has been accepted by Allah.

2. A judge (Qadi) should decide on the case which comes before him in the light of arguments presented to him by the litigants. He should not make decision according to speculation but go by the arguments which are in his opinion more convincing.

3. The decision of the Qadi will be evidently enforced, but it will not make the lawful as unlawful or vice versa. That is to say, it will not be enforced intrinsically, as is believed by some people. If somebody succeeds in winning a case, it will be invalid and the one who secures it will suffer its consequences in the Hell-fire.

220. Ibn `Umar (May Allah bepleased with them) reported: Messenger of Allah (PBUH) said, "A believer continues to guard his Faith (and thus hopes for Allah's Mercy) so long as he does not shed blood unjustly".
[Al-Bukhari].

Commentary: This Hadith has two meanings. Firstly, so long as a Muslim does not kill another Muslim without valid reason, he remains, by the Grace of Allah, capable of acting upon the Deen. That is to say, he is more hopeful of the Mercy of Allah, and deserves it also, as long as he does not commit murder. When he kills an innocent person, the gate of Allah's Compassion is closed on him.

Ibn Al-Arabi interpretted this Hadith as follows:

A Muslim will still have ample chance for accomplishing good deeds to face evil deeds until he sheds blood. Or, he has the chance of forgiveness until he sheds blood. (M.R.M.)

221. Khaulah bint `Thamir (May Allah bepleased with her) reported: Messenger of Allah (PBUH) said, "Many people misappropriate (acquire wrongfully) Allah's Property (meaning Muslims' property). These people will be cast in Hell on the Day of Resurrection".
[Al-Bukhari].

Commentary: Misappropriation in national exchequer and its use for vested rather than public interest is a major sin which is punishable, if the delinquent does not sincerely beg pardon for it.


Reverence towards the Sanctity of the Muslims

Chapter 27
Reverence towards the Sanctity of the Muslims

Allah, the Exalted, says:

"And whosoever honours the sacred things of Allah, then that is better for him with his Rubb". (22:30)

"And whosoever honours the Symbols of Allah, then it is truly from the piety of the heart". (22:32)

"And lower your wing for the believers (be courteous to the fellow believers)". (15:88)

"...if anyone killed a person not in retaliation of murder, or (and) to spread mischief in the land - it would be as if he killed all mankind, and if anyone saved a life, it would be as if he saved the life of all mankind". (5:32)

222. Abu Musa (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "The relationship of the believer with another believer is like (the bricks of) a building, each strengthens the other.'' He (PBUH) illustrated this by interlacing the fingers of both his hands.
[Al-Bukhari and Muslim].

Commentary: This Hadith enjoins unity in the Muslim community, each member of which is like a brick, which, when they are all combined, lend strength to each other. Similarly, Muslims are like hands and arms, which physically joined together, are bound to co-operate with one another.

223. Abu Musa (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Whoever enters our mosque or passes through our market with arrows with him, he should hold them by their heads lest it should injure any of the Muslims".
[Al-Bukhari and Muslim].

Commentary: Islam has made a forceful and elaborate arrangement for the security of the lives of the Muslims, but the abundance of arms and ammunition has vitiated this arrangement. Its senseless use has resulted in killing at large scale. It is used even on happy occasions to spread terror. Sometimes firing in the air for jubilation, costs some precious lives. Similarly, display of fireworks on festivities is a cause of great nuisance for the people living in that locality. May Allah grant us guidance to adhere to His Injunctions in every walk of life.

224. Nu`man bin Bashir (May Allah bepleased with them) reported: Messenger of Allah (PBUH) said, "The believers in their mutual kindness, compassion and sympathy are just like one body. When one of the limbs suffers, the whole body responds to it with wakefulness and fever".
[Al-Bukhari and Muslim].

Commentary: This Hadith has the same purport which is mentioned in the previous Hadith. It says that Muslims are akin to a living person. When he feels pain in one of his eyes, for example, his entire body feels it. When he suffers from a headache, he feels its pain throughout his body.

225. Abu Hurairah (May Allah bepleased with him) reported: The Prophet (PBUH) kissed his grandson Al-Hasan bin `Ali (May Allah bepleased with them) in the presence of Al-Aqra` bin Habis. Thereupon he remarked: "I have ten children and I have never kissed any one of them.'' Messenger of Allah (PBUH) looked at him and said, "He who does not show mercy to others will not be shown mercy".
[Al-Bukhari and Muslim].

Commentary: To kiss children with kindness and affection is not only permissible but also a means of attaining Allah's Mercy.

226. `Aishah (May Allah bepleased with her) reported: Some bedouins came to Messenger of Allah (PBUH) and asked: "Do you kiss your children?'' He said, "Yes". They then said: "By Allah, we do not kiss them.'' The Prophet (PBUH) replied, "I cannot help you if Allah has snatched kindness from your hearts".
[Al-Bukhari and Muslim].

Commentary: Showing kindness and affection to children is a sign of that mercy and compassion with which Allah endows mankind.

227. Jarir bin `Abdullah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "He who is not merciful to people Allah will not be merciful to him.''
[Al-Bukhari and Muslim].

Commentary: Kind treatment to Allah's creatures is very much liked by Allah. Even animals and birds are included in this category. Kind treatment with them makes a person eligible to the Mercy of Allah. Decent behaviour with people has been specifically mentioned in this Hadith although all creatures are covered by it.

228. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "When one of you leads the Salat, he should not prolong it because the congregation includes those who are feeble, ill or old". One version adds: "those who have to attend to work'') While offering prayers alone, you may pray as long as you like".
[Al-Bukhari and Muslim].

Commentary: According to this Hadith, the Imam - one who leads the congregational prayer, is enjoined to shorten the prayer in consideration of those who pray behind him. Shortening of prayer here means that the Surah of the Qur'an recited by him in the prayer should not be very long. This does not mean, however, that the postures of Salat, such as standing, bowing, prostration and sitting should not be done properly, as it is taken to mean by Muslims in general. Although it is a Sunnah about which the Noble Prophet (PBUH) is reported to have said, "Pray as you see me praying.'' Thus, it is essential to perform Salat properly.

229. `Aishah (May Allah bepleased with her) reported: Messenger of Allah (PBUH) would sometimes abstain from doing something he wished to do, lest others should follow him and it might become obligatory upon them.
[Al-Bukhari and Muslim].

Commentary: This Hadith indicates the affection which the Prophet (PBUH) had for his followers. In spite of his fervent desire, he would sometime deliberately leave voluntary prayer lest it became obligatory upon the Muslims.

230. `Aishah (May Allah bepleased with her) reported: The Prophet (PBUH) prohibited his Companions out of mercy for them, from observing continuous fasting without a break. They said: "But you observe fast continuously". He replied, "I am not like you. I spend the night while my Rubb provides me with food and drink".
[Al-Bukhari and Muslim].

(This means that Allah has bestowed upon him the power of endurance like that of a person who eats and drinks).

Commentary: The words "I am not like you'' should not be taken to mean here: "I am not a human like you''. What they really mean is that no one else has that special contact with Allah which he has. On account of this quality which was special to the Prophet (PBUH), it is prohibited to keep fast continuously. In fact it is not only prohibited, but unlawful. In such cases, it is obligatory for Muslims to follow him faithfully.

231. Abu Qatadah Al-Harith bin Rib`i (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "I stand up to lead Salat with the intention of prolonging it. Then I hear the crying of an infant and I shorten the Salat lest I should make it burdensome for his mother".
[Al-Bukhari].

Commentary: In this Hadith, brevity of prayers stands for recitation of short Surah of the Noble Qur'an in prescribed congregational prayers. The Sahih Muslim has elucidated this by saying that the Prophet (PBUH) would recite short Surah on hearing the crying of a baby. In short, this Hadith mentions that affection which he had for his followers. Its importance can be judged by the fact that he made a demonstration of it even in the prescribed prayers.

232. Jundub bin Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When anyone offers the Fajr (dawn) prayer, in congregation, he is in the Protection of Allah. So let not Allah call him to account, withdrawing, in any respect, His Protection. Because, He will get hold of him and throw him down on his face in the Hell-fire.''
[Muslim]

Commentary: This Hadith tells us that the Fajr prayer is in the nature of an agreement between Allah and His slave (Muslim). It tells us that he would not all day long depart from the way of Allah as he has not done by performing his Fajr prayer. He will not only perform all the other prescribed prayers but would also do nothing which will displease Allah. A Muslim who does not care to adhere to this agreement, and thereby shows disobedience of Allah, will be answerable to Him for it on the Day of Resurrection.

233. Ibn `Umar (May Allah bepleased with them) reported: Messenger of Allah (PBUH) said, "A Muslim is a brother of another Muslim. So he should not oppress him nor should he hand him over to (his satan or to his self which is inclined to evil). Whoever fulfills the needs of his brother, Allah will fulfill his needs; whoever removes the troubles of his brother, Allah will remove one of his troubles on the Day of Resurrection; and whoever covers up the fault of a Muslim, Allah will cover up his fault on the Day of Resurrection".
[Al-Bukhari and Muslim].

Commentary: This Hadith is extremely important for the reason that it advises Muslims to live like family members. It says that one does not like to subject one's own son, brother, etc, to suppression, nor leaves him helpless in trouble, but helps him when he is in need of it, endeavours to relieve him of hardship and admonishes him when he does anything wrong. Almighty Allah is pleased with such behaviour and gives him best reward for it in this world and the next.

234. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "A Muslim is a brother to a Muslim. He should neither deceive him nor lie to him, nor leave him without assistance. Everything belonging to a Muslim is inviolable for a Muslim; his honour, his blood and property. Piety is here (and he pointed out to his chest thrice). It is enough for a Muslim to commit evil by despising his Muslim brother.''
[At-Tirmidhi].

Commentary: This Hadith deals with the subject discussed in the preceding one. In fact, it elucidates the points raised there. Now, the heart is one thing which no one can check out; Allah Alone knows about it. The case of those who openly lead a sinful and impious life is of course quite different. To show hatred and disgust against such people is warranted by Faith.

235. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Do not envy one another; do not inflate prices by overbidding against one another; do not hate one another; do not harbour malice against one another; and do not enter into commercial transaction when others have entered into that (transaction); but be you, O slaves of Allah, as brothers. A Muslim is the brother of another Muslim; he neither oppresses him nor does he look down upon him, nor does he humiliate him. Piety is here, (and he pointed to his chest three times). It is enough evil for a Muslim to hold his brother Muslim in contempt. All things of a Muslim are inviolable for his brother-in-faith: his blood, his property and his honour".
[Muslim].

Commentary: This Hadith elaborates the importance of mutual brotherhood and goodwill among the Muslims. They are warned against jealousy which is a very malicious moral disease. One who suffers from it does not like to see others in happy circumstances and wants that they are deprived of whatever good they have.

This Hadith also prohibits Muslims from mutual hatred, enmity and indifference to others because all such things go against the concept of Islamic fraternity. The Hadith also warns Muslims against Najash (false bidding to raise the price in an auction) as it is clear deception and fraud is opposed to goodwill for others, while Muslims are required to express for each other goodwill, not ill-will.

This Hadith also prohibits making one bargain over the others because it generate malice and enmity.

236. Anas (May Allah bepleased with him) reported: The Prophet (PBUH) said, "No one of you shall become a true believer until he desires for his brother what he desires for himself".
[Al-Bukhari and Muslim].

Commentary: This Hadith deals more comprehensively with the subject discussed above. When a Muslim likes the same thing for another Muslim which he does for himself, then he will be obviously expressing goodwill to his fellow Muslims. When Muslims adopt this attitude at the community level, no Muslim will be an enemy of the other. In fact, each Muslim would then be a well-wisher and helper of other Muslims. May Allah enable us to adopt this attitude.

237. Anas (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "Help your brother, whether he is an oppressor or is oppressed". A man enquired: "O Messenger of Allah! I help him when he is oppressed, but how can I help him when he is an oppressor?'' He (PBUH) said, "You can keep him from committing oppression. That will be your help to him".
[Al-Bukhari and Muslim].

Commentary: This Hadith contains a very comprehensive injunction to eliminate disturbance and tyranny in the Muslim society. It not only ordains helping the oppressed but also encourages people endowed with moral courage to stop the oppressor's oppression. Doing so requires great courage and boldness, but Muslims would be able to do full justice to their duty of wishing well to their fellow Muslims when they develop the moral courage to stop the oppressor from tyranny, or at least protest against it verbally.

238. Abu Hurairah (May Allah bepleased with him) reported: Messenger of Allah (PBUH) said, "A believer owes another believer five rights: responding to greetings, visiting him in illness, following his funeral, accepting his invitation, and saying `Yarhamuk-Allah (May Allah have mercy on you),' when he says `Al-hamdu lillah (Praise be to Allah)' after sneezing".
[Al-Bukhari and Muslim].

Muslim's narration is, "There are six rights of a Muslim upon a Muslim: When you meet him, greet him; when he invites you, respond to him; when he seeks counsel, give him advice; when he sneezes and praises Allah, say to him: `May Allah have mercy on you (Yarhamuk-Allah)'; when he is sick, visit him; and when he dies, follow his funeral".

Commentary: The bond of brotherhood among the Muslims has been further strengthened by the list in this Hadith about the rights of Muslims on one another.

239. Al-Bara' bin `Azib (May Allah bepleased with them) reported: The Prophet (PBUH) commanded us to observe seven things and forbade us seven. He ordered us to visit the sick; to follow funeral processions; to respond to a sneezer with `Yarhamuk-Allah (May Allah have mercy on you)' when he says `Al-hamdu lillah (Praise be to Allah),' to help the oppressed and to help others to fulfill their oaths, to accept invitation and to promote greeting. He forbade us to wear gold rings, to drink in silver utensils, to use Mayathir (silk carpets placed on saddles), to wear Al-Qassiy (a kind of silk cloth) to wear fine silk brocade.
[Al-Bukhari and Muslim].

Commentary: To materialize the pledge means that if a person relies on you and says that by Allah, you must do such and such a thing, then you should not let him down, you should do that work and fulfill his pledge. But this is subject to the condition that the work in question is not unlawful. It is not only permissible but also comes in the list of high moral values.


Covering Faults of the Muslims

Chapter 28
Covering Faults of the Muslims

Allah, the Exalted, says:

"Verily, those who like that (the crime of) illegal sexual intercourse should be propagated among those who believe, they will have a painful torment in this world and in the Hereafter.'' (24:19)

240. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah will cover up on the Day of Resurrection the defects (faults) of the one who covers up the faults of the others in this world".
[Muslim].

Commentary: Covering up the shortcomings and faults of people is an excellent manner. That is why this quality is very much liked by Almighty Allah. On the Day of Resurrection, Allah will give a matching reward to that man who has such a quality, which means that Allah will forgive his sins and will not call him to account for his sins. If at all He will do so, He will not do it publicly so that he is not embarrased before others. Then Allah may forgive him or send him to Hell for a short while.

241. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Every one of my followers will be forgiven except those who expose (openly) their wrongdoings. An example of this is that of a man who commits a sin at night which Allah has covered for him, and in the morning, he would say (to people): "I committed such and such sin last night,' while Allah had kept it a secret. During the night Allah has covered it up but in the morning he tears up the cover provided by Allah Himself.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that commission of a sin due to human frailties on which one is ashamed but does not like to express is something which might hopefully be forgiven by Allah. In fact, its remission after penitence is almost sure. But to commit a sin openly is totally different because, firstly, the heart of such a person is deprived of the fear of Allah. Secondly, he has no respect and regard for Divine injunctions. Thirdly, such a person usually does not repent his sins. Fourthly, he makes a declaration of breach of Divine injunctions which amounts to inviting His wrath and punishment.

242. Abu Hurairah (May Allah bepleased with him) reported: The Prophet (PBUH) said, "When a slave-girl commits fornication and this fact of fornication has become evident, she must be given the penalty of (fifty) lashes without hurling reproaches at her; if she does it again, she must be given the penalty but she should not be rebuked. If she does it for the third time, he should sell her, even for a rope woven from hair (i.e., something worthless)".
[Al-Bukhari and Muslim].

Commentary: If a slave-girl is guilty of fornication, she is liable to a punishment of fifty stripes, and this punishment can be given by her master. This Hadith is, in fact addressed to the master of such a slave-girl. The order that one should not censure and reproach her is perhaps based on the consideration that she may abstain from such a sin in future because politeness often proves more effective than reproach. If politeness proves ineffective and she commits that sin again then that slave-girl should be sold for cheap.

243. Abu Hurairah (May Allah bepleased with him) reported: A man who had drunk wine was brought to the Prophet (PBUH) and he asked us to beat him; some struck him with their hands, some with their garments (making a whip) and some with their sandals. When he (the drunkard) had gone, some of the people said: "May Allah disgrace you!'' He (the Prophet (PBUH)) said, "Do not say so. Do not help the devil against him".
[Al-Bukhari].

Commentary: To imprecate a Muslim virtually amounts to helping Satan against him, because the latter is avowed to mislead people and to expose man to humiliation in this world and the Hereafter. Such people who believe that no Hadd punishment is fixed for drinking take support from this Hadith. They hold that its punishment is discretionary which can be increased or decreased according to the circumstances. But other learned men who hold that its Hadd is forty stripes argue that the incident quoted in this Hadith relates to the period when its Hadd had not been fixed. When the Prophet (PBUH) ordered the punishment of forty stripes for it then it became its prescribed Hadd. Abu Bakr (May Allah bepleased with him) followed it during the period of his caliphate. `Umar (May Allah bepleased with him) also applied it in the early years of his caliphate but subsequently raised its punishment to eighty stripes. The `Ulama' who maintain the punishment of forty stripes contend that the original Hadd was forty stripes and the additional forty stripes comprised discretionary punishment for which the Head of a state has full authority. If he feels, he can add discretionary punishment to the Hadd. The nature of this additional punishment depends on his discretion. The latter opinion seems to be more correct that Hadd is fixed for drinking and its punishment is not based on discretion. The Hadd for it is forty stripes but this Hadd can be increased by adding discretionary punishment to it. Allah knows best.


Fulfillment of the needs of the Muslims

Chapter 29
Fulfillment of the needs of the Muslims

Allah, the Exalted, says:

"... and do good that you may be successful". (22:77).

244. Ibn `Umar (May Allah bepleased with them) reported: Messenger of Allah (PBUH) said, "A Muslim is a brother of (another) Muslim, he neither wrongs him nor does hand him over to one who does him wrong. If anyone fulfills his brother's needs, Allah will fulfill his needs; if one relieves a Muslim of his troubles, Allah will relieve his troubles on the Day of Resurrection; and if anyone covers up a Muslim (his sins), Allah will cover him up (his sins) on the Resurrection Day".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that we should fulfill the needs of Muslims for the Pleasure of Allah only, regardless of any vested interest or worldly motive. It is a very meritorious approach. The needs of people who adopt this attitude in life are fulfilled by Allah, and the reward they get for it in the Hereafter will be greater than that to be given in this world.

245. Abu Hurairah (May Allah bepleased with him) reported: The Prophet (PBUH) said, "He who removes from a believer one of his difficulties of this world, Allah will remove one of his troubles on the Day of Resurrection; and he who finds relief for a hard-pressed person, Allah will make things easy for him on the Day of Resurrection; he who covers up (the faults and sins) of a Muslim, Allah will cover up (his faults and sins) in this world and in the Hereafter. Allah supports His slave as long as the slave is supportive of his brother; and he who treads the path in search of knowledge, Allah makes that path easy, leading to Jannah for him; the people who assemble in one of the houses of Allah, reciting the Book of Allah, learning it and teaching, there descends upon them the tranquillity, and mercy covers them, the angels flock around them, and Allah mentions them in the presence of those near Him; and he who lags behind in doing good deeds, his noble lineage will not make him go ahead.''
[Muslim]

Commentary: Besides other advantages mentioned in this Hadith, we learn the following from it:

1. It is an act of great merit to relieve a Muslim from his financial difficulty.

2. To strive for attaining religious knowledge is a highly meritorious act.

3. To recite the Noble Qur'an, make arrangement for its study and teaching, and hold meetings for the understanding and elucidation of the message of the Noble Qur'an are acts of great distinction and reward.


Intercession

Chapter 30
Intercession

Allah, the Exalted, says:

"Whosoever intercedes for a good cause will have the reward thereof.'' (4:85)

246. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: Whenever a needy person would come to the Prophet (PBUH), he would turn to those who were present and say, "If you make intercession for him, you will be rewarded, because Allah decreed what He likes by the tongue of His Messenger".
[Al-Bukhari and Muslim].

Commentary: The recommendation mentioned in this Hadith relates to lawful and permissible matters. One is not permitted to make any intercession for unlawful matter nor for remission of Hadd.

247. Ibn `Abbas (May Allah bepleased with them), reported in connection with the case of Barirah (May Allah bepleased with her) and her husband: The Prophet (PBUH) said to her, "It is better for you to go back to your husband.'' She asked: "O Messenger of Allah, do you order me to do so.'' He replied, "I only intercede'' She then said: "I have no need for him".
[Al-Bukhari].

Commentary: Barirah (May Allah bepleased with her) was a slave-girl of `Aishah (May Allah bepleased with her). Barirah was married to a slave named Mughith (May Allah bepleased with him). She was freed by `Aishah (May Allah bepleased with her). Now, Islam has permitted a slave-girl that after being freed, she can break her matrimonial bond if she does not like to live with her husband. Mughith was madly in love with her and he would all the time persuade her not to break their bond of marriage. When the Prophet (PBUH) came to know the condition of Mughith, he interceded for him and asked Barirah to restore her matrimonial connection with her husband. Since this was an advice and recommendation, she did not think it suitable for herself and regretted that she could not accept it. The Hadith evidently shows that Islam accepts legitimate rights of individuals and honours personal freedom, provided they do not exceed the limits of Shari`ah.

This freedom cannot be forfeited by suppression or force.


Making Peace among People

Chapter 31
Making Peace among People

Allah, the Exalted, says:

"There is no good in most of their secret talks save (in) him who orders Sadaqah (charity in Allah's Cause), or Ma`ruf (Islamic Monotheism and all the good and righteous deeds which Allah has ordained), or conciliation between mankind.'' (4:114)

"...and making peace is better.'' (4:128)

"So fear Allah and adjust all matters of difference among you.'' (8:1)

"The believers are nothing else than brothers (in Islamic religion). So make reconciliation between your brothers.'' (49:10)

248. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On every joint of man, there is charity, on everyday when the sun rises: doing justice between two men is charity, and assisting a man to ride an animal or to load his luggage on it is charity; and a good word is charity, every step which one takes towards (the mosque for) Salat is charity, and removing harmful things from the way is charity".
[Al-Bukhari and Muslim].

Commentary: Almighty Allah has made human body flexible, that is to say, its parts have joints which enable him to make all kinds of movements. If human beings did not have these joints, it would not have been possible for its different parts to make movements which they do. Had it been so, one would not have been able to use various parts of his body as he likes. Thus, these joints are a valuable gift from Allah for which one should always be grateful to Him. In all, a person has three hundred and sixty joints in his body, as has already been stated in a Hadith narrated earlier.

According to some Ahadith, two Rak`ah of Duha prayer (optional forenoon prayer) has been regarded sufficient for this purpose, while in others, it has been stated that if one cannot do anything else for expressing gratefulness to Allah, he should refrain from harming others as it is a form of Sadaqah.

249. Umm Kulthum bint `Uqbah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, 'The person who (lies) in order to conciliate between people is not a liar, when he conveys good or says (something) good".
[Al-Bukhari and Muslim].

The narration in Muslim added: She said, "I never heard him (she meant the Prophet (PBUH)) giving permission of lying in anything except in three (things): war, conciliating between people and the conversation of man with his wife and the conversation of a woman with her husband".

Commentary: This Hadith tells us a very important principle, that is, in spite of its being unlawful, one is permitted to tell a lie if one has to do it for reforming one's society or family or in the interest of Muslims in general. If two Muslim brothers are estranged and someone communicates to them such things which are likely to remove conflict and rancour between them, promote mutual love and bring them nearer to each other, such action, even if it has a lie, is not called a lie in Islam.

1. In order to keep the enemy unaware of the true position, it is permissible to make false propaganda as it is an indispensable device for winning war.

2. In order to maintain pleasant atmosphere in family life, and for this purpose telling a lie becomes inevitable. Shari`ah has permitted lying on such occasions.

250. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) heard the voices of altercation of two disputants at the door; both the voices were quite loud. One was asking the other to make his debts little (so that he could pay them) and was pleading with him to show leniency to him, whereupon the (other one) said: "By Allah, I will not do that". Then there came Messenger of Allah (PBUH) to them and said, "Where is he who swore by Allah that he would not do good?'' He said: "O Messenger of Allah, it is me. Now he may do as he desires".
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the following four main points:

1. It is desirable to help someone who is in straitened circumstances because of a debt. If the lender forgives a part of the loan or gives concession of time in repayment of loan, it is an act of great merit. As Allah says:

"And if the debtor is in a hard time (has no money), then grant him time till it is easy for him to repay; but if you remit it by way of charity, that is better for you if you did but know.'' (2:280)

2. If someone seems to incline towards evil, he should be scolded so that he would keep himself away from it and would turn to virtue.

3. Such people who quarrel among themselves should not be left to mutual bickering but efforts should be made for their reconciliation.

4. People who are quarrelling should also co-operate with those who make efforts for reconciliation, and respect their spirit of goodwill.

251. Sahl bin Sa`d As-Sa`idi (May Allah be pleased with him) reported: There was some quarrel among the members of Banu `Amr bin `Auf. Messenger of Allah (PBUH) went with some of his Companions to bring about peace between them and he was detained. The time for Salat approached and Bilal (May Allah be pleased with them) went to Abu Bakr (May Allah be pleased with him) and said to him: "Messenger of Allah (PBUH) has got late and it is the time for Salat. Will you lead Salat?'' He said: "Yes, if you desire". Bilal (May Allah be pleased with him) proclaimed the Adhan and then pronounced Iqamah. Abu Bakr (May Allah be pleased with him) stepped forward and commenced As-Salat. (He recited Takbir and the people followed him). In the meantime, Messenger of Allah (PBUH) arrived and, passing through the rows, took his stand in the first row. The people started clapping. It was the habit of Abu Bakr (May Allah be pleased with him) that whenever he started praying, he would never look round. He paid no heed (to the clapping). When the clapping increased, he turned round and saw Messenger of Allah (PBUH). He (the Prophet (PBUH)) beckoned him to continue performing Salat. But Abu Bakr (May Allah be pleased with him) raised his hands and praised Allah. Then he retreated, taking his steps backwards. When Messenger of Allah (PBUH) saw that, he went ahead and led Salat. When he finished Salat, he faced the congregation and said, "Why do you clap when something happens during the Salat. Clapping is only for women. If something happens in the course of Salat you should say, Subhan Allah. It is bound to attract attention. And you, Abu Bakr, what prevented you from carrying on with Salat, after I beckoned to do so?'' He said, "It was not becoming for the son of Abu Quhafah to lead Salat in the presence of Messenger of Allah (PBUH)".
[Al-Bukhari and Muslim].

Commentary:
1. Banu `Amr bin `Auf was a big tribe of Aus which consisted of many families, they lived in Quba. A quarrel arose among them on some issue and they used stones and brickbats against each other. When the Prophet (PBUH) came to know about it, he personally went to them. The Hadith shows how important it is to bring about reconciliation amongst Muslims who are estranged from each other so that tension among them is not aggravated. If efforts are not made for reconciliation at the initial stages, the conflict will be escalated and then it will become difficult to resolve it.

2. Salat can be offered behind two Imam, one after the other.

3. In the course of Salat if Imam makes an error, his followers should bring it to his attentions by saying the words "Subhan Allah'' aloud. Women may clap only.

4. In case of need, it is permissible in Salat to turn one's face slightly, to look with glances and move a little onward or backward. Such an act does not constitute a defect which renders the prayer invalid.


Superiority of Poor, Weak and unrenowned Muslims

Chapter 32
Superiority of Poor, Weak and unrenowned Muslims

Allah, the Exalted, says:

"And keep yourself (O Muhammad (PBUH)) patiently with those who call on their Rubb (i.e., your companions who remember their Rubb with glorification, praising in prayers, and other righteous deeds) morning and afternoon, seeking His Face, and let not your eyes overlook them.'' (18:28)

252. Harithah bin Wahb (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "Shall I not inform you about the people of Jannah? It is every person who is, modest and humble (before Allah), a person who is accounted weak and is looked down upon but if he adjures Allah, Allah will certainly give him what he desires. Now shall I not inform you about the inmates of Hell? It is every violent, impertinent and proud man".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us about distinction of such weak, poor and secluded persons who do not have any important position in society but are so eminent in the realm of piety that, out of their utmost trust in Allah, if they take an oath for something, Almighty Allah fulfills their oath. Thus, this Hadith highlights the importance of modesty and condemns pride, miserliness and lust for name and fame.

253. Sahl bin Sa`d As-Sa`idi (May Allah be pleased with him) reported: A man passed by the Prophet (PBUH), so he asked a man who was sitting near him, "What is your opinion about this man?'' That man replied: "He is one of the noblest men. By Allah he is certainly a proper person for (a girl) being given in marriage if he seeks to marry, and his recommendation is fit to be accepted if he recommends". Messenger of Allah (PBUH) remained silent. Then another man passed. Messenger of Allah (PBUH) enquired, "What is your opinion about this man?'' He replied: "O Messenger of Allah, he is one of the poor Muslims. He is not a proper person (for a girl) to be given in marriage to, and his recommendation would not be accepted if he makes one; if he speaks, he is not to be listened to.'' Messenger of Allah (PBUH) said, "He is better than the former by earthfuls".
[Al-Bukhari and Muslim].

Commentary: This Hadith contains the following two important points:

1. The distinction and greatness of such poor Muslims who are neither known in society because due to their poverty nor are they respected by people. But due to their Faith and piety, each of them is better in the sight of Allah than others. This Hadith makes it abundantly clear that what really matters with Allah is Faith and piety not lineage nor pomp and show.

2. For marriage purposes, men and women of noble character should be selected even if they are poor because at the level of religion they are on par with other Muslims. Thus, the principle underlined here is that the preference should be given to the equality in respect of religion rather than worldly wealth and richness.

254. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Prophet (PBUH) said: There was a dispute between the Hell and Jannah. The Hell said: "The haughty and proud are my inmates.'' Jannah said: "The modest and the humble are my residents". Thereupon, Allah the Exalted and Glorious (addressing Jannah) said: "You are My Mercy, through you I shall show mercy to those whom I wish". (And addressing the Hell), He said: "You are (the means) of My punishment by which I shall punish such of My slaves as I wish and each one of you would have its fill".
[Muslim].

Commentary: In this Hadith people who are termed as `modest' and `humble' are the rich in Faith and piety. They lead a life of patience and contentment. This Hadith gives glad tidings to such noble people. On the contrary, it has a threat of Hell for those who disobey Divine injunctions and are haughty and proud. Now, it is entirely one's own choice which way he goes.

The dialogue between Jannah and Hell quoted in this Hadith is not something impossible. It is not at all difficult for Allah to create in them such intelligence and consciousness which can enable them to make a discussion on the subjects mentioned in the Hadith. Thus, there is no need to offer any justification for the veracity of such Ahadith. These should, therefore, be taken as literally correct. This Hadith is mentioned in detail in Musnad Ahmad and is narrated by Abu Hurairah (May Allah be pleased with him) at greater length than in the narration of Abu Sa`id Al-Khudri (May Allah be pleased with him) quoted in Kitab-ut-Tafsir (the Book of Commentary) of Sahih Al-Bukhari.

255. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, there will be brought forth a bulky person whose value to Allah will be less than that of the wing of a mosquito".
[Al-Bukhari and Muslim].

Commentary: This Hadith means that manifestation of power and splendour, which are considered so important for people in this world, will be of no value to Allah. In the Hereafter, Allah will judge a person by his Faith, devotion and piety. It is, therefore, essential that one should concentrate on the reformation of his own heart and mind.

256. Abu Hurairah (May Allah be pleased with him) reported: A black woman (or probably a young man) used to clean the mosque. Messenger of Allah (PBUH) missed her (or him) and asked about her (or him). He was told that she (or he) had died. He (PBUH) said, "Why did you not inform me?'' (It seemed as if) they (Companions) considered the matter insignificant. Then he (PBUH) said, "Show me her (or his) grave.'' When it was shown to him, he offered (Janazah-funeral) prayer over it and said, "These graves cover those in them with darkness, and Allah illumines them for the inmates as a result of my supplication for them".
[Al-Bukhari and Muslim].

Commentary: On the basis of some other narrations, the 'Ulama' have accepted that the person mentioned in this Hadith who used to sweep the mosque was a woman known as Umm Mihjan. This Hadith highlights the following four important points:

1. The merit of keeping mosques clean.

2. The height of compassion and kindness of the Prophet (PBUH).

3. The importance of participation in the funeral prayer of virtuous persons.

4. Permission to perform funeral prayer of virtuous person after his/her burial, if one is unable to participate in it when it is performed before the burial of the deceased.

257. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Many a person with shaggy and dusty hair, dusty and driven away from doors (because of their poverty and shabby clothes) were to swear by Allah (that something would happen), Allah will certainly make it happen".
[Muslim].

258. Usamah bin Zaid (May Allah be pleased with him) reported: The Prophet (PBUH) said, "I stood at the gate of Jannah, and (I saw) that the majority of those who entered it are the poor, and the wealthy were kept confined. The inmates of the Fire had been ordered to (enter) the Fire (Hell), and I stood at the gate of Hell and saw that the majority of its inmates are women".
[Al-Bukhari and Muslim].

Commentary: The Prophet (PBUH) was told about the state of affairs in Jannah and Hell by means of Wahy (Revelation). In some cases, the conditions of the inhabitants of Jannah and Hell were shown to him by means of dreams. The Prophet (PBUH) stated that one of the main reasons for a greater number of women in Hell is that they are more ungrateful to their husbands. Women refered to in the Hadith are those who do not follow the Divine injuctions and do not discharge their duty towards Allah.

259. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "None spoke in the cradle but only three (persons), Isa (Jesus) son of Maryam (Mary), the second one was the companion of Juraij who was a pious person. Juraij took a secluded monastery for worship and confined himself in it. His mother came to him as he was busy in prayer and she called: `Juraij.' He said: `My Rubb, my mother (is calling me while I am engaged in) my prayer.' He continued with the prayer. She returned and she came on the next day and he was (still) busy in prayer. She called: `Juraij.' And he said: `My Rubb, my mother (is calling me while I am engaged) in prayer, and he continued with the prayer,' and she returned. Then on the next day she again came while he was busy in prayer and called: `Juraij.' And he said: `My Rubb, my mother (is calling me while I am engaged) in my prayer.' And he continued with the prayer. She said: `My Rubb, don't let him die until he has seen the faces of the prostitutes.' The story of Juraij and that of his meditation and prayer spread amongst Banu Israel. There was a prostitute who had been a beauty personified. She said (to the people): `If you like, I can lure him to evil.' She presented herself to him but he paid no heed (to her). She came to a shepherd who lived near the temple and she offered herself to him. He (the shepherd) had sexual intercourse with her and so she became pregnant. When she gave birth to a baby she said: `This is from Juraij.' So they came and asked Juraij to get down and demolished the temple and began to beat him. He asked them what the matter was. They said: `You have committed fornication with this prostitute and she has given birth to a baby from you.' He said: `Where is the baby?' They brought him (the baby) and then he said: `Just leave me so that I should perform prayer.' He performed prayer and when he finished, he lifted the baby in his stomach and asked him: `O boy, who is your father?' The baby answered: `He is such and such a shepherd.' So, the people turned towards Juraij, kissed him and touched him (for seeking blessing) and said: `We are prepared to construct your temple with gold.' He said, `No just, rebuild it with mud as it had been,' and so they did". (The Prophet (PBUH) continued:) "Then there was a baby who was sucking at his mother's breast when a person dressed in fine garment came on a priceless riding animal's back. His mother said: `O Allah, make my child like this one.' He (the babe) left sucking and looked at him, and said: `O Allah, don't make me like him.' He then returned to the breast and resumed sucking.'' He (Abu Hurairah (May Allah be pleased with him) said: As though I can see Messenger of Allah (PBUH) as he is illustrating the scene of his sucking milk with his forefinger in his mouth and sucking that. He (Abu Hurairah (May Allah be pleased with him)) further reported Messenger of Allah (PBUH) as saying, "There happened to pass by them a slave girl who was being beaten and they were saying: `You have committed fornication and theft.' She was saying: `Allah is enough for me and He is my Good Protector, and his mother said: `O Allah, don't make my child like her.' He left sucking looked at her and said: `O Allah! Make me like her.' It was followed by a conversation between the mother and the child. She said: `A good looking man happened to pass by and I said: O Allah, make my child like him, and you said: O Allah, don't make me like him, and there passed a girl while they were beating her and saying: You committed fornication and theft, and I said: O Allah, don't make my child like her, and you said: O Allah, make me like her.' The child said: `That man was a tyrant, and I said: O Allah don't make me like him; and they were saying about the girl: You committed fornication, whereas in fact she had not committed that and they were saying: You have committed theft, whereas she had not committed theft, so I said: O Allah, make me like her".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us of three babies who spoke in the cradle. All the three babies were from Banu Israel and their story is mentioned in Sahih Muslim in the story of Ashab-ul-Ukhdud. This Hadith proves the following points:

1. When a person is called by his parents while he is engaged in voluntary prayer, he should give priority to the call of parents.

2. A true Muslim has to pass sometimes through great trials. He must face them with patience and steadfastness because ultimately Almighty Allah helps the true believers.

3. One must avoid copying haughty people no matter how attractive their appearance is. One should try to emulate the virtuous people because true success lies in their conduct.


Benevolent Treatment towards Orphans, Girls, the Weak, the Poor and the Humble Persons

Chapter 33
Benevolent Treatment towards Orphans, Girls, the Weak, the Poor and the Humble Persons

Allah, the Exalted, says:

"And lower your wings for the believers (be courteous to the fellow-believers)". (15:88)

"And keep yourself (O Muhammad (PBUH)) patiently with those who call on their Rubb (i.e., your companions who remember their Rubb with glorification, praising in prayers, and other righteous deeds) morning and afternoon, seeking His Face, and let not your eyes overlook them, desiring the pomp and glitter of the life of the world.'' (18:28)

"Therefore, treat not the orphan with oppression. And repulse not the beggar.'' (93:9,10)

"Have you seen him who denies the Recompense? That is he who repulses the orphan (harshly). And urges not the feeding of Al-Miskin (the poor)". (107:1-3)

260. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: Six of us were with the Prophet (PBUH) when the infidels said to him: "Drive these ones away, lest they should begin to venture against us". The six were, myself, Ibn Mas`ud, a man of the Hudhail tribe, Bilal and two other men whose names I don't know. Messenger of Allah (PBUH) thought what Allah wished him to think, and Allah revealed: "And turn not away those who invoke their Rubb, morning and afternoon seeking His Face.'' (6:52)
[Muslim].

Commentary: This Hadith tells us that those people alone have value in the sight of Allah who are equipped with Faith and good deeds, no matter how humble they are in the eyes of people because of their poverty and indigence. Those who are deprived of Faith and good conduct have absolutely no value in His sight even if they hold a high status in this world.

This Hadith also exhorts the believers that criterion for respect and honour should also be Faith, not the lineage or wealth.

261. `Aidh bin `Amr Al-Muzani (May Allah be pleased with him) reported: Abu Sufyan passed by Salman, Suhaib and Bilal and some other Companions (May Allah be pleased with them). They said to him: "Did not the swords of Allah exact their due from the foes of Allah?'' Abu Bakr (May Allah be pleased with him) said to them: "Do you speak like this to the chief of the Quraish and their master?'' Then he went to the Prophet (PBUH) and related this to him. He (PBUH) said, "Abu Bakr, perhaps you have angered them. If so, you have angered your Rubb''. Abu Bakr (May Allah be pleased with him) went back to them and said: "Brothers, did I offend you?'' They replied: "No. May Allah forgive you, brother".
[Muslim].

Commentary: This Hadith enjoins the Muslims to treat one another with affection and kindness and keep their hearts free from ill-feeling and malice. If someone inadvertently says to another anything that hurts the latter's feelings, he must immediately apologize to him.

262. Sahl bin Sa`d (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "I will be like this in Jannah with the person who takes care of an orphan". Messenger of Allah (PBUH) raised his forefinger and middle finger by way of illustration.
[Al-Bukhari].

Commentary: It will be indeed a great honour to be close to the Prophet (PBUH) in Jannah. This honour will be given to those who are kind to the orphans. The Prophet (PBUH) has regarded it the `best house' in which an orphan is treated with kindness. He declared the worst home in which an orphan child is not treated with affection.

263. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who takes care of an orphan, whether he is his relative or a stranger, will be in Jannah with me like these two". The narrator, Malik bin Anas raised his forefinger and middle finger for illustration.
[Muslim].

Commentary: The Islamic system of welfare and economic security is not restricted to relatives only. It includes every orphan and needy. If Muslims put this system into practice, there will be no need for insurance - a system which is based on usury. May Allah enable the Muslims to adopt the teachings of Islam so that they will be relieved of the curse of the system of usury.

264. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "A Miskin (needy) is not the one who can be turned away with a date-fruit or two, or a morsel or two. The true Miskin is one who, despite his poverty, abstains from begging".
[Al-Bukhari and Muslim].

In another narration Messenger of Allah (PBUH) said, " A Miskin is not the one who goes round begging from people and who can be turned away with a morsel or two, or a date-fruit or two. A true Miskin is he who does not find enough to suffice him, does not disclose his poverty so that he might be given alms, and does not stand up to beg".
[Al-Bukhari and Muslim].

Commentary: This Hadith throws light on a very important problem relating to beggars who go door to door begging. They are, in fact, not poor because they accumulate a lot of wealth through small amounts which they collect every day. The real needy and poor are those who are not well-to-do, but their appearance and dress hide their poverty. Their self-respect does not permit them to make a request for help. The real purport of this Hadith is that it is the latter category of poor people, with a sense of self-respect, who should be given preference in financial help over the professional beggars because it is they who are really poor.

265. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "One who strives to help the widows and the poor is like the one who fights in the way of Allah.'' The narrator said: I think that he (PBUH) added also: "I shall regard him as the one who stands up (for prayer) without rest and as the one who observes fasts continuously".
[Al-Bukhari and Muslim].

Commentary: Here the words `widow' and `poor' have been mentioned for example only while they cover the whole range of indigent, invalid and needy people. Efforts for their care, support and welfare has been regarded equivalent to Jihad. Islam has done full justice in supporting the helpless individuals and the entire poor class of the society by elevating the status of those who undertake this noble task to the level of Mujahidun.

It makes it clear that worship is not restricted to prayers and fasting only but also covers every good deed. Thus, those who are always mindful of the weak and the poor and constantly strive for their welfare are engaged in perpetual worship.

266. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The worst food is the food of the marriage banquet from which those are left out who would like to come; and to which those are invited who refuse to come. He who rejects an invitation disobeys Allah and His Messenger".
[Muslim].

In another narration Messenger of Allah (PBUH) said, "The worst food is the food of the marriage banquet to which the rich are invited and from which the poor are left out".
[Muslim].

Commentary: Our rich class has made Walimah (marriage banquet given by the bridegroom) a highly luxurious affair and a means of displaying wealth and richness. This excessive exaggeration of a simple feast has brought in its wake many religious, moral and social evils. In its present form, it is sheer extravagance and wastage which are satanic acts and those who do it are brothers of Satan. It is such a big loss and serious threat that if our rich class is left with any sense of religion, it should immediately abandon this extravagance which is escalating day by day. Its moral disadvantage is that one invites in this function only men of his own status and not the the poor, whereas the fact is that it is the latter who deserve to be invited because of their need, and not the former. Good manners also warrant that the needy should be given priority over the affluent. Its social disadvantage is that display of wealth on such occasions creates a sense of deprivation in the poor segments of society while what Islam teaches is the uplift, material and moral help, consolation and encouragement and respectable treatment of the poor.

Instead of holding sumptuous feasts on Walimah, if the Muslims shift to one or two simple food items and invite the poor along with their friends and relatives, they not only save themselves from all the three evils mentioned above, but also prevent themselves from the accountability in the Hereafter; otherwise they will suffer loss in both the worlds.

This Hadith exhorts the Muslims to participate in the Walimah ceremony but it is the kind of feast which is simple and in accordance with the teachings of Islam.

267. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Whoever supports two girls till they attain maturity, he and I will come on the Day of Resurrection like this". Messenger of Allah (PBUH) joined his fingers illustrating this.
[Muslim].

Commentary: In the pre-Islamic era, Arabs were greatly dejected and showed resentment on the birth of a daughter, which in fact reflected the status of women in society, In order to give them their rightful place in the society, Islam taught its followers to recognize their legitimate rights. Among the injunctions which were issued in this behalf, the most important was that their proper upbringing, education and training were made a means to attain Jannah so that people did not only feel joy over the birth of sons but also felt pleasure on the birth of daughters. In this respect, Islam is the first religion which has not only ensured protection of their rights but also made full arrangements for their respect and prestige in society. For instance, they have been prohibited from having close contacts with men and for this purpose restriction of the veil has been imposed on them. Islam has emancipated them from the obligation of earning their own livelihood so that they are safe from the malicious eyes of evil-minded, and secure from the sexual lust of men, the way it is happening with women who are working side by side with men in the West. But it is a curse indeed that due to intellectual immaturity and evil trends, this freedom of women, which has disgraced and robbed them of the virtues of a chaste life, is liked by many people and they are trying that Muslim women should also imitate the style of western women. To the people of such crooked thinking, the Islamic teachings, which ensure the honour and chastity of women, appear to be the yoke of slavery and they want to release women from it.

268. `Aishah (May Allah be pleased with her) reported: A woman came to me with her two daughters. She asked me (for charity) but she found nothing with me except one date-fruit, so I gave it to her. She accepted it and then divided it between her two daughters and herself ate nothing out of that. She then got up and went out. When Messenger of Allah (PBUH) came in, and I narrated to him the story, he said, "He who is involved (in the responsibility) of (bringing up) daughters, and he is benevolent towards them, they would become protection for him against Hell-fire".
[Al-Bukhari and Muslim].

Commentary: This Hadith also tells us about the great merit and reward of kind treatment with daughters.

269. `Aishah (May Allah be pleased with her) reported: A poor woman came to me carrying her two daughters. I gave her three date-fruits. She gave a date to each of them and then she took up one date-fruit and brought that to her mouth to eat, but her daughters asked her that also. She then divided between them the date-fruit that she intended to eat. This (kind) treatment of her impressed me and I mentioned that to Messenger of Allah (PBUH) who said, 'Verily, Allah has assured Jannah for her, because of (this act) of her,'' or said, "He (SWT) has rescued her from Hell-Fire".
[Muslim].

Commentary: Besides great merit of the upbringing of daughters, this Hadith also tells us that if a wife has secured general permission from her husband about Sadaqah (alms and charity) she can offer Sadaqah, and its reward will be given to both of them. The former will be entitled to it for paying it, while the latter will be eligible to it for giving his consent to it.

270. Abu Shuraih Khuwailid bin `Amr Al-Khuza`i (May Allah be pleased with him) reported: The Prophet (PBUH) said, "O Allah, I declare inviolable the rights of two weak ones: the orphans and women".
[An-Nasa'i].

Commentary: The poor are generally treated callously in human society. Women and orphans are regular victims of this cruelty. They are deprived of their share in property to which they are entitled under the Islamic law. In some cases their properties are usurped and they are maltreated at the hands of usurpers. The Prophet (PBUH) has threatened them with serious consequences to prevent the Muslims from committing such injustice. The attitude of Muslims and the teachings of Islam in this matter are two different things. How can Islam be blamed for the attitude of Muslims? It is time Muslims should understand that Islam is getting a bad name because of their bad conduct. As a result of this they are committing a double crime. On the one hand, they are guilty of usurping others of their legitimate rights and perpetrating cruelties, and on the other, disgracing their religion. In other words, rather than preaching Islam they are creating obstacles in the way of people joining the fold of Islam. May Allah grant us guidance to follow the right path. Amin!

271. Mus`ab bin Sa`d bin Abu Waqqas (May Allah be pleased with them) reported: Sa`d considered himself better than his inferiors, so the Prophet (PBUH) said to him, "You are given help and provision because of your weak ones".
[Al-Bukhari].

Commentary: This Hadith exhorts the resourceful people not to look down upon the poor and resourceless people of the society and not to consider themselves superior to others. They should learn to respect the weak and co-operate with them because may be Almighty, Allah, is providing them because of the poor.

272. Abud-Darda (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Seek among your weak ones, for you are given provision and help only because of the weak amongst you.''
[Abu Dawud].

Commentary: This Hadith mentions the reason for the acceptance of the invocations of the weak and poor. Since their hearts are free from the worldly vices and are gifted with greater sincerity and fear of Allah, their prayers are more acceptable to Him. This point has been mentioned more explicitly in Nasa'i which says: "Almighty Allah helps the Ummah because of the prayers, worship and devotion of its weak people". (Aun-ul-Ma`bud, Vol. No. 2, chapter Al-Jihad). The words which occur in most of the manuscripts of Riyad-us-Saliheen are (Abghow fi ad-duafa') and the translation quoted here follows these words. But in the manuscripts of Abu Dawud, the word (fi) does not figure in the text. In one manuscript, however, we find the words (Abghow fi ad-duafa') which means "For me search Muslims who are weak so that I find reason to support you with their prayers".


Recommendations with regard to Women

Chapter 34
Recommendations with regard to Women

Allah, the Exalted, says:

"... and live with them honourably". (4:19)

"You will never be able to do perfect justice between wives even if it is your ardent desire, so do not incline too much to one of them (by giving her more of your time and provision) so as to leave the other hanging (i.e., neither divorced nor married). And if you do justice, and do all that is right, and fear Allah by keeping away from all that is wrong, then Allah is Ever Oft-Forgiving, Most Merciful.'' (4:129)

273. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said: "Take my advice with regard to women: Act kindly towards women, for they were created from a rib, and the most crooked part of a rib is its uppermost. If you attempt to straighten it; you will break it, and if you leave it alone it will remain crooked; so act kindly toward women".
[Al-Bukhari and Muslim].

In another narration of Al-Bukhari and Muslim, Messenger of Allah (PBUH) said: "A woman is like a rib, if you attempt to straighten it, you will break it; and if you benefit from her, you will do so while crookedness remains in her".

In another narration of Muslim, Messenger of Allah (PBUH) said: 'Woman has been created from a rib and will in no way be straightened for you; so if you want to benefit from her, you will benefit from her while crookedness remains in her. If you attempt to straighten her, you will break her, and breaking her is divorcing her".

Commentary: The words (Istawso bi' nisa') mean, take care of your wives. Whatever is the formation of the words of the Hadith, it stresses the importance of kind treatment to wives because woman is not only weaker than man by nature, but also less intelligent. On account of his being more intelligent and having greater patience, man should be more forgiving in his dealing with her. The secret of a pleasant family life lies in this advice of the Prophet (PBUH) with its emphasis on kind treatment to wives.

274. `Abdullah bin Zam`ah (May Allah be pleased with him) reported that he heard the Prophet (PBUH) giving a speech when he mentioned the she-camel (of Prophet Salih) and the man who had killed her. Messenger of Allah (PBUH) said: "When the most wicked man among them went forth (to kill the she-camel).' (91:12) signifies that a distinguished, wicked and most powerful chief of the people jumped up to kill the she-camel.'' Then he (PBUH) made mention of women and said, "Some of you beat your wives as if they were slaves, and then lie with them at the end of the day".

Then he (PBUH) admonished them against laughing at another's passing of wind, saying, "Why does any of you laugh at another doing what he does himself"
[Al-Bukhari and Muslim].

Commentary: Although Islam has permitted man, in inevitable circumstances, to rebuke his wife, it has also suggested a very wise course for it. It has suggested that first of all he should advise and preach her, and if she does not mend her ways by these means, then he should stop sleeping with her, which is a great warning for the sensible wife. If she does not improve even by this method, then he may take recourse to slight beating, but in that he must avoid her head and face. He should take recourse to beating if he thinks that it would work, otherwise it is better to avoid it. But surprisingly enough some start the process of reformation with beating and that too with great ruthlessness which has not been permitted by Islam in any case. It is this aspect which the Prophet (PBUH) has highlighted in this Hadith. He has contended that when the wife is indispensable for man and it is very difficult for him to pass night without her then why should he beat her like a slave or bondmaid? He should try to understand that she, too, has feelings and her position is like one of the two wheels of the cart of life. If at all it comes to beating her then he must keep her true status in view before taking recourse to it. He should never loose sight of her importance in conjugal life.

275. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "A believer must not hate (his wife) believing woman; if he dislikes one of her characteristics he will be pleased with another".
[Muslim].

Commentary: This Hadith also contains a very wise counsel for a happy married life. It tells us that every person has certain good qualities as well as some shortcomings. Man has been advised here to overlook the shortcomings that he does not like in his wife and appreciate her good qualities. Similarly, a woman is advised to ignore the shortcomings of her husband and admire his good qualities.

276. `Amr bin Al-Ahwas Al-Jushami (May Allah be pleased with him) reported that he had heard the Prophet (PBUH) saying on his Farewell Pilgrimage, after praising and glorifying Allah and admonishing people, "Treat women kindly, they are like captives in your hands; you do not owe anything else from them. In case they are guilty of open indecency, then do not share their beds and beat them lightly but if they return to obedience, do not have recourse to anything else against them. You have rights over your wives and they have their rights over you. Your right is that they shall not permit anyone you dislike to enter your home, and their right is that you should treat them well in the matter of food and clothing".
[At-Tirmidhi].

Commentary: 1. Here again we find justificat
ion for beating one's wife in case of her persistence in default, but it is to be done in the manner prescribed in the Hadith quoted above.

2. It is the responsibility of the wife that during the absence of her husband, besides the guarding of her own chastity, and property of her husband, she should not let in anyone who is not liked by her husband, however closely related that person be to her.

3. It is the responsibility of the husband to provide, according to his means, good food and clothes to his wife.

277. Mu`awiyah bin Haidah (May Allah be pleased with him) reported: I asked Messenger of Allah (PBUH): "What right can any wife demand of her husband?'' He replied, "You should give her food when you eat, clothe her when you clothe yourself, not strike her on the face, and do not revile her or separate from her except in the house".
[Abu Dawud].

Commentary: If it comes to temporarily severing relation with a disobedient wife to set her right, it should be done within the house and the best course for it is that one suspends the practice of sleeping with her. Some people say that this suspension should be to the extent of sleeping with her only and one should not stop speaking to her because that will increase the rift between the two. But in case of special circumstances, one can separate from her by leaving his home, as was done by the Prophet (PBUH) by shifting to upper room of his house.

278. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The believers who show the most perfect Faith are those who have the best behaviour, and the best of you are those who are the best to their wives".
[At-Tirmidhi].

279. Iyas bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Do not beat Allah's bondwomen.'' When `Umar (May Allah be pleased with him) came to Messenger of Allah (PBUH) and complained saying: "The women have become very daring towards their husbands,'' He (PBUH) gave permission to beat them. Then many women went to the family of the Messenger of Allah (wives) complaining of their husbands, and he (the Prophet (PBUH)) said, "Many women have gone round Muhammad's family complaining of their husbands. Those who do so, that is, those who take to beating their wives, are not the best among you".
[Abu Dawud].

Commentary: This Hadith tells us that those who take to beating their wives are not perfect people. The decency of manners warrants that one must refrain from beating, as is evident from the conduct of the Prophet (PBUH) who neither resorted to beating with his own hand any of his wives nor slaves nor any other. He would avenge those who transgressed the limits of Allah.

280. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "The world is but a (quick passing) enjoyment; and the best enjoyment of the world is a pious and virtuous woman".
[Muslim].

Commentary: This Hadith mentions the qualities of a virtuous woman. When her husband looks at her, she pleases him; when he orders her, she obeys him; and when he is absent, she guards herself (chastity) and the property of her husband. (Abu Dawud and Nasa'i).

This Hadith stresses the fact that if one wants success in this world and the Hereafter, he should select a pious wife. Rather than going after her beauty, lineage and wealth, one should give preference to her Faith over all other considerations. If he chooses a woman who is faithful to her Deen and strictly adheres to the Shari`ah, she would be a source of blessing for him in this life and the Hereafter.


Husband's rights concerning his Wife

Chapter 35
Husband's rights concerning his Wife

Allah, the Exalted, says:

"Men are the protectors and maintainers of women, because Allah has made one of them to excel the other, and because they spend (to support them) from their means. Therefore, the righteous women are devoutly obedient (to Allah and to their husbands), and guard in the husband's absence what Allah orders them to guard (e.g., their chastity and their husband's property).'' (4: 34)

281. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a man calls his wife to his bed, and she does not respond and he (the husband) spends the night angry with her, the angels curse her until morning".
[Al-Bukhari and Muslim].

In another narration: The Messenger of Allah (PBUH) said, "When a woman spends the night away from the bed of her husband, the angels curse her until morning".
[Al-Bukhari and Muslim].

In another narration: Messenger of Allah (PBUH) said, "By Him in Whose Hand is my life, when a man calls his wife to his bed, and she does not respond, the One Who is above the heaven becomes displeased with her until he (her husband) becomes pleased with her".
[Al-Bukhari and Muslim].

Commentary: This Hadith makes it abundantly clear that obedience of the husband is compulsory on the wife. If, in the absence of any lawful reason, she refuses to obey the orders of her husband, she will be liable to the Wrath and Curse of Allah until she returns to obedience. This Hadith has a stern warning for those women who do not care for the displeasure of their husbands because of their bad temperament, stubbornness and habit of dominating their husbands.

282. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "It is not lawful for a woman to observe (voluntary) fasting without the permission of her husband when he is at home; and she should not allow anyone to enter his house without his permission.".
[Al-Bukhari and Muslim].

Commentary: It lays down a principle for a wife that performing Nawafil (voluntary acts of worship) at the cost of the husband rights is not permissible.

283. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said, "All of you are guardians and are responsible for your subjects. The ruler is a guardian of his subjects, the man is a guardian of his family, the woman is a guardian and is responsible for her husband's house and his offspring; and so all of you are guardians and are responsible for your subjects.''
[Al-Bukhari and Muslim].

Commentary: This Hadith ordains every individual in society, whether he is a ruler or ruled citizen or even a woman who leads her life within the four walls of her house, to perform his duties within his own sphere. Not only that, every person has been made responsible to reform the state of affairs in his control and establish equity and justice because he will be held accountable for any negligence on his part in this respect.

284. Abu `Ali Talq bin `Ali (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a man calls his wife to satisfy his desire, she must go to him even if she is occupied with the oven".
[At-Tirmidhi and An-Nasa'i].

285. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "If I were to order anyone to prostrate himself before another, I would have ordered a woman to prostrate herself before her husband".
[At-Tirmidhi]

Commentary: This Hadith also shows the unique importance of the wife's obedience to her husband within her capacity and as long as he does not order her to disobey Allah.

286. Umm Salamah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "Any woman dies while her husband is pleased with her, she will enter Jannah".
[At-Tirmidhi].

Commentary: The distinction mentioned in this Hadith is for those women who abide by the duties and obligations entrusted to them by Islam and also endeavour to keep their husbands happy. Allah (SWT) will pardon their ordinary acts of omission and commission and admit them to Jannah.

287. Mu`adh bin Jabal (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Whenever a woman harms her husband in this world (that is without any due right), his wife among the (Houris in Jannah) says: `You must not harm him. May Allah destroy you! He is only a passing guest with you and is about to leave you to come to us".
[At-Tirmidhi].

Commentary: The Islamic Shari`ah commands men to treat their wives with kindness. In the same spirit it commands wives to be obedient to their husbands. She can hurt the feelings of her husband by using indecent language, immodest conduct, immoral actions and making unfair demands which are beyond his means. It is very common among women to tease and trouble their husbands by these three practices, except for pious women.

288. Usamah bin Zaid (May Allah be pleased with them) reported: The Prophet (PBUH) said, "I am not leaving behind me a more harmful trial for men than women".
[Al-Bukhari and Muslim].

Commentary: According to this Hadith, women and their beauty are the greatest and most disastrous mischief for men. This fact can be easily verified by observation. Men are generally constrained to take to corruption and unfair means of income to fulfill undue demands of their wives. If women learn to lead a simple life, men will not need much to make money through unlawful means. Similarly, it is women who compel men to hold all kinds of meaningless customs and ceremonies on marriage parties and thereby violate Islamic injunctions, and incur more expenses. If women go by the Islamic injunctions, the marriages would become a greater source of happiness and pleasure.


Sustentation of the Members of the Family

Chapter 36
Sustentation of the Members of the Family

Allah, the Exalted, says:

"The father of the child shall bear the cost of the mother's food and clothing on a reasonable basis". (2:233)

"Let the rich man spend according to his means, and the man whose resources are restricted, let him spend according to what Allah has given him. Allah puts no burden on any person beyond what He has given him". (65:7)

"And whatsoever you spend of anything (in Allah's Cause), He will replace it". (34:39)

289. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "A dinar you spend in Allah's way, or to free a slave, or as a charity you give to a needy person, or to support your family, the one yielding the greatest reward is that which you spend on your family".
[Muslim].

Commentary: A Muslim is ordained to spend first of all on the need of his wife and children and their food and clothes. There is greater reward for him in this because these expenses are obligatory on him while spending on other items is in the nature of Nawafil. Obviously, one cannot forego the former for the latter.

290. Thauban bin Bujdud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The most excellent dinar is one that a person spends on his family, and the dinar which he spends on his riding-animal in the way of Allah (in Jihad), and the dinar he spends on his companions in the way of Allah".
[Muslim].

Commentary: This Hadith relates to the same subject which has been mentioned in the previous Hadith. It stresses that men of small means should first of all spend on their own families and children. It is in fact an act of great merit. After fulfilling their needs, if he still has something left with him then he can spend it on other items in the order of precedence mentioned in the Hadith.

291. Umm Salamah (May Allah be pleased with her) reported: I asked Messenger of Allah (PBUH), "Would I be rewarded for what I spend on Abu Salamah's sons? For I can't let them go here and there (to beg people).'' Messenger of Allah (PBUH) replied, "Spend on them and you will be rewarded for what you spend on them".
[Al-Bukhari and Muslim].

Commentary: Although parents spend money on their children out of their natural love for them, Allah is so Gracious that He not only rewards them for it, but He gives it in greater proportion than what they spend on other meritorious items.

292. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported in a Hadith included in the chapter of Intention, that Messenger of Allah (PBUH) said, "Whatever you spend seeking thereby the Pleasure of Allah, will have its reward, even the morsel which you put in the mouth of your wife".
[Al-Bukhari and Muslim].

Commentary: This Hadith also highlights the point that one should feed his family and children with the intention that it has been ordained by Allah. In that case, this natural instinct will become an act of worship for which he will be rewarded.

293. Abu Mas`ud Al-Badri (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When someone spends on his family seeking his reward for it from Allah, it is counted as a charity from him".
[Al-Bukhari and Muslim].

Commentary: `Seeking his reward' means that one is supporting his family as a duty entrusted by Allah. It is also warranted by compassion for the near ones. A person who does it as a duty ordained by Allah and shows mercy to his deserving relatives to attain His Pleasure then what he spends with this intention on his children will be eligible for reward from Allah.

294. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Neglecting one's own dependents is a reason enough for a man to commit a sin".
[Abu Dawud]

The narration in Muslim is: Messenger of Allah (PBUH) said, "It is enough sin for a person to hold back the due of one whose provision is in his hand".

Commentary: This Hadith tells us that negligence in matter of maintenance of one's family is such a great sin that if a person is free from all other sins, this one alone will be enough to make him accountable before Allah. The words used in this Hadith are so comprehensive that they include servants and slaves besides family and children because he is also equally responsible for their maintenance. Thus, this Hadith makes it evident that it is the responsibility of the head of the family to provide the necessities of life to all his dependents; and any negligence on his part in this respect is a great sin.

295. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Two angels descend every morning, and one says: `O Allah, give him who spends something, in place of what he spends.' The other one says: `O Allah, give destruction to him who withholds".
[Al-Bukhari and Muslim].

Commentary: This Hadith provides justification to pray for virtuous people to get better than what they have spent, and to destroy the wealth of the niggardly who refuse to spend in the way of Allah.

296. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The upper hand is better than the lower one (i.e., the spending hand is better than the receiving hand); and begin (charity) with those who are under your care; and the best charity is that which given out of surplus; and he who asks (Allah) to help him abstain from the unlawful and the forbidden, Allah will fulfill his wish; and he who seeks self-sufficiency will be made self-sufficient by Allah".
[Al-Bukhari].

Commentary: This Hadith mentions the importance of spending in the way of Allah, preference of one's family and children over others, and chasteness and contentment. It also tells us that Allah helps one in getting what one prays for.


Spending favorite things for Allah's sake

Chapter 37
Spending favorite things for Allah's sake

Allah, the Exalted, says:

"By no means shall you attain Al-Birr (piety, righteousness - here it means Allah's reward, i.e., Jannah), unless you spend (in Allah's Cause) of that which you love.'' (3:92)

"O you who believe! Spend of the good things which you have (legally) earned, and of that which We have produced from the earth for you, and do not aim at that which is bad to spend from it.'' (2:267)

297. Anas (May Allah be pleased with him) reported: Abu Talhah (May Allah be pleased with him) was the richest among the Ansar of Al-Madinah and possessed the largest property from palm-trees, and among his possessions what he loved most, was his garden known as Bairuha' which was opposite the mosque, and Messenger of Allah (PBUH) often visited it and drank from its fresh water. When this Ayah was revealed: "By no means shall you attain Al-Birr (piety, righteousness - here it means Allah's reward, i.e., Jannah), unless you spend (in Allah's Cause) of that which you love,'' (3:92), Abu Talhah came to Messenger of Allah (PBUH) and said, "Allah says in His Book: `By no means shall you attain Al-Birr, unless you spend (in Allah's Cause) of that which you love,' and the dearest of my property is Bairuha' so I have given it as Sadaqah (charity) for Allah's sake, and I anticipate its reward with Him; so spend it, O Messenger of Allah, as Allah guides you.'' Messenger of Allah (PBUH) said, "Well-done! That is profit earning property. I have heard what you have said, but I think you should spend it on your nearest relatives.'' So Abu Talhah (May Allah be pleased with him) distributed it among nearest relatives and cousins.
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith mentions the spirit of obedience to Allah and His Prophet (PBUH) and effort which the Companions of the Prophet (PBUH) made for attaining a higher status in virtue.

2. To spend the best of one's property in the way of Allah is a sign of perfection of Faith.

3. In the matter of Sadaqat (alms giving and charity), preference must be given to one's closest relations, provided they are poor and stand in need of help, otherwise, these should be spent on other deserving people.


Urging one's kith and kin to Obey Allah and refrain from evils

Chapter 38
Urging one's kith and kin to Obey Allah and refrain from evils

Allah, the Exalted, says:

"And enjoin Salat (the prayer) on your family, and be patient in offering them (i.e., the Salat).'' (20:132)

"O you who believe! Ward off yourselves and your families against a Fire (Hell), whose fuel is men and stones.'' (66:6)

298. Abu Hurairah (May Allah be pleased with him) reported: Al-Hasan bin `Ali (May Allah be pleased with them) took one of the dates of the Sadaqah (charity) and put it in his mouth, whereupon Messenger of Allah (PBUH) said, "Leave it, leave it, throw it away. Do you not know that we do not eat the Sadaqah (charity)?''
[Al-Bukhari and Muslim].

Commentary: This Hadith emphasizes the following points:

1. Sadaqah is not lawful for the Prophet (PBUH) and his family. His family here means Banu Hashim and Banu Abdul-Muttalib.

2. Proper upbringing of children is extremely important. They must be prohibited by parents from such things which are indecent and unbecoming.

3. What is collected as Sadaqah is a national trust. The houses and institution where it is collected and kept, should take strict care of its proper utilization. It is the duty of the custodians of Sadaqat that they protect them and give them to the deserving people.

299. `Umar bin Abu Salamah (May Allah be pleased with him) reported: I was a boy under the care of Messenger of Allah (PBUH), and my hand would wander about in the dish. Messenger of Allah (PBUH) said to me "Mention Allah's Name (i.e., say Bismillah before you start eating), eat with your right hand and eat from what is near to you". I always followed this way of eating after this incident.
[Al-Bukhari and Muslim].

Commentary: This Hadith brings the following points into focus:

1. Teaching good manners and morals to the children.

2. One must start his meals with Bismillah (Begin with the Name of Allah) and take his share of food from the side of vessel in front of him, if all are eating from one vessel. If there are many varieties of fruit on the table then one can choose freely.

3. If a child makes any mistake, he should be corrected right away because that proves more effective and is engraved in his mind and heart.

300. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "All of you are guardians and are responsible for your subjects. The ruler is a guardian and responsible for his subjects; the man is a guardian of his family; the woman is guardian in her husband's house and responsible for her wards; a servant is guardian of his master's property and responsible for his ward. So all of you are guardians and are responsible for your subjects".
[Al-Bukhari and Muslim].

Commentary: This Hadith ordains every individual in society, whether a ruler or ruled or even a woman who leads her life within the four walls of her house, to perform one's duties within one's own sphere.

301. `Amr bin Shu`aib reported on his father's authority that his grandfather (May Allah be pleased with him) said: Messenger of Allah (PBUH) said, "Command your children to perform Salat (prayer) when they are seven years old, and beat them for (not offering) it when they are ten, and do not let (boys and girls) sleep together".
[Abu Dawud].

Commentary: This Hadith highlights the following points:

1. The importance of the prescribed five daily Salat (prayers).

2. When warranted by the situation, it is permissible to beat children for their proper upbringing and education. But this should not be in any case violent and aggressive. It should rather be done in a manner that the child does not suffer any physical injury and receives the right type of training. It is an absurd theory that children should be given a free hand, and leave alone the corporal punishment, they should not even be rebuked on doing something wrong. Suitable punishment is essential for their proper training and education.

3. Muslim jurists have written that like Salat, other injunctions of Shari`ah should also be instilled in the minds of children, and if possible, they should also be given practical training for their performance. For instance, they should be made to observe Saum (fast) occasionally in accordance with their age and capacity during the month of Ramadan, so that the importance of obligation of fasting is impressed on their minds in an early age. This exercise will prove very fruitful when they attain maturity. They will then be conscious that for a Muslim, fasting in the month of Ramadan is compulsory like the five daily Salat.

4. A child generally does not attain maturity at the age of ten years, but nevertheless he does acquire some sense. It is, therefore, necessary that rather than putting children in one bed they are provided separate beds once they reach the age of 10, especially children of the opposite sex.

302. Sabrah bin Ma`bad Al-Juhani (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Teach a boy Salat (the prayer) when he attains the age of seven years, and punish him (if he does not offer it) at ten".
[Abu Dawud and Tirmidhi].

The narration in Abu Dawud is: Messenger of Allah (PBUH) said, "Order a boy to perform Salat (the prayer) when he is seven years old".

Commentary: Obviously only such teachers and parents can persuade the children to perform Salat who are themselves very strict about it. In the early period of Islam, one could not even think of a Muslim who ignored it. It is very unfortunate indeed that in the present-day Muslim societies, a large majority of Muslims are careless about this fundamental religious duty. In such a state of affairs who would instruct and persuade them to perform this religious obligation of the first order?


Rights of Neighbors

Chapter 39
Rights of Neighbors

Allah, the Exalted, says:

"Worship Allah and join none with Him (in worship); and do good to parents, kinsfolk, orphans, Al-Masakin (the poor), the neighbour who is near of kin, the neighbour who is a stranger, the companion by your side, the wayfarer (you meet), and those (slaves) whom your right hands possess.'' (4:36)

303. Ibn `Umar and `Aishah (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Jibril kept recommending treating neighbours with kindness until I thought he would assign a share of inheritance".
[Al-Bukhari and Muslim].

Commentary: This Hadith illustrates the importance of nice treatment to neighbours in Islam.

304. Abu Dharr (May Allah be pleased with him) reported: Messenger of Allah (PBUH) commanded me thus, "O Abu Dharr! Whenever you prepare a broth, put plenty of water in it, and and give some of it to your neighbours".
[Muslim].

In another narration of Muslim, narrated Abu Dharr (May Allah be pleased with him): My friend, (Messenger of Allah (PBUH)) advised me saying, "Whenever you prepare a broth, put plenty of water in it, and give some to your neighbours and then give them out of this with courtesy.''

Commentary: This Hadith makes it clear that Islam does not like a Muslim to ignore his poor neighbour and eat up everything himself. It stresses that one must take care of his poor neighbours. If a person is not in a position to do more, he should at least add some water in the broth he cooks for his own food and send a portion of it to his deserving neighbour. It leads us to the conclusion that a Muslim should in no case be unmindful of his neighbour and if he is well-to-do, he should be all the more charitable to his neighbours.

305. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "By Allah, he is not a believer! By Allah, he is not a believer! By Allah, he is not a believer.'' It was asked, "Who is that, O Messenger of Allah?'' He said, "One whose neighbour does not feel safe from his evil".
[Al-Bukhari and Muslim].

Another narration of Muslim is: Messenger of Allah (PBUH) said, "He will not enter Jannah whose neighbour is not secure from his wrongful conduct".

Commentary: This Hadith reveals that hurting or troubling a neighbour is such a serious offence that it causes Allah's Wrath, and thus punishment in Hell.

306. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "O Muslim women! No one of you should consider insignificant (a gift) to give to her neighbour even if it is (a gift of) the trotters of a sheep".
[Al-Bukhari and Muslim].

Commentary: This Hadith means that neighbours should present gifts to each other. The rich men and the poor according to their means. One who is poor should not think that what he is presenting to his neighbour is not worthy of giving. Even his humble gift, provided it is presented with sincerity, will find acceptance with Allah. According to the Noble Qur'an: "So whosoever does good equal to the weight of an ant (or a small ant) shall see it.'' (99:7)

It is, however, better for a rich person to present a gift which goes well with his means. He should not give anything to his neighbour which is stale or which he does not like for himself because apart from insincerity, such a thing shows his contempt for the neighbour while gift is, in fact, a token of sincerity and brotherhood.

307. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "No one should prohibit his neighbour from placing a peg in his wall". Abu Hurairah (May Allah be pleased with him) added: Now I see you turning away from this (Sunnah), but by Allah, I shall go on proclaiming it.
[Al-Bukhari and Muslim].

Commentary: The importance of the injunction contained in this Hadith comes into prominence in localities comprising huts and tents, or at places where the two neighbours still have common walls between their houses. (In big cities each house has its own independent walls.) In any case, it is evident from this Hadith that a Muslim should be considerate of his neighbours. Islam ordains us to co-operate and sympathize with them. All Muslims are likened to a body each organ of which is linked with the other. In the light of this injunction, one can very well understand the rights of the neighbours in Islam.

308. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who believes in Allah and the Last Day let him not harm his neighbour; and he who believes in Allah and the Last Day let him show hospitality to his guest; and he who believes in Allah and the Last Day let him speak good or remain silent".
[Al-Bukhari and Muslim].

Commentary: This Hadith unfolds the fruits of Faith. One who does not have the qualities mentioned in it, is deprived of the blessings of the Faith. Faith of such a person is like a fruitless tree, or a flower without fragrance, or a body without soul.

309. Abu Shuraih Al-Khuza`i (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who believes in Allah and the Last Day, let him be kind to his neighbour; and he who believes in Allah and the Last Day, let him show hospitality to his guest; and he who believes in Allah and the Last Day, let him either speak good or remain silent".
[Muslim].

310. `Aishah (May Allah be pleased with her) reported: I said, "O Messenger of Allah (PBUH), I have two neighbours, to which of them should I send a present?'' He (PBUH) replied, "To the one whose door is nearer to you".
[Al-Bukhari]

Commentary: When a Muslim does not have the means to present gifts to his neighbours and wants to present a gift only to one of them, he should go by the principle laid down in this Hadith. The principle enunciated here is: "One who is the nearest neighbour, should have precedence over all others.''

311. `Abdullah bin `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "The best of companions with Allah is the one who is best to his companions, and the best of neighbours to Allah is the one who is the best of them to his neighbour".
[At-Tirmidhi].

Commentary: Companion is a common word which covers companions in journey and stay. Muslims are ordained to treat all of them nicely. But one's neighbour has precedence over others. Nice treatment to him is the best means to attain a distinctive place with Allah.


Kind Treatment towards Parents and establishment of the ties of Blood Relationship

Chapter 40
Kind Treatment towards Parents and establishment of the ties of Blood Relationship

Allah, the Exalted, says:

"Worship Allah and join none with Him (in worship); and do good to parents, kinsfolk, orphans, Al-Masakin (the poor), the neighbour who is near of kin, the neighbour who is a stranger, the companion by your side, the wayfarer (you meet), and those (slaves) whom your right hands possess". (4:36)

"And fear Allah through Whom you demand (your mutual rights), and (do not cut the relations of) the wombs (kinship)". (4:1)

"And those who join that which Allah has commanded to be joined (i.e., they are good to their relatives and do not sever the bond of kinship)". (13:21)

"And we have enjoined on man to be good and dutiful to his parents". (29:8)

"And your Rubb has decreed that you worship none but Him. And that you be dutiful to your parents. If one of them or both of them attain old age in your life, say not to them a word of disrespect, nor shout at them but address them in terms of honour. And lower unto them the wing of submission and humility through mercy, and say: `My Rubb! Bestow on them Your Mercy as they did bring me up when I was young". (17:23,24)

"And We have enjoined on man (to be dutiful and good) to his parents. His mother bore him in weakness and hardship upon weakness and hardship, and his weaning is in two years- give thanks to Me and to your parents". (31:14)

312. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: I asked the Prophet (PBUH) , "Which of the deeds is loved most by Allah?'' Messenger of Allah (PBUH) said, "Salat at its proper time.'' I asked, ``What next?'' He (PBUH) replied, ``Kindness to parents.'' I asked, ``What next?'' He replied, ``Jihad in the way of Allah.''
[Al-Bukhari and Muslim].

Commentary: Performance of Salat at the stated time means its performance in earliest prescribed or at least its regularity. One should not give preference to mundane affairs over it. Salat and Jihad are the two most meritorious duties of a Muslim. When nice treatment to parents is mentioned along with Salat and Jihad, it gives further importance to this injunction.

313. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "No son can repay (the kindness shown by his father) unless he finds him a slave and buys him and emancipates him".
[Muslim].

Commentary: This Hadith also brings out the eminence of parents and outstanding importance of their rights.

314. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who believes in Allah and the Last Day, let him be hospitable to his guest; and he who believes in Allah and the Last Day, let him maintain good the ties of blood relationship; and he who believes in Allah and the Last Day, must speak good or remain silent".
[Al-Bukhari and Muslim].

Commentary: This Hadith is mentioned here to highlight the importance of kindness to relatives. It enjoins considerate treatment to relatives and stresses that one should maintain relationship with them at all costs. So much so that even if they misbehave and sever relations with him, one should make efforts to restore not only relationship with them but also their rights. This is what kindness to relatives really means. Islam has laid great stress on it. Relatives include both paternal and maternal relatives.

315. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah created all the creatures and when He finished the task of His creation, Ar-Rahm (ties of relationship) said: `(O Allah) at this place I seek refuge with You against severing my ties.' Allah said: `That I treat with kindness those who treat you with kindness and sever ties with those who sever ties with you.' It said: `I am satisfied.' Allah said: `Then this is yours". Then Messenger of Allah (PBUH) said, "Recite this Ayah if you like: `Would you then, if you were given the authority, do mischief in the land, and sever your ties of kinship? Such are they whom Allah has cursed, so that He has made them deaf and blinded their sight". (47:22,23).
[Al-Bukhari and Muslim].

The words in Al-Bukhari are: Messenger of Allah (PBUH) said, "Allah (SWT) says: `He who maintains good ties with you, I maintain good ties with him; and he who severs your ties, I sever ties with him".

Commentary: This Hadith also stresses the importance of proper treatment with relatives for the reason that this is a special means of attaining the nearness and Mercy of Allah. A conduct contrary to it, that is to say, devouring the rights of relatives and continuation of estrangement with them, is the cause of displeasure and Wrath of Allah.

316. Abu Hurairah (May Allah be pleased with him) reported: A person came to Messenger of Allah (PBUH) and asked, "Who among people is most deserving of my fine treatment?'' He (PBUH) said, "Your mother". He again asked, ``Who next?'' "Your mother", the Prophet (PBUH) replied again. He asked, "Who next?'' He (the Prophet (PBUH)) said again, "Your mother.'' He again asked, "Then who?'' Thereupon he (PBUH) said,'' Then your father.''

In another narration: "O Messenger of Allah! Who is most deserving of my fine treatment?'' He (PBUH) said, "Your mother, then your mother, then your mother, then your father, then your nearest, then nearest".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that the rights of the mother are three times more important than that of the father for the reasons that:

1 She is weaker than the father.

2. The following three troubles are borne exclusively by the mother while the father does not share them with her:

a) She carries the baby in her womb for nine months,

b) The labor pain which she suffers.

c) Two years' period of suckling which disturbs her sleep at night and affects her health. She has also to be very cautious in her food for the welfare of the baby.

317. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "May he be disgraced! May he be disgraced! May he be disgraced, whose parents, one or both, attain old age during his life time, and he does not enter Jannah (by rendering being dutiful to them)".
[Muslim].

Commentary: The word ``Ragham'' means soil. When a person's nose is soiled, it is a mark of his extreme humiliation. This metaphor carries a curse for an unfortunate person who does not win the pleasure of Allah by serving and obeying his parents. In fact, it is a malediction as well as a prediction of someone's inauspicious end. Service of parents is essential at every stage of their life - whether they are young or old. But this Hadith mentions their old age for the reason that in that period of their life they stand in greater need of care and service. It is a very callous offense to leave them at the mercy of circumstances when they are old, senile and depend on others for their needs. To neglect them at that stage is a major sin for which one deserves Hell-fire.

318. Abu Hurairah (May Allah be pleased with him) reported: A man said to Messenger of Allah (PBUH): "I have relatives with whom I try to keep the ties of relationship but they sever relations with me; and whom I treat kindly but they treat me badly, I am gentle with them but they are rough to me.'' He (PBUH) replied, "If you are as you say, it is as if you are feeding them hot ashes, and you will be with a supporter against them from Allah as long as you continue to do so".
[Muslim].

Commentary: This Hadith has three important lessons:

First, the misbehaviour of one's relative is no justification for the misbehaviour of another, let alone the severing of relations on that account.

Second, the person who treats his relatives nicely in all events and circumstances is blessed by Allah Who will send from heaven helpers to support him.

Third, the consequence of denying compassion and kindness to relatives is as woeful as the eating of hot ashes.

319. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who desires ample provisions and his life be prolonged, should maintain good ties with his blood relations". [Al-Bukhari and Muslim].

Commentary: One who is benevolent and compassionate towards one's own relatives, stands to gain at least two definite advantages in this world besides the reward in the next. These two advantages are the increase in his subsistence and longevity of life.

Increase in subsistence means that Almighty Allah will increase the quantity of his worldly goods or his means of subsistence will be blessed by Him. Similar is the case of longevity of life. The life of such person is either actually increased (in terms of years) or his life is graced with the Blessings of Allah. Both interpretations are correct.

320. Anas (May Allah be pleased with him) reported: Abu Talhah (May Allah be pleased with him) was the richest among the Ansar of Al-Madinah and possessed the largest property; and among his possessions what he loved most was his garden known as Bairuha' which was opposite the mosque, and Messenger of Allah (PBUH) often visited it and drank from its fresh water. When this ayah was revealed: "By no means shall you attain Al-Birr (piety, righteousness - here it means Allah's reward, i.e., Jannah), unless you spend (in Allah's Cause) of that which you love,'' (3:92). Abu Talhah came to Messenger of Allah (PBUH), and said: "Allah says in His Book: `By no means shall you attain Al-Birr, unless you spend (in Allah's Cause) of that which you love,' and the dearest of my property is Bairuha' so I have given it as Sadaqah (charity) for Allah's sake, and I anticipate its reward with Him; so spend it, O Messenger of Allah, as Allah guides you". Messenger of Allah (PBUH) said, "Well-done! That is profitable property. I have heard what you have said, but I think you should spend it on your nearest relatives.'' So Abu Talhah distributed it among his nearest relatives and cousins.
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned in the chapter which deals with the merits of spending of what one loves best in the way of Allah. It has been repeated here in support of benevolence to the relatives. Its repetition makes it clear that while spending in the way of Allah, one should always first of all consider his relatives and help those of them who deserve assistance. After fulfilling their needs, if anything remains then it can be given to others.

321. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: A man came to the Prophet (PBUH) of Allah and said, "I swear allegiance to you for emigration and Jihad, seeking reward from Allah.'' He (PBUH) said, "Is any of your parents alive?'' He said, "Yes, both of them are alive.'' He (PBUH) then asked, "Do you want to seek reward from Allah?'' He replied in the affirmative. Thereupon Messenger of Allah (PBUH) said, "Go back to your parents and keep good company with them".
[Al-Bukhari and Muslim].

In another narration it is reported that a person came to Messenger of Allah (PBUH) and sought his permission to participate in Jihad. The Prophet (PBUH) asked, "Are your parents alive?'' He replied in the affirmative. The Prophet a(PBUH) said, "(You should) consider their service as Jihad.''

Commentary: Under normal circumstances, Jihad is Fard Kifayah (collective duty -- which means that if some people observe it, the rest of the Muslims will be exempted from its obligation). In such circumstances permission of parents to participate in Jihad is necessary because their service is Fard-ul-`ain (individual duty -- an injunction or ordinance, the obligation of which extends to every Muslim in person), and the former cannot be preferred to the latter. This Hadith explains such a situation. In certain circumstances, however, Jihad becomes Fard-ul-`ain and in that case permission of the parents to take part in Jihad is not essential because then every Muslim is duty-bound to take part in it.

322. `Abdullah bin `Amr Al-`as (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The person who perfectly maintains the ties of kinship is not the one who does it because he gets recompensed by his relatives (for being kind and good to them), but the one who truly maintains the bonds of kinship is the one who persists in doing so even though the latter has severed the ties of kinship with him".
[Al-Bukhari].

Commentary: This Hadith makes clear the essentials of kindness to relatives. Those kinsmen who respect and honour you, would obviously be treated by you fairly. It goes without saying that people usually reciprocate sentiments showed to them. But this is not maintaining the ties of kinship but kindness for kindness. On the opposite side, there is a kinsman who is rough and rude and is always bent upon severing relation with you, but you tolerate his excesses with patience and perseverance, return his harshness with politeness, maintain relationship with him in spite of all his efforts to break it, then what you are exercising is maintaining the ties of kinship. This is what Islam actually demands from a Muslim. But this is the excellence of Faith which one must try to attain. There is nothing remarkable in exchanging dry smiles.

323. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "The bond of relationship is suspending from the Throne, and says: `He who keeps good relations with me, Allah will keep connection with him, but whosoever severs relations with me, Allah will sever connection with him".
[Al-Bukhari and Muslim].

Commentary: The discourse on compassion to relatives mentioned in this Hadith is not impossible because Almighty Allah is Omnipotent and is thus Capable of doing what He likes. He can create perception, consciousness and power of speech in everything. An instance of it has already been mentioned in a Hadith quoted earlier.

324. It has been narrated that Maimuna bint Al-Harith (May Allah be pleased with her) had set free a slave-girl without the Prophet's permission. When her turn came (the Prophet (PBUH) used to visit his wives in turns), she made mention of that to him saying, "Did you know I have set slave-girl free?'' He said, "Have you, indeed?'' She replied, "Yes''. He (PBUH) then remarked, "Had you given her to your maternal uncles, you would have your reward increased".
[Al-Bukhari and Muslim].

Commentary: This Hadith brings out the following two points:

1) A woman is free to spend anything of her own property without the permission of her husband, but not of things owned by her husband.

2) To spend on the needy relatives is more meritorious than to set a slave free because to set a slave free is a Sadaqah (charity) only, while paying Sadaqah to a kinsman has a double merit as it carries the reward of Sadaqah as well as "maintaining the ties of kinship.''

325. Asma' bint Abu Bakr As-Siddiq (May Allah be pleased with her) said: My mother came to me while she was still a polytheist, so I asked Messenger of Allah (PBUH), "My mother, who is ill-disposed to Islam, has come to visit me. Shall I maintain relations with her?'' He (PBUH) replied, "Yes, maintain relations with your mother".
[Al-Bukhari and Muslim].

Commentary: The woman mentioned in this Hadith had come from Makkah to Al-Madinah. What this Hadith signifies is that it is essential to be kind to parents even if they are Mushrikun (polytheists) and Kuffar (disbelievers). This has also been clearly ordained in the Noble Qur'an: ``... but behave with them in the world kindly". (31:15).

326. Zainab Ath-Thaqafiyah (May Allah be pleased with her) the wife of `Abdullah bin Mas`ud (May Allah be pleased with him) reported: When Messenger of Allah (PBUH) told the women that they should give Sadaqah (charity), even if it should be some of their jewellery, I returned to `Abdullah bin Mas`ud and said, "You are a man who does not possess much, and Messenger of Allah (PBUH) has commanded us to give Sadaqah. So go and ask him if giving to you will serve the purpose; otherwise, I shall give it to someone else.'' He asked me that I should better go myself. I went and found a woman of the Ansar at the door of Messenger of Allah (PBUH), waiting to ask a similar question as mine. The Prophet (PBUH) was endowed with dignity, and so we could not go in. When Bilal (May Allah be pleased with him) came out to us, we said to him: "Go to Messenger of Allah (PBUH) and tell him that there are two women at the door who have come to ask him whether it will serve them to give Sadaqah to their husbands and to orphans who are in their charge, but do not tell him who we are. Bilal (May Allah be pleased with him) went in and asked him, and Messenger of Allah (PBUH) asked him who the women were. When he told him that they were a woman of the Ansar and Zainab, he asked him which Zainab it was, and when he was told it was the wife of `Abdullah bin Mas`ud, he (PBUH) said, "They will have a double reward, one for maintaining the ties of kinship and another for Sadaqah".
[Al-Bukhari and Muslim].

Commentary:

1. We learn from this Hadith that a woman can also give Sadaqah and Zakat to her husband, provided he is poor. But its opposite is not permissible. That is to say, a husband cannot pay Zakat to his wife because he is responsible for her maintenance while wife is not obliged to do it for her husband. So, the principle deduced from it is that one who is bound to pay Zakat under the Shari`ah is not permitted to pay it to his dependents.

2. In case of need, a woman can go out of her house subject to the condition that she observes the restriction of the veil prescribed by the Shari`ah in this behalf.

3) Like men, women should also take, keen interest in religious matters. They should not feel shy of doing it.

327. Abu Sufyan Sakhr bin Harb (May Allah be pleased with him) mentioned Heraclius in a long Hadith and said: Heraclius asked me, "What does this Prophet (PBUH) teach you?'' I said, "He orders us to worship Allah Alone and not to associate a thing with Him in worship, to discard what our ancestors said, to perform the Salat (prayer), speak the truth, and maintain the ties of kinship".
[Al-Bukhari and Muslim].

Commentary: Besides Tauhid (Oneness of Allah), this Hadith enjoins punctuality in Salat and excellence of character. In all the forms of worship, Salat is the most important, and the best in the nobility of character is righteousness. After professing faith in Tauhid and belief that Muhammad (PBUH) is the last Prophet of Allah, a Muslim should be punctual in Salat and make himself a model of excellent character.

328. Abu Dharr (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "You will soon conquer a land where people deal with Qirat.''

And according to another version: Messenger of Allah (PBUH) said, "You will soon conquer Egypt where Al-Qirat is frequently mentioned. So when you conquer it, treat its inhabitants well. For there lies upon you the responsibility because of blood ties or relationship (with them)".
[Muslim].

Commentary: In this Hadith, the Prophet (PBUH) has urged his Companions to treat the Egyptians nicely for the reason of maintaining the ties of kinship and for the fact that Egypt was the country of his in-laws (Mariyah, the mother of Ibrahim, and one of the Prophet's wives was from that place). This is why this Hadith has been included in the present chapter which deals with the subject of maintaining the ties of kinship. This Hadith is also a Prophecy of the Prophet (PBUH) due to the fact that the prophecy he had made came true. A short time after his death, Egypt became part of the Muslim empire.

329. Abu Hurairah (May Allah be pleased with him) reported: When this Verse was revealed: "And warn your tribe (O Muhammad (PBUH)) of near kindred". (26:214) Messenger of Allah (PBUH) called the Quraish; when they gathered, he said to them: "O sons of `Abd Shams; O sons of Ka`b bin Lu'ai, rescue yourselves from the Fire! O sons of Murrah bin Ka`b, rescue yourselves from the Fire! O sons of `Abd Manaf, rescue yourselves from the Fire! O sons of `Abdul-Muttalib, rescue yourselves from the Fire! O Fatimah, rescue yourself from the Fire, for I have no power (to protect you) from Allah in anything except that I would sustain relationship with you".
[Muslim].

Commentary:
1. This Hadith tells us that lineage in the Hereafter will not help anybody. So much so that even one's relationship with Messenger of Allah (PBUH) shall not carry any weight on that day. The only thing that will then help in salvation will be one's good deeds. People for whom the Prophet (PBUH) and pious men will intercede will be believers with some sins in their account and not the disbelievers devoid of Faith and good actions. Neither will anybody intercede for the infidels, nor will the infidels find salvation.

2. In preaching religion, priority must be given to one's own close relatives. They deserve it more than anyone else, and for this reason Divine injunctions should be first of all conveyed to them.

3. Even if a Muslim's relatives are pagans and polytheists, their rights of kinsmen and the demands of "maintaining the ties of kinship'' enjoined by Islam must be fulfilled. The first and foremost demand of their rights is that they should be invited to the right path so that they will be saved from Hell-fire.

330. Abu Abdullah `Amr bin Al-`as (May Allah be pleased with them) said: I heard Messenger of Allah (PBUH) saying openly not secretly, "The family of so-and-so (i.e., Abu Talib) are not my supporters. My supporter is Allah and the righteous believing people. But they (that family) have kinship (Rahm) with whom I will maintain good the ties of kinship".
[Al-Bukhari and Muslim].

Commentary: Messenger of Allah (PBUH) had made it absolutely clear that although such persons were his near relatives, he did not have any affection and friendship with them because there cannot be any affection between a pagan and a Muslim. Friendship and affection can only be for Allah and those who have faith in Him. One can accommodate the non-Muslim relatives to the extent permitted by "maintaining the ties of kinship'', provided they are not at war with the Muslims.

331. Abu Ayyub Khalid bin Zaid Al-Ansari (May Allah be pleased with him) reported: A man came to Messenger of Allah (PBUH) and said, "Direct me to a deed which will admit me to Jannah and take me away from the Fire". The Messenger of Allah (PBUH) said, "Worship Allah and associate no partner with Him, perform As-Salat, pay Zakat, and maintain the ties of kinship".
[Al-Bukhari and Muslim].

Commentary: This Hadith indicates the actions which constitute the means to attain Jannah and salvation from Hell. Thus, it makes evident that Jannah cannot be achieved by wishful thinking. One cannot get it without Faith and good deeds. In the absence of these two factors, intercession of any person will be of no avail.

332. Salman bin `Amir (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When you break fast, you should do it with a date-fruit for there is blessing in it, and if you do not find a date-fruit, break it with water for it is pure.'' Messenger of Allah (PBUH) added: "Charity towards a poor person is charity, and towards a relation is both charity and maintaining the ties (of kinship)".
[Tirmidhi].

Commentary: We learn two points from this Hadith:

Firstly, it is more rewarding to break the fast with date-fruit or water. Secondly, payment of Sadaqah to one's poor relatives carries a double reward.

333. Ibn `Umar (May Allah be pleased with them) reported: I had a wife whom I loved but `Umar (May Allah be pleased with him) disliked her. He asked me to divorce her and when I refused, `Umar (May Allah be pleased with him) went to Messenger of Allah (PBUH) and mentioned the matter to him. Messenger of Allah (PBUH) asked me to divorce her.
[At-Tirmidhi and Abu Dawud].

Commentary: If parents' order to divorce one's wife is based on the principles of Shari`ah and morality, it must be obeyed, as is evident from this Hadith. If their order is founded on other factors, then one should try to convince them politely so that they agree with one's view on the issue. Here Ibn `Umar (May Allah be pleased with him) loved his wife for love's sake, but his father `Umar bin Khattab (May Allah be pleased with him) disliked her basing his decision on religious grounds. This is why the Prophet (PBUH) ordered Ibn `Umar to obey his father.

334. Abud-Darda' (May Allah be pleased with him) reported: A man came to me and said, "I have a wife whom my mother commands me to divorce". I replied him that I had heard Messenger of Allah (PBUH) saying, "A parent is the best of the gates of Jannah; so if you wish, keep to the gate, or lose it.''
[At-Tirmidhi and Ibn Majah].

Commentary: The word "Walid,'' applies to mother as well as father. As the word "Walidain'' is a dual form and covers mother and father both; similarly the noun "father'', also applies to both. This Hadith also stresses that obedience of parents and submission to their order must have preference over the love for the wife as long as this order of theirs is fair and just.

335. Al-Bara' bin `Azib (May Allah be pleased with them) reported: I heard the Prophet (PBUH) saying: "A mother's sister is equivalent to (real) mother (in status)".
[At-Tirmidhi]

Commentary: This Hadith tells us that one should be as respectful to one's aunt (mother's real sister) as one is to mother, as it is a virtue as well as "a form of maintaining the ties of kinship".


Prohibition of Disobeying Parents and severance of Relations

Chapter 41
Prohibition of Disobeying Parents and severance of Relations

Allah, the Exalted, says:

"Would you then, if you were given the authority, do mischief in the land, and sever your ties of kinship? Such are they whom Allah has cursed, so that He has made them deaf and blinded their sight.'' (47:22,23)

"And those who break the Covenant of Allah, after its ratification, and sever that which Allah has commanded to be joined (i.e., they sever the bond of kinship and are not good to their relatives), and work mischief in the land, on them is the curse (i.e., they will be far away from Allah's Mercy), and for them is the unhappy (evil) home (i.e., Hell).'' (13:25)

"And your Rubb has decreed that you worship none but Him. And that you be dutiful to your parents. If one of them or both of them attain old age in your life, say not to them a word of disrespect, nor shout at them but address them in terms of honour. And lower unto them the wing of submission and humility through mercy, and say: `My Rubb! Bestow on them Your Mercy as they did bring me up when I was young.''' (17:23,24)

336. Abu Bakrah Nufai` bin Al-Harith (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Shall I not inform you of the biggest of the major sins?'' Messenger of Allah (PBUH) asked this question thrice. We said, "Yes, O Messenger of Allah. (Please inform us.)". He said, "Ascribing partners to Allah, and to be undutiful to your parents". Messenger of Allah (PBUH) sat up from his reclining position and said, "And I warn you against giving forged statement and a false testimony; I warn you against giving forged statement and a false testimony". Messenger of Allah (PBUH) kept on repeating that warning till we wished he would stop.
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions some of the major sins. A major sin is one against which there is a serious warning in the Noble Qur'an and Hadith. When disobedience to parents is mentioned along with Shirk (polytheism), it makes the fact evident that both of these are very serious sins. Similar is the case of telling a lie and false testimony, which in the incident mentioned in this Hadith made Messenger of Allah (PBUH) to leave his pillow and sit attentively. It indicates that the latter two are serious. May Allah protect all Muslims from all such sins.

337. Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: The Prophet (PBUH) said, "(Of the) major sins are: to ascribe partners to Allah, disobey parents, murder someone, and to take a false oath (intentionally)".
[Al-Bukhari].

Commentary: There are many more major sins which have been enlisted and discussed at length by Muhaddathun in independent volumes, such as Az-Zawajir `an iqtraf-al-Kaba'ir, Kitab-al-Kaba'ir by Adh-Dhahabi. This Hadith mentions some of the major sins enumerated by the Prophet (PBUH) on a particular occasion. We can also say that the sins mentioned here are some of the most serious among the major sins.

338. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "It is one of the gravest sins to abuse one's parents.'' It was asked (by the people): "O Messenger of Allah, can a man abuse his own parents?'' Messenger of Allah (PBUH) said, "He abuses the father of somebody who, in return, abuses the former's father; he then abuses the mother of somebody who, in return, abuses his mother".
[Al-Bukhari and Muslim].

Another narration is: Messenger of Allah (PBUH) said, "One of the major sins is to curse one's parents". It was submitted: "O Messenger of Allah! How can a man curse his own parents?'' He (PBUH) said, "When someone curses the parents of another man who in return abuses the former's father; and when someone abuses the mother of another man who in return abuses his mother.''

Commentary: We learn from this Hadith that one should not abuse anyone's parents, because in the event, he is paid in the same coin, he will be responsible for disgracing his own parents.

339. Abu Muhammad Jubair bin Mut`im (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The person who severs the bond of kinship will not enter Jannah".
[Al-Bukhari and Muslim].

Commentary: This Hadith poses a serious threat to those who violate the Divine injunctions of maintaining good ties of kinship. In spite of such a serious warning, this major sin is very common in our present-day society. The purpose of this warning is that Muslims prevent themselves from it. May Allah save us from it.

340. Abu 'Isa Al-Mughirah bin Shu`bah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah has forbidden you: disobedience to your mothers, to withhold (what you should give), or demand (what you do not deserve), and to bury your daughters alive. And Allah dislikes idle talk, to ask too many questions (for things which will be of no benefit to one), and to waste your wealth".
[Al-Bukhari and Muslim].


Excellence in doing Good to the Friends of Parents and other Relatives

Chapter 42
Excellence in doing Good to the Friends of Parents and other Relatives

341. `Abdullah bin `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The finest act of goodness is that a person should treat kindly the loved ones of his father".
[Muslim].

342. `Abdullah bin Dinar reported: `Abdullah bin `Umar (May Allah be pleased with them) met a bedouin on his way to Makkah, he greeted him, offered him to mount the donkey he was riding and gave him the turban he was wearing on his head. Ibn Dinar said to him: "May Allah make you pious! Bedouins can be satisfied with anything you give them (i.e., what you have given the bedouin is too much). Upon this, `Abdullah bin `Umar said, the father of this man was one of `Umar's friends whom he loved best, and I heard Messenger of Allah saying, "The finest act of goodness is the good treatment of someone whom one's father loves".

Another narration goes: When `Abdullah bin `Umar (May Allah be pleased with them) set out to Makkah, he kept a donkey with him to ride when he would get tired from the riding of the camel, and had a turban which he tied round his head. One day, as he was riding the donkey, a bedouin happened to pass by him. He (`Abdullah bin `Umar) said, "Aren't you so-and-so?'' The bedouin said, "Yes". He (`Abdullah bin `Umar) gave him his donkey and his turban and said, "Ride this donkey, and tie this turban round your head". Some of his companions said, "May Allah forgive you, you gave to this bedouin the donkey which you enjoyed to ride for change, and the turban which you tied round your head".`Abdullah bin `Umar said,"I heard Messenger of Allah (PBUH) saying, `The finest act of goodness is the kind treatment of a person to the loved ones of his father after his death,' and the father of this person was a friend of `Umar (May Allah be pleased with him).
[Muslim].

Commentary: This Hadith teaches that after the death of one's parents, one should maintain contact with their friends and treat them nicely. Besides being a great virtue it is warranted by the needs for showing compassion to relatives. To forget friends of one's parents and break contact with them is condemned by the Shari`ah.

343. Abu Usaid Malik bin Rabi`ah As-Sa`idi (May Allah be pleased with him) reported: We were sitting with Messenger of Allah (PBUH) when a man of Banu Salamah came to him and asked, "O Messenger of Allah! Is there any obedience to parents left that I can show to them after their death?'' He (PBUH) replied, "Yes, to pray for them, to supplicate for their forgiveness, to fulfill their promises after their death, to maintain the ties of kinship which cannot be maintained except through them, and honour their friends.''
[Abu Dawud].

Commentary: We learn from this Hadith that one should consider the life of one's parents a blessing because their life provides one with an opportunity to serve them wholeheartedly, which is ordained by Allah. If one wants to be nice to them after their death, one should adopt the methods mentioned in this Hadith. It needs to be noted that it does not mention the ceremonies like recitation of the Noble Qur'an on the third, seventh and fortieth day after the death of a person, in vogue in our society. All these methods of conveying the reward of virtuous deeds or rites are wrong for the reason that they are neither helpful for the dead nor the living. What really benefits the dead as well as living, is prayer and begging forgiveness from Allah. In this Hadith, these have been regarded as acts of beneficence for the deceased parents. It clearly means that the children will be rewarded for the virtuous acts they do for their parents and the status of the deceased parents will also be elevated in the next world. The acceptance of the prayer in favour of the deceased parents is also confirmed from that Hadith also which tells that death brings to an end all the activities, except the following:

Firstly, an ongoing Sadaqah (Sadaqah Jariyah); like the digging of a well, the building of a mosque, etc.,

Secondly, knowledge which benefits Muslims;

Thirdly, prayers of virtuous offspring.

344. `Aishah (May Allah be pleased with her) reported: I never felt jealous of any of the wives of the Prophet (PBUH) as much as I did of Khadijah (May Allah be pleased with her), although I have never seen her, but the Prophet (PBUH) used to mention her very often. Whenever he slaughtered a sheep, he would cut it into pieces and send them to the women friends of Khadijah (May Allah be pleased with her). When I sometimes said to him: "You treat Khadijah in such a way as if there is no woman on earth except her". He (PBUH) would say, "Khadijah was such and such (commending her and speaking well of her), and I had children from her".
[Al-Bukhari and Muslim].

Another narration is: And if he (PBUH) slaughtered a sheep, he would send meat to the friends of Khadijah (May Allah be pleased with her) as a present as much as would suffice them.

Another narration is: When a sheep was slaughtered, he (PBUH) would say, "Send this meat to Khadijah's friends.'' Once, Halah bint Khuwailid (May Allah be pleased with her), sister of Khadijah (May Allah be pleased with her), sought permission of Messenger of Allah (PBUH) to enter. He recognized and recalled to his mind the manner of Khadijah (May Allah be pleased with her) and was deeply moved. He said, "O Allah, she must be Halah bint Khuwailid".
[Al-Bukhari and Muslim].

Commentary: This Hadith brings out the following five points:

1. A brief reference to the great qualities of Khadijah (May Allah be pleased with her).

2. The love that Messenger of Allah (PBUH) had for Khadijah (May Allah be pleased with her) because of her great qualities.

3. Reference to the kindness which Messenger of Allah (PBUH) continued to show to the women who were close to Khadijah (May Allah be pleased with her).

4. Expression of the sentiments which the remembrance of some deceased friend brings with it. These sentiments can be pleasing as well as painful.

345. Anas bin Malik (May Allah be pleased with him) reported: I set out along with Jarir bin `Abdullah Al-Bajali (May Allah be pleased with him) on a journey and he served me. I said to him: "Don't do that.'' Thereupon, he said, "I have seen the Ansar doing this with Messenger of Allah (PBUH), and I swore by Allah, whenever I accompany anyone of the Ansar, I would serve him".
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith gives a fair idea of the love that the Companions of the Prophet (PBUH) had for him. It was so profound that they regarded it a great honour to serve the servants of the Prophet (PBUH), even if they were younger in age.

2. It also tells of the hospitality of the Companions of the Prophet (PBUH). They neither felt any hesitation in showing respect to their youngers nor were they shy of serving them.

3. The Companions of Messenger of Allah (PBUH) had a friendly, fraternal and faithful relationship with one another and it was founded on a common bond in them - the gratitude for the Prophet (PBUH).


Showing reverence to the Family of Allah's Messenger (pbuh)

Chapter 43
Showing reverence to the Family of Allah's Messenger (pbuh)

Allah, the Exalted, says:

"Allah wishes only to remove Ar-Rijs (evil deeds and sins) from you, O members of the family (of the Prophet (PBUH)), and to purify you with a thorough purification.'' (33:33)

"And whosoever honours the Symbols of Allah, then it is truly from the piety of the heart.'' (22:32)

346. Yazid bin Haiyan reported: I went along with Husain bin Sabrah and `Amr bin Muslim to Zaid bin Arqam (May Allah be pleased with them) and, as we sat by his side, Husain said to him, "Zaid, you acquired great merits, you saw Messenger of Allah (PBUH), listened to him talking, fought by his side in (different) battles, and offered Salat (prayer) behind him. Zaid, you have indeed earned great merits. Could you narrate to us what you heard from Messenger of Allah (PBUH)?'' Zaid said, "By Allah! I have grown old and have almost spent up my age and I have forgotten some of the things which I remembered in connection with Messenger of Allah (PBUH), so accept what I narrate to you, do not compel me to narrate what I fail to narrate". He then said, "One day Messenger of Allah (PBUH) stood up to deliver a Khutbah at a watering place known as Khumm between Makkah and Al-Madinah. He praised Allah, extolled Him, and exhorted (us) and said, `Amma Ba`du. O people, I am a human being. I am about to receive a messenger (the angel of death) from my Rubb and I will respond to Allah's Call, but I am leaving with you two weighty things: the first is the Book of Allah, in which there is right guidance and light, so hold fast to the Book of Allah and adhere to it.' He exhorted (us to hold fast) to the Book of Allah and then said, `The second is the members of my household, I remind you (to be kind) to the members of my family. I remind you (to be kind) to the members of my family. Husain said to Zaid, "Who are the members of his household, O Zaid? Aren't his wives the members of his family?'' Thereupon Zaid said, "His wives are the members of his family. (But here) the members of his family are those for whom Zakat is forbidden". He asked, "Who are they?'' Zaid said, "Ali and the offspring of `Ali, `Aqil and the offspring of `Aqil and the offspring of Ja`far and the offspring of `Abbas.'' Husain asked, "For all of them the acceptance of Zakat is forbidden?'' Zaid (May Allah be pleased with him) said, "Yes".
[Muslim].

Another narration is: Messenger of Allah (PBUH) said, "I am leaving behind me two weighty things. One of them is the Book of Allah; that is the strong rope of Allah. Whosoever holds firmly to it, will be the guided, and whosoever leaves it goes astray".

Commentary: This Hadith brings out the following points:

1. Messenger of Allah (PBUH) was a human being. He too was subject to the inevitable law of death.

2. It stresses upon the establishment of a firm bond with the Book of Allah (the Qur'an) and lays emphasis on showing respect and honour to the members of the Prophet's family.

3. The members of the Prophet's family are classified into two categories:

Firstly, wives of Messenger of Allah (PBUH) or Mothers of the believers. This is established from the categorical Verses of the Noble Qur'an.

Secondly, persons who have close relationship with Messenger of Allah (PBUH) . They are Banu Hashim and Banu Abdul-Muttalib and include descendants of `Ali, `Aqil, Ja`far, `Abbas and Harith (May Allah be pleased with them). Sadaqah is unlawful for the latter category.

347. Ibn `Umar (May Allah be pleased with them) reported: Abu Bakr (May Allah be pleased with him) said: "Show reverence to Messenger of Allah (PBUH) by honouring the members of his family.''
[Al-Bukhari].

Commentary: In this Hadith, the love and respect for the members of the Prophet's (PBUH) family has been tied with the love and respect of the Prophet (PBUH). In other words, a person who loves and respects the descendants of the Prophet (PBUH) will be deemed to be a lover and admirer of the Prophet (PBUH). On the contrary, one whose heart is devoid of the love of the descendants of the Prophet (PBUH), will be considered devoid of the love and respect of the Prophet (PBUH). But love and respect here does not mean that they are taken for sinless persons and their status is exaggerated beyond reason, as is the case with the Shiites. Their whole religious thinking is founded on the exaggeration of the qualities of the members of the family of Messenger of Allah (PBUH) and they have exhausted their imagination in proving them sinless. While their love and respect lies in adopting the noble features of their character and cherishing their piety. Their love and respect does not lie in sentimental attachment with a particular family and exaggerating its praise beyond all limits.


Revering the Scholars and Elders, Preferring them to others and raising their Status

Chapter 44
Revering the Scholars and Elders, Preferring them to others and raising their Status

Allah, the Exalted, says:

"Say: `Are those who know equal to those who know not?' It is only men of understanding who will remember (i.e., get a lesson from Allah's Signs and Verses).'' (39:9)

348. Abu Mas`ud `Uqbah bin `Amr Al-Badri Al-Ansari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The person who is best versed in the recitation of the Book of Allah, should lead the prayer; but if all those present are equally versed in it, then the one who has most knowledge of the Sunnah; if they are equal in that respect too, then the one who has emigrated (to Al-Madinah) first, if they are equal in this respect also, then the oldest of them. No man should lead another in prayer where the latter has authority, or sit in his house, without his permission".
[Muslim].

In another narration in Muslim: Messenger of Allah (PBUH) said, "One who is senior most in accepting Islam, should lead the Salat (prayer)".

Yet another narration is: Messenger of Allah (PBUH) said, "A man who is well versed in the Book of Allah and can recite it better, should lead the Salat (prayer); if (all those present) are equal in this respect, then the man who is senior most in respect of emigration, if they are equal in that respect too, then the oldest of them should lead the prayer".
[Muslim].

Commentary: This Hadith highlights the following three points:

1. The order of priority for the appointment of Imam [one who leads As-Salat (the prayers) should be as follows:

First, preference should go to a good Qari (reciter of the Noble Qur'an) who is also an expert in it, provided he is pious and acts upon the teachings of the Noble Qur'an faithfully. He should not be a non-practising Muslim. Nowadays, we have an abundance of Imam but many of them are neither pious nor faithfully act upon religious teachings. In any case, where we can find a Qari who fulfills the requirements just mentioned, he deserves first preference for appointment as Imam. Even a religious scholar will come next to him. It must be borne in mind that nice recitation of the Noble Qur'an does not mean its recitation with great skill, but its essentials are elegant voice, acquaintance with the `Ilm-ut-Tajwid (or science of reciting the Qur'an), clear and distinct recitation.

2. The ruler of a territory, its highest officer and governor should work as Imam in their respective areas. In the early ages of Islam, these authorities used to administer their areas, dispense justice and lead congregational prayers (Salat).

3. When one goes to somebody's house, he should not occupy the place reserved for the master of the house unless he himself asks him to sit there.

349. Abu Mas`ud Al-Ansari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) would place his hands upon our shoulders when we would form rows for As-Salat (the prayer) and say, "Stand in straight rows and do not differ among yourselves, or else your hearts will differ due to disaccord. Let those be nearest to me who are mature and endowed with understanding (of the religion), then those who are nearest to them in these respects and then those who are nearest to them".
[Muslim].

350. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Let those be nearest to me in Salat (prayer) who are mature and possess (religious) knowledge, then those who are nearest to them in these respects". He repeated this three times and then added, "Beware of indulging in the loose talks of the markets (when you are in the mosque)".
[Muslim].

Commentary: The meaning of the last sentence of this Hadith seems to be that one should not quarrel, make noise or engage in loose talk in or near a mosque to disturb the people in the mosque because such activities are severely condemned by Islim.

351. Sahl bin Abu Hathmah Al-Ansari (May Allah be pleased with him) reported: `Abdullah bin Sahl and Muhaiyisah bin Mas`ud ¨(May Allah be pleased with them) went to Khaibar during the period of the truce (after its conquest) and they separated to perform their duties. When Muhaiyisah returned to `Abdullah bin Sahl, he found him murdered, drenched in his blood. So he buried him and returned to Al-Madinah. Then `Abdur-Rahman bin Sahl, Huwaiyisah and Muhaiyisah, the two sons of Mas`ud went to Messenger of Allah (PBUH) and spoke about the case of their (murdered) friend. `Abdur-Rahman, who was the youngest of them all, started talking. Messenger of Allah (PBUH) said, "Let those older than you speak first.'' So he stopped talking and the (other two) spoke about the case of their (murdered) friend. Messenger of Allah (PBUH) said, "Will you take an oath whereby you will have the right to receive the blood money of your murdered man?'' And mentioned the rest of the Hadith.''
[Al-Bukhari and Muslim].

Commentary: The author of this book, Imam Nawawi, has reproduced only that portion of Hadith which is related to this chapter. This Hadith makes out the following points:

1. The eldest person has the first right to speak in a gathering. But this principle is to be followed when all the persons present there are equal in virtue and intelligence; otherwise, one who is superior to others in these qualities will have a prior right to speak.

2. The Hadith explains the issue of Qasamah which was in vogue in the pre-Islamic period and was maintained by Islam. Qasamah was a mode of settling cases of undetected murders. In such situations, fifty persons from the heirs of the victim were asked to take an oath that murder was committed by some person of that locality (or some persons from the heirs were required to take oath for fifty times to this effect); after this oath, the people of that area were liable to pay Diyah (blood money) to the heirs of the victim. If the persons blamed for the murder said on the similar oath that none of them had committed that offense, they were absolved from the payment of Diyah and the payment of blood money was made to the heirs of the victim from the Bait-ul-Mal (state exchequer). In the incident referred in this Hadith when the Prophet (PBUH) asked the brothers of the victim to take the required oath, they refused to do so as they were not sure as to who had committed the crime. The Prophet (PBUH) did not ask the inhabitants of Khaibar for the oath because they were Jews and the heirs of the victim did not have faith in them. Thus, the Prophet (PBUH) himself made the payment of the blood money to the heirs of the victim.

352. Jabir (May Allah be pleased with him) reported: After the battle of Uhud, the Prophet (PBUH) arranged the burial of two of the martyrs in one grave. In each case he would ask, "Which one of them had learnt more Qur'an by heart?'' Whichever was thus pointed out to him, was placed by him first in the Lahd.
[Al-Bukhari].

Commentary: Lahd is a type of grave in which a niche is made on the left side of it to place the corpse. The grave which is straight, a common type, is called Darih. This Hadith tells about the distinction of the Hafiz and his superiority over others. Similarly, the learned, the pious and men of outstanding virtues should have preference over others. The Hadith also indicates the permissibility to bury two or three persons in a single grave in time of need or necessity.

353. `Abdullah bin `Umar (May Allah be pleased with tehm) reported: The Prophet (PBUH) said, "It was shown to me in my dream that I was cleaning my teeth with a Miswak and two men came to me, one being older than the other. I gave the Miswak to the younger one, but I was asked to give it to the older, which I did".
[Al-Bukhari and Muslim].

Commentary: A Musnad Hadith is one in which the full chain of its narrators is mentioned while the Mu`allaq Hadith is that in which the first one or two or more or all its narrators are omitted. This Hadith has been mentioned in Al-Bukhari without any authority.

We learn two things from this Hadith. First, one can use Miswak of another person with his permission. Second, the eldest people should have precedence over others in every matter, except in cases where a younger one excels them in some merit.

354. Abu Musa (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "It is out of reverence to Allah in respecting an aged Muslim, and the one who commits the Qur'an to memory and does not exaggerate pronouncing its letters nor forgets it after memorizing, and to respect the just ruler".
[Abu Dawud]

Commentary: An aged Muslim here means one who lives a pious life till his old age. The word "Hamil-ul-Qur'an'' translated here as `the one who commits the Qur'an to memory,' who have memorized the complete Qur'an. That is to say he is not aggressive in putting it into practice and does not take shelter of far-fetched interpretations to justify his own intellectual and religious perversion. This Hadith stresses that a pious old man, a Hamil-ul-Qur'an and a just head of a Muslim government should be respected. Since their respect has been ordained by Allah, respecting them is in fact revering Allah.

355. `Amr bin Shu`aib (May Allah be pleased with him)on the authority of his father who heard it from his father reported: Messenger of Allah (PBUH) said: "He is not one of us who shows no mercy to younger ones and does not acknowledge the honour due to our elders".
[At-Tirmidhi and Abu Dawud].

Commentary: The words "he is not one of us'' here mean that he is not following the way of the Prophet (PBUH). To show compassion to youngster means showing kindness and generosity to them. On the same principle, it is essential for the young that they respect the elders, the learned and the pious.

356. Maimun bin Abu Shabib (May Allah had mercy upon him) reported: A begger asked `Aishah (May Allah be pleased with her) for charity and she gave him a piece of bread. Thereafter, one well-dressed person asked her for charity and she invited him to sit down and served him food. When she was asked about the reason for the difference in treatment, she said: "Messenger of Allah (PBUH) instructed us: `Treat people according to their status".
[Abu Dawud].

Commentary: This Hadith stresses that:

1. One should neither belittle a respectable person nor should one elevate a mean one. Everyone should be treated according to his real status.

2. It is unbecoming to take support from the Qur'an and Hadith and twist it to substantiate one's own views.

3. The Hadith, however, is classified as Da`if (weak) as there is no link in the chain of its narrators between `Aishah and Maimun.

357. Ibn Abbas (May Allah be pleased with them) reported: `Uyainah bin Hisn came to Al-Madinah and stayed with his nephew Al-Hurr bin Qais who was among those who were close to `Umar (May Allah be pleased with him) and had access to his council. The scholarly persons, whether they were old or young, had the privilege of joining his council and he used to consult them. `Uyainah said to Al-Hurr: "My dear nephew, you have an access to the Leader of the Believers. Will you obtain permission for me to sit with him?'' Al-Hurr asked `Umar and he accorded permission. When `Uyainah came into the presence of `Umar, he addressed him thus: "O son of Al-Khattab, you neither bestow much on us nor deal with us justly.'' `Umar (May Allah be pleased with him) got angry and was about to beat him when Al-Hurr said: "O Leader of the Believers, Allah has said to his Prophet (PBUH): `Show forgiveness, enjoin what is good, and turn away from the foolish (i.e., don't punish them), [i.e., `Uyainah] (7:199). This is one of the ignorant ones.'' By Allah! When al-Hurr recited this, `Umar became quite motionless in his seat. He always adhered strictly to the Book of Allah.
[Al-Bukhari]

Commentary: This incident has been cited in this chapter for the reason it tells us that many `Ulama' and Qurra' were members of the special advisory council of `Umar (May Allah be pleased with him). Therefore, men in authority should appoint their advisors from men who are known for their knowledge, intelligence and piety so that they have the benefit of their sincere and sagacious advice regardless of the flimsy and temporary worldly interests. Besides this, the rulers should also be rich in patience and perseverance.

358. Abu Sa`id Samurah bin Jundub (May Allah be pleased with him) reported: I was a boy during the lifetime of Messenger of Allah (PBUH), and used to commit to my memory what he said, but I do not narrate what I preserved because there were among us people who were older than me.
[Al-Bukhari and Muslim].

Commentary: Ibn `Allan has stated that scholars of Hadith have disliked it that in the presence of an eminent and a pious scholar of Hadith in a city, a man inferior to him narrates a Hadith.

We learn from this Hadith the following:

1. It is improper to talk about the Sunnah of the Prophet (PBUH) in the presence of someone who is older and knows better in this respect.

2. It is permissible for young children to attend the gathering of the aged and the learned.

3. Honouring and respecting the olderly.

359. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "If a young man honours an older person on account of his age, Allah appoints someone to show reverence to him in his old age"
[At-Tirmidhi].

Commentary: The reward of the noble behaviour mentioned in this Hadith is confirmed by other authentic texts.

The Hadith is classified as Da`if (weak).


Visiting the Pious Persons, loving them and adoption of their company

Chapter 45
Visiting the Pious Persons, loving them and adoption of their company

Allah, the Exalted, says:

"And (remember) when Musa (Moses) said to his boy-servant: `I will not give up (travelling) until I reach the junction of the two seas or (until) I spend years and years in travelling''' (up to) "... Musa (Moses) said to him (Khidr): `May I follow you so that you teach me something of that knowledge (guidance and true path) which you have been taught (by Allah)?". (18:60-66)

"And keep yourself (O Muhammad (PBUH)) patiently with those who call on their Rubb (i.e., your companions who remember their Rubb with glorification, praising in prayers, and other righteous deeds) morning and afternoon, seeking His Pleasure.'' (18:28)

360. Anas bin Malik (May Allah be pleased with him) reported: After the death of Messenger of Allah (PBUH), Abu Bakr (May Allah be pleased with him) said to `Umar (May Allah be pleased with him) : "Let us visit Umm Aiman (May Allah be pleased with her) as Messenger of Allah (PBUH) used to visit her". As we came to her, she wept. They (Abu Bakr and `Umar (May Allah be pleased with him) said to her, "What makes you weep? Do you not know that what Allah has in store for His Messenger (PBUH) is better than (this worldly life)?'' She said, "I weep not because I am ignorant of the fact that what is in store for Messenger of Allah (PBUH) (in the Hereafter) is better than this world, but I weep because the Revelation has ceased to come". This moved both of them to tears and they began to weep along with her.
[Muslim].

Commentary: Umm Aiman (May Allah be pleased with her) belonged to Ethiopia and was a slave-girl of the Prophet's father (`Abdullah bin `Abdul-Muttalib). After the death of `Abdullah, Umm Aiman (May Allah be pleased with him) remained with the Prophet's mother, Aminah, and took great care in his upbringing. Subsequently, the Prophet (PBUH) set her free and then she was married to Zaid bin Harithah (May Allah be pleased with her) This Hadith holds justification for weeping over the death of the pious and also shows that it is desirable to visit such persons to whom one's friends go to pay respect. The incident mentioned in this Hadith also shows the love that the Companions of the Prophet (PBUH) had for him.

361. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A man set out to visit a brother (in Faith) in another town and Allah sent an angel on his way. When the man met the angel, the latter asked him, "Where do you intend to go?'' He said, "I intend to visit my brother in this town.'' The angel said, "Have you done any favour to him?'' He said, "No, I have no desire except to visit him because I love him for the sake of Allah, the Exalted, and Glorious.'' Thereupon the angel said, "I am a messenger to you from Allah (to inform you) that Allah loves you as you love him (for His sake)"
[Muslim].

Commentary: This Hadith points out the following:

1. The great merit of visiting Muslims for Allah's sake.

2. The bond of brotherhood in Islam is much stronger than the bonds of blood relationship and worldly interests and, therefore, comes before them in preference.

3. Whoever loves someone for Allah's sake, Allah will love him in a manner that suits His Majesty.

362. Abu Hurairah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "Whosoever visits an ailing person or a brother of his to seek the Pleasure of Allah, an announcer (angel) calls out: `May you be happy, may your walking be blessed, and may you be awarded a dignified position in Jannah".
[At-Tirmidhi].

Commentary: This Hadith highlights the merit of visiting the sick and Muslim to gain the Pleasure of Allah.

363. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "The similitude of good company and that of bad company is that of the owner of musk and of the one blowing the bellows. The owner of musk would either offer you some free of charge, or you would buy it from him, or you smell its pleasant fragrance; and as for the one who blows the bellows (i.e., the blacksmith), he either burns your clothes or you smell a repugnant smell".
[Al-Bukhari and Muslim].

Commentary: This Hadith enjoins that one should sit in the company of the pious persons and avoid the impious ones because the former has the quality of a perfume seller and the latter of a blacksmith. In the association of pious men, one stands to gain all the time and ultimately becomes like them. In bad company one is out-and-out a loser and can never hope to gain any benefit from them.

364. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A woman is married for four things: for her wealth, for her lineage, for her beauty or for her piety. Select the pious, may you be blessed!".
[Al-Bukhari and Muslim].

Commentary: Only a pious woman is in the true sense faithful and obedient to her husband of good conduct. Such a couple not only lead a happy life but its future generation is also brought up on the right lines with the help of such a woman. The women of the remaining three types are generally a source of trouble for their husbands and spoil their future generations. For this reason, while selecting a wife, one should give preference to religion over all other qualities.

365. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said to Jibril (Gabriel), "What prevents you from visiting us more frequently?'' Thereupon was revealed the Ayah: "(The angels say:) `And we (angels) descend not except by the Command of your Rubb. To Him belongs what is before us and what is behind us, and what is between those two". (19:64)
[Al-Bukhari].

Commentary: This Hadith tells us about the Prophet's desire for meeting angel Jibril (Gabriel) to have that knowledge which was revealed to him by means of Wahy (Revelation).

It also tells us that angels descend to earth for certain mission by the Command of Allah. They have no say of their own in any matter. It also indicates that it is permissible to enquire about Muslim brothers after a long period of time as this is a sign of true love.

366. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Keep only a believer for a companion and let only a pious eat your food".
[At-Tirmidhi and Abu Dawud].

Commentary: This Hadith forbids Muslims from befriending infidels and stresses that they should establish a bond of friendship and fraternity with the pious persons only.

The above Hadith signifies that taking believers for company has good consequences on the Muslim. While feeding only pious people compels the Muslim host to provide only Halal or lawful foodstuff for his household as well as his guests. (M.R. Murad)

367. Abu Hurairah (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "Man follows his friend's religion, you should be careful who you take for friends".
[At-Tirmidhi and Abu Dawud].

Commentary: This Hadith also induces one to avoid the company of impious people and seek the association of the pious persons.

368. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A person will be summoned with the one whom he loves".
[Al-Bukhari and Muslim].

Another narration is: The Prophet (PBUH) was asked; "What about a person who loves a people but cannot be with them?'' (i.e., either he cannot attain their lofty position of righteousness or that he has not met with them in this life). He (PBUH) replied, "A person will be in the company of those whom he loves".

Commentary: Besides bringing to eminence the high merit of entertaining the love for the pious persons, this Hadith tells us about the Mercy and Blessings of Allah which He will shower upon those who love the pious people. Because of this love, Allah will elevate even the inferior people and include them among those whom He loves. This Hadith also serves a warning that association and love with the impious people is extremely dangerous as one can meet the same bad end which is inevitable for them. May Allah save us from it.

369. Anas bin Malik (May Allah be pleased with him) reported: A bedouin came to Messenger of Allah (PBUH) and said to him, "When will be the Hour (i.e., the Day of Resurrection)?" He (the Prophet (PBUH)) said, "What preparation have you made for it?'' He said, "Only the love of Allah and His Messenger.'' Then Messenger of Allah (PBUH) said, "You will be with those whom you love.''
[Al-Bukhari and Muslim].

The narration in Muslim is: The man replied: "I have made no significant preparation with regard to Salat (prayer), Saum (fasting) and Sadaqah (charity) but I love Allah and His Messenger".

Commentary: The love of the Companions of the Prophet (PBUH) for Allah and His Prophet (PBUH) was not verbal only, as is the case of present-day Muslims. Their love was full of obedience and submission to Allah in the true sense. This is what the bedouin mentioned in this Hadith really meant when he said that he had not amassed a large treasure by way of Salat, Saum (fasts) and Sadaqah for presentation on the Day of Resurrection. What he meant by them was voluntary acts and not the obligations. The reason being that the obligatory acts like Salat, Saum and Zakat are incumbent on every Muslim and no one can claim to be a true believer and lover of Allah and His Prophet (PBUH) who ignores them. Any Muslim who entertains true love of Allah and His Prophet (PBUH), makes it evident in his practical life by his strict performance of the duties and obligations enjoined by Allah and demonstrated by His Prophet (PBUH) through his Sunnah. Even if such a person does not have to his credit a large amount of voluntary acts, he will be declared successful by Allah. This is the real import of this Hadith, otherwise a Muslim's claim for the love of Allah and His Prophet (PBUH) will be void if he does not fulfill his religious obligations. In fact, without the fulfillment of religious obligations, his claim will be nothing short of self-deception. His claim for the love of Allah and His Prophet (PBUH), which is not supported by his actions will carry no weight before Allah. This is what the following Ayah of the Noble Qur'an enjoins: "Say (O Muhammad (PBUH) to mankind:) `If you (really) love Allah then follow me (i.e., accept Islamic Tauhid, follow the Qur'an and the Sunnah), Allah will love you and forgive your sins. And Allah is Oft-Forgiving, Most Merciful.''' (3:31)

370. Ibn Mas`ud (May Allah be pleased with him) reported: A man came to Messenger of Allah (PBUH) and said, "O Messenger of Allah! What do you think of a man who loves some people but does not go any nearer to their position?'' He (PBUH) replied, "A man will be with those whom he loves".
[Al-Bukhari and Muslim].

Commentary: "Lam yalhaq bihim" means that he has not been able to come close to them in righteousness and good deeds but in the next world Almighty Allah will, by His Grace and Mercy, elevate him and bring him on par with the righteous and the pious persons because of his love for them.

371. Abu Hurairah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "People are like gold and silver; those who were best in Jahiliyyah (Pre-Islamic Period of Ignorance) are best in Islam, if they have religious understanding; and the souls are like recruited soldiers, they get mixed up with those similar with them in qualities and oppose and drift away from those who do not share their qualities".
[Muslim].

Commentary:
1. Metals differ from each other. Some of them are precious and others worthless. Similar is the case of the people's conduct and actions. There are people of both kinds in the world. If good persons of the pre-Islamic period (who were distinguished for their noble character) embraced Islam, and understood and acted upon the injunctions of Islam, they were entitled to the same distinction which they were holding previously (in the pre-Islamic period). There would be no reduction in their prestige and status with their conversion.

2. The words "souls are like recruited soldiers'' signify the natural difference of nature and temperament in people. Those who are noble, would be introduced to the pious ones; and others who are fascinated by evil, will be introduced to the mischievous ones. People of each kind will maintain contact with their own fellows, as is indicated by a proverb:

`Birds of a feather flock together, pigeons go with pigeons, hawks with hawks.'

Some scholars have pointed out that a person who hates the righteous people must find out its cause because it is a dangerous symptom of one's bad end. After discovering its cause he must try to change it.

372. Usair bin `Amr (Ibn Jabir) reported: When delegations from Yemen came to the help of (the Muslim army at the time of Jihad) `Umar (May Allah be pleased with him) would ask them, "Is there Owais bin `Amir amongst you?'' (He continued searching him) until he met Owais (May Allah be pleased with him). He said, "Are you Owais bin `Amir?'' He said, "Yes". `Umar asked, "Are you from the Qaran branch of the tribe of Murad?'' He said, "Yes". He `Umar (May Allah be pleased with him) again said, "Did you suffer from leucoderma and then you were cured from it but for the space of a dirham?'' He said, "Yes". He `Umar (May Allah be pleased with him) said, "Is your mother still alive?'' He said, "Yes". He `Umar (May Allah be pleased with him) said, "I heard Messenger of Allah (PBUH) saying, `There would come to you Owais bin `Amir with the reinforcement from the people of Yemen. He would be from Qaran (the branch) of Murad. He had been suffering from leucoderma from which he was cured but for a spot of a dirham. He has a mother to whom he is very dutiful. If he were to take an oath in the Name of Allah, Allah would fulfill his oath. And if it is possible for you, ask him to ask forgiveness for you.' So, ask forgiveness for me". He Owais (May Allah be pleased with him) did so. `Umar (May Allah be pleased with him) then said, "Where do you intend to go?'' He said, "To Kufah.'' He `Umar (May Allah be pleased with him) said, "Let me write a letter for you to its governor,'' whereupon he Owais (May Allah be pleased with him) said, "I love to live amongst the poor people". The following year, a person from among the elite (of Kufah) performed Hajj and he met `Umar (May Allah be pleased with him). `Umar (May Allah be pleased with him) asked him about Owais (May Allah be pleased with him). He said, "I left him in a state with meagre means of sustenance in a decayed house.'' (Thereupon) `Umar (May Allah be pleased with him) said, "I heard Messenger of Allah (PBUH) saying, `There would come to you Owais bin `Amir of Qaran, a branch (of the tribe) of Murad, along with the reinforcement of the people of Yemen. He had been suffering from leucoderma which would have been cured but for the space of a dirham. He has a mother to whom he is very dutiful. Were he to swear, trusting Allah, for something, Allah would fulfill his oath. If you can ask him to pray for forgiveness for you, do so". This man went to Owais (May Allah be pleased with him) and asked him to pray for forgiveness for him. Owais (May Allah be pleased with him) said to him, "You have just returned from a blessed journey, it is you who should pray for forgiveness for me; and did you meet `Umar?'' The man said, "Yes". `Owais (May Allah be pleased with him) then prayed for forgiveness for him. People became aware of the high status of Owais (May Allah be pleased with him) and he set out following his course.
[Muslim].

Another narration is: A delegation from Kufah came to `Umar (May Allah be pleased with him). Among them was one who used to make fun of Owais (May Allah be pleased with him). `Umar (May Allah be pleased with him) enquired, "Is there anyone among you who is from Qaran?'' So this man stepped forward. Then `Umar (May Allah be pleased with him) said, "I heard Messenger of Allah (PBUH) saying, `A man will come to you from Yemen named Owais. He will have left in the Yemen only his mother. He was suffering from leucoderma and prayed to Allah to be cured of it. So he was cured except for a space of the size of a dinar or a dirham. Whoever of you should meet him should ask him to pray for forgiveness for him.'''

Another narration is: `Umar (May Allah be pleased with him) said: "I heard Messenger of Allah (PBUH) saying, `The best one of the next generation (At-Tabi`un) is a man called Owais, he will have a mother and he will be suffering from leucoderma. Go to him and ask him to pray for forgiveness for you".
[Muslim].

Commentary:
1. This Hadith is one of the clear miracles of the Prophet (PBUH) because he not only told the name of Owais (May Allah be pleased with him) but also some of his special qualities and characteristics which tallied with the description given by him.

2. It tells the virtues of simplicity, and anonymity.

3. The merit of nice treatment to mother.

4. This Hadith is also a proof on Owais being the best of the successors to the Prophet's Companions (i.e., At-Tabi`un).

5. The humbleness of `Umar (May Allah be pleased with him) and his desire for goodness despite being in the position of the Leader of the Believers.

373. `Umar bin Al-Khattab (May Allah be pleased with him) reported: I sought permission of the Prophet (PBUH) to perform `Umrah. He granted me leave and said, "Dear brother! Do not forget us in your supplications". (`Umar added): This is something I would not exchange for the whole world.

Another narration is: He (PBUH) said, "Include us, my dear brother, in your supplications.'' [Abu Dawud and At-Tirmidhi, who categorized the Hadith as Hasan Sahih. Sheikh Salim Al-Hilali in his book "Bahjatun-Nazireen, Sharh Riyad-us-Saliheen'' classifies it as "Da`if'', the reason being that `Asim bin `Abdullah is "weak'' in narration].

Commentary: It is Mustahab (desirable) to request such a person for prayer who is proceeding on a journey, especially one who is going with the intention of Hajj or `Umrah. The reason being:

1. Prayer for someone in his absence is imbued with sincerity.

2. The places a pilgrim visits in the course of Hajj are such that prayers made there are accepted by Allah.

3. It is also Mustahab that during the course of Hajj when a pilgrim supplicates on special sites and occasions, he should not pray for himself alone but also include his relatives and friends in his supplications.

4. The act of praying for others goes to prove the eminence of religious fraternity of the Muslims. The Prophet (PBUH) is the spiritual father of the entire Muslim community, and is the most superior in nobility and excellence in the whole universe, but in respect of Faith, he is also a brother of all the Muslims and all the Muslims are his brothers. It is illustrated by the fact that he called `Umar (May Allah be pleased with him) his brother.

374. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) used to visit Quba', either mounted or on foot and would offer two Rak`ah prayer in the mosque there.
[Al-Bukhari and Muslim].

Another narration is: The Prophet (PBUH) used to visit the mosque at Quba' every Saturday (i.e., every week) either mounted or on foot, and Ibn `Umar (May Allah be pleased with them) used to do the same thing.

Commentary:

1.Quba' was a village about two miles away from Al-Madinah. Now, it is a part of the city. According to a Hadith, the Prophet (PBUH) has regarded the performance of one Salat there equal to an `Umrah. (At-Tirmidhi, Al-Jami` As-Saghir).

2. This Hadith also shows the passion which Ibn `Umar (May Allah be pleased with them) had for following the Sunnah for which he is well-reputed.


Excellence and Etiquette of Sincere love for the sake of Allah

Chapter 46
Excellence and Etiquette of Sincere love for the sake of Allah

Allah, the Exalted, says:

"Muhammad (PBUH) is the Messenger of Allah. And those who are with him are severe against disbelievers, and merciful among themselves. You see them bowing and falling down prostrate (in prayer), seeking bounty from Allah and (His) Good Pleasure. The mark of them (i.e., of their Faith) is on their faces (foreheads) from the traces of prostration (during prayers). This is their description in the Taurat (Torah). But their description in the Injeel (Gospel) is like a (sown) seed which sends forth its shoot, then makes it strong, and becomes thick and it stands straight on its stem, delighting the sowers, that He may enrage the disbelievers with them. Allah has promised those among them who believe (i.e., all those who follow Islamic Monotheism, the religion of Prophet Muhammad (PBUH) till the Day of Resurrection) and do righteous good deeds, forgiveness and a mighty reward (i.e., Jannah).'' (48:29)

"And those who, before them, had homes (in Al-Madinah) and had adopted the Faith, - love those who emigrate to them...'' (59:9)

375. Anas bin Malik (May Allah be pleased with him) reported: The Prophet (PBUH) said, "There are three qualities whoever has them, will taste the sweetness of Iman: To love Allah and His Messenger (PBUH) more than anyone else; to love a slave (of Allah) only for (the sake of) Allah; and to abhor returning to infidelity after Allah has saved him from it as he would abhor to be thrown into the fire (of Hell)".
[Al-Bukhari and Muslim].

Commentary:
1. In this Hadith, the love of Allah signiffies the sweetness of Iman.

2. The love of Allah and His Prophet (PBUH) is the cornerstone of the Faith. When it is said that this love should exceed one's love for everything else in the universe, it means that what is enjoined by Allah and His Prophet (PBUH) must be given preference over everything else, whether it is love for the wife, children, worldly interests, desires or whims. When there is a clash between the two, the former should be given preference over the latter.

376. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Seven are (the persons) whom Allah will give Shade of His Thrown on the Day when there would be no shade other than His Throne's Shade: A just ruler; a youth who grew up worshipping Allah; a man whose heart is attached to mosques; two persons who love and meet each other and depart from each other for the sake of Allah; a man whom an extremely beautiful woman seduces (for illicit relation), but he (rejects this offer by saying): `I fear Allah'; a man who gives in charity and conceals it (to such an extent) that the left hand does not know what the right has given; and a person who remembers Allah in solitude and his eyes well up".
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions seven types of people whom Almighty Allah provides special protection or His Throne's Shade. In some Ahadith this blessing has also been promised for some noble actions over and above those which have been mentioned here. Some `Ulama' including As-Sakhkhawi and Al-Hafiz Ibn Hajar have given a list of seventy such actions. Imam As-Suyuti said: "The (present) Hadith mentions only seven qualities to bring into prominence their importance and also the importance of acting upon them'.

377. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, Allah, the Exalted, will say: `Where are those who have mutual love for the sake of My Glory? Today I shall shelter them in My Shade when there will be no shade except Mine".
[Muslim].

Commentary: It should be borne in mind that the shade referred to in the Hadith is the shade of Allah's Throne. Referring to this shade in the Arabic text as the Shade of Allah, is similar to the `she camel of Allah,' the `land of Allah' `the house of Allah' that are mentioned in the Qur'an. (Editor's Note)

378. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "By Him in Whose Hand my soul is! You will not enter Jannah until you believe, and you shall not believe until you love one another. May I inform you of something, if you do, you love each other. Promote greeting amongst you (by saying As-salamu `alaikum to one another)".
[Muslim].

Commentary: In this Hadith, Islam has been regarded as the medium of mutual love. This is the reason Muslims have been enjoined to greet each other regardless of acquaintance. It does not, however, mean that a Muslim will be a true believer or entitled to Jannah, by mere greeting. What it really means is that his Faith will become meaningful only when it is supported by actions. Greeting is an Islamic custom and a practical form and demonstration of it. The combination of Faith and its practice will take a Muslim to Jannah.

379. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A man set out to visit a brother (in Faith) in another town and Allah sent an angel on his way. When the man met the angel, the latter asked him, "Where do you intend to go?'' He said, "I intend to visit my brother in this town". The angel said, "Have you done any favour to him?'' He said, "No, I have no desire except to visit him because I love him for the sake of Allah, the Exalted, and Glorious.'' Thereupon the angel said, "I am a messenger to you from Allah (to inform you) that Allah loves you as you love him (for His sake)".
[Muslim].

380. Al-Bara' bin `Azib (May Allah be pleased with them) reported: The Prophet (PBUH) said about the Ansar: "Only a believer loves them, and only a hypocrite hates them. Allah loves him who loves them and Allah hates him who hates them".
[Al-Bukhari and Muslim].

Commentary: The way the Ansar or Helpers, faithfully served Islam, Muslims and the Prophet (PBUH), constitutes not only one of the brightest chapters of Islamic history but also makes them a model of excellent conduct and character. Almighty Allah rewarded them for their devotion to Islam with immense love for Faith - the love which became a symbol of their Faith and love for Allah. Not only that, because of this devotion of the Ansar, everyone who entertained jealousy and hatred against them was declared a hypocrite by Allah. There were two famous tribes, namely Al-Aus and Al-Khazraj in Al-Madinah. In the pre-Islamic days they were enemies to each other. When they embraced Islam, they became close brothers. They welcomed the Muhajirun (the Emigrants) with open arms and rendered every possible assistance to them. For this reason they were named Ansar. May Allah be pleased with them and they be pleased with Him.

381. Mu`adh (bin Jabal) (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah, the Exalted, has said: `For those who love one another for the sake of My Glory, there will be seats of light (on the Day of Resurrection), and they will be envied by the Prophets and martyrs".
[At-Tirmidhi].

Commentary: This Hadith tells us that Allah will grant an exalted position to such people who love one another for His sake. "They will be envied by the Prophets and martyrs'' does not mean that they will be granted a place higher than even the Prophets because the highest position will be granted to the Prophets, as these are the best of Allah's creation. These words simply draw our attention to the superiority and the exalted position those who love one another for Allah's sake will have on the Day of Resurrection.

382. Abu Idris Al-Khaulani (May Allah had mercy upon him) reported: I once entered the mosque in Damascus. I happened to catch sight of a young man who had bright teeth (i.e., he was always seen smiling). A number of people had gathered around him. When they differed over anything they would refer it to him and act upon his advice. I asked who he was and I was told that he was Mu`adh bin Jabal (May Allah be pleased with him) The next day I hastened to the mosque, but found that he had arrived before me and was busy in performing Salat. I waited until he finished, and then went to him from the front, greeted him with Salam and said to him, "By Allah I love you.'' He asked, "For the sake of Allah?'' I replied, "Yes, for the sake of Allah". He again asked me, "Is it for Allah's sake?'' I replied, "Yes, it is for Allah's sake.'' Then he took hold of my cloak, drew me to himself and said, "Rejoice,! I heard Messenger of Allah (PBUH) saying, `Allah, the Exalted, says: My love is due to those who love one another for My sake, meet one another for My sake, visit one another for My sake and spend in charity for My sake".
[Malik].

Commentary: Besides the merit of mutual affection, contact and co-operation for the pleasure of Allah, this Hadith tells us that one should disclose one's affection to him whom one loves. It also tells us that when a person is engaged in worship or daily round of recitation, his visitor should not sit before him so that his concentration is not affected. He should sit behind him and wait till he has finished his prayer. The Hadith also teaches us to approach someone from the front so as not to scare him.

383. Abu Karimah Al-Miqdad bin Ma`dikarib (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When a man loves his brother (for Allah sake) let him tell him that he loves him".
[At-Tirmidhi and Abu Dawud].

Commentary: The wisdom behind informing someone that one loves him for the sake of Allah, is to make him aware of the regard shown to him so that this will turn into mutual affection and will, therefore, promote cooperation with each other.

384. Mu`adh (bin Jabal) (May Allah be pleased with him) reported: Messenger of Allah (PBUH) held my hand and said, "O Mu`adh, By Allah, I love you and advise you not to miss supplicating after every Salat (prayer) saying: `Allahumma a`inni `ala dhikrika wa shukrika, wa husni `ibadatika,' (O Allah, help me remember You, expressing gratitude to You and worship You in the best manner)".
[Abu Dawud and An-Nasa'i].

Commentary: We learn from this Hadith the following:

1. It is commendable to inform those whom one loves for Allah's sake, of this love.

2. The superiority of Mu`adh.

3. It is commendable to say this Du`a after each obligatory Salat.

4. It is commendable to seek Allah's Help in order to discharge one's duties towards Allah in the best possible manner.

385. Anas bin Malik (May Allah be pleased with him) reported: A man was with the Prophet (PBUH) when another man passed by and the former said: "O Messenger of Allah! I love this man (for Allah's sake)". Messenger of Allah (PBUH) asked, "Have you informed him?'' He said, "No". Messenger of Allah (PBUH) then said, "Tell him (that you love him)". So he went up to the man and said to him, "I love you for the sake of Allah;'' and the other replied, "May Allah, for Whose sake you love me, love you.''
[Abu Dawud].


Signs of Allah's love for His slaves and the efforts for its Achievement

Chapter 47
Signs of Allah's love for His slaves and the efforts for its Achievement

Allah, the Exalted, says:

"Say (O Muhammad (PBUH) to mankind): `If you (really) love Allah then follow me (i.e., accept Islamic Monotheism, follow the Qur'an and the Sunnah), Allah will love you and forgive you of your sins. And Allah is Oft-Forgiving, Most Merciful.''' (3:31)

"O you who believe! Whoever from among you turns back from his religion (Islam), Allah will bring a people whom He will love and they will love Him; humble towards the believers, stern towards the disbelievers, fighting in the way of Allah, and never afraid of the blame of the blamers. That is the Grace of Allah which He bestows on whom He wills. And Allah is All-Sufficient for His creatures' needs, All-Knower.'' (5:54)

386. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah, the Exalted, has said: `I will declare war against him who treats with hostility a pious worshipper of Mine. And the most beloved thing with which My slave comes nearer to Me, is what I have enjoined upon him; and My slave keeps on coming closer to Me through performing Nawafil (voluntary prayers or doing extra deeds besides what is obligatory) until I love him, (so much so that) I become his hearing with which he hears, and his sight with which he sees, and his hand with which he strikes, and his leg with which he walks; and if he asks Me something, I will surely give him, and if he seeks My Protection (refuge), I will surely protect him".
[Al-Bukhari]

Commentary: This Hadith tell us the status and distinctive signs of the favoured men of Allah ('Auliya' Allah) The Noble Qur'an has defined them as:

"Those who believed (in the Oneness of Allah) and used to fear Allah much (by abstaining from evil deeds and sins and by doing righteous deeds)". (10:63).

According to this definition, every believer who really fears Allah is a favoured of Allah. It means that except for Faith and piety, favoured of Allah are neither people of the special kind nor have they any special distinctive signs, as is generally thought by some people. In this respect, the ignorance of the general public is shocking because they regard even such persons as favoured of Allah who not only neglect the religious obligations and the practice of the Prophet (PBUH), but also woefully lack cleanliness. Sometimes they call even mad or half-mad persons as favourites of Allah, whereas a Wali in the true sense is one who is meticulous about observing the obligations and is fearful of Allah.

This Hadith brings about the following four points:

Firstly, the love of those whom Allah loves entail the love of Allah, and hating them entails the hatred of Allah..

Secondly, when a true Muslim acquires nearness and love of Allah by means of performing religious obligations, supererogatory and voluntary prayers, Allah then becomes his special helper and protects his limbs and organs and does not let them work for His disobedience. Then he does not use any part of his body for things which are disliked by Him. It is wrong to infer from this Hadith, as men of heretical and polytheistic trend try to do, that Auliya' become the eyes, ears, hands, feet, etc. of Allah. That is to say that Almighty Allah descends in them. Thus, on the basis of this contemptible reasoning, they conclude that it makes no difference whether one begs from Allah or Auliya because the two are one being. For such people supplicating "O Allah! Help us'', "O Prophet of Allah! Help us'' and "O Ali! Help us'' etc., are all right. One who says so has certainly gone astray, rather commits Shirk (polytheism). May Allah save us from these sins. According to the Hadith, a true pious man likes and adopts what is liked by Allah, and avoids all such things which are not liked by Him.

Thirdly, the performance of the obligatory acts of worshipping has the first and foremost importance for attaining the pleasure of Allah because their fulfillment is liked the most by Allah and also because they furnish the foundation, on which the edifice of Islam is built. As we cannot think of a building without foundation, similarly, we cannot think of voluntary worship without fulfilling the basic obligations. The fact is that one who neglects them ceases to be a Muslim. This is the reason for the severe warnings of Allah to those who default on this account. Those who neglect voluntary prayers have not been given any warning. It is, however, true that their performance in addition to the obligatory ones increases lustre of obligations. Nawafil (voluntary acts of worship) help one to attain the exalted place of being loved by Allah by virtue of which one is endowed with the special Help of Allah.

Fourthly, Almighty Allah certainly grants the prayers of those whom He loves. But acceptance of their prayers, however, does not mean that their results appear at once. Sometime the results of these prayers appear after a long time. The prayer of virtuous persons is certainly granted but whether it takes a long or short time depends solely on the Will of Allah.

387. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When Allah loves a slave, calls out Jibril and says: `I love so-and-so; so love him'. Then Jibril loves him. After that he (Jibril) announces to the inhabitants of heavens that Allah loves so-and-so; so love him; and the inhabitants of the heavens (the angels) also love him and then make people on earth love him".
[Al-Bukhari and Muslim].

Another narration of Muslim is: Messenger of Allah, (PBUH) said: "When Allah loves a slave, He calls Jibril (Gabriel) and says: `I love so-and-so; so love him.' And then Jibril loves him. Then he (Jibril) announces in the heavens saying: Allah loves so-and-so; so love him; then the inhabitants of the heavens (the angels) also love him; and then people on earth love him. And when Allah hates a slave, He calls Jibril and says: `I hate so-and-so, so hate him.' Then Jibril also hates him. He (Jibril) then announces amongst the inhabitants of heavens: `Verily, Allah hates so-and-so, so you also hate him.' Thus they also start to hate him. Then he becomes the object of hatred on the earth also".
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions the reward of love for the sake of Allah. A person who loves for the sake of Allah is not only loved by Allah but also by the inhabitants of the earth as well as the heavens. On the other hand, those who are hated by Allah are also hated by the inhabitants of the earth and the heavens. It must be borne in mind that they alone remain popular in this world who are righteous by nature - who strictly maintain the distinction between the lawful and the unlawful (Ma`ruf and Munkar). But those whose nature is defected by constant sins, cease to distinguish between right and wrong and lose their credibility. They generally hate the pious persons for the reason that every category of people loves and likes people of its own kind.

388. `Aishah (May Allah be pleased with her) reported: Messenger of Allah, (PBUH) appointed a man in charge of an army unit who led them in Salat (prayer); he always concluded his recitation with Surat Al-Ikhlas: "Say (O Muhammad (PBUH)): 'He is Allah, (the) One. Allah-us-Samad (Allah - the Self-Sufficient). He begets not, nor was He begotten. And there is none equal or comparable to Him.''' (112:1-4) Upon their return to Al-Madinah, they mentioned this to Messenger of Allah (PBUH), who said, "Ask him why he does so?'' He was asked and he said, "This Surah contains the Attributes of Allah, the Gracious, and I love to recite it. Messenger of Allah (PBUH) then told them, "Tell him that Allah loves him".
[Al-Bukhari and Muslim].

Commentary: We learn from the Hadith the following:

1. The Companions always rushed to the Prophet (PBUH) to ask his opinion about anything they noticed strange to them.

2. The superiority of Surat Al-Ikhlas as it clarifies points of Tauhid.

3. The permissibility to recite two Surah during Salat, apart from Surat Al-Fatihah, in one single Rak`ah.

4. The permissibility of reciting the same Surah over and over again, as this Sahabi (Companion) who led the Salat used to recite Surat Al-Ikhlas after each recitation.


Warning against persecution of the Pious, the Weak and the Indigent

Chapter 48
Warning against persecution of the Pious, the Weak and the Indigent

Allah, the Exalted, says:

"And those who annoy believing men and women undeservedly, they bear (on themselves) the crime of slander and plain sin.'' (33:58)

"Therefore, treat not the orphan with oppression. And repulse not the beggar.'' (93:9,10)

389. Jundub bin Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who performs the Fajr (dawn) prayer comes under the Protection of Allah, so beware lest Allah questions you about what you owe Him. For if He questions anyone of you and he falls short of fulfilling the duty which he owes Him, He will requite and then throw upon his face into the Hell-fire".
[Muslim].

Commentary: A Muslim who performs Fajr prayer receives the protection of Allah. But he who does not fall short of fulfilling the duty which he to owes Allah. It also serves a warning in case of not observing such duty, Allah will demand failing to it. If He does, Hell will be the requital. This highlights the merit of performing the Fajr prayer with congregation, while the second warns a Muslim that since he has started that day by a pledge with Allah, he must keep it for the full day and abstain from doing anything which goes against it.


Making Judgment of people keeping in view their evident actions and leaving their hidden Actions to Allah (swt)

Chapter 49
Making Judgment of people keeping in view their evident actions and leaving their hidden Actions to Allah (swt)

Allah, the Exalted, says:

"But if they repent and perform As-Salat (Iqamat-As-Salat), and give Zakat, then leave their way free. Verily, Allah is Oft-Forgiving, Most Merciful.'' (9:5)

390. `Abdullah bin `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "I have been commanded (by Allah) to fight people until they testify that there is no true god except Allah, and that Muhammad is the Messenger of Allah, and perform Salat and pay Zakat. If they do so, they will have protection of their blood and property from me except when justified by Islam, and then account is left to Allah".
[Al-Bukhari and Muslim].

Commentary: This Hadith brings out the following three points:

1. The objective of Jihad. This objective warrants that one must struggle against Kufr (disbelief) and Shirk (polytheism) and the worship of falsehood in all its forms. Jihad has to continue until this objective is achieved. This contention is supported by a Hadith, to the effect that Jihad will continue till the Day of Resurrection. In this Hadith the word (An-Nas) translated above as "people" stands for the polytheists and idolaters. The reason being that other Nasus (pl. of Nass, meaning `text') confirm the exemption of Ahl-ul-Kitab (people of the Scriptures) from it subject to the condition that they agree to pay Jizyah (dues imposed by Islam on the people of the Book living under the protection of an Islamic state) and submit to the Muslim rule. The Arab pagans have only the choice to either embrace Islam or face war. In the latter case, it is incumbent on the Mulsims to wage Jihad against them to wipe out Kufr and Shirk and raise the banner of Tauhid everywhere.

This Hadith strongly refutes the people who distort the Islamic concept of Jihad and hold that Islam preaches defensive war only. It is an apologetic approach because defensive war has to be fought in any case by every nation and country. Thus, it is a compulsion and needs no justification. The real distinction of Islam lies in its enjoining Muslims to wage war for upholding the truth beside fighting for their own defense. The domination of Kufr, Shirk and falsehood is darkness, heresy and tyranny, and the objective of Islam is to purge the world of all these evils. It aims at liberating man from the worship of man, set them on the path of worship of Allah, and to provide a just and equitable society to mankind. Wherever in the world there is tyranny, ignorance and heresy, Muslims are bound to fight such evils and finish them by means of Jihad.

There is also a third form of Jihad which is waged against countries where Muslims are victims of aggression, suppression and cruelties of the non-Muslims. It is incumbent upon Muslims to liberate their brethren in Faith from the clutches of the non-Muslims by means of Jihad. So long Muslims performed this obligation with a sense of duty, Islam and its followers were dominant in the world and ever since they have ignored this obligation, both are in subjugation and disgrace. In other words, the secret of power and stability of Muslims lies in Jihad. Muslims need to understand this secret like their ancestors.

2. Life and property of every person is secured after his joining the fold of Islam. He will, however, be subject to the law of Islam, one of which is payment of Zakat. If he murders any Muslim, he will also be killed in return, unless the heirs of the victim pardon the murderer or accept blood-money (Diyah) for it.

3. When a person embraces Islam, the laws of Shari`ah apply to him according to his apparent condition only. His heart will not be probed for this purpose. In case, he is not sincere or he has some design in joining the fold of Islam, no action will be taken against him until guilt is fully proved. What he has in his heart will be left to Allah Who will pass judgement on his intention on the Day of Resurrection. This Hadith is related to this chapter for its third point. In their debate on this point, some `Ulama' have contended that such people who believe in Tauhid and obey the injunctions of Shari`ah are not to be declared as infidels.

391. Abu Abdullah bin Tariq bin Ashyam (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who professes La ilaha illallah (There is no true god except Allah), and denies of everything which the people worship besides Allah, his property and blood become inviolable, and it is for Allah to call him to account".
[Muslim].

392. Al-Miqdad bin Al-Aswad (May Allah be pleased with him) reported: I said, "Tell me, O Messenger of Allah, if I meet an infidel, and we fight together, and he cuts off my hands with his sword, then hides from me behind a tree and (then) says he has submitted himself to Allah. Shall I kill him after he has said it?'' He (PBUH) replied, "Do not kill him.'' I submitted, "But O Messenger of Allah, he cut off one of my hands and only then he said it.'' Messenger of Allah (PBUH) then replied, "Do not kill him, for if you do so, he will be in the position in which you were before you killed him (i.e., he will be considered a Muslim and thus his life will be inviolable), and you will be in the position in which he was before he made his testimony (i.e., your life will not be inviolable, for his heirs can ask for Qisas)".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that injunctions of Islam will be enforced on a person according to his apparent condition not his insight. The reason being that nobody is capable of knowing the insight of others. When a person professes Islam, we have to accept him a Muslim; and it will be our duty to protect his life and property. If, in spite of knowing that his life and property are sacred, a Muslim murders him, then it will be quite fair for the heirs of the victim to have Qisas for the murder. If the murderer poses ignorance or takes shelter of some reason, then he will be liable for Diyah only. The Prophet (PBUH) arranged payment of Diyah to the heirs of the victim in the case mentioned in this Hadith because some of the Companions of the Prophet (PBUH) had advanced the argument that the murderer had slain the victim on the presumption that he had professed Islam just to save his life.

393. Usamah bin Zaid (May Allah be pleased with them) reported: Messenger of Allah (PBUH) sent us to Huraqat, a tribe of Juhainah. We attacked that tribe early in the morning and defeated them, (then) a man from the Ansar and I caught hold of a man (of the defeated tribe). When we overcame him, he said: `La ilaha illallah (There is no true god except Allah).' At that moment, the Ansari spared him, but I attacked him with my spear and killed him. By the time we went back to Al-Madinah, news had already reached Messenger of Allah (PBUH). He said to me, "O Usamah, did you kill him after he professed La ilaha illallah (There is no true god except Allah)?'' I said, "O Messenger of Allah! He professed it only to save his life.'' Messenger of Allah (PBUH) repeated, "Did you kill him after he had professed La ilaha illallah?'' He went on repeating this to me until I wished I had not embraced Islam before that day (so that I would have not committed this sin).
[Al-Bukhari and Muslim].

Another narration is: Messenger of Allah (PBUH) said, "Did you kill him in spite of his professing La ilaha illallah?'' I said, "O Messenger of Allah! He said out of fear of our arms.'' He (PBUH) said, "Why did you not cut his heart open to find out whether he had done so sincerely or not?'' He continued repeating it until I wished that I had embraced Islam only that day.

Commentary: The relevance of this Hadith with the present chapter is evident from the fact that it stresses that injunctions of Islam will be enforced on every Muslim according to his apparent condition. It is a very wise course indeed for the reason that it has closed the door of retaliation; otherwise, everyone could kill his enemy on the pretext that the victim was not sincere in his profession of Islam. In order to rule out the possibility of any such mischief, probing into the true condition of the heart is ruled out. A Muslim has to be treated according to his apparent condition only.

394. Jundub bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) dispatched a contingent of the Muslims to a tribe of the polytheists. The two sides met (in combat) at one place. A man among the polytheists was so dashing that, whenever he intended to kill a man from Muslims, he killed him. Amongst the Muslims, too, was a man looking forward to (an opportunity of) his (polytheist's) unmindfulness. He (the narrator) said: We talked that he was Usamah bin Zaid (May Allah be pleased with him). When he raised his sword, he (the soldier of the polytheists) uttered: "La ilaha illallah (There is no true god except Allah).'' But he (Usamah bin Zaid) killed him. When the good news of victory reached Messenger of Allah (PBUH) he asked him (about the events of the battle), and he informed him about the man (Usamah) and what he had done. He (Messenger of Allah (PBUH)) sent for him and asked him why he had killed him. He (Usamah) said, "O Messenger of Allah, he struck the Muslims and killed such and such of them.'' And he named some of them. (He continued): "I attacked him and when he saw the sword he said: `La ilaha illallah.''' Messenger of Allah (PBUH) said, "Did you kill him?'' He (Usamah) replied in the affirmative. The Messenger of Allah then remarked, "What would you do with regard to (the utterance): La ilaha illallah, when it comes (before you) on the Day of Resurrection?'' He (Usamah) said, "O Messenger of Allah! Beg forgiveness for me". He (the Prophet (PBUH)) said, "What would you do with regard to (the utterance): La ilaha illallah, when it comes (before you) on the Day of Resurrection?'' He (Messenger of Allah (PBUH)) added nothing to it but kept repeating, "What would you do with regard to (the utterance): La ilaha illallah, when it comes (before you) on the Day of Resurrection?".
[Muslim].

Commentary: This Hadith mentions the incident which has been quoted in the preceding one. There is only a slight variation in the wording of the two. This Hadith is reported by Muslim under the chapter "The prohibition of killing a Kafir (disbeliever) after having testified that none has the right to be worshipped but Allah".

395. `Abdullah bin `Utbah bin Mas`ud reported: I heard `Umar bin Al-Khattab (May Allah be pleased with him) reported saying: "In the lifetime of Messenger of Allah (PBUH) some people were called to account through Revelation. Now Revelation has discontinued and we shall judge you by your apparent acts. Whoever displays to us good, we shall grant him peace and security, and treat him as a near one. We have nothing to do with his insight. Allah will call him to account for that. But whosoever shows evil to us, we shall not grant him security nor shall we believe him, even if he professed that his intention is good.''
[Al-Bukhari].

Commentary: This Hadith also proves that the injunctions go with the apparent acts of a person and not with will and intention. It also indicates that a good intention does not waive the Qisas and establishing the justice.


Fear (of Allah)

Chapter 50
Fear (of Allah)

Allah, the Exalted, says:

"And fear none but Me". (2:40)

"Verily, (O Muhammad (PBUH)) the Grip (punishment) of your Rubb is severe". (85:12)

"Such is the Seizure of your Rubb when He seizes the (population of) towns while they are doing wrong. Verily, His Seizure is painful, (and) severe. Indeed in that (there) is a sure lesson for those who fear the torment of the Hereafter. That is a Day whereon mankind will be gathered together, and that is a Day when all (the dwellers of the heavens and the earth) will be present. And We delay it only for a term (already) fixed. On the Day when it comes, no person shall speak except by His (Allah's) Leave. Some among them will be wretched and (others) blessed. As for those who are wretched, they will be in the Fire, sighing in a high and low tone". (11:102-106)

"And Allah warns you against Himself (His punishment)". (3:30)

"That Day shall a man flee from his brother. And from his mother and his father. And from his wife and his children. Every man that Day will have enough to make him careless of others". (80:34-37)

"O mankind! Fear your Rubb and be dutiful to Him! Verily, the earthquake of the Hour (of Resurrection) is a terrible thing. The Day you shall see it, every nursing mother will forget her nursling, and every pregnant one will drop her load, and you shall see mankind as in a drunken state, yet they will not be drunken, but severe will be the Torment of Allah". (22:1,2)

"But for him who fears the standing before his Rubb, there will be two Gardens (i.e., in Jannah)". (55:46)

"And some of them draw near to others, questioning. Saying: `Aforetime, we were afraid (of the punishment of Allah) in the midst of our families. So Allah has been gracious to us, and has saved us from the torment of the Fire. Verily, we used to invoke Him (Alone and none else) before. Verily, He is Al-Barr (the Most Subtle, Kind, Courteous, and Generous), the Most Merciful.". (52:25-28)

396. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH), the truthful and the receiver of the truth informed us, saying, "The creation of you (humans) is gathered in the form of semen in the womb of your mother for forty days, then it becomes a clinging thing in similar (period), then it becomes a lump of flesh like that, then Allah sends an angel who breathes the life into it; and (the angel) is commanded to record four things about it: Its provision, its term of life (in this world), its conduct; and whether it will be happy or miserable. By the One besides Whom there is no true god! Verily, one of you would perform the actions of the dwellers of Jannah until there is only one cubit between him and it (Jannah), when what is foreordained would come to pass and he would perform the actions of the inmates of Hell until he enter it. And one of you would perform the actions of the inmates of Hell, until there is only one cubit between him and Hell. Then he would perform the acts of the dwellers of Jannah until he would enter it.''
[Al-Bukhari and Muslim].

Commentary: This Hadith deals with the problem of fate in which Faith is essential. What it means is that Almighty Allah already knows about every person, whether he will be pious or impious, whether he will go to Jannah or Hell. He has already recorded all this. But it does not mean that man is absolutely helpless and is deprived of will and power, as is believed by some deviant sects who have gone astray. Fate is in fact a manifestation of the Knowledge of Allah and it has nothing to do with the will and intention of a person. Allah has not created man as a helpless creature, but has endowed him with the freedom of will and action, because in the absence of these two qualities, there would be no justification for his trial. He could only be put to test if he was granted not only the ability to choose between good and evil but also the freedom to act. For this purpose, Almighty Allah, has clearly indicated to man both the paths and granted him freedom to choose whichever he likes. He has also told him the ultimate end of each. The Noble Qur'an says:

"Verily, We showed him the way, whether he be grateful or ungrateful". (76:3)

"Then whosoever wills, let him believe; and whosoever wills, let him disbelieve". (18:29).

But by mentioning this Hadith in the chapter relating to the fear of Allah, Imam An-Nawawi has warned that we should be fearful of Allah, pray for His Help, and an auspicious end of our life. He has advised us to adopt whatever means are available to us. In other words, we should make Faith and piety a way of life because one can find the means and resources according to one's capacity. Since nobody knows the result of his endeavours, one should leave it to Allah and rest assured that He Who has created him with a purpose will also create the ways and means to attain it. He who adopts piety, the ways to piety will open for him; and he who adopts evil, the ways to evil will open for him.

A Muslim should never go towards evil at any stage of his life, lest his life comes to an end suddenly and he is deprived of the reward of all the good deeds he has done during his life and consequently he is consigned to Hell rather than Jannah. May Allah save us from a bad end and such actions which lead one to Hell.

397. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Hell will be brought on that Day (the Day of Resurrection) with seventy bridles; and with every bridle will be seventy thousand angels, pulling it".
[Muslim].

Commentary: This Hadith deals with the hidden matters relating to the Unseen world. Muslims are ordained by Allah to believe in them. It is wrong to hold them as metaphorical. They are realities but we can not imagine them.

398. Nu`man bin Bashir (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "The least tortured man on the Day of Resurrection is one underneath whose feet will be placed two live coal, and his brain will be boiling, and he would think that he is the most tortured, while he is the least tortured",
[Al-Bukhari and Muslim].

Commentary: According to the narration in Muslim, the straps of shoes to be worn by the inhabitants of Hell would be of fire which will make their brains boil like a cooker placed on oven. Some narrators have stated that the man alluded to will be Abu Talib, the real uncle of the Prophet (PBUH) and his most kind and sympathetic supporter. But since he had died as polythiest, he will be sent to Hell. May Allah save us from it.

399. Samurah bin Jundub (May Allah be pleased with him) reported: Prophet of Allah (PBUH) said, "Among the people of Hell are there those who will be emersed in fire to their ankels, some to their knees, some to their waists, and some to their throats".
[Muslim].

Commentary: This Hadith tells us that the inhabitants of Jannah will be classified into different categories and enjoy different kinds of luxuries according to their merits. A similar classification will also be made in the inhabitants of Hell and they will suffer torments according to their misdeeds.

400. Ibn `Umar (May Allah be pleased with them) reported: I heard Messenger of Allah (PBUH) as saying, "Mankind will stand before Allah, the Rubb of the worlds (on the Day of Resurrection), some of them will stand submerged in perspiration up to half of their ears".
[Al-Bukhari and Muslim].

Commentary: This Hadith gives us a glimpse of the horrible scene of the Resurrection when people will stand in awe before Allah.

401. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) delivered a Khutbah to us the like of which I had never heard from him before. He said, "If you knew what I know, you would laugh little and weep much". Thereupon those present covered their faces and began sobbing.
[Al-Bukhari and Muslim].

Another narration is: Messenger of Allah (PBUH) heard of something about his Companions upon which he addressed them and said, "Jannah and (Hell) Fire were shown to me and I have never seen the like of this day in good and in evil. If you were to know what I know, you would laugh little and weep much". His Companions experienced such suffering on that day that had no equal. They covered their faces and began to weep.
[Al-Bukhari].

Commentary:
1. We learn from this Hadith that Jannah and Hell do exist. The Prophet (PBUH) was shown both of them.

2. Excessive laughing is improper because it indicates that one is careless and forgetful of the Hereafter, while a Muslim is required to be all the time alert and careful about it.

3. To weep out of fear of Allah, is praiseworthy because it indicates that one's heart is full of fear and he is worried about the Hereafter.

402. Al-Miqdad (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, the sun will come so close to people that there would be left only a distance of one Meel''. Sulaim bin `Amir said: By Allah, I do not know whether he meant by "Meel'', the mile of the distance measure or the stick used for applying antimony powder to the eye. (Messenger of Allah (PBUH) is, however, reported to have said:) "The people then will be submerged in perspiration according to their deeds, some up to their ankles, some up to their knees, some up to the waist and some will have the bridle of perspiration (reaching their mouth and nose) and, while saying this Messenger of Allah (PBUH) pointed to his mouth with his hand".
[Muslim].

Commentary: It is not clear whether the Arabic word (Meel) in this Hadith is for the mileage or is the stick used for applying antimony. A mile consists of eight furlongs. Some of the commentators of Hadith hold that it comprises four thousand Dhira`. Hafiz Ibn Hajar is of the opinion that it is equal to twelve thousand human steps. (For detail please see the book `Mir'atul Mafatih' Chapter Salat-us-Safar). If it stands for the mileage even then it gives an idea of the heat of the sun. Although it is billions of miles away from the earth but one cannot bear its heat in summer. When the sun shall be at a distance of one mile, its heat shall be so intense that people would be immersed in sweat. May Allah save us from it.

403. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The people will perspire on the Day of Resurrection and their perspiration will be seventy cubits down in the earth and it will reach up to their ears (they will be bridled with it)".
[Al-Bukhari and Muslim].

404. Abu Hurairah (May Allah be pleased with him) reported: We were in the company of Messenger of Allah (PBUH) when we heard a bang. Thereupon Messenger of Allah (PBUH) said. "Do you know what this (sound) is?'' We said, "Allah and His Messenger know better.'' He (PBUH) said, "That is a stone which was thrown into Hell seventy years before and it has just reached its bottom".
[Muslim].

Commentary: One can imagine the torments and horrors of Hell from its depth.

405. `Adi bin Hatim (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Everyone of you will speak to his Rubb without an interpreter between them. He will look to his right side and will see only the deeds he had previously done; he will look to his left and will see only the deeds he had previously done, and he will look in front of him and will see nothing but Fire (of Hell) before his face. So protect yourselves from Fire (of Hell), even by giving half a date-fruit (in charity)".
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. Here it has been repeated in the context of the fear of Allah because it also has an inducement for fear of Allah and warning against the horrors of Hell.

406. Abu Dharr (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "I see what you do not see and I hear what you do not hear; heaven has squeaked, and it has right to do so. By Him, in Whose Hand my soul is, there is not a space of four fingers in which there is not an angel who is prostrating his forehead before Allah, the Exalted. By Allah, if you knew what I know, you would laugh little, weep much, and you would not enjoy women in beds, but would go out to the open space beseeching Allah".
[At-Tirmidhi].

Commentary:
1. This Hadith also highlights the importance of fear of Allah because the more awareness a Muslim has of the Majesty and Magnificence of Allah, the greater shall be the terror in his heart for His punishment and hope of His Mercy. With this state of mind, he will perform greater acts of obedience and abstain more rigidly from sins.

2. The Hadith also mentions the heaven teeming with angels who are all the time prostrating before Allah in worship. When this is the condition of the angels, who do not slack for a moment in the obedience of Allah, how important it is for man to worship Him because he is all the time violating commands of Allah. It is, therefore, incumbent on man to obey Allah and always seek His Help and Refuge.

407. Abu Barzah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Man's feet will not move on the Day of Resurrection before he is asked about his life, how did he consume it, his knowledge, what did he do with it, his wealth, how did he earn it and how did he dispose of it, and about his body, how did he wear it out.''
[At-Tirmidhi].

Commentary:
1. This Hadith first of all highlights the importance and value of this transitory life, every breath of which is invaluable. Not a moment of it should, therefore, be wasted in the disobedience of Allah because one shall also be made to account for it.

2. Man shall also be answerable for his knowledge. Here, we find an inducement for acquiring religious knowledge because that alone is beneficial for him. He should make use of his knowledge for winning the pleasure of Allah. If he does not do that then he must think about the justification for not doing so. He must also think how he would be facing Allah on the Day of Resurrection.

3. The question in respect of wealth raised in this Hadith clearly shows that one should earn wealth by legitimate means only and spend it strictly in a lawful manner. If he takes to unfair means of income or squanders it, he will be sinful and required to account for the violation of the Divine injunctions.

4. One should protect his body from everything that is unlawful and force himself to submit to the Divine injunctions. When he is asked to account for neglecting them, it will be difficult for him to escape the consequences of accountability.

In short, this Hadith makes one conscious of the accountability so that one keeps it all the time in view so that he will be saved from humiliation on the Day of Resurrection. How nice would it really be if one bears the accountability of the Day of Resurrection always in mind!

408. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) recited, "That Day it (the earth) will reveal its news (about all that happened over it of good or evil).'' (99:4). Then he (PBUH) inquired, "Do you know what its news are?'' He was told: "Allah and His Messenger know better". He said, "Its news is that it shall bear witness against every slave man and woman they did on its back. It will say: `You did this and this on such and such day.' Those will be its news.''
[At-Tirmidhi]

Commentary: This Hadith makes evident the perfect Omnipotence of Allah by telling us that He will bestow power of speech on the earth and it will bear witness to the acts committed on its surface. It has stern warning for people that however they may try to hide their sins from others, they will not be able to save themselves from Allah and His system of accountability.

409. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "How can I feel at ease when the Angel of the Trumpet, (Israfil) has put his lips to the Trumpet and is waiting for the order to blow it". He (PBUH) perceived as if this had shocked his Companions, so he (PBUH) told them to seek comfort through reciting: `Hasbunallah wa ni`mal-Wakil [Allah (Alone) is Sufficient for us, and He is the Best Disposer of affairs (for us)]".
[At-Tirmidhi].

Commentary:
1. This Hadith tells us about the fear of Allah and the fright of the Hereafter entertained by the Prophet (PBUH) and his Companions. It has a lesson for us that how, in spite of being innocent and having the assurance of the forgiveness of Allah, they were always fearful of Allah and the horrors of the Day of Resurrection. As against them, we are immersed in sins, neglect and violate the Divine injunctions day and night but even then we have neither the fear of Allah nor the fright of the Day of Resurrection.

2. In the event of fear and anxiety one should seek the help of Allah and frequently recite the Verse of the Noble Qur'an "Hasbunallahu wa ni`mal Wakil'' [Allah (Alone) is Sufficient for us, and He is the Best Disposer of affairs (for us).]'' (3:173).

410. Abu Hurairah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "He who is afraid of the pillage of the enemy, sets out in the early part of the night; and he who sets out early, reaches his destination. Be on your guard that the commodity of Allah is precious. Verily the commodity of Allah is Jannah".
[At-Tirmidhi].

Commentary: Imam At-Taibi has stated that the Prophet (PBUH) mentioned this example for travellers to the Hereafter, because Satan is sitting on this passage and man's self and his false desires are his helpers. If a person is wide-awake in his travel and exercises caution in his activities, he is not only saved from the vices of Satan, but his own false desires also do not stand in his way. The Prophet (PBUH) also pointed out that the way to the Hereafter is very hard and littered with great impediments and obstructions and it is by no means easy to traverse it. Jannah is an invaluable gift and unless man gives the sacrifice of his life and wealth, he will not become eligible for entering it. "Allah has purchased the lives and properties of Muslims for Jannah". (Tuhfatul Ahwadhi).

This Hadith encourages us to observe obedience of our Rubb and to spare no effort to desist from all acts of disobedience in order to achieve the lofty goal of entering Jannah, by Allah's Leave.

411. `Aishah (May Allah be pleased with her) reported: I heard Messenger of Allah (PBUH) saying, "The people will be assembled on the Day of Resurrection barefooted, naked and uncircumcised". I said, "O Messenger of Allah! Will the men and the women be together on that Day; looking at one another?'' Upon this Messenger of Allah (PBUH) said, "O Aishah, the matter will be too serious for them to look at one another".
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions the horrors and torments of the Day of Resurrection which makes its connection with this chapter obvious. What this chapter, and Ahadith mentioned in it, make clear is that a Muslim should never be unmindful of the preparations for the Hereafter nor should he ever lose sight of the fact that he has to appear before Allah on the Day of Resurrection and account for all his actions. In order to save himself from the humiliation on that Day, he should lead a life of Faith and fear of Allah. Those who do not do so and lead a life free from fear of Allah and torments of the Hereafter, will have no hesitation in disobeying Allah, which will inevitably lead them to humiliation, disgrace and heavy punishment in the Hereafter.


Hope in Allah's Mercy

Chapter 51
Hope in Allah's Mercy

Allah, the Exalted, says:

"Say: O `Ibadi (My slaves) who have transgressed against themselves (by committing evil deeds and sins)! Despair not of the Mercy of Allah: verily, Allah forgives all sins. Truly, He is Oft-Forgiving, Most Merciful". (39:53)

"And never do We requit in such a way except those who are ungrateful (disbelievers)". (34:17)

'(Say:) `Truly, it has been revealed to us that the torment will be for him who denies (believes not in the Oneness of Allah, and in His Messengers), and turns away (from the truth and obedience of Allah)". (20:48)

"And My Mercy embraces all things". (7:156)

412. `Ubadah bin As-Samit (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who bears witness that there is no true god except Allah, alone having no partner with Him, that Muhammad is His slave and His Messenger, that `Isa (Jesus) is His slave and Messenger and he (Jesus) is His Word which He communicated to Maryam (Mary) and His spirit which He sent to her, that Jannah is true and Hell is true; Allah will make him enter Jannah accepting whatever deeds he accomplished".
[Al-Bukhari and Muslim].

Another narration in Muslim is: the Messenger of Allah (PBUH) said, "Whosoever testifies that there is no true god except Allah and that Muhammad is the Messenger of Allah, Allah (SWT) saves him from the Fire (of Hell)".

Commentary: This Hadith confirms that all Prophets of Allah were men and thus refutes those who attribute divinity to them and exclude them from the category of men or regard them a part of Allah, as Christians believes Prophet `Isa (Jesus to be Christ) by regarding him Allah or His son, or the Jews do Prophet `Uzair by venerating him as son of Allah. The misconception has also taken hold of a sect of the Muslims. They have invented the belief that Prophet Muhammad (PBUH) is "Light from the Light of Allah". Thus further considering to be of him with Divine qualities. They exclude him from the category of men. This Hadith tells us that the belief that Prophets were men constitutes part of Faith and denial of it is the denial of a part of Faith and amounts to evasion from Tauhid - Oneness of Allah.

Prophet `Isa (Jesus) has been referred in the Qur'an as "Kalimatullah" (the Word of Allah) (4:171). What these words really mean is that he was born in an unusual manner, without being fathered by anyone, only on the express fiat of Allah.

This Hadith shows that a major sin does not cast a Muslim out of the fold of Islam, as is believed by certain deviant sects who have gone astray. Such a person does remain a Muslim and his eligibility for admission into Jannah also remains intact but his admission entirely depends on the pleasure of Allah. He may forgive a sinful Muslim and send him to Jannah even in the initial stage or keep him in Hell for sometime and then send him to Jannah. Thus, when it is said that Muslims are protected against Hell, it means that they will not abide in Hell for ever. It will be a temporary phase varying with his sins. When that punishment comes to an end, or even before it, when Almighty, Allah, wills, he will be removed from Hell to Jannah.

413. Abu Dharr (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah, the Almighty, says: `Whosoever does a good deed, will have (reward) ten times like it and I add more; and whosoever does an evil, will have the punishment like it or I will forgive (him); and whosoever approaches Me by one span, I will approach him by one cubit; and whosoever approaches Me by one cubit, I approach him by one fathom, and whosoever comes to Me walking, I go to him running; and whosoever meets Me with an earth-load of sins without associating anything with Me, I meet him with forgiveness like that".
[Muslim]

Commentary: This Hadith mentions the infinite Compassion and Mercy of Allih to His obedient slaves and a special expression of which will be made by Him on the Day of Resurrection. On that Day, He will give at least ten times reward for each good deed. In some cases it may be far more than that, seven hundred times or more, as He would like. Such benevolence on His part warrants that a Muslim should never lose hope of His forgiveness.

414. Jabir (May Allah be pleased with him) reported: A bedouin came to the Prophet (PBUH) and asked him, "O Messenger of Allah, what are the two imperatives which lead to Jannah or Hell". He (PBUH) replied, "He who dies without associating anything with Allah will enter Jannah, and he who dies associating partners with Allah will enter the Fire".
[Muslim]

Commentary: This Hadith also holds promise for a Muslim that being a Muslim and Muwahhid (believer in the Oneness of Allah) he will be at last sent to Jannah. Whether he goes straight to Jannah or after suffering the punishment of his sins in Hell, is a separate issue, but he will not remain in Hell for ever. Eternal punishment in Hell is reserved only for pagans, polytheists, and infidels.

415. Anas bin Malik (May Allah be pleased with him) reported: Mu`adh bin Jabal was riding on the beast with the Prophet (PBUH), when he (PBUH) said to him, "O Mu`adh!'' Mu`adh replied, "Here I am responding to you, and at your pleasure, O Messenger of Allah.'' He (PBUH) again called out, "O Mu`adh.'' He (again) replied, "Here I am responding your call, and at your pleasure.'' He (Messenger of Allah) addressed him (again), "O Mu`adh!'' He replied, "Here I am responding to you, and at your pleasure, O Messenger of Allah.'' Upon this he (the Prophet (PBUH)) said, "If anyone testifies sincerely that there is no true god except Allah, and Muhammad is His slave and Messenger, truly from his heart, Allah will safeguard him from Hell.'' He (Mu`adh) said, "O Messenger of Allah, shall I not then inform people of it, so that they may have glad tidings.'' He (PBUH) replied, "Then they will rely on it alone (and thus give up good works altogether).'' Mu`adh (May Allah be pleased with him) disclosed this Hadith at the time of his death, to avoid sinning for concealing.
[Al-Bukhari and Muslim].

Commentary: Imam At-Taibi says that the honesty of heart means firmness of faith and arrangement of actions which will provide evidence of Tauhid and Risalah (Oneness of Allah and the Prophethood of Muhammad (PBUH)). Al-Hafiz Ibn Hajar states that Imam At-Taibi has made this elaboration to remove the ambiguity which arises from the wording of the Hadith because it is generally held by Ahadith that one who bears witness to Tauhid and Risalah will not go to Hell, while Ahlus-Sunnah hold that it stands proved by concrete arguments that sinful Muslims will be consigned to Hell and then brought out from it by intercession. It shows that for the determination of real meanings of this Hadith we shall have to keep in view other related arguments as well. These meanings are riveted with good deeds. In other words, one who bears witness to Tauhid and Risalah and fulfills Islamic injunctions and obligations and requirements of Faith and fear of Allah, will not be consigned to Hell. Some scholars are of the opinion that this Hadith refers to such people who truly repented and renounced Kufr and Shirk and wholeheartedly professed Tauhid and Risalah but died soon after that and thus did not get an opportunity to do good deeds. Such people will certainly go to Jannah.

This Hadith leads to the conclusion that ordinary people should not be told things the true meanings of which they find difficult to grasp and accomplish evil deeds relying on such glad tidings.

416. Abu Hurairah (May Allah be pleased with him) or may be Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: On the day of the battle of Tabuk, the Muslims were hard pressed by hunger and they asked Messenger of Allah (PBUH): "O Messenger of Allah, grant us permission to slaughter our camels to eat and use their fat". He (PBUH) accorded permission. On this `Umar (May Allah be pleased with him) came and said: "O Messenger of Allah, if it is done, we shall suffer from lack of transportation. I suggest you pool together whatever has been left and supplicate Allah to bless it.'' Allah will bestow His Blessing upon it. Messenger of Allah (PBUH) agreed and called for leather mat and had it spread out, and asked people to bring the provisions left over. They started doing it. One brought a handful of corn, another brought a handful of dates, a third brought a piece of bread; thus some provisions were collected on the mat. Messenger of Allah (PBUH) invoked blessings, and then said, "Now take it up in your vessels". Everyone filled his vessel with food, so that there was not left a single empty vessel in the whole camp. All of them ate to their fill and there was still some left over. Messenger of Allah (PBUH) said, "Any slave who meets Allah, testifying there is no true god except Allah, and that I am His Messenger, without entertaining any doubt about these (two fundamentals), will not be banished from entering Jannah.''
[Muslim].

Commentary: This Hadith mentions a miracle of the Prophet (PBUH) and the effect of his prayer by means of which a small quantity of food sufficed the whole army. The exact number of Muslims who took part in the battle of Tabuk is not mentioned in any reliable account. Al-Hafiz Ibn Hajar has stated, with reference to some narratives of Fath Al-Bari mentioned in connection with the biography of the Prophet (PBUH) and the wars he had fought in the way of Allah, that they numbered thirty to forty thousand men.

Although these figures are open to question but one can safely infer from these figures that their number was very large. According to Sahih Al-Bukhari: "A large number of Muslims participated with the Prophet (PBUH) in this war. Their number was so large that they could not be described in a register. It was difficult for the Prophet (PBUH) to discover who was absent except that he was informed about him by Allah.'' (Sahih Al-Bukhari, Kitab Al-Maghazi, Bab Ghazwah Tabuk, Hadith Ka`b bin Malik). This extract goes to prove that although the number of Muslims who took part in this war was very large the provisions weighing a few seers only sufficed for them all.

We also learn from this Hadith that one who is blessed with the Grace of Allah, can offer advice to a person who is superior to him on this account. Similarly, the one who is superior in virtue should listen to the advice of those who are inferior to him because there is every possibility that their advice may offer something better. It does not harm either of them. Neither does it detract from the superiority of the superior nor can it be regarded an affront of a junior.

417. `Itban bin Malik (May Allah be pleased with him) reported, who was with Messenger of Allah (PBUH) in the battle of Badr: I used to lead my people at Bani Salim in Salat (prayer) and there was a valley between me and those people. Whenever it rained, it became difficult for me to cross it for going to their mosque. So I went to Messenger of Allah (PBUH) and said, "I have weak eyesight and the valley between me and my people flows during the rainy season and it becomes difficult for me to cross it. I wish you to come to my house and offer Salat at a place so that I could reserve that as a Musalla (place for prayer).'' Messenger of Allah (PBUH) said, "I will do so". So Messenger of Allah (PBUH) and Abu Bakr (May Allah be pleased with him) came to my house the (next) morning after the sun had risen high. Messenger of Allah (PBUH) asked my permission to enter and I admitted him. He did not sit before saying, "Where do you want us to offer Salat in your house?'' I pointed to the place where I wanted him to offer prayers. So Messenger of Allah (PBUH) stood up for the prayer and started the prayer with Takbir and we aligned in rows behind him; and he offered two Rak`ah prayer and finished them with Taslim, and we also performed Taslim with him. I detained him for a meal called Khazirah which I had prepared for him. (Khazirah is a special type of dish prepared from barley flour and meat soup). When the neighbours got the news that Messenger of Allah (PBUH) was in my house, they started coming till a large number of men gathered in my house. One of them said, "What is wrong with Malik, for I do not see him?'' One of them replied, "He is a hypocrite and does not love Allah and His Messenger". On that Messenger of Allah (PBUH) said, "Don't say this. Haven't you seen that he testified that there is no true god except Allah,' for Allah's sake only.'' The man replied, "Allah and His Messenger know better, but by Allah, we never saw him but helping and talking with the hypocrites.'' Messenger of Allah (PBUH) replied, "No doubt, whosoever testifies that there is no true god except Allah, seeking by so professing the pleasure of Allah only, Allah will safeguard him against (Hell) Fire.''
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the following four points:

1. One can offer Salat at home if one has a lawful reason for it.

2. In the event one is obliged to offer Salat at home it is well to reserve a place for it.

3. It is not permissible to suspect a Muslim on the basis of mere doubt.

4. In the end, every Muslim will be sent to Jannah. This point has already been elaborated.

418. `Umar bin Al-Khattab (May Allah be pleased with him) reported: Some prisoners were brought to Messenger of Allah (PBUH) amongst whom there was a woman who was running (searching for her child). When she saw a child among the captives, she took hold of it, pressed it against her belly and gave it a suck. Messenger of Allah (PBUH) said, "Do you think this woman would ever throw her child in fire?'' We said, "By Allah, she would never throw the child in fire.'' Thereupon Messenger of Allah (PBUH) said, "Allah is more kind to his slave than this woman is to her child".
[Al-Bukhari and Muslim].

Commentary: Al-Hafiz Ibn Hajar states that the Musnad Ismai`li has the following additional words in the narrative: "After continuous search, she finally found her baby. She took the baby and hugged him".

It is permissible to illustrate by example what one cannot make others understand by means of reason and senses, the way the Prophet (PBUH) did it in the present case. Since it was not possible to describe the immensity of Allah's Mercy, he cited the example of that woman to illustrate his point.

419. Abu Hurairah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "When Allah created the creatures, He wrote in the Book, which is with Him over His Throne: `Verily, My Mercy prevailed over My Wrath"
[Al-Bukhari and Muslim].

Another narration is: Messenger of Allah (PBUH) said, "(Allah wrote) `My Mercy dominated My Wrath".

Still another narration is: Messenger of Allah (PBUH) said, "(Allah wrote) `My Mercy surpasses My Wrath".

Commentary: Imam Al-Khattabi states that here the word "Kitab'' (translated here as `Book') means the decision of Almighty Allah which He has already made, an instance of which is the following Verse of the Noble Qur'an:

"Allah has decreed: `Verily, it is I and My Messengers who shall be the victorious". (58:21).

In this Ayah the Arabic word "Kataba'' is used in the sense of "Qada' (decided);'' or the word "Kataba'' signifies "Lauh Mahfooz'' on which He has recorded everything. Almighty Allah is on the 'Arsh' (the Throne of Allah) and this Book is with Him. (Fath Al-Bari, Kitab At-Tauhid, Bab: Wa kana Arshuhu `alal-Ma'.)

420. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah has divided mercy into one hundred parts; and He retained with Him ninety-nine parts, and sent down to earth one part. Through this one part creatures deal with one another with compassion, so much so that an animal lifts its hoof over its young lest it should hurt it".
[Al-Bukhari and Muslim]

Another narration is: Messenger of Allah (PBUH) said, "Allah has one hundred mercies, out of which He has sent down only one for jinn, mankind, animals and insects, through which they love one another and have compassion for one another; and through it, wild animals care for their young. Allah has retained ninety-nine mercies to deal kindly with His slaves on the Day of Resurrection.''
[Al-Bukhari and Muslim].

Another narration in Muslim is reported: by Salman Al-Farisi: Messenger of Allah (PBUH) said, "Allah has hundred mercies, out of which one mercy is used by his creation for mutual love and affection. Ninety-nine mercies are kept for the Day of Resurrection.''

Another narration is: Messenger of Allah (PBUH) said, "Allah created one hundred units of mercy on the Day He created the heavens and the earth. Each one of them can contain all that is between the heaven and the earth. Of them, he put one on earth, through which a mother has compassion for her children and animals and birds have compassion for one another. On the Day of Resurrection, He will perfect and complete His Mercy". (That is He will use all the hundred units of mercy for his slaves on that Day).

Commentary:
1. We learn from this Hadith that kind and compassionate treatment is liked by Allah and is in fact His Blessing and Benevolence. This is the reason He has given a part of it to His creatures, and a person who is so hard-hearted, that he is not even aware of it has a defect which is extremely displeasing to Allah. Moreover, it is a sign that such a person is deprived of Divine blessing and mercy.

2. On the Day of Resurrection, Almighty Allah will bestow upon the believers hundred mercies. This news has great hopes and joy for His slaves.

421. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah, the Exalted, and Glorious said: `A slave committed a sin and he said: O Allah, forgive my sin,' and Allah said: `My slave committed a sin and then he realized that he has a Rubb Who forgives the sins and punishes for the sin.' He then again committed a sin and said: `My Rubb, forgive my sin,' and Allah (SWT) said: `My slave committed a sin and then realized that he has a Rubb Who forgives his sin and punishes for the sin.' He again committed a sin and said: `My Rubb, forgive my sin,' and Allah (SWT) said: `My slave has committed a sin and then realized that he has a Rubb Who forgives the sin or takes (him) to account for sin. I have granted forgiveness to my slave. Let him do whatever he likes".
[Al-Bukhari and Muslim].

The last sentence "let him do..". means, as long he keeps asking for forgiveness after the commission of sins, and repents, Allah will forgive him because repentance eliminates previous sins". (Editor's Note)

Commentary: This Hadith tells us that so long as the heart of a Muslim remains free from willful disobedience of Divine injunctions and he does not deliberately neglect his religious duties, that is to say he goes on committing sins and each time wholeheartedly begs pardon for them, Almighty, Allah will forgive him. The reason being that he is penitent for his wrongs and does not insist upon them for fear of accountability. This condition of his shows that his heart is full of awe and Majesty of Allah and he does not feel any disgrace in showing his utter humbleness before Him. Now this is a merit of the sinful which is pleasing to Allah. Thus, He says that so long as his slave continues submission and prostration He will go on forgiving him.

On the contrary, there is a person who goes on committing sins but he neither repents for them nor seeks pardon for his wrongs; nor has any fear of accountability. Obviously, he is altogether different from the kind of Muslims mentioned before, and he will be therefore treated differently by Allah. The conduct of the former is of a Muslim who, in spite of his sins, is liked by Allah while the second is of that of a rebel for whom He has kept severe punishment ready. May Allah rank us among the former category of people.

422. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "By the One in Whose Hand my soul is, were you not to commit sins, Allah would replace you with a people who would commit sins and then seek forgiveness from Allah; and Allah would forgive them".
[Muslim].

Commentary: This Hadith also tells us that Allah has a profound liking for such people who are penitent and seek pardon for their sins from Him. So much so that if such people cease to exist who neither commit sins nor seek pardon from Him, He will create people who will do so. It does not, however, mean that He likes sins or the sinful persons. What it really means is that He likes penitence and the penitents. This is the true purport of this Hadith.

It also means that it is natural for man to commit sins, and that Allah loves whenever a slave commits a sin to rush and beg for His forgiveness. (Editor's Note).

423. Abu Ayyub Khalid bin Zaid (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Were you not to commit sins, Allah would create people who would commit sins and ask for forgiveness and He would forgive them".
[Muslim].

424. Abu Hurairah (May Allah be pleased with him) reported: We were sitting with Messenger of Allah (PBUH). Abu Bakr and `Umar (May Allah be pleased with them) were also there among the audience. In the meanwhile Messenger of Allah (PBUH) got up and left us. We waited long for his return: When we were worried about his safety, and got scared, we got up. I, therefore, went out to look for Messenger of Allah and came to a garden which belonged to the Ansar. He (PBUH) said to me "Go and give glad tidings of Jannah to anyone who testifies `La ilaha illallah (There is no true god except Allah),' being whole-heartedly certain of it"
[Muslim].

Commentary: This Hadith also tells us that ultimately a Muslim will be awarded Jannah. Whether he will go there in the first stage or after suffering the punishment in Hell, is a matter that depends entirely on the Will of Allah.

425. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: The Prophet (PBUH) recited the Words of Allah, the Exalted, and the Glorious, about Ibrahim (PBUH) who said: "O my Rubb! They have led astray many among mankind. But whosoever follows me, he verily, is of me". (14:36) and those of `Isa (Jesus) (PBUH) who said: "If You punish them, they are Your slaves, and if You forgive them, verily, You, only You, are the All-Mighty, the All-Wise". (5:118). Then he (PBUH) raised up his hands and said, "O Allah! My Ummah, my Ummah,'' and wept; Allah, the Exalted, said: "O Jibril (Gabriel)! Go to Muhammad (PBUH) and ask him: `What makes you weep?" So Jibril came to him and asked him (the reason of his weeping) and the Messenger of Allah informed him what he had said (though Allah knew it well). Upon this Allah said: "Jibril, go to Muhammad (PBUH) and say: `Verily, We will please you with regard to your Ummah and will never displease you".
[Muslim].

Commentary: This Hadith makes two points clear:

Firstly, the kindness and mercy which the Prophet (PBUH) had for his Ummah, a full manifestation of which will be seen on the Day of Resurrection.

Secondly, the love that Allah has for His Prophet, Muhammad (PBUH). Both these benefits will then go to the advantage of the faithful Muslims as they will be then blessed with Mercy and forgiveness of Allah. May Allah include us among them.

426. Mu`adh bin Jabal (May Allah be pleased with him) reported: I was riding a pillion with the Prophet (PBUH) on a donkey. He (PBUH) said, "O Mu`adh, do you know what is the right of Allah upon His slaves, and what is the Right of His slaves upon Allah?'' I said: "Allah and His Messenger know better". Upon this the Messenger of Allah (PBUH) said, "Allah's Right upon His slaves is that they should worship Him Alone and associate nothing with Him; and His slaves' right upon Him is that He should not punish who does not associate a thing with Him.'' He (Mu`adh) added: I said to the Messenger of Allah: "Shall I give the glad tidings to people?'' He (PBUH) said, "Do not tell them this good news for they will depend on it alone".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that ordinary people, who are generally unable to understand the meanings of things in their context, will think that mere verbal profession of Tauhid and Risalah is sufficient to attain forgiveness, and it is not necessary to do what this profession entails. With this notion, they become unmindful of the obligations. Verbal profession does give them the security that they would not abide in Hell forever for ultimately they will go to Jannah. Our people are generally under the impression that all sinful Muslims, like the perfect Muslims, will go to Jannah in the very first instance. According to proofs furnished by other injunctions of Shari`ah, this is not so. This point has been already discussed at length earlier. In any case, the point made here is that no Muslim will go to Hell means that no Muslim will abide in Hell for ever. It does not at all mean that however sinful a Muslim may be, he will not be sent to Hell or suffer its torments.

427. Bara' bin `Azib (May Allah be pleased with them) reported: The Prophet (PBUH) said, "When a believer is questioned in the grave, he testifies that, `there is no true god except Allah and Muhammad is the Messenger of Allah.' About him the Words of Allah, the Exalted, are: `Allah will keep firm those who believe, with the firm statement (The Testimony of Faith) in this world and the Hereafter)". (14:27)
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions both the parts of the Shahadah together, that is to say "La ilaha illallah, Muhammad-ur-Rasulullah'' (There is no true god except Allah, and Muhammad (PBUH) is the Messenger of Allah).

The questioning in the grave is beyond question and is a part of Muslim Belief. Every Muslim will, by the Grace of Allah, give their correct answers in respect of Tauhid and Risalah.

428. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When an infidel accomplishes any good deed, he is rewarded for it in this world; and in the case of a Muslim, Allah stores up his good acts for him in the Hereafter and provides him with subsistence in this life due to his obedience.''

Another narration is: Messenger of Allah (PBUH) said, "Allah does not wrong a believer a good deed because he is given blessings for it in this world and will be rewarded for it in the Hereafter. But the infidel is given in the world the reward for good deeds, he has performed for the sake of Allah and when he comes to the Hereafter, there is no good deed for which he can be rewarded".
[Muslim].

Commentary: The infidels also do in this world many works which are for public welfare, or which come under the category of good deeds. Almighty Allah gives them reward for such good deeds in this world in the form of wealth, sound health, or saving them from some trouble, because Belief is precondition for reward in the Hereafter. Since an infidel is deprived of it, he will also be deprived of their reward in the Hereafter. Thus, we learn that Belief constitutes the basis of every action and is a precondition for the acceptance of any good deed by Allah.

429. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The five daily Salat (prayers) are like a great river running by your door in which you take a bath five times a day.''
[Muslim].

Commentary: This Hadith mentions the merits of performing the five-times prescribed Salat (prayer) punctually. A person who takes bath five times daily, cannot have any dirt on his body; similarly, one who performs Salat regularly is washed of all the minor sins. If he repents and makes penitence, his major sins are also pardoned. One who is meticulous about Salat and other obligations, generally does not commit any major sin but if at all he commits it, he does not stick to it. He is sorry for it and abandons it. His minor sins are washed away by his Salat.

430. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Any Muslim dies and forty men who do not associate anything with Allah (in worship), perform his funeral prayer, Allah makes them intercede for him".
[Muslim]

Commentary:
1. The acceptance of intercession here means that Allah grants the prayer which they (intercessors) make for the deceased and forgives him, provided he is worthy of it.

2.aA large number of Muwahhidun (believers in the Oneness of Allah) in a funeral holds greater promise of the pardon of the deceased.

431. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: There were, about forty of us with Messenger of Allah (PBUH) in a camp when he said, "Aren't you pleased that you will constitute one-fourth of the inhabitants of Jannah?'' We said, "Yes". He again said, "Aren't you pleased that you will constitute one-third of the inhabitants of Jannah?". We said: "Yes.'' Upon this he (PBUH) said, "By Him in Whose Hand Muhammad's soul is, I hope that you will constitute one-half of the inhabitants of Jannah; and the reason is that only Muslims will be admitted into Jannah; and you are no more compared to the polytheists than as a white hair on the skin of a black ox, or a black hair on the skin of a white ox.''
[Al-Bukhari and Muslim].

Commentary: This Hadith reveals the following two points:

1. As compared with the believers and the faithful, there will be a large number of infidels in Hell.

2. As compared with the followers of other Prophets, there will be a larger number of Muslims in Jannah, to the extent that half of its occupants will be Muslims. This Hadith has glad tidings for the Muslim Ummah and bestows great respect and honour on them. (May Allah include us among them.)

432. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, Allah will deliver to every Muslim, a Jew or a Christian and say: `This is your ransom from Hell-fire.'''

Another narration is: Messenger of Allah (PBUH) said, "There would come people amongst the Muslims on the Day of Resurrection with sins as heavy as a mountain, and Allah would forgive them".
[Muslim].

Commentary: "This is your ranson'' is interpreted by the Hadith of Abu Hurairah (May Allah be pleased with him):

"There is a place for everyone in both Jannah and Hell. When the believer occupies his place in Jannah, an infidel will take his place in Hell on account of his infidelity. This also means: "You believers were exposed to Fire, but this infidel is your ransom. Because Allah has prepared a number of His creature for Hell, so when the infidels occupy it on account of their sins and infidelity, they are considered as ransoms for the believers. Allah knows best.'' (Editor's Note)

Commentary: This Hadith tells us about the auspicious end of the believers and a bad one of disbelievers.

433. Ibn `Umar (May Allah be pleased with them) reported: I heard Messenger of Allah (PBUH) saying, "A believer will be brought close to his Rubb on the Day of Resurrection and enveloping him in His Mercy, He (SWT) will make him confess his sins by saying: `Do you remember (doing) this sin and this sin?' He will reply: `My Rubb, I remember.' Then He (SWT) will say: `I covered it up for you in the life of world, and I forgive it for you today.' Then the record of his good deeds will be handed to him".
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us about the believers who will be treated with special favour by Allah. (May Allah include us among them.) It also shows that the admittance of the sins leads to having them forgiven by Allah. The Hadith also encourages us to cover the sins of the believers as best we can.

434. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: A man kissed a woman and he came to the Prophet (PBUH) and made a mention of that to him. It was (on this occasion) that this Ayah was revealed:

"And perform As-Salat (Iqamat-As-Salat), at the two ends of the day and in some hours of the night [i.e., the five compulsory Salat (prayers)]. Verily, the good deeds remove the evil deeds (i.e., small sins)". (11:114)

That person said, "O Messenger of Allah (PBUH), does it concern me only?". He (Messenger of Allah (PBUH)) said, "It concerns the whole of my Ummah".
[Al-Bukhari and Muslim].

Commentary: This Hadith brings out the following three points:

1. Minor sins are forgiven by virtue of Salat.

2. One must not expose one's sins.

435. Anas bin Malik (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said, "O Messenger of Allah, I have committed a sin liable of ordained punishment. So execute punishment on me". Messenger of Allah (PBUH) did not ask him about it, and then came the (time for) Salat (prayers). So he performed Salat with Messenger of Allah (PBUH). When Messenger of Allah (PBUH) finished Salat, the man stood up and said: "O Messenger of Allah! I have committed a sin. So execute the Ordinance of Allah upon me". He (PBUH) asked, "Have you performed Salat with us?'' "Yes", he replied. Messenger of Allah (PBUH) said, "Verily, Allah has forgiven you".
[Al-Bukhari and Muslim].

Commentary: The person who had committed the sin came to the Prophet (PBUH) to seek punishment for his wrongdoing is said to have been Abul-Yusr Ka`b bin `Amr whose story was also mentioned in the previous Hadith. The sin he had committed was not a major one that is why by Salat it was wiped out.

436. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah is pleased with His slave who eats a meal and praises Him for it; and takes a drink and praises Him for it".
[Muslim].

Commentary: One should always say "Al-hamdu lillah'' (all the praise and thanks be to Allah) after food and drink.

This Hadith has been mentioned in the present chapter for the reason that it holds fear as well as hope. If one remembers Allah in the meals, he can hope for the Pleasure of Allah. One should also bear in mind that it is He who gives everything. If He likes, He can forefeit all those things or in spite of providing all the riches, deprive one of hunger and thirst, as it does happen in certain diseases. May Allah protect us from such deprivations.

437. Abu Musa (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah, the Exalted, stretches His Hand during the night so that those who commit sins by day may repent, and He stretches His Hand in the day so that those who commit sins by night may repent. He keeps doing so until the sun rises from the West".
[Muslim].

Commentary: This Hadith has been mentioned before.

Allah's stretching of His Hands is one of His Attributes, and as Muslims we have to believe in this without reasoning, as is the case with His other Attributes. This has been the stand of our pious predecessors (As-Salaf-us-Salih). The process of acceptance of penitence by Allah will continue until the Day of Resurrection when the sun will rise from the West and repenting or accepting Islam will not avail. Therefore, one should not make any delay in penitence.

We must add here that, we must not name or qualify Allah except with what He or His Messenger (PBUH) has named or qualified Him; without changing them or ignoring them completely or twisting the meanings or giving resemblance to any created things:

"The Most Gracious (Allah) rose over the (Mighty) Throne". (20:5) above the seventh heaven; and He only descends to the first (nearest) heaven during the day of `Arafah (Hajj, i.e., the 9th Dhul-Hijjah) and also during the last third part of every night, as mentioned by the Prophet (PBUH), but He is with us by His Knowledge only, not in His essence (Bi Dhatihi): "There is nothing like Him, and He is the All-Hearer, the All-Seer". (42:11)

438. Abu Najih `Amr bin `Abasah (May Allah be pleased with him) reported: In the Pre-Islamic Period of Ignorance, I used to think that people who used to worship idols, were deviated and did not adhere to the true religion. Then I heard of a man in Makkah who was preaching a message. So I mounted my camel and went to him. I found that (this man who was) Messenger of Allah (PBUH) remained hidden because of the persecution by his people. I had entered Makkah stealthily and when I met him I asked him, "Who are you?'' He (PBUH) said, "I am a Prophet.'' I asked; "What is a Prophet?'' He said, "Allah has sent me (with a message)". I asked, "With what has He sent you?'' He said, "He sent me to strengthen the ties of kinship, to destroy idols so that Allah alone should be worshipped and nothing should be associated with Him". I asked, "Who has followed you in this?'' He said, "A freeman and a slave". (At that time only Abu Bakr and Bilal (May Allah be pleased with her) were with him). I said, "I shall follow you". He said, "You can not do that now. Do you not see my situation and that of the people? Go to your people, and when you hear that my cause has prevailed, come to me". So I went back to my people, and while I was with my people, Messenger of Allah (PBUH) emigrated to Al-Madinah. I continued to ask people about him till some of my people visited Al-Madinah. On their return, I asked them, "How is that man who has arrived in Al-Madinah faring?'' They said, "People are hastening to him. His own people had planned to kill him but did not succeed.'' Then I went to Al-Madinah and came to him and said, "O Messenger of Allah, do you recognize me?'' He (PBUH) said, "Yes, you are the one who met me in Makkah.'' I said, "O Messenger of Allah, tell me of that which Allah has taught you and of which I am unaware. Tell me about Salat first.'' He (PBUH) replied, "Perform the Fajr (morning) Salat, then stop Salat until the sun has risen up to the height of a lance, for when it rises, it rises up between the horns of the devil, and the infidels prostrate themselves before it at that time. Then perform Salat, for Salat is witnessed and angels attend it, until the shadow becomes equal to the length of its object; then stop Salat, for at that time Jahannam (Hell) is heated up. Then pray when the shadow becomes longer, for the prayer is witnessed and angels attend it, until you perform `Asr prayer; then stop Salat till sun sets, for it sets between the horns of a devil. At that time the infidels prostrate themselves before it.'' I then asked the Messenger of Allah to tell me about Wudu', and he (PBUH) said, "When a person begins the Wudu' and washes his mouth and nose, the sins committed by his face, mouth and nostrils are washed out. Then when he washes his face as commanded by Allah, the sins of his face are washed out with the water from the sides of his beard. Then when he washes his hands up to elbows, the sins of his hands are washed out through his fingers with water. Then he passes his wet hands over his head and the sins of the head are washed out through the ends of his hair with water. Then he washes his feet up to the ankles, the sins of his feet are washed out through his toes with water. Then, if he stands up for Salat and praises Allah, glorifies Him, proclaims His Greatness as He deserves and devotes his heart wholly to Allah, he emerges sin free as the day he was born".

When `Amr bin `Abasah (May Allah be pleased with him) narrated this Hadith to Abu Umamah (May Allah be pleased with him) a Companion of the Prophet (PBUH), the latter said to him, "Watch what you are saying. O `Amr bin `Abasah, a man will be getting all of this in one shot?'' `Amr (May Allah be pleased with him) replied, "O Abu Umamah, I have attained old age, my bones have become dry, my death is approaching and there is no need for me to tell lies concerning Allah and His Messenger (PBUH). Had I not heard this from the Messenger of Allah only once, twice, thrice (and he counted up to seven) I would never have reported it. Indeed I have heard this frequently".
[Muslim].

Commentary: This Hadith makes the following seven points:

1. The preacher should be concerned about the safety of his followers. It is for this reason, the Prophet (PBUH) stressed upon `Amr bin Abasah (May Allah be pleased with him) to stay at home and keep his conversion to Islam secret.

2. No matter how unfavourable are the circumstances and how tough is the opposition, a preacher should always have firm hope of help from Allah and be confident about his victory over his enemy. That is why, the Prophet (May Allah be pleased with him) asked `Amr (May Allah be pleased with him) to come to him when he received information about his domination.

3. It is a proof of his Prophethood that what eventually happened was exactly according to his prophecy.

4. Angels attend the Salat. One should, therefore, perform Salat not only with peace of mind but also with utmost humility and fear of Allah, so that it is reported and becomes more meritorious.

5. The times when Salat is unpraiseworthy are as follows:

a. After the Salat of Fajr to the time of sunrise.

b. At the time when the sun begins to decline.

c. After the Salat of `Asr to the time of sunset.

d. When the sun is rising or setting.

6. Wudu' and Salat expiate for sins. For this reason this Hadith has been mentioned in this chapter.

7. Even in the Days of Ignorance (pre-Islamic period), pious and right-minded people were averse to idolatry and thought it a deviation from the Right Path.

439. Abu Mu sa Al-Ash`ari (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When Allah intends to show mercy to a people, He collects their Prophet before them and makes him a herald to happiness for them in the Hereafter; and when He intends to destroy a people, He punishes them while their Prophet is alive, and destroys them while he is alive and watches them and makes him witness their destruction because they disbelieved in him and disobeyed his commands".
[Muslim].

Commentary: This Hadith tells us about a Divine law in respect of Prophets, which is meant to deter people from opposing the Prophet (PBUH) and commands us to follow his footsteps, so that we can benefit from his intercession on the Day of Resurrection.


Excellence of Good Hopes

Chapter 52
Excellence of Good Hopes

Allah, the Exalted, says:

"(And the man who believed said:) `... and my affair I leave it to Allah. Verily, Allah is the All-Seer of (His) slaves.' So Allah saved him from the evils that they plotted (against him)". (40:44,45)

440. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah says: `I am just as My slave thinks of Me when he remembers Me.' By Allah! Allah is more pleased with the repentance of His slave than one of you who unexpectedly finds in the desert his lost camel. `He who comes closer to Me one span, I come closer to him a cubit; and he who comes closer to Me a cubit, I come closer to him a fathom; and if he comes to Me walking, I come to him running".
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the merits of expecting good treatment of Allah. But this has to be backed by good actions, in the same way as one can hope for good results after ploughing and sowing seeds. It is obvious that one who accomplishes good deeds will expect good consequences, and one who does evil deeds will expect evil consequences. Allah will treat people according to their expectation that are founded on their actions, and the reward will match their deeds.

441. Jabir bin `Abdullah (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying three days before his death: "Let none of you die unless he has good expectations from Allah".
[Muslim].

Commentary: This Hadith also tells us that one should always perform good deeds because no one knows the time of his death. At the time of death one must entertain hope for Allah's Pardon and Mercy which cannot be possible without good actions. Thus, this Hadith conveys the same meanings of the following Ayah:

"And die not except in a state of Islam (as Muslims)". (3:102).

442. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah, the Exalted, has said: `O son of adam, I forgive you as long as you pray to Me and hope for My forgiveness, whatever sins you have committed. O son of 'Adam, I do not care if your sins reach the height of the heaven, then you ask for my forgiveness, I would forgive you. O son of 'Adam, if you come to Me with an earth load of sins, and meet Me associating nothing to Me, I would match it with an earthload of forgiveness.'''
[At-Tirmidhi].

Commentary:
1. What it really means is that if sins of a Muslim, committed in ignorance and carelessness, become so numerous that in stacks touch the heights of skies, he should not lose hope in Allah's Mercy. If he repents wholeheartedly for his sins, makes penitence for them and begs Allah's forgiveness, he will certainly find Allah's Mercy open for him.

2. Shirk (polytheism) is an absolutely unpardonable sin. All other sins, how many and how grave they may be, can be forgiven by Allah. He will pardon them if He likes and send the sinful persons straight to Jannah, or keep them for a while in Hell and then shift them to Jannah. In any case, the punishment of Hell will not be eternal for them, as it is for the Mushriks (polytheist).


Combining Hope and Fear (of Allah)

Chapter 53
Combining Hope and Fear (of Allah)

Allah, the Exalted, says:

"None feels secure from the Plan of Allah except the people who are the losers.'' (7:99)

"Certainly no one despairs of Allah's Mercy, except the people who disbelieve.'' (12:87)

"On the Day (i.e., the Day of Resurrection) when some faces will become white and some faces will become black...'' (3:106)

"Verily, your Rubb is Quick in Retribution (for the disobedient, wicked) and certainly He is Oft-Forgiving, Most Merciful (for the obedient and those who beg Allah's forgiveness).'' (7:167)

"Verily, the Abrar (pious and righteous) will be in Delight (Jannah). And verily, the Fujjar (the wicked, disbelievers, sinners and evildoers) will be in the blazing Fire(Hell).'' (82:13,14)

"Then as for him whose balance (of good deeds) will be heavy, he will live a pleasant life (in Jannah). But as for him whose balance (of good deeds) will be light, he will have his home in Hawiyah (pit, i.e., Hell)". (101:6-9)

443. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "If a believer had full knowledge of the chastisement of Allah, none would covet His Jannah; and were an infidel to know the Mercy Allah has, none would despair of His Jannah".
[Muslim].

Commentary:
1. This Hadith mentions the torments which one will have to suffer in consequence of Divine wrath. These are described to enable a sinner to save himself from them. It also tells about the infinite Mercy of Allah so that one will always be hopeful of.

2. Only such people will receive Allah's Grace and Mercy who are obedient to Him, while the disobedient will suffer the consequences of His Wrath.

444. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a dead body is placed on a bier and men carry it on their shoulders, if the deceased was pious, it (the corpse) will say: `Take me in haste'; but if he was not, it will say (to its bearers): `Woe to it. Where are you taking it?' Everything except man hears its voice. Had a human being heard its voice, he would have surely died".
[Al-Bukhari].

Commentary: The speech of a dead is a matter of the realm of the Unseen (or Al-Ghaib) which is mentioned in this Hadith. A deceased person will certainly say what has been disclosed here. A Muslim must have absolute faith in it. Almighty Allah is certainly capable of endowing the power of speech on a deceased person as he does speak with the angels (Munkar and Nakir) when they come to the dead in the grave and question him. This Hadith is intended to induce people to virtues so that after death, one has not to say: "Woe to me! Where are you taking me?". One should spend the life in such a manner that after death when he is taken to the graveyard for burial, he should be in a position to say: "Hasten to take me to my grave so that I can enjoy Divine blessings there".

445. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Jannah is nearer to you than your shoelace, and so is the (Hell) Fire".
[Al-Bukhari].

Commentary: Jannah is close to him who adopts the path of righteousness and he can easily attain it. Its opposite case is also equally true. He is close to Hell who takes the path of evil. Thus, this Hadith has an inducement for virtue and warning against evil.


Excellence of Weeping out of Fear from Allah (swt)

Chapter 54
Excellence of Weeping out of Fear from Allah (swt)

Allah, the Exalted, says:

"And they fall down on their faces weeping and it increases their humility.'' (17:109)

"Do you then wonder at this recitation (the Qur'an)? And you laugh at it and weep not". (53:59-60)

446. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said to me: "Recite the Qur'an to me". I said, "O Messenger of Allah! Shall I recite the Qur'an to you, when it has been revealed to you?'' He (PBUH) replied, "I love to hear it recited by others". So I recited to him a portion from Surat An-Nisa'. When I reached the Ayah:

"How (will it be) then, when We bring from each nation a witness and We bring you (O Muhammad (PBUH)) as a witness against these people?". (4:41)

He (PBUH) said, "Enough for now". When I looked at him I saw his eyes were shedding tears.
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that besides the recitation of the Noble Qur'an, a Muslim should also listen to it from others so that he can contemplate further on it. It also makes one weep when one listens to the Noble Qur'an.

447. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) delivered a Khutbah to us the like of which I had never heard from him before. In the course of the Khutbah, he said: "If you knew what I know, you would laugh little and weep much". Thereupon those present covered their faces and began to sob.
[Al-Bukhari and Muslim].

Commentary: This Hadith has been mentioned in this chapter for the reason that it furnishes positive proof of the fact that the Companions of the Prophet (PBUH) used to weep out of fear of Allah when they heard sermons and preachings. It induces us to follow them.

448. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "One who weeps out of fear of Allah, will not enter the Hell till milk returns back in the udder; and the dust raised on account of fighting in the path of Allah and the smoke of Hell will never exist together".
[At-Tirmidhi].

Commentary:
1. A person who has such a fear of Allah that he weeps on account of it, cannot be disobedient to Allah. Obviously, his life will generally be spent in obedience of Allah and strict abstinence from sins. It is very true to say that it is as impossible for such a person to go to Hell as the return of milk to the udders.

2. Similarly, Jihad is a highly meritorious act for a Muslim. A Mujahid, who fights for the sake of Allah, is perfectly safe from Hell because the dust that falls on this way on him, cannot mix with the smoke of Hell.

449. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Seven people Allah will give them His Shade on the Day when there would be no shade but the Shade of His Throne (i.e., on the Day of Resurrection): And they are: a just ruler; a youth who grew up with the worship of Allah; a person whose heart is attached to the mosques, two men who love and meet each other and depart from each other for the sake of Allah; a man whom an extremely beautiful woman seduces (for illicit relation), but he (rejects this offer and) says: `I fear Allah'; a man who gives in charity and conceals it (to such an extent) that the left hand does not know what the right has given; and a man who remembers Allah in solitude and his eyes become tearful".
[Al-Bukhari and Muslim].

Commentary: This Hadith has been included in this chapter for the reason that it highlights the merits of weeping for fear of Allah. The fear of Allah keeps one away from disobedience of Allah, the reward of which in the Hereafter is Jannah - a world which abounds in the Bounties and Pleasure of Allah.

450. `Abdullah bin Ash-Shikhkhir (May Allah be pleased with him) reported: I came to Messenger of Allah (PBUH) when he was performing prayers. He was sobbing and his chest sounded like a boiling kettle.
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith tells us how the Prophet (PBUH) used to weep in prayer out of fear of Allah. To weep in the course of supplication and at the thought of one's appearance before Allah reflects piety.

451. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said to Ubayy bin Ka`b (May Allah be pleased with him), "Allah (SWT) has ordered me to recite to you Surat-Al-Baiyyinah (98): `Those who disbelieve ..."

Ubayy (May Allah be pleased with him) asked, "Did He name me?'' Messenger of Allah (PBUH) replied in the affirmative. Whereupon Ubayy (May Allah be pleased with him) began to weep.
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the following:

1. The permissibility of crying out of joy when a certain bounty has been bestowed upon one, and out of fear that one fails to show gratefulness to the Bestower of the bounty (i.e., Allah).

2. The superiority of Ubayy bin Ka`b (May Allah be pleased with him) and the high position he occupies with regard to his recitation and memorization of the Qur'an.

452. Anas bin Malik (May Allah be pleased with him) reported: After the death of Messenger of Allah (PBUH), Abu Bakr said to `Umar (May Allah be pleased with them): "Let us visit Umm Aiman (May Allah be pleased with him) as Messenger of Allah (PBUH) used to visit her.'' As we came to her, she wept. They (Abu Bakr and `Umar (May Allah be pleased with them) said to her, "What makes you weep? Do you not know that what Allah has in store for His Messenger (PBUH) is better than (this worldly life)?'' She said, "I weep not because I am ignorant of the fact that what is in store for Messenger of Allah (PBUH) (in the Hereafter) is better than this world, but I weep because the Revelation has ceased to come.'' This reply moved both of them to tears and they began to weep along with her.
[Muslim].

Commentary: Here, this Hadith has been reproduced to furnish justification for weeping on the departure of virtuous people because their presence is a source of many blessings. With their departure from this world, people are deprived of many graces. Pious people are certainly very much grieved on their death.

453. Ibn `Umar (May Allah be pleased with them) reported: When the illness of Messenger of Allah (PBUH) became serious, he was asked about the leading of Salat and he said, "Ask Abu Bakr to lead Salat.'' Whereupon, `Aishah (May Allah be pleased with her) said; "Abu Bakr is very tender hearted. He is bound to be overcome by weeping when he recites the Qur'an.'' Messenger of Allah (PBUH) repeated, "Ask him (Abu Bakr) to lead Salat".

In another narration: `Aishah (May Allah be pleased with her) said: "When Abu Bakr stands in your place, he will not be able to recite the Noble Qur'an to the people on account of weeping.''
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith brings into prominence the distinction of Abu Bakr As-Siddiq (May Allah be pleased with him). It was because of this distinction that the Companions of the Prophet (PBUH) selected him as Khalifah (caliph) after the death of the Prophet (PBUH). On this occasion, `Umar (May Allah be pleased with him) said, "Should we not like him for our (worldly life) political leadership when the Prophet (PBUH) had chosen him for our Deen".

2. The justification for weeping at the time of the recitation of the Noble Qur'an. This was a special virtue of Abu Bakr As-Siddiq (May Allah be pleased with him) which was a mark of his perfect Faith.

454. Ibrahim bin `Abdur-Rahman bin `Auf reported: Food was brought to `Abdur-Rahman bin `Auf (May Allah be pleased with him) when he was observing Saum (fast) and he said: "Mus`ab bin `Umair (May Allah be pleased with him) was martyred and he was better than me, but only one sheet was available to shroud him. It was so small that when his head was covered; his feet remained uncovered and if his feet were covered, his head remained uncovered. Then the bounties of this world have been bestowed upon us generously. I am afraid that the reward of our good deeds have been awarded to us in this world.'' On this he began to sob and left the food untouched.
[Al-Bukhari].

Commentary: This Hadith tells us about the hospitality of the Companions of the Prophet (PBUH) and the respect they had for each other.

Abdur-Rahman bin `Auf (May Allah be pleased with him) was one of the figures of `Al-Ashratul-Mubash-sharun bil Jannah (the ten Companions of the Prophet (PBUH) who were given the glad tidings of entering Jannah during their lifetime). For this reason, he is superior to Mus`ab bin `Umair (May Allah be pleased with him), but he acknowledged him superior on the consideration of his martyrdom and poverty through which he had passed. He holds Mus`ab bin `Umair (May Allah be pleased with him) better on the grounds that he had confronted the infidels in extremely difficult circumstances and sacrificed his life for the sake of Allah.

The second point which this Hadith brings out is the fear which Abdur-Rahman bin `Auf (May Allah be pleased with him) felt at the abundance of wealth and property, although he used to spend his wealth and riches in the way of Allah and Jihad. Today, the only purpose of our wealth is that we waste it either on foolish customs and ceremonies of marriage or construction of buildings and their decoration. It was this abundance of wealth of which the Companions of the Prophet (PBUH) were afraid. The Prophet (PBUH) had himself expressed great anxiety over it.

455. Abu Umamah Sudaiy bin `Ajlan Al-Bahili (May Allah be pleased with him) reported: The Prophet (PBUH) said: "Nothing is dearer to Allah than two drops and two marks: A drop of tears shed out of fear of Allah and a drop of blood shed in Allah's way. Regarding the two marks, they are: Marks left in the Cause of Allah and a mark left in observing one of the obligatory act of worship of Allah, the Exalted".
[At-Tirmidhi].

Commentary: This Hadith mentions the merits of the following:

1. Weeping out of fear of Allah.

2. The blood which flows in the way of Allah.

3. The marks of injuries which are left on the bodies of those who take part in Jihad.

4. The marks of wounds received in the performance of obligations.

The Ahadith on the subject are many.

456. Al-`Irbad bin Sariyah (May Allah be pleased with him) reported: One day Messenger of Allah (PBUH) delivered us a very eloquent Khutbah on account of which eyes shed tears and hearts became softened.
[Abu Dawud and At-Tirmidhi].

Commentary: Even in the relevant chapter, the author has only given a reference of this Hadith and not its full text. This has, however, been stated in chapter 16, bearing the title "Observing the Sunnah and the manners of its obedience".


Excellence of Leading an Ascetic Life, and Virtues of Simple Life

Chapter 55
Excellence of Leading an Ascetic Life, and Virtues of Simple Life

Allah, the Exalted, says:

"Verily, the likeness of (this) worldly life is as the water (rain) which We send down from the sky; so by it arises the intermingled produce of the earth of which men and cattle eat: until when the earth is clad in its adornments and is beautified, and its people think that they have all the powers of disposal over it, Our Command reaches it by night or by day and We make it like a clean-mown harvest, as if it had not flourished yesterday! Thus, do We explain the Ayat (proofs, evidences, verses, lessons, signs, revelations, laws, etc.) in detail for the people who reflect.'' (10:24)

"And put forward to them the example of the life of this world: it is like the water (rain) which We send down from the sky, and the vegetation of the earth mingles with it, and becomes fresh and green. But (later) it becomes dry and broken pieces, which the winds scatter. And Allah is Able to do everything. Wealth and children are the adornment of the life of this world. But the good righteous deeds that last, are better with your Rubb for rewards and better in respect of hope.'' (18:45,46)

"Know that the life of this world is only play and amusement, pomp and mutual boasting among you, and rivalry in respect of wealth and children. (It is) as the likeness of vegetation after rain, thereof the growth is pleasing to the tiller; afterwards it dries up and you see it turning yellow; then it becomes straw. But in the Hereafter (there is) a severe torment (for the disbelievers-evildoers), and (there is) forgiveness from Allah and (His) Good Pleasure (for the believers-gooddoers). And the life of this world is only a deceiving enjoyment". (57:20).

"Beautified for men is the love of things they covet; women, children, much of gold and silver (wealth), branded beautiful horses, cattle and well-tilled land. This is the pleasure of the present world's life; but Allah has the excellent return (Jannah with flowing rivers) with Him.'' (3:14).

"O mankind! Verily, the Promise of Allah is true. So let not this present life deceive you, and let not the chief deceiver (Satan) deceive you about Allah.'' (35:5).

"The mutual rivalry (for piling up of worldly things) diverts you. Until you visit the graves (i.e., till you die). Nay! You shall come to know! Again nay! You shall come to know! Nay! If you knew with a sure knowledge (the end result of piling up, you would not have been occupied yourselves in worldly things)". (102:1-5).

"And this life of the world is only amusement and play! Verily, the home of the Hereafter is the real life if they but knew". (29:64).

457. `Amr bin `Auf Al-Ansari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) sent Abu `Ubaidah bin Al-Jarrah (May Allah be pleased with him) to Bahrain to collect (Jizyah). So he returned from Bahrain with wealth. The Ansar got news of it and joined with the Prophet (PBUH) in the Fajr prayer. When the Prophet (PBUH) concluded the prayer, they stood in his way. When he saw them, he smiled and said, "I think you have heard about the arrival of Abu `Ubaidah with something from Bahrain". They said, "Yes! O Messenger of Allah!". He (PBUH) said, "Rejoice and hope for that which will please you. By Allah, it is not poverty that I fear for you, but I fear that this world will be opened up with its wealth for you as it was opened to those before you; and you vie with one another over it as they did and eventually it will ruin you as it ruined them".
[Muslim].

Commentary: We learn from this Hadith that, from the religious angle, poverty of an individual or nation is not as dangerous as its affluence. For this reason, the Prophet (PBUH) cautioned his Ummah against the consequences of abundance of wealth and warned his followers to save themselves from its evils. We witness today that all his fears have come true. The excess of wealth has made the majority of rich extremely careless about their religious obligations. It is this negligence and evasion from religion about which the Prophet (PBUH) had expressed grave fear.

458. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) sat on the pulpit and we sat around him. He said: "What I am concerned most is the flourishment and the beauty of this world will be available to you".
[Al-Bukhari and Muslim].

459. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said: "The world is sweet and green (alluring); and verily, Allah is making you to succeed each other, generations after generations in it in order to see how you act. So beware of this world and beware of women".
[Muslim].

Commentary: This Hadith has already been mentioned under chapter 6, "Piety". The stress that it lays on guarding against the evil of women shows how grave a mischief woman is for man. The warning it contains is intended to alert men against the cunning and deceit of women and induces them to take preventive measures prescribed by the Shari`ah in this behalf. Those who disregard the injunctions of Shari`ah in this respect generally become a victim of the seduction, wiles and guiles of women. May Allah save us from their amorous ways.

460. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said: "O Allah, there is no true life but the life of the Hereafter".
[Al-Bukhari and Muslim].

Commentary: The saying of the Prophet (PBUH) quoted in this Hadith relates to two different occasions.

Firstly, to the Ghazwah of Al-Khandaq (the battle of the Trench) when Muslims were engaged in digging the trench under very difficult circumstances. It was intended to impress upon them the need for patience and boost their morale. They were made to understand that they should not be perplexed by the strenuous period they were passing through because these were transitory and temporary phases of life after which lay the everlasting life, the real life that was not only permanent but also full of perpetual luxuries.

Secondly, to the occasion of Hajjat-ul-Wada` (last Hajj performed by the Prophet (PBUH)) when he saw around him a large crowd of Muslims. Then he warned them against becoming proud or overjoyed by their strength and power. The grandeur and majesty being witnessed by them would come to an end. The real life was of Al-'akhirah (Hereafter) and they should do their utmost to reform it.

461. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said: "Three (things) follow a dead person: Members of his family, his property and his deeds. Two of them return; and one remains with him. The people and his wealth return; his deeds remain with him".
[Al-Bukhari and Muslim].

Commentary: This Hadith has a warning for the Muslims that they should adopt the way of piety and fear (of Allah), not of sin and impiety because those are actions which will go with him to the grave and which decide his fate in the life after death. If he carries with him good deeds, he will have a comfortable sojourn in Barzakh (the intervening stage between death and Resurrection). On the contrary, if the record of his life is devoid of good deeds, all the wealth that he leaves behind, even if it is beyond calculation, will be of no avail to him because what he will be having with him will be the bad deeds which he performed during his life. These bad deeds will be a constant source of torture for him during his stay in Barzakh.

462. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Among the inmates of Hell, a person who had led the most luxurious life in this world will be brought up on the Day of Resurrection and dipped in the Fire and will be asked: `O son of Adam! Did you ever experience any comfort? Did you happen to get any luxury?' He will reply: `By Allah, no, my Rubb.' And then one of the people of Jannah who had experienced extreme misery in the life of this world will be dipped in Jannah. Then he will be asked: `O son of Adam! Did you ever experience any misery? Did you ever encounter difficulty?' He will say: "By Allah, no my Rubb, I neither experienced misery nor passed through hardship".
[Muslim].

Commentary: This Hadith also induces one to work for the life of the Hereafter, as the amenities of this world which one strives hard to attain, and for which one violates the injunctions of Shari`ah, will be forgotten with a glimpse of the Hell-fire. Therefore, the sensible course is that one should adopt a way of life which is full of true faith and good deeds so that one becomes eligible for the eternal blessings and joys of the life of the Hereafter.

463. Al-Mustaurad bin Shaddad (May allah be pleased with him) reported: Messenger of Allah (PBUH) said, "This world (i.e., its pleasures and duration) in comparison with the Hereafter is (similar to the amount of water) one gets when he puts his finger in the sea. Let him then see what it returns with".
[Muslim].

Commentary: This Hadith shows the value of the Hereafter and its blessings compared to the worldly life. The proportion between the two is that the former is like an ocean while the latter is like the proportion of water left on one's finger when dipped in the sea!.

464. Jabir bin `Abdullah (May allah be pleased with him) reported: Messenger of Allah (PBUH) was passing through the bazaar with his Companions on his both sides, when he saw a dead skinny lamb. He held its ear and said, "Who of you would like to have it for a dirham". They replied, "We do not like to get it for nothing, and what shall we do with it?". Then he (PBUH) asked, "Would you like to have it for nothing?". They replied, "Had it been alive, it would have been defective because it is skinny; but when dead it is of no use". Messenger of Allah (PBUH) said, "Truly, the world is more contemptible to Allah than this (the dead lamb) is to you".
[Muslim].

Commentary: This Hadith also shows the futility of this world for which one struggles so madly throughout his life. It is also an indication that the Prophet (PBUH) used to seize the right opportunities to guide and teach his followers.

465. Abu Dharr (May allah be pleased with him) reported: I was walking with the Prophet on the stony ground in Al-Madinah in the afternoon when Uhud Mount came into sight. Messenger of Allah (PBUH) said, "O Abu Dharr!'' I said, "O Messenger of Allah, here I am responding to you". He said, "If I had as much gold as the weight of Uhud, it would not please me to have a single dinar out of it with me after the passage of three days, but I would hold back something for the repayment of a debt. I would distribute it among the slaves of Allah like this and like this and like this.'' And he (PBUH) pointed in front of him, and on his right side and on his left side. We then walked a little further and he (PBUH) said: "The rich would be poor on the Day of Resurrection, except he who spent like this and like this and like this,". and he pointed as he did the first time. "But such persons are few". Then he said, "Stay where you are till I come back to you". He (the Prophet (PBUH)) walked ahead a little further in the darkness of the night and disappeared from my sight. I heard a loud voice. I said (to myself): "The Messenger of Allah might have met (mishap or an enemy)". I wished I could go after him but I remembered his commanding me to stay till he came back. So I waited for him; and when he came, I made mention of what I had heard. He asked, "Did you hear it?". I said, "Yes". Then he said, "It was Jibril (Gabriel), who came to me and said: `He who dies among your Ummah without having associated anything with Allah (in worship) will enter Jannah.' I said: `Even if he committed illicit sexual intercourse or steals?' He (Jibril) said: `Even if he has committed illicit sexual intercourse or steals".
[Al-Bukhari and Muslim].

Commentary: The last portion of this Hadith means that a Muslim, having firm faith in the Oneness of Allah, will go to Jannah even if he has committed major sins in his life. If Allah wills, he will be sent straight to Jannah, or he will be sent there after suffering punishment in Hell for sometime. Some scholars have associated this Hadith with such persons who make repentance at the time when they are close to death and then they do not get time to do good or bad deeds. Almighty Allah will pardon even their major sins without giving them any punishment.

This Hadith also tells us that it is permissible, rather essential, to reserve some money for the payment of loan because its repayment is far more important than giving (voluntary alms).

It also mentions the piety of the Prophet (PBUH) and his passion for spending in the way of Allah.

466. Abu Hurairah (May allah be pleased with him) reported: Messenger of Allah (PBUH) said: "If I had gold equal to Mount Uhud (in weight), it would not please me to pass three nights and I have a thing of it left with me, except what I retain for repayment of a debt".
[Al-Bukhari and Muslim].

Commentary: The words of the Prophet (PBUH) speak eloquently for his matchless piety and prove that he did not like to keep worldly goods with him. This Hadith also shows that expression of a pious desire is permissible.

467. Abu Hurairah (May allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Look at those who are inferior to you and do not look at those who are superior to you, for this will keep you from belittling Allah's Favour to you.''
[Al-Bukhari and Muslim].

This is the wording in Sahih Muslim. The narration in Al-Bukhari is: Messenger of Allah (PBUH) said: "When one of you looks at someone who is superior to him in property and appearance, he should look at someone who is inferior to him".

Commentary: By looking at the worldly goods and riches of others, a person gradually becomes unthankful for the blessings which Allah has bestowed on him. The best remedy for this "disease" is that which has been prescribed by Messenger of Allah (PBUH) in this Hadith. The remedy is that one should look at the people who have lesser worldly goods and riches than one's own. If a person has a small house of his own which can protect him from the harshness of weather, then he has no need to see enviously towards sky-high buildings and palatial houses of others. He should look at the homeless people who spend their nights on footpaths and live in huts which in rain leak like sieve and are swept away by a wave of flood water, etc. But from a religious angle, one should see towards those who are more fearful of Allah and observe their Salat meticulously so that one becomes more fond of obedience of Allah, has a greater fear of Him and devotes more time to prayer and devotion. This dispensation is also given in other Ahadith.

468. Abu Hurairah (May allah be pleased with ihm) reported: The Prophet (PBUH) said, "May he be miserable, the worshipper of the dinar and dirham, and the worshipper of the striped silk cloak. If he is given anything, he is satisfied; but if not, he is unsatisfied".
[Al-Bukhari]

Commentary: "A slave of dinar and dirham and silk cloaks (clothes)" here means a person who prefers these things to the Divine injunctions and commands and strives day and night to amass worldly goods. Instead of worshipping Allah, he worships such things and is thus guilty of worship of others besides Allah, a condition which causes his ruin.

469. Abu Hurairah (May allah be pleased with him) reported: I saw seventy of the people of the Suffah and none of them had a cloak. They had either a lower garment or a blanket which they suspended from their necks. Some (cloaks) reached halfway down to the legs and some to the ankles; and the man would manage to keep it in his hand to avoid exposing his private parts.
[Al-Bukhari].

Commentary: The term "people of the Suffah" mentioned in the Hadith refers to those Companions of the Prophet (PBUH) who were poor. They used to resort to "the Suffah", a shady place at the back of the Prophet's Mosque (in Al-Madinah).

470. Abu Hurairah (May allah be pleased with him) reported: Messenger of Allah (PBUH) said: "The world is the believer's prison and the infidel's Jannah".
[Muslim].

Commentary: As compared with the pleasures and luxuries, which are in store for a true believer in Jannah in the Hereafter, this world is a prison; and against the ceaseless torture that awaits the Kuffar (disbelievers) in Hell, this world is a Jannah for them. It can also mean that the way a Muslim saves himself in life from lusts and desires and leads a pious life with fear of Allah, this world is a prison for him because he is fettered in the chains of rules and regulations, while a Kafir (disbeliever) is free from all kinds of restrictions and is completely given to lusts and desires, and this is how this world is a Jannah for him. The purpose of this Hadith is to induce Muslims for the preparation of Al-akhirah (the Hereafter) and prevent them from unlawful luxuries of this world.

471. `Abdullah bin `Umar (May allah be pleased with them) reported: Messenger of Allah (PBUH) took hold of my shoulders and said, "Be in the world like a stranger or a wayfarer".

Ibn `Umar (May Allah be pleased with them) used to say: "When you survive till the evening, do not expect to live until the morning; and when you survive until the morning, do not expect to live until the evening; (do good deeds) when you are in good health before you fall sick, and (do good deeds) as long as you are alive before death strikes".
[Al-Bukhari].

Commentary: A person who will consider this world as a temporary stage, will certainly not like that his clothes be entangled in thorny bushes of this world. The greatest fault of man is that he does not understand this status of the world. In spite of the fact that he is not sure of a moment's life here, he occupies himself in amassing goods and riches which would last for a hundred years.

472. Sahl bin Sa`d As-Sa`idi (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said, "O Messenger of Allah, guide me to such an action which, if I do Allah will love me and the people will also love me.'' He (PBUH) said, "Have no desire for this world, Allah will love you; and have no desire for what people possess, and the people will love you.''
[Ibn Majah]

Commentary: "Zuhd'' (ascetism) does not mean renunciation of the world and obligations of life. What it really means is that one should be contented with what he possess and rid himself of greed. Islam neither permits renunciation of the world nor does it condemn genuine struggle to acquire wealth and riches. Therefore, involvement in worldly affairs and struggle for lawful means of livelihood are not against Zuhd. A person who is contented with the lawful means of income is a distinguished person as all his activities are exalted to the level of worship. Similarly, unconcern with the wealth and riches of others and ignoring them is a part of Zuhd and contentment. One additional advantage of it is that such a person wins the love and respect of the people because he who begs people, rather than Allah, has to suffer disgrace and is disliked by the people. The case of begging from Allah is just the opposite. The more a person begs Him, the more pleased He will be with him. In fact, He is displeased if someone does not beg Him. This has been exquisitely stated in an Arabic verse, the meaning of which is:

"Do not stretch your hands before anyone for your needs, but beg from Him (Allah) whose door is always open".

"If a person does not beg Him (Allah), He is displeased, while if one begs someone He becomes furious".

473. An-Nu`man bin Bashir (May Allah be pleased with them) reported: `Umar bin Al-Khattab (May Allah be pleased with him) spoke at length regarding the worldly prosperity that people had achieved and said: "I saw that the Messenger of Allah (PBUH) would pass his days in hunger and could not get even degraded dates to fill his stomach".
[Muslim].

Commentary: During the reign of `Umar (May Allah be pleased with him), when people became more prosperous on account of frequent victories, he asked them to remember the early period of Islam in which they were poor and faced very difficult circumstances, to the extent that even the Prophet (PBUH) was placed in the situation mentioned in this Hadith. The purpose of mentioning it was to warn the people against the evils of abundance of wealth and luxuries. They were exhorted to beware of the love of the world which could make them forget about Al-akhirah (Afterlife).

474. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) died when my house was void of any edible thing except for a small quantity of barley I had on a shelf and from which I kept eating it for a long time. Then when I measured what was left of it, it soon finished.
[Al-Bukhari and Muslim].

Commentary: During the last days of the Prophet (PBUH) the financial position of the Muslims had largely improved due to the spoils of war and he could have lived a comfortable life if he liked, but he stuck to the same austere life which he had led earlier. In this Hadith, `Aishah (May Allah be pleased with her) has related an account of the extremely austere and pious life of the Prophet (PBUH) although her house was the house of his most beloved wife.

This Hadith also tells us that in spite of his profound love for `Aishah (May Allah be pleased with him), the Prophet (PBUH) did not accord her any preferential treatment. He treated all his wives equally. Thus, this Hadith has a lesson for `Ulama' and their families that they should not look towards worldly riches and the amenities enjoyed by them but keep in view the life of the Prophet (PBUH) and his wives and learn to keep themselves contented with minimum income.

475. `Amr bin Al-Harith (May Allah be pleased with him) the brother of Juwairiyah (May Allah be pleased with her), the Mother of believers) reported: (When he died) Messenger of Allah (PBUH) left neither a dinar nor a dirham nor a male slave nor a female slave, nor anything else except his white riding mule, his weapons and his land which he had given in charity to wayfarers.
[Al-Bukhari].

Commentary: Banu Al-Mustaliq Battle took place in the year 5 A.H. Men and women who were made captives in it, included Jawairiyah, and she came to the share of the Prophet (PBUH). She embraced Islam and the Prophet (PBUH) married her. When the Companions of the Prophet (PBUH) learnt about it they released all the prisoners of Banu Mustaliq, who were about one hundred, in consideration of their being in-laws of the Noble Prophet (PBUH).

Weapons here means lance and sword while land signifies that portion of land which the Prophet (PBUH) had got as his share from Fadak, and Khaibar and Al-Qura Valley, etc. He gave it in Sadaqah saying that he was from the class of the Prophets of Allah who have no descendants. Whatever is left by them is Sadaqah (charity). At the time of his death, the Prophet (PBUH) did not have any male or female slave whom he had not set free.

476. Al-Khabbab bin Al-Aratt (May Allah be pleased with him) reported: We emigrated with Messenger of Allah (PBUH) seeking the pleasure of Allah and expecting our reward from Him. Some of us died without enjoying anything of it. Among them was Mus`ab bin `Umair (May Allah be pleased with him), who was killed in the battle of Uhud, leaving only a small coloured sheet of wool (which we used as his shroud). When we covered his head with it, his feet were exposed, and when we covered his feet with it, his head was uncovered. So the Prophet (PBUH) told us to cover his head and to put some Idhkhir (i.e., fragrant grass) over his feet. Others among us enjoy prosperity.
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us about the distinction of Hijrah (emigration) and Jihad and their reward. In this world this reward is given to those Mujahidun of Islam who gain victory and will also be given to them in Al-akhirah (Hereafter). As for those Mujahidun who get martyred on the battlefield, they will get all their rewards on the Day of Resurrection.

477. Sahl bin Sa`d (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Were this world worth a wing of mosquito, He would not have given a drink of water to an infidel.''

[At-Tirmidhi].

Commentary: This Hadith makes it clear that the world and its wealth and riches has no significance to Allah. Thus, it should not have much significance to the believers. It should be considered a means to reform the Afterlife, or a place of trial.

478. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Verily! The world is accursed and what it contains is accursed, except remembrance of Allah and those who associate themselves with Allah; and a learned man, and a learning person.''
[At-Tirmidhi].

Commentary:
1. This Hadith does not mean that this world is totally condemned. What it really means is that such things of this world are cursed which take a person away from Allah and make him careless about his obedience. Thus, anything of this world can be good and evil. For instance, worldly goods are auspicious if one acquires them through lawful means and spends them in a permissible manner, otherwise, they are condemnable. Similar is the case of other things of this world.

2. That knowledge is good which brings one closer to Allah and is a source of benefit for mankind, otherwise, it is also condemnable.

3. This Hadith also brings into prominence the distinction of men of learning, especially scholars of religious disciplines.

479. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said: "Do not crave for property lest you should be absorbed in the desire of worldly life.''
[At-Tirmidhi]

Commentary: The word "Dai`ah'' translated here as "property'' means land, industry, agriculture or business. One should not be so engrossed in them to the extent that, they become the sole purpose of one's life and all one's efforts are exhausted to acquire them, thus forgetting all about the Hereafter. To the extent of one's genuine needs and self-sufficiency, making and maintaining of property, land, industry, agriculture and commerce come in permissible acts. None of them is forbidden provided the means employed for making and maintaining them are fair and do not distract one's attention from Allah and the Hereafter.

480. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: We were repairing our thatchy hut when Messenger of Allah (PBUH) passed by and asked us, "What are you doing?'' We said, "The thatch had gone weak and we are repairing it.'' He (PBUH) said, "I see the sure thing (death) approaching sooner than this.''
[Abu Dawud].

Commentary: The word "Khuss'' means a hut or a house which is made of wood and reed/bamboo and plastered with mud. The Hadith reminds us to be mindful of death at all times and be certain that there is nothing nearer to us than it. It also tells us that we should not engage in those worldly things which are bound to make us forget about our appointed term in this world.

481. Ka`b bin `Iyad (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Verily, there is a Fitnah (trial) for every nation and the trial for my nation (or Ummah) is wealth.''
[At-Tirmidhi].

Commentary: The word "Fitnah'' means trial. Anything with which a person is tried is a Fitnah for him. For this reason children and property have been regarded Fitnah for mankind in the Noble Qur'an. This Hadith strongly urges the Muslim Ummah to exercise moderation in their love for worldly goods and riches otherwise all these things, which are Gifts of Allah, can become a source of woeful torture for them.

482. `Uthman bin `Affan (May Allah be pleased with him) reported: The Prophet (PBUH) said, "There is no right for the son of adam except in these (four) things: A house to live in, a cloth to cover therewith his private parts, bread and water.''
[At-Tirmidhi].

483. `Abdullah bin Ash-Shikhkhir (May Allah be pleased with him) reported: I came to the Prophet (PBUH) while he was reciting (Surat At-Takathur 102):

"The mutual rivalry (for hoarding worldly things) preoccupy you. Until you visit the graves (i.e., till you die). Nay! You shall come to know! Again nay! You shall come to know! Nay! If you knew with a sure knowledge (the end result of hoarding, you would not have been occupied in worldly things). Verily, you shall see the blazing Fire (Hell)! And again, you shall see it with certainty of sight! Then (on that Day) you shall be asked about the delights (you indulged in, in this world)!'' (102:1-8)

(After reciting) he (PBUH) said, "Son of adam says: `My wealth, my wealth.' Do you own of your wealth other than what you eat and consume, and what you wear and wear out, or what you give in Sadaqah (charity) (to those who deserve it), and that what you will have in stock for yourself.''
[Muslim].

Commentary: This Hadith enjoins that if a person is given wealth, he should spend it in the ways liked by Allah because it is this Sadaqah which will be a valuable treasure in the Afterlife. Whatever else he consumes in this world, will finish or rot in this world and will be of no avail in Hereafter.

484. `Abdullah bin Mughaffal (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said, "O Messenger of Allah! By Allah, I love you.'' He (PBUH) said, "Think about what you are saying.'' The man repeated thrice, "I swear by Allah that I love you.'' He (Prophet (PBUH)) said, "If you love me, you should be ready for acute poverty; because poverty comes to those who love me, faster than a flood flowing towards its destination.''
[At-Tirmidhi].

485. K`ab bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Two hungry wolves sent in the midst of a flock of sheep are no more destructive to them than a man's greed for wealth and fame is to his Deen.''

[At-Tirmidhi]

Commentary: The havoc played by wealth, rank and position, which have been mentioned in this Hadith, can be seen everywhere today. Even some `Ulama' and self-proclaimed pious men have a craze for these things and they have not been able to save themselves from the ruin caused by it. May Allah save us from these evils. Greed for wealth and fame are doubtless detrimental to religion as preference of the life of the world over religion is explicit in such a trivial pursuit.

486. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) slept on a straw mat and got up with the marks left by it on his body. Ibn Mas`ud (May Allah be pleased with him) said, "O Messenger of Allah! Would that you make us spread out a soft bedding for you.'' He (PBUH) replied, "What have I to do with the world? I am like a rider who had sat under a tree for its shade, then went away and left it.''
[At-Tirmidhi].

Commentary: Beside mentioning the piety of the Prophet (PBUH), this Hadith tells in a very eloquent manner the reality of this world by means of an example.

487. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The poor will enter Jannah five hundred years before the rich.''
[At-Tirmidhi].

Commentary: Al-Fuqara' (the poor) means those Fuqara' who are perfect in Faith. Such people will go to Jannah five hundered years before the rich because the latter will have to account for their wealth, from where they had got it and how they had spent it, while the former will not be answerable for any such thing.

488. Ibn `Abbas and `Imran bin Al-Husain (May Allah be pleased with them) reported: The Prophet (PBUH) said, "I looked into Jannah and saw that most of its dwellers are the poor; and I looked into Hell and saw that most of its inmates were women.''
[Al-Bukhari and Muslim].

Commentary: The Prophet (PBUH) had observed Jannah and Hell either on the eve of Mi`raj (Ascension to heavens), or of Salat-ul-Kusuf (Eclipse prayer) in which he (PBUH) was shown Jannah and Hell. A large majority of Fuqara' will go to Jannah. The rich people do not attach much importance to the requirements of faith and its practice.

The reason women are the majority in Hell is because they are given to taunts and curses and are ungrateful to their husbands. The Hadith urges women to try to overcome these serious defects in order to be saved from the Hell-fire.

489. Usamah bin Zaid (May Allah be pleased with them) reported: The Prophet (PBUH) said, "I stood at the gate of Jannah and saw that most of those who enter it were poor, whereas the rich were held back; but those who were destined to go to Hell were ordered to be sent there (immediately).''
[Al-Bukhari and Muslim].

490. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The most truthful statement a poet has ever made is the saying of Labid: Everything besides Allah is vain.''
[Al-Bukhari and Muslim].

Commentary:
1. We learn from this Hadith that to compose, recite and quote good verses, as evidence, is permissible.

2. The Verse of Labid, quoted in this Hadith, is the asme effect as the verdict of the Noble Qur'an:

"Whatsoever is on (the earth) will perish." (55:26).

This Verse accepts the elernity of the Afterlife and the transitory nature of this world.


Excellence of Simple Living and being Content with Little

Chapter 56
Excellence of Simple Living and being Content with Little

Allah, the Exalted, says:

"Then, there has succeeded them a posterity who have given up As-Salat (the prayers) [i.e., made their Salat (prayers) to be lost, either by not offering them or by not offering them perfectly or by not offering them in their proper fixed times] and have followed lusts. So they will be thrown in Hell. Except those who repent and believe (in the Oneness of Allah and His Messenger Muhammad (PBUH)), and work righteousness. Such will enter Jannah and they will not be wronged in aught.'' (19:59,60)

"So he went forth before his people in his pomp. Those who were desirous of the life of the world, said: `Ah, would that we had the like of what Qarun (Korah) has been given! Verily, he is the owner of a great fortune.' But those who had been given (religious) knowledge said: `Woe to you! The reward of Allah (in the Hereafter) is better for those who believe and do righteous good deeds'.'' (28:79,80)

"Then, on that Day, you shall be asked about the delights (you indulged in, in this world)!'' (102:8)

"Whoever desires the quick-passing (transitory enjoyment of this world), We readily grant him what We will for whom We like. Then, afterwards, We have appointed for him Hell; he will burn therein disgraced and rejected (far away from Allah's Mercy).'' (17:18)

491. `Aishah (May Allah be pleased with her) reported: The family of Muhammad (PBUH) never ate to the fill the bread of barley for two successive days until he died.
[Al-Bukhari and Muslim].

Another narration is: `Aishah (May Allah be pleased with her) said: Never did the family of Muhammad (PBUH) eat to the fill, since their arrival to Al-Madinah, the bread of wheat for three successive nights until his death.

Commentary: This Hadith tells us about the extreme piety, contentment and simplicity of the Prophet (PBUH). This mode of his life continued to his last days when he had started storing provision for one year for the maintenance of his wives. But he would always distribute it among the needy, so much so that nothing was left with him. Thus, the statement of the wives of the Prophet (PBUH) that the family of Muhammad (PBUH) had never taken bellyful of food for two days is absolutely true. If they had it on one day they did not have it on the next day. This is how they lived their whole life in the companionship of the Prophet (PBUH).

492. `Urwah from `Aishah (May Allah be pleased with her) reported that she used to say to Urwah (May Allah be pleased with him): "O son of my sister, by Allah, I used to see the new moon, then the new moon, then the new moon, i.e., three moons in two months, and a fire was not kindled in the house of Messenger of Allah (PBUH). "I (`Urwah) said, "O my aunt, what were your means of sustenance?'' She said; "Dates and water. But it (so happened) that Messenger of Allah (PBUH) had some Ansar neighbours who had milch animals. They used to send Messenger of Allah (PBUH) some milk of their (animals) and he gave that to us to drink.''
[Al-Bukhari and Muslim].

Commentary: `Aishah (May Allah be pleased with her) did not say this by way of complaint but as warning and exhortation to the Muslims, especially women, so that they would also live a simple life. The latter should prepare their family budget keeping in view the lawful earnings of their husbands and do not place so much burden on them that they are compelled to look for unfair means of earning.

493. Abu Sa`id Maqburi reported: Abu Hurairah (May Allah be pleased with him) said that he happened to pass by some people who had a roast lamb before them. They invited him, but he declined, saying: "The Messenger of Allah (PBUH) left the world without having eaten his fill with barley bread.''
[Al-Bukhari].

Commentary:
1. This Hadith shows how much care the Companions of the Prophet (PBUH) exercised in following him. They would even emulate him in matters in which it was not obligatory under the Shari`ah to follow him. It was in fact the result of that extreme love that they had for the Prophet (PBUH). They were not like the present-day lovers of the Prophet (PBUH) whose love does not go beyond lip-service. They were his true lovers and they followed him faithfully.

2. One should refuse to participate in feasts where extravagance is displayed, as is in common practice today, so that the evil tendency of extravagance and wastage is discouraged. One who avoids such parties, does not refuse invitations but respects the principles and values of Shari`ah which is a highly meritorious act.

494. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) neither ate on a dining cloth, nor ate soft bread throughout his life.
[Al-Bukhari].

One narration adds: He (PBUH) never even saw a Samit lamb.

Samit is an animal prepared for food by removing its hair by boiling water, and then roasted without being skinned. This type of food is preferred by wealthy people. (Editor's Note)

Commentary: It means that the Prophet (PBUH) has not adopted the ways of the rich but embraced a simple way of life which is the mode of Fuqara' - poor people. Thus, he remained contented with simple food and had no relish for extravagant feasts.

495. An-Nu`man bin Bashir (May Allah be pleased with them) reported: I have seen your Prophet (PBUH) when he did not find enough of even the inferior quality of dates to eat and fill his belly.
[Muslim].

496. Sahl bin Sa`d (May Allah be pleased with him) reported: Messenger of Allah (PBUH) had never seen bread made out of fine flour throughout his life, since Allah commissioned him until his death. He was asked, "Did you not have sieves at the time of the Messenger of Allah?'' He replied, "Messenger of Allah (PBUH) never saw a sieve.'' He was asked, "How did you manage to eat barley bread made of unsieved flour?'' He said, ''We used to ground it and then blew away the husk, and what remained we kneaded into dough.''
[Al-Bukhari].

497. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) went out (of his house) one day, or one night, and there he met Abu Bakr and `Umar (May Allah be pleased with them) also. He (PBUH) said, "What made you leave your houses at this hour?'' They said, "It is hunger, O Messenger of Allah.'' He said, "By Him in Whose Hands my soul is, what made you leave, made me also leave, so come along!'' And he went along with them to a man from the Ansar, but they did not find him in his house. When the wife of that man saw the Prophet, she said, "You are most welcome.'' Messenger of Allah (PBUH) said to her, "Where is so-and-so?'' She said, "He went to fetch some fresh water for us.'' In the meantime, the Ansari came back, saw Messenger of Allah (PBUH) and his two companions and said: "Praise be to Allah, today no one has more honourable guests than I.'' He then went out and brought them a bunch of date fruit, having dates, some still green, some ripe, and some fully ripe, and requested them to eat from it. He then took his knife (to slaughter a sheep). Messenger of Allah (PBUH) said to him, "Do not kill a milch sheep.'' So he slaughtered a sheep for them. After they had eaten and drunk to their fill, Messenger of Allah (PBUH) said to Abu Bakr and `Umar (May Allah be pleased with them), "By Him in Whose Hand my soul is, you will certainly be questioned about this treat on the Day of Resurrection. Hunger brought you out of your homes, and you do not return to your homes till you have been blessed with this treat.''
[Muslim].

Commentary:
1. This Hadith refers to the period of great hardship through which the Prophet (PBUH) and his Companions had passed after Hijrah (emigration).

2. It is permissible for one to seek help from such friends about whom one is confident that they will be happy to help.

3. The Hadith enjoins us to respect our guests and to thank Allah on their visit.

498. Khalid bin `Umar Al-`Adawi reported: `Utbah bin Ghazwan, the governor of Basrah, delivered a Khutbah. He praised Allah, glorified Him, then said: "Amma b`adu, verily, the world has been given the news of its end and is running to meet its end swiftly. Nothing is left out of it but a very little amount. Similar to the remainder in a dish whose owner is collecting it to drink; and you are going to move to an abode which knows no end, and you should proceed there with the good before you, for we have been informed (by the Prophet (PBUH)) that a stone would be thrown at one side of the Hell and it would travel down for seventy years but would not reach its bottom. By Allah, it will be filled (with men and jinn). Do you find it strange? We have been informed (i.e., by the Prophet (PBUH)) that the distance between two shutters of the gate of Jannah is forty years (distance). And a day would come when it would be fully packed; I was the seventh amongst the seven who had been with Messenger of Allah (PBUH), and we had nothing to eat but the leaves of the tree until the sides of our mouth were injured. We found a sheet which we tore into two and divided between myself and Sa`d bin Malik. I made the lower garment with half of it and so did Sa`d. Today, there is none amongst us who has not become the governor of a city, and I seek refuge with Allah that I should consider myself great while I am insignificant to Allah.''
[Muslim].

Commentary: This Hadith brings the following points into prominence:

1. Remembrance of Al-akhirah (the Hereafter) and the torment of Hell.

2. Description of the fast decline of the world and its trend towards destruction.

3. Description of the vastness of Jannah and Hell.

4. Reference to the affluence of the Companions of the Prophet (PBUH) which they had at a subsequent stage. It was in fact fulfillment of the Promise of Allah that He will bestow upon them power and majesty in this world.

5. The description of the graceful conduct of the Companions of the Prophet (PBUH). In spite of having power and authority, they had neither arrogance nor pride. Goodwill and humility were special traits of their character and they always sought refuge with Allah against vanity and pride.

6. The Companions of the Prophet (PBUH) had sought to gain the pleasure of Allah rather than that of the people.

7. Humbleness of the Companions of the Prophet (PBUH), as well as their good conduct and uprightness despite being in a position of authority.

499. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: `Aishah (May Allah be pleased with her) showed us a sheet and a thick lower garment and said to us Messenger of Allah (PBUH) was wearing them when he died.
[Al-Bukhari and Muslim].

Commentary: The incident reported in this Hadith abundantly proves that the Prophet (PBUH) was not only austere in the matter of food but also in clothes and other worldly goods. He was contented with a minimum of necessities of life.

500. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: By Allah, I am the first Arab who shot an arrow in the Cause of Allah. We fought along with Messenger of Allah (PBUH) when our food was only the leaves of Hublah and Samur trees (wild trees) until one of us would defecate like the droppings of sheep.
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith offers justification for enumerating the Blessings of Allah and the hardships which one may have suffered in one's past life, provided one does not mention the latter by way of complaint.

2. Lack of provision does not mean that the Companions of the Prophet (PBUH) did not make any arrangement for food when they used to go for Jihad, but that their provision would finish during their campaigns.

What it actually means is the scarcity of food. They did not have foodstuff which could last till the end of the war, nor had they any system for its supply according to the requirements, with the result that they sometimes had to live on the tree-leaves.

501. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) used to supplicate: "O Allah, make the provisions of family of Muhammad (PBUH) bare subsistence.''
[Al-Bukhari and Muslim].

502. Abu Hurairah (May Allah be pleased with him) reported: By Allah other than Whom there is none worthy of worship, I used to press my stomach against the earth owing to my hunger; I would tie a stone over it. One day, I was sitting on the way they usually take when the Prophet (PBUH) passed by me. When he saw me he smiled at me and knew my condition and my feelings. He called me and I replied, "At your service, O Messenger of Allah.'' He said, "Follow me.'' So I followed him. Having arrived at home, he sought permission and entered. He allowed me in and I, too, entered. He found milk in a bowl and asked, "Where is this from?'' He was told that it was a gift for him from so-and-so. He called me and I responded: "At your service, O Messenger of Allah.'' He said, "Go to the people of As-Suffah and usher them in.'' He Abu Hurairah (May Allah be pleased with him) explained: The people of As-Suffah were guests of Islam; they had no family, no property and no relations. When Messenger of Allah (PBUH) used to receive something in charity, he would send it to them without taking anything from it. When he received a present, he would send for them and share it with them. On this occasion, I disliked to give them anything. I said to myself: "This meagre quantity of milk will not be enough for all the people of As-Suffah! I am more deserving of it than anyone else. By drinking it I may attain some strength. When they come, he will order me to give it to them. I do not expect that anything will be left for me from this milk.'' As there was no alternative but to obey Allah and His Messenger (PBUH). I went and called them. They came and sought permission which was granted. They took their seats. The Prophet (PBUH) called me and I responded, "At your service, O Messenger of Allah.'' He then said, "Take the milk and give it to them.'' I took the bowl and gave it to one man who drank his fill and returned it to me, and I gave it to the next and he did the same. I went on doing this till the bowl reached Messenger of Allah (PBUH). By that time all had taken their fill. He (PBUH) took the bowl, put it on his hand, looked at me, smiled and said, "Abu Hirr.'' I said, "At your service, O Messenger of Allah.'' He said, "Now you and I are left.'' I said, "That is true, O Messenger of Allah.'' He said, "Sit down and drink.'' I drank, but he went on saying, "Drink some more.'' I said, "By Him Who has sent you with the Truth, I have no room for it.'' He said, "Then give it to me.'' So I gave him the bowl. He praised Allah, uttered the Name of Allah and drank the remainder.
[Al-Bukhari].

Commentary: First, this Hadith indicates the miracle of the Prophet (PBUH) as well as his love and compassion for Ahlus-Suffah, i.e., those poor people who used to stay at As-Suffah. Second, the Prophet (PBUH) would not accept charity, but only gifts. Third, he would also let others share a gift given to him by somebody. Fourth, as seen in this incident, the leftovers of a Muslim, whether food or drink, is permissible to others to consume. Fifth, to persuade a guest to eat or drink more is commendable. Sixth, to eat or drink to one's fill, without extravagance, is also permissible.

503. Muhammad bin Sirin (May Allah be pleased with him) reported: Abu Hurairah (May Allah be pleased with him) said: "I would fall in swoon between the pulpit of (the mosque of) Messenger of Allah (PBUH) and the chamber of `Aishah (May Allah be pleased with her) and every passer-by would put his foot on my neck thinking I was insane. I was not insane but I was awfully hungry.''
[Al-Bukhari].

Commentary: The Hadith throws light on the poverty of the Companions as well as their self-respect, patience and contentment which prevented them from begging people.

504. `Aishah (May Allah be pleased with her) reported: When Messenger of Allah (PBUH) died, his armour was mortgaged with a Jew for thirty Sa` (measures) of barley.
[Al-Bukhari and Muslim].

Commentary: In the Hadith, there is a mention of the asceticism of the Prophet (PBUH) and also a permissibility for transactions with the people of the Book (the Jews and the Christians). That is why he mortgaged his coat of mail with a Jew and took a loan against it.

505. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) mortgaged his armour for a quantity of barley, and I took to him some barley bread and rancid fat. I heard him saying: "The family of Muhammad never possessed a measure of wheat from dawn to dusk although they were nine houses (to feed).''

[Al-Bukhari].

Commentary: The Prophet (PBUH) was perfectly humble and very generous to the point that he did not put anything away for himself until he had to mortgage his own armour for food.

506. Abu Hurairah (May Allah be pleased with him) reported: I saw seventy of the people of As-Suffah and none of them had a cloak. They had either a lower cloth or a blanket which they suspended from their necks. Some reached half way down to the legs and some to the ankles, and one of them would manage to keep it in his hand to avoid exposing his private parts.
[Al-Bukhari].

507. `Aishah (May Allah be pleased with her) reported: The mattress of Messenger of Allah (PBUH) was a piece of tanned skin stuffed with palm fibres.
[Al-Bukhari].

Commentary: The Prophetic model of a simple way of living pictured in these Ahadith is vastly different from today's luxurious lifestyle adopted by Muslims. May they adopt the simplicity of their Prophet (PBUH)!.

508. Ibn `Umar (May Allah be pleased with them) reported: We were once sitting in the company of Messenger of Allah (PBUH) when a man from the Ansar came and greeted. As he was leaving, Messenger of Allah (PBUH) said to him, "O brother of the Ansar, how is my brother Sa`d bin `Ubadah?'' He replied, "He is well.'' Messenger of Allah (PBUH) asked, "Which of you is desirous of visiting him?'' Having said this he got up and we followed him. We were ten and odd in number and we had neither shoes nor light boots nor caps nor shirts. We walked on foot through the barren plain till we came to the residence of Sa`d (May Allah be pleased with him). His people made way and Messenger of Allah (PBUH) along with those who accompanied him went up to him.
[Muslim].

Commentary: In this Hadith the description which the Companions made about their condition reflects its relevance with this chapter. Second, we come to know that the Prophet (PBUH) called Sa`d (May Allah be pleased with him) as his brother. This shows his perfect humbleness and great care for his Companions. Third, if the house is small, the host is presumed to make arrangement within the narrow space to accommodate the visitors, so that they may sit beside the patient for a while and enquire about his health.

509. `Imran bin Husain (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The best of you, are my contemporaries, then those who follow them, then those who will come after them. (`Imran said, I do not know if he said this twice or thrice). Then, they will be followed by those who will testify but will not be called upon to testify; they will betray the trust, and will not be trusted. They will make vows but will not fulfill them, and obesity will prevail among them.''
[Al-Bukhari and Muslim].

Commentary: In this Hadith, three eras have been called as the best of ages in a graded order: first, the Prophetic era, second, the Successors' era, and third, the Followers of the Successors' era. Goodness and religion collectively prevailed during this time. Then gradually there was an overall deterioration and every new era that the pass of time brought it, proved to be worse than the preceding one. Today's Muslims have fallen due to their weakness in character. Now, the majority of Muslims lack morals and belief as described in the Qur'an and the Hadith. The complaint is to be lodged only with Allah!

510. Abu Umamah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "O son of Adam, if you spend the surplus, it will be better for you; and if you retain it, it will be evil for you. You will not be reprimanded for storing what is enough for your need. First of all spend upon those who are your dependents.''
[At-Tirmidhi].

Commentary: The Muslims have been allowed, rather emphatically told and commanded, to possess as much wealth as could meet their personal and family needs. Yet, they have also been advised to spend the spare money on the needy. Man has been told that it is unwise on his part to be niggardly about money because it spawns unfavourable results in this world as well as in the Hereafter. The concentration of wealth within a few hands freezes its vitality and leads to corruption in society. As for the Hereafter, the result of stinginess will be definitely bad as the Qur'an says:

"The things which they covetously withheld shall be tied to their necks like a collar on the Day of Resurrection.'' (3:180)

Some `Ulama' are of the opinion that after the payment of the annual Zakat (poor-due), it is not necessary to spend more. But to be accurate, if somebody pays Zakat and yet retains enough money with him, and there are some needy people also in his knowledge, then he will be bound to spend on them. At-Tirmidhi quoted a Hadith in which Messenger of Allah (PBUH) said, "Indeed there is a right (for poor) in the wealth in addition to Zakat.''

511. `Ubaidullah bin Mihsan Al-Ansari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whosoever begins the day feeling family security and good health; and possessing provision for his day is as though he possesed the whole world.''
[At-Tirmidhi].

Commentary: To have one-day food and to enjoy peace and health is indeed a great blessing. It may be said that one has the same satisfaction which one can have on getting the whole world. And if one lacks peace and health, the treasures of the whole world will be of no use because the heaps of wealth cannot provide peace of mind to one, nor can it make one enjoy sound health. The Hadith also implies an advice to man that instead of running after wealth, he should endeavour to seek patience and contentment which alone can guarantee him peace and satisfaction. Otherwise, he is likely to stake everything on the pursuit of this mirage.

512. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Successful is the one who enters the fold of Islam and is provided with sustenance which is sufficient for his day's needs, and Allah makes him content with what He has bestowed upon him.''
[Muslim].

Commentary: The real success of a man will be measured by his being blessed with Divine mercy and forgiveness in the Hereafter, and this is contingent on Islam alone. If he lacks the wealth of Islam, all the worldly possessions will not ensure his success in the next world. This Hadith tells us that richness is not to be defined in terms of a lot of belongings, and that the real richness is gauged by the contentment of the soul.

513. Fadalah bin `Ubaid Al-Ansari (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) say: "Happiness is due to him who is guided to Islam and possesses provision that suffices him for his day and remains content.''
[At-Tirmidhi].

Commentary: The word Tuba (translated here as happiness) is given to Jannah. Some Ahadith say that it is the name of a heavenly tree as well. Lexically, however, it means greeting and good tiding. The sense of this Hadith is analogous to that of the previous one.

514. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) went to bed hungry for several successive nights, nor did his family have a thing for supper for many consecutive nights; and their bread was mostly of barley.
[At-Tirmidhi].

Commentary: This Hadith also displays the asceticism and economic scantiness of the Prophet (PBUH) and his wives.

515. Fadalah bin `Ubaid (May Allah be pleased with him) reported: When Messenger of Allah (PBUH) led Salat, some people would fall down from their standing posture out of extreme hunger. They were of the people of As-Suffah. The nomad Arabs would say that they were insane. After concluding Salat, Messenger of Allah (PBUH) would turn to them and say, "If you were to know what is in store for you with Allah, the Exalted, you would wish to augment your starvation and lack of provisions.''
[At-Tirmidhi].

Commentary: The habit of maintaining self-respect in the period of studentship makes man self-respecting, patient and content throughout his life. The dignity of `Ulama' lies in patience, contentment and indifference and not in wishing to drain the purses of others and asking them for alms.

516. Miqdad bin Ma`dikarib (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) say: "No man fills a container worse than his stomach. A few morsels that keep his back upright are sufficient for him. If he has to, then he should keep one-third for food, one-third for drink and one-third for his breathing.''
[At-Tirmidhi].

Commentary: This Hadith dissuades us from overeating as this causes laziness and affects one's health.

517. Abu Umamah bin Tha`labah (May Allah be pleased with him) reported: The Companions of Messenger of Allah (PBUH) mentioned the life of the world before him. He (PBUH) said, "Do you not hear? Do you not hear? Simplicity (in life) is part of Faith, simplicity is part of Faith.''
[Abu Dawud].

Commentary: This Hadith invites our attention to a simple way of living - ordinary dress and simple and non-rich food - and discourages us from being habitual of an affected life style - use of costly dress, delicious and rich food and other dainties of life. The more a man shuns the trappings and accessories of life, the better engaged will he be in being readied for the Hereafter. The increased degree of his involvement in worldly comforts and luxuries will keep decreasing his concern for the accountability of future life. We may keep it in mind that simplicity does not mean escape from cleanliness. Because cleanliness is in itself `half the Faith'. How can a believer ignore purity and cleanliness?

518. Jabir bin `Abdullah (May Allah be pleased with them) reported: Messenger of Allah (PBUH) sent us in an expedition under the command of Abu `Ubaidah (May Allah be pleased with him) to intercept a caravan of the Quraish. He provided us with a bag of dates, apart from which he found nothing for us. Abu `Ubaidah (May Allah be pleased with him) gave each of us one date (every day). He (the narrator) was asked: "What did you do with that?'' He said: We sucked that just like a baby and then drank water over that, and it was sufficient for us for the day until night. We beat off leaves with the help of our sticks, then drenched them with water and ate them. We then went to the seaside, when there appeared before us something like a big mound. We came near it and we found that it was a beast called Al-Anbar. Abu 'Ubaidah (May Allah be pleased with him) said: "It is dead (so it useless for us).'' He then said: "No (but it does not matter), we have been sent by Messenger of Allah (PBUH) in the way of Allah and you are hard-pressed (on account of the scarcity of food), so you can eat that.'' We, three hundred in number, stayed there for a month until we fattened up (having plenty to eat of that fish). He (Jabir) said: I saw how we extracted pitcher after pitcher full of fat from the cavity of its eye, and sliced from it compact piece of meat equal to a bull or almost like a bull. Abu 'Ubaidah (May Allah be pleased with him) called thirteen men from us and he made them sit in the cavity of its eye, and he held one of its ribs and raised it erect and then saddled the biggest of the camels we had with us and it passed through it (the arched rib), and we carried large pieces of meat for use in our journey. When we came back to Al-Madinah we went to Messenger of Allah (PBUH) and told him about that, whereupon he said, "That was a sustenance Allah had brought forth for you. Do you have any piece of meat left with you, for us to eat.'' Jabir (May Allah be pleased with him) said: We sent to Messenger of Allah (PBUH) some of that (meat) and he ate it.
[Muslim].

Commentary: This Hadith also points to the economic pinch from which the Companions suffered in the early phase of Islam. They braved it patiently. Secondly, The blessing came to them in the sense that each one of them was patient enough to live on a single date-fruit and water in twenty-four hours. Thirdly, it emphasizes that according to the circumstances, there is always room for Ijtihad (independent juristic reasoning). First Abu 'Ubaidah (May Allah be pleased with him) hesitated, but later he established a different opinion on the basis of his Ijtihad and decided to use the body of the giant fish as food. Fourthly, it provides us a proof of the sacrifice of the Companions that Allah miraculously granted them such a huge sea-fish that a group of three hundred people kept eating for one month. Fifthly, it tells us that a sea-carrion is a lawful food as indicated in another Hadith: "The water of the sea and its carrion are both Halal.'' Sixthly, this particular fish, like the whale, is a gigantic phenomenon which is normally about 50 feet long.''

519. Asma' bint Yazid (May Allah be pleased with them) reported: The sleeves of the shirt of Messenger of Allah (PBUH) reached his wrists.
[At-Tirmidhi].

Commentary: Wearing long clothes is commonly known to be a sign of arrogance. Moreover, such type of dress retreads physical movement, whereas short clothes cause inconvenience to the wearer in summer and winter. Moderation, therefore, is the best way and therefore, the Prophetic example.

520. Jabir (May Allah be pleased with him) reported: On the day of the battle of Al-Khandaq (the Trench), we were digging the trench when a very hard boulder came in our way. The Companions went to Messenger of Allah (PBUH) and told him about it. He said, "I will go down the trench to see it.'' He stood up and it was noticed that he had tied a stone over his stomach due to intense hunger. We had not tasted anything for three days. He took up a spade and struck the hard rock with it and it turned into sand. I sought his permission to go home, (after reaching home I) said to my wife, "I have seen the Prophet (PBUH) in a state that I am unable to endure. Have you got anything in the house?'' She said, "I have a small quantity of barley and a lamb.'' I slaughtered the lamb, ground the barley and put the meat in the cooking pot. Then I went to the Prophet (PBUH). In the meantime the flour had been kneaded and the meat in the pot was nearly cooked. I said to him, "O Messenger of Allah, I have some food, will you come along with one or two Companions?'' He asked, "How many men should go there?'' I told him the number. He said, "It will be better if they are more in number. Tell your wife not to remove the pot from the hearth nor the bread from the oven till I arrive.'' Then he said to the Muhajirun and the Ansar: "Let us go (to eat).'' They all rose (and went with him). I went to my wife and said, "Bless you, the Prophet (PBUH), the Muhajirun, the Ansar and the whole company are coming.'' She said, "Did he (PBUH) ask you?'' I replied in the affirmative. (When they arrived) Messenger of Allah (PBUH) said to his Companions, "Enter, but do not crowd in.'' Then he started breaking up the bread and putting meat on it. He would take from the pot and the oven then would cover them up, approach his Companions and hand it over to them. He would then go back and uncover the pot and the oven. He continued to break up the bread and put meat on it till all had eaten to their fill and still some of the food remained. Then he said to my wife, "Eat from it, and send it as a present, for the people have been afflicted with severe hunger.''
[Al-Bukhari and Muslim].

Another narration is: Jabir said: When the trench was being dug, I noticed the signs of hunger on the face of the Prophet (PBUH). I returned to my wife and said to her, "Have you got anything in the house? I have seen the signs of severe hunger on the face of Messenger of Allah (PBUH).'' She brought out a bag which contained a Sa` (a measure that equals approximately 3kg.) of barley. We had a lamb which was reared in the home. I slaughtered the lamb and she ground the flour for baking bread. I then cut the meat and put it in the cooking pot. When I was returning to Messenger of Allah (PBUH), my wife said to me, "Do not embarass me before Messenger of Allah (PBUH) and his Companions.'' (She said this because she thought that the food would not be enough for everyone, for how can very little food cater for a thousand people?) When I came to him, I said to him in a low tone, "O Messenger of Allah (PBUH), we have slaughtered a small lamb and have ground a Sa` of barley. Please accompany me with a few of your Companions.'' Thereupon he (PBUH) announced in a loud voice, "O people of the Trench, Jabir has arranged a feast for you, so all of you are welcome.'' And addressing me he said, "Do not take the pot off the fire, nor bake the kneaded flour till I arrive.'' So I came home and he came ahead of the people. My wife said, "It will be a matter of disgrace for you (because there is not enough food).'' I said, "I did only what you told me.'' She brought out the kneaded flour and Messenger of Allah (PBUH) spat into it, and invoked the blessing of Allah on it, and then he spat into the cooking pot and invoked the blessing of Allah on it. Then he said, "Call another woman to help bake bread and let her take out from the cooking pot, but do not take it off the fire.'' There were about a thousand guests. All of them ate till they left the food and went off. Our pot still bubbled as before and the dough was being baked as before.

Commentary: This Hadith throws light on the simple life style which the Prophet (PBUH) and his Companions led. It also throws light on the miracle of the augmentation of food. Besides, it highlights the humbleness of the Prophet (PBUH) that he, side by side with his Companions, also did hard and arduous jobs. Also we are informed that it is preferable to make an offering, particularly to a needy and hungry person.

521. Anas (May Allah be pleased with him) reported: Abu Talhah (May Allah be pleased with him) said to (to his wife) Umm Sulaim(May Allah be pleased with her), "I noticed some weakness in the voice of Messenger of Allah (PBUH) and I feel it was due to hunger. Have you got any food?'' She said, "Yes.'' So she brought out barley loaves, took off her head covering, in a part of which she wrapped these loaves and then put them beneath my mantle and covered me with a part of it. She then sent me to Messenger of Allah (PBUH). I set forth and found Messenger of Allah (PBUH) sitting in the mosque in the company of some people. I stood near them whereupon Messenger of Allah (PBUH) asked, "Has Abu Talhah sent you?'' I said, "Yes.'' Thereupon he said to those who were with him to get up (and follow him). He went forth and so did I, ahead of them until I came to Abu Talhah and informed him. Abu Talhah said, "O Umm Sulaim, here comes Messenger of Allah (PBUH) along with the people and we do not have enough (food) to feed them.'' She said, "Allah and His Messenger know better.'' Abu Talhah went out (to receive him) until he met Messenger of Allah (PBUH), and he came forward along with him until they both (Messenger of Allah (PBUH) and Abu Talhah (May Allah be pleased with him) came in. Then Messenger of Allah (PBUH) said, "O Umm Sulaim, bring forth what you have with you.'' So she brought the bread. Messenger of Allah (PBUH) commanded that the bread be broken into small pieces and after Umm Sulaim (May Allah be pleased with her) had squeezed clarified butter out of a butter container and made it just like soup. Messenger of Allah (PBUH) recited over it what Allah wished him to recite. He then said, "Allow ten guests to come in.'' They ate until they had their fill. They then went out. He (Messenger of Allah (PBUH)) again said, "Allow ten (more to come in)'', and he (the host) ushered them in. They ate to their fill. Then they went out. He (PBUH) again said, "Allow ten (more),'' until all the people ate to their fill. They were seventy or eighty persons.
[Al-Bukhari and Muslim].

Another narration is: Anas said: When all had eaten, the remaining food was collected. It was as much as there was in the beginning.

Yet another narration is: Anas said: The groups of ten people ate by turn. After eighty persons had eaten, Messenger of Allah (PBUH) and the family of that house ate, and there was still a quantity left over.

Another narration is: Anas (May Allah be pleased with him) said: I visited Messenger of Allah (PBUH) one day, and found him sitting in the company of his Companions, with a belt tied over his waist. I asked, "Why has Messenger of Allah (PBUH) tied the belt on his waist?'' I was told, "Due to hunger.'' I went to Abu Talhah (May Allah be pleased with him) the husband of Umm Sulaim (May Allah be pleased with her) and said, "O father, I have seen Messenger of Allah (PBUH) with a belt tied over his waist. I asked one of his Companions about the reason of it and he said that it was on account of severe hunger.'' Abu Talhah (May Allah be pleased with him) went to my mother and asked, "Have you got anything?'' She said, "Yes. I have a piece of bread and some dry dates. Were Messenger of Allah (PBUH) to come alone, we could feed him his fill, but if he comes along with others, there would not be enough food.'' Anas then narrated the Hadith in full.

Commentary: This Hadith mentions the same things we have seen in the previous one. Yet, in this latter one, there is an elucidation that the Prophet (PBUH) and the host-family took meal after everybody had taken it. Imam An-Nawawi said: This shows that it is desirable that hosts should take meal after guests have taken it.

Secondly, Anas (May Allah be pleased with him) addressed Abu Talhah (May Allah be pleased with him) as father and he did so out of respect. Abu Talhah (May Allah be pleased with him) was the step-father of Anas (May Allah be pleased with him). His real father was Malik bin An-Nadir and mother was Umm Sulaim (May Allah be pleased with him). She embraced Islam but her husband remained a non-believer. He left his Muslim wife and migrated to Syria where he died. Afterwards she married Abu Talhah (May Allah be pleased with him). Thirdly, the events of ascetic, contented and destitute life as experienced by the Prophet (PBUH) and his Companions are unthinkable today. But these are such facts, reported most authentically, as can be hardly refuted by being labelled as myths. Yet, some scholars say that it was a particular phase of time when there existed a conflict between Islam and paganism. It demanded that Muslims, by being indifferent to the world and its comforts, should be engaged day and night in uprooting disbelief, and paving the way for the predominance of Islam.


Contentment and Self-esteem and avoidance of unnecessary begging of People

Chapter 57
Contentment and Self-esteem and avoidance of unnecessary begging of People

Allah, the Exalted, says:

"And no moving (living) creature is there on earth but its provision is due from Allah.'' (11:6)

"(Charity is) for Fuqara (the poor), who in Allah's Cause are restricted (from travel), and cannot move about in the land (for trade or work). The one who knows them not, thinks that they are rich because of their modesty. You may know them by their mark, they do not beg of people at all.'' (2:273)

"And those, who, when they spend, are neither extravagant nor niggardly, but hold a medium (way) between those (extremes).'' (25:67)

"And I (Allah) created not the jinn and mankind except that they should worship Me (Alone). I seek not any provision from them (i.e., provision for themselves or for My creatures) nor do I ask that they should feed Me (i.e., feed themselves or My creatures).'' (51:56,57)

522. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Richness is not the abundance of wealth, rather it is self-sufficiency.''
[Al-Bukhari and Muslim].

Commentary: Self-sufficiency means that man lives on whatever he possesses, remains contentedly independent of others and avoids begging of them. Herein lies a suggestion that man should submit to Divine dispensation. He should not desire more than he needs, nor should he keep an eye on the wealth of others.

523. `Abdullah bin `Amr bin Al-as (May Allah be pleased with them) reported: the Messenger of Allah (PBUH) said, "Successful is the one who has entered the fold of Islam and is provided with sustenance which is sufficient for his needs, and Allah makes him content with what He has bestowed upon him.''.
[Muslim].

Commentary: To be contented with the independent subsistence (Kafaf) has been counted a merit by the Prophet (PBUH) because this prevents one from begging of people. The Hadith points out the excellence of those people who remain satisfied with their limited resources and do not beg of people. Similarly, autarky has its own merit because affluence often makes a man proud, whereas penury lowers his image in the eyes of people. Yet adequate livelihood has no room for the pitfalls of the two other situations.

524. Hakim bin Hizam (May Allah be pleased with him) reported: I begged Messenger of Allah (PBUH) and he gave me; I begged him again and he gave me. I begged him again and he gave me and said, "O Hakim, wealth is pleasant and sweet. He who acquires it with self-contentment, it becomes a source of blessing for him; but it is not blessed for him who seeks it out of greed. He is like one who goes on eating but his hunger is not satisfied. The upper hand is better than the lower one.'' I said to him, "O Messenger of Allah, by Him Who sent you with the Truth I will not, after you, ask anyone for anything till I leave this world.'' So Abu Bakr (May Allah be pleased with him) would summon Hakim (May Allah be pleased with him) to give his rations, but he would refuse. Then 'Umar (May Allah be pleased with him) would call him but he would decline to accept anything. So 'Umar (May Allah be pleased with him) said addressing Muslims: "O Muslims, I ask you to bear testimony that I offer Hakim his share of the booty that Allah has assigned for him but he refuses my offer.'' Thus Hakim did not accept anything from anyone after the death of Messenger of Allah (PBUH), till he died.
[Al-Bukhari and Muslim].

Commentary: Man constantly remains engaged in hoarding wealth and there comes no point of termination to this process. Rather, the more he gets it, the more he is overpowered by lust for it till he is carried to the grave. If man gets wealth in a dignified way without being crazy for it, ethics certainly allows him to do so.

525. Abu Burdah (May Allah be pleased with him) reported: Abu Musa Al-Ash`ari (May Allah be pleased with him) said: "Six of us accompanied Messenger of Allah (PBUH) in an expedition. We had one camel with us; we rode it in turn. Our feet got injured and my nails also fell out. We wrapped up our feet in rags; and because of this the campaign came to be known as Dhat-ur-Riqa` (the Campaign of Rags).'' Abu Burdah (May Allah be pleased with him) says: Abu Musa reported this Hadith but regretted having done so. He said, "Would that I had not mentioned it!'' He said so because he disliked to disclose anything concerning his deeds.
[Al-Bukhari and Muslim].

Commentary: This Hadith also throws light on the ascetic and insightful life of the Companions and their submission to the Divine will. Moreover, we are told that it is advisable not to disclose virtuous deeds in order to avoid committing the sin of showing off.

526. `Amr bin Taghlib (May Allah be pleased with him) reported: Some booty or prisoners of war were brought to Messenger of Allah (PBUH) and he distributed them, giving some men and neglecting others. Then, he was informed that those whom he had not given a thing were displeased. On this the Messenger of Allah (PBUH) praised Allah and glorified Him and said, "It is a fact that I give to one and overlook another. The one I ignore is dearer to me than the one I give. I give to those in whose hearts I perceive anxiety; others I leave with the richness and contentment that Allah has put in their hearts. One of them is `Amr bin Taghlib.'' Upon this `Amr bin Taghlib said, "By Allah I shall not accept a herd of red camels in exchange for what the Prophet said (about me).''
[Al-Bukhari].

Commentary: Whatever voluntary gifts or the spoils of war were brought to Messenger of Allah (PBUH), he divided them out to the Companions. In distribution, he weighed different considerations in his mind and the beneficiaries were categorized into three groups: the needy, the deserving cases and those whose hearts were to be won over. His primary concern, however, was to make donations to only those people about whom he had apprehensions that, if ignored, they would display impatience and weakness. In this way the reliable and contented type of men were intentionally ignored. The superiority of `Amr bin Taghlib (May Allah be pleased with him) is determined by the fact that the Prophet (PBUH) counted him among the latter, and he rightly took it as a great honour for him. Hence, we conclude that a ruler enjoys powers of expediency with regard to doling out from the public treasury. Yet, he is supposed to carry into practice what is implied by piety, integrity and trustworthiness. He must not be subordinate to self interests.

527. Hakim bin Hizam (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The upper hand is better than the lower one; and begin (charity) with those who are under your care; and the best charity is (the one which is given) out of surplus; and he who wishes to abstain from begging will be protected by Allah; and he who seeks self-sufficiency will be made self-sufficient by Allah.''
[Al-Bukhari].

Commentary: In this Hadith the underlying points are self-evident but the last point is very important: Those who avoid begging of others and remain independent of them are beloved to Allah. Indeed He helps such people. Instead of leaving them alone to be degraded on account of begging, He bestows upon them the sense of self-sufficiency, patience and contentment.

528. Abu Sufyan (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Do not be importunate in begging. By Allah! If one of you asks me for something and I give it to him unwillingly, there is no blessing in what I give him.''
[Muslim].

Commentary: Here one has been prevented from making demands to others importunately, pressingly and persistently. Because even if one gets something in this way, it will be bereft of blessing. The reason is that the giver's will is not involved in the matter as he has given the charity to the beggar with a sense of reluctance and aversion and out of modesty.

529. `Auf bin Malik Al-Ashja`i (May Allah be pleased with him) reported: Seven, eight or nine people, including myself, were with Messenger of Allah (PBUH) on an occasion when he (PBUH) remarked, "Would you pledge allegiance to Messenger of Allah?'' As we had taken oath of allegiance shortly before, we said, "We have already done so, O Messenger of Allah.'' He again asked, "Would you not pledge allegiance to Messenger of Allah?'' So we stretched out our hands and said, "We have already made our pledge with you, O Messenger of Allah, on what should we make a pledge with you?'' He said, "To worship Allah and not to associate anything with Him, to perform the five (daily) Salat and to obey.'' Then he added in a low tone, "And not to ask people for anything.'' Thereafter, I noticed that some of these people who were present did not ask anyone to pick up even the whip for them if it fell from their hands. [Muslim].

Commentary: Herein we find an approval of renewing the oath of loyalty; besides, there is also a ground for administering such oath in respect of the obedience and worship of Allah, and decent behaviour. What is more, we are also under obligation to observe all that the oath of fealty stands for.

530. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said, "If one of you would keep begging (of people) until he meets Allah (on the Day of Resurrection) his face will be without a shred of flesh.''
[Al-Bukhari and Muslim].

Commentary: The lack of flesh from the face is either metaphorically indicative of disgrace and wretchedness, or it would factually happen as a symptom of sinning and the punishment thereof. This seems to be more plausible. Aversion against begging has been fomented in this Hadith because it brings shame both in this world and the Hereafter.

531. Ibn `Umar (May Allah be pleased with them) reported: While Messenger of Allah (PBUH) was on his pulpit (in the mosque) delivering a Khutbah (religious talk) about Sadaqah (charity) and begging, he said, "The upper hand is better than the lower hand, the upper hand is the one which gives and the lower hand is the begging one.''
[Al-Bukhari and Muslim].

532. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who begs to increase his riches is in fact asking only for a live coal. It is up to him to decrease it or increase it.''
[Muslim].

Commentary: We come to know that begging without a pressing need is such a disgraceful crime that it brings one to Hell-fire. What a pity that beggary prevails among the followers of a religion which brands it as an abominable crime! It is extremely pitiable and lamentable that Muslims are ignorant of and indifferent to Islamic teachings.

533. Samurah bin Jundub (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Begging is a cut that a person inflicts upon his face; except for asking a ruler, or under the stress of circumstances from which there is no escape.''
[At-Tirmidhi].

Commentary: To submit his demand to the Head of state means that if a man deserves help, he should go to the public treasury which exists in an Islamic country so as to fulfill the needs of the needy gracefully. If his access to it is not possible, he is free to put his demand to others as well.

534. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who suffers poverty and seeks relief from people, he will not be relieved; but he who seeks relief from Allah Alone, he will be relieved sooner or later.''
[Abu Dawud and At-Tirmidhi].

Commentary: In this Hadith, it has been suggested that a man in need should turn to Allah Alone and not to human beings because He Alone meets the needs of all creatures. Yet, if the situation and need so demand, he may also resort to people, but he should have the firm conviction that their co-operation and help depend on the Will of Allah.

535. Thauban (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who guarantees me that he will not beg anything from anyone, I will guarantee him (to enter) Jannah.'' I said, "I give you the guarantee.'' Then Thauban (May Allah be pleased with him) never begged anything from anyone.
[Abu Dawud].

Commentary: Not to seek any kind of aid from anybody means that a request should not be made as such without need. Because in the hour of need a man is permitted by the Shari`ah to request somebody to meet his requirement. Yet, if on such occasions he still avoids begging of anybody, it will reflect a very high point of his scrupulous uprightness. Later Thauban (May Allah be pleased with him) adopted this way. Ibn Majah says in his Sunan that if from the horseback his whip fell on the ground, instead of seeking the help of anybody he would himself get down and pick it up.

536. Qabisah bin Al-Mukhariq (May Allah be pleased with him) reported: I stood as surety for a debt and came to Messenger of Allah (PBUH) to seek his help in discharging it. Messenger of Allah (PBUH) said, "Wait till we receive charity and I shall give you out of it.'' He (PBUH) added, "O Qabisah, begging is not lawful except for three people. One who has incurred debt (for assuming guarantee), for him begging is permissible till the guarantee is discharged and he should then refrain; a person whose property has been destroyed by a calamity is allowed to beg till he attains self-sufficiency; a person who meets with dire necessity (due to hunger) provided that three men of understanding from his people affirm the genuineness (of his poverty), for him begging is lawful till he attains means of his subsistence. Other than these, O Qabisah, anything received through begging is unlawful, its recipient devours it unlawfully.''
[Muslim].

Commentary: This Hadith explicitly tells us about the three types of men who are allowed to beg of others. A detailed description has already been mentioned above.

537. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "A needy person is not the one who goes from door to door, begging and is turned away with a morsel or two or with a date or two. But a needy person is the one who does not have enough to live upon, and neither from his appearance it occurs that he is needy and should be given alms, nor does he himself beg anything from others.''
[Al-Bukhari and Muslim].

Commentary: The professional beggars and the truly needy have clearly been identified here. The point is that we should try to find out deserving people and spend on them. Because, despite being needy, they do not wear a professional look nor do they approach anybody to receive alms. In no way will it be counted as charity if we satisfy ourselves by giving a few coins to a professional beggar whom we come across on the road


Permissibility of Assistance without Greed

Chapter 58
Permissibility of Assistance without Greed

538. Salim, son of Abdullah bin `Umar, from his father Abdullah; from `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) would give me some gift, but I would say: "Give it to someone who needs it more than I.'' Thereupon he (PBUH) would say, "Take it when it comes to you without begging and without greed, and add it to your property. Then use it yourself or give it away in charity. As for the rest, do not covet it.'' Salim said: `Abdullah bin `Umar would never ask anything from anyone, nor would he refuse accepting it when it was given to him.
[Al-Bukhari and Muslim].

Commentary: In this Hadith, three points merit our attention. First, there is an account of the exemplary character of the Companions who became unmindful of their own needs when they saw that somebody else was more needy and deserved assistance. Second, there is an allowance for accepting a gift provided one's heart is free from desire for it. Third, a man is allowed to accumulate wealth but on the condition that he would fulfill his personal and family needs. Besides, he should resolve that he would also spend money on the needy as well as on the lines approved by Allah so as to win His pleasure.


Encouraging Livelihood by (working with) Hands and Abstaining from Begging

Chapter 59
Encouraging Livelihood by (working with) Hands and Abstaining from Begging

Allah, the Exalted, says:

"Then when the (Jumu`ah) Salat (prayer) is ended, you may disperse through the land, and seek the Bounty of Allah (by working).'' (62:10)

539. Zubair bin `Awwam (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "It is far better for you to take your rope, go to the mountain, (cut some firewood) carry it on your back, and sell it and thereby save your face than begging from people whether they give you or refuse.''
[Al-Bukhari].

Commentary: As compared to beggary, this Hadith puts emphasis on hard work. However, people may look down upon manual labour or hard work, yet it is certainly far better than seeking charity servilely, because doing a job like this will certainly save a man's self-respect, whereas begging puts him in an awkward position. To put it in this way, Islam stands for a man's deliverance from indignity and teaches him to keep his sense of dignity.

540. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "It is better for anyone of you to carry a bundle of wood on his back and sell it than to beg of someone whether he gives him or refuses.''
[Al-Bukhari and Muslim].

541. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "(Prophet) Dawud (PBUH) ate only out of that which he earned through his manual work.''
[Al-Bukhari].

542. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "(Prophet) Zakariyya (PBUH) was a carpenter.''
[Al-Bukhari].

543. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "No food is better to man than that which he earns through his manual work. Dawud (PBUH), the Prophet of Allah, ate only out of his earnings from his manual work.''
[Al-Bukhari].

Commentary: Labour and manual work make the living of a man good, laudable and excellent. The Prophets also earned their living with their own work. Upon such earnings we get the Blessing of Allah. Some people wrongly think that earning a living is at variance with trust in Allah. Rather the right form of trust requires us to adopt ways and means according to our capacity and then to leave the matter to Allah. Also the Prophetic argument tells us that any manual skill or occupation, and the one who depends on it for his living should not be considered inferior. Instead, such people deserve respectable and worthy place in society because they emulate the example of the Prophets. In our society, a highbrow attitude towards them is unfortunate and deserves our deprecation. We have chosen to put some trades in a very low estimate and so is our view of those who are attached with them. In fact, no trade is inferior, nor is the person who adopts it.


Excellence of Generosity and Spending in a Good cause with Reliance on Allah

Chapter 60
Excellence of Generosity and Spending in a Good cause with Reliance on Allah

Allah, the Exalted, says:

"And whatsoever you spend of anything (in Allah's Cause), He will replace it.'' (34:39)

"And whatever you spend in good, it is for yourselves, when you spend not except seeking Allah's Countenance. And whatever you spend in good, it will be repaid to you in full, and you shall not be wronged.'' (2:272)

"And whatever you spend in good, surely Allah knows it well.'' (2:273)

544. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Envy is permitted only in two cases: A man whom Allah gives wealth, and he disposes of it rightfully, and a man to whom Allah gives knowledge which he applies and teaches it.''
[Al-Bukhari and Muslim].

Commentary: Envy in the Hadith means "Ghibtah'' the equivalent of which does not exist in English language. What it means is that you wish to enjoy things which others have, such as wealth and knowledge, without wishing that they should be deprived of them to your exclusive benefit. Envy is a corrosive disease of moral nature which snatches away man's peace of mind. It means resentment at the condition of a man enjoying some Divine favour, and to wish it to be finished. It is forbidden because it wipes out one's good deeds. But there is no harm in being enviable of somebody. It has some positive connotation in the sense that you admire Allah's Blessing over a person and wish to be favoured with it too. This Hadith interprets envy as a "Ghibtah'' but not in the absolute sense because it is condemnable.

This Hadith, however, points out in unambiguous terms the excellence of a rich man who not only spends the Gifts of Allah (SWT) on his own person but also allocates a portion of it to the poor and the needy as well as to the propagation of religion. It further throws light on the excellence of a man who is well-grounded in theological doctrine and suggests solutions to people's problems in the light of the Qur'an and the Hadith and also imparts the religious knowledge to others. Everybody should aspire, apart from affluence, for an excessive fervour of spending in the way of Allah. Moreover, the quest of Islamic disciplines and their underlying rationale should remain at the centre of his heart, so that he may inherit the legacy of the Prophets, doing full justice to it as well. None can do it but with the Blessing of Allah.

545. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) asked, "Who of you loves the wealth of his heir more than his own wealth?'' The Companions said: "O Messenger of Allah! There is none of us but loves his own wealth more.'' He (PBUH) said, "His wealth is that which he has sent forward, but that which he retains belongs to his heir.''
[Al-Bukhari].

Commentary: This Hadith spotlights in a wise fashion the significance and perception of spending in the way of Allah. The real wealth of man is that which he spends in His way and the channels He approves. Only this wealth will stand him in good stead on the Day of Resurrection. Otherwise, what apart from it, will be personally used up by him in the worldly life, and what he leaves behind will fall to the lot of his heirs. It implies that if Allah has bestowed worldly riches upon a man, he should spend them to the maximum in the way to Allah.

546. `Adi bin Hatim (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Protect yourself from Hell-fire even by giving a piece of date as charity.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned previously. It tells us that, according to one's resource capacity, one can win the pleasure of Allah even by spending a small quantity of wealth in His way.

547. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) never said `no' to anyone who asked him for anything.
[Al-Bukhari and Muslim].

Commentary: This Hadith illustrates the refined morals, sublimity of soul and the generosity of the Prophet (PBUH). Had somebody asked him of something, provided it was in his possession, he would never say `no' to him. He would also on occasions resort to borrowing to meet the want of a needy person. If the borrowing were not possible, he would promise to fulfill his need.

548. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Everyday two angels descend and one of them says, `O Allah! Compensate (more) to the person who gives (in charity)'; while the other one says, `O Allah! Destroy the one who withholds (charity, etc)".
[Al-Bukhari ].

Commentary: The spending for which there is good news of Divine blessing may be said as expenses on household and guests, etc., as well as voluntary and obligatory charity. And the miserliness which incurs imprecation is restraining from paying Zakat, giving alms and not spending on what is commendable. Destruction may imply the destruction of wealth or that of the miser himself. Only Allah knows better!

549. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah, the Exalted, says, `Spend, O son of Adam, you will also be spent upon.''
[Al-Bukhari and Muslim].

Commentary: According to the Hadith, one who spends in the way of Allah, will be duly paid. It means that Allah will enhance the provision of such a man and grant him the best recompense.

550. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: A man asked Messenger of Allah (PBUH), "Which act in Islam is the best?'' He (PBUH) replied, "To feed (the poor and the needy) and to greet those whom you know and those you do not know.''
[Al-Bukhari and Muslim].

Commentary: The provision of food to somebody may signify almsgiving or offering or an act of hospitality. It may also be interpreted as meeting the want of a needy person: If he is hungry, he should be fed; if he lacks clothes, the same should be given to him; if he is sick, medicine should be provided to him; and if he is under debt, he should be helped to pay off his debt, and so on. As for greeting (saying `As-Salamu `alaikum'), it is meant to be popularized because it brings hearts closer to each other and is an antidote to hatred and hostility.

551. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with him) reported: the Messenger of Allah (PBUH) said, "There are forty kinds of virtue, the highest of which is to gift a (milch) she goat. He who practises any of these virtues, expecting its reward (from Allah) and believing on the verity of the promise made for it, will enter Jannah.''
[Al-Bukhari].

Commentary: The Hadith speaks of the returnable gift of a mammal like a goat or she-camel which should be gifted to somebody for the provision of milk or wool. It is also a benevolent act and good trait of character. The forty qualities of character, as mentioned in this Hadith, have been enumerated by some `Ulama' in their own respective ways. But Al-Hafiz Ibn Hajar Al-Asqalani says that the Prophet (PBUH) did not name these qualities, and that perhaps the reason behind this is that no one should disparage or underestimate a good act, no matter how small it may be, because this could lead to doing without this good act altogether.

552. Abu Umamah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "O son of Adam, if you spend the surplus, it will be better for you; and if you retain it, it will be bad for you. You will not be reprimanded for keeping what is enough for your need. Begin with those who are your dependents, and the upper hand (i.e., the one that spends in the way of Allah) is better than the lower hand (i.e., the one that receives charity.)''
[Muslim].

Commentary: A similar Hadith reported by At-Tirmidhi has already been mentioned. Read the commentary on (Hadith No. 510).

553. Anas (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) was asked a thing by one who is about to accept Islam but he would give it. A man came to the Prophet (PBUH) and he gave him a herd of sheep scattered between two mountains. When he returned to his people, he said to them: "O my people! Embrace Islam because Muhammad gives like one who has no fear of poverty.'' Some people would embrace Islam only for worldly gains, but soon Islam becomes dearer to them than the world with all what it contains.
[Muslim].

Commentary: In this Hadith, there is a provision of giving economic aid to converts to win over their hearts so that their loyalty to Islam is firmly established. The result of this sensible policy was that if somebody had embraced Islam for the sake of gaining material gains, this sentiment, in due course of time, would be stripped off from his heart, and finally he would turn into a sincere Muslim. In view of its rationale, Allah has termed the policy of reconciling hearts, to Islam as a Zakat expenditure. In other words, an allocated sum of the Zakat fund can be expended on this head as well. Some scholars argue that it is now no more permissible to spend on this head. But to be accurate, expending out of the Zakat fund on this head is valid for all times. If a measure is adequately taken on an institutional basis to make the hearts of converts incline to Islam, we can witness its benefits even today.

554. `Umar (May Allah be pleased with him) reported: Messenger of Allah (PBUH) distributed some wealth and I said to him, "O Messenger of Allah! Do you not think that there are other people who are more deserving than these whom you gave.'' He (PBUH) said, "They had, in fact, left no alternative for me except either they should beg of me importunately or they would regard me as a miser; but I am not a miser.''
[Muslim].

Commentary: Here also, we hear about the same converts who were still ignorant of Islam and the status of Prophethood. Owing to this ignorance and weak faith, they could adopt such attitude as would have been inappropriate or would have caused lack of courtesy towards the Prophet (PBUH). This brought him to giving preference to them with regard to the distribution of offerings so as to guard them against the sway of the weakness referred to. This reflects the Prophet's generosity and his accommodating sense as well as the care which he took to win over the hearts as mentioned earlier. The purpose behind it was to help increase Faith in their hearts and make them rise above mundane interests as sincere Muslims.

555. Jubair bin Mut`im (May Allah be pleased with him) reported: While I was walking with the Prophet (PBUH) on his return from the battle of Hunain, a few bedouins caught hold of him and began to demand their shares. They forced him to a tree and someone snatched away his cloak (which got entangled in that thorny tree). The Prophet (PBUH) said, "Give my cloak back to me. Were I to have camels equal to the number of these trees, I would have distributed them all among you, and you would not have found me a miser, or a liar, or a coward.''
[Al-Bukhari].

Commentary: This Hadith also throws light on the issue of distribution of charities for winning over hearts; besides, it depicts the sublime morals of the Prophet (PBUH) as to how he tolerated the harshness and discourtesy of bedouins with patience and humbleness. It also reveals that negative attributes like stinginess, falsehood and cowardice should not be attributed to Imam (religious leader).

556. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Wealth is not diminished by giving (in charity). Allah augments the honour of one who forgives; and one who displays humbleness towards another seeking the pleasure of Allah, Allah exalts him in ranks.''
[Muslim].

Commentary: This Hadith has described three facts. First, Sadaqah does not diminish wealth because Allah blesses the rest of it and thus recompenses it. Besides, the loss of wealth of the almsgiver will certainly be rewarded on the Day of Resurrection. Second, man thinks that a conciliatory or forgiving attitude will weaken his position in the eyes of others. He erroneously takes it as his disparagement and insult. However, this Hadith reveals the reality that by this way, Allah (SWT) raises his image and he is not belittled at all, because a forgiving gesture will enhance his esteem in the hearts of people, and in the Hereafter, Divine reward for it will definitely lead to his elevation. Third, if somebody displays affability and humbleness in his behaviour, Allah (SWT) will project his prestige and dignity into the hearts of others or bless him in the Hereafter.

557. Abu Kabshah `Amr bin Sa`d (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "I swear by Allah for three (qualities) which I am going to tell you about. Remember them well:

(1) The wealth of a man will not diminish by Sadaqah (charity).

(2) Allah augments the honour of a man who endures an oppression patiently.

(3) He who opens a gate of begging, Allah opens a gate of poverty (or he said a word similar to it).''

He (PBUH) also said, "Remember well what I am going to tell you: The world is for four kinds of people. (1) One upon whom Allah has bestowed wealth and knowledge and so he fears his Rubb in respect to them, joins the ties of blood relationship and acknowledges the Rights of Allah on him (and fulfills them); this type will have the best position (in Jannah). (2) One upon whom Allah has conferred knowledge but no wealth, and he is sincere in his intention and says: `Had I possessed wealth, I would have acted like so-and-so.' If that is his intention, his reward is the same as that of the other. (3) One whom Allah has given wealth but no knowledge and he squanders his wealth ignorantly, does not fear Allah in respect to it, does not discharge the obligations of kinship and does not acknowledge the Rights of Allah. Such a person will be in the worst position (in the Hereafter). (4) One upon whom Allah has bestowed neither wealth nor knowledge and he says: `Had I possessed wealth, I would have acted like so-and-so (i.e., he would squander his wealth).' If this is his intention, both will have equal sin.''
[At-Tirmidhi].

Commentary: This Hadith highlights the following points:

1. Those who forgive people and pardon them will be granted honour and elevation both in this life and in the Hereafter.

2. Those who have sufficient means to live on and still beg of people out of greed, will be afflicted with poverty.

3. The Hadith also urges us to acquire religious knowledge, and also the practise of this knowledge along with the intention to please Allah Alone.

4. The Hadith also criticizes ignorance of religious teachings and ignorant people, for ignorance can easily lead one to commit forbidden acts.

558. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) had slaughtered a sheep and distributed major portions of its meat. Then he (PBUH) asked, "Is there anything left?'' She replied, "Nothing, except the shoulder.'' Thereupon he said, "All of it is left except its shoulder.''
[At-Tirmidhi].

Commentary: This Hadith reveals a truth to man that he should not eat up anything and everything all alone, rather in this regard he is supposed to take the maximum care for the distribution of alms and charity so that it may stand him in good stead in the Hereafter. What one has given in charity will by no means be wasted, for he will doubtlessly find its reward with Allah on the Day of Resurrection.

559. Asma' bint Abu Bakr (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said to me, "Do not hoard; otherwise, Allah will withhold from you.''
[Al-Bukhari and Muslim].

Commentary: Herein is enshrined a Divine principle; His Retribution is determined by the kind of things done by man. A proverb may be quoted to this effect, "As you sow, so shall you reap''. If we spend a lot in the way of Allah, He will also recompense us a lot. And if we stint spending in His way, He will dispense sustenance to us with restrain, too. If we accumulate wealth in a miserly fashion and avoid spending it in the way of Allah, He will also restrain the flow of His bounty to us. To sum up, the Hadith inspires us to generously spend money in the way of Allah and also sternly warns us of the consequences of stinginess and parsimony.

560. Abu Hurairah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying: "The case of a miserly man and a generous man who gives in charity is similar to that of two persons who are clad in armour from their breasts up to their collar bones. When the generous man gives in charity, his armour expands so much as to cover his fingertips and toes. When the miser intends to spend something the armour contracts and every ring of it sticks to the place where it is (sinks into his flesh). He tries to loosen it but it does not expand.''
[Al-Bukhari and Muslim].

Commentary: The Hadith metaphorically highlights the significance of giving in charity, saying it covers up a man's sins in such way as a full coat of mail, reaching his feet, conceals his whole body. Aside from it, there is a good news for the almsgiver that his wealth will receive Divine blessing and he will be safe from trials and tribulations. Whereas a miser faces a warning that his sins and defects will be made known to people and not concealed from them, and he will remain the target of miseries. We are further told that when a generous man intends to give charity, his chest expands for it and he happily gives vent to his generosity. On the other hand, when a niggardly man intends to spend money in charity, his chest contracts and he withholds his giving hand. To conclude, this Hadith brings good news to generous people, and a warning to misers.

561. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who gives in charity the value of a date which he legally earned, and Allah accepts only that which is pure, Allah accepts it with His Right Hand and fosters it for him, as one of you fosters his mare, until it becomes like a mountain.''
[Al-Bukhari and Muslim].

Commentary: Here is an Attribute of Allah, His Hand, has been mentioned. We are supposed to believe in it without interpretation or comparison; that is to say that Allah has Hands as befit His Glory. We cannot compare his essential attributes to anything, nor can we describe them.

It is evident from this Hadith that Allah increases the reward of charity which is given from lawfully-earned money until it becomes like a mountain in greatness.

562. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "While a man was walking through a barren land, he heard a voice coming out of a cloud saying: `Irrigate the garden of so-and-so.' Thereupon the cloud drifted in a certain direction and discharged its water over a rocky plain. The streamlets flowed into a channel. This man followed the channel until it reached a garden and he saw the owner of the garden standing in its center, working with his spade spreading the water (changing the course of the water). He asked him: "O slave of Allah, what is your name?'' He told his name, which was the same that he heard from the cloud. The owner of the garden then asked him: "O slave of Allah, why did you ask my name?'' He replied: "I heard a voice from a cloud which poured down this water saying: `Irrigate the garden of so-and-so.' I would like to know what do you do with it.'' He said: "Now that you asked me, I will tell you. I estimate the produce of the garden and distribute one-third of it in charity, I spend one-third on myself and my family and invest one-third back into the garden.''
[Muslim].

Commentary: This Hadith, besides the virtue of alms and charity, touches upon the theme of clairvoyance and miracles. It is something supernormal that a man should hear a voice from the cloud. Yet such supernatural phenomenon signify only the Omnipotence of Allah. Nobody is presumed to claim that he can demonstrate at will something unusual by virtue of his clairvoyant and miraculous power. There are indeed some people who lay such a claim and thereby swindle away the money of gullible souls and lead them astray.


Prohibition of Miserliness

Chapter 61
Prohibition of Miserliness

Allah, the Exalted, says:

"But he who is greedy miser and thinks himself self-sufficient. And belies Al-Husna. We will make smooth for him the path for evil. And what will his wealth avail him when he goes down (in destruction)?'' (92:8-11)

"And whosoever is saved from his own covetousness, then they are the successful ones.'' (64:16)

563. Jabir bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Beware of oppression, for oppression will be darkness on the Day of Resurrection; and beware of stinginess because it destroyed those who were before you. It incited them to shed their blood and deem unlawful as lawful.''
[Muslim].

Commentary: This Hadith has been mentioned before. Refer to Hadith No. 205.


Selflessness and Sympathy

Chapter 62
Selflessness and Sympathy

Allah, the Exalted, says:

"And give them (Emigrants) preference over themselves, even though they were in need of that.'' (59:9)

"And they give food, in spite of their love for it (or for the love of Him), to the poor, the orphan, and the captive.'' (76:8)

564. Abu Hurairah (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said; "I am hard pressed by hunger.'' He (PBUH) sent a word to one of his wives who replied: "By Him Who has sent you with the Truth, I have nothing except water.'' Then he sent the same message to another (wife) and received the same reply. He sent this message to all of them (i.e., his wives) and received the same reply. Then he (PBUH) said, "Who will entertain this (man) as guest?'' One of the Ansar said: "O Messenger of Allah, I will.'' So he took him home and said to his wife: "Serve the guest of Messenger of Allah (PBUH).''

Another narration is: The Ansari asked his wife: "Have you got anything?'' She answered: "Nothing, except a little food for the children.'' He said: "Keep them busy with something, and when they ask for food put them to sleep. When the guest enters, extinguish the light and give him the impression that we are also eating.'' So they sat down and the guest ate and they passed the night hungry. When he came to the Prophet (PBUH) in the morning, he said to him, "Allah admired what you did with your guest last night.''
[Al-Bukhari and Muslim].

Commentary: This Hadith describes a unique example of hospitality and kindness liked by Allah. It imparts to man the sense of self-sacrifice and a feeling of fellowship.

565. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The food for two suffices for three; and the food for three suffices for four persons.''
[Al-Bukhari and Muslim].

In Muslim, Jabir (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The food for one person suffices for two; the food for two suffices for four, and the food fof four suffices for eight persons.''

Commentary: We are told that if on some occasion a host feels that the prepared food is too little to feed his guests, all of them should willingly share it with each other. This will be both blessing and rewarding from Allah.

566. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Once we were on a journey with Messenger of Allah (PBUH) when a rider came and began looking right and left. Messenger of Allah (PBUH) said, "Whoever has an extra mount should offer it to him who is without it, and whoever has surplus food should give it to him who has nothing;'' and he continued mentioning other properties until we thought that none of us had any right to surplus of his own property.
[Muslim].

Commentary: The mention of this Hadith in this chapter reveals that in their social life, particularly in a period of crisis, the Muslims should adopt a co-operative, consolatory and sympathetic attitude towards one another, being willing to give over their superfluous things to the needy Muslims. This commandment, however, is not of essential and binding nature. If it were so, no Muslim could be in a position to amass wealth. This is simply desirable and based on free will. If the common Muslims were possessed of generosity, this moral instruction would have been practised by all and sundry with Muslim society being exemplary in terms of brotherhood and solidarity. Yet, the lack of sublime morals has denuded this precept of its entire import and significance. Small wonder, in Muslim communities there is a general deplorable trend of showing indifference to fellow-Muslims, instead of establishing a worth-emulating example of co-operation and fellow-feeling.

567. Sahl bin Sa`d (May Allah be pleased with him) reported: A woman brought a woven piece of cloth to Messenger of Allah (PBUH) and said to him: "I have woven this sheet with my own hands for you to wear.'' He accepted it as he was in need of it. He later came out wearing it as a lower garment. Someone said: "How nice it is! Kindly give it to me.'' Messenger of Allah (PBUH) said, "Very well.'' He remained in our company for some time, then he went back, folded it and sent it to the man. The people said (to that man): "You did not do well. Messenger of Allah (PBUH) wore it and he was in need of it, and you asked him for it when you are well aware that he (PBUH) never refuses a request.'' He said: "I swear by Allah that I did not ask it for wearing. I asked him for it so that it might be my shroud after my death.'' Sahl (the narrator of this Hadith) said: And in fact it was used as his shroud.
[Al-Bukhari].

Commentary: First, the Hadith is suggestive of accepting a present because the exchange of presents increases mutual love. Messenger of Allah (PBUH) said, "Offer presents to each other as these generate mutual love.'' Second, the Prophet (PBUH) would never turn down anyone asking for something. Third, it is permissible to get a thing prepared to meet a future need. Fourth, we are allowed to receive a benediction from the pious ones as the Companions did in case of those things which had touched the blessed body of Messenger of Allah (PBUH). Yet, today the benedictory sanction is being misapplied by people. For example, the washing of graves is erroneously taken to be a sacred act. Whereas, going by the Islamic Law, there is no room for the concretion of a grave, still less of washing it. Rather this act is unclean and sacrilegious. Similarly, we see some half-mad and insane people bereft of the sense of purity and cleanliness. Yet, the masses consider them to be ecstatics and even try to seek benediction from them. As a matter of fact, such lunatics are totally unconscious of the obligations of Islam, rather everything else. But the sanity of a man becomes questionable if he considers them saints. Also there are places where some relics, attributed to the Prophet (PBUH), are at display but without historical authenticity. We are supposed to shun them.

568. Abu Musa (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When the Ash`ariyun run short of food in the Jihad or when they are at home in Al-Madinah, they collect all the provisions they have in a sheet and then divide it equally among themselves. They are of me and I am of them.''
[Al-Bukhari and Muslim].

Commentary: "They are of me and I am of them''. These Prophetic words of the Prophet (PBUH) imply nearness to and psychic identity (with some souls) in matter of moral sense, character and good actions. Apart from the superiority of Ash`ari clan, the Hadith suggests the significance of brotherhood and the sense of togetherness. Particularly there is an emphasis on this point that if in times of crisis and tribulation, people extend co-operation to one another, the have-nots will escape hardship and embarrassment. Herein lies the essence of all the Ahadith of this chapter. The Ash`ariyun are the people of Abu Musa Al-Ash`ari, the Companion (May Allah be pleased with him).


Competition in matters of the Hereafter

Chapter 63
Competition in matters of the Hereafter

Allah, the Exalted, says:

"Let (all) those strive who want to strive (i.e., hasten earnestly to the obedience of Allah).'' (83:26)

569. Sahl bin Sa`d (May Allah be pleased with him) reported: A drink was brought to the Messenger of Allah (PBUH) and he drank some of it. On his right was a boy and on his left were elderly people. He said to the boy, "Would you permit me to give the rest of this drink to these on my left?'' The boy said, "O Messenger of Allah, I would certainly not give preference to anyone in anything that might come to me from you.'' So he handed over the rest of the drink to him.
[Al-Bukhari and Muslim].

Commentary: The Shari`ah rule says that in order to distribute something in an assembly of people, a beginning should be made from the right side. In the said incident, Ibn `Abbas (May Allah be pleased with them) then a young boy, was sitting on the right side, while the aged people were sitting on the left side. Regard for the age difference demanded that the beginning should have been made from the side of the latter. But the correct way was that the beginning should be made from Ibn `Abbas (May Allah be pleased with them) because he was sitting on the right side. For this reason, the Prophet (PBUH) did not ignore his right of priority due to his young age, rather by seeking his permission he made it clear that priority should be given to a rightful person, irrespective of the fact that he happened to be a child. On the other hand, it was also essential for Ibn `Abbas (May Allah be pleased with them) that in view of respect for elders, he should surrender his right. But he faced a more delicate problem. The cup containing the left-over drink of the Prophet (PBUH) had touched his blessed mouth and this fact prompted Ibn `Abbas i(May Allah be pleased with them) to take lead in benefiting from the benediction. He, therefore, preferred the Prophetic benediction to showing respect to the aged. The Hadith throws light on the requisite respect for the aged as well as highlights the significance of receiving blessing from the pious persons. Besides, it proves the right of priority of the rightful person.

570. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "While Ayyub (PBUH) the Prophet was taking a bath, naked, a large number of gold locusts fell on him. He tried to collect them in a piece of cloth, when he heard his Rubb (Allah) calling him: `O Ayyub ! Have I not sufficed you to care for what you see (the worldly possessions)?' Ayyub (PBUH) said: `Indeed by Your Power, but I can never do away with Your Blessings.'''
[Al-Bukhari].

Commentary: Prophet Ayyub (PBUH), as the Hadith tells us, started collecting the gold pieces that looked like locusts. As the Hadith involves an aspect of blessedness, it has been included in this chapter. It has two other sides as well: first, one can amass wealth (of course by fair means and by fulfilling the other relevant conditions); second, the Shari`ah allows man to take a bath in the naked state, provided he is all alone and away from all eyes. However, it is commendable if one takes a bath with his private parts being covered, even if there is no one around.


Excellence of a Grateful Rich Man

Chapter 64
Excellence of a Grateful Rich Man

Allah, the Exalted, says:

"As for him who gives (in charity) and keeps his duty to Allah and fears Him, and believes in Al-Husna. We will make smooth for him the path of ease (goodness).'' (92:5-7)

"And Al-Muttaqun (the pious and righteous) will be far removed from it (Hell). He who spends his wealth for increase in self-purification. And who has (in mind) no favour from anyone to be paid back. Except to seek the Countenance of his Rubb, the Most High. He surely, will be pleased (when he will enter Jannah).'' (92:17-21)

"If you disclose your Sadaqat (alms-giving), it is well; but if you conceal them and give them to the poor, that is better for you. (Allah) will expiate you some of your sins. And Allah is Well-Acquainted with what you do.'' (2:271)

"By no means shall you attain Al-Birr (piety, righteousness - here it means Allah's reward, i.e., Jannah), unless you spend (in Allah's Cause) of that which you love; and whatever of good you spend, Allah knows it well.'' (3:92)

571. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Envy is permitted only in two cases: A man whom Alah gives wealth, and he disposes of it rightfully, and a man to whom Allah gives knowledge which he applies and teaches it.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. Yet, its relevance with this chapter has prompted us to repeat it here. It lays emphasis on two points. First, if Allah gives wealth to a man, his sense of gratitude should be expressed in his spending it in good ways according to the Divine command. Second, if Allah has endowed somebody with knowledge and wisdom, he should be thankful to his Rubb by way of putting it into practice and by imparting it to others. It means one can aspire for knowledge and richness, provided one's motive is to benefit others. Envy is a bad quality which Muslims must shun. In this Hadith, however, envy (or Ghibtah) refers to the feeling of wishing to have what somebody else has or to be like somebody else without these blessings be taken away from the envied person.

572. Ibn `Umar (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said: "Envy is justified in regard to two types of persons only: a man whom Allah has given knowledge of the Qur'an, and so he recites it during the night and during the day; and a man whom Allah has given wealth and so he spends from it during the night and during the day.''
[Al-Bukhari and Muslim].

Commentary: Ahadith permit us to envy (in the positive sense of the word: see commentary on the previous Hadith) only two traits of character of somebody. Grammatically, the texts of these Ahadith imply both feminine and masculine genders. In the preceding Hadith, the word 'knowledge' has been used. It stands for the Word of Allah. To apply and teach knowledge means to put into practise the teachings of the Qur'an. And that includes the recitation of the Qur'an (both in Salat and otherwise), imparting its teaching and passing judgements in its light. From this point of view both the Ahadith convey the similar sense, and similarly we may also read into them two persons or two traits of character.

573. Abu Hurairah (May Allah be pleased with him) reported: Some of the poor Emigrants came to Messenger of Allah (PBUH) and said to him, "The wealthy have obtained all high ranks and everlasting bliss.'' He asked, "How is that?'' They replied: "They offer Salat as we do, and observe Saum (fasting) as we do, but they give in Sadaqah (charity) and we do not, and they emancipate slaves and we cannot.'' He (PBUH) said, "Shall I not teach you something whereby you will catch up with those who have preceded you and will get ahead of those who follow you, and no one will surpass you unless he does the same as you do?'' They said, "Surely, O Messenger of Allah.'' He said, "Say: Subhan Allah, and Allahu Akbar, and praise Him (by saying Al-hamdu lillah) thirty-three times at the end of every Salat.'' They returned to him and said: "Our brothers, the possessors of wealth, having heard what we are doing, have started doing the same.'' Messenger of Allah (PBUH) said, "This is Grace of Allah which He gives to whom He wishes.''
[Al-Bukhari and Muslim].

Commentary: The wording of the Hadith apparently reveals that Subhan Allah "Glory be to Allah'', Al-hamdu lillah "Praise be to Allah'', and Aallhu Akbar "Allah is the Greatest'' should be recited thirty-three times. If each group of words is said eleven times, the total number will become thirty-three. But Al-Hafiz Ibn Hajar believes that each formula should be uttered thirty-three times, that is to say, after each prayer "Subhan Allah'', "Al-hamdu lillah'' and "Allahu Akbar'' should be uttered thirty-three times each. But according to some Ahadith, Imam An-Nawawi is of the view that "Allahu Akbar'' should be said thirty-four times and in the end "La ilaha illallahu Wahdahu la sharika Lahu, Lahul-mulku wa Lahul-hamdu, wa Huwa `ala kulli shai'in Qadir'' (none has the right to be worshipped but Allah, He is One; He has no partners; to Him belongs the dominion and all the praise; and He has power over all things) should be recited. Should we recite them together or separately? Al-Qadi `Iyad is of the opinion that it is better to recite them separately, but Imam An-Nawawi is of the view that both ways are correct. In fact, in both ways the number remains the same. Besides, an addition must not be made to the Sunnah of Messenger of Allah (PBUH). Practically we knew that it is necessary to use the prescription of a physician without making any alteration in its elements; otherwise, it will not work properly. Similarly, there are spiritual benefits, blessings and efficacy in the number told by the Prophet (PBUH). Any alteration in it will nullify its blessing and efficacy. (Fath Al-Bari).

This Hadith reveals how fervently the Companions were inclined towards good and how concerned about surpassing those who were better than them in some forms of good deeds. Indeed, all Muslims are equal with regard to the practice of religious principles. But what gives an edge to the rich over their poor coreligionists are the financial forms of worship, that is, charity and almsgiving, which the latter are unable to do.


Remembrance of Death and Restraint of Wishes

Chapter 65
Remembrance of Death and Restraint of Wishes

Allah, the Exalted, says:

"Everyone shall taste death. And only on the Day of Resurrection shall you be paid your wages in full. And whoever is removed away from the Fire and admitted to Jannah, he indeed is successful. The life of this world is only the enjoyment of deception (a deceiving thing).'' (3:185)

"No person knows what he will earn tomorrow, and no person knows in what land he will die...'' (31:34)

"...when their term comes, neither can they delay nor can they advance it an hour (or a moment).'' (16:61)

"O you who believe! Let not your properties or your children divert you from the remembrance of Allah. And whosoever does that, then they are the losers. And spend (in charity) of that with which We have provided you, before death comes to one of you, and he says: `My Rubb! If only You would give me respite for a little while (i.e., return to the worldly life), then I should give Sadaqah (i.e., Zakat) of my wealth, and be among the righteous [i.e., perform Hajj (pilgrimage to Makkah) and other good deeds].' And Allah grants respite to none when his appointed time (death) comes. And Allah is All-Aware of what you do.'' (63:9-11)

"Until, when death comes to one of them (those who join partners with Allah), he says: `My Rubb! Send me back. So that I may do good in that which I have left behind!' No! It is but a word that he speaks; and behind them is Barzakh (a barrier) until the Day when they will be resurrected. Then, when the Trumpet is blown, there will be no kinship among them that Day, nor will they ask of one another. Then, those whose Scales (of good deeds) are heavy, they are the successful. And those whose Scales (of good deeds) are light, they are those who lose their ownselves, in Hell will they abide. The Fire will burn their faces, and therein they will grin, with displaced lips (disfigured). `Were not My Verses (this Qur'an) recited to you, and then you used to deny them?' They will say: `Our Rubb! Our wretchedness overcame us, and we were (an) erring people. `Our Rubb! Bring us out of this; if ever we return (to evil), then indeed we shall be Zalimun (polytheists, oppressors, unjust, wrong-doers, etc? He (Allah) will say: `Remain you in it with ignominy! And speak you not to Me!' Verily! There was a party of My slaves, who used to say: `Our Rubb! We believe, so forgive us, and have mercy on us, for you are the Best of all who show mercy!' `But you took them for a laughing stock, so much so that they made you forget My remembrance while you used to laugh at them! Verily! I have rewarded them this Day for their patience, they are indeed the ones that are successful. He (Allah) will say: `What number of years did you stay on earth?' They will say: `We stayed a day or part of a day. Ask of those who keep account.' He (Allah) will say: `You stayed not but a little, if you had only known! Did you think that We had created you in play (without any purpose), and that you would not be brought back to Us?''' (23:99-115)

"Has not the time come for the hearts of those who believe (in the Oneness of Allah - Islamic Monotheism) to be affected by Allah's Reminder (this Qur'an), and that which has been revealed of the truth, lest they become as those who received the Scripture [the Taurat (Torah) and the Injeel (Gospel)] before (i.e., Jews and Christians), and the term was prolonged for them and so their hearts were hardened? And many of them were Fasiqun (the rebellious, the disobedient to Allah).'' (57:16)

574. `Abdullah bin `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) took hold of my shoulders and said, "Be in the world like a stranger or a wayfarer.'' Ibn `Umar (May Allah be pleased with them) used to say: When you survive till the evening do not expect to live until the morning; and when you survive till the morning do not expect to live until the evening. While in good health (do good deeds) before you fall sick; and while you are alive (do good deeds) before death strikes.
[Al-Bukhari].

Commentary: This Hadith has already been mentioned. Refer to the commentary on Hadith No. 479.

575. `Abdullah bin `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "It is the duty of a Muslim who has something which is to be given as a bequest not to have it for two nights without executing a written will.''
[Al-Bukhari and Muslim].

In the narration of Muslim it is narrated as `three nights'. Ibn `Umar (May Allah be pleased with them) said: Since I heard the Messenger of Allah say this, I have never spent a night without having my will with me.

Commentary: The emphasis of Messenger of Allah (PBUH) on the necessity of making a last will shows that man has no knowledge of the time of his death. It is necessary for the rich that they should keep with them a testament so as to leave their affairs settled after their death and to ward off any untoward situation with regard to the distribution of their property among their inheritors.

576. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) drew a few lines and said, "One of them represents man and another indicates death; and a man continues like this until the nearest line (i.e., death) overtakes him.''
[Al-Bukhari].

577. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) drew up a square and in the middle of it he drew a line, the end of which jutted out beyond the square. Further across the middle line, he drew a number of smaller lines. Then he (PBUH) said, "The figure represents man and the encircling square is the death which is encompassing him. The middle line represents his desires and the smaller lines are vicissitudes of life. If one of those misses him, another distresses him, and if that one misses him, he falls victim to another.''
[Al-Bukhari].

Commentary: This means that human life is perpetually exposed to mishaps. If man escapes one mishap, he comes across the other one. His life is spent in a continuous struggle against tackling the hostile situations. Besides, his life remains entangled in unending hopes and wishes which are never fulfilled and finally he slips into the iron-grip of death. To sum up, man is ever closer to the border line of death and not supposed to remain unprepared for it. There is no end to wishful thinking and, therefore, he should not adopt a careless attitude towards the inescapable death in the pursuit of illusory hopes. The best course for him is to remain ever-ready for his exit from the worldly stage.

578. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Hasten to do good deeds before you are overtaken by one of the seven afflictions.'' Then (giving a warning) he said, "Are you waiting for poverty which will make you unmindful of devotion, or prosperity which will make you corrupt, or a disease which will disable you, or senility which will make you mentally unstable, or sudden death which will take you all of a sudden, or Ad-Dajjal who is the worst expected, or the Hour; and the Hour will be most grievous and most bitter.''
[At-Tirmidhi].

Commentary: The Hadith focuses on seven things which hold back man from the virtuous path. Taking in consideration the turning health and the brief span of life to his account, he is, therefore, apt to gather up good deeds for the Hereafter because an untoward situation may confront him any moment and render him unable to do good things to his benefit in the otherworldly life.

579. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Remember more often the destroyer of pleasures - death.''
[At-Tirmidhi].

Commentary: Being heedful and talking about death checks man from being lost in the worldly pleasures and seductions. We are, therefore, supposed to remember death frequently and to avoid remaining indifferent to post-death affairs and occurrences.

580. Ubayy bin Ka`b (May Allah be pleased with him) reported: When one-third of the night would pass, Messenger of Allah (PBUH) would get up and call out, "O people, remember Allah. The Rajifah (i.e., the first Blowing of the Trumpet which will shake the whole universe and thus cause all life to cease) has come, followed by Ar-Radifah (i.e., the second Blowing of the Trumpet which will restore life and thus mark the Resurrection Day). Death has approached with all that it comprises. Death has approached with all that it comprises.'' I said: "O Messenger of Allah (PBUH), I frequently invoke Allah to elevate your rank. How much of my supplications should I devote to you?'' He said, "You may devote as much as you wish.'' When I suggested a quarter, he said, "Do whatever you wish, but it will be better for you if you increase it.'' I suggested half, and he said, "Do whatever you wish, but it will be better for you if you increase.'' I suggested two-thirds, and he said, "Do whatever you wish but it will be better for you if you increase it.'' I said, "Shall I devote all my supplications invoking Allah to elevate your rank?'' He said, "Then you will be freed from your worries and your sins will be forgiven.''
[At-Tirmidhi].

Commentary: The Qur'an exactly corroborates what has been stated in this Hadith. There will be two soundings of the Trumpet. The first will throw the earth and mountains into tremendous convulsions, annihilating all life and disrupting the entire physical structure of the universe. The second - after an indefinite period of time known to Allah Alone - will mark the Resurrection Day and bring forth the whole scenario of the Last Judgement. Messenger of Allah (PBUH) has invited the attention of mankind to the horrendous ordeal awaiting it in the Last Hour. Besides, this Hadith urges the believers to send the maximum greetings to Messenger of Allah (PBUH). It also highlights the excellence of such an invocation. The Qur'an itself makes this demand to the believers:

"Allah sends His Salat (Graces, Honours, Blessings, Mercy) on the Prophet (Muhammad (PBUH)), and also His angels (ask Allah to bless and forgive him). O you who believe! Send your Salat on (ask Allah to bless) him (Muhammad (PBUH)), and (you should) greet (salute) him with the Islamic way of greeting (salutation, i.e., As-salamu `alaikum).'' (33:56).


Desirability of visiting the Graves for men, and that they should say

Chapter 66
Desirability of visiting the Graves for men, and that they should say

581. Buraidah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "(In the past) I forbade you from visiting graves, but visit them now.''

In another narration Messenger of Allah (PBUH) said, "Whoever wants to visit a graveyard, let him do so, because it reminds us of the Hereafter.''
[Muslim].

Commentary: The visit to the graves is not only recommendable from a theological point of view but, in the light of the Prophetic saying, it is also compulsory and binding. However, at the dawn of Islam it was forbidden due to the apprehension that the Muslims might relapse into some wrongdoing by harking back to the pre-Islamic memory. But when the Monotheistic Belief took root in their minds and the apprehension of pagan echoings evaporated, the ban on visiting the graves was lifted. Rather an emphasis was laid on such a visit, so that an overpowering thought of death might penetrate a believer's mind as a deterrent force against the promptings of his animal self. The believers must remember death and remember that they will be dead sooner or later. It has been reported that `Umar bin Al-Khattab(May Allah be pleased with him) used to address himself thus: "Death suffices to serve as an admonitor, O `Umar!''

582. `Aishah (May Allah be pleased with her): reported Whenever it was her turn to spend with Messenger of Allah (PBUH), he used to go to the Baqi` (graveyard in Al-Madinah) at the last part of night and say, "May you be safe, O abode of the believing people. What you have been promised has come to you. You are tarried till tomorrow and certainly we shall follow you if Allah wills. O Allah, forgive the inmates of the Baqi`-al-Gharqad.''
[Muslim].

Commentary: The example of Messenger of Allah (PBUH) shows that it is right to visit the graves even at night. But the visitor is required to pray the Prophetic prayer there as it invokes Divine blessing on and pardon to the dead. It may be emphasized here that to greet the dead is a prayer for them. It is not necessary that they should hear it and also respond to it. Allah has the power to make them hear it, too. But ours should not be the belief that the dead do hear and reply. The exact position is known to Allah Alone. We are only supposed to follow the example of Messenger of Allah (PBUH) and say the greeting and prayer as mentioned above.

583. Buraidah (May Allah be pleased with him) reported: The Prophet (PBUH) used to teach them (i.e., the Companions) whenever they came out to visit the graveyard to say: "As-salamu `alaikum ahlad-diyyari minal-Mu'minina wal-Muslimina, wa inna in sha' Allahu bikum lahiqun. As'alul-laha lana wa-lakumul- `afiyyah (May you be safe, O inmates of the abodes of the believers and the Muslims, and if Allah pleases, we shall follow you, we pray to Allah for well-being for ourselves and for you).''
[Muslim].

Commentary: This Hadith has a provision for a believer to visit the graveyard and to pray for his dead relatives, because the prayer of the living benefits the departed souls.

584. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) passed by the graves at Al-Madinah. He turned his face towards them and said, "May you be granted safety, O inmates of the graves. May Allah forgive us and you. You have preceded us, and we are to follow.''
[At-Tirmidhi].

Commentary: Imam At-Tirmidhi considers it as a credible Hadith and Imam An-Nawawi has also reduced it to writing without `ifs' and `buts'. However, Shaikh Al-Albani calls it undependable from the viewpoint of the chain of reporters. For a detailed study, one may refer to Ahkam Al-Jana'iz by Al-Albani, page 197.


Abomination of longing for Death

Chapter 67
Abomination of longing for Death

585. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "None of you should wish for death. If he is righteous, perhaps he may add to (his) good works, and if he is a sinner, possibly he may repent (in case he is given a longer life).''
[Al-Bukhari].

In Muslim, Abu Hurairah (May Allah be pleased with him) reported : Messenger of Allah (PBUH) said, "Let none of you wish for death, nor he ask for it before it comes to him, because when he dies, his actions will be terminated; certainly the age of a (true) believer does not add but good.''

Commentary: This Hadith forbids a believer to wish for his death as the longevity of his age suits him by all means. The longer he lives, the greater degree of progress will he make in virtues pursuits. And in case he infringes upon the Shari`ah rules, he may perhaps incline towards penitence. A believer should, therefore, consider his life as a boon and try his utmost to do good things.

586. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Let none of you wish for death on account of an affliction that befalls him. If he has no alternative, let him pray: `Allahumma ahyine ma kanatil-hayatu khairan li, wa tawaffani idha kanatil-wafatu khairan li (O Allah! Give my life so long as the life is good for me, and take away my life if death is good for me)'.''
[Al-Bukhari and Muslim].

Commentary: Here, too, a believer has been prevented from wishing for death. Because it betrays that he is far from agreeing to what Allah wills or has ordained. If at all his wishing becomes intense and indispensable under the pressure of circumstances, he should pray in the Prophetic words mentioned in the Hadith above.

587. Qais bin Abu Hazim (May Allah be pleased with him) reported: I went to visit Khabbab bin Aratt (May Allah be pleased with him) during his illness. He had been cauterized in seven places. He said: "Our companions who have died have left (this world) without having enjoyed the pleasures of the world (in order to get a great full reward in the Hereafter) while we have amassed wealth exceeding our needs for which there is no place to keep except in the earth. Had Messenger of Allah (PBUH) not prohibited us from longing for death, I would have prayed for it.'' Then we visited him again and he was building a wall. He said: "There is a reward in store for a Muslim in respect of everything on which he spends except for something he places in the earth (i.e., something exceeding our needs or essentials).''
[Al-Bukhari and Muslim].

Commentary: This Hadith forbids a believer to wish for his death as the longevity of his age suits him by all means. The longer he lives, the greater degree of progress he will make in the pursuit of virtues. And in case he infringes upon the Shari`ah rules, he may perhaps incline towards penitence. A believer should, therefore, consider his life as a boon and try his utmost to do good things .


Leading an Abstemious Life and refraining from the Doubtful

Chapter 68
Leading an Abstemious Life and refraining from the Doubtful

Allah, the Exalted, says:

"...you counted it a little thing, while with Allah it was very great.'' (24:15)

"Verily, your Rubb is Ever Watchful (over them).'' (89:14)

588. An-Nu`man bin Bashir (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "What is lawful is clear and what is unlawful is clear, but between them are certain doubtful things which many people do not know. So he who guards against doubtful things keeps his religion and his honour blameless. But he who falls into doubtful things falls into that which is unlawful, just as a shepherd who grazes his cattle in the vicinity of a pasture declared prohibited (by the king); he is likely to stray into the pasture. Mind you, every king has a protected pasture and Allah's involved limits is that which He has declared unlawful. Verily, there is a piece of flesh in the body, if it is healthy, the whole body is healthy, and if it is corrupt, the whole body is corrupt. Verily, it is the heart.''
[Al-Bukhari and Muslim].

Commentary: There are such meeting-points between what is permissible and what is not permissible in the matter of religion of which the majority of people are ignorant. If man abstains from them, it means that he is keeping his duty to Allah. Yet, if he is involved in them without caring for what is allowable or unallowable, he may be supposed to have outstepped the Divine limits. Businessmen and traders are particularly warned here to avoid things of dubious nature and are urged to adopt only that pattern which is lawful. Another important point underlying this Hadith concerns the heart. Its purity or impurity directly affects the human conduct in a good or bad way. It is, therefore, absolutely necessary to cleanse the heart of all wiles and impurities, and this is not possible without sound Faith and consciousness of Allah.

589. Anas bin Malik (May Allah be pleased with him) reported: The Prophet (PBUH) found a dry date-fruit lying in the way and said, "Had it not been for fear of being from charity I would have eaten it.''
[Al-Bukhari and Muslim].

Commentary: As Sadaqah and Zakat were forbidden to Messenger of Allah (PBUH) and the members of his family, he avoided to eat the date-fruit he had found in the way because he was not sure about the allowability of its nature. It is a lesson for a Muslim that he should stay away from a thing when he doubts its lawful aspect. The previous Hadith also confirms this view. Moreover, we come to know that the use of an insignificant thing found in the way is not forbidden. Similarly, one is permitted to pick up an eatable thing - provided it is not dubious - and eat it because it involves both humility and regard for a blessing.

590. An-Nawwas bin Sam`an (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Piety is good manner, and sin is that which creates doubt and you do not like people to know of it.''
[Muslim].

Commentary: Islam lays much importance on courteous behaviour and also explains and stresses its different aspects. To meet people cheerfully, to avoid causing trouble to them, rather to try to make things convenient and comfortable to them, to do social service, to extend co-operation to others in good things and to be generous, and to like for others also that you like for yourself, are all forms of moral behaviour that are counted as virtues in Islam. All that is bad and vicious is considered by Islam as sinful. This Hadith describes two signs of a sin. First, man should feel scruples in committing it. Second, one does not like others being informed about it. The Hadith further tells us that human nature leads man to correct conclusions and keeps him away from evils, provided it has not been deformed by the environment and bad company.

591. Wabisah bin Ma`bad (May Allah be pleased with him) reported: I went to Messenger of Allah (PBUH) and he asked me, "Have you come to inquire about piety?'' I replied in the affirmative. Then he said, "Ask your heart regarding it. Piety is that which contents the soul and comforts the heart, and sin is that which causes doubts and perturbs the heart, even if people pronounce it lawful and give you verdicts on such matters again and again.''
[Ahmad and Ad-Darmi].

Commentary: There are two points about this Hadith. First, it is one of the miracles of Messenger of Allah (PBUH) who discovered the nature of the question before it was put to him. Second, man's heart is the biggest guide to him and he, therefore, should keep his heart illuminated with the light of Faith so as to continue receiving guidance from it.

592. `Uqbah bin Al-Harith (May Allah be pleased with him) reported that he had married a daughter of Abu Ihab bin `Aziz and a woman came to him and said she had suckled both `Uqbah and the woman whom he had married, to which he replied: "I am not aware that you suckled me, and you did not inform me.'' So he (`Uqbah) rode to Messenger of Allah (PBUH) in Al-Madinah and put the matter before him. The Messenger of Allah (PBUH) said, "How can you continue (to be her husband) after what you have been told?'' `Uqbah (May Allah be pleased with him) therefore divorced her and she married another man.
[Al-Bukhari].

Commentary: Opinions differ about the evidence of a woman. But it is so about financial matters and Hudud (punishments) and Qisas (retaliation in punishment). For example, regarding the first, the Qur'an says that the evidence of two women is equal to that of one man. Similarly, the `Ulama' have not trusted the evidence of a woman about matters concerning Hudud and Qisas, rather they have considered in this connection, the evidence of man indispensable. However, they are all unanimous in accepting the evidence of even a single woman in matters of which men are uninformed. These, for instance, include the problems of a child's birth and its legitimacy and the weak points of women. And the argument is supported by this Hadith. When the woman gave evidence that she had suckled both the husband and the wife and was the foster-mother of the two, they separated from each other. Also, Messenger of Allah (PBUH) declared their wedlock untenable. The Hadith urges us to dispense with what is doubtful in order to be on the safe side in matters of religion.

593. Hasan bin `Ali (May Allah be pleased with them) reported: I have retained these words of Messenger of Allah (PBUH), "Leave what causes you doubt and turn to what does not cause you doubt.''
[At-Tirmidhi].

Commentary: This Hadith, as also mentioned previously, urges a believer to give up what appears to him doubtful.

594. `Aishah (May Allah be pleased with her) reported: Abu Bakr (May Allah be pleased with him) had a slave who brought him his earnings and Abu Bakr (May Allah be pleased with him) would eat from it. One day he brought him something and when Abu Bakr (May Allah be pleased with him) had eaten some of it, the slave asked him whether he knew where he had got that (food) from, Abu Bakr (May Allah be pleased with him) asked what it was, and he replied: I acted as a soothsayer for a man in the pre-Islamic period, and not being good at it, I deceived him; today he met me and he rewarded me for that soothsaying what you have eaten. Abu Bakr (May Allah be pleased with him) put his hand in his mouth and vomited up all that he had eaten.
[Al-Bukhari].

Commentary: Soothsaying was prevalent in the pre-Islamic Arab society. Islam brought an end to it and declared its income unlawful. That was the reason when Abu Bakr (May Allah be pleased with him) came to know that what he had eaten had been accrued to the slave from soothsaying, he vomited it up. The incident reflected his extreme continence and aversion to pagan customs and propensities.

595. Nafi` (May Allah be pleased with him) reported: `Umar bin Al-Khattab (May Allah be pleased with him) fixed the payment amounting to four thousand dirhams for each of the early Emigrants, but for his son, he fixed only three thousand five hundred. He was asked: "He is also an (early) Emigrant, why have you fixed a lesser sum for him?'' He said: "It was his father who took him along with him. He is not like one who emigrated by himself.''
[Al-Bukhari].

Commentary: This Hadith throws light on `Umar's fairness, fear of Allah, uprightness and sense of custodianship. The annual allowance which he got fixed from the treasury for his son was five hundred dirhams less than that given to other Muhajirun. His plea was that since the recipient had migrated to Al-Madinah accompanied by his parents, his grade should have been less as compared to those Muhajirun who had emigrated voluntarily.

596. `Atiyyah bin `Urwah As-Sa`di (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "No one will attain complete righteousness until he abandons (certain) unobjectionable (but doubtful) things so as to remain on his guard against something objectionable.''
[At-Tirmidhi].


Desirability of Seclusion at times of corruption committed by the people of the World

Chapter 69
Desirability of Seclusion at times of corruption committed by the people of the World

Allah, the Exalted, says:

"So flee to Allah (from His Torment to His Mercy - Islamic Monotheism), verily, I (Muhammad (PBUH)) am a plain warner to you from Him.'' (51:50)

597. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah loves a slave who is pious, free of all wants and the unnoticed.''
[Muslim].

Commentary: Isolation, according to this Hadith, is recommendable for the obedience and worship of Allah. It is particularly approved when the prevalent corruption and social intercourse endanger religion, or its implementation looks no more feasible.

598. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Someone asked Messenger of Allah (PBUH): "Who is the best man?'' He (PBUH) answered, "A believer who strives in the Cause of Allah with his life and his wealth.'' The man asked: "Who is the next?'' He said, "One who retires into a narrow valley and worships his Rubb.''

Another narration is: Messenger of Allah (PBUH) said, "One who fears Allah and safeguards people against his own mischief.''
[Al-Bukhari and Muslim].

Commentary: Here Jihad is counted as the supreme virtue and next to it comes the superiority of a man who takes to seclusion with this intention that he will worship Allah and keep away the evil of his animal self from the people.

599. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The best possession of a Muslim will be a herd of sheep with which he retires to the top of a mountain or places where rain is expected to fall (pastures) so as to safeguard with his faith from tribulation.''
[Al-Bukhari].

Commentary: At a certain period of history, says the Hadith, the virus of moral corruption will spread among people so perilously and so widely that, while living amongst them, one will hardly be able to save his religion. In such circumstances, there will be no other alternative than to escape from cities to save religion. Today, moral crisis faces the Islamic countries. The result is that the grip of religion over people is loosening day by day, rather they are constantly suffering the loss of religious values and principles. No wonder the work of the establishment and practice of religion is becoming more and more trying for the religious-minded people.

600. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Every Prophet has tended sheep''. He was asked: "And did you?'' He replied, "Yes, I tended them for a few carats for the Makkans.''
[Al-Bukhari].

Commentary: The Prophet (PBUH) used to graze the sheep of Makkans for a few carats (a carat is one-twentieth, or a bit more, of a dinar). This practice was indeed a Divine training for the Prophets so that it might be easier for them to deal with humans and forbear afflictions which came to them from men. A shepherd indeed needs greater patience and forbearance to look after his herd. This practice proved useful to the Prophets. Moreover, this Hadith is suggestive of the adoption of a lawful occupation, no matter how people may look askance at it. That was the reason why the Prophets took such occupations.

601. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The best of people is a man who is holding his horse's rein in the way of Allah (in Jihad) and is galloping towards the place wherever he hears a call for war or detects a note of danger; he goes on proceeding, seeking martyrdom or death wherever it is expected. And a man who retires with some sheep in a mountainside or a valley. He performs Salat regularly and pays the Zakat, continues worshipping his Rubb, till death overtakes him. He does not interfere in the affairs of the people except for betterment.''
[Muslim].

Commentary: Herein two types of men have been counted as the best of all. First, such man who remains engaged in the preparation for Jihad, being ever-ready for it. Second is the man who flees townships and takes shelters in a mountain or jungle, living on a few sheep; the motive behind his shift is the preservation and practice of his Faith and religion.


Excellence of mixing with People and attending their social activities

Chapter 70
Excellence of mixing with People and attending their social activities

Imam An-Nawawi says: Remember! Mixing with people in the way I have mentioned earlier is most desirable. This was the way of Messenger of Allah (PBUH) and other Prophets of Allah, the Righteous Caliphs (May Allah be pleased with them), the followers of the Companions, scholars and pious people. The majority of the followers of the Companions and their followers adopted it. Imam Ash-Sha-fi`i, Imam Ahmad and the majority of other jurists followed it.

Allah, the Exalted, says:

"Help you one another in Al-Birr and At-Taqwa (virtue, righteousness and piety).'' (5:2)

The Quranic Verses on the subject are many and well-known.


Modesty and Courtesy towards the Believers

Chapter 71
Modesty and Courtesy towards the Believers

Allah, the Exalted, says:

"And be kind and humble to the believers who follow you.'' (26:215)

"O you who believe! Whoever from among you turns back from his religion (Islam), Allah will bring a people whom He will love and they will love Him; humble towards the believers, stern towards the disbelievers.'' (5:54)

"O mankind! We have created you from a male and a female, and made you into nations and tribes, that you may know one another. Verily, the most honourable of you with Allah is that (believer) who has At-Taqwa [he is one of the Muttaqun (the pious)].'' (49:13)

"So ascribe not purity to yourselves. He knows best him who fears Allah and keeps his duty to Him [i.e., those who are Al-Muttaqun (the pious)].'' (53:32)

"And the men on Al-a`raf (the wall) will call unto the men whom they would recognise by their marks, saying: `Of what benefit to you were your great numbers (and hoards of wealth), and your arrogance (against Faith)?' Are they those, of whom you swore that Allah would never show them mercy. (Behold! It has been said to them): `Enter Jannah, no fear shall be on you, nor shall you grieve.''' (7:48,49)

602. `Iyad bin Himar (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah has revealed to me that you should humble yourselves to one another. One should neither hold himself above another nor transgress against another.''
[Muslim].

Commentary: To treat each other humbly, leniently and lovingly is understood as humility. One, under this principle, is also required not to despise anybody on the basis of wealth, social distinction and lineage. Moreover, one should also not adopt an unkind attitude towards others. Besides, if Allah has bestowed honour on somebody, he is supposed to be grateful to Him, instead of behaving disrespectfully towards people and subjecting them to unkindness and tyranny.

603. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Wealth does not diminish by giving Sadaqah (charity). Allah augments the honour of one who forgives; and one who serves another seeking the pleasure of Allah, Allah will exalt him in ranks.''
[Muslim].

Commentary: Apparently giving in Sadaqah (charity) decreases wealth, but Allah fairly compensates an almsgiver by increasing his wealth. Otherwise, he is sure to receive the best recompense in the Hereafter which will make good his loss. Or, Allah blesses the rest of his wealth in such a way that the sense of loss is removed from his mind. As for a lenient and humble attitude, it is sometimes mistaken by man for his humiliation. But Messenger of Allah (PBUH) calls such an impression as erroneous. Indeed, humility increases his honour and dignity. And as regards the Hereafter, the best reward is bound to accrue to him when he will be blessed with spiritual heights.

604. Anas (May Allah be pleased with him) passed by some children and greeted them (by saying As-salamu `alaikum to them). Then he said: The Prophet (PBUH) used to do the same.
[Al-Bukhari and Muslim].

Commentary: To greet (saying As-salamu `alaikum) small children is an excellent expression of humbleness. Similarly, a believer is under obligation to greet his wife and children while entering his home, and this will be a sign of his humbleness as well. Besides, he is also supposed to greet his subordinates, servants and other lowly people. Escape from it is an indication of pride and arrogance and shows a deviation from the practice of the Prophet (PBUH) which is enough to incur the displeasure of Allah.

605. Anas bin Malik (May Allah be pleased with him) reported: A slave-girl of Al-Madinah would take hold of the hand of the Prophet (PBUH) and take him wherever she desired.
[Al-Bukhari].

Commentary: This Hadith throws light on the sublime courtesy and unique humbleness of Messenger of Allah (PBUH) as well as his passion to meet the wants of the needy. It provides all the Muslims with a worth-emulating example. The Hadith does not mean that the slave-girl would actually touch the Prophet's hands, but that he would show humbleness to all kinds of people, be they young or old, rich or poor, men or women.

606. Al-Aswad bin Yazid (May Allah be pleased with him) reported: `Aishah (May Allah be pleased with her) was asked: "What did Messenger of Allah (PBUH) used to do inside his house?'' She answered: "He used to keep himself busy helping members of his family, and when it was the time for Salat (the prayer), he would get up for prayer.''
[Al-Bukhari].

Commentary: Here too, we are informed about the extreme humbleness of Messenger of Allah (PBUH). Many a man deems his insult and indignity to extend his co-operation to woman in household affairs. This is against the practice of Messenger of Allah (PBUH). To co-operate with woman in doing domestic things is a Sunnah and man should not feel complex in it. However, an excessive interest in domestic engagements which makes one indifferent to Salat is not desirable. Rather, one is supposed to give up all domestic engagements when it is time to offer Salat and be ready for it.

607. Tamim bin Usaid (May Allah be pleased with him) reported: I came to Messenger of Allah (PBUH) while he was delivering a Khutbah and said: "O Messenger of Allah, a stranger (meaning himself) has come to inquire about his Deen. He is quite ignorant about his Deen.'' Messenger of Allah (PBUH) interrupted his Khutbah and turned to me. Then a chair was brought for him and he sat on it. He started instructing me what Allah had taught him. Then he resumed his Khutbah and completed it.
[Muslim].

Commentary: This Hadith also mirrors, apart from the extreme humbleness of the Prophet (PBUH), his affability and consolation for a traveller as well as the priority which he gave to faith and Islamic teachings. Moreover, it reveals that, during the delivery of sermon, if it is needed, the preacher can converse with somebody and also leave the pulpit temporarily.

608. Anas (May Allah be pleased with him) reported: When the Messenger of Allah (PBUH) finished eating his food, he would lick his three fingers (i.e., the forefinger, the middle finger and the thumb). He (PBUH) said, "If anyone of you drops a morsel, he should remove anything harmful from it and then eat it. He should not leave it for Shaitan.'' He commanded us to clean out the dish saying, "You do not know in what portion of your food the blessing lies.''
[Muslim].

Commentary: This Hadith also stresses humbleness, simplicity and regard for the Blessings of Allah. To be unwilling to pick up a fallen morsel and eat it and to keep from cleaning up the dish is the style of arrogant and wealthy people. It displays disregard for Allah's Blessing. To eat the fallen morsel after cleaning it and to lick up the dish shows, apart from humbleness, regard for the Divine gift. Such an act pleases Allah. In it there is another advantageous aspect. Man never knows which is the blessed portion of food. When one licks up the dish, or even his fingers, picks up the fallen morsel and eats it after cleaning it, nothing will be wasted from the meal. In this way, the blessed portion of meal will automatically come to him and he will not remain deprived of it. Moreover, the Hadith tells us that Allah's Blessing, in whatever small quantity it may be, must not be wasted. Yet unfortunately, as we see today, food is wasted like anything in the feasts and marriage ceremonies. Whereas there are countless people in the world who do not get enough to eat, and there are many areas where people simply starve. May Allah guide us!

609. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Every Prophet has tended sheep.'' He was asked: "And did you?'' He replied: "Yes, I tended them for a few carats for the Makkans.''
[Al-Bukhari].

Commentary: This Hadith has already been mentioned earlier, approving of secluded life in a peculiar situation. As the same has relevance with humbleness, it is repeated in this chapter as well. Indeed, it is the quality of humble people that they earn their living by manual labour.

610. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said: "If I am invited to a meal consisting of a sheep's foot or shoulder, I would respond and I would accept as a gift a shoulder or a foot of a sheep.''
[Al-Bukhari].

Commentary: This Hadith brings to our knowledge the humbleness and simplicity of Messenger of Allah (PBUH). It serves as an exemplar to us that we should accept the simple invitation of a poor man and even an ordinary gift. We must not reject the gift owing to its ordinariness and inadequacy.

611. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) had a she-camel called Al-`Adba' which would not allow any other camel to surpass her. A bedouin came riding his camel which outstripped it. The Muslims were much grieved at this. Messenger of Allah (PBUH) perceived it and said, "It is Allah's Way that he lowers whatever raises itself in the world."
[Al-Bukhari].

Commentary: This Hadith underlines a Principle of Allah that He never keeps anything in the world on the rise eternally. Every rising star has its eventual decline. Individuals and nations apart, this law of nature also applies to animal life. In it is embedded Divine wisdom. First, annihilation and fall is the fate of everything. Second, lest power and growth should go to man's head, he is warned by being reduced to smallness that there exists a Supreme One Who holds sway over all creatures and can render the powerful weak and helpless. The bedouin camel-rider resented the Companions by overtaking Messenger of Allah (PBUH), yet he himself did not express his resentment. Rather the occasion caused him to explain the Divine wisdom behind it. The Hadith also shows the Prophet's humility.


Condemnation of Pride and Self-Conceit

Chapter 72
Condemnation of Pride and Self-Conceit

Allah, the Exalted, says:

"That home of the Hereafter (i.e., Jannah), We shall assign to those who rebel not against the truth with pride and oppression in the land nor do mischief by committing crimes. And the good end is for the Muttaqun (the pious and righteous persons).'' (28:83)

"And walk not on earth with conceit and arrogance.'' (17:37)

"And turn not your face away from men with pride, nor walk in insolence through the earth. Verily, Allah likes not any arrogant boaster.'' (31:18)

"Verily, Qarun (Korah) was of Musa's (Moses) people, but he behaved arrogantly towards them. And We gave him of the treasures, that of which the keys would have been a burden to a body of strong men. Remember when his people said to him: `Do not exult (with riches, being ungrateful to Allah). Verily, Allah likes not those who exult (with riches, being ungrateful to Allah...(up to)... So We caused the earth to swallow him and his dwelling place.'' (28:76-81)

612. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who has, in his heart, an ant's weight of arrogance will not enter Jannah.'' Someone said: "A man likes to wear beautiful clothes and shoes?'' Messenger of Allah (PBUH) said, "Allah is Beautiful, He loves beauty. Arrogance means ridiculing and rejecting the Truth and despising people.''
[Muslim].

Commentary: The Hadith says that a man who has even an iota of pride in his heart will be barred from entering Jannah. The Hadith word used for the smallest amount means in Arabic either the smallest ant or the particle which is radiated by sun-rays and seen through a wall-chink. Obviously, such a particle has almost a non-existent amount, but even this much is disapproved by Allah. If pride incites a man to deny the existence of Allah and His Revelation, he is sure to be thrown into Hell. He also faces Divine displeasure and the danger of infernal fire if mere consideration of riches, physical beauty, social and intellectual prominence and family status makes him proud and self-conceited and he looks down upon others, or persists in the denial of Truth. First he will receive punishment and only then will be admitted into Jannah. A good dress, however, is not counted the sign of pride.

613. Salamah bin Al-Akwa` (May Allah be pleased with him) reported: A man ate in the presence of Messenger of Allah (PBUH) with his left hand. He (PBUH) said, "Eat with your right hand.'' He said: "I cannot.'' Thereupon he (the Prophet (PBUH)) said, "May you never be able to do that.'' It was arrogance that prevented him from doing it, and he could not raise it (the right hand) up to his mouth afterwards.
[Muslim].

Commentary: This Hadith occurred in chapter 16 concerning the observance of Sunnah but is repeated here to identify pride and its detriment and to describe the bad end of the arrogant people as we see in it. See the commentary on Hadith No. 160.

614. Harithah bin Wahab (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Shall I not inform you about the inmates of Hell? It is every violent, impertinent and proud person.''
[Al-Bukhari and Muslim].

Commentary: Flouting at Divine rules, niggardliness (to keep from spending in the way of Allah) and haughtiness are condemnable habits, and those who indulge in them will be pushed into Hell. May Allah keep us in His Shelter from it!

615. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Prophet (PBUH) said, "There was a dispute between Hell and Jannah, and Hell said: `The haughty and proud are in me.' The Jannah said: `In me are the weak and the humble.' Thereupon Allah, the Exalted, judged between them saying: `You the Jannah are My Mercy, and through you I shall show mercy to those whom I wish.' (And addressing the Hell) He said: `You are My punishment to punish whom I wish amongst My slaves, and each one of you will have its fill.'''
[Muslim].

Commentary: This Hadith warns us against haughtiness and pride and urges us to observe modesty and humility. Jannah and Hell - two otherworldly phenomena - have been called as the manifestations of Allah's Mercy and punishment. True, only the Will of Allah prevails everywhere but the decision to send a man either to Jannah or to Hell will not be taken capriciously. Rather set Divine rules will be working behind it. Allah, will place some people in Jannah due to their good deeds; similarly he will place some people in Hell due to their bad deeds. Allah does not wrong anyone.

616. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, Allah will not look at him who trails his lower garment out of pride.''
[Al-Bukhari and Muslim].

Commentary: Here Allah's refusal to see an arrogant man means the restraint of the flow of His Grace towards him. Instead of Allah's Mercy, His Wrath will smite the arrogant. The garment which man wears to cover the lower half of his body is called Izar in Arabic. Hence pyjamas, trousers, Shalwar and Tahband will be taken as Izar. Messenger of Allah (PBUH) has emphatically said that Izar should remain above the ankle of men as its dragging down signifies arrogance. Indeed it displays the attitude of the haughty whose grim fate can be seen in this Hadith.

617. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "There are three (types of) people to whom Allah will not speak on the Day of Resurrection, nor will He purify them, nor look at them, and they will have a painful punishment. These are: An aged man who commits Zina (illicit sexual act), a ruler who lies, and a proud poor person.''
[Muslim].

Commentary: Here "will not speak'' means He will not say something which will please them, not to talk happily and willingly. Adultery is forbidden to everybody, whether young or old. But it is more condemnable if an old man commits it, because to be guilty of such a detestable act in old age shows that the adulterer has become hardened in sin and his heart is free from the fear of Allah. Lying is forbidden to everybody. But it is particularly vicious in case of a king or head of state. Since he possesses all powers and resources, he has little reason to tell a lie. Hence, if in spite of all this he invents a lie, it will betray his vicious mind and lack of God-consciousness. Similarly, all humans are prohibited from giving vent to pride and arrogance. But if a beggar or destitute, who has no reason to claim dignity and superiority, displays arrogance, it will be a convincing proof of his indifference to the fear of Allah and Shari`ah rules. From this point of view, his arrogance is more abominable and disgusting than that of a wealthy man.

618. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah, the Exalted, says: `Honour is My Izar and Pride is My Cloak. Whoever vies with Me regarding one of them, shall be tormented.'''
[Muslim].

Commentary: According to this Hadith, power and superiority (honour), greatness and grandeur are Divine attributes alone. If anybody tries to invest himself with these attributes or claims them, it means that he is audacious enough to claim godhood. Allah says that it is the result of His sheer Grace to a man if he enjoys these qualities in a restricted measure, and he is supposed to be obedient and grateful to Him for that. In no manner does it behave him to trumpet his own grandeur and greatness. If someone out-steps his limits in this regard, he will get himself into Hell. The Hadith is a signal of warning to men that they must not boast of their power and behave arrogantly towards their fellow-humans.

619. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "While a man was walking, dressed in clothes admiring himself, his hair combed, walking haughtily when Allah caused the earth to swallow him. Now he will continue to go down in it (as a punishment) until the Day of Resurrection.''
[Muslim].

Commentary: This Hadith warns us against self-praise and arrogance which may pervade our hearts by fine clothes and physical beauty. Instead of adopting a proud attitude, we should be sensible enough to thank Allah for these favours and confess our servitude to Him.

620. Salamah bin Al-Akwa` (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Man continues to display haughtiness and arrogance until he is recorded among the arrogant and will be therefore afflicted with what afflicts them.''
[At-Tirmidhi].

Commentary: To adopt the habits and manners of good people is deemed to be desirable. But, on the contrary, to take to the bad ways of bad people is considered undesirable. A man will ultimately be counted among those people whom he will take as a model to emulate, because he is gradually fitted into their framework and assimilates all of their qualities. Quite naturally then retribution will be administered to him accordingly.


Good Conduct

Chapter 73
Good Conduct

Allah, the Exalted, says:

"And verily, you (O Muhammad (PBUH)) are on an exalted (standard of) character.'' (68:4)

"The Jannah is prepared for those)... who repress anger, and who pardon men.'' (3:134)

621. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) was the best of all the people in behaviour.
[Al-Bukhari and Muslim].

622. Anas (May Allah be pleased with him) reported: I never felt any piece of velvet or silk softer than the palm of the Messenger of Allah (PBUH), nor did I smell any fragrance more pleasant than the smell of Messenger of Allah (PBUH). I served him for ten years, and he never said `Uff' (an expression of disgust) to me. He never said `why did you do that?' for something I had done, nor did he ever say `why did you not do such and such' for something I had not done.
[Al-Bukhari and Muslim].

Commentary: This Hadith reflects the sublime morality of Messenger of Allah that he never found faults with the doings of his valet nor did he ever scold him during his ten-year-long service. To be sure, this is something unique in human history. May the Ummah, too, adopt the refined way of the living of its Prophet (PBUH).

623. Sa`b bin Jaththamah (May Allah be pleased with him) reported: I presented a wild ass to Messenger of Allah (PBUH) as a gift but he returned it to me. When he perceived signs of despair on my face, he said, "I have declined to accept it because I am in the state of Ihram.''
[Al-Bukhari and Muslim].

Commentary: As, in the state of Ihram, hunting is not allowed to a pilgrim; similarly, the meat of the game, killed on his suggestion or instruction, is forbidden to him, too. For this reason, Messenger of Allah (PBUH) sent back the gift of the wild ass to his Companion. The Hadith further illustrates that if the recipient has any valid excuse for not accepting a gift, he should explain it so that the sender may not feel dejected. It may be mentioned here that some Ahadith allow us to eat the meat of a game killed by others, whereas this Hadith shows it is not permissible. The orthodox `Ulama', however, have attempted to reconcile the two seemingly incompatible sets of Ahadith with each other. According to the first category of Ahadith, a man, not in the state of Ihram who kills a chase and gives a portion of it as a gift to someone who is in Ihram, the gift will be permissible to the latter. As for the second category of Ahadith, the former kills a game for the latter, or on his suggestion, the man in the state of Ihram will be barred from eating it (as mentioned in Fath Al-Bari). Similarly, it will not be lawful if the game is sent alive to the man in the state of Ihram with this intention that he should himself sacrifice it. The Hadith under discussion depicts this very situation. Imam Bukhari, as we know, has consequently adduced from this Hadith that if an unkilled game, like the wild donkey, is sent as a gift to a man in the state of Ihram, he should not accept it.

624. Nawwas bin Sam`an (May Allah be pleased with him) reported: I asked Messenger of Allah (PBUH) about virtue and sin, and he said, "Virtue is noble behaviour, and sin is that which creates doubt and you do not like people to know about it.''
[Muslim].

Commentary: An important principle enshrined in this Hadith says that courtesy is a virtue, because a refined mind cultivates good habits, performs good deeds, and shuns all that is bad and corrupt. Also, a simple and understandable principle is laid down about sin. Man feels the pricking of conscience over every bad deed and is also afraid of the reproach of fault-finders, provided he has not reached the lowest point of moral depravity. But a seared conscience is least disturbed even by a heinous and deadly sin or by public censure. We can understand it by the example of man's smelling sense. If it is not dead, man can feel a stink and repugnant odour. But a long association with a dung heap robs away one's smelling sense and feeling of refuse.

625. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: Messenger of Allah (PBUH) did not indulge in loose talk nor did he like to listen to it. He used to say, "The best of you is the best among you in conduct.''
[Al-Bukhari and Muslim].

Commentary: This Hadith, apart from describing the refined behaviour and sublime morality of Messenger of Allah (PBUH), tells us that a person with the highest moral sense is in fact the best among people.

626. Abud-Darda (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Nothing will be heavier on the Day of Resurrection in the Scale of the believer than good manners. Allah hates one who utters foul or coarse language.''
[At-Tirmidhi].

Commentary: The most beneficial thing on the Day of Resurrection will be a courteous behaviour which will outweigh all good actions. But that will be witnessed in case of a believer as there is no question of weighing a non-believer's good actions. Allah Himself says in the Qur'an: "So their works are in vain, and on the Day of Resurrection, We shall assign no weight for them.'' So will a morally depraved and nonsensical man stand unfavoured with Allah, and this will be a sign of his frustration and disillusionment in the Hereafter.

627. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) was asked about the deed which will be foremost to lead a man to Jannah. He replied, "Fear of Allah and the good conduct.'' Then he was asked about indulgence which will admit a man to Hell (Fire) and he answered, "The tongue and the genitals.''
[At-Tirmidhi].

Commentary: This is also a very comprehensive Hadith. Fear of Allah really links up a man to Him, and moral refinement prevents him from falling short of his duties to people. To be sure, adherence to this two-fold practice will cause the entry of a lot of people to Jannah. Many a man, on the other hand, has a long, sharp and dangerous tongue and this causes him to pour out heretic utterances and indulge in backbiting, slandering and abusive and nonsensical talk. All this activity leads to Hell. As for genitals, an unwary and unrestrained attitude incites one to indulge in immoral pursuits. In both these cases countless people will be led into Hell. For this reason it is imperative for everybody to develop Taqwa (consciousness of Allah / fear of Allah ) and refined behaviour and shun the wickedness of tongue and genitals so that his life in the Hereafter may not be ruined.

628. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The most perfect man in his faith among the believers is the one whose behaviour is most excellent; and the best of you are those who are the best to their wives.''
[At-Tirmidhi].

Commentary: This Hadith brings into light the corollary of faith and complaisant manners. We may put it in this way that the degree of a man's excellent behaviour determines the degree of his faith. Or the sublimity of faith calls for the sublimity of morals. Similarly, a man who is polite and courteous to his wife will be considered as the best.

629. `Aishah (May Allah be pleased with her) reported: I heard Messenger of Allah (PBUH) saying: "A believer will attain by his good behaviour the rank of one who prays during the night and observes fasting during the day.''
[Abu Dawud].

Commentary: The two practices are difficult. But those who manage to keep them will be richly rewarded by Allah. There is a third category of men who fail to observe the above mentioned voluntary practices. Yet they are polite, and courteous in their behaviour towards others and by virtue of this sociable quality, they will also be graded up in the two other categories. And this highlights the significance and excellence of a polite and pleasing behaviour.

630. Abu Umamah Al-Bahili (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "I guarantee a house in Jannah for one who gives up arguing, even if he is in the right; and I guarantee a home in the middle of Jannah for one who abandons lying even for the sake of fun; and I guarantee a house in the highest part of Jannah for one who has good manners.''
[Abu Dawud].

Commentary: Withdrawal from one's right in order to end a dispute is a manly act of great merit. Likewise, this Hadith tells us that a man should avoid telling a lie even in a light vein. If he gives great importance to the rules of the Shari`ah (Islamic Law) and the Commandments of Allah and His Prophet (PBUH), he will definitely refrain from telling a lie even in a chat session or just for the sake of joke. Usually, people don't mind if one tells a lie in a jocular mood, rather some will perhaps approve it. Yet, Allah disapproves of even the harmless or trivial form of falsehood and commands His slaves to keep away from it. From all considerations, however, moral excellence carries immense weight. Because no wrong or evil thing can be shunned without it. In other words, moral excellence surpasses all forms of goodness.

631. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The dearest and nearest among you to me on the Day of Resurrection will be one who is the best of you in manners; and the most abhorrent among you to me and the farthest of you from me will be the pompous, the garrulous, and Al-Mutafaihiqun.'' The Companions asked him: "O Messenger of Allah! We know about the pompous and the garrulous, but we do not know who Al-Mutafaihiqun are.'' He replied: "The arrogant people.''
[At-Tirmidhi].

Commentary: This Hadith lays emphasis on polite and polished behaviour. Besides, it teaches us to refrain from unnecessary, incautious and insincere talk intended to influence others and assert superiority over them. But to talk less and in simple words is a good thing. On the other hand, to talk much, showing off cleverness with a tinge of affectation, is detestable.


Clemency, Tolerance and Gentleness

Chapter 74
Clemency, Tolerance and Gentleness

Allah, the Exalted, says:

"...who repress anger, and who pardon men; verily, Allah loves Al-Muhsinun (the good-doers).'' (3:134)

"Show forgiveness, enjoin what is good, and turn away from the foolish (i.e., don't punish them).'' (7:199)

"The good deed and the evil deed cannot be equal. Repel (the evil) with one which is better (i.e., Allah orders the faithful believers to be patient at the time of anger, and to excuse those who treat them badly) then verily he, between whom and you there was enmity, (will become) as though he was a close friend. But none is granted it (the above quality) except those who are patient - and none is granted it except the owner of the great portion (of happiness in the Hereafter, i.e., Jannah and of a high moral character) in this world.'' (41:34,35)

"And verily, whosoever shows patience and forgives that would truly be from the things recommended by Allah.'' (42:43)

632. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said to Ashaj Abdul-Qais (May Allah be pleased with him), "You possess two qualities that Allah loves. These are clemency and tolerance.''
[Muslim].

Commentary: This Hadith teaches us to adopt a patient, mild and discreet attitude towards others. Moreover, there is a provision for praising somebody in his presence, provided there is no likelihood of his being conceited. The Hadith also provides inspiration for the cultivation of good habits.

633. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) said, "Allah is Forbearer and loves forbearance in all matters.''
[Al-Bukhari and Muslim].

Commentary: Mildness also brings human beings closer to one another, and on this count, Allah likes it very much.

634. `Aishah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah is Forbearer and He loves forbearance, and rewards for forbearance while He does not reward severity, and does not give for any thing besides it (forbearance).''
[Muslim]

Commentary: Mildness is the opposite of harshness. Allah enjoins softness and dislikes stiffness in human relations. Allah assures of reward for gentle behaviour in society, not for unkindness or anything like that. However, inflexibility is preferred to flexibility when there arises a question of religious matters and the limits set by Allah.

635. `Aishah (May Allah be pleased with her) reported: The Prophet (PBUH) said, "Whenever forbearance is added to something, it adorns it; and whenever it is withdrawn from something, it leaves it defective.''
[Muslim].

Commentary: To be soft-spoken is such a quality that by virtue of which a man is not only endeared to people but also to Allah. And by being bereft of it, he not only becomes a contempt incarnate in the eyes of people but also with Allah.

636. Abu Hurairah (May Allah be pleased with him) reported: A bedouin urinated in the mosque and some people rushed to beat him up. The Prophet (PBUH) said: "Leave him alone and pour a bucket of water over it. You have been sent to make things easy and not to make them difficult.''
[Al-Bukhari].

Commentary: This Hadith brings into light the fact that leniency is also vitally needed in the sphere of education and discipline. This is particularly true in the case of ignorant and ill-bred people. This is so because if they are treated unkindly, they will become more indocile on account of their wild temperament and foolishness. A kind handling is indispensable for putting them to discipline, even if they make desperate blunders. This Hadith is very beneficial with regard to the way of Da`wah, guidance and practical education. Another point this Hadith discloses is that the flow of water can wipe out dirt and impurity, and make the place free from its effect.

637. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Make things easy and do not make them difficult, cheer the people up by conveying glad tidings to them and do not repulse (them).''
[Al-Bukhari and Muslim].

Commentary: This Hadith informs us that preaching, sermons, religious discourses and moral advice all should concentrate on such things as may be helpful to people in being inclined towards gaining religious knowledge. Likewise this aspect should also be kept in view in the exposition and interpretation of religion. Moreover, the tone and mode of expression of religious leaders should not be repulsive and based on sectarian hatred, rather it should pull hearts to religion. In brief, preachers and `Ulama' must be regardful of the central point of the cause to which they are dedicated.

638. Jarir bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who is deprived of forbearance and gentleness is, in fact, deprived of all good.''
[Muslim].

639. Abu Hurairah (May Allah be pleased with him) reported: A man asked the Prophet (PBUH) to give him advice, and he (PBUH) said, "Do not get angry.'' The man repeated that several times and he (PBUH) replied (every time), "Do not get angry.''
[Al-Bukhari].

Commentary: This Hadith has already been quoted. Yet the compiler has repeated it on account of its relevance with this chapter. It is to be noticed that an advice should be made as circumstances demand. When Messenger of Allah (PBUH) perceived by his insight that the visitor was a person of sharp and fiery temper, he repeatedly advised him to resist anger.

640. Abu Ya`la Shaddad bin `Aus (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Verily Allah has prescribed Ihsan (kindness) for everything. So when you kill, you must make the killing in the best manner; when you slaughter, make your slaughter in the best manner. Let one of you sharpen his knife and give ease to his animal (in order to reduce his pain).''
[Muslim].

Commentary: By killing is meant the killing of a harmful animal, or the killing of a murderer as retribution and the killing of the enemy in the battlefield. All these situations warrant killing but with a stress on moderation, thanks to Islamic teachings. A believer is told not to let his passions of enmity go wild, and even an enemy or a criminal ought not to be put to a torturous death. In the Pre-Islamic Period of Ignorance it was a prevalent practice that the limbs of a victim were mutilated before he was finally killed. Islam has forcefully forbidden this inhuman custom, stating that the victim should be beheaded with the one swing of sword. Similarly, there are specific instructions regarding an animal's slaughter. First, the knife should be sharpened. Second, the animal must not be slaughtered from its nape, because in both ways it will suffer pain. This Shari`ah rule ensures quick death of the animal. In modern Europe, an animal is slaughtered with one stroke of a cutting-machine. Apparently this method seems to be easy and smooth, yet in this way the animal's blood doesn't flow out from its body completely. So the consumption of the meat of such a kill is injurious to human health. Due to this reason, Islam considers the discharge of blood as a prerequisite to Halal (lawful). Certainly, only the Islamic way of slaughtering an animal is more sound, scientific and wholesome.

641. `Aishah (May Allah be pleased with her) reported: Whenever the Prophet (PBUH) was given a choice between two matters, he would (always) choose the easier as long as it was not sinful to do so; but if it was sinful he was most strict in avoiding it. He never took revenge upon anybody for his own sake; but when Allah's Legal Bindings were outraged, he would take revenge for Allah's sake.
[Al-Bukhari and Muslim].

Commentary: The two things between which Messenger of Allah (PBUH) would make his choice could be religious or worldly. For instance, if he were asked to award one of the two punishments to somebody, he would choose the milder one. And if he had the liberty of choice between two obligations, he would opt for the easier one. Between war and peace he would always go for peace, provided it involved the interest of Islam and Muslims. Moreover, in all matters he used to take the line of least resistance, in case it went without the disobedience of Allah. In this Hadith, a principle has been defined for Muslims in general as well that they are free to take to an easy way but this must not entail a loophole in respect of the Shari`ah. Secondly, the most excellent character of Messenger of Allah (PBUH) also comes to our view that he never retaliated for personal reasons. His extraordinary concern for the sanctity of Islamic Law is also displayed by the fact that he could never brook the transgression of Allah's limits, and the transgressor was sure to be punished by him. The Prophet's attitude also explains and delimits the sphere of morality that to let the violator of Divine law go scot-free must not be counted as a sign of good manners. Rather it reflects the lack of religious sensibility. Not to take exception to lapses in mundane affairs surely speaks of moral excellence, but we are not allowed to dispense with the evasion of religious rules.

642. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Shall I not tell you whom the (Hell) Fire is forbidden to touch? It is forbidden to touch a man who is always accessible, having polite and tender nature.''
[At-Tirmidhii].

Commentary: The Hadith throws light on a kind bearing which is rooted in Faith and saves man from Hell-fire. The second lesson is that prior to discussing something important with somebody we should make him attentive and receptive, so that he may take interest and put faith in what we tell him.


Forgiveness of the Ignorant

Chapter 75
Forgiveness of the Ignorant

Allah, the Exalted, says:

"Show forgiveness, enjoin what is good, and turn away from the foolish (i.e., don't punish them).'' (7:199)

"So overlook (O Muhammad (PBUH)), their faults with gracious forgiveness.'' (15:85)

"Let them pardon and forgive. Do you not love that Allah should forgive you?'' (24:22)

"And who pardon men; verily, Allah loves Al-Muhsinun (the good-doers)'' (3:134)

"And verily, whosoever shows patience and forgives, that would truly be from the things recommended by Allah.'' (42:43)

643. `Aishah (May Allah be pleased with her) reported: I asked the Prophet (PBUH) "Have you ever experienced a day harder than the day of the battle of Uhud?'' He replied, "Indeed, I experienced them (dangers) at the hands of your people (i.e., the disbelievers from amongst the Quraish tribe). The hardest treatment I met from them was on the Day of `Aqabah when I went to Ibn `Abd Yalil bin `Abd Kulal (who was one of the chiefs of Ta'if) with the purpose of inviting him to Islam, but he made no response (to my call). So I departed with deep distress. I did not recover until I arrived at Qarn ath-Tha`alib. There, I raised my head and saw a cloud which had cast its shadow on me. I saw in it Jibril (Gabriel) (PBUH) who called me and said: `Indeed, Allah, the Exalted, heard what your people said to you and the response they made to you. And He has sent you the angel in charge of the mountains to order him to do to them what you wish.' Then the angel of the mountains called me, greeted me and said: `O Muhammad, Allah listened to what your people had said to you. I am the angel of the mountains, and my Rubb has sent me to you so that you may give me your orders. (I will carry out your orders). If you wish I will bring together the two mountains that stand opposite to each other at the extremities of Makkah to crush them in between.''' But Messenger of Allah (PBUH) said, "I rather hope that Allah will raise from among their descendants people as will worship Allah the One, and will not ascribe partners to Him (in worship).''
[Al-Bukhari and Muslim].

Commentary: In the vicinity of Al-Madinah stands a mountain, called Uhud, where the `Battle of Uhud' took place. It was in this battle that the Prophet's face was wounded, one of his molars was broken and he fell into a pit dug by `Amr Ar-Rahib. Besides, his uncle, Hamzah (May Allah be pleased with him) was martyred and the disbelievers mutilated his body. `Aqabah was a place at Ta'if where Messenger of Allah (PBUH) rode up from Makkah and met the worst experience. Or, it could be that the incident occurred somewhere at Mina where, during the Hajj season, he urged the different clans to accept the message of Islam so as to seek their help to establish the true religion. Qarn Ath-Tha`alib is also the name of a place which is the Miqat (transit-point where pilgrims assume the state of Ihram) of the Najd people.

This Hadith also reflects the marvellous character of Messenger of Allah (PBUH) that he never rebuked the ignorant and those who caused him harm, nor did he ever avenge anybody on grounds of personal hostility. Secondly, he would endure all forms of hardships in the way of Allah with patience and endurance. He never became furious over his harassers, rather he prayed for their guidance. No doubt, the Prophetic life-pattern perennially provides inspiration to preachers and religious instructors. The responsibility of preaching is not a bed of roses but a thorny path to tread on. It is not the welcome and applause which is meted out to him, but people's taunts, reproaches and insults are heaped on the preacher. Consequently, patience, self-possession, self-control and tolerance are vital to braving trials and tribulations in the way of Allah.

644. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) never hit anything with his hand neither a servant nor a woman but of course, he did fight in the Cause of Allah. He never took revenge upon anyone for the wrong done to him, but of course, he exacted retribution for the sake of Allah in case the Injunctions of Allah about unlawful acts were violated.
[Muslim].

Commentary: For explanatory comments, the reader may refer to Hadith No. 641.

645. Anas (May Allah be pleased with him) reported: I was walking with Messenger of Allah (PBUH) who was wearing a Najrani cloak with a very thick border when a bedouin happened to meet him. He took hold of the side of his cloak and drew it violently. I noticed that the violence of jerk had bruised the neck of Messenger of Allah (PBUH). The bedouin said: "O Muhammad! Give me out of Allah's wealth that you possess.'' Messenger of Allah (PBUH) turned to him and smiled and directed that he should be given something.
[Al-Bukhari and Muslim].

Commentary: This Hadith also highlights the Prophet's sublime morality, patience and self-control. He smiled away the discourtesy of the bedouin and bade the offering of a gift to him.

646. Ibn Mas`ud (May Allah be pleased with him) reported: I can see the Messenger of Allah (PBUH) look like one of the Prophets of Allah whose people beat and made him bleed while he was wiping the blood from his face and supplicating: "O Allah, forgive my people because they know not.''
[Al-Bukhari and Muslim].

Commentary: The `Ulama' say that by relating the painful incident of a Prophet, Messenger of Allah (PBUH) in fact implied his own experience at the hands of his people. Indeed, this expresses his extreme numbleness that he vaguely described his bitter self-experience without bringing into light the unthinking persecutors of his nation.

647. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The strong man is not the one who wrestles, but the strong man is in fact the one who controls himself in a fit of rage.''
[Al-Bukhari and Muslim].

Commentary: People are usually impressed by the physical power and strength of somebody. But the real strength of a man lies in the fact that he should be able to wrestle with his passions in a fit of anger and avoid committing an act for which he may subsequently regret. This is a common observation that wild anger leads to many a wrongdoing of which man repents later on or sheds tears over the ruin resulting from it.


Endurance of Afflictions

Chapter 76
Endurance of Afflictions

Allah, the Exalted, says:

"(Those) who repress anger, and who pardon men; verily, Allah loves Al-Muhsinأn (the good-doers).'' (3:134)

"And verily, whosoever shows patience and forgives, that would truly be from the things recommended by Allah.'' (42:43)

648. Abu Hurairah (May Allah be pleased with him) reported: A man said to Messenger of Allah (PBUH): "I have relatives with whom I try to maintain good relationship but they sever relations with me; whom I treat kindly but they treat me badly, with whom I am gentle but they are rough to me.'' He (PBUH) replied, "If you are as you have said, then it is as though you are feeding them hot ashes and you will not be without a supporter against them from Allah, as long as you do so.''
[Muslim].

Commentary: Also owing to its obvious relevance with this chapter this Hadith has been mentioned here. The above-mentioned Verses and this Hadith impress on a believer that in order to win the pleasure of Allah, he should be forgiving and tolerant with regard to the sufferings he experiences at the hands of people. Both, good behaviour and the example of the Prophet (PBUH), call for such an attitude.


Indignation against the Transgression of Divine Laws

Chapter 77
Indignation against the Transgression of Divine Laws

Allah, the Exalted, says:

"And whoever honours the sacred things of Allah, then that is better for him with his Rubb...'' (22:30)

"If you help (in the Cause of) Allah, He will help you, and make your foothold firm.'' (47:7)

649. Abu Mas`ud `Uqbah bin `Amr Al-Badri (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said: "I join the morning Salat late because of so-and-so who leads it and prolongs it.'' (Abu Mas`ud said): I have never seen the Prophet (PBUH) so angry while giving a speech as he was on that day. He (PBUH) said, "Some of you create hatred among the people against faith. Whoever leads Salat (the prayer), should make it brief because the congregation includes old men and youngsters and those who have some urgent work to do.''
[Al-Bukhari and Muslim].

Commentary: First, there is allowance for a genuine complaint regarding some public inconvenience. Second, a believer is supposed to be passionately uncompromising on religious precepts. Third, the Imam should refrain from prolonging Salat (prayer) and be considerate of the congregation standing behind him. But a brief recitation of the Qur'an or prayer does not imply a disregard of the example of the Prophet and the adjustment of different postures in Salat. In no way should it be a hasty and heedless Salat as unfortunately offered by a majority of men. They are scarcely regardful of the example of the Prophet in offering Salat. What a pity! Fourth, one may be exempted from offering congregational Salat for a valid religious excuse. fifth, the Imam should eschew an attitude which may foment people's aversion to worship.

650. `Aishah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) returned once from a journey, and saw a curtain which I had hung along a platform with some pictures on it. The colour of his face changed. He tore it up and said, "O `Aishah, the most tormented people on the Day of Resurrection are those who contend with Allah in terms of creation.''
[Al-Bukhari and Muslim].

Commentary: Here, too, we are told that lapses in religious matters may be resented vehemently. The Shari`ah condemns both the making of human portraits and their decoration in homes and, if displayed as sacred objects, they may be read as polytheistic manifestation. Besides, orthodox `Ulama' and researchers are of the opinion that making or keeping of any type of picture is forbidden and unlawful. The rule equally applies to a hand-made picture and a camera photograph, provided it is that of an animate object. Yet, making or keeping pictures of inanimate objects, both of mineral and vegetable kingdoms, is permissible. However, one is at liberty to get oneself photographed in an unavoidable situation. For instance, photographs are indispensable to passports, identity cards and similar other necessities of modern times in which man is helpless and we can not assert that he is inclined to satisfy his taste or to get himself photographed as a token of permissibility. Indeed, it is the requirement of international law. So, up to this extent he will not be called to account. Yet, he cannot be justified in overstepping this limit.

651. `Aishah (May Allah be pleased with him) reported: The Quraish were much worried about the case of a Makhzumiyah woman who had committed theft and wondered who should intercede for her with Messenger of Allah (PBUH) (so that she would not get punished for her crime). Some said Usamah bin Zaid (May Allah be pleased with him) was his beloved and so he may dare do so. So Usamah(May Allah be pleased with him) spoke to him about that matter and the Prophet (PBUH) said to him, "Do you intercede when one of the legal punishments ordained by Allah has been voilated?'' Then he got up and addressed the people saying, "The people before you were ruined because when a noble person amongst them committed theft, they would leave him, but if a weak person amongst them committed theft, they would execute the legal punishment on him. By Allah, were Fatimah, the daughter of Muhammad, to commit the theft, I would have cut off her hand.''
[Al-Bukhari and Muslim].

Commentary: The example of Allah's Messenger (PBUH) clearly tells us that no intercession is allowed for a person who transgresses the limits set by Allah. And if anybody has the audacity to do so, the deciding authority is presumed to be impervious to his solicitation. Nor should the criminal's social status or family influence, if any, obstruct the administration of justice. The law and retribution rise above all discrimination and social hierarchy. Any contravention in this regard is enough to incur Divine wrath.

652. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) noticed spittle in the mosque in the direction of the Qiblah. The signs of disgust were perceived on his face. Then, he stood up and scraped it away with his own hand and said, "When you stand in Salat, you hold communion with your Rubb and He is between you and the Qiblah. Let no one therefore cast out his spittle in that direction, but only to his left or under his foot.'' Then he caught hold a corner of his sheet, spat into it and folded it up and said, "Or he should do like this.''
[Al-Bukhari and Muslim].

Commentary: Worshippers are under obligation to observe certain manners in the mosque with the most important being abstinence from spitting towards Qiblah (Ka`bah). Instead the method pointed out in the Hadith may be put in effect right during Salat (prayer). Yet one, if not offering Salat, can turn to the mosque's washing-place where a channel exists for the outflow of unclean water, etc. Obviously, it is a better substitute for a pocket-handkerchief or sheet which should be used when necessary. Second, this Hadith tells us that every effort should be made to keep the place of worship neat and clean, and if anyone finds some dirt in the mosque, he should immediately remove it.


Obligation of Rulers to show Kindness to their Subjects

Chapter 78
Obligation of Rulers to show Kindness to their Subjects

Allah, the Exalted, says:

"And be kind and humble to the believers who follow you.'' (26:215)

"Verily, Allah enjoins Al-`Adl (justice) and Al-Ihsan (performing duties in a perfect manner), and giving (help) to kith and kin, and forbids Al-Fahsha' evil deeds and Al-Munkar (all that is prohibited) and Al-Baghy (oppression). He admonishes you, that you may take heed.'' (16:90)

653. Ibn `Umar (May Allah be pleased with them) reported: I heard Messenger of Allah (PBUH) saying, "All of you are guardians and are responsible for your wards. The ruler is a guardian and responsible for his subjects; the man is a guardian and responsible for his family; the woman is a guardian and is responsible for her husbands house and his offspring; and so all of you are guardians and are responsible for your wards.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned in the chapter pertaining to the duties of a wife to her husband. Its repetition in this chapter is meant to remind rulers that if they are negligent of the duties devolved upon their shoulders, they will be wrongdoers to Allah and put to reckoning on the Day of Resurrection.

654. Abu Ya`la Ma`qil bin Yasar (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Any slave whom Allah makes him in charge of subjects and he dies while he is not sincere to them, Allah will make Jannah unlawful for him.''
[Al-Bukhari and Muslim].

Another narration is: Allah's Messenger (PBUH) said, "He who does not look after his subjects with goodwill and sincerity, will be deprived of the fragrance of Jannah.''

A narration in Muslim is: Messenger of Allah (PBUH) said, "A ruler who, having control over the affairs of the Muslims, does not strive diligently for their betterment and does not serve them sincerely, will not enter Jannah with them.''

Commentary: Here the attention of rulers has been invited to their obligations. They are told that their designation is very important because they are responsible for tackling the problems and affairs of millions of people. If their single-minded devotion, determined efforts and heartfelt feelings of well-wishing will not go to solving these problems, they will be deemed guilty by Allah. Rulers are, therefore, warned, lest power should go to their head and make them unheedful of people's problems, rights and concerns. Instead being fully conscious of their accountability to Allah (SWT) they are apt to make full efforts to provide justice and peace to people. By "forbid from entering Jannah'' means they will not enter it with the first successful people until they get punished for their wrongdoings. If however, they were treacherous to their subjects while regarding this injustice lawful, thus disobeying Allah and His Commands, they will stay in Hell forever because this way they have made permissible and lawful what Allah has forbidden.

655. `Aishah (May Allah be pleased with her) reported: I heard the the Messenger of Allah (PBUH) supplicating in my house: "O Allah! Treat harshly those who rule over my Ummah with harshness, and treat gently those who rule over my Ummah with gentleness.''
[Muslim].

Commentary: How fortunate is a ruler who establishes his claim to the special benediction of Messenger of Allah (PBUH) by providing justice to people! On the other hand, how unfortunate is that ruler who incurs the Prophetic imprecations by doing injustice to people! This Hadith is suggestive of a rulership based on justice and lays emphasis on refraining injustice and atrocity.

656. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The Banu Isra'il were ruled by the Prophets. When one Prophet died, another succeeded him. There will be no Prophet after me. Caliphs will come after me, and they will be many.'' The Companions said: "O Messenger of Allah, what do you command us to do?'' He said, "Fulfill the pledge of allegiance to which is sworn first (then swear allegiance to the others). Concede to them their due rights and ask Allah that which is due to you. Allah will call them to account in respect of the subjects whom He had entrusted to them.''
[Al-Bukhari and Muslim].

Commentary: The political conduct of the Prophets means that rulership and government affairs were also assigned to them, that is, both religious and worldly affairs lay in their custody. There was no dichotomy between the two, they formed a single unit. This also characterized the period of the Rightly-Guided Caliphs and the short spell that followed it in the history of Islam. This explains why after the death of one Prophet came another Prophet and became his successor. Second, the Hadith also settles the issue of the finality of Prophethood once for all. "No Prophet will succeed me except the caliphs'', said the Prophet (PBUH). In the case of many claimants to caliphate, he also gave a ruling, that is, people should primarily fulfill their allegiance pledged to the first caliph and keep away from caring for another claimant to caliphate. Third, the Prophet (PBUH) focused, on the lapses of rulers but without being suggestive of a rebellion and public demonstrations against them. Instead he teaches us to obey them in the administrative sphere and also to turn to Allah (SWT) and seek His Mercy and Blessing as long as they rule by the Law of Allah.

657. `Aidh bin `Amr (May Allah be pleased with him) reported: I visited `Ubaidullah bin Ziyad and said to him: "Dear son, I heard Messenger of Allah (PBUH) saying, `The worst of rulers are those who treat their subjects harshly. Beware, lest you should be one of them.'''
[Al-Bukhari].

Commentary: There is a typical, brutish sheep-herder who severely drives his flock and flogs them mercilessly. As a result of which the timid animals get upon one another. In the Hadith, this word has been brought in for a tyrant ruler who subjects people to oppression and treats them unkindly. It implies a strong warning and intimidation to cruel rulers.

658. Abu Maryam Al-Azdi (May Allah be pleased with him) reported: I said to Mu`awiyah (bin Abu Sufyan) (May Allah be pleased with them): I heard Messenger of Allah (PBUH) saying, "If Allah invests to someone the affairs of the Muslims and he (i.e., the ruler) ignores their rights, denies their access to him and neglects their needs, Allah will not answer his prayer or realize his hopes and will act towards him with indifference on the Day of Resurrection.'' So Mu`awiyah appointed a person to keep a vigil on the necessities of the people and to fulfill them.
[Abu Dawud and At-Tirmidhi].

Commentary: The Hadith warns such a ruler who is heedless of the problems and affairs of the needy and who keeps them away from him. On the Last Day, Allah, too, will be indifferent to him. Indeed, a stern warning is given to such rulers who have no direct contact with the needy people and who keep their doors shut to them.


The Just Ruler

Chapter 79
The Just Ruler

Allah, the Exalted, says:

"Verily, Allah enjoins Al-`Adl (justice) and Al-Ihsan (performing duties in a perfect manner).'' (16:90)

"And be equitable. Verily! Allah loves those who are the equitable.'' (49:9)

659. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Seven are (the persons) whom Allah will give protection with His Shade* on the Day when there will be no shade except His Shade (i.e., on the Day of Resurrection), and they are: A just ruler; a youth who grew up with the worship of Allah; a person whose heart is attached to the mosque; two persons who love and meet each other and depart from each other for the sake of Allah; a man whom a beautiful and high ranking woman seduces (for illicit relation), but he (rejects this offer by saying): `I fear Allah'; a person who gives a charity and conceals it (to such an extent) that the left hand might not know what the right has given; and a person who remembers Allah in solitude and his eyes well up.''
[Al-Bukhari and Muslim].

* The Shade of Allah to which this Hadith refers to is the shade of His Throne.

Commentary: This Hadith has already been described in the chapter about the excellence of the love of Allah. Here, it has been carried forward in view of its relevance with the just ruler's excellence. Refer to the commentary on Hadith No. 379.

660. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "The just will be seated upon pulpits of light.'' Those who are fair with regards to their judgement and their family and those who are under them.''
[Muslim].

Commentary: How will be the likeness of the pulpits of light? Although we are not aware of their reality, yet we are supposed to have faith in them. We must also believe that these people (just rulers) will be under the shade of the Throne or the Divine mercy, while people will be drenched in their sweat depending on their deeds. The Hadith throws light on the excellence of justice and the high rank of those who do justice.

661. `Auf bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The best of your rulers are those whom you love and who love you, and those who supplicate Allah in your favour and you supplicate Allah in their favour. The worst of your rulers are those whom you hate and who hate you; and whom you curse and who curse you.'' It was asked (by those who were present): "Should not we oppose them?'' He said, "No, as long as they establish Salat; as long as they establish Salat in your midst.''
[Muslim].

Commentary: The Hadith identifies two categories of rulers. First, those rulers who are well-wishers of people and provide them with justice. These are the best rulers for whom people also pray. Second, the worst rulers who are only concerned with their rule and interests and take no interest in providing justice to people and removing their difficulties. In fact, rulers are advised to adhere to justice, uprightness and equity as this can endear them to Allah as well as to people. Moreover, we are told that rebellion against rulers is disallowed till they commit a flagrant act of disbelief and stop abiding by the duties of Islam, particularly Salat (prayer).

662. `Iyad bin Himar (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The people of Jannah will be of three kinds: A just successful ruler, a man who shows mercy to his relatives, and a pious believer who has a large family and refrains from begging.''
[Muslim].

Commentary: All the three qualities mentioned in the Hadith particularly characterize the men of Faith and will cause their entry to Jannah. Every believer is expected to strive for being invested with these good qualities.


Obligation of Obedience to the Ruler in what is Lawful and Prohibition of Obeying them in what is Unlawful

Chapter 80
Obligation of Obedience to the Ruler in what is Lawful and Prohibition of Obeying them in what is Unlawful

Allah, the Exalted, says:

"O you who believe! Obey Allah and obey the Messenger (Muhammad (PBUH)), and those of you (Muslims) who are in authority.'' (4:59)

663. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said, "It is obligatory upon a Muslim to listen (to the ruler) and obey whether he likes it or not, except when he is ordered to do a sinful thing; in such case, there is no obligation to listen or to obey.''
[Al-Bukhari and Muslim].

Commentary: This Hadith crystallizes the parameters of the Muslim subjects' obedience to their Muslim rulers. The honour of the latter is bound up with their surrender to the Command of Allah and His Messenger (PBUH). Otherwise, apart from the torment in the Hereafter, they will also be subjected to humiliation in this world.

664. Ibn `Umar (May Allah be pleased with them) reported: Whenever we took a pledge of allegiance to Messenger of Allah (PBUH) to hear and obey, he (PBUH) would say to us, "As far as you are capable of.''
[Al-Bukhari and Muslim].

Commentary: Obedience to a Muslim ruler calls for two conditions: First, his command must not infringe upon the canonical sanctity; second, it ought not to outweigh people's limitations. In case, he fails to meet these two prerequisites, his obedience will also become non-obligatory. This Hadith conveys a warning to rulers that they must not put people to a hardship unbearable to them.

665. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "One who withdraws his hand from obedience (to the Amir) will find no argument (in his defense) when he stands before Allah on the Day of Resurrection; and one who dies without having sworn allegiance will die the death of one belonging to the Days of Ignorance.''
[Muslim].

Another narration is: The Messenger of Allah (PBUH) said, "He who dies having defected from obedience (to the Amir) and discards his association with the main body of the (Muslim) community, dies the death of one belonging to the Days of Jahiliyyah.''

Commentary: The Hadith makes it clear that it is binding upon Muslims to show obedience to the just Muslim ruler and to join forces with the Muslim Community to give allegiance to him as long as he does not call to a sin.

666. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Hear and obey even if an Abyssinian slave whose head is like a raisin is placed in authority over you.''
[Al-Bukhari].

Commentary: Nobody pays respect to a slave, with a black complexion and small head at that. But the Hadith brings such a man in focus to emphasize that obedience to a ruler is inescapable. The only condition is that his governance should be confined to the Shari`ah framework without reference to his geographical, tribal and ethnic background.

667. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "It is obligatory upon you to listen and obey the orders of the ruler in prosperity and adversity, whether you are willing or unwilling, or when someone is given undue preference to you.''
[Muslim].

Commentary: Obedience to a ruler is indispensable in view of the collective interests of a community. A believer has, therefore, been enjoined to obey the ruler in all circumstances rising above his personal interests, preferences and psychological urges. The ruler, however, must not be obeyed if he breaks the Shari`ah rules.

668. `Abdullah bin `Amr (May Allah be pleased with them) reported: We accompanied Messenger of Allah (PBUH) on a journey. We halted at a place to take a rest. Some of us began to set right their tents, others began to graze their animals while others were engaged in competing with one another in archery when an announcer of Messenger of Allah (PBUH) announced that people should gather for Salat. We gathered around the Messenger of Allah and he ((PBUH)) addressed us, saying, "Every Prophet before me was under obligation to guide his followers to what he knew was good for them and to warn the evil thing which he knew. As for this Ummah, it will have sound state and in its early stage of existence; but the last phase of its existence, will be faced with trials and with things you do not recognize. There will be tremendous trials, one after the other, and to each the believer will say, `That is it'. Whenever a trial arrives the believer will say: `This is going to bring about my destruction.' When this passes, another calamity will approach and he will say: `This surely is going to be my end.' Whosoever wishes to be removed from the Fire (Hell) and admitted to Jannah should die with faith in Allah and the Last Day; and he should treat others as he wishes to be treated. He who swears allegiance to an Imam, he should give him the pledge in ratification and the sincerity of his heart. He should obey him to the best of his capacity. If another man comes forward as a claimant (when one has already been installed), behead the second.''
[Muslim].

Commentary: Here `its early stage' means the period of the Companions, of the Successors (of the Companions), and of the Followers (of the Successors). In another Hadith, it has been called as the best era. In comparison with all the succeeding periods, this period is surpassingly good, peaceful and blessed. Later would emerge, it was prophesized, mischief after mischief, each being worse than the preceding one. Today, everybody sees the truth of this prophecy like the light of day. By predicting the emergence of mischief, Messenger of Allah (PBUH) wanted to warn his followers that they should keep themselves aloof from them. To them he further explained in advance the precautionary measures, that is, to keep faith in Allah, to remain firm-footed in the belief in the Hereafter and to deal with people fairly, attempting to be polite to them at the same time.

Besides, prophecy has been made about the abundance of the power-hungry people with a remedial note. In the first instance believers are supposed to swear allegiance to the caliph, and by extending their cooperation to him they should kill another claimant to the caliphate because it is only in this way that the unity of the Muslim Ummah can be maintained, free of chaos and discord. Yet, unfortunately, the power-orientated groups have found a plaything in the shape of democracy, turning peace and unity into a legend of the past. What a pity that despite all that they seek stability and progress! Is it the miracle of time or the quirk of the vested interests that has reversed the whole scheme of things? There is little hope of the improvement of the Muslim world's affairs. Indeed, it faces an ironical situation.

669. Wa'il bin Hujr (May Allah be pleased with him) reported: Salamah bin Yazid Al-Ju`f (May Allah be pleased with him) asked Messenger of Allah (PBUH): "O Prophet of Allah! Tell us, what you command us to do if there arises over us rulers who demand of us what is due to them and refuse us what is due to us.'' Messenger of Allah (PBUH) turned away from him, but he repeated the same question. Thereupon Messenger of Allah (PBUH) said, "Listen to them and obey them. They are responsible for their obligations and you are accountable for yours.''
[Muslim].

Commentary: This Hadith means that both the ruler and the ruled have their own respective obligations. If any of the two sides fails to play its due role, it will bear the brunt of its deficiency on the Final Day. Yet, people are debarred from disobeying a ruler who neglects to do what is required of him. Negligence is not rectifiable by negligence as it will make matters worse. To endure the high-handedness of a ruler in view of the overall national interest, is therefore, preferable to revolting against him. True, one cannot take the law into one's own hands, yet there always remains room for improvement and positive criticism. To make use of it within limits and to make efforts for the enforcement of the canonical discipline will not be deemed as an uprising. Indeed, this will be deemed, to some extent, binding on everybody.

670. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "There will be discrimination after my death and there will be other matters that you will disapprove.'' He was asked: "O Messenger of Allah! What do you command us to do when we are encountered with such happenings?'' He answered, "Give what is due from you and supplicate to Allah for your rights.''
[Al-Bukhari and Muslim].

Commentary: There are two aspects of this Hadith. On the one hand, people are advised to put up patiently with the transgressive behaviour of rulers as well as their nepotism or monopolization of all the national resources. On the other hand, rulers are warned to ward off a capricious conduct of life, lest they should face the Wrath of Allah.

671. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whosoever obeys me, obeys Allah; and he who disobeys me, disobeys Allah; and whosoever obeys the Amir (leader), in fact, obeys me; and he who disobeys the Amir, in fact, disobeys me.''
[Al-Bukhari and Muslim].

Commentary: This Hadith informs us that it is imperative that we obey the leader of the Muslim community so long as he does not call to a sin, because doing so is in fact obedience to Allah (SWT).

672. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "If a person notices in his ruler what he dislikes, he should show patience because he who departs from the (Muslim) community a cubit, dies like those who died in the Days of Ignorance.''
[Al-Bukhari and Muslim].

Commentary: This Hadith urges us to bear patiently when a ruler makes a mistake so long as he does not call to a sin. It also warns us against disobedience to the ruler as this will cause mischief at the cost of the unity and common interests of the Muslim community.

673. Abu Bakrah (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "He who insults the rulers Allah will insult him.''
[At-Tirmidhi].

Commentary: To affront and degrade the ruler means to disobey him and to by-pass his orders. This impairs his power, honour and dignity. Believers have been told to obey and support rulers for the sake of national interest and welfare, understanding that they desist from committing an overt disbelief and maintain congregation Salat and other duties of religion. The political system of Islam is totally incompatible with western democracy. The concept of government party and the opposition is alien to Islam. All belong to one Ummah with only one goal and pursue the same aims and objects of Islamic guidelines!


Undesirability of Aspiring for Office

Chapter 81
Undesirability of Aspiring for Office

Allah, the Exalted, says:

"That home of the Hereafter (i.e., Jannah), We shall assign to those who rebel not against the truth with pride and oppression in the land nor do mischief by committing crimes. And the good end is for the Muttaqun (the pious and righteous persons).'' (28:83)

674. `Abdur-Rahman bin Samurah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me, "Do not ask for position of authority. If you are granted this position without asking for it, you will be helped (by Allah) in discharging its responsibilities; but if you are given it as a result of your request, you will be left alone as its captive. If you take an oath to do something and then find a better alternative, you should adopt the latter and expiate for your oath.''
[Al-Bukhari and Muslim].

Commentary: By rulership is meant caliphate or any other rank affiliated to its hierarchy. Yet, it is undesirable to be eager or to strive for such an extraordinary position as it entails a heavy responsibility and one may face a sufficient difficulty in being absolved from it. However, if a man gets it without solicitation, he should accept it. The other part of the Hadith concerns swearing. Somebody takes an oath to do something but he finds another work more rewarding and righteous. In such a situation he is advised to dissolve his oath and make expiation for it. Thereafter, he will be free to avail the advantageous option. As for the expiation of breaking an oath, there are four options: to set free a slave, or to feed an average-quality food to ten needy persons, or to provide clothes to them; and the expiator who cannot afford all that, should observe fasting for three days.

675. Abu Dharr (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said to me, "O Abu Dharr, I see that you are weak and I like for you what I like for myself. Do not rule over (even) two persons, and do not manage an orphan's property.''
[Muslim].

Commentary: Abu Dharr Al-Ghifari (May Allah be pleased with him) was one of the most ascetic Companions who was little interested in mundane affairs. Finding him weak to do responsible jobs, Messenger of Allah (PBUH) gave him this advice. In fact, the one who takes interest in worldly affairs and understands them well can discharge the responsibilities appropriately. But a person who has aversion to worldly pursuits and keeps clear of them will be considered unfit in this regard.

676. Abu Dharr (May Allah be pleased with him) reported: I said to Messenger of Allah (PBUH): "Why do you not appoint me to an (official) position?'' He (PBUH) patted me on the shoulder with his hand and said, "O Abu Dharr, you are a weak man and it is a trust and it will be a cause of disgrace and remorse on the Day of Resurrection except for the one who takes it up with a full sense of responsibility and fulfills what is entrusted to him (discharges its obligations efficiently).''
[Muslim].

Commentary: There are, according to this Hadith, two conditions for putting people in official positions. The first is the relevant talent for the job, a man is put in charge of; and the second is his capacity for discharging responsibilities thereof. For example, a ruler should primarily possess the ability to maintain law and order and to establish justice; and secondly, he should be endowed with sufficient dynamism and vision to cope with new demands and situations. This basic principle applies to every official, whether in the capacity of governor, minister, advisor, financial administrator or a clerk. Apart from the sense of job, ability and integrity, he should be fired with determination with regard to his work. An office is indeed an important trust, and to have it without meeting the said conditions is a sort of treachery .

677. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "You will covet for getting a position of authority, but remember that it will be a cause of humiliation and remorse on the Day of Resurrection.''
[Al-Bukhari]

Commentary: This Hadith urges people, particularly the incapable ones, to shed off the ambition to achieve rulership and power. It is feared that owing to their lack of talent they will mismanage the task which will be assigned to them. This will render them guilty with Allah. The Prophet (PBUH) dissuades such people from accepting any government portfolio as in this way they will remain safe and trouble-free. Yet, if a deserving person gets a job of high responsibility, he should do his utmost to do full justice to it, so that he may be spared remorse on the Day of Resurrection.


Appointment of Pious Governors, Advisors and Judges

Chapter 82
Appointment of Pious Governors, Advisors and Judges

Allah, the Exalted, says:

"Friends of that Day will be foes one to another except Al-Muttaqun: (i.e., pious and righteous persons).'' (43:67)

678. Abu Sa`id and Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Allah neither raised up any Prophet nor did He authorize any person with ruling power but for whom there were two types of entourage: one enjoins upon him to do good and incites him to carry it out, and the other enjoins evil and goads him; and the protected (from the bad entourage) is the one whom Allah protects.''
[Al-Bukhari].

Commentary: A ruler has been told here that Taqwa (consciousness and fear of Allah), honesty, integrity and ability are the prerequisites to chosing anybody as his aide or advisor. Prior to their nomination, he should check up the reputation of his advisors. This precautionary measure will serve as a safeguard against the spread of corruption in society and serve the cause of goodness. Secondly, a ruler should obey the Commands of Allah and His Messenger (PBUH) because this discipline will not only keep him safe from making faults but will also serve as a shield against the machinations of wicked people.

679. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "When Allah desires good for a ruler, He appoints for him a sincere adviser who will remind him if he forgets and helps him if he remembers. When Allah wishes for him the contrary, He appoints for him a bad adviser who will not remind him if he forgets, nor will he help him if he remembers.''

Commentary: In the recruitment of good and scrupulous aides lies the Blessing of Allah to a ruler because such aides will prove helpful to him in making sound judgements, reaching right conclusions and guarding him against leaning towards evil ways. Yet, if all of these aides are self-seekers, flatterers and corrupt, they will undoubtedly influence his decision-making in a bad way. And one can believe that the end of the ruler will be far from being desirable because history also supports this view. As for the Hereafter, he will be hardly safe from the infernal torment.


Prohibition of Appointing an Aspirant Person to a Public Office of Authority

Chapter 83
Prohibition of Appointing an Aspirant Person to a Public Office of Authority

680. Abu Musa Ash`ari (May Allah be pleased with him) reported: I called on the Prophet (PBUH) with two of my cousins. One of them said to him: "O Messenger of Allah (PBUH), appoint me governor of some land over which Allah has given you authority.'' The other also requested for something of the same nature. Messenger of Allah (PBUH) said, "By Allah we do not appoint someone to this post who seeks it or someone who contends for it.''
[Al-Bukhari and Muslim].

Commentary: This Hadith supports the theme presented in this chapter by Imam An-Nawawi, that is, a person pushing himself up for an office should be deprived of it. Ambitious persons usually manage to get a high office for self-aggrandizement, damaging the interests of other people. A government should primarily aim at the welfare of people and not serve the interests of the privileged few or benefit the holders of key posts alone.


Book One: The Book of Good Manners

  • Chapter 84 : Exaltation of Modesty
  • Chapter 85 : Secrecy of Private Matters (Guarding Secrets)
  • Chapter 86 : Fulfillment of Promises
  • Chapter 87 : Safeguarding and Perpetuating Good Habits
  • Chapter 88 : Excellence of meeting with a smiling Countenance and Politeness in Speech
  • Chapter 89 : Clarity of Discourse
  • Chapter 90 : Listening Attentively
  • Chapter 91 : Brevity in Preaching
  • Chapter 92 : Dignity and Tranquility
  • Chapter 93 : Excellence of Walking Solemnly (Towards the Mosque) to perform As-Salat (The Prayer) and other Religious Duties
  • Chapter 94 : Honoring the Guest
  • Chapter 95 : Excellence of Conveying Glad Tidings and Congratulations
  • Chapter 96 : Bidding Farewell and Advising on the Eve of Departure for a Journey or other Things
  • Chapter 97 : Istikhara (Seeking Guidance from Allah), and Consultation
  • Chapter 98 : Excellence of Adopting Different Routes for going and returning on 'Eid Prayer and various other Occasions
  • Chapter 99 : Excellence of using the right Hand for Performing various good Acts


Exaltation of Modesty

Chapter 84
Exaltation of Modesty

681. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) passed by a man of the Ansar who was admonishing his brother regarding shyness. Messenger of Allah (PBUH) said, "Leave him alone, for modesty is a part of Iman.''
[Al-Bukhari and Muslim].

Commentary: The Ansari, who was being lectured by his brother, was indeed an embodiment of modesty and unpretentiousness. Such a man is never sharp in worldly affairs because modesty restrains him from following wrong ways. For this reason, modesty has been called a part of the faith. This is an inborn quality, that is, some people are unassertive by birth. Yet, if they are gradually guided and directed towards virtues, their unassumingness further increases. And in Islam it is counted a virtue.

682. `Imran bin Husain (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Shyness does not bring anything except good.''
[Al-Bukhari and Muslim].

In a narration of Muslim: Messenger of Allah (PBUH) said, "All of shyness is good.''

Commentary: This Hadith enlightens us on the excellence of modesty, which serves the good purpose of preventing man from the disobedience of Allah and from immoral and evil pursuits. Evidently, it has a salutary impact on society. Besides, it keeps man free from sins, and, consequently, he will stand blameless with Allah. From this standpoint, modesty is certainly a thorough good.

683. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Iman has sixty odd or seventy odd branches. The uppermost of all these is the Testimony of Faith: `La ilaha illallah' (there is no true god except Allah) while the least of them is the removal of harmful object from the road. And shyness is a branch of Iman.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already occurred in a previous chapter, see commentary on Hadith No. 125. Here it has been repeated with reference to the degrees of Faith. Modesty, too, is a part of Faith, rather one of its most important ingredients, because it plays an effective role in the training and sublimation of human psyche.

684. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) was even shier than a virgin behind her veil. When he saw something which he disliked, we could perceive it on his face.
[Al-Bukhari and Muslim].

Commentary: Though this Hadith particularly refers to the character of Messenger of Allah (PBUH), it also reveals the fact that modesty is a peculiar quality of woman. An unmarried woman, above all else, is considered to be the embodiment of bashfulness. Islamic countries have witnessed many curses of western civilization and the worst is the one which has robbed away the modesty of woman because it is the last protective shield of Islamic civilization which the enemy is consistently sweeping off. May Allah grant Muslims the insight to avert this wickedness!


Secrecy of Private Matters (Guarding Secrets)

Chapter 85
Secrecy of Private Matters (Guarding Secrets)

Allah, the Exalted, says:

"And fulfill (every) covenant. Verily! The covenant, will be questioned about.'' (17:34)

685. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The most evil of the people to Allah on the Day of Resurrection will be the man who consorts with his wife and then publicizes her secret.''
[Muslim].

Commentary: Islam treats conjugal union as a sacred and secret act, both in social and moral terms. Indeed, the sanctity of conjugal rights contributes to the consolidation of moral norms and social cohesion. Yet, what passes between wife and husband on the consummation night is usually taken in a light vein in our societies. In the morning, both of them relate their sexual experience to their friends respectively. This is moral indecency which is incompatible with human dignity and civilized behaviour. This Hadith reckons it as a grave sin which must be eschewed. The bed-experience must be kept private by the married couple to the exclusion of a third person.

686. `Abdullah bin `Umar (May Allah be pleased with them) reported: My father `Umar (May Allah be pleased with him) said: When (his daughter) Hafsah (May Allah be pleased with her) became a widow, I met `Uthman bin `Affan (May Allah be pleased with him) and offered Hafsah for marriage to him. `Uthman said: "I shall think over the matter.'' I waited for a few days and then `Uthman met me and said: "It occurred to me that I should not marry at present.'' Then I met Abu Bakr (May Allah be pleased with him) and said to him: "If you are willing, I shall marry my daughter Hafsah to you.'' Abu Bakr (May Allah be pleased with him) remained silent and did not utter any word to me in reply. I grew more angry with him than with `Uthman. I had waited for only a few days when Messenger of Allah (PBUH) asked for her hand in marriage and I married her to him. Thereafter, I met Abu Bakr (May Allah be pleased with him) who said, "Perhaps you were angry with me when you offered Hafsah to me and I said nothing in reply.'' I said, "Yes, that is so.'' He said, "Nothing stopped me to respond to your offer except that I knew that Messenger of Allah (PBUH) had mentioned her and I could not disclose the secret of Messenger of Allah (PBUH). Had Messenger of Allah (PBUH) left her, I would have accepted her.''
[Al-Bukhari and Muslim].

Commentary: To keep a secret and not to disclose it to people is the theme of this chapter as reflected in this Hadith. The Hadith has also other points which invite our attention. Firstly, a man can offer his daughter's hand to a righteous person. Secondly, it is undesirable for parents to send a message to another party for the wedlock of their daughter when talks with someone else are already continuing in this regard. Thirdly, if Messenger of Allah (PBUH) wanted to marry a woman but could not realize his intention for a reason or another, it was permissible for a Muslim to marry her because, juristically speaking, such a woman could not be counted as the Prophet's wife.

687. `Aishah (May Allah be pleased with her) reported: On one occasion all the wives of the Prophet (PBUH) were with him when his daughter, Fatimah (May Allah be pleased with her) who walked after the style of his father, came there. He (PBUH) welcomed her saying, "Welcome, O my daughter'', and made her sit on his right side, or on his left side and then whispered something to her at which she wept bitterly. When he perceived her grief, he talked secretly to her again and she smiled (with happiness). I said to her: "Messenger of Allah (PBUH chose you from amongst all his wives to speak secretly to you and yet you cried.'' When he left, I asked her, "What did Messenger of Allah (PBUH) say to you?'' She said, "I will not divulge the secret of Messenger of Allah (PBUH).'' When Messenger of Allah (PBUH) passed away, I said to her: "I adjure you by the right I have in respect of you to tell me what Messenger of Allah (PBUH) had told you.'' She said: "Now (when Messenger of Allah (PBUH) has died), I will tell you. When he whispered to me the first time, he told me, `Jibril (Gabriel) used to listen to my recitation of the Qur'an and then recite it back to me once or twice a year, and this time he has done it twice; and so I perceive that my death is approaching. Then be mindful of your duty to Allah and be patient and steadfast, for I shall be an excellent predecessor for you.' On this I wept as you saw. When he perceived my distress he talked to me secretly the second time and said, `O Fatimah, are you not pleased that you will be the chief among the believing women or of this Ummah?' This made me smile as you saw.''
[Al-Bukhari and Muslim].

Commentary: This Hadith, too, has an implication for keeping a secret and concealing it from people. Moreover, we learn that one can spontaneously weep over hearing a sorrowful occurrence and also that we should be patient in distress. The Hadith also teaches us not to feel proud upon receiving a blessing. Above all, the excellence of Fatimah (May Allah be pleased with her) and the advisability of reading the Qur'an are brought into our focus.

688. Thabit (May Allah be pleased with him) reported: Anas (May Allah be pleased with him) said: Messenger of Allah (PBUH) came to me while I was playing with the boys. He greeted us and sent me on an errand. This delayed my return to my mother. When I came to her, she asked, "What detained you?'' I said; "Messenger of Allah (PBUH) sent me on an errand.'' She asked, "What was it?'' I said, "It is a secret.'' My mother said; "Do not disclose to anyone the secret of Messenger of Allah (PBUH).'' Anas (May Allah be pleased with him) said to Thabit (May Allah be pleased with him): By Allah, were I to tell it to anyone I would have told you.
[Muslim].

Commentary: Here, too, an emphasis has been laid on keeping a secret. When Anas (May Allah be pleased with him) told his mother about the cause of secrecy, she refrained from insisting that the secret should be disclosed to her. Rather, she lent support to her son's standpoint and advised him to conceal the secret. To be sure, it is part of moral teaching that we should keep the secrets of friends in our hearts. Unless we receive a go-ahead from a friend, we must not make his secret public.


Fulfillment of Promises

Chapter 86
Fulfillment of Promises

Allah, the Exalted, says:

"And fulfill (every) covenant. Verily! The covenant will be questioned about. (17:34)

"And fulfill the Covenant of Allah (Bai`ah: pledge for Islam) when you have covenanted.'' (16:91)

"O you who believe! Fulfill (your) obligations.'' (5:1)

"O you who believe! Why do you say that which you do not do? Most hateful it is with Allah that you say that which you do not do.'' (61:2,3)

689. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Three are the signs of a hypocrite: When he speaks, he lies; when he makes a promise, he breaks it; and when he is trusted, he betrays his trust.''
[Al-Bukhari and Muslim].

Another narration adds the words: "Even if he observes Saum (fasts), performs Salat (prayer) and claims to be a Muslim.''

Commentary: This Hadith has already been mentioned in the chapter about trusts. See Commentary on Hadith No. 201. Its repetition here is meant to stress the point that a hypocrite is recognized by breaking his promise.

690. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Four are the qualities which, when found in a person, make him a sheer hypocrite, and one who possesses one of them, possesses one characteristic of hypocrisy until he abandons it. These are: When he is entrusted with something, he betrays trust; when he speaks, he lies; when he promises, he acts treacherously; and when he argues, he behaves in a very imprudent, insulting manner.''
[Al-Bukhari and Muslim].

Commentary: Theologically speaking, a disagreement between heart and tongue - or word and deed - about the declaration of faith in Islam is defined as hypocrisy. In the lifetime of the Prophet (PBUH) there existed a group of hypocrites whose traits of characters have been outlined in Ahadith. Humanly it is not possible to perceive malice hidden in one's heart. Even Messenger of Allah (PBUH) hardly knew what lay in the hearts of people because, despite having the exalted status of Prophethood, he was fundamentally a human. Allah, however, had revealed hearts to him. But today, we have no error-free source to pick hypocrites from the ranks of believers. Quite naturally, we fall back on the Hadith which provides us definite symptoms of the character and manners of hypocrites so as to distinguish them from sincere Muslims.

`Ulama' say that there are two aspects of hypocrisy, relating to faith and practice. In the first case, a hypocrite conceals his disbelief in his heart but verbally professes Islam. Anyone who belongs to this category of hypocrites will be, as stated in the Qur'an: "In the lowest depths of the Fire.'' (4:145). In the second case, a man does have faith in his heart but in practice he portrays the characteristics of a hypocrite, unfortunately a majority of today's Muslims practically behave like hypocrites and possess their propensities. It is this hypocritical attitude and moral deficiencies of Muslims that have degraded them and made Islam unappealing. May Allah put Muslims on the right path!

691. Jabir (May Allah be pleased with him) reported: The Prophet (PBUH) said to me, "When the revenues of Bahrain will arrive, I shall give you such and such and such.'' He passed away before the revenues were received. When they arrive during the caliphate of Abu Bakr (May Allah be pleased with him), he ordered to be announced: "Anyone whom Messenger of Allah (PBUH) promised or owed anything, should come to him.'' I went to him and said: "Messenger of Allah (PBUH) had said to me such and such.'' He took a double handful out of the money and gave it to me. I counted it and found that it was five hundred dirham. Then Abu Bakr (May Allah be pleased with him) said to me: "Take twice as much more of that amount.''
[Al-Bukhari and Muslim].

Commentary: Messenger of Allah (PBUH), according to Al-Bukhari, spread his both hands thrice in a gesture and indicated to Jabir (May Allah be pleased with him): "I will give you double handfuls of money thrice''. Abu Bakr (May Allah be pleased with him), however, fulfilled the Prophet's promise during his caliphate.

This Hadith is suggestive of fulfillment of the deceased pledge by the ascendant, that is, his death will not invalidate it. Rather, the responsibility of fulfilling his pledge devolves upon his inheritors. Similarly, a new ruler is under obligation to carry out the commitment made by his predecessor on the government level.


Safeguarding and Perpetuating Good Habits

Chapter 87
Safeguarding and Perpetuating Good Habits

Allah, the Exalted, says:

"Verily, Allah will not change the (good) condition of a people as long as they do not change their state (of goodness) themselves (by committing sins and by being ungrateful and disobedient to Allah).'' (13:11)

"And be not like her who undoes the thread which she has spun, after it has become strong.'' (16:92)

"... lest they become as those who received the Scripture [the Taurat (Torah) and the Injeel (Gospel)] before (i.e., Jews and Christians), and the term was prolonged for them and so their hearts were hardened?'' (57:16)

"But that they did not observe it with the right observance.'' (57:27)

692. `Abdullah bin `Amr bin Al-`as (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said to me, "O `Abdullah! Do not be like so-and-so; he used to get up at night for optional prayer but abandoned it later.''
[Al-Bukhari and Muslim].

Commentary: This Hadith also stresses the same point, that is, man should be steadfast in his good doings. There should be no cessation in this respect, otherwise, he will unconsciously begin to incline to evil and, therefore, to the erosion of moral foundations of his character. Steadfastness in the observance of good ensures man's security against pitfalls and has Divine approval, too.


Excellence of meeting with a smiling Countenance and Politeness in Speech

Chapter 88
Excellence of meeting with a smiling Countenance and Politeness in Speech

Allah, the Exalted, says:

"And lower your wings for the believers (be courteous to the fellow-believers).'' (15:88)

"And had you been severe and harsh-hearted, they would have broken away from about you.'' (3:159)

693. `Adi bin Hatim (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Guard yourselves against the Fire (of Hell) even if it be only with half a date-fruit (given in charity); and if you cannot afford even that, you should at least say a good word.''
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the point that Sadaqah has great benefits and even in its minimum scope and quantity it can ensure our safety against Hell-fire. We are told that if we do not have even a single date or half of it to give to a needy person, we can manage to have the same benefit by talking to him in a compassionate tone, provided we have Faith in our heart.

694. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "It is also charity to utter a good word.''
[Al-Bukhari and Muslim].

Commentary: In Islam, it is not spending money alone that counts as charity; talking to somebody in a decent way also comes in the same context. Now, one can feel the importance Islam gives to moral values and good manners. This saying of Messenger of Allah (PBUH) is part of a long Hadith mentioned earlier. See Hadith No. 122.

695. Abu Dharr (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Do not disdain a good deed, (no matter how small it may seem) even if it is your meeting with your (Muslim) brother with a cheerful face.''
[Muslim].

Commentary: Every deed approved by the Shari`ah is considered good and rewarding. Howsoever seemingly small people may consider it, it must not be looked at from a highbrow angle. Even to meet people cheerfully is one of the Islamic virtues, though it may appear quite insignificant to some people.


Clarity of Discourse

Chapter 89
Clarity of Discourse

696. Anas (May Allah be pleased with him) reported: Whenever the Prophet (PBUH) said something, he would repeat his words thrice so that the meanings would be understood fully; and whenever he came upon a group of people, he would greet them, and he would repeat salutation thrice.
[Al-Bukhari and Muslim].

Commentary: To lay stress on a point thrice or to repeat greetings, according to this Hadith, is preferable. It is particularly so when a situation so demands and when explaining a point to the audience once and twice may not be enough.

697. `Aishah (May Allah be pleased with her) reported: the speech of Messenger of Allah (PBUH) was so clear that all those who listened to it would understand it.
[Abu Dawud].

Commentary: Interpreting `Aishah's report, some commentators say that Messenger of Allah (PBUH) used to speak clearly and decisively. However, it may also mean that, while speaking, he would pause upon his words in such a way that each and every word which came from his lips appeared detached from the other. He was never like those who speak quickly and their words are mixed up with each other. This Hadith reflects the Prophet's eloquence as well as his due care and decency in putting in his viewpoint to the convenience of his audience.


Listening Attentively

Chapter 90
Listening Attentively

698. Jarir bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) asked me on the occasion of the Farewell Pilgrimage to tell the people to keep silent, then he (PBUH) said, "Do not revert to disbelief after me, chopping the heads of one another.''
[Al-Bukhari and Muslim].

Commentary: Commenting on this Hadith, Imam An-Nawawi has argued that one is allowed to lend ear to somebody if he has something reasonable to say. This will not be considered as eavesdropping which is unallowable on doctrinal basis. Secondly, silence is a prerequisite of setting ears to a sermon. And a Khatib (one who delivers a sermon) is perfectly justified if he asks his audience to observe silence so as to be able to listen to him in real earnest.


Brevity in Preaching

Chapter 91
Brevity in Preaching

Allah, the Exalted, says:

"Invite (mankind, O Muhammad (PBUH)) to the way of your Rubb (i.e., Islam) with wisdom (i.e., with the Divine Revelation and the Qur'an) and fair preaching.'' (16:125)

699. Shaqiq bin Salamah reported: Ibn Mas`ud (May Allah be pleased with him) used to preach to us once every Thursday. A man said to him: "O Abu `Abdur-Rahman, we love your talk and we wish that you preach us every day.'' He said: "There is nothing to prevent me from doing so, but I don't lest I bore you. I follow the same method in preaching to you that Messenger of Allah (PBUH) adopted in preaching to us for fear of boredom.''
[Al-Bukhari and Muslim].

Commentary: This Hadith throws light on the indispensability of equilibrium in sermons and discourses so that people may not shun them. Monotony, though well designed, is repugnant to human nature. Similarly, teaching and instructional training requires such hours which may facilitate people's willing participation. Compulsion and economic incentives rarely work in spiritual spheres. We are also informed of the Companions' keenness to follow Messenger of Allah (PBUH).

700. `Ammar bin Yasir (May Allah be pleased with them) reported: I heard Messenger of Allah (PBUH) saying, "Prolonging Salat (prayer) and shortening the Khutbah (religious talk) indicate the religious knowledge of the person. Make your Salat long and your sermon short.''
[Muslim].

Commentary: A prolonged Salat (prayer) by no means implies a disregard of worshipper's constraints. It is indeed forbidden. Rather the Imam is emphatically told to perform a brief and concise Salat because his followers also include, amongst others, the weak, the aged and the sick people. Herein an emphasis is laid on prolonging Salat instead of Khutbah (religious talk). The Friday Khutbah is meant to be brief. It must not be too lengthy in relation to a brief Salat offered heedlessly and in sheer haste. Salat must be offered in all humility and with full attention and concentration of mind. Furthermore, a worshippper ought to maintain a well-paused equilibrium in different postures of its performance. Brevity should be kept in view of Khutbah.

701. Mu`awiyah bin Al-Hakam As-Sulami (May Allah be pleased with him) reported: While I was in Salat with Messenger of Allah (PBUH), a man in the congregation sneezed and I responded with: `Yarhamuk-Allah (Allah have mercy on you).' The people stared at me with disapproving looks. So I said: "May my mother lose me. Why are you staring at me?'' Thereupon, they began to strike their thighs with their hands. When I saw them urging to me to remain silent, I became angry but restrained myself. When Messenger of Allah (PBUH) concluded his Salat. I have never before seen an instructor who gave better instruction than he, may my father and mother be sacrificed for him. He neither remonstrated me, nor beat me, nor abused me. He simply said,"It is not permissible to talk during Salat because it consists of glorifying Allah, declaring His Greatness as well as recitation of the Qur'an,'' or he said words to that effect.'' I said: "O Allah's Messenger, I have but recently accepted Islam, and Allah has favoured us with Islam. There are still some people among us who go to consult soothsayers.'' He said, "Do not consult them.'' Then I said: "There are some of us who are guided by omens.'' He said, "These things which come to their minds. They should not be influenced by them.''
(Muslim).

Commentary: This Hadith emphasizes four points. Firstly, as no talk is allowed in Salat (prayer), nobody can utter benedictory words for a sneezer either. Secondly, this Hadith throws light on the Prophet's way of imparting moral instruction to others. He would prudently enlighten ignorant people on Islam, avoiding to express his resentment over their lapses which simply betrayed their lack of knowledge. This has a lesson for `Ulama' and preachers. Thirdly, Muslims are prohibited from consulting soothsayers. Fourthly, belief in bad omens is also prohibited. Divinations and presages were the popular fallacies of Arabs in the pre-Islamic epoch. Islam abolished them. Yet, once again these absurdities have caught the fancy of ignorant Muslims. May Allah guide them!

702. `Irbad bin Sariyah (May Allah be pleased with him) reported: One day, Messenger of Allah (PBUH) delivered a very effective speech, as a result, eyes shed tears and hearts became softened. A man said: "O Prophet of Allah! It sounds as if this is a farewell speech, so advise us.'' He (PBUH) said, "I admonish you to fear Allah, and to listen and obey even if a black slave has been appointed as your leader. For whoever among you lives after me will see much discord. So hold fast to my Sunnah and the Sunnah of the Rightly-Guided Caliphs who will come after me. Adhere to them and hold fast to them. Beware of Bid`ah (in religion) because every Bid`ah is a misguidance.''
[Abu Da wud and At-Tirmidhi].

Commentary: According to this Hadith, the best sermon may be defined as brief, comprehensive, appealing and beneficial. Refer to the Commentary on Hadith No. 185.


Dignity and Tranquility

Chapter 92
Dignity and Tranquility

Allah, the Exalted, says:

"And the (faithful) slaves of the Most Gracious (Allah) are those who walk on the earth in humility and sedateness, and when the foolish address them (with bad words) they reply back with mild words of gentleness.'' (25:63)

703. `Aishah (May Allah be pleased with him) reported: I have never seen Messenger of Allah (PBUH) laughing so heartily that his uvula could be seen. He used to smile only.
[Al-Bukhari and Muslim].

Commentary: To laugh much is one of the sign of indifference to the remembrance of Allah. Besides, the habit of laughing aloud robs away the dignity and impressiveness of a man.


Excellence of Walking Solemnly (Towards the Mosque) to perform As-Salat (The Prayer) and other Religious Duties

Chapter 93
Excellence of Walking Solemnly (Towards the Mosque) to perform As-Salat (The Prayer) and other Religious Duties

Allah, the Exalted, says:

"And whosoever honours the Symbols of Allah, then it is truly from the piety of the heart.'' (22:32)

704. Abu Hurairah (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "When the Iqamah are pronounced, do not come to it running, you should walk calmly with tranquillity to join the congregation. Then join in what you catch for and complete what you miss.''
[Al-Bukhari and Muslim].

In Muslim it is added: Messenger of Allah (PBUH) said, "For when one of you is walking for Salat, he is, in fact, engaged in Salat.''

Commentary: This Hadith prevents us from running or walking hurriedly in order to join a congregational prayer because this is undignified. Whereas, we are commanded to be self-composed and dignified with regard to all matters. Secondly, when a believer walks up to the mosque after performing ablution at home, he is considered to be in a state of Salat. Thirdly, the first Rak`ah he prays behind the Imam will be counted his first Rak`ah, so he must make up for the Rak`ah he may have missed, if any, after the Imam has concluded his Salat.

705. Ibn `Abbas (May Allah be pleased with them) reported: I accompanied the Prophet (PBUH) while we were returning from `Arafat. Messenger of Allah (PBUH) heard behind him a loud noise of beating and of driving the camels forcibly. He pointed towards it with his whip and said, "O people! Proceed calmly. No virtue lies in rushing.''
[Al-Bukhari and Muslim].

Commentary: People return from `Arafat jostling against one another as if they are being thrust forward from behind. Such an act is incompatible with decorum. Messenger of Allah (PBUH) advised them to observe tranquillity and orderliness and to avoid a disorderly haste. There is indeed dire need to act upon this advice of Messenger of Allah (PBUH) at Hajj sites during the performance of the sacred rites. May Allah guide Muslims!


Honoring the Guest

Chapter 94
Honoring the Guest

Allah, the Exalted, says:

"Has the story reached you, of the honoured guests [three angels; Jibril (Gabriel) along with another two] of Ibrahim (Abraham)? When they came in to him and said: `Salam (peace be upon you),' He answered: `Salam (peace be upon you),' and said: `You are a people unknown to me.' Then he turned to his household, and brought out a roasted calf [as the property of Ibrahim (Abraham) was mainly cows]. And placed it before them, (saying): `Will you not eat?''' (51: 24-27)

"And his (Lut's) people came rushing towards him, and since aforetime they used to commit crimes (sodomy), he said: `O my people! Here are my daughters (i.e., the women of the nation), they are purer for you (if you marry them lawfully). So fear Allah and degrace me not with regard to my guests! Is there not among you a single right-minded man? ''' (11:78)

706. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who believes in Allah and the Last Day, let him show hospitality to his guest; and he who believes in Allah and the Last Day, let him maintain good relation with kins; and he who believes in Allah and the Last Day, let him speak good or remain silent.''
[Al-Bukhari and Muslim].

Commentary: To honour a guest means to welcome him cheerfully, entertain him happily according to our capacity and have full regard of his comfort and rest. As for our relatives, we are supposed to treat them nicely and to do our duty towards them.

Reserve in speech implies that we should avoid senseless and irrelevant talk. We are apt to pass most of our time in the remembrance of Allah, seeking His forgiveness and saying what is good to everybody. Or we had better keep silent. These three qualities are possessed by those people who believe in Allah and the Day of Reckoning.

In other words, those who lack these qualities betray only a weak and imperfect Faith.

707. Abu Shuraih Khuwailid bin `Amr Al-Khuza`i (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "He who believes in Allah and the Last Day, should accommodate his guest according to his right.'' He was asked: "What is his right, O Messenger of Allah?'' He (PBUH) replied: "It is (to accommodate him) for a day and a night, and hospitality extends for three days, and what is beyond that is charity.''
[Al-Bukhari and Muslim].

In Muslim it is added: Messenger of Allah (PBUH) said, "It is not permissible for a Muslim to stay so long with his brother till he makes him sinful.'' He was asked: "O Messenger of Allah, how can he make him sinful?'' He replied, "He prolongs his stay with him till nothing is left with the host to entertain him (guest).''

Commentary: This Hadith throws light on something more of the etiquette and scope of hospitality. A guest ought to be given the best entertainment on the first day and night. For the next two days, hospitality should be moderate. On the fourth day, the guest should leave for his destination. Yet if he chooses to stay, hospitality will be in the sense of charity.


Excellence of Conveying Glad Tidings and Congratulations

Chapter 95
Excellence of Conveying Glad Tidings and Congratulations

Allah, the Exalted, says:

"So announce the good news to My slaves. Those who listen to the Word [good advice La ilaha illallah (none has the right to be worshipped but Allah) and Islamic Monotheism] and follow the best thereof (i.e., worship Allah Alone, repent to Him and avoid Taghut).'' (39: 17, 18)

"Their Rubb gives them glad tidings of a Mercy from Him, and that He is pleased (with them), and of Gardens (Jannah) for them wherein are everlasting delights.'' (9:21)

"But receive the glad tidings of Jannah which you have been promised! " (41:30)

"So we gave him the glad tidings of a forbearing boy.'' (37:101)

"And verily, there came Our messengers to Ibrahim (Abraham) with glad tidings.'' (11:69)

"And his wife was standing (there), and she laughed [either, because the messengers did not eat their food or for being glad for the destruction of the people of Lut (Lot)]. But We gave her glad tidings of Ishaq (Isaac), and after Ishaq, of Ya`qub (Jacob).'' (11:71)

"Then the angels called him, while he was standing in prayer in Al-Mihrab (a praying place or a private room), (saying): `Allah gives you glad tidings of Yahya (John).''' (3:39)

"(Remember) when the angels said: `O Maryam (Mary)! Verily, Allah gives you the glad tidings of a Word [`Be!'- and he was! i.e., `Isa (Jesus) the son of Maryam] from Him, his name will be the Messiah `Isa.'' (3:45)

708. `Abdullah bin Abu Aufa (May Allah be pleased with him) reported: Messenger of Allah (PBUH) gave glad tidings to Khadijah (May Allah be pleased with her) about a palace of hollowed pearls in Jannah, free from noise and toil.
[Al-Bukhari and Muslim].

Commentary: This Hadith throws light on the excellence of Khadijah (May Allah be pleased with her) and also mentions the glad tidings given to her by Messenger of Allah (PBUH) about her blessful place in a heavenly abode in the Hereafter.

709. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: One day, I performed my Wudu' in my house and then set forth with the determination that I would stick to Messenger of Allah (PBUH) and spend the whole day with him. I came to the mosque and asked about him. The Companions told that he (PBUH) had gone in a certain direction. Abu Musa added: I followed him inquiring until I came to Bi'r Aris (a well in the suburb of Al-Madinah). (There) I sat down at the door till he (PBUH) had relieved himself and performed Wudu'. Then I went to him and saw him sitting on the platform of the well with his shanks uncovered and his legs dangling in the well. I greeted him and returned to the door of the garden, saying to myself, "I will be the doorkeeper of the Messenger of Allah today.'' Abu Bakr (May Allah be pleased with him) came and knocked at the door. I said; "Who is that?'' He said: "Abu Bakr.'' I said, "Wait a moment.'' Then I went to the Messenger of Allah (PBUH) and said, "O Messenger of Allah! Abu Bakr is at the door seeking permission to enter.'' He said, "Admit him and give him the glad tidings of Jannah.'' I returned and said to Abu Bakr (May Allah be pleased with him): "You may enter and Messenger of Allah (PBUH) has given you the glad tidings of (entering) Jannah.'' Abu Bakr (May Allah be pleased with him) came in and sat down on the right side of Messenger of Allah (PBUH) and suspended his legs into the well and uncovered his shanks, as the Messenger of Allah had done. I returned to the door and sat down. I had left my brother at home while he was performing Wudu' and intending to join me. I said to myself: "If Allah intends good for him (i.e., to be blessed to come at this time and receive the glad tidings of entering Jannah), He will bring him here.'' Someone knocked at the door and I said, "Who is it?'' He said, "Umar bin Al-Khattab.'' I said, "Wait a moment.'' Then I proceeded towards Messenger of Allah (PBUH). I greeted him and said, "Umar is at the door, seeking permission to enter. He said, "Let him in and give him the glad tidings of entering Jannah.'' I went back to `Umar (May Allah be pleased with him) and said to him, "Messenger of Allah has given you permission as well as glad tidings of entering Jannah.'' He entered and sat down with Messenger of Allah (PBUH) on his left side and dangled his feet into the well. I returned to the door and sat down and said to myself: "If Allah intends good for my brother, He will bring him here.'' Someone knocked at the door and I said, "Who is it?'' He said, "Uthman bin `Affan.'' I said, "Wait a moment.'' I went to Messenger of Allah (PBUH) and informed him about his arrival. He said, "Let him in and give him glad tidings of entering Jannah together with a tribulation which he will have to face.'' I came back to him and said, "You may enter; and Messenger of Allah (PBUH) gives you the glad tidings of entering Jannah together with a tribulation that will afflict you.'' He got in and saw that the elevated platform round the well was fully occupied. So he sat on opposite side. Sa`id bin Al-Musaiyab (May Allah be pleased with him) a subnarrator has reported: The order in which they sat down indicated the places of their burial.
[Al-Bukhari and Muslim].

Another narration adds: Abu Musa Al-Ash`ari (May Allah be pleased with him) said: The Prophet (PBUH) ordered me to guard the door. When `Uthman was told (about the misfortune) he praised Allah then said: "Allahu Musta`an (His help is to be sought).''

(The interpretation of Sa`id bin Al-Musaiyab is that the graves of Abu Bakr and `Umar (May Allah be pleased with them) are by the side of the Prophet (PBUH), in the same position they took when they sat next to the Prophet (PBUH) while the grave of `Uthman is away from their graves, in the public graveyard of Al-Madinah known as Baqi` Al-Gharqad).

Commentary: This Hadith brings four points under our consideration. First, in certain cases, a glad tiding is given about the future life. Second, the Prophet (PBUH) himself gave the good news to the first three Rightly-Guided Khulafa' (caliphs) that they would go to Jannah. Now only an inborn wretch can doubt their Faith. Third, the riot foretold by the Prophet (PBUH) with regard to `Uthman (May Allah be pleased with him) took place in the concluding days of his caliphate. Influenced by the wicked and baseless propaganda of a Jew, `Abdullah bin Saba', a splinter group blockaded `Uthman's house and finally put him to death. The incident reveals the Prophet's truthfulness. Fourth, things are also interpreted while one is awake, and the power of intuition is of course the basis of such a state. Yet, a vision is not necessarily commensurate with the external reality in all cases. However, the first two caliphs, as envisioned by Abu Musa Al-Ash`ari (May Allah be pleased with him), are eternally resting, along with the Prophet (PBUH), in `Aishah's room, while `Uthman (May Allah be pleased with him) is buried in the Al-Madinan graveyard of Baqi` Al-Gharqad.

710. Abu Hurairah (May Allah be pleased with him) reported: We were sitting in the company of the Messenger of Allah (PBUH), and Abu Bakr and `Umar (May Allah be pleased with them) were also present. All of a sudden the Messenger of Allah (PBUH) got up and left us. When he was late to return to us we began to worry lest he should meet with trouble in our absence. I was the first to be alarmed and set out in search of him until I came to a garden belonging to Banu-Najjar (a section of the Ansar). I went round it looking for an entrance, but failed to find one. However, I saw a stream of water flowing into the garden from a well outside. I drew myself together like a fox and slinked into the place and reached the Messenger of Allah (PBUH). He said, "Is it Abu Hurairah?'' I replied in the affirmative. He asked, "What is the matter with you?'' I replied, "You were sitting with us and then you left us and delayed for a time. Fearing you had met with some adversities we got alarmed. I was the first to be alarmed. So when I came to this garden, I squeezed myself like a fox and these people are coming behind me.'' He (the Prophet (PBUH)) gave me his sandals and said, "O Abu Hurairah! Take these sandals of mine, and whoever you meet outside this garden testifying that La ilaha illallah (There is no true god except Allah), being assured of it in his heart, give him the glad tidings that he will enter Jannah.'' (Abu Hurairah then narrated the Hadith in full).
[Muslim].

Commentary: As explained earlier in detail, a believer will definitely go to Jannah, provided he/she sincerely believes in Allah without associating anyone with His Divinity, either he/she is very likely to be admitted to Jannah in the first stage, or otherwise after being chastised depending on his or her sins. His eternal abode will be in Jannah and not in Hell-fire, In sha' Allah.

711. Ibn Shumasah reported: We visited `Amr bin Al-`as (May Allah be pleased with him) when he was in his deathbed. He wept for a long time and turned his face towards the wall. His son said: "O father, did not the Messenger of Allah (PBUH) give you the good news of such and such? Did he not give you glad tidings of such and such?'' Then he (`Amr) turned his face towards us and said: "The best thing which you can count upon is the affirmation that: La ilaha illallah (there is no true god except Allah), and that Muhammad is the Messenger of Allah. I have passed through three phases. I remember when I hated none more than I hated the Messenger of Allah (PBUH), and there was no other desire stronger in me than that of killing him. Had I died in that state, I would have definitely been one of the dwellers of Fire (Hell). When Allah instilled the love for Islam in my heart, I went to Messenger of Allah (PBUH) and said, `Extend your right hand, so that I pledge allegiance to you.' He (PBUH) stretched out his right hand, but I withdrew my hand. He said, `What is the matter, `Amr?' I said, `I wish to lay down same conditions.' He asked, `What conditions do you wish to put forward?' I replied, `To be granted forgiveness.' He said, `Do you not know that (embracing) Islam wipes out all that has gone before it (previous misdeeds). Verily, emigration wipes out all the previous sins, and the Hajj (pilgrimage) wipes out all the previous sins.' Thereafter, no one was dearer to me than Messenger of Allah (PBUH), and none was more respectable than him in my eyes. So bright was his splendour that I could not gather enough courage to look at his face for any length of time. If I were asked to describe his feature, I would not be able to do so because I have never caught a full glimpse of his face. Had I died in that state I could have hoped to be one of the dwellers of Jannah. Thereafter, we were made responsible for many things and in the light of which I am unable to know what is in store for me. When I die, no mourner, nor fire should accompany my bier. When you bury me, throw the earth gently over me and stand over my grave for the space of time within which a camel is slaughtered and its meat is distributed so that I may enjoy your intimacy, and in your presence ascertain what answer can I give to the Messengers of my Rubb (the angels in grave).''
[Muslim].

Commentary: This Hadith tells us about three phases of the life of `Amr bin Al-`as (May Allah be pleased with him), that is, pre-Islamic period, post-faith period and the governorship period. Of the last one, when he shouldered heavy responsibilities, he feared that he might have committed some lapses and for that he might be subjected to accountability before Allah. The Hadith invites our attention to the following points:

First, Amr's vehement hostility of pre-faith days was transformed into intense love for the Prophet (PBUH) upon embracing Islam. Second, the greatness of the Prophet (PBUH) was ingrained in the Companions' hearts. Third, the fear of error and the hope of Divine mercy may cause one to shed tears at the moment of death. Fourth, it is desirable on the part of relatives and friends to do something for the comfort of a dying person by giving him the glad tidings of Allah's Mercy. Fifth, Islam wipes out all previous sins, but afterwards, life should be led according to the dictates of true Faith. In the same way the minor sins are pardoned on account of Hijrah, and Hajj, but a sincere repentance with all its conditions is indispensable to the remission of major sins. Sixth, lamentation over a dead body is forbidden. Seventh, one may desirably make a will before death, particularly with regard to the anti-Shari`ah heresies and rites to which the bereaved people are likely to take recourse. Eighth, there is an affirmation of the orthodox belief that Munkir and Nakir (two angels) appear in the grave and question the dead person about his or her religious beliefs. Ninth, to stand over the grave and to pray for the salvation of the dead person is a desirable act, as the dead person enjoys the intimacy and the visit of the righteous to his grave. This Hadith, therefore, recommends believers to pray for the firmness of the dead person.


Bidding Farewell and Advising on the Eve of Departure for a Journey or other Things

Chapter 96
Bidding Farewell and Advising on the Eve of Departure for a Journey or other Things

Allah, the Exalted, says:

"And this (submission to Allah, Islam) was enjoined by Ibrahim (Abraham) upon his sons and by Ya`qub (Jacob) (saying), `O my sons! Allah has chosen for you the (true) religion, then die not except in the Faith of Islam (as Muslims - Islamic Monotheism).' Or were you witnesses when death approached Ya`qub (Jacob)? When he said unto his sons, `What will you worship after me?' They said, `We shall worship your Ilah (God - Allah) the Ilah (God) of your fathers, Ibrahim (Abraham), Isma`il (Ishmael), Ishaq (Isaac). One Ilah (God), and to Him we submit (in Islam)'.'' (2:132,133)

712. Yazid bin Haiyan (May Allah be pleased with him) reported: I went along with Husain bin Sabrah and `Amr bin Muslim to Zaid bin Arqam (May Allah be pleased with them) and, as we sat by his side, Husain said to him: "O Zaid, you acquired great merits that you saw Messenger of Allah (PBUH), listened to his talk, fought by his side in (different) battles, and offered Salat behind him. You have in fact earned great merits, Zaid! Could you then tell us what you heard from the Messenger of Allah (PBUH)?'' He said: "O my cousin! By Allah! I have grown old and have almost spent up my age and I have forgotten some of the things which I remembered in connection with Messenger of Allah (PBUH), so accept what I narrate to you, and what I fail to narrate, do not compel me to narrate that.'' He then said: "One day Messenger of Allah (PBUH) stood up to deliver a Khutbah at a watering place known as Khumm between Makkah and Al-Madinah. He praised Allah, extolled Him and delivered the Khutbah and exhorted (us) and said, `Amma Ba`du (now then)! O people, certainly I am a human being. I am about to receive a messenger (the angel of death) from my Rubb and I, in response to Allah's Call, but I am leaving among you two weighty things: the Book of Allah in which there is right guidance and light, so hold fast to the Book of Allah and adhere to it.' He exhorted (us) (to hold fast) to the Book of Allah and then said, `The second are the members of my household, I remind you (of your duties) to the members of my family.'''

Commentary: The Prophet (PBUH) told his Companions with reference to his human nature that he too could not escape death because it was a grim reality. So he left his example to others with regard to making a will before death. The Hadith points out the desirability of giving good counsel to one's family and friends, exhorting them to observe uprightness and establish Faith, upon parting either for a journey or while one is on deathbed.

713. Malik bin Al-Huwairith (May Allah be pleased with him) reported: We came to the Messenger of Allah (PBUH) when we were all young men of nearly equal age. We stayed with him for twenty days. He was extremely kind and considerate. He perceived that we missed our families so he asked us about those we left behind, and we informed him. Then he (PBUH) said, "Go back to your families, stay with them, teach them (about Islam) and exhort them to do good. Perform such Salat (prayer) at such a time and such Salat at such a time. When the time for Salat is due, one of you should announce Adhan (call for prayer) and the oldest among you should lead Salat.''
[Al-Bukhari and Muslim].

Commentary: This Hadith sheds light on seven points. First, we are informed of certain young men who had left their homes and come to the Prophet (PBUH) in order to receive religious training from him. This shows that a student of knowledge should not hesitate to set forth on a journey in the pursuit of knowledge. Second, a teacher/mentor is supposed to have firsthand information about the affairs and requirements of students and to take measures accordingly. Third, after graduation or the completion of an orientation course in religious studies, the beneficiaries are also required to impart religious knowledge and training to those who lack it. Fourth, they should also tell people to do what is commanded by the Shari`ah (Islamic Law) and to shun what it prohibits. Fifth, an arrangement must be made for a Mu'adhdhin to call people to Salat (prayers). Sixth, in case each one of the congregation is equally qualified to lead the Salat, the one who is most senior in age should perform the duty. The first prerequisite of becoming an Imam is the ability to recite Qur'an well and in the right manner. The second in priority is that person who is well-grounded in the religion - Qur'an and Hadith. In other words, a good Qari (reciter) is most fit to become an Imam and the second choice should be the one who has the mastery of religious knowledge. Seventh, the crux of the matter is that on all occasions and at all places, believers are under obligation to take care to establish congregational prayer after the prayer-call.

714. `Umar bin Al-Khattab (May Allah be pleased with him) reported: I sought permission of the Prophet (PBUH) to perform `Umrah, and he granted me leave and said, "Brother, do not forget us in your supplications.'' I would not exchange these words of his for the whole world.

Another narration is: He (PBUH) said, "Include us, my brother, in your supplications.''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith is being repeated here to prove that a highly-ranked person in virtue and excellence may ask his inferior to pray for him. Furthermore, it reflects the Prophet's humility that he asks his followers to pray for him. This Hadith is enough evidence that supplications benefit the living people.

715. Salim bin `Abdullah bin `Umar (May Allah be pleased with them) reported: When a man was to set out on a journey, `Abdullah bin `Umar (May Allah be pleased with them) would say to him: "Draw near so that I may bid farewell to you as Messenger of Allah (PBUH) used to bid farewell to us. (The Messenger of Allah (PBUH) used to say: "`Astaudi`ullaha dinaka, wa amanataka, wa khawatima `amalika' (I entrust Allah with your Deen, your trust and your last deeds).''
[At-Tirmidhi].

Commentary: Herein, we note a provision for uttering benedictory words and praying for a person on the occasion of seeing him off. The benedictory utterances are: "I entrust your Deen, your (religious) trust (i.e., religious obligations) and your last deeds with Allah.''

716. `Abdullah bin Yazid Al-Khatmi (May Allah be pleased with him) reported: When Messenger of Allah (PBUH) intended to bid farewell to his army he would say: "Astau-di'ullaha dinakaum, wa amanatakum, wa khawatima `amalikum (I entrust Allah with your Deen, your trust and your last deeds).''
[Abu Dawud].

Commentary: This Hadith presents the same benediction as stated above. Yet, here its addresses are the plural number of second person, whereas in the previous Hadith it was singular number. The Hadith points out the virtue desirability of the leader to bid farewell to his army before they set out for the battlefield, and to advise them using the Prophet's words stated above, reminding them to hold fast to their religion for which they have left everything behind to fight for it and to win Allah's Mercy.

717. Anas (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said: "O Messenger of Allah! I intend to go on a journey, so supplicate for me.'' He (PBUH) said, "May Allah grant you the provision of piety.'' The man said: "Please supplicate more for me.'' He (PBUH) said, "May He forgive your sins!'' The man repeated: "Please supplicate more for me.'' Messenger of Allah (PBUH) said, "May He facilitate for you the doing of good wherever you are.''
[At-Tirmidhi].

Commentary: Spiritually speaking, the most beneficial thing that a traveller can bank upon is a benediction. So, it is desirable for a traveller to visit his fellow Muslim brother to pray for him before he starts his journey.


Istikhara (Seeking Guidance from Allah), and Consultation

Chapter 97
Istikhara (Seeking Guidance from Allah), and Consultation

Allah, the Exalted, says:

"And consult them in the affairs.'' (3:159)

"And who (conduct) their affairs by mutual consultation.'' (42:38)

718. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) used to teach us the Istikharah (seeking guidance from Allah) in all matters as he would teach us a Surah of the Qur'an. He used to say: "When one of you contemplates entering upon an enterprise, let him perform two Rak`ah of optional prayer other than Fard prayers and then supplicate: "Allahumma inni astakhiruka bi `ilmika, wa astaqdiruka bi qudratika, wa as-'aluka min fadlikal-`azim. Fainnaka taqdiru wa la aqdiru, wa ta`lamu wa la a`lamu, wa Anta `allamul-ghuyub. Allahumma in kunta ta`lamu anna hadhal-`amra (and name what you want to do) khairun li fi dini wa ma`ashi wa `aqibati amri, (or he said) `ajili amri ajilihi, faqdurhu li wa yassirhu li, thumma barik li fihi. Wa in kunta ta`lamu anna hadhal `amra (and name what you want to do) sharrun li fi dini wa ma`ashi wa `aqibati amri, (or he said) wa `ajili amri wa ajilihi, fasrifhu `anni, wasrifni `anhu, waqdur liyal-khaira haithu kana, thumma ardini bihi.'' (O Allah, I consult You through Your Knowledge, and I seek strength through Your Power, and ask of Your Great Bounty; for You are Capable whereas I am not and, You know and I do not, and You are the Knower of hidden things. O Allah, if You know that this matter (and name it) is good for me in respect of my Deen, my livelihood and the consequences of my affairs, (or he said), the sooner or the later of my affairs then ordain it for me, make it easy for me, and bless it for me. But if You know this matter (and name it) to be bad for my Deen, my livelihood or the consequences of my affairs, (or he said) the sooner or the later of my affairs then turn it away from me, and turn me away from it, and grant me power to do good whatever it may be, and cause me to be contented with it). And let the supplicant specify the object.''
[Al-Bukhari and Muslim]

Commentary: Literally Istikharah means seeking goodness from Allah through a particular prayer. This Hadith lays emphasis on it and displays its significance. We should, therefore, practise Istikharah regarding every important matter. However, it is imperative only in cases where one is ignorant of good and evil. Yet, with regard to obligatory and indisputable rules, practices of the Prophet (PBUH) and commendable deeds, no Istikharah is allowed. Similarly, commands and prohibitions of the Shari`ah are categorical and nobody is allowed to seek further guidance by performing Istikharah prayer. Moreover, to set aside the example of the Prophet (PBUH) of Istikharah, and to trust astrologers, palmists and soothsayers seeking the knowledge of future events is sheer ignorance and unpardonable error. The knowledge of the Unseen (or Ghaib) is the domain of Allah Alone and man is supposed to seek His Blessings. Only Allah is Omnipotent and humans must turn to Him to seek inspiration and strength, trusting everything to His Care.

Istikharah prayer can be offered at any time except in the forbidden hours for prayer because the performance of two Rak`ah is a prerequisite to it. Some people think that the right time for it is before going to bed. This is not true. This supplication (Du`a) can be offered even after performing the two Rak`ah of Istikharah prayer, or before Taslim (i.e., saying Assalamu `Alaikum to conclude the prayer) after Tashahhud or in the state of prostration. If somebody does not know this Du`a by heart, he can, after performing the prayer, read it from some prayerbook.


Excellence of Adopting Different Routes for going and returning on 'Eid Prayer and various other Occasions

Chapter 98
Excellence of Adopting Different Routes for going and returning on 'Eid Prayer and various other Occasions

719. Jabir (May Allah be pleased with him) reported: On the occasion of the `Eid, the Prophet (PBUH) would proceed to the prayer place taking one route and returning from another.
[Al-Bukhari and Muslim].

Commentary: The `Ulama' say that there are many subtle points of wisdom in changing the way. According to Imam An-Nawawi, this causes an increase in the places of worship. Some say that both ways will bear witness on the Day of Reckoning, that he had passed through them in a state of worship. This may also be the object that instead of one way, the needy on two ways should benefit from alms and charity.

720. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) used to go by way of Ash-Shajarah and return by way of Al-Mu`arras. He would also enter Makkah through the Higher Pass and would leave it through the Lower Pass.
[Al-Bukhari and Muslim].

Commentary: It was the habit of Messenger of Allah (PBUH) that while going to Makkah from Al-Madinah, he would adopt the route of a shallow ravine and his return route being always a deep ravine. Ash-Shajarah is a well-known place. He would pass through it and reach Dhul-Hulaifah and spend a night there. Yet, he would proceed to Al-Madinah through Al-Mu`arras, a name given to Dhul-Hulaifah Masjid (mosque) which is six-mile away from Al-Madinah. Again this is to be concluded that while returning to our destination from any place, we should choose a different route because this was exactly the habit of the Prophet (PBUH) .


Excellence of using the right Hand for Performing various good Acts

Chapter 99
Excellence of using the right Hand for Performing various good Acts

Allah, the Exalted, says:

"Then as for him who will be given his Record in his right hand will say: `Take, read my Record!''' (69:19)

"So those on the Right Hand (i.e., those who will be given their Records in their right hands) how (fortunate) will those be on the Right Hand! (As a respect for them, because they will enter Jannah). And those on the Left Hand (i.e., those who will be given their Record in their left hands) how (unfortunate) will those be on the Left Hand! (As a disgrace for them, because they will enter Hell).'' (56:8,9)

721. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) liked to use his right hand in all matters: in combing his hair and wearing his shoes.
[Al-Bukhari and Muslim].

722. `Aishah (May Allah be pleased with her) reported: Messenger of Allah was used to using his right hand for performing Wudu' and for eating his food whereas he was used to using his left hand in his toilet and for other similar purposes.
[Abu Dawud]

Commentary: Messenger of Allah (PBUH) used to use his left hand in washing his private parts and cleaning his nose and similar things, Muslims are obliged to follow his example.

723. Umm `Atiyyah (May Allah be pleased with her) reported: The Prophet (PBUH) instructed us at the time of washing the dead body of his daughter Zainab (May Allah be pleased with her) to begin with her right side, and from the parts that are washed in Wudu'.
[Al-Bukhari and Muslim].

Commentary: Here we are told about the excellence of washing the dead starting with their right side, Umm `Atiyyah (May Allah be pleased with her) was one of those women who had washed the dead body of the Prophet's daughter Zainab (May Allah be pleased with her). Messenger of Allah (PBUH) directed these women to do as mentioned above. We infer from this Hadith that either women should wash the dead body of a woman or this job should be done by her husband.

724. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When any of you puts on his shoes, he should put on the right one first; and when he takes them off, he should begin with the left. Let the right shoe be the first to be put on and the last to be taken off.''
[Al-Bukhari and Muslim].

Commentary: This Hadith sheds light on the etiquette of wearing as well as removing shoes. Every Muslim is supposed to have regard for the Prophetic example and to follow it.

725. Hafsah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) used to use his right hand for eating, drinking and wearing his clothes and used to use his left hand for other purposes.
[Abu Dawud].

726. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When you wear your clothes or perform your Wudu', begin with your right side.''
[Abu Dawud and At-Tirmidhi].

727. Anas (May Allah be pleased with him) reported: When Messenger of Allah (PBUH) went to Mina, he came to Jamrat-ul-`Aqabah and threw pebbles at it. After that, he went to his lodge in Mina and sacrificed. Then he called for a barber and pointed his right side to him, said, "Shave from here.'' Then he pointed his left side and said, "Take (hair) from here.'' Then he distributed his hair among the people.
[Al-Bukhari and Muslim].

Another narration is: After the Messenger of Allah (PBUH) had thrown pebbles at Jamrah and sacrificed an animal, he turned the right side of his head towards the barber who shaved it for him. Then he called Abu Talhah Ansari (May Allah be pleased with him) and gave his hair to him. Then he turned his head to the left side and asked the barber to shave it. He gave the hair to Abu Talhah and told him, "Distribute it among the people.''

Commentary: After returning from `Arafat on the 10th of Dhul-Hijjah, pilgrims throw pebbles at Jamrat-ul-Aqabah. This is followed by the sacrifice of an animal, the shaving of the head and the farewell Tawaf (circumambulation) of the Holy House. All this is to be observed on the Sacrificial Day in the exact order of priorities. Yet, an unexpected disturbance in this order involves no juristic disadvantage. Moreover, the act of throwing pebbles marks an end to the ban on legal concessions. But this permissibility is minor and partial, that is, everything becomes lawful except the physical contact with one's wife. The ban is totally lifted in the wake of the farewell circumambulation of the House of Allah. Secondly, we are told that the ritual shaving of the head should begin from the right side. Thirdly, there is a mention of the distribution of the Prophet's hair as a blessing among the Companions which is one of the Prophetic characteristics.


Book Two: The Book about the Etiquette of Eating

  • Chapter 100 : Mentioning Bismillah before and saying Al-Hamdulillah after Eating
  • Chapter 101 : Prohibition of Criticizing Food
  • Chapter 102 : Response to an Invitation extended to a Man observing Saum (Fasting)
  • Chapter 103 : What should one say to the Host if an uninvited Person is accompanied with an invited Person
  • Chapter 104 : Eating from what is in front of One
  • Chapter 105 : Prohibition of Eating two Date-fruits Simultaneously
  • Chapter 106 : What should a Person say or do when he Eats but is not Satisfied
  • Chapter 107 : Eating from the Side of the Vessel
  • Chapter 108 : Undesirability of Eating in a Reclining Posture
  • Chapter 109 : Excellence of Eating with three Fingers and Licking them
  • Chapter 110 : Merit of Sharing Food
  • Chapter 111 : Etiquette of Drinking Water
  • Chapter 112 : Undesirability of Drinking directly from the mouth of a Water-Skin
  • Chapter 113 : Undesirability of blowing into the Vessel while Drinking
  • Chapter 114 : Permission to Drink while in a standing Posture
  • Chapter 115 : Excellence of Cupbearer drinking Last
  • Chapter 116 : Permissibility of drinking water from clean Vessels of all types except Gold and Silver ones


Mentioning Bismillah before and saying Al-Hamdulillah after Eating

Chapter 100
Mentioning Bismillah before and saying Al-Hamdulillah after Eating

728. `Umar bin Abu Salamah (May Allah be pleased with him) reported: Messenger of Allah (PBUH), said to me, "Mention Allah's Name (i.e., say Bismillah before starting eating), eat with your right hand, and eat from what is near you.''
[Al-Bukhari and Muslim].

Commentary: There are two things about this Hadith. First, we should start eating or drinking by pronouncing the Name of Allah. Second, we should eat from our side without stretching our hand to the side where someone else is eating. This may be the case when more than one or two people are eating the same kind of food from a single dish. Good manners do not allow it, yet in case a variety of food or fruit is lying before us on the table, we are free to take our pick.

729. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "When any of you wants to eat, he should mention the Name of Allah in the begining, (i.e., say Bismillah). If he forgets to do it in the beginning, he should say Bismillah awwalahu wa akhirahu (I begin with the Name of Allah at the beginning and at the end).''
[At-Tirmidhi and Abu Dawud].

Commentary: This Hadith provides us a concession. If we have forgotten to pronounce the Name of Allah before beginning to eat, we can do it during eating or in the end.

730. Jabir (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "If a person mentions the Name of Allah upon entering his house or eating, Satan says, addressing his followers: `You will find no where to spend the night and no dinner.' But if he enters without mentioning the Name of Allah, Satan says (to his followers); `You have found (a place) to spend the night in, and if he does not mention the Name of Allah at the time of eating, Satan says: `You have found (a place) to spend the night in as well as food.'''
[Muslim].

Commentary: Herein, we are told that in order to ward off Satan and his followers, we are supposed to remember Allah before entering our house and before beginning to eat. The remembrance of Allah implies those appropriate prayers of the Prophet (PBUH) which have been mentioned in Ahadith. For example, we are instructed to pronounce the Name of Allah before beginning to eat. On entering our house we recite the following Prophetic prayer: "Allahumma inni as'aluka khairal-mawliji wa khairal-makhraji. Bismillahi wa lajna, wa bismillahi kharajna, wa `al-Allahi rabbina tawakkalna.'' (O Allah! I ask you for what is good of entrance and what is good for exit. With the Name of Allah do we enter, and with the Name of Allah do we leave, and upon our Rubb Allah have we put our trust).

731. Hudhaifah (May Allah be pleased with him) reported: When we attended a meal with the Messenger of Allah (PBUH), we would not stretch forth our hands towards the food until he (PBUH) would start eating first. Once, we were with him when a little girl rushed in as if someone was impelling her. She was about to lay her hand on the food when the Messenger of Allah (PBUH) caught her hand. Then a bedouin came in rushing as if someone were pushing him. He (PBUH) caught his hand also and said, "Satan considers that food lawful for himself on which the Name of Allah is not mentioned. He (Satan) brought this girl to make the food lawful through her but I caught her hand. Then he brought the bedouin to make it lawful through him but I caught his hand too. By Him in Whose Hand my soul is, now Satan's hand is in my grasp along with their hands.'' Then he mentioned the Name of Allah and began to eat.
[Abu Dawud and An-Nasa'i].

Commentary: Here, too, we are told that if we do not pronounce Allah's Name, Satan and his minions will share our meal with us. So prior to eating, we must pronounce the Name of Allah. An incident is related in this Hadith. Once, Messenger of Allah (PBUH) and his Companions were just to start taking their meal when an unknown girl and a bedouin burst upon the scene. Without seeking the formal permission and pronouncing the Name of Allah they hurriedly stretched their hands to eat. Yet, Messenger of Allah (PBUH) restrained them from doing so. Owing to Divine inspiration, he had seen the hidden hand of the Devil behind their abrupt actions. We have only one way to escape the Devil, that is, on such occasions we should first pronounce the Name of Allah. Second, this Hadith enlightens us on table manners calling for decency and decorum. It will be called an act of sheer indecency to voraciously pounce upon food as is commonly witnessed in feasts and weddings. Indeed, it is the result of deviation from Islamic teachings that many Muslims have grown ignorant of the Prophet's manner of eating. Allah, too, has left them unrestrained in their beast-like hunger.

732. Umaiyyah bin Makhshi (May Allah be pleased with him) reported: Messenger of Allah (PBUH) was sitting while a man was eating food. That man did not mention the Name of Allah (before commencing to eat) till only a morsel of food was left. When he raised it to his mouth, he said: "Bismillah awwalahu wa akhirahu (With the Name of Allah, in the beginning and in the end).'' Messenger of Allah (PBUH) smiled at this and said, "Satan had been eating with him but when he mentioned the Name of Allah, Satan vomited all that was in his stomach.''
[Abu Dawud and An-Nasa'i].

Commentary: This Hadith also informs us that Satan shares food and drink with those people who do not mention the Name of Allah.

733. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) was eating with his six Companions when a desert Arab came and ate up the food in two mouthfuls. Messenger of Allah (PBUH) said, "Had he mentioned the Name of Allah, it would have sufficed for all of you.''
[At-Tirmidhi].

Commentary: The pronouncement of Allah's Name brings blessing to the meal, and the omission of His Name robs blessing away.

734. Abu Umamah (May Allah be pleased with him) reported: Whenever the Prophet (PBUH) finished a meal, he would say: "Al-hamdu lillahi kathiran taiyiban mubarakan fihi, ghaira makfiyyin wa la muwadda`in, wa la mustaghnan `anhu, Rabbuna. (All praise is due to Allah, praise which is abundant, pure, and full of blessings, which is indispensable and to which one cannot be indifferent).''
[Al-Bukhari].

Commentary: This Hadith mentions a supplication which Messenger of Allah (PBUH) used to recite after taking meal. The economy of words was the essence of the Prophet's (PBUH) eloquence as displayed here. To supplicate this Prophetic prayer after taking a meal is recommendable.

735. Mu`adh bin Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who has taken food and says at the end: `Al-hamdu lillahi-lladhi at`amani hadha, wa razaqanihi min ghairi haulin minni wa la quwwatin (All praise is due to Allah Who has given me food to eat and provided it without any endeavour on my part or any power),' all his past sins will be forgiven.''
At-Tirmidh i].

Commentary: This Hadith tells us that if we praise Allah after taking a meal, all our minor sins committed in the past will be forgiven by Him.


Prohibition of Criticizing Food

Chapter 101
Prohibition of Criticizing Food

736. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) never found fault with food. If he had inclination to eating it, he would eat; and if he disliked it, he would leave it.
Al-Bukhari and Muslim].

Commentary: This Hadith throws light on the Prophet's excellent manners which ought to be followed by all Muslims. It is a deplorable state of affairs that when we find a dish a bit unsavoury, we lose our temper and create quite a scene in the house. May we follow the excellent example of our Prophet (PBUH)!

737. Jabir (May Allah be pleased with him) reported: The Prophet (PBUH) asked for sauce and was told that there was nothing except vinegar. He asked for it and began to eat from it saying, "How excellent is vinegar when eaten as sauce! How excellent is vinegar when eaten as Udm!''
Muslim].

Commentary: This Hadith speaks about the simplicity and humility of Messenger of Allah (PBUH) with regard to food. As he abstained from a luxurious lifestyle, he hardly craved for delicious food. No mention of dainties, he would readily eat whatever was available to him.


Response to an Invitation extended to a Man observing Saum (Fasting)

Chapter 102
Response to an Invitation extended to a Man observing Saum (Fasting)

738. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When any of you is invited to a meal, he should accept the invitation. If he is observing Saum (fasting), he should supplicate for the betterment of the host and if he is not fasting, he should eat.''
Muslim].

Commentary: Shari`ah permits a person to break a voluntary fasting. The example of Messenger of Allah (PBUH) clearly shows that it is not binding on him to keep it again as a redeeming step. A man is, therefore, free to break his voluntary fasting and participate in the feast to which he is invited. However, if somebody is reluctant to break the fast, he should pray for the good and welfare of the host. But we should refuse to attend such treats which are flagrantly masked by extravagance and frivolous un-Islamic rites to the disobedience of Allah.


What should one say to the Host if an uninvited Person is accompanied with an invited Person

Chapter 103
What should one say to the Host if an uninvited Person is accompanied with an invited Person

739. Abu Mas`ud Al-Badri (May Allah be pleased with him) reported: A man prepared some food especially for the Prophet (PBUH) and invited him along with four others. But a man accompanied him. Having arrived at the door, Messenger of Allah (PBUH) said to the host, "This person has followed us. You may allow him, if you like, and if you like he will return.'' He said: "O Messenger of Allah, I allow him, too.''
[Al-Bukhari and Muslim].

Commentary: It will be considered an expression of bad manners if somebody participates in a feast as an uninvited, parasitic guest. Yet, he stands a chance in case he is allowed by the host. In this Hadith, there is a case when Messenger of Allah (PBUH) said to the host that it was up to him to let the uninvited person to stay for food or go. However, the invitees may take along with them two or three uninvited guests if they believe that the host will not take it ill.


Eating from what is in front of One

Chapter 104
Eating from what is in front of One

740. `Umar bin Abu Salamah (May Allah be pleased with them) reported: I was a boy under the care of Messenger of Allah (PBUH), and as my hand used to wander around in the dish, he (PBUH) said to me once, "Mention Allah's Name (i.e., say Bismillah), eat with your right hand, and eat from what is in front of you.''
[Al-Bukhari and Muslim].

Commentary: `Umar bin Abu Salamah (May Allah be pleased with them) had learnt table manners from Messenger of Allah (PBUH) who was his stepfather and guardian. Hence, everybody is morally bound to teach his wards or children good manners.

741. Salamah bin Al-Akwa` (May Allah be pleased with him) reported on the authority of his father: A man ate with his left hand in the presence of Messenger of Allah (PBUH), whereupon he said, "Eat with your right hand.'' The man said: "I cannot do that.'' Thereupon he (the Prophet (PBUH)) said, "May you not be able to do that.'' It was vanity that prevented him from doing it and he could not raise it (the right hand) up to his mouth afterwards.
[Muslim].

Commentary: This report has already been given earlier and is being repeated here owing to its relevance to the chapter. In the light of this Hadith, we are supposed to keep table manners in our focus and also to urge others to observe them. Furthermore, it is extremely undesirable to deny a reality out of sheer arrogance as it incurs the displeasure of Allah. We are also informed of a miracle of Messenger of Allah (PBUH) whose supplications were instantly answered.


Prohibition of Eating two Date-fruits Simultaneously

Chapter 105
Prohibition of Eating two Date-fruits Simultaneously

742. Jabalah bin Suhaim reported: We were with `Abdullah bin Az-Zubair (May Allah be pleased with them) in a time of famine, then we were provided with dates. (Once) when we were eating, `Abdullah bin `Umar (May Allah be pleased with them) passed by us and said: "Do not eat two dates together, for Messenger of Allah (PBUH) prohibited it, unless one seeks permission from his brother (partner).''
[Al-Bukhari and Muslim].

Commentary: This Hadith has a lesson for today's Muslims whose majority seems to be ignorant of good manners. It is commonly seen at feasts that somebody, unconcerned about others around him, will be engaged in filling his own plate with food. Such a greed of eating is against the Prophet's teaching and guidance which inspire us to have a due regard for others and not to serve our own purpose alone.


What should a Person say or do when he Eats but is not Satisfied

Chapter 106
What should a Person say or do when he Eats but is not Satisfied

743. Wahshi bin Harb (May Allah be pleased with him) reported: Some of the Companions of Messenger of Allah (PBUH) said: "We eat but are not satisfied.'' He (PBUH) said, "Perhaps you eat separately.'' The Companions replied in affirmative. He then said: "Eat together and mention the Name of Allah over your food. It will be blessed for you.''
[Abu Dawud].


Eating from the Side of the Vessel

Chapter 107
Eating from the Side of the Vessel

744. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said, "Blessing descends upon food in its middle, so eat from the sides of the vessel and do not eat from its middle.''
[At-Tirmidhi and Abu Dawud].

Commentary: This Hadith tells us that if a few people or members of the same family recite the Name of Allah and take meal at the same table, a two-fold benefit will accrue to them. Their hunger will be sated with their subsistence being given the Divine blessing. And if they do otherwise, the result will be otherwise too.

745. `Abdullah bin Busr (May Allah be pleased with him) reported: The Prophet (PBUH) had a large bowl called Al-Gharra', which would be carried by four men. One day, when the Companions finished their Duha (forenoon optional) prayer, Al-Gharra' was brought full of sopped bread, meat and broth, and they sat down around it. When their number increased, Messenger of Allah (PBUH) sat down on his knees and rested on the soles of his feet. A bedouin said to him: "What sort of sitting is that?'' Thereupon Messenger of Allah (PBUH) said, "Verily, Allah has made me a courteous slave not a fierce tyrant.'' Then he said, "Eat from the sides of the bowl and leave the central part of it so that your food will be blessed.''
[Abu Dawud].

Commentary: Here, too, we are told to eat collectively and from our side of the table. Messenger of Allah (PBUH) calls it the blessed way. There is also a provision for sitting with bent knees (while resting on one's soles). Moreover, the excellence of Messenger of Allah (PBUH) as well as his humility are brought to our knowledge.


Undesirability of Eating in a Reclining Posture

Chapter 108
Undesirability of Eating in a Reclining Posture

746. Abu Juhaifah Wahb bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "I do not eat reclining (against a pillow).''
[Al-Bukhari].

Commentary: What is meant by reclining? There is a difference of opinion on it. Some say that it means leaning on one side, whether right or left, or against the wall. Imam Al-Khattabi takes it in this sense that somebody should lay out a mattress and sit on it comfortably as one sits cross-legged. Messenger of Allah (PBUH) used to take hardly an adequate meal. Ibn Hajar says that one should sit with the right knee drawn up and the left one bent down.

747. Anas (May Allah be pleased with him) reported: I saw Messenger of Allah (PBUH) eating some dates while sitting on his buttocks, with his legs raised.
[Muslim].

Commentary: This Hadith sheds light on another sitting posture of Messenger of Allah (PBUH). But it betrays his uneasy state. In fact, when he was in a hurry he would be eager by eating a few dates so that he might be free to attend to some more important business. Also a report of Anas (May Allah be pleased with him) quoted by Muslim explains this state of mind of Messenger of Allah (PBUH).


Excellence of Eating with three Fingers and Licking them

Chapter 109
Excellence of Eating with three Fingers and Licking them

748. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "When one of you finishes eating, he should not wipe his fingers until he has licked them himself or has given them to someone else to lick for him.''
[Al-Bukhari and Muslim].

Commentary: Messenger of Allah (PBUH) instructed his followers that after taking meal they should lick up their fingers before they wash or wipe them with a towel. Or they may get them licked by somebody - wife, son or disciple - provided he or she feels no aversion to doing so. Since Messenger of Allah (PBUH) approved of this act, it is commendable. As to its rationale, the subsequent Ahadith will offer exposition.

749. Ka`b bin Malik (May Allah be pleased with him) reported: I saw Messenger of Allah (PBUH) eating with three fingers (i.e., the thumb, the index finger and the middle finger) and licking them after having finished the food.
[Muslim].

Commentary: To use less than three fingers for eating speaks of the manner of the arrogant, whereas to use both hands to this end is indicative of an overpowering greed. So, the best way of eating is that shown by Messenger of Allah (PBUH). Here, too, is the affirmation of licking the fingers after taking meal, and not during it.

750. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) commanded the licking of fingers and the gleaning of the dish, saying, "You do not know in which portion the blessing lies.''
[Muslim].

Commentary: This Hadith underlines the wisdom behind licking the fingers and the vessel. The eater never knows whether a blessing underlies what has been eaten by him, or the particles sticking to his fingers and vessels contain it. Those particles, therefore, should not be wasted; they should be made part of food by being licked. They may be invested with a blessing and proved more useful for the eater's health and strength. Moreover, by this way he escapes disregarding the Bounty of Allah.

751. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When a morsel of any of you falls, he should pick it up and remove any of the dirt on it and then eat it, and should not leave it for Satan nor should wipe his hand with towel until he has licked his fingers, for he does not know in what portion of the food the blessing lies.''
[Muslim].

Commentary: This Hadith tells us to pick up a fallen morsel and eat it after cleaning the dirt that may have stuck on it. This marks the expression of humility overcoming Satan as well as getting the blessing. Present-day Muslims hardly care for this directive of Messenger of Allah (PBUH) because they think that this act will bring disgrace and dishonour upon them. To make matters worse, they throw away a large quantity of unconsumed food in street dumps and dunghills and drains. They even deem it necessary to leave over some food in plates and dishes, still less of licking them. What a pity, the Muslim community has gone far away from the teachings and excellent example of their Prophet (PBUH)!

752. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Satan appears at every thing done by you; he appears even at one's dinner. When a morsel of any of you falls, he should pick it up and remove any dirt on it, and then eat it. He should not leave it for Satan, nor should he wipe his hand with the towel until he has licked his fingers, for he does not know in what portion of the food the blessing lies.''
[Muslim].

Commentary: A Muslim should be perpetually on his guard against satanic insinuations, even at mealtime. He is required to recite the Name of Allah in the very beginning so that he may be immune from satanic participation and mischief. If a man avoids picking up the fallen morsel, he will be providing Satan and his minions a chance to share food with him. So we seek the Refuge of Allah from the condemned Satan and his associates.

753. Anas (May Allah be pleased with him) reported: Whenever Messenger of Allah (PBUH) ate food, he would lick his three fingers and say, "If anyone of you drops a morsel of food, he should remove any dirt that may have stuck on it and then eat it, and should not leave it for Satan.'' He (PBUH) also commanded us that we should glean the pot, saying, "You do not know in which part of your food the blessings lies.''
[Muslim].

754. Sa`id bin Al-Harith reported: I asked Jabir (May Allah be pleased with him) whether it was obligatory to make Wudu' for Salat (prayer) after eating cooked food. He said: "No, because in the lifetime of Messenger of Allah (PBUH), such food was rarely available. We had no handkerchiefs, so when we ate such food we would wipe our fingers against our palms, forearms or (the sole of our) feet, and would offer Salat without fresh Wudu' (for prayer).''
[Al-Bukhari].

Commentary: There are three points in this Hadith. First, the life of the Companions was simple, divested of all kinds of luxuries and comforts. They lived on whatever was available to them. Second, a man's ablution is not nullified by eating a cooked food. In the early days of Islam, this command was put into practice but later it was cancelled. Third, if a handkerchief, or a towel or water is not available, a man can (after taking a meal) clean his mouth and hands with his palms and wrists so that his clothes will not be smeared during Salat (prayer).


Merit of Sharing Food

Chapter 110
Merit of Sharing Food

755. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The food of two persons suffices for three persons, and the food of three persons suffices for four persons.''
[Al-Bukhari and Muslim].

756. Jabir bin `Abdullah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The food of one person suffices for two, the food of two persons suffices for four persons, and the food of four persons suffices for eight persons.''
[Muslim].

Commentary: This Hadith indicates that if a few persons share the same dinner-table, a small quantity of food will be enough for many persons. Moreover, this increases mutual love and fellow-feeling. A detailed light has already been shed on this topic in Chapter No. 62. See Hadith No. 565.


Etiquette of Drinking Water

Chapter 111
Etiquette of Drinking Water

757. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) used to breathe three times in the course of a drink (he used to drink in three gulps).
[Al-Bukhari and Muslim].

Commentary: Water should be drunk in three breaths, that is one should breathe three times outside the drinking vessel one is drinking from. This habit has a salutary impact on one's character and helps one avoid doing things in haste.

758. Ibn `Abbas (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Do not drink in one gulp like a camel, but in two or three (gulps). Mention the Name of Allah (i.e., say Bismillah) when you start drinking and praise Him (i.e., say Al-hamdu lillah) after you have finished (drinking).''
[At-Tirmidhi].

Commentary: This Hadith, too, prohibits us from drinking water in a single breath. It is preferable to say Bismillah every time we drink, and Al-hamdu lillah every time we stop drinking.

759. Abu Qatadah (May Allah be pleased with him) reported: The Prophet (PBUH) forbade breathing into the vessel while drinking.
[Al-Bukhari and Muslim].

Commentary: The Messenger of Allah (PBUH) prohibited us from breathing in the drinking vessel because the bad smell or spittle may flow into the drink. This is both loathsome as well as injurious to one's health.

760. Anas (May Allah be pleased with him) reported: Milk mixed with water was brought to Messenger of Allah (PBUH). On his right side was sitting a bedouin and on his left was sitting Abu Bakr (May Allah be pleased with him). He (PBUH) drank from it and handed the rest to the bedouin saying, "One who is on the right has preference, then again the one who is on the right.''
[Al-Bukhari and Muslim].

761. Sahl bin Sa`d (May Allah be pleased with him) reported: A drink was brought to Messenger of Allah (PBUH) and he drank (some) from it. On his right was a boy and on his left were some elderly people. He (PBUH) said to the boy, "Would you permit me to give rest of this drink to these on my left?'' The boy said: "O Messenger of Allah, I would certainly not give preference to anyone in anything that might come to me from you.'' So he (PBUH) handed over the rest of the drink to him.
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned earlier. Sheikh Al-Albani says: Some wrongly think that (in order to distribute something) in accordance with the Sunnah, a beginning should be made from an elderly person of the audience. Similarly, the view of Imam An-Nawawi is also not sound that the distribution should begin from his own person and then give it out to the gathering in the right order. Whereas the fact is, as mentioned in the Hadith, Messenger of Allah (PBUH) had demanded the drink for himself and, therefore, drunk it first of all. And if the situation is otherwise, the beginning should be made from the right side according to the Sunnah. Neither should the distributor give priority to himself nor to any elderly person from amongst the gathering. Rather, he should begin from the right side and then keep distributing in the serial order. Sheikh Al-Albani, therefore, says that Imam An-Nawawi is wrong to think that the distributor should begin after himself from the right side.


Undesirability of Drinking directly from the mouth of a Water-Skin

Chapter 112
Undesirability of Drinking directly from the mouth of a Water-Skin

762. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) forbade turning the water-skin upside down and drinking directly from its mouth.
[Al-Bukhari and Muslim].

Commentary: Messenger of Allah (PBUH) has forbidden us to drink water from the mouth of a water-skin or something similar to it because some harmful insect in the water-skin may flow into the stomach. So, instead of drinking direct from the mouth of the water-skin, it is better to pour it into a drinking vessel in order to shun any possible harm.

763. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) prohibited drinking directly out of the mouth of a water-skin.
[Al-Bukhari and Muslim].

Commentary: This Hadith and the preceding one are complementary to each other.

764. Umm Thabit Kabshah (May Allah be pleased with her), daughter of Thabit (May Allah be pleased with him) and the sister of Hassan bin Thabit, the Prophet's poet) reported: Messenger of Allah (PBUH) visited me and drank some water from a hanging water-skin while he was in a standing posture. So, I stood up and cut off the mouth (of that water-skin). An-Nawawi said that the reason why she did this was to keep to receive benediction that part of the water-skin which the lips of Messenger of Allah (PBUH) touched.
[At-Tirmidhi].

Commentary: The first two Ahadith forbid us from drinking water out of the mouth of a water-skin, whereas, once Messenger of Allah (PBUH) himself had done so. This shows that not to drink water by this way is also approved. However, if needed, it is allowable. For this reason Imam An-Nawawi clarified that to drink water out of the mouth of the water-skin is conditionally permissible and not forbidden. But to eschew it is desirable. Likewise, to receive benediction from the Prophet's left-overs is permissible as long as this does not take the form of worship and glorification.


Undesirability of blowing into the Vessel while Drinking

Chapter 113
Undesirability of blowing into the Vessel while Drinking

765. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) prohibited us blowing in the drinking water. A man said: "O Messenger of Allah! Sometimes I see some litter floating about on the surface. What should I do then?'' He (PBUH) replied, "Pour them out.'' Then the man said: "My thirst is not quenched with one draught.'' Messenger of Allah (PBUH) said, "Then put away the cup from your mouth (in between three gulps), and take breath.''
[At-Tirmidhi].

Commentary: If one sees straw or something like that in the water-vessel, he should not blow in the water. Messenger of Allah (PBUH) has forbidden it. Instead, some of the water or all the water should be poured out. Also, if his thirst is not quenched in a single breath, one should remove the vessel from his mouth. After taking breath, he should again drink water. To drink water in three breaths is preferable. However, in case of hot tea or milk, sipping is permissible, no matter if sips are in plenty.

766. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) prohibited us from breathing into the drinking vessel or blowing onto.
[At-Tirmidhi].


Permission to Drink while in a standing Posture

Chapter 114
Permission to Drink while in a standing Posture

767. Ibn `Abbas (May Allah be pleased with them) reported: I served Messenger of Allah (PBUH) Zamzam water to drink and he drank it while he was standing.
[Al-Bukhari and Muslim].

768. An-Nazzal bin Sabrah (May Allah be pleased with him) reported: `Ali bin Abu Talib (May Allah be pleased with him) arrived at Bab Ar-Rahbah (in Kufah) and drank water in a standing posture. Then he said: "I saw Messenger of Allah (PBUH) doing what you have seen me doing.''
[Al-Bukhari].

769. Ibn `Umar (May Allah be pleased with them) reported: During the lifetime of Messenger of Allah (PBUH) we would eat while walking and would drink while standing.
[At-Tirmidhi].

Commentary: The Companions would not habitually eat something while being on the move and drink water in a standing position. In fact, the Hadith simply tells us that these were some moments in their life when they did so. The Ahadith that follow show that drinking in a standing posture is deprecated.

770. `Amr bin Shu`aib on the authority of his father and grandfather reported: that they saw Messenger of Allah (PBUH) drink standing, and sitting.
[At-Tirmidhi].

The last three Ahadith point out the permissibility of eating and drinking while walking or standing or sitting, but drinking in the sitting position remains the best.

771. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) forbade us from drinking while standing. Qatadah reported: "We asked him: `What about eating?''' He said: "That is even worse, (or may be he said) more detestable.''

Another narration is: Messenger of Allah (PBUH) reprimanded us for drinking while standing.
[Muslim].

772. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "None of you should drink standing; and if any one forgets, he must vomit.''
[Muslim].

Commentary: In the preceding Ahadith, we are told that one can drink water even in a standing position, it is better to eat or drink while seated in order to be on the safe side. Otherwise, the truth of the matter is that one should be cautious enough to eat or drink seated. Doubtless, it is an approved practice. Nowadays, people have made it a habit to eat food at feasts in a standing posture. They argue it is convenient because the whole of the gathering is dealt out at the same time. Yet, they fail to keep in their view the overwhelming disadvantages of this convenience. First, it involves the emulation of western example without any benefit. Second, the Prophet (PBUH) has forbidden it. Third, the indiscipline it spawns hardly befits the social behaviour of a dignified and civilized nation. Fourth, a long wait, tedious and boring normally features feasts and wedding parties. Fifth, in order to make it agreeable and to do away with the boredom of participants, either film songs or musical notes are played on record-players, or jesters and buffoons are brought in to amuse and entertain them. This is all satanic work, forbidden and unlawful, having no place in Islam


Excellence of Cupbearer drinking Last

Chapter 115
Excellence of Cupbearer drinking Last

773. Abu Qatadah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who serves others with drinking water should be the last to drink himself.''
[At-Tirmidhi].

Commentary: Referring to this Hadith, Imam An-Nawawi stresses the manner of serving food or drink and says that the distributor should have his share in the end.


Permissibility of drinking water from clean Vessels of all types except Gold and Silver ones

Chapter 116
Permissibility of drinking water from clean Vessels of all types except Gold and Silver ones

774. Anas bin Malik (May Allah be pleased with him) reported: Once the time for As-Salat (the prayer) approached. Those whose houses were near, went to their houses to perform Wudu' while some of the people remained with Messenger of Allah (PBUH). A stone (containing some water) bowl was brought for him. It was too small for him to spread his hand over it. He performed his Wudu' and it (the water) sufficed for all the others also. Anas was asked: "How many of you were present there?'' He said: "Eighty or more.''
[Al-Bukhari and Muslim].

Another narration in Muslim is: The Prophet (PBUH) called for a vessel containing water. A wide shallow vessel with a little water in it was brought for him. He put his fingers in it. Anas says: "I kept looking at the water pouring from between his fingers. I estimated that the number of people who made their Wudu' with it was from seventy to eighty.''

Commentary: This Hadith mentions a miracle of Messenger of Allah (PBUH) and also provides for the use of a stoneware.

775. `Abdullah bin Zaid (May Allah be pleased with him) reported: The Prophet (PBUH) visited us and we brought water for him in a brass vessel for his ablution and he performed ablution.
[Al-Bukhari].

Commentary: This Hadith tells us that brassware can be used for performing ablution as well as for other purposes.

776. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) visited the house of a man of the Ansar with one of his Companions and said to him, "If you have some water in the water-skin left over from last night, give it to us for drinking; otherwise, we shall drink from some stream directly.''
[Al-Bukhari].

Commentary: With reference to this Hadith, Imam An-Nawawi says that apart from drinking water from a vessel, one can also drink at a cistern or stream.

777. Hudhaifah (May Allah be pleased with him) reported: The Prophet (PBUH) prohibited us from wearing brocade or silk and drinking out of gold or silver vessels and said, "These are meant for them (disbelievers) in this world and for you in the Hereafter.''
[Al-Bukhari and Muslim].

Commentary: Silk clothes are forbidden to men but allowed to women. Yet, both sexes are forbidden to use utensils made of silver and gold. However, the orthodox `Ulama' say that women can use ornaments of silver and gold and that, it is advisable not to use them because many vices stem from their use and display.

778. Umm Salamah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said, "He who drinks from the vessel of silver kindles the Fire (of Hell) in his belly.''
[Al-Bukhari and Muslim].

A narration in Muslim is: Messenger of Allah (PBUH) said, "Surely, he who eats or drinks in gold and silver vessels fills his belly with Hell-fire.''

Commentary: To use utensils of silver and gold involves extravagance. Moreover, it is a sign of pride and ostentatious lifestyle. Allah detests them both. On this count they are major sins, involving the danger of severe chastisement in Hell-fire.


Book Three: The Book of Dress

  • Chapter 117 : Excellence of wearing white clothes and the permissibility of wearing red, green, yellow and black clothes made from Cotton, Linen but not Silk
  • Chapter 118 : Excellence of Qamees
  • Chapter 119 : Description of the length of Qamees and the Sleeves, the end of the Turban, the Prohibition of wearing long Garments out of Pride and the undesirability of wearing them without Pride
  • Chapter 120 : Excellence of giving up Elegant Clothes for Humility
  • Chapter 121 : Excellence of Adopting Moderation in Dress
  • Chapter 122 : Prohibition of wearing Silk for men and its permissibility for Women
  • Chapter 123 : Lawfulness to wear Silk in case one is suffering from an Itch
  • Chapter 124 : Prohibition of using the skin of the Leopard
  • Chapter 125 : Supplication at the time of wearing new Dress or Shoes
  • Chapter 126 : Excellence of Starting from the right side first while wearing a Dress (or a pair of Shoes)


Excellence of wearing white clothes and the permissibility of wearing red, green, yellow and black clothes made from Cotton, Linen but not Silk

Chapter 117
Excellence of wearing white clothes and the permissibility of wearing red, green, yellow and black clothes made from Cotton, Linen but not Silk

Allah, the Exalted, says:

"O Children of ¢dam! We have bestowed raiment upon you to cover yourselves (screen your private parts) and as an adornment, and the raiment of righteousness, that is better.'' (7:26)

"And (Allah) has made for you garments to protect you from the heat (and cold), and coats of mail to protect you from your (mutual) violence.'' (16:81)

779. Ibn `Abbas (May Allah be pleased with them) reported: I heard Messenger of Allah (PBUH) saying, "Put on white clothes because they are the best; and use them for shrouding your dead.''
[At-Tirmidhi and Abu Dawud].

780. Samurah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, 'Wear white clothes because they are the purest and they are closest to modesty; and shroud the dead in it.''
[An-Nasa'i and Al-Hakim].

Commentary: Both these Ahadith tell us that white clothes are fine and likeable and are especially recommended on Fridays and on all other occasions except on `Eid days where new clothes, if any, are recommended. The purity and beauty of this colour befits the dignity and honour of man.

781. Bara' (May Allah be pleased with him) reported: Messenger of Allah (PBUH) was of medium stature. I saw him wearing a red mantle. I have never seen anything more graceful than that.
[Al-Bukhari and Muslim].

Commentary: On the basis of this Hadith, some argue that red dress is also allowed to men. Imam An-Nawawi seems to hold the same view. However, many `Ulama' believe that the dress of Messenger of Allah (PBUH) was not all red but had red stripes. They, therefore, maintain that the red clothes which women wear are not permissible to men. Some `Ulama' think that a ruling on this issue will be on condition of space and time. If at some place disbelievers or women are fond of this colour, it will be banned for Muslim men because of its relevance to disbelief and womanishness. Yet, it will be allowed to Muslim men in a contrary situation. Opinions also exist that the indoor wear of red clothes is permissible to men but forbidden in public. To sum up, the red-coloured dress is not itself a taboo with regard to men. A ruling on it will be conditional in accordance with the situation. For example, in the Eastern society the red-coloured dress is usually worn by women and is peculiar to brides on the occasion of wedding. Men are, therefore, banned to wear it. Allah Alone has the true knowledge.

782. Abu Juhaifah Wahb bin `Abdullah (May Allah be pleased with him) reported: I saw the Prophet (PBUH) by Al-Abtah valley in Makkah, in a red tent made from tanned skin. Bilal brought him ablution water. Then Messenger of Allah (PBUH) came out wearing a red mantle; and I can still remember looking at whiteness of his shanks. So he made his ablution, and Bilal (PBUH) pronounced the call for prayer (Adhan). I kept following the movement of his (Bilal's) face to the right and to the left when he recited: `Come to the prayer; come to the success.' Then a spear was fixed (as a Sutrah) in front of Messenger of Allah (PBUH) who then stepped forward and led the prayer. Dogs and donkeys passed in front of him (beyond the spear) and no one prevented them from doing so.
[Al-Bukhari and Muslim].

Commentary: `Al-Abtah' is the name of a place which is also called the Muhassab valley. Lexically `Al-Abtah' means a sloping ground. Since it was the passage of rainy water owing to its downward slope, it came to be known by this name. Here the Prophet (PBUH) encamped in a tent.

This Hadith provides for wearing red-coloured clothes as mentioned in detail in the preceding Hadith. Second, it points out an issue concerning the ritual prayer. The worshipper should place something before him as a symbol of obstruction (Sutra) so that somebody who goes past him may not divert his attention. Yet, there is no harm if the passer is an animal.

783. Abu Rimthah Rifa`ah At-Taimi (May Allah be pleased with him) reported: I saw Messenger of Allah (PBUH) wearing two green garments.
[Abu Dawud and At-Tirmidhi].

Commentary: Here we see a provision for wearing green-coloured clothes.

784. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) entered Makkah on the day of its conquest and he was wearing a black turban.
[Muslim].

785. Abu Sa`id `Amr bin Huraith (May Allah be pleased with him) reported: As if I am seeing Messenger of Allah (PBUH) wearing a black turban and both ends of it are falling over his shoulders.
[Muslim].

Another narration is: Messenger of Allah (PBUH) was delivering a Khutbah wearing a black turban.

Commentary: We conclude from this Hadith that one can also put on black-coloured dress, turban and covering. Muslim scholars have said that it is a desirable act Mustahab to wear a black turban after defeating the enemy.

786. `Aishah (May Allah be pleased with her) reported: The body of Messenger of Allah (PBUH) was shrouded in three white Yemeni cotton garments, among which was neither a gown nor a turban.
[Al-Bukhari and Muslim].

Commentary: The shroud of a dead body consists of three simple pieces of cloth to the exclusion of a turban, shirt and Izar. It is better for the shroud to be white.

787. `Aishah (May Allah be pleased with her) reported: One morning Messenger of Allah (PBUH) went out wearing a black blanket made of camel's or sheep's black hair with patterns of camels' bags upon it.
[Muslim].

Commentary: This Hadith tells us that one can wear a black woollen cloth with the woven image of an inanimate object.

788. Al-Mughirah bin Shu`bah (May Allah be pleased with him) reported: I was with Messenger of Allah (PBUH) in a journey one night, and he asked me, "Do you have any water with you?'' I said, "Yes.'' So he dismounted from his riding camel and walked away (to answer the call of nature) until he disappeared in the darkness. When he returned, I poured out some water from a vessel and he washed his face. He was wearing a long woollen cloak and could not take out his forearms from his sleeves, so he brought them out from below the cloak and then washed them, and then passed his (wet) hands over his head. I stretched out my hand to take off his Khuff (leather socks), but he said, "Leave them. I put them on after performing Wudu','' and he passed his (wet) hands over them.
[Al-Bukhari and Muslim].

Another narration is: Messenger of Allah (PBUH) was wearing a Syrian cloak with tight sleeves.

Another narration is: This incident took place during the battle of Tabuk.

Commentary: Here, too, we have justification for wearing woollen dress. In order to answer the call of nature, one is supposed to get out of people's sight. Instead of washing the feet while performing Wudu', one may simply pass wet hands over the socks or stockings if these have been worn after the performance of ablution. A non-travelling person is allowed this facility for twenty-four hours while in the case of a traveller, this period is extended to three days. However, in case of sexual impurity one must take full bath.


Excellence of Qamees

Chapter 118
Excellence of Qamees

789. Umm Salamah (May Allah be pleased with her) reported: Out of all garments Messenger of Allah (PBUH) liked Qamees the best.
[At-Tirmidhi and Abu Dawud].

Commentary: Qamees is a piece of clothing with two sleeves, generally made of sewn cotton and worn under the rest of the clothes. In the lifetime of the Prophet (PBUH) the Arabs would commonly use two simple sheets of cloth as dress, one covering the lower part of body and one wrapping its upper part. Qamees was also in vogue but very few people used it. No doubt it covers the body adequately and is also comparatively convenient. So, the Prophet (PBUH) liked it most.


Description of the length of Qamees and the Sleeves, the end of the Turban, the Prohibition of wearing long Garments out of Pride and the undesirability of wearing them without Pride

Chapter 119
Description of the length of Qamees and the Sleeves, the end of the Turban, the Prohibition of wearing long Garments out of Pride and the undesirability of wearing them without Pride

790. Asma` bint Yazid (May Allah be pleased with her) reported: The Qamees sleeves of Messenger of Allah (PBUH) reached down to his wrists.
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith simply tells us that Messenger of Allah (PBUH) used to wear a Qamees with long sleeves (up to the wrist); but in the case of all the other clothes, apart from the Qamees, the sleeves should not go beyond the finger tips.

791. Ibn `Umar (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Whoever allows his lower garment to drag out of vanity will find that Allah will not look at him on the Day of Resurrection.'' On this Abu Bakr (May Allah be pleased with him) submitted: "O Messenger of Allah! My lower garment keeps sliding down though I take care to pull it and wrap it.'' Messenger of Allah (PBUH) said, "You are not of those who do it out of vanity.''
[Al-Bukhari].

Commentary: Messenger of Allah (PBUH) has given a severe warning to those who intentionally wear a dress which is dragging along the ground because this is a sign of arrogance. Yet, if a person's garment unintentionally slips downward he will not be put to accountability.

792. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, Allah will not look at him who trails his lower garment out of pride.''
[Al-Bukhari and Muslim].

Commentary: A disregard of Allah's Favours and gifts means ungratefulness which is essentially manifested in a haughty attitude. It is also a sign of arrogance that one wears a dress with the hem trailing on the ground.

793. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "What is below the ankles of a lower garment is condemned to the Fire (Hell).''
[Al-Bukhari].

Commentary: The apparent sense of the Hadith words is that the part of the dress hanging down below the ankles will be put into Hell-fire. Yet, if this is the fate of the particular piece of cloth the wearer will surely go to Hell. When Nafi` (May Allah be pleased with him) was asked about it he said, "Yes, but what sins have the clothes committed?''

794. Abu Dharr (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "There are three to whom Allah will neither speak on the Day of Resurrection nor will look at them nor purify them (i.e., of their sins), and they will be severely tormented.'' When he repeated this (statement) thrice, Abu Dharr (May Allah be pleased with him) said: "They are doomed and destroyed! (But) who are they, O Messenger of Allah (PBUH)?'' He said, "One whose lower garment trails, one who boasts of kindness shown to another; and one who promotes sale of his business by taking false oaths.''
[Muslim].

Commentary: This Hadith sheds light on three major sins which, unfortunately, prevail in Muslim societies. May Allah amend the lapses of Muslims' behaviour!

795. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said, "On the Day of Resurrection, Allah will not look at one who trails his lower garment, Qamees or turban arrogantly.''
[Abu Dawud and An-Nasa'i].

Commentary: This Hadith tells us if trousers and pajamas, out of pride etc., hang loose below the ankles, the wearer will be committing a grave blunder. The excessive hang of shirt or turban out of pride is also a sign of arrogance and involves the wearer in a major sin. Wearing long garments without the intention of pride is disliked.

796. Abu Juraiy Jabir bin Sulaim (May Allah be pleased with him) reported: I noticed a man whose opinion was followed by every body, and no one acted contrary to what he said. I asked who he was, and I was informed that he was Messenger of Allah (PBUH). I said to him twice: "Alaikas-salam ya Rasul-Allah (may Allah render you safe).'' He said, "Do not say: `Alaikas-salamu.' This is the salutation to the dead (in Jahiliyyah times). Say, instead: `As-salamu `alaika (may Allah render you safe).''' I asked: "Are you Messenger of Allah?'' He replied, "(Yes) I am the Messenger of Allah, Who will remove your affliction when you are in trouble and call to Him, Who will cause food to grow for you when you are famine-stricken and call to Him, and Who will restore to you your lost riding beast in the desert when you call upon Him.'' I said to him: "Give me instructions (to act upon).'' He ((PBUH) said, "Do not abuse anyone.'' (Since then I have never abused anyone, neither a freeman, nor a slave, nor a camel, nor a sheep). He (PBUH) continued, "Do not hold in contempt even an insignificant act of goodness, because even talking to your brother with a cheerful countenance is an act of goodness. Hold up your lower garment half way to the leg, and at least above the ankles; for trailing it is arrogance, and Allah dislikes pride. And if a man imputes to you of bad things he knows you possess, do not impute to him bad things that you know he has for he will assume the evil consequences of his abuse.''
[Abu Dawud and At-Tirmidhi].

Commentary: Herein, we are informed that the Companions of Messenger of Allah (PBUH) would lend a ready ear to the Prophet's advice and put it into practice resolutely. Besides, in Islam the greeting of peace or Salam is alike to the living as well as the dead.

The Hadith also tells us about the desirable length of Izar or lower garment. Shari`ah allows it up to the ankles, but if it goes below, the wearer will be involved in a serious transgression incurring Hell-fire as mentioned earlier. Second, any good act, however small it may be, must not be underestimated and ignored. At no cost should it be given up. Third, nobody should be reproached for his fault or mistake, that is, he should not be put to humiliation in public for it. However, in private conversation he may be advised to improve his behaviour and desist from repeating his mistake.

797. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said to a man who was performing Salat while his lower garment was trailing, "Go and perform your Wudu' again.'' That man went and came back having performed it. The Messenger of Allah (PBUH) said (again), "Go and perform your Wudu'.'' Someone present said to Messenger of Allah (PBUH): "O Messenger of Allah! You ask him to perform his Wudu' and then you kept silent (without saying the reason for it).'' He (PBUH) said, "He performed Salat while his lower garment was below his ankels. Allah does not accept the Salat of a man who trails his lower garment.''
[Abu Dawud].

798. Qais bin Bishr At-Taghlibi reported that his father, who attended the company of `Abud-Darda' (May Allah be pleased with him) told him: There was a man in Damascus who was a Companion of the Messenger of Allah (PBUH). He was called Ibn Al-Hanzaliyyah. He was a lonesome person and would rarely spend some time in the company of people. He would spend most of his time in performing Salat and when he finished, he would engage himself in Tasbih (Subhan-Allah) and Takbir (Allahu Akbar), till he would go home. He passed by us one day when we were sitting with Abud-Darda' (May Allah be pleased with him). The latter said to him: "Tell us something which will benefit for us and will not harm you.'' He said: "Messenger of Allah (PBUH) sent a detachment. When they returned, one of them came to the assemblage in which Messenger of Allah (PBUH) was present and said to his neighbour during the conversation: `I wish you had seen us when we encountered the enemy. So-and-so (a believer) took up his spear, struck and said: Take this from me and I am the Ghifari boy. Now what do you think of this?' The neighbour said: `I think that he lost his reward because of boasting.' He said: `I see no harm in it.' They began to exchange arguments till Messenger of Allah (PBUH) heard them and said, `Subhan-Allah (Allah is free from every imperfection). He would be rewarded (in the Hereafter) and praised (in this world)'. I noticed that Abud-Darda' (May Allah be pleased with him) felt a great pleasure at this remark and, raising his head began to repeat: "Have you heard Messenger of Allah (PBUH) say this!'' Ibn Al-Hanzaliyyah (May Allah be pleased with him) continued responding till I asked Abud-Darda' (May Allah be pleased with him) not to annoy him.

Ibn Al-Hanzaliyyah (May Allah be pleased with him) happened to pass by us another day and Abud-Darda' said to him: "Tell us something which will benefit us and will not harm you.'' He said: "The Messenger of Allah (PBUH) told us, `He who spends to purchase a horse (for Jihad) is like one who extends his hand for spending out of charity without withholding it.'''

He passed by us another day and Abud-Darda' (May Allah be pleased with him) said to him: "Tell us something which might benefit us, and will not harm you.'' He said: "The Messenger of Allah (PBUH) once said, `Khuraim Al-Usaidi is an excellent man were it not of his long hair and his lower garment which is hanging down.' When Khuraim heard about what the Prophet had said about him, he trimmed his long hair up to his ears with a knife and raised his lower garment half way on his shanks.''

On another occasion he passed by us and Abud-Darda' (May Allah be pleased with him) said to him: "Tell us something that will benefit us and will not harm you.'' He said that he heard Messenger of Allah (PBUH) say, while coming back from an expedition: "You are returning to your brothers, so set your saddles and clothes in order so that you look tidy and graceful. Allah hates untidiness.''
[Abu Dawud].

Commentary: This Hadith talks about six points. First, a war cry expressive of one's chivalrous deeds and designed to intimidate the enemy is permissible. Second, it is not an impeachable act and will be rewarded by Allah if it is done with a good intention. Third, hair should be grown either up to the earlobes or up to the neck-end as was the Prophet's practice. The Prophet (PBUH) disapproved the long hair upon the shoulders. Fourth, on return from a journey, a man is advised to clean up his appearance and dust-covered clothes; due to the fatigue and dust of journey, he may appear untidy and out of shape. With his ruffled hair and run-down face, whether intentional or unintentional, he will perhaps give a depressive impression to his wife and children and other family members to the displeasure of Allah. Fifth, we may sympathetically allude to the minor shortcomings of a person in his absence for the sake of his moral uplifting. This will not be considered as backbiting. Messenger of Allah (PBUH) talked about Khuraim Al-Usaidi (May Allah be pleased with him) in the same spirit. Sixth, indecency which means something ugly and disgraceful is taken here in an untidy and dishevelled sense which is against aesthetic principles.

799. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "The lower garment of a believer should be half way below the knees. He is guilty of no sin if they are up to the ankles. That which is below the ankles is in the Fire (of Hell). Allah will not look at one who allows his lower garment to trail out of vanity.
[Abu Dawud].

Commentary: This Hadith says that a garment like trousers, pajamas, etc., should, properly speaking, go down up to the middle of the shanks. However, it is permissible to lower it up to the ankles which should remain uncovered. This commandment is for men alone. On the contrary, women are required to cover not only their ankles but also their feet, particularly when they go out.

800. Ibn `Umar (May Allah be pleased with them) reported: My lower garment was trailing as I passed by Messenger of Allah (PBUH) so he said, "Raise your lower garment, Abdullah.'' I lifted it up and he told me to raise it higher. I complied with his orders and as I was still trying to find the best place (for it), one of the people asked where it should reach and he (PBUH) replied, "Half way down the knees.''
[Muslim].

801. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "On the Day of Resurrection, Allah will not look at the one who trails his lower garment out of arrogance.'' Umm Salamah (May Allah be pleased with her) asked: "What should women do with the hem of their clothes?'' He (PBUH) said, "They might lower them a hand's span.'' She said: "But their feet would still remain exposed.'' He said, "Let them lower those equal to arm's length but not more than that.''
[Abu Dawud and At-Tirmidhi].

Commentary: Herein, women are commanded to cover themselves completely up to an arm's length from the hem of their clothes in order to cover the sole of their feet with their wraps and lower-body garments.


Excellence of giving up Elegant Clothes for Humility

Chapter 120
Excellence of giving up Elegant Clothes for Humility

802. Mu`adh bin Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whoever gives up wearing elegant and expensive garments out of humbleness, when he can do so, Allah will call him on the Day of Resurrection and before all the creations, He will give him the choice to wear whichever garment of Iman he would like to wear.''
[At-Tirmidhi].

Commentary: To adopt humility and not to assert superiority over others, according to this Hadith, is an excellent act with Allah. `The clothes of Iman' imply those special clothings of Jannah that Allah has prepared for sincere believers only.


Excellence of Adopting Moderation in Dress

Chapter 121
Excellence of Adopting Moderation in Dress

803. `Amr bin Shu`aib on the authority of his father and grandfather reported: Messenger of Allah (PBUH) said, "Allah loves to see the sign of His Bounties on his slave.''
[At-Tirmidhi].

Commentary: A simple dress is commendable if one wears it as a gesture of humility wining Allah's Pleasure. Yet, to zealously pursue the goal of goodness, to extend a helping hand to the indigent and the needy, to behave favourably towards one's relatives and to wear a fine dress as a manifestation of Allah's Favours are equally good acts of high merit. A fine dress is not impeachable in itself but it becomes so, if worn with an air of arrogance and self-importance. On the other hand, an expression of Divine bounty makes it praiseworthy. In other words, it is the intention which makes an act good or bad. Alongside the practice of the example of Messenger of Allah (PBUH), the sincerity of action and making right intention, therefore, become indispensable.


Prohibition of wearing Silk for men and its permissibility for Women

Chapter 122
Prohibition of wearing Silk for men and its permissibility for Women

804. `Umar bin Al-Khattab (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Do not wear silk (clothes). For whoever wears (them) in this life will be deprived of them in the Hereafter.''
[Al-Bukhari and Muslim].

Commentary: It is not women but men who have been forbidden to wear silk dress. It is banned for men due to its aspect of adornment and beautification which is peculiar to women alone. The silk dress is not befitting to men because it affects their typical characteristics such as bravery, strength and fearlessness. Second, it betrays arrogance and haughtiness which is condemnable by all norms of morality. Third, it has relevance to disbelievers and polytheists known for their love for worldly possessions. Fourth, its use is against that austerity which Islam aims to develop in a Muslim's life. And this is borne out by the saying of Messenger of Allah (PBUH): "Simplicity is part of Faith.''

805. `Umar bin Al-Khattab (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying, "Silk (clothes) are worn only by him who has no share in the Hereafter.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that men will fall into a serious error if they wear dress made from silk. And if they do not sincerely repent for it, they will undoubtedly be punished in Hell-fire.

806. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who wears silk clothes in this life shall not wear them in the Hereafter.''
[Al-Bukhari and Muslim].

807. `Ali (May Allah be pleased with him) reported: I saw Messenger of Allah (PBUH) holding a piece of gold in his left hand and a silk (cloth) in his right hand. Then he said, "These two are forbidden for the males of my Ummah.''
[Abu Dawud].

808. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Wearing of silk and gold has been made unlawful for males and lawful for the females of my Ummah.''
[At-Tirmidhi].

Commentary: Both the above mentioned Ahadith indicate that the use of silk and gold is allowed to women. But Divine sanction should not be so over-stretched as to make the ornaments of gold part and parcel of marriage. Yet, unfortunately, this sad situation exists in Muslim societies, making resourceless people feel extremely ill. In fact, at need, if resources permit, women are free to use gold but without making it as an essential ingredient of marriage. May Allah guide Muslims!

809. Hudhaifah (May Allah be pleased with him) reported: The Prophet (PBUH) prohibited us from eating or drinking in gold or silver utensils and from wearing silk and brocade, or sitting on (anything made from) them.
[Al-Bukhari].

Commentary: There are many kinds of silk. But the real silk is that which is naturally spun by the silkworm. However, the artificially manufactured silk is also available nowadays. Men are not under ban to use it. But there are certain varieties of such cloth which are used only by women. These are forbidden to men. Besides, they are disallowed to sit on a silk cloth. Similarly, quilts, mattresses and pillows should not be made from it because both men and women use them.


Lawfulness to wear Silk in case one is suffering from an Itch

Chapter 123
Lawfulness to wear Silk in case one is suffering from an Itch

810. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) permitted Zubair and `Abdur-Rahman bin `Auf (May Allah be pleased with them) to wear silk because they were suffering from an itch.
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that, if needed, even men can wear clothes made from silk. For example, it may be suggested in case of a skin disease like itch. A man may also be allowed to wear a silk dress in order to escape extremely cold or hot weather provided he has no other clothes.


Prohibition of using the skin of the Leopard

Chapter 124
Prohibition of using the skin of the Leopard

811. Mu`awiyah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Do not ride on saddles made from silk or leopard's skin.''
[Abu Dawud].

Commentary: This Hadith prohibits Muslim men from using fur and the leopard's hide. In fact the non-Muslim contemporaries of the Prophet (PBUH) used to wear them. Since, they had an epicurean lifestyle, unconcerned about the Hereafter, the Muslims were dissuaded from emulating their example. The motive behind the ban by Messenger of Allah (PBUH) was to help believers in acquiring a sense of Taqwa (consciousness of Allah/fear of Allah). As for pure silk, Muslim men are totally disallowed to use it. Even the saddle-cloth must not be of silk. The same rule applies to any usable thing made from the leopard's hide because it is expressive of arrogance and also bears resemblance to the non-Muslim way of life.

812. Abul-Malih on the authority of his father reported: Messenger of Allah (PBUH) prohibited the use of the skins of wild animals.
[Abu Dawud, At-Tirmidhi and An-Nasa'i].

Another narration in At-Tirmidhi is: Messenger of Allah (PBUH) forbade the use of the skins of wild animals in making Firash (i.e., something to sit on or lie down on, such as cushions, pillows, covers, spreads, saddles, etc.).

Commentary: The Messenger of Allah (PBUH) has forbidden the use of hide of wild beasts. Explaining the ban by Messenger of Allah (PBUH), some say that even the tanning process cannot wipe out hair from a beast's hide. As a result it retains some impurity. Others think that the prohibitive order is related only to the untanned hides and is inapplicable to the tanned ones. This opinion also goes since such hides are used by extravagant and arrogant people, and its use by Muslims may hold them analogous to the former. But Imam Ash-Shaukani is of the view that the hides of beasts, whether tanned or untanned, must not be used. We also have in view the saying of Messenger of Allah (PBUH): "Tanning purifies every hide.'' Yet, in the light of the current Hadith it will be considered as specific. The hides of beasts will remain unclean and unusable in all circumstances.


Supplication at the time of wearing new Dress or Shoes

Chapter 125
Supplication at the time of wearing new Dress or Shoes

813. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: When Messenger of Allah (PBUH) wore a new garment, he would name it. For instance, a turban or shirt or cloak and would supplicate: "Allahumma lakal-hamdu, Anta kasautanihi, as`aluka khairahu wa khaira ma suni`a lahu, wa a`udhu bika min sharrihi wa sharri ma suni`a lahu (O Allah, all the praise is for You that You have given it to me to put on. I ask You its goodness and the goodness of the purpose for which it was made, and I seek Your Protection from its evil and the evil of the purpose for which it was made).''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith tells us that we should recite the invocation taught by Messenger of Allah (PBUH) on wearing a new dress. Imam An-Nawawi argues that on wearing a new pair of shoes or something like that one should also recite this prayer.


Excellence of Starting from the right side first while wearing a Dress (or a pair of Shoes)

Chapter 126
Excellence of Starting from the right side first while wearing a Dress (or a pair of Shoes)

(Ahadith concerning this chapter has already been narrated. See chapter 99)


Book Four: The Book of the Etiquette of Sleeping, Lying and Sitting, etc.

  • Chapter 127 : What is to be said at the time of Sleeping
  • Chapter 128 : Manners of Lying down on one's back and placing one leg upon the Other
  • Chapter 129 : Etiquette of Attending company and sitting with Companions
  • Chapter 130 : Visions in Dream and matters relating to them


What is to be said at the time of Sleeping

Chapter 127
What is to be said at the time of Sleeping

814. Al-Bara' bin `Azib (May Allah be pleased with them) reported: Whenever Messenger of Allah (PBUH) went to bed, he would lie down on his right side and recite: "Allahumma aslamtu nafsi ilaika, wa wajjahtu wajhi ilaika, wa fawwadtu amri ilaika, wa 'alja'tu zahri ilaika, raghbatan wa rahbatan ilaika, la malja'a wa la manja illa ilaika. Amantu bikitabikal-ladhi anzalta, wa nabiyyikal-ladhi arsalta [O Allah! I have submitted myself to You, I have turned my face to You, committed my affairs to You, and depend on You for protection out of desire for You and out of fear of You (expecting Your reward and fearing Your punishment). There is no refuge and no place of safety from You but with You. I believed in the Book You have revealed, and in the Prophet You have sent (i.e., Muhammad (PBUH)).]''
[Al-Bukhari].

Commentary: Before going to bed, a believer revives his commitment to Faith, Islam and Allah by reciting this prayer of Messenger of Allah (PBUH). Through this practice, every night he is able to remember Allah and His Commandments amidst the activities of the day time.

815. Al-Bara' bin `Azib (May Allah be pleased with them) reported: Messenger of Allah (PBUH) directed me thus: "Whenever you go to bed, perform Wudu' as you do for Salat then (before sleeping) recite: `O Allah! I have submitted myself to You, I have turned myself to You, committed my affairs to You and sought Your refuge for protection out of desire for You and fear of You (expecting Your reward and fearing Your punishment). There is no refuge and no place of safety from You but with You. I believe in the Book You have revealed and in the Prophet (PBUH) You have sent.''' Messenger of Allah (PBUH) added: "If anyone recites these words and dies during the night, he will die on the true Deen, and if he remains alive till the morning, he will obtain good. And make this supplication your last words (before sleeping).''
[Al-Bukhari and Muslim].

816. `Aishah (May Allah be pleased with her) reported: The Prophet (PBUH) used to offer eleven Rak`ah of optional Salat (prayers) in the latter part of night. When it was about dawn, he would offer two short Rak`ah and then would lie down on his right side till the Mu'adhdhin (one who calls for prayer) would come to inform him that the congregation had gathered (for prayer).
[Al-Bukhari and Muslim].

Commentary: This Hadith throws light on the Prophet's night prayers (Tahajjud), that is, it comprised thirteen Rak`ah including three Rak`ah of Witr. It is also reported in Al-Bukhari on the authority of `Aishah (May Allah be pleased with him) that Messenger of Allah (PBUH) would always perform thirteen Rak`ah in the Tahajjud prayer. This Hadith further tells us that after his midnight prayer, the Prophet (PBUH) would perform two Rak`ah of Sunnah (i.e., after the Adhan of Fajr prayer) and then lie down on his right side. This practice of Messenger of Allah (PBUH) is an established fact.

817. Hudhaifah (May Allah be pleased with him) reported: Whenever the Prophet (PBUH) lay down for sleep at night, he would place his (right) hand under his (right) cheek and supplicate: "Bismika Allahumma amutu wa ahya [O Allah, with Your Name will I die and live (wake up)].'' And when he woke up, he would supplicate: "Al-hamdu lillahil-ladhi ahyana ba`da ma amatana, wa ilaihin-nushur (All praise is due to Allah, Who has brought us back to life after He has caused us to die, and to Him is the return).''
[Al-Bukhari].

Commentary: In this prayer of Messenger of Allah (PBUH) the state of sleep is associated with death, while the state of being awake is associated with life. Furthermore, it conjures up the vision of Doomsday. However, to recite these prayers prior to going to sleep and on getting up was the practice of Messenger of Allah (PBUH).

818. Ya`ish bin Tikhfah Al-Ghifari (May Allah be pleased with him) reported: My father said: I was lying down on my belly in the mosque when someone shook me with his foot and said, "Lying down this way is disapproved by Allah.'' I looked up and saw that it was Messenger of Allah (PBUH).
[Abu Dawud].

Commentary: To sleep in prone position is extremely repugnant and Messenger of Allah (PBUH) has forbidden it.

819. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whoever sits in a place where he does not remember Allah (SWT), he will suffer loss and incur displeasure of Allah; and whoever lies down (to sleep) in a place where he does not remember Allah, he will suffer sorrow and incur displeasure of Allah.''
[Abu Dawud].

Commentary: In the light of this Hadith, remembrance of Allah is commendable everywhere. Indifference to it doubtless incurs Divine wrath.


Manners of Lying down on one's back and placing one leg upon the Other

Chapter 128
Manners of Lying down on one's back and placing one leg upon the Other

820. `Abdullah bin Zaid (May Allah be pleased with them) reported: I saw Messenger of Allah (PBUH) lying down on his back in the mosque, placing one leg on the other.
[Al-Bukhari and Muslim].

821. Jabir bin Samurah (May Allah be pleased with him) reported: After the Fajr (dawn) prayer the Prophet (PBUH) used to sit crossed legged in the same place in which he had prayed till the sun shone brightly.
[Abu Dawud].

Commentary: This Hadith tells us that it is commendable to stay in the mosque after offering Fajr prayer with the congregation until sunrise. It also commends sitting cross-legged.

822. Ibn `Umar (May Allah be pleased with them) reported: I saw Messenger of Allah (PBUH) sitting in the compound of the Holy Ka`bah, with the thighs against the stomach and arms around his legs.
[Al-Bukhari].

823. Qailah bint Makhramah (May Allah be pleased with her) reported: I saw the Prophet (PBUH) seated with his arms enfolding his legs; and when I saw him in such a state of humble guise I trembled with fear due to the awe (he showed in that posture).
[At-Tirmidhi].

824. Ash-Sharid bin Suwaid (May Allah be pleased with him) reported: Messenger of Allah (PBUH) passed by me when I was sitting with my left hand behind my back and leaning on my palm. On seeing me in this posture he said, "Do you sit like those upon whom the Wrath of Allah has descended?''
[Abu Dawud].

Commentary: The Jews and Christians are the people upon whom came the Wrath of Allah. Muslims have been stopped from copying their example. But unfortunately they now take a pride in imitating them in every matter and think it necessary for worldly progress.


Etiquette of Attending company and sitting with Companions

Chapter 129
Etiquette of Attending company and sitting with Companions

825. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) said, "Do not ask someone to give up his seat in order to take it, but make accommodation wide and sit at ease.'' It was Ibn `Umar's habit that if a person left his seat for him, he would not take it.
[Al-Bukhari and Muslim].

Commentary: Herein, we are told that the space of meeting should be wide enough to accommodate every participant. None should feel the space problem. Good manners disallow a newcomer to get a seat vacated for himself by force, no matter if the occupant is an inferior. Yet, there is nothing undesirable if the latter willingly vacates the seat for a superior. Ibn `Umar (May Allah be pleased with them) would never agree to availing even a willing offer in this respect. Obviously extreme Taqwa (fear of Allah) and moral scruples lay behind his reluctance to take the place of somebody else. Yet, there are a few exceptions in this regard. For example, if somebody sits in the chair of his teacher, he may be asked to leave it. Also if a man has fixed place in the market to sell his goods, another person will not be justified in occupying it forcibly.

826. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "If someone leaves his seat (for one reason or another) and returns to it, he is better entitled to it.''
[Muslim].

827. Jabir bin Samurah (May Allah be pleased with them) reported: Whenever we came to the gathering of the Prophet, we would sit down at the end (of the assembly).
[Abu Dawud].

Commentary: This Hadith throws light on social etiquette. Suppose, if somebody comes to participate in a meeting, he should not behave in a rustic manner by crossing over the heads of the sitting people. Nor should he attempt to forcibly put himself in the place of another person.

828. Salman Al-Farisi (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "If a man takes a bath on Friday, purifies himself thoroughly, uses oil and perfume which is available in the house, sets forth for the mosque, does not (forcibly) sit between two persons, offers the prayer that is prescribed for him and listens to the Imam silently, his sins between this Friday and the previous Friday will be forgiven.''
[Al-Bukhari].

Commentary: This Hadith highlights eight points. First, to take a bath on Friday is a matter of commendation. Some say this bath is commendable, while others think it is necessary. Second, one should take it in the morning or before going to the mosque to offer prayer. Third, on this occasion the use of perfume or hair-cream is preferable. Fourth, there is a mention of good manners. Instead of crossing over the heads of worshippers, one should try to locate an open space and sit there. To thrust oneself between two sitting persons looks awkward. Fifth, entry into the mosque should be followed by the performance of two Rak`ah prayer, even if the Imam is delivering Khutbah (religious talk). Sixth, an attempt should be made to offer voluntary prayer before the Khutbah. Seventh, complete silence should be observed during the Khutbah to the point that one is not allowed to say to the other person: "Keep silent,'' if one does not want to loose reward. Eighth, if a man offers his Friday prayer by observing the said conditions and prerequisites, his week-long sins will be forgiven by Allah. But these are exclusively minor sins including failure in doing one's duty to Allah. As regards major sins, the sinner will not be forgiven by Allah unless he sincerely repents from the sins. Similarly, a man's failure to do his duties towards his fellow-Muslim brothers or sisters, in case he has wronged them in anyway, will not be pardoned unless he is forgiven by them.

829. `Amr bin Shu`aib on the authority of his father and grandfather reported: Messenger of Allah (PBUH) said, "It is not permissible for a person to sit between two people without their permission.''
[At-Tirmidhi].

Commentary: This Hadith tells us that a man is forbidden to push himself between two sitting persons unless they themselves allow him to do that.

830. Hudhaifah bin Al-Yaman (May Allah be pleased with him) reported: Whosoever takes seat in the midst of an assembly has been cursed by Messenger of Allah (PBUH) The Messenger of Allah curses the one who sits in the middle of people's circle.
[Abu Dawud].

Commentary: Herein, we are also told that a man must not push himself into the circles of some sitting people as this shows no consideration for their feelings. A Muslim should not intrude on other people's personal affairs.

831. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: I heard Messenger of Allah (PBUH) saying "The best assemblies are those in which people make room for one another.''
[Abu Dawud].

Commentary: This Hadith tells us that the closely-sitting people have a feeling of narrowness and suffocation. On the other hand, in a well-spaced meeting, one has a feeling of relief and comfort. The Hadith urges us to spread out in assemblies and make room for one another to the comfort of everyone.

832. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Whoever sits in a gathering and indulges in useless talk and before getting up supplicates: `Subhanaka Allahumma wa bihamdika, ash-hadu an la ilaha illa Anta, astaghfiruka wa atubu ilaika (O Allah, You are free from every imperfection; praise be to You. I testify that there is no true god except You; I ask Your Pardon and turn to You in repentance),' he will be forgiven for (the sins he may have intentionally or unintentionally committed) in that assembly.''
[At-Tirmidhi].

Commentary: A senseless, boisterous talk, not related to the life to come, is unprofitable and warrants deprecation. But since it is a small sin, it may be pardoned if one sincerely repents of it. Yet, it cannot be classified under the head of major sins and human-right violations which are unpardonable. Scholars unanimously agree that those sins which can be forgiven upon sincerely reciting the above-mentioned supplication are minor sins which relate to the violation of Allah's Rights, as evidenced by other Ahadith.

833. Abu Barzah (May Allah be pleased with him) reported: Towards the end of his life, Messenger of Allah (PBUH) would supplicate before leaving an assembly thus: "Subhanaka Allahumma wa bihamdika, ash-hadu an la ilaha illa Anta, astaghfiruka wa atubu ilaika (O Allah, You are free from every imperfection; all praise is for You. I testify that there is no true god except You, I ask Your forgiveness and turn to You in repentance).'' A man once said to him: "O Messenger of Allah! You have spoken such words as you have never uttered before.'' He said, "It is an expiation of that which goes on in the assembly.''
[Abu Dawud].

Commentary: Messenger of Allah (PBUH) would recite this supplication at the end of every assembly to teach his Ummah how to gain more rewards and to beseech Allah to forgive the lapses which they might have inadvertently committed during the course of a general conversation. There is no indication in the Hadith that he himself used to engage in idle talk while he was with his Companions.

834. Ibn `Umar (May Allah be pleased with them) reported: Messenger of Allah (PBUH) seldom left a gathering without supplicating in these terms: "Allahumma-qsim lana min khashyatika ma tahulu bihi bainana wa baina ma`sika, wa min ta`atika ma tuballighuna bihi jannataka, wa minal-yaqini ma tuhawwinu `alaina masa-'ibad-dunya. Allahumma matti`na biasma`ina, wa absarina, wa quwwatina ma ahyaitana, waj`alhul-waritha minna, waj`al tharana `ala man zalamana, wansurna `ala man `adana, wa la taj`al musibatana fi dinina, wa la taj`alid-dunya akbara hammina, wa la mablagha `ilmina, wa la tusallit `alaina man-la yarhamuna, (O Allah, apportion to us such fear as should serve as a barrier between us and acts of disobedience; and such obedience as will take us to Your Jannah; and such as will make easy for us to bear in the calamities of this world. O Allah! let us enjoy our hearing, our sight and our power as long as You keep us alive and make our heirs from our own offspring, and make our revenge restricted to those who oppress us, and support us against those who are hostile to us let no misfortune afflict our Deen; let not worldly affairs be our principal concern, or the ultimate limit of our knowledge, and let not those rule over us who do not show mercy to us).''
[At-Tirmidhi].

Commentary: This Hadith reveals a prayer through which we may be able to reach all that which is good in this world as well as in the Hereafter.

835. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Those people who leave a gathering in which they have not remembered Allah, will conclude it as if it has foul odour similar to that of a rotten carcass of a donkey. And it will be a cause of grief to them.''
[Abu Dawud].

Commentary: Messenger of Allah (PBUH) has warned us against refraining from the remembrance of Allah because most of the heart diseases are caused by this indifference, and because most of the sins are committed as a result of this indifference.

836. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Whenever a group of people sit in a gathering in which they do not remember Allah the Exalted, nor supplicate to elevate the rank of their Prophet, such a gathering will be a cause of grief to them. If Allah wills, He will punish them, and if He wills He will forgive them.''
[At-Tirmidhi].

Commentary: Any meeting where Allah (SWT) is not glorified and praised and His blessings are not invoked to elevate the rank of His Prophet (PBUH), will cause grief and punishment to the participants in the Hereafter.

837. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "If anyone sits in a gathering where he does not remember Allah, he will bring grief upon himself (on the Day of Resurrection), and he who lies down in a place where he does not remember Allah, will bring grief upon himself (on the Day of Resurrection).''
[Abu Dawud].

Commentary: To sum up what has gone in the Ahadith of this chapter, man should remember Allah on all occasions. This will establish and cement his bond with Allah, keeping heedlessness away from his heart and mind. It is heedlessness which prompts man to transgress Divine rules and limits, whereas the remembrance of Allah prevents him from indulging in backbiting and passing slanderous remarks against people in their absence or reproaching and belittling someone at a meeting. Unfortunately, such petty and negative out-pourings are relished at chat sessions in our society. This generates grudge, illwill and hostility in hearts and splits up social cohesion and Islamic solidarity. Every Muslim should, therefore, take care to avoid such gatherings.


Visions in Dream and matters relating to them

Chapter 130
Visions in Dream and matters relating to them

Allah, the Exalted, says:

"And among His Signs is your sleep by night and by day.'' (30:23)

838. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "All that is left from Prophethood is the glad tidings.'' He was asked what the glad tidings were, and he said, "The good dream.''
[Al-Bukhari].

Commentary: Dreams are both pleasant and unpleasant or nightmarish. Sometimes a dream is based on truth and foreshadows a coming event. The significance of such a dream is realised at a moment when our vision flows into a real occurrence. Coming to the meaning of this Hadith, since the institution of Prophethood is abolished, Revelation too cannot descend upon anybody. Yet, one Prophetic vestige still exists and that means a prophetic dream about some future event. It may be with a good or bad omen, though this Hadith brings into focus dreams with good tidings alone.

839. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When the time draws near (i.e., near the end of the world), the dream of a believer can hardly be false; and the dream of a believer represents one part from forty-six parts of Prophethood.''
[Al-Bukhari and Muslim].

One narration says: Messenger of Allah (PBUH) said, "The most truthful of you in their speech are those who see the truest visions.''

Commentary: According to the saying of Messenger of Allah (PBUH), in the last phase of this world, true believers will see dreams in which Allah will show them certain facts. Al-Muhallab said: The visions of the Prophets are true and those of the believers are mostly true because Satan does not overtake their hearts. As for the dreams of the disbelievers and the disobedient Muslims, they are mostly untrue because Satan has overtaken their hearts.

840. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "He who sees me in his dream will see me in his wakefulness (or he (PBUH) may have said it is as though he has seen me in a state of wakefulness), for Satan does not appear in my form.''
[Al-Bukhari and Muslim ].

Commentary: Two things are reported in this Hadith. The narrator forgets which of the two has been uttered by Messenger of Allah (PBUH). If it is the first, it means that a believer who saw Messenger of Allah (PBUH) in a dream would also see him on the Day of Resurrection. In a sense it verifies the veracity of the believer. In the case of the second, the sense is clear. Yet, Satan may also appear in a believer's dream under a saintly guise and put him into delusion that he has seen Messenger of Allah (PBUH). Every Muslim, therefore, is required to know the identity and features of Messenger of Allah (PBUH) so that Satan may not deceive him.

841. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "When one of you sees a dream that he likes, then it is from Allah. He should praise Allah for it and relate it to (others).''

Another narration adds: Messenger of Allah(PBUH) said, "He should not report it except to those whom he loves. And if he sees one which he dislikes, then it is from the Satan. He should seek refuge in Allah against its evil and should not mention it to anyone. Then it will not harm him.''
[Al-Bukhari and Muslim].

Commentary: There are clear instructions from Messenger of Allah (PBUH) about both good and bad dreams. A good dream means a good news sent by Allah to a person who has seen it. It should be related only to those who are close to his heart and not to such people who may start nourishing malice against him like the brothers of Prophet Yusuf (Joseph). A bad dream should be attributed to Satan and not be described to others because it often causes one to be pessimistic and it may be taken as a bad omen, which is not allowed in Islam. Rather, a man should seek Allah's Refuge against its evil. And if he puts faith in Allah, no harm will come to him.

842. Abu Qatadah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A good vision (dream) is from Allah and a bad dream is from the Satan. He who sees something in a dream that he dislikes, should blow thrice on his left, must seek Allah's Refuge from the evil of the Satan (i.e., by saying: A`udhu billahi minash-Shaitanir-Rajim). Then it will not harm him.''
[Al-Bukhari and Muslim].

Commentary: As mentioned in the preceding Hadith, there are good dreams and bad dreams. This Hadith shows us what to do in order to avoid the evil of Satan who cannot harm anyone except by Allah's leave.

843. Jabir (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When one of you sees a bad dream let him blow three times on his left, seek refuge in Allah from the Satan three times (i.e., by saying: A`udhu billahi minash-Shaitanir-Rajim) and change the side on which he was lying.''
[Muslim].

Commentary: This Hadith makes an addition to the preceding ones, that is, on seeing a bad dream, one should change his side. If he is lying on his right side, he should turn to the left, and vice versa. By this precaution Allah will turn a bad dream into a good one by His leave.

844. Wathilah bin Al-Asqa` (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "Of the worst lies are: to claim a false father, or to pretend to have seen what one has not seen (tell a false dream), or to attribute to the Messenger of Allah (PBUH) what he has not said.''
[Al-Bukhari].

Commentary: To disown one's father and attribute fatherhood to somebody else is a major sin, because apart from causing doubts and confusion in people's minds about one's blood, descent and character, this will give rise to social, moral and psychological problems as well. And of the same serious nature is the case where fabricated sayings and acts are attributed to the Messenger of Allah (PBUH). Unfortunately, some unwary `Ulama', particularly the story-telling preachers, frequently indulge in uttering fabricated Ahadith. The warning equally holds good in case a man narrates a Hadith of a weak chain of transmission without pointing to its category. One should, therefore, refrain from recounting all Ahadith of such a category.

There are always some so-called `Ulama', ambitious of social distinction and fame, who have made tall claims on the basis of their dreams. They are audacious enough to claim that they unceremoniously see the Prophet (PBUH) and receive instructions from him. There also exist certain misguided people who justify their fantastic views on the basis of their dreams and repudiate the rightly-established beliefs and precepts. All this is baseless and nonsensical. Dreams cannot be made the touchstone of verifying what is lawful or unlawful, or what is true or untrue. What we need indeed are the tangible arguments of the Shari`ah.


Book Five: The book of Greetings

  • Chapter 131 : Excellence of Promoting Greetings
  • Chapter 132 : Words to be used for offering Greetings
  • Chapter 133 : Etiquette of offering Greetings
  • Chapter 134 : Excellence of Greeting the Acquaintance Repeatedly
  • Chapter 135 : Excellence of Greeting at the time of entry into the House
  • Chapter 136 : Greeting the Children
  • Chapter 137 : Greeting one's Wife and other Women
  • Chapter 138 : Greeting the non-Muslims and Prohibition of taking an Initiative
  • Chapter 139 : Excellence of Greeting on Arrival and Departure
  • Chapter 140 : Seeking Permission to enter (somebody's House) and Manners relating to it
  • Chapter 141 : Seeking Permission to enter by telling one's Name
  • Chapter 142 : Saying 'Al-Hamdulillah' on Sneezing, its reply and Manners relating to Sneezing and Yawning
  • Chapter 143 : Excellence of Hand shaking at the time of Meeting


Excellence of Promoting Greetings

Chapter 131
Excellence of Promoting Greetings

Allah, the Exalted, says:

"O you who believe! Enter not houses other than your own, until you have asked permission and greeted those in them.'' (24:27)

"But when you enter the houses, greet one another with a greeting from Allah (i.e., say: As-Salamu `alaikum - peace be on you), blessed and good.'' (24:61)

"When you are greeted with a greeting, greet in return with what is better than it, or (at least) return it equally.'' (4:86)

"Has the story reached you, of the honoured guests [three angels; Jibril (Gabriel) along with another two] of Ibrahim (Abraham)? When they came in to him, and said, `Salam (peace be upon you)!' He answered: `Salam (peace be upon you).''' (51:24,25)

845. Abdullah bin `Amr bin Al-`as (May Allah be pleased with them) reported: A man asked the Messenger of Allah (PBUH): "Which act in Islam is the best?'' He (PBUH) replied, "To give food, and to greet everyone, whether you know or you do not.''
[Al-Bukhari and Muslim].

Commentary: Feeding poor and destitute is an act of goodness, and so is fulfilling the needs of the indigent. Greeting everybody (saying `As-Salamu `Alaikum'), whether an acquaintance or a stranger, is a good manner too. Both of these acts generate mutual love and remove hatred and ill will from hearts. All other forms of greetings do not no substitute for Islamic greeting.

846. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When Allah created Adam (PBUH), He said to him: `Go and greet that company of angels who are sitting there - and then listen to what they are going to say in reply to your greetings because that will be your greeting and your off-spring's.' Adam (PBUH) said to the angels: `As-Salamu `Alaikum (may you be safe from evil).' They replied: `As-Salamu `Alaikum wa Rahmatullah (may you be safe from evil, and Mercy of Allah be upon you).' Thus adding in reply to him: `wa Rahmatullah (and Mercy of Allah)' to his greeting.''
[Al-Bukhari and Muslim].

Commentary: The Islamic form of greeting - As-Salamu `Alaikum (may you be safe from evil) - has been in existence since the days of Prophet Adam. According to some Ahadith, it is better to add in response: wa Rahmatullahi wa Barakatuhu (and the Mercy and Blessings of Allah).

847. Al-Bara' bin `Azib (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) commanded us to do seven things: to visit the sick, to follow the funeral (of a dead believer), to invoke the Mercy of Allah upon one who sneezes (i.e., by saying to him: Yarhamuk-Allah), to support the weak, to help the oppressed, to promote the greeting of `As-Salamu `Alaikum', and to help those who swear to do something to keep their oaths.
[Al-Bukhari and Muslim].

Commentary: Muslims have obligations towards one another. The fulfillment of this social responsibility creates among them mutual love, a sense of cohesion and feelings of respect for one another.

848. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "By Him in Whose Hand is my life! You will not enter Jannah until you believe, and you will not believe until you love one another. Shall I inform you of something which, if you do, you will love one another? Promote greetings amongst yourselves.''
[Muslim].

Commentary: Iman is a prerequisite for entry to Jannah. Whereas mutual love among Muslims is complementary to it, and this quality can only be attained by giving a social character to the Islamic form of greeting, that is to say, `As-Salamu `Alaikum.'

849. `Abdullah bin Salam (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "O people, exchange greetings of peace (i.e., say: As-Salamu `Alaikum to one another), feed people, strengthen the ties of kinship, and be in prayer when others are asleep, you will enter Jannah in peace.''
[At-Tirmidhi].

Commentary: All these habits and practices are indispensable to a believer because each one of them leads to Jannah with the first people to enter it without being punished in Hell first.

850. At-Tufail bin Ubayy bin Ka`b (May Allah be pleased with him) reported: I used to visit `Abdullah bin `Umar (May Allah be pleased with them) in the morning and accompany him to the market. `Abdullah offered greetings of peace to every one he met on the way, be they sellers of petty goods, traders or poor people. One day when I came to him, he asked me to accompany him to the market. I said to him: "What is the point of your going to the market when you do not sell, nor ask about articles, nor offer a price for them, nor sit down with any company of people. Let us sit down here and talk.'' He replied: "O Abu Batn (belly)! (Tufail had a large belly), we go to the market to greet everyone we meet.''
[Malik].

Commentary: This Hadith highlights `Abdullah bin `Umar's passion for promoting Salam which is a practice of Sunnah. Secondly, we can call a person by his epithetic name provided he is not offended by it.


Words to be used for offering Greetings

Chapter 132
Words to be used for offering Greetings

It is recommended for the one offering greetings to say: `As-Salamu Alaikum wa Rahmatullahi wa Barakatuhu'. The reply is `Wa `Alaikum us-Salamu wa Rahmatullahi wa Barakatuhu.'

851. `Imran bin Husain (May Allah be pleased with them) reported: A man came to the Prophet (PBUH) and said: "As-Salamu `Alaikum (may you be safe from evil). Messenger of Allah (PBUH) responded to his greeting and the man sat down. The Prophet (PBUH) said, "Ten (meaning the man had earned the merit of ten good acts).'' Another one came and said: "As-Salamu `Alaikum wa Rahmatullah (may you be safe from evil, and Mercy of Allah be upon you).'' Messenger of Allah (PBUH) responded to his greeting and the man sat down. Messenger of Allah (PBUH) said, "Twenty.'' A third one came and said: "As-Salamu `Alaikum wa Rahmatullahi wa Barakatuhu (may you be safe from evil, and the Mercy of Allah and His Blessings be upon you).'' Messenger of Allah (PBUH) responded to his greeting and the man sat down. Messenger of Allah (PBUH) said, "Thirty.''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith shows that we can earn ten-fold good rewards by greeting a person in the Islamic way. There will be a further ten-fold addition to it if we say, "As-Salamu `Alaikum wa Rahmatullah". may you be safe from evil, and the Mercy of Allah be upon you). And if we say, "As-Salamu `Alaikum wa Rahmatullahi wa Barakatuhu'' may you be safe from evil, and the Mercy of Allah and His Blessings be upon you), thirty-fold good reward comes to us. But Ahadith are silent on increasing more words to Salam. So this much will suffice.

852. `Aishah (May Allah be pleased with her) reported: Messenger of Allah (PBUH) said to me, "This is Jibril (Gabriel) who is conveying you greetings of peace.'' I responded: "Wa `Alaihis-Salamu wa Rahmatullahi wa Barakatuhu (may he be safe from evil, and the Mercy of Allah and His Blessings be upon him).''
[Al-Bukhari and Muslim].

Commentary: This Hadith affirms the excellence of `Aishah (May Allah be pleased with him). It also tells us how to respond to the Salam of a third person, that is, we should say, "Wa `Alaihis-Salamu wa Rahmatullahi wa Barakatuhu.'

853. Anas (May Allah be pleased with him) reported the Prophet (PBUH) used to repeat his words thrice so that the meaning thereof would be fully understood, and whenever he came upon a gathering of people, he would greet them. He would repeat Salam thrice.
[Al-Bukhari].

Commentary: This Hadith tells us about one aspect of the Prophet's excellent manners that he would take due care of showing regard for the sentiments of people. The whole of a gathering is not supposed to hear the Salam of somebody and respond to him. A single person can represent the gathering in this regard. Yet, it was characteristic benevolence of the Messenger of Allah (PBUH) which prompted him to repeat his saying "As-Salamu `Alaikum'' thrice so that everybody would hear it and may not have a feeling of being neglected.

854. Al-Miqdad (May Allah be pleased with him) reported in course of a long Hadith: We used to reserve for the Prophet (PBUH) his share of the milk, and he would come at night and offer greetings in such a manner as did not disturb those asleep and was heard only by those who were awake. In fact, the Prophet (PBUH) came and offered greetings as usual.
[Muslim].

Commentary: Herein, we are told how to offer Salam to people when some of them are asleep while others are awake. Our voice should be so low so as not to disturb those who are asleep and to give a chance to those who are awake to respond to it.

855. Asma' bint Yazid (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) passed through the mosque one day and there was a group of women (about ten of them) sitting in the mosque. He raised his hand to offer greetings.
[At-Tirmidhi].

Commentary: To offer As-Salam by the gesture of hand from a distance is forbidden in Islam because it is the way of non-Muslims. However, it is allowed if words are also uttered along with it. Secondly, Messenger of Allah (PBUH) could greet women because he was sinless and permanently stood under Allah's Protection. Yet, it is not permissible to other men for the fear of provoking temptation. But this Hadith can be carried into effect in case one feels that no temptation and evil will be involved in it. For example, a man can greet aged and respectable women. However, Salam to young women is not allowed as it can give birth to wickedness.

856. Abu Juraiy Al-Hujaimi (May Allah be pleased with him) reported: I saw Messenger of Allah (PBUH) and said: "Alaikas-Salamu ya Rasulallah! (Upon you be peace, O Messenger of Allah)!'' He said, "Do not say: `Alaikas-Salamu (Upon you be peace).' This is the Salam to the dead.''
[Abu Dawud and At-Tirmidhi].

Commentary: This is part of a long Hadith which has been mentioned earlier on. Refer to Hadith 796 and the commentary following it.


Etiquette of offering Greetings

Chapter 133
Etiquette of offering Greetings

857. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, 'A rider should greet a pedestrian; a pedestrian should greet one who is sitting; and a small group should greet a large group (of people).''
[Al-Bukhari and Muslim].

The narration in Al-Bukhari adds: Messenger of Allah (PBUH) said, "The young should greet the elderly.''

Commentary: The greeting of As-Salamu Alaikum should be uttered according to the prescribed way. It is the situations under reference and not the grades which will be taken into consideration in this respect.

858. Abu Umamah Sudaiy bin `Ajlan Al-Bahili (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The person nearest to Allah is one who is the first to offer greeting.''
[Abu Dawud].

The narration in At-Tirmidhi is: The Messenger of Allah (PBUH) was asked: "O Messenger of Allah! When two persons meet, who should greet the other first?'' The Messenger of Allah (PBUH) said, "The person nearest to Allah (i.e., one who is more obedient and therefore closer to Allah will say: As-Salam first.''

Commentary: The degree of a man's humbleness and modesty will be measured by the degree of his nearness to Allah. One who is nearer to Allah is always the first to offer As-Salam to others, while others stick to their stuck-up behaviour


Excellence of Greeting the Acquaintance Repeatedly

Chapter 134
Excellence of Greeting the Acquaintance Repeatedly

859. Abu Hurairah (May Allah be pleased with him)reported in the Hadith in respect of the person who was at fault in performing his Salat (prayer): He came to the Prophet (PBUH) and greeted him. The Prophet (PBUH) responded to the greeting and said, "Go back and repeat your Salat because you have not performed the Salat (properly).'' He again performed Salat as he had prayed before and came to the Prophet (PBUH) and greeted him. The Prophet (PBUH) responded to the greetings (and repeated his words to him). This act of repeating (the Salat and the Salam) was done thrice.
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that one can greet others after short intervals.

860. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When one of you meets a brother (in Faith) he should greet him. Then if a tree or a wall or a stone intervenes between them and then he meets him again, he should greet him.''
[Abu Dawud].

Commentary: This Hadith convincingly bears out the subject matter of the chapter.


Excellence of Greeting at the time of entry into the House

Chapter 135
Excellence of Greeting at the time of entry into the House

Allah, the Exalted, says:

"But when you enter the houses, greet one another with a greeting from Allah (i.e., say: As-Salamu `Alaikum - may you be safe from evil), blessed and good.'' (24:61)

861. Anas bin Malik (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said to me, "Dear son, when you enter your house, say As-Salamu `Alaikum to your family, for it will be a blessing both to you and to your family.''
[At-Tirmidhi].

Commentary: Many people, on returning home, feel belittled in saying As-Salamu `Alaikum to their household. In fact, As-Salam is a prayer for goodness, blessing and peace, and one should have no complex about it.


Greeting the Children

Chapter 136
Greeting the Children

862. Anas (May Allah be pleased with him) reported that he passed by some children and greeted them. Then he said: "Messenger of Allah (PBUH) used to do the same.''
[Al-Bukhari and Muslim].

Commentary: By greeting children, we please their hearts and also vent our modesty. Besides, the importance of As-Salam is unconsciously felt by them. Above all it is the Sunnah of the Messenger of Allah (PBUH) and so we are supposed to put it into practice.


Greeting one's Wife and other Women

Chapter 137
Greeting one's Wife and other Women

863. Sahl bin Sa`d (May Allah be pleased with him) reported: There was a woman among us who would put beet root in a pot and add to it some ground barley. She used to cook them together. On returning from the Friday prayer, we would greet her and she would offer it to us.
[Al-Bukhari].

864. Umm Hani (May Allah be pleased with her), the daughter of Abu Talib reported: I went to the Prophet (PBUH) on the day of the conquest of Makkah. He was taking a bath and Fatimah was screening him with a cloth. I greeted him. And she mentioned the rest of the Hadith.
[Muslim].

865. Asma bint Yazid (May Allah be pleased with her) reported: The Prophet (PBUH) passed by us when we were with a party of women, and he greeted us.
[Abu Dawud].

Commentary: The permissibility of men to greet women, and vice versa, is with the condition that there will be no fear of temptation to commit the unlawful. Here are the details:

1. A young woman is forbidden to greet men and to respond to their greeting.

2. A group of women or an old woman are allowed to greet men and to respond to men's greetings. Men are also allowed to greet a group of women or an old woman.

3. A man on his own is not allowed to greet a young woman.

4. A man on his own is allowed to greet a group of women.

However, in all these cases, Islamic rules in this regard, including the lowering of the gaze, are to be observed.


Greeting the non-Muslims and Prohibition of taking an Initiative

Chapter 138
Greeting the non-Muslims and Prohibition of taking an Initiative

866. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Do not greet the Jews and the Christians before they greet you; and when you meet any one of them on the road, force him to go to the narrowest part of it.''
[Muslim].

Commentary: This Hadith prohibits Muslims from greeting non-Muslims first. It also tells us that when the road is crowded, we should use the middle of the road and let the non-Muslims use its sides. This Hadith shows the dignity of Muslims and the disgrace and humiliation of the non-Muslims.

867. Anas (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When the people of the Book greet you (i.e., by saying `As-Samu `Alaikum,' meaning death be upon you), you should respond with: `Wa `alaikum' [The same on you (i.e., and death will be upon you, for no one will escape death)].''
[Al-Bukhari and Muslim].

868. Usamah bin Zaid (May Allah be pleased with him) reported: The Prophet (PBUH) passed by a mixed company of people which included Muslims, polytheists and Jews, and he gave them the greeting (i.e., saying As-Salamu `Alaikum).
[Al-Bukhari and Muslim].

Commentary: If there is a mixed assembly of Muslims and non-Muslims, one should utter greeting to it but consider Muslims as one's addressees.


Excellence of Greeting on Arrival and Departure

Chapter 139
Excellence of Greeting on Arrival and Departure

869. Abu Hurairah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "When one of you arrives in a gathering, he should offer Salam to those who are already there, and he should also do so when he intends to depart. The first act of greeting is not more meritorious than the last.''
[Abu Dawud].

Commentary: We should offer As-Salam to those sitting in a gathering, on our arrival as well as departure. Both the greetings are essential. "The first act of greeting is not more meritorious than the last'' means that we should utter it on both occasions.


Seeking Permission to enter (somebody's House) and Manners relating to it

Chapter 140
Seeking Permission to enter (somebody's House) and Manners relating to it

Allah, the Exalted, says:

"O you who believe! Enter not houses other than your own, until you have asked permission and greeted those in them.'' (24:27)

"And when the children among you come to puberty, then let them (also) ask for permission, as those senior to them (in age).'' (24:59)

870. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Permission is to be sought thrice. If it is accorded, you may enter; otherwise, go back.''
[Al-Bukhari and Muslim].

871. Sahl bin Sa`d (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Seeking permission to enter (somebody's house) has been prescribed in order to restrain the eyes (from looking at something we are not supposed to look at).''
[Al-Bukhari and Muslim].

Commentary: Within the four walls of their homes, people are normally engaged in different types of domestic chores, or they rest in seclusion. Women understandably do things at home in a relaxed manner which is scarcely possible for them in the presence of a man not belonging to their household. We commit an intrusion upon others' privacy and also eye the Hijab-observing women by entering a house without permission. Both the things are prohibited and must be avoided.

872. Rib`i bin Hirash (May Allah be pleased with him) reported: A man of Banu `Amir tribe has told us that he had asked the Prophet (PBUH) for permission to enter when he was at home. He said: "May I enter?'' Messenger of Allah (PBUH) said to the servant, "Go out and instruct him about the manner of seeking permission. Tell him to say: As-Salamu `Alaikum (may you be safe from evil). May I come in?'' The man heard this and said: "As-Salamu `Alaikum (may you be safe from evil). May I come in?'' The Prophet (PBUH) then accorded permission to him and he entered in.
[Abu Dawud].

Commentary: This Hadith teaches us manners of visiting a house. One should offer As-Salam to the host at the doorstep and then seek his permission to enter. Moreover, we are told to impart a religious information to an ignorant person so that he may put it into practice.

873. Kildah bin Al-Hanbal (May Allah be pleased with him) reported: I visited the Prophet (PBUH) and I entered his house without seeking permission. So he said, "Go back and say: `As-Salamu `alaikum (may you be safe from evil). May I come in?'''
[Abu Dawud and At-Tirmidhi].


Seeking Permission to enter by telling one's Name

Chapter 141
Seeking Permission to enter by telling one's Name

874. Anas (May Allah be pleased with him) reported in the course of his famous Hadith pertaining to Al-Isra' (the Ascension) that Messenger of Allah (PBUH) said, "Then Jibril (Gabriel) ascended along with me to the nearest heaven and requested for the gate to be opened. He was asked: `Who is there?' He replied: `Jibril.' He was asked: `Who is with you?' He said: `Muhammad.' Then he ascended to the second heaven and requested for the opening of the gate. He was asked: `Who is there?' He said: `Jibril.' He was asked: `Who is with you?' He replied: `Muhammad.' In the same way he ascended to the third, fourth and all the heavens (i.e., until the seventh). At all of the gates he was asked: `Who is there?' He replied: Jibril.'''
[Al-Bukhari and Muslim]

875. Abu Dharr (May Allah be pleased with him) reported: I stepped out one night and saw Messenger of Allah (PBUH) walking by himself. I began to walk in the moonlit night. He turned round and saw me and asked, "Who is there?'' I replied: "Abu Dharr.''
[Al-Bukhari and Muslim].

876. Umm Hani (May Allah be pleased with her) reported: I went to the Prophet (PBUH) who was taking a bath while Fatimah was screening him. He asked, "Who is there?'' I replied: "I am Umm Hani.''
[Al-Bukhari and Muslim].

877. Jabir (May Allah be pleased with him) reported: I went to the Prophet (PBUH) and knocked at the door (to seek permission). He asked, "Who is there?'' I said: "I''. He repeated, '' I, I?!'' as if he disliked it.
[Al-Bukhari and Muslim].

Commentary: At the doorstep, the visitor should disclose his identity to the host. Secondly, to knock at the door or to ring the door-bell is tantamount to seeking permission to enter the house. When the host comes out, the visitor should first offer him As-Salam.


Saying 'Al-Hamdulillah' on Sneezing, its reply and Manners relating to Sneezing and Yawning

Chapter 142
Saying 'Al-Hamdulillah' on Sneezing, its reply and Manners relating to Sneezing and Yawning

878. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah likes sneezing and dislikes yawning. When any one of you sneezes and says `Al-hamdu lillah (praise be to Allah)', it becomes obligatory upon every Muslim who hears him to respond with `Yarhamuk-Allah (may Allah have mercy on you)'. Yawning is from the devil. When one of you feels like yawning, he should restrain it as much as possible, for the devil laughs when one of you yawns.''
[Al-Bukhari].

Commentary: Sneezing lightens the mind of man, and bodily he feels comfort. It is, therefore, something good and one should glorify Allah for it. Whereas, yawning is indicative of gluttony, sloth and heaviness and is considered disagreeable. The Prophet (PBUH) commanded us to stop it either by closing our mouth or by putting our hand across it in order to avoid an act which pleases Satan.

879. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When one of you sneezes he should say: `Al-hamdu lillah (praise be to Allah),' and his brother or his companion should say to him: `Yarhamuk-Allah (may Allah have mercy on you).' When he says this he should reply: `Yahdikum-ullah wa yuslihu balakum (may Allah guide you and render sound your state of affairs).'''
[Al-Bukhari].

Commentary: This Hadith teaches Muslims to have good wishes for one another and to return good for good. This reciprocity increases mutual love and results in the unity, peace and dynamism of the Muslim society. May we act upon the golden principles of our religion!

880. Abu Musa (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When one of you sneezes and praises Allah (i.e., says Al-hamdu lillah), you should invoke Allah's Mercy upon him (i.e., say Yarhamuk-Allah); but if he does not praise Allah, you should not make a response.'' [Muslim].

Commentary: Two senses have been attributed to this prayer of Messenger of Allah (PBUH). It means to pray for the good and growth of somebody. Yet, it may also be interpreted in this way, "May Allah save you from such things as will please your opponents.''

881. Anas (May Allah be pleased with him) reported: When two men sneezed in the presence of the Prophet (PBUH), he responded to one with "Yarhamuk-Allah (may Allah have mercy on you)'' and did not respond to the other. The latter said to him: "You invoked a blessing on this man but did not do so in my case.'' The Prophet (PBUH) replied, "He praised Allah (i.e., he said `Al-hamdu lillah') but you did not.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that we should seek Blessings of Allah only to that sneezer who says Al-hamdu lillah.

882. Abu Hurairah (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) sneezed, he would cover his mouth with his hand or a piece of cloth, suppressing the sound this way.
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith stresses a very important point. In the presence of others, a sneezer is supposed to put his hand or handkerchief over his mouth so that the explosive sound may be suppressed. The other benefit of this precaution is that it avoids causing an uneasy feeling to persons sitting beside him.

883. Abu Musa (May Allah be pleased with him) reported: The Jews used to intentionally sneeze in the presence of the Messenger of Allah (PBUH) hoping that he would say to them: `Yarhamukum-ullah (may Allah have mercy on you),' but he would respond with: "Yahdikum-ullahu wa yuslihu balakum (may Allah guide you and render sound your state of affairs).''
[Abu Dawud and At-Tirmidhi].

Commentary: Here, we are told that in response to sneezing on the part of non-Muslims, we should only utter these benedictory words: "Yahdikum-ullahu wa yuslihu balakum (may Allah guide you and render sound your state of affairs)!''

884. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When one yawns, he should put his hand over his mouth, otherwise the devil will enter.''
[Muslim].

Commentary: At the time of yawning, one should put his hand across his mouth. It is a disliked act or Makruh to yawn noisily, because this act pleases Satan. In other words, we must not miss any chance to degrade and frustrate Satan


Excellence of Hand shaking at the time of Meeting

Chapter 143
Excellence of Hand shaking at the time of Meeting

885. Abu Khattab Qatadah (May Allah be pleased with him) reported: I asked Anas: "Did the Companions of Messenger of Allah (PBUH) use to shake hands?'' He said: "Yes.''
[Al-Bukhari].

Commentary: To shake hands with somebody is a welcome sign and the practice of the Messenger of Allah (PBUH). The social behaviour of the Companions also included handshaking along with saying `As-Salamu `Alaikum.'

886. Anas (May Allah be pleased with him) reported: When the people of Yemen came, the Messenger of Allah (PBUH) said, "The people of Yemen have visited you. They are the first to introduce the tradition of handshaking.''
[Abu Dawud].

Commentary: This Hadith shows that the custom of handshaking was prevalent in Yemen. When some Yemenites came to see the Prophet (PBUH), they displayed their practice of handshake. He liked and approved it as his Sunnah.

887. Al-Bara' (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Two Muslims will not meet and shake hands without having their sins forgiven (by Allah ) before they depart.''
[Abu Dawud].

Commentary: Herein, we are told that Allah forgives the minor sins of the two believers who shake hands. However, major sins cannot be forgiven without heartfelt repentance with its conditions. As for our duty towards our fellow-humans, it is inescapable, and a failure in this regard is not forgiven. To sum up, when two Muslims meet and shake hands, two benefits accrue to them. Firstly, their mutual love increases, and secondly, their minor sins are pardoned by Allah.

888. Anas (May Allah be pleased with him) reported: A man asked: "O Messenger of Allah! When a man meets a brother or a friend, should he bow to him?'' He said, "No.'' The man asked whether he should embrace and kiss him? The Messenger of Allah (PBUH) replied, "No.'' He asked whether he should hold his hand and shake it? The Messenger of Allah (PBUH) replied, "Yes.''
[At-Tirmidhi].

Commentary: Here, we are clearly told that when two Muslims meet they are not allowed to bow. Some say the bowing must not come down to the position as assumed in Ruku`. But the Hadith imposes a total ban on it. There is no question of more or less degree of bowing, still less of touching the knees and feet of anybody. Here embracing has been prohibited too, but the prohibition is effective only if the kissing of hands is also involved. Otherwise, some Ahadith allow embracing, particularly on return from a journey or when two persons meet after a long time. Thirdly, the Hadith is absolutely clear on handshake. The question put to the Prophet u was about taking a single hand to which he had replied in the affirmative. There was no reference to taking or using both hands for handshake.

889. Safwan bin `Assal (May Allah be pleased with him) reported: A Jew asked his companion to take him to the Prophet (PBUH); and when they came to the Messenger of Allah (PBUH), they asked him about the nine clear signs (given to Prophet Musa). Safwan narrated the long Hadith which concludes: They kissed the hands and feet of the Messenger of Allah (PBUH) and said: "We testify that you are a Prophet.''
[At-Tirmidhi] (Unapproved Hadith).

890. In a narration of Ibn Umar (May Allah be pleased with them) at the end of the narration of the Hadith ) he said: "We came near the Prophet (PBUH) and kissed his hand.''
[Abu Dawud] (Weak Hadith).

891. `Aishah (May Allah be pleased with her) reported: Zaid bin Harithah came to the Messenger of Allah (PBUH) when he was in my house. Zaid knocked at the door. The Prophet (PBUH) rose to receive him, trailing his garment. He embraced and kissed him.
[At-Tirmidhi].

Commentary: Since Muhammad bin Ishaq, known for his delusive tendency, happens to be a narrator in this Hadith, Sheikh Al-Albani deems it deficient. Indeed, Hadith memorizers and researchers believe that the Ahadith about the kissing of hand are weak and deficient from the viewpoint of authenticity. The two persons should, therefore, confine to handshake when they meet. Though there is no harm if they embrace.

892. Abu Dharr (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me, "Do not belittle any good deed, even your meeting with your brother (Muslim) with a cheerful face.''
[Muslim].

Commentary: This Hadith has already been reported. See the commentary on Hadith No. 695.

893. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) kissed his grandson Hasan bin `Ali in the presence of Aqra` bin Habis. Thereupon Aqra` remarked: "I have ten children and I have never kissed any one of them.'' The Messenger of Allah (PBUH) cast a glance upon him and said, "He who does not show mercy to others, will not be shown mercy.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been placed earlier. To pamper and kiss children is an expression of compassion and kindness. One who lacks this tender quality and fails to behave kind-heartedly towards people, may be deprived of Divine mercy. The Messenger of Allah (PBUH) has said, "Have compassion for others, Allah will have mercy on you.'' On another occasion the Messenger of Allah (PBUH) said, "Be merciful to others and Allah will have mercy on you, and forgive (others), you will be forgiven.''


Book Six: The Book of Visiting the Sick

  • Chapter 144 : Following the Funeral, and Matters relating to Illness and Death
  • Chapter 145 : Supplication for the Sick
  • Chapter 146 : Recommendation of Inquiring the Family Members of the Patient about his Condition
  • Chapter 147 : Supplication when one is disappointed about his Life
  • Chapter 148 : Instructing the Patient's family to be kind to him - Consoling the Patients and showing kindness to one Facing Death Sentence
  • Chapter 149 : Permissibility of expressing feelings of agony in Serious Illness
  • Chapter 150 : Helping a dying Person to Pronounce 'La Ilaha Illahllah'
  • Chapter 151 : Supplication to be made soon after a Person's Death
  • Chapter 152 : Goof Words to be Uttered before a dying Person and his Family
  • Chapter 153 : The Ruling of crying and wailing over a Dead Person
  • Chapter 154 : Prohibition of Disclosing the Physical defects of the Deceased
  • Chapter 155 : Participation in Funeral Prayer and Procession and the dislike of Women Participating in the Funeral Procession
  • Chapter 156 : Excellence of Participation in Funeral Prayers in Large Numbers and Formation of Three Rows or More
  • Chapter 157 : Supplications in Funeral Prayers
  • Chapter 158 : Haste in Burial
  • Chapter 159 : About Speedy Repayment of the Debts of a Deceased Person and Preparation of Burial
  • Chapter 160 : Admonition beside the Grave
  • Chapter 161 : Supplication for the Deceased after his Burial
  • Chapter 162 : Charity on behalf of the Deceased and Praying for him
  • Chapter 163 : Praising the Deceased
  • Chapter 164 : Superiority of one who is Bereaved of his Infants
  • Chapter 165 : Weeping while Passing by the Graves of the Infidals


Following the Funeral, and Matters relating to Illness and Death

Chapter 144
Following the Funeral, and Matters relating to Illness and Death

894. Al-Bara' bin `Azib (May Allah be pleased with them) reported: Messenger of Allah (PBUH) has ordered us to visit the sick, to follow the funeral (of a dead believer), respond to the sneezer (i.e., by saying to him: Yarhamuk-Allah after he says: Al-hamdu lillah), to help those who vow to fulfill it, to help the oppressed, to accept the invitation extended by the inviter; and to promote greetings (i.e., saying As-Salamu `Alaikum).
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned with slightly different wording. Here it has been repeated owing to its relevance to this chapter. See Hadith No. 847.

895. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Every Muslim has five rights over another Muslim (i.e., he has to perform five duties for another Muslim): to return the greetings, to visit the sick, to accompany funeral processions, to accept an invitation, to respond to the sneezer [i.e., to say: `Yarhamuk-Allah (may Allah bestow His Mercy on you),' when the sneezer praises Allah].''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. See the commentary on Hadith No. 240.

896. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Verily, Allah, the Exalted, and Glorious will say on the Day of Resurrection: `O son of Adam, I was ill but you did not visit Me.' He would say: `O my Rubb, how could I visit you and You are the Rubb of the worlds?' Thereupon He would say: `Did you not know that such and such a slave of Mine was ill but you did not visit him? Did you not realize that if you had visited him (you would have known that I was aware of your visit to him, for which I would reward you) you would have found Me with him? O son of Adam, I asked food from you but you did not feed Me.' He would submit: `My Rubb, how could I feed You and You are the Rubb of the worlds?' He would say: `Did you not know that such and such a slave of Mine asked you for food but you did not feed him? Did you not realize that if you had fed him, you would certainly have found (its reward) with Me? O son of Adam, I asked water from you but you did not give it to Me.' He would say: `My Rubb, how could I give You (water) and You are the Rubb of the worlds?' Thereupon He would say: `Such and such a slave of Mine asked you for water to drink but you did not give it to him. Did you not realize that if you had given him to drink you would have found (its reward) with Me?'''
[Muslim].

Commentary: The person who is more beneficial to the slaves of Allah is loved most by Him. Allah likes it very much if somebody serves His creatures and treats them well. He will give him the best reward for it. Here, one has been urged in an effective and eloquent way to visit the sick and to treat the needy nicely.

* This Hadith is a clear-cut proof refuting pantheism for it is clear that this Hadith differentiates between the Creator and the creature in terms of feeding, giving water to drink, visiting, etc.

* This Hadith confirms the speech as Divine attribute.

* That Allah rewards His slaves for their good deeds, and never wrongs a thing.

* The duty of looking after the Muslims and their interests seeking the pleasure of Allah.

* The duty of visiting the sick.

* The duty of offering food for the hungry needy Muslims.

897. Abu Musa (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Visit the sick, feed the hungry, and (arrange for the) release of the captive.''
[Al-Bukhari].

Commentary: Islam calls upon its followers to co-operate with one another in good things. Like the previous Ahadith, this Hadith too, should be viewed in the same context. Herein, believers are enjoined to endeavour for the liberation of a fellow-Muslim who becomes a prisoner of war or is taken captive by disbelievers in any way. This instruction of the Messenger of Allah (PBUH) is also meant for the help of that person who is involved in a false case or is undergoing jail term on this count. Similarly, it is the duty of the community to extend help and co-operation to a Muslim suffering a financial difficulty so that he becomes self-sufficient.

898. Thauban (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who visits his brother in Faith, will remain engaged in picking the fresh fruits from the garden of Jannah till he returns.''
[Muslim].

899. `Ali bin Abu Talib (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "When a Muslim visits a sick Muslim at dawn, seventy thousand angels keep on praying for him till dusk. If he visits him in the evening, seventy thousand angels keep on praying for him till the morning; and he will have (his share of) reaped fruits in Jannah.''
[At-Tirmidhi].

Commentary: Both, this Hadith and the preceding one, lay stress on the virtue of visiting a sick person so as to obtain the Divine reward. The Hadith mentions "dawn'' and "evening'' to mean at all times, and not necessarily at those particular times.

900. Anas (May Allah be pleased with him) reported: A young Jewish boy who was in the service of the Prophet (PBUH) fell ill. The Prophet (PBUH) went to visit him. He sat down by his head and said to him, "Embrace Islam.'' The little boy looked at his father who was sitting beside him. He said: "Obey Abul-Qasim (i.e., the Messenger of Allah (PBUH)).'' So he embraced Islam and the Prophet ü stepped out saying, "Praise be to Allah Who has saved him from Hell-fire.''
[Al-Bukhari].

Commentary: Herein, the example of the Messenger of Allah (PBUH) inspires us to visit even a sick disbeliever and invite him to accept Islam. Besides, the Hadith tells that the company of the virtuous does bear fruit and that we should continue to hope that the heart of a disbeliever will turn to Allah at any moment. Furthermore, we come to believe that parents, though not clinging to the right way, may tell their offspring to pursue the truth.


Supplication for the Sick

Chapter 145
Supplication for the Sick

901. `Aishah (May Allah be pleased with him) reported: When a person complained to the Prophet (PBUH) about an ailment or suffered from a sore or a wound, the Prophet (PBUH) would touch the ground with his forefinger and then raise it (Sufyan bin `Uyainah, the narrator, demonstrated this with his forefinger) and would recite: `Bismil-lahi, turbatu ardina, biriqati ba`dina, yushfa bihi saqimuni, bi 'idhni Rabbina' (With the Name of Allah, the dust of our ground mixed with the saliva of some of us would cure our patient with the permission of our Rubb.''
[Al-Bukhari and Muslim].

Commentary: The Prophet (PBUH) would put his forefinger on earth and then mix his spittle with the dust sticking to it. Afterwards, he would put it on the patient's pain-spot or wound and utter the said supplication. This simple act would cure the patient. Some believe that it was peculiar only to the Prophet (PBUH) and was indeed his miracle because the particular dust was of Al-Madinah's soil with the Prophet's spittle being of a unique quality. But Ibn Hajar differs from this view. Spittle and dust, according to him, are simply external means and the curative effect in them comes from Allah Alone. Secondly, we may turn to the pious people to seek their blessings and prayers for the removal of our ailments and troubles, provided the spiritual treatment is bereft of amulets and other polytheistic ways.

902. `Aishah (May Allah be pleased with her) reported: When the Prophet (PBUH) visited any ailing member of his family, he would touch the sick person with his right hand and would supplicate: "Allahumma Rabban-nasi, adhhibil-ba'sa, washfi, Antash-Shafi, la shifa'a illa shifa'uka, shifaan la yughadiru saqaman [O Allah! the Rubb of mankind! Remove this disease and cure (him or her)! You are the Great Curer. There is no cure but through You, which leaves behind no disease].''
[Al-Bukhari and Muslim].

Commentary: The word "Ya`udu'' (enquired about the patient's health or visited) occurs in the Hadith text quoted by Imam An-Nawawi. But according to Al-Bukhari, this word is "Yuawwidu'' which, says Ibn Hajar, is synonymous to the word "Yarqee'' (blew over the patient).

903. Anas (May Allah be pleased with him) reported: I said to Thabit (May Allah had Mercy upon him) Should I not perform Ruqyah (i.e., recite supplication or Quranic Ayat and blow) over you, such supplication as was practised by the Messenger of Allah (PBUH)?'' He said: "Please do so.'' Anas (May Allah be pleased with him) supplicated: "Allahumma Rabban-nasi, mudh-hibal-ba'si, ishfi Antash-Shafi, la shafiya illa Anta, shifa'an la yughadiru saqaman [O Allah! the Rubb of mankind! Take away this disease and cure (him or her). You are the Curer. There is no cure except through You. Cure (him or her), a cure that leaves no disease].''
[Al-Bukhari].

Commentary: The said Hadith testifies that the Prophet (PBUH) and the Companions had certainly `blown over' the patients. There is no doubt about that. Yet, the act of blowing over must be based on the Names and Attributes of Allah and the Prophetic prayers or on Qur'anic Surat and Ayat. Besides, one should have the firm belief that the secondary causes cannot yield the desired effect unless Allah wills so.

904. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) visited me during my illness and supplicated, "O Allah! Cure Sa`d. O Allah! Cure Sa`d. O' Allah! Cure Sa`d.''
[Muslim].

Commentary: To pray for the health and recovery of the patient, particularly uttering his name, is commendable. Furthermore, one should repeatedly pray to Allah and beseech Him with supplication till He responds.

905. Abu `Abdullah bin Abul-`as (May Allah be pleased with him) reported: I complained to the Messenger of Allah (PBUH) about a pain I had in my body. The Messenger of Allah (PBUH) said, "Place your hand where you feel pain and say: `Bismillah (With the Name of Allah)' three times; and then repeat seven times: `A`udhu bi`izzatillahi wa qudratihi min sharri ma ajidu wa `uhadhiru (I seek refuge with Allah and with His Power from the evil that afflicts me and that which I apprehend).'''
[Muslim].

Commentary: This Hadith tells us it is not necessary that a patient should exclusively get Ruqyah from others; rather he can also do Ruqyah himself by reciting the Prophet's supplications.

906. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said, "He who visits a sick person who is not on the point of death and supplicates seven times: As'alullahal-`Azima Rabbal-`Arshil-`Azimi, an yashfiyaka (I beseech Allah the Great, the Rubb of the Great Throne, to heal you), Allah will certainly heal him from that sickness.''
[Abu Dawud and At-Tirmidhi].

Commentary: There is always a great certainty that Allah will respond to a supplication which springs from a sincere, veracious heart. One should, therefore, pray for a patient with full conviction and reassurance of heart. Moreover, the Prophet's prayers have special effect and grace and therefore their original wordings should be uttered.

907. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) visited a bedouin who was sick. Whenever he visited an ailing person, he would say, "La ba'sa, tahurun in sha' Allah [No harm, (it will be a) purification (from sins), if Allah wills].''
[Al-Bukhari].

Commentary: According to this Hadith, a patient should be told that his disease will purge out his sins. To sit beside the sick, to comfort his heart and to say a few words of sympathy to him was the Prophet's practice.

908. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Jibril (Gabriel) came to the Prophet (PBUH) and said: "O Muhammad (PBUH)! Do you feel sick?'' He (PBUH) said, "Yes.'' Jibril supplicated thus (i.e., he performed Ruqyah): "Bismillahi arqika, min kulli shay'in yu'dhika, min sharri kulli nafsin aw `ayni hasidi, Allahu yashfika, bismillahi arqika. [With the Name of Allah. I recite over you (to cleanse you) from all that troubles you, and from every harmful mischief and from the evil of the eyes of an envier. Allah will cure you; and with the Name of Allah, I recite over you].''
[Muslim].

Commentary: This Hadith clearly tells us that the Prophet (PBUH) was not free from the basic attributes of human nature and occasionally he also fell ill. Angel Jibril (Gabriel) therefore prayed for his health and safety against all those things which could harm him. These prayers should be recited after the Prophet's practice.

909. Abu Sa`id Al-Khudri and Abu Hurairah (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "If a person says: `La ilaha illallahu wallahu Akbar (There is no true god except Allah and Allah is Greatest)', his Rubb responds to him and affirms: `(Yes!) There is no true god except I, and I am the Greatest.' When he says: `La ilaha illallahu Wahdahu la sharika Lahu (There is no true god except Allah, the One, He has no partner).' Allah (SWT) affirms: `(Yes!) There is no true god except I. I have no partner.' When he says: `La ilaha illallahu Lahul mulku wa Lahul-hamdu (the sovereignty belongs to Him and all the praise is due to Him).' He (SWT) affirms: `(Yes!) There is no true god except I, Mine is the praise and to Me belongs the sovereignty.' When he says: `La ilaha illallahu wa la hawla wa la quwwata illa Billah (There is no true god except Allah, and there is no might and power but with Allah).' He (SWT) affirms: `(Yes!) There is no true god except I, and there is no might and power but with Me.''' The Messenger of Allah (PBUH) added, "He who recites this during his illness and dies, will not be touched by the Fire (Hell).''
[At-Tirmidhu].

Commentary: This Hadith points out the excellence of the words mentioned above. This is so because of great meaning they have, namely the firm belief in Allah, His Oneness and Glorification; that to Him Alone we should return, upon Him Alone we should rely, and to Him Alone we should express gratefulness. If somebody utters them during his illness, his life is sure to come to an end in a good way, that is, he will go to Jannah.


Recommendation of Inquiring the Family Members of the Patient about his Condition

Chapter 146
Recommendation of Inquiring the Family Members of the Patient about his Condition

910. Ibn `Abbas (May Allah be pleased with them) reported: When `Ali (May Allah be pleased with him) came out after visiting the Messenger of Allah (PBUH) during his last illness, the people asked: "How is Messenger of Allah (PBUH), O Abul-Hasan?'' He replied: "Praise be to Allah, he (PBUH) is feeling better.''
[Al-Bukhari].

Commentary: This Hadith shows that if a patient is in a critical condition and people are advised not to visit him, it will be appropriate to enquire of his blood relatives about his health. The family members, too, are supposed to give an encouraging report about the patient's condition to enquirers.


Supplication when one is disappointed about his Life

Chapter 147
Supplication when one is disappointed about his Life

911. `Aishah (May Allah be pleased with her) reported: While the Prophet (PBUH) was reclining against me (during his last illness) I heard him saying: "Allahumma-ghfir li, warhamni, wa alhiqni bir Rafiqil-A`la (O Allah, forgive me, bestow Your Mercy on me and let me join with the exalted companions.''
[Al-Bukhari and Muslim].

Commentary: Most of the `Ulama' believe that Allah is the Sublime Companion (Ar-Rafiq Al-A`la). Ar-Rafiq (the Companion) is one of the Divine Names. Some take it to mean the supreme communion of angels, Prophets, martyrs and the righteous. Prophet Yusuf (Joseph) had prayed to Allah, "... And join me with the righteous.'' (12:101).

At the hour of death, man should cut off his link with the world and unite it with the Hereafter. By seeking Divine forgiveness, the Prophet (PBUH) aimed at moral elevation and abundance of goodness. Otherwise, he was protected by Allah and immune against sinning.

912. `Aishah (May Allah be pleased with her) reported: I saw the Messenger of Allah (PBUH) when he was at the point of death. He had a drinking bowl with water in it. He would dip his hand into the bowl, and wipe his face. Then he would supplicate, "O Allah! Help me over pangs and agony of death.''
[At-Tirmidhi].

Commentary: This Hadith, too, affirms the Prophet's creatural aspect, that is to say, like other humans he was also overwhelmed by the intensity of illness and felt its agony. In his last days, he suffered from intense fever. In order to decrease the high temperature, he repeatedly wet his right hand with water and passed it over his face. Like all mortals, he too, experienced the agony of the last moments and prayed to Allah for its alleviation and sought His Help. Sheikh Al-Albani considers the authenticity of this Hadith as deficient. However, the Prophet (PBUH) is authentically reported to have lost consciousness during severe illness. Both the Ahadith of this chapter reveal that man should seek help from Allah at the hour of his departure from this world.


Instructing the Patient's family to be kind to him - Consoling the Patients and showing kindness to one Facing Death Sentence

Chapter 148
Instructing the Patient's family to be kind to him - Consoling the Patients and showing kindness to one Facing Death Sentence

913. `Imran bin Husain (May Allah be pleased with them) reported: A woman belonging to the Juhainah tribe came to the Messenger of Allah (PBUH) after having conceived from Zina. She submitted: "O Messenger of Allah! I am liable to Hadd (punishment ordained by Allah), so execute it.'' The Messenger of Allah (PBUH) called her guardian and said, "Treat her well and bring her to me after delivery.'' He acted accordingly. Then the Messenger of Allah (PBUH) commanded to tie her clothes firmly around her and then stoned her to death. He (PBUH) then offered funeral prayer for her.
[Muslim].

Commentary: This Hadith has relevance to the theme of the chapter as we see it. Moreover, it reveals that if a woman becomes pregnant after committing adultery, she will not be subjected to punishment immediately. Instead, the penalty will take place after childbirth. This will certainly contribute to the remission of her sins and will also be a factor in offering the funeral prayer for her.


Permissibility of expressing feelings of agony in Serious Illness

Chapter 149
Permissibility of expressing feelings of agony in Serious Illness

914. Ibn Mas`ud (May Allah be pleased with him) reported: I visited the Prophet ({PBUH) while he was suffering. I said: "(O Messenger of Allah!) You suffer too much.'' He said, "Yes, I suffer as much as two men of you.''
[Al-Bukhari and Muslim].

Commentary: This Hadith also throws light on the fact that the Prophet (PBUH) was merely a human being. Besides, it tells us that one is at liberty to speak of one's suffering.

915. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) came to visit me when I had a severe pain. I said: "I am suffering from such trouble as you are observing. I am a wealthy man and the only heir of mine is my daughter.'' (Then Sa`d narrated the whole incident).
[Al-Bukhari and Muslim].

916. Al-Qasim bin Muhammad reported `Aishah (May Allah be pleased with her) said: "Oh, my head.'' (It was hurting due to pain.) Thereupon the Prophet (PBUH) said, "Rather it is I who says: `Oh, my headache.''' (Then Al-Qasim narrated the complete narration).
[Al-Bukhari].

Commentary: `Aishah (May Allah be pleased with her) had a headache and she told the Prophet (PBUH) about it. He said, "My head too is splitting with pain.'' This means that a man can express the intensity of his pain and suffering, provided he has no intention to complain against the Will of Allah and point out his sorrow and frustration. Al-Qasim bin Muhammad bin Abu Bakr, the reporter of this Hadith, was `Aishah's nephew and one of the seven distinguished jurists of Al-Madinah.


Helping a dying Person to Pronounce 'La Ilaha Illahllah'

Chapter 150
Helping a dying Person to Pronounce 'La Ilaha Illahllah'

917. Mu`adh bin Jabal (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He whose last words are: `La ilaha illallah' (There is no true god except Allah) will enter Jannah.''
[Abu Dawud].

Commentary: This Hadith says that if a man's tongue spontaneously starts uttering the basic testification of Islam: "None has the right to be worshipped but Allah'' just before his death, he will undoubtedly enter Jannah. However, it is not definite whether he will go to Jannah in the first phase or will be admitted to it in the second phase after undergoing a purification process. This depends on the Will of Allah. Yet, admission to Jannah is subjected to his thorough understanding of monotheism and its conditions, that is to say, a complete abstinence from a polytheistic conduct of life. Otherwise, Jannah is likely to be denied to many of the so-called Muslims overtly indulging in polytheism.

918. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Exhort your dying men to recite: `La ilaha illallah' (There is no true god except Allah).''
[Muslim].

Commentary: This Hadith implies the Prophet's instruction to his followers to recite the testification of Islam: La ilaha illallah (There is no true god except Allah) beside the dying people so that they may also recite it after hearing it. Yet, they should not be urged to recite it (i.e., by saying to the dying person: say it, say it) lest they refuse in embarrassment involving an affront to Faith. May Allah guard us against such a thing!


Supplication to be made soon after a Person's Death

Chapter 151
Supplication to be made soon after a Person's Death

919. Umm Salamah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) visited Abu Salamah (May Allah be pleased with him) when his eyes were open soon after he died. He closed them (the eyes) for him and said, "When the soul is taken away, the sight follows it.'' Some members of his family began to weep. He (PBUH) said: "Do not supplicate for yourselves anything but good, for the angels say `amin' to what you say.'' Then he ü said, "O Allah! Forgive Abu Salamah, raise his rank among those who are rightly-guided and grant him a successor from his descendants who remain behind. Grant him pardon and us, too. O Rubb of the worlds. Make his grave spacious for him and give him light in it.''
[Muslim].

Commentary: When the soul leaves the body, the eyes remain open as if gazing at it. So, the eyes of the dead body should be closed. Secondly, one should avoid uttering any imprecation on such occasions as the angels, present on the occasion, say `Amin' to it. Thirdly, the Prophet's example requires the pious persons to visit a bereaved family. Condoling them, they should invoke supplication and blessing for the departed soul. Besides, they should pray to Allah to bless the bereaved with both spiritual and material gains and multiple goodness. Supplication, as other Ahadith also tell us, is beneficial to the dead person. Condolence and supplication is undoubtedly a confirmed practice of the Prophet (PBUH). We are supposed to follow only what the Prophet (PBUH) did on such occasions, that is to say, to pray for both the departed soul and the bereaved family. This is not confirmed if in any mourning session, the Prophet ü ever prayed by raising his hands. But in view of the accepted mode of praying, to raise hands is also allowable.


Goof Words to be Uttered before a dying Person and his Family

Chapter 152
Goof Words to be Uttered before a dying Person and his Family

920. Umm Salamah (May Allah be pleased with her): The Messenger of Allah (PBUH) said, "When you visit a sick or a dying person, you should utter good words because the angels say `Amin' at what you say.'' She added: When Abu Salamah (May Allah be pleased with him) died, I came to the Prophet (PBUH) and said: "O Messenger of Allah, Abu Salamah has died.'' He (PBUH) directed me to supplicate thus: "Allahummaghfir li wa lahu, wa a`qibni minhu `uqba hasanatan [O Allah, forgive me and him, and bestow upon me a better future (give me a better substitute)].'' So I supplicated as he directed, and Allah gave me a man who was better for me than Abu Salamah (i.e., the Prophet Muhammad (PBUH)). (The Prophet (PBUH) married Umm Salamah afterwards.)
[Muslim].

Commentary: In order to fill the vacuum of the dead person, the family members should pray to Allah to grant them a better substitute as He is Omnipotent and nothing is impossible to Him.

921. Umm Salamah (May Allah be pleased with her) reported: I heard the Messenger of Allah (PBUH) saying, "When a person suffers from a calamity and utters: `Inna lillahi wa inna ilaihi raji`un. Allahumma ujurni fi musibati, wakhluf li khairan minha (We belong to Allah and to Him we shall return. O Allah! Compensate me in my affliction, recompense my loss and give me something better in exchange for it), then Allah surely compensates him with reward and better substitute.'' Umm Salamah (May Allah be pleased with her) said: When Abu Salamah (May Allah be pleased with him) died, I repeated the same supplication as the Messenger of Allah (PBUH) had commanded me (to do). So Allah bestowed upon me a better substitute than him (I was married to Muhammad, the Messenger of Allah (PBUH)).
[Muslim].

Commentary: The better substitute which fell to Umm Salamah (May Allah be pleased with her) as her lot, was her marriage with the Prophet (PBUH) after the death of her husband Abu Salamah (May Allah be pleased with him). She got the reward in her earthly life. If somebody remains deprived of it in the world, he is sure to have it in the life to come. However, this depends on the Will of Allah, for being the Creator, He has the best knowledge of what is appropriate and good for us.

922. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When a man's child dies, Allah, the Exalted, asks His angels, `Have you taken out the life of the child of My slave?' and they reply in the affirmative. He (SWT) then asks, `Have you taken the fruit of his heart?' and they reply in the affirmative. Thereupon He asks, `What did my slave say?' They say: `He praised You and said: Inna lillahi wa inna ilaihi raji'un (We belong to Allah and to Him we shall return).' Allah says: `Build a house for my slave in Jannah and name it Baitul-Hamd (the House of Praise).'''
[At-Tirmidhi].

Commentary: The death of a child is distressing to parents. But it will be a matter of great excellence on their part if they are patient.

923. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said: "Allah, the Exalted, says: `I have no reward except Jannah for a believing slave of Mine who shows patience and anticipates My reward when I take away his favourite one from the inhabitants of the world.'''
[Al-Bukhari].

924. Usamah bin Zaid (May Allah be pleased with them) reported: A daughter of the Prophet (PBUH) sent a message to him that her son was at his last breath, and requested him to come to her. The Messenger of Allah (PBUH) sent back the informer saying: "To Allah belongs what He takes and what He gives, and everything has a limited period (in this world). So ask her to endure patiently, and expect the reward of Allah.''
[Al-Bukhari and Muslim].

Commentary: This Hadith exhorts us to keep self-composure at a moment of tribulation. The Prophet's daughter mentioned in this Hadith is Zainab (May Allah be pleased with her). See the Commentary on Hadith No. 29.


The Ruling of crying and wailing over a Dead Person

Chapter 153
The Ruling of crying and wailing over a Dead Person

Wailing is unanimously forbidden (Haram) as will be mentioned later on. There are some Ahadith which forbid us from crying over somebody's death, and which inform us that the dead will be tormented in their graves as a result of their relatives crying over their death. This prohibition applies only to those cases where crying is accompanied with lamenting and wailing. Weeping without these two is, permissible; and the Ahadith in support of this are many, including the following:

925. Ibn `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) visited Sa`d bin `Ubadah during his illness. He was accompanied by `Abdur-Rahman bin `Auf, Sa`d bin Abu Waqqas and `Abdullah bin Mas`ud (May Allah be pleased with them). The Messenger of Allah (PBUH) began to weep. When his Companions saw this, their tears also started flowing. He (PBUH) said, "Do you not hear, Allah does not punish for the shedding of tears or the grief of the heart, but punishes or bestows mercy for the utterances of this (and he pointed to his tongue).''
[Al-Bukhari and Muslim].

Commentary: Under the stress of grief, man becomes heavy-hearted and tears flow out from his eyes. This is something natural and beyond human control. Rather the outflow of tears results from Divine compassion. This is neither forbidden nor subject to accountability. It is only wailing which is Haram, and is punishable. Yet, man is blessed with Divine mercy if he gives expression to patience and gratefulness by his tongue. Moreover, to mention the merits and excellence of a departed soul is in itself a good thing because others may be stimulated to adopt them. But to recount them by way of wailing is disliked. A Hadith says that a dead person is tormented because of the weeping of his household. Here weeping means lamenting and wailing. Otherwise, to weep is human instinct and no curbs can be put over it. Besides, this warning is meant for such a person who might have been accustomed to wailing during his lifetime. Or he might have left a will to his family for wailing over his death. May be he consciously avoided giving a predeath warning to his kith and kin against wailing. In all the three situations, he will be equally held accountable with his soul being tormented for the wailing of his relatives. In case, he is uninvolved in any of the situations, he will remain free from hellish torments. Instead the wailers will have to bear the brunt of their sin. As the Qur'an says, "No one laden with burdens can bear another's burden.'' (17:15).

926. Usamah bin Zaid (May Allah be pleased with him) reported: A grandson (child of the daughter) of the Messenger of Allah (PBUH) was presented to him while the child was at his last breath. Tears began to flow from the eyes of the Messenger of Allah (PBUH). Sa`d said to him: "What is this, O Messenger of Allah?'' He (PBUH) said, "It is mercy which Allah has placed in the hearts of his salves. Allah bestows His Mercy on the merciful among His slaves.''
[Al-Bukhari and Muslim].

927. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) came to his son Ibrahim (May Allah be pleased with him) when he was breathing his last. The eyes of the Messenger of Allah (PBUH) began shedding tears. `Abdur-Rahman bin `Auf (May Allah be pleased with him) said, "O Messenger of Allah, you too weep?'' He (PBUH) said, "O Ibn `Auf! It is mercy.'' Then he began to weep and said, "The eyes are shedding tears and the heart is grieved, and we will not say except what pleases our Rubb. O Ibrahim! Indeed we are grieved by your departure.''
[Al-Bukhari].

Commentary: The death of the Prophet's son, Ibrahim, born of Miriyah (May Allah be pleased with her) had occurred in the tenth year of Hijra. The Ahadith clearly prove that weeping over a loved one's death is permissible. But it should be void of wailing.


Prohibition of Disclosing the Physical defects of the Deceased

Chapter 154
Prohibition of Disclosing the Physical defects of the Deceased

928. Abu Rafi` Aslam (May Allah be pleased with him), the freed slave of the Messenger of Allah (PBUH) reported: The Messenger of Allah (PBUH) said, "He who washes a dead body and conceals what he notices of physical defects, he will be forgiven forty times.''
[Al-Hakim].

Commentary: If during washing a man's dead body, the washer has noticed some physical defect or some sort of deformation in it, he should avoid disclosing it to others so that a bad name may not come to the departed soul. Yet, the deformity in his body may have come as a Divine vengeance for the sinful and heretic life led by him in this world. In this case, there will be room for such a disclosure. Because on being dreaded and warned of a horrible end, people will come to adopt a clean and pure life in accordance with the religious principles.


Participation in Funeral Prayer and Procession and the dislike of Women Participating in the Funeral Procession

Chapter 155
Participation in Funeral Prayer and Procession and the dislike of Women Participating in the Funeral Procession

929. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whoever follows the funeral procession and offers the funeral prayer for it, will get a reward equal to one Qirat, and whoever attends it till burial, will get a reward equal to two Qirat.'' It was asked, "What are two Qirat?'' He (PBUH) replied, "Equal to two huge mountains.''
[Al-Bukhari and Muslim].

Commentary: Participation in a Muslim's funeral procession and prayer for him brings a Muslim a great reward - like the massiveness of a big mountain. And if he stays beside the grave till the burial takes place, the reward will become two-fold, that is, equaling the massiveness of two huge mountains.

930. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whosoever attends the funeral of a Muslim believing and hoping for the reward from Allah and remains with it until the prayer is offered over it and the burial is completed, he will return with a reward of two Qirat; each Qirat is equivalent to Mount Uhud; and whosoever offers his prayer over it and returns before its burial, he will come back with one Qirat.''
[Al-Bukhari].

Commentary: This Hadith explains that the only person who will earn the rewards for participating in the funeral prayer is the one who does it only to fulfill the Commands of Allah in order to seek His Pleasure. It will be denied to him in case his intention is based on social, political and family considerations.

931. Umm Atiyyah (May Allah be pleased with her) reported: We (womenfolk) were prohibited from accompanying a funeral procession, but we were not compelled (not to do so).
[Al-Bukhari and Muslim].

Commentary: Women have been prohibited from walking along the bier so as to escape mixing with men. Yet, they have room for participation when there is no danger of mixing with men. Here, lack of a hardened stance means that women, if and when required, can walk side by side with the bier but not without meeting the prerequisites. The orthodox `Ulama', therefore, call this Shari`ah restraint by the name of (suggestive prohibition). (Fath Al-Bari).


Excellence of Participation in Funeral Prayers in Large Numbers and Formation of Three Rows or More

Chapter 156
Excellence of Participation in Funeral Prayers in Large Numbers and Formation of Three Rows or More

932. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) said, "If a group of Muslims numbering a hundred perform funeral prayer over a dead person, and all of them ask Allah's forgiveness for him, their prayer for him will be accepted.''
[Muslim].

933. Ibn `Abbas (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "If a Muslim dies and forty people, who do not associate anything with Allah in worship, participate in the funeral prayer over him, Allah will accept their intercession for him.''
[Muslim].

934. Marthad bin `Abdullah Al-Yazni reported: When Malik bin Hubairah (May Allah be pleased with him) offered a funeral prayer and found a small number of participants, he would divide them into three rows and would say that the Messenger of Allah (PBUH) said, "If three rows of men offer funeral prayer over anyone, his entry into Jannah will become certain.''
[Abu Dawud and At-Tirmidhi].

Commentary: These Ahadith reveal to us that the maximum participation of people in a funeral prayer is a welcome sign. But the condition is that they should be righteous people, well-rooted in Faith and monotheistic belief. But heretics and those who associate partners with Allah in worship have no value to Allah. If the participants are small in number, they should be divided in three rows. Different Ahadith speak of different numbers, all of which convey the sense of abundance. And this abundance is not to be taken in the unqualified sense, rather it means the abundance of sincere and pious believers and monotheists. May Allah multiply their number!


Supplications in Funeral Prayers

Chapter 157
Supplications in Funeral Prayers

To pronounce four Takbir (saying Allahu Akbar) in the funeral prayer. After the first Takbir, after saying A`udhu billahi minash-Shaitanir-rajim, recite Surat Al-Fatihah. After the second Takbir, send Salam [Allahumma Salli `ala Muhammadin wa `ala ali Muhammadin kama sallaita `ala Ibrahima wa `ala ali Ibrahima, innaka Hamidun Majid. Allahumma barik `ala Muhammadin wa `ala ali Muhammadin, kama barakta `ala Ibrahima, wa `ala ali Ibrahima, innaka Hamidun Majid. Then after the third Takbir, invoke supplication for the deceased and for the Muslims as we will mention later on, in sha' Allah. After the fourth Takbir, supplicate Allah. (Some of the supplications of the Messenger of Allah (PBUH), which are to be recited after the third Takbir are mentioned in the following Ahadith:)

935. Abu `Abdur-Rahman `Auf bin Malik (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) offered a funeral prayer and I memorized his supplication. He (PBUH) prayed: "Allahummaghfir lahu, warhamhu, wa `afihi, wa`fu `anhu, wa akrim nuzulahu, wa wassi` mudkhalahu, waghsilhu bil-ma'i wath-thalji wal-baradi, wa naqqihi minal-khataya, kama naqqaytath-thawbal-abyada minad-danasi, wa abdilhu daran khairan min darihi, wa ahlan khairan min ahlihi, wa zawjan khairan min zawjihi, wa adkhilhul-Jannata, wa a`idh-hu min `adhabil-qabri, wa min `adhabin-nar [if the dead person is a woman, one should change the ending of certain words in this supplication from hu to ha] (O Allah! Forgive him, bestow mercy upon him, pardon him, accord him a noble provision and make his grave spacious, wash him with water, snow and hail, purify him from sins as You have purified the white garment from soiling, give him a better abode in place of his present one, and a better family in exchange of his present one, and a better spouse in place of his present wife; admit him to Jannah and protect from the trial in the grave and punishment in the Hell).'' (After hearing this supplication of the Messenger of Allah (PBUH), Abu' Abdur-Rahman 'Auf bin Malik (May Allah be pleased with him) said: I wished I had been that dead man.
[Muslim].

936. Abu Hurairah, Abu Qatadah, and Abu Ibrahim Al-Ash-hali (May Allah be pleased with them) reported: The Prophet (PBUH) offered a funeral prayer and said: "Allahummaghfir lihaiyina wa maiyitina, wa saghirina wa kabirina, wa dhakarina wa unthana, wa shahidina wa gha'ibina. Allahumma man ahyaiytahu minna, fa'ahyihi `alal-Islam, wa man tawaffaiytahu minna, fatawaffahu `alal-Iman. Allahumma la tahrimna ajrahu, wa la taftinna ba`dahu (O Allah, forgive our living and our dead, our present and our absent, our young and our old, our male and our female. O Allah, whosoever of us You keep alive, keep him alive (faithful) to Islہm, and whosoever of us You cause to die, let him die having Iman. O Allah, do not deprive us of our reward (for being patient) and do not subject us to trials after his death.''
[Abu Dawud and At-Tirmidhi].

937. Abu Hurairah (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying: "When you pray over the dead, make a sincere supplication for him.''
[Abu Dawud and Ibn Majah].

938. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) supplicated in course of funeral prayer: "Allahumma Anta Rabbuha, wa Anta khalaqtaha, wa Anta hadaytaha lil-Islam, wa Anta qabadta ruhaha, wa Anta a`lamu bisirriha wa `alaniyyatiha, ji'naka shufa`a'a lahu [if the dead person is a man, or laha if the dead person is a woman], faghfir lahu [or laha, if it is a woman] (O Allah, You are its Rubb; You created it; You guided it to Islam; You have taken its life back and You know best its insight and outer condition. We have come as intercessors, so forgive him).''
[Abu Dawud].

939. Wathilah bin Al-Asqa` (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) led the funeral prayer of a Muslim man in our presence, and I heard him saying "Allahumma inna [name of the dead person] fi dhimmatika wa habli jiwarika, faqihi fitnatal-qabri; wa `adhaban-Nari, wa Anta ahlul-wafa'i wal-hamdi; Allahumma faghfir lahu warhamhu, innaka Antal-Ghafur-ur-Rahim [If the dead person is a woman, one can change hu in some words here with ha] [O Allah, (so-and-so son of so-and-so) is in Your Protection and inside the surroundings of Your Refuge. Safeguard him from the trial of the grave and the punishment of the Hell. You keep Your Promise and You deserve to be praised. O Allah! Forgive him and be merciful to him. Indeed, You are the Forgiving, the Merciful].''
[Abu Dawud].

940. `Abdullah bin Abu Aufa (May Allah be pleased with them) reported: While offering the funeral prayer of one of his daughters, he recited four Takbir, and after the fourth Takbir he continued standing for a time equal to an interval between two Takbir, praying for her and seeking Allah's forgiveness for her.'' Then he said: "The Messenger of Allah (PBUH) used to do so.''

Another narration is: He (Abdullah) recited four Takbir and remained standing in prayer for some time till we thought that he would recite the fifth Takbir. Then he gave Salam on the right and on the left. When he turned aside, we asked him about it. He replied: "I would add nothing to what I saw the Messenger of Allah (PBUH) doing,'' or he said: "The Messenger of Allah (PBUH) used to do so.''
[Al-Hakim].

Commentary: All the above mentioned supplications are those which were recited by the Prophet (PBUH) in the funeral prayers. It is, therefore, advisable if they are all put together and recited because we are commanded to pray sincerely for a dead body. Another point comes to our knowledge about the funeral prayer, that is to say, it may be said aloud as affirmed by the above mentioned Ahadith because if the Prophet (PBUH) had not offered it aloud, the Companions would not have been able to memorize these supplications. Thirdly, we are uncertain that after saying a funeral prayer, the Prophet ü and his Companions ever stood round the bier and supplicated for the dead body. It is an innovation (Bid`ah) and must be abolished. We are unauthorized to refer this practice to the Prophet (PBUH). It looks strange that believers should persist in reciting supplications in their own self-styled way after the funeral prayer, but desist from them during the funeral prayer to which they have relevance. It implies that prayer is not the object of their pursuit, otherwise they would have prayed in accordance with the Sunnah. In fact, they cherish their self-fabricated line of action and seem determined to pursue it. May Allah grant them right understanding!


Haste in Burial

Chapter 158
Haste in Burial

941. Abu Hurairah (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "Hurry up with the dead body (for its burial), for if it is pious, you are speeding it to goodness and if it is otherwise, you are laying an evil off your necks.''
[Al-Bukhari and Muslim].

Commentary: This Hadith underlines the Prophet's command of an undelayed shrouding and burial of a dead body as well as the rationale behind it. Hence, there should be no unnecessary delay in the funeral, rather the burial procession should reach the grave with utmost haste without of course causing inconvenience to those following it, nor shaking the dead body.

942. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Prophet (PBUH) said, "When a dead body is placed on a bier and men carry it on their shoulders, if he was a pious man, it (corpse) says: `Take me in haste.' But if he was not righteous, it says to its bearers: `Woe to it. Where are you taking it?' Everything except man hears its voice. Had a human being heard its voice, he would have surely fallen into swoon.''
[Al-Bukhari].

Commentary: Only Allah knows the reality as to how a dead body speaks. However, no improbability is involved in this matter. Allah is empowered to let any dead body speak if He so likes. We are supposed to believe it on the authority of authentic Ahadith.


About Speedy Repayment of the Debts of a Deceased Person and Preparation of Burial

Chapter 159
About Speedy Repayment of the Debts of a Deceased Person and Preparation of Burial

943. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The soul of the deceased believer remains pending on account of the debt till it (the debt) is repayed.''
[At-Tirmidhi].

Commentary: The Divine decision regarding the redemption or punishment of a dead man remains suspended till the time his debt, if any, is paid off. A bereaved family is supposed to give top priority to the clearance of a debt.

944. Hussain bin Wahwah (May Allah be pleased with him) reported: When Talhah bin Al-Bara' (May Allah be pleased with him) fell ill, the Prophet (PBUH) came to visit him and said, "Verily, I think that Talhah is about to die. So inform me when he is dead and make haste (in burying him). Indeed, it is improper for the corpse of a Muslim to be kept lying unburied among his family members.''
[Abu Dawud].

Commentary: This Hadith tells us that a delay in the burial of a dead person will be considered ill-advised if not supported by solid reasons or a Shari`ah argument.


Admonition beside the Grave

Chapter 160
Admonition beside the Grave

945. `Ali (May Allah be pleased with him) reported: We were accompanying a funeral procession in Baqi` Al-Gharqad (graveyard in Al-Madinah) when the Messenger of Allah (PBUH) proceeded towards us and sat down. We sat around him. He had a small stick in his hand. He was bending down his head and scraping the ground with the stick. He said, "There is none among you but has a place assigned for him either in the Jannah or in the Hell.'' The Companions said: "O Messenger of Allah, should we not depend upon what has been written for us (and give up doing good deeds)?'' The Messenger of Allah (PBUH) said, "Carry on doing good deeds. Every one will find it easy to do such deeds (as will lead him to his destined place) for which he has been created.''
[Al-Bukhari and Muslim].

Commentary: The subject of this chapter is exactly related to the Hadith accounting for reasons of giving a sermon speech beside the grave. As the dimension of the world's impermanent nature and a heart-moving scene directly confront a man's eyes on this occasion, any moral exhortation is most likely to touch the heart. Secondly, the good or bad deeds of man during his fixed life span in this world prefigure in Allah's Knowledge, and He has ordained the good or bad end of everybody. But this does not mean that man is simply helpless in doing what Allah has predetermined. Indeed, Allah already knows that such and such a person will adopt the righteous conduct and meet a good end; and such and such a person will take to the mischievous way and consequently meet a bad end. Unless man has access to Allah's Knowledge and the Preserved Tablet (which is impossible), he is not supposed to give up the right conduct by banking upon His Knowledge. When he is totally ignorant of the Sacred Writ on his ultimate end, he has no other choice but to continue endeavouring in good pursuits. Allah has given him the freedom of choice and will subject him to accountability on this count alone. Moreover, it is the Divine principle that He helps everybody do only that type of work - facilitating it to him as well - which is germane to his bent of mind. Then, there is no reason that man should lag behind in embarking upon the virtuous path and not try to seek the Grace of Allah.


Supplication for the Deceased after his Burial

Chapter 161
Supplication for the Deceased after his Burial

946. Abu `Amr (also called Abu `Abdullah and also Abu Laila) from `Uthman bin `Affan (May Allah be pleased with him) reported: After the burial of a dead man, the Prophet (PBUH) would stand by the grave and say, "Ask Allah to forgive your brother and supplicate for him for steadfastness because he is being questioned (about his deeds) now.''
[Abu Dawud].

Commentary: We are told in this Hadith that two angels question man in the grave. Allah helps a true believer in answering correctly. He says to the angels, "Allah is my Rubb. Islam is my religion. And the man sent by Allah as His Prophet is Muhammad.'' A condemned person will say, "Aa, Aa, I do not know.'' We are, therefore, particularly instructed that after the burial of a fellow-Muslim, we should supplicate beside his grave for his being firm-footed against the ordeal to which he will be subjected.

947. `Amr bin Al-`as (May Allah be pleased with him) used to say: "When you have buried me, keep standing near my grave till (for the time it takes to) a camel is slaughtered and its meat is distributed, so that I may feel your nearness and know what to reply to the angels sent by my Rubb.''
[Muslim].

Commentary: As mentioned in the previous Hadith, the Prophet (PBUH) has instructed his followers that after a Muslim's burial, they should keep standing beside his grave for some time and pray for his firmness on facing the interrogating angels in the grave. `Amr bin Al-`as, too, made a will to this effect. The reference made to Imam Ash-Shafi`i (May Allah had Mercy upon him) about the recitation of the Qur'an beside a Muslim's grave is in disagreement with the Prophet's practice. What has come to us from the Prophet (PBUH) as his Sunnah in this respect is the act of supplicating, and it will be appropriate to confine to it. Aside from it, the reference made to Imam Ash-Shafi`i seems to be of doubtful authenticity. Because according to Fath Al-Bari, Tafsir Ibn Kathir and some other books, Imam Ash-Shafi`i rejected the view that the benefit of reciting the Qur'an could be transmitted to the dead.


Charity on behalf of the Deceased and Praying for him

Chapter 162
Charity on behalf of the Deceased and Praying for him

Allah, the Exalted, says:

"And those who came after them say: `Our Rubb! Forgive us and our brothers who have preceded us in Faith.''' (59:10)

948. `Aishah (May Allah be pleased with her) reported: A man said to the Prophet (PBUH): "My mother has died suddenly. I think that if she were able to talk (alive) she would have given in Sadaqah (charity). So, if I give Sadaqah now on her behalf, will she get the reward?'' The Messenger of Allah (PBUH) said, "Yes (she will be rewarded for that).''
[Al-Bukhari and Muslim].

Commentary: This Hadith plainly tells us that the reward of the alms given on behalf of a dead person reaches his or her soul just like the benefit of prayer, if accepted by Allah. Charity and prayer are two permissible forms of the transmission of blessing to the dead. But rites like `Qul' and `Chehlum' are all of Hindu origin to which the ignorant Muslims have taken a fancy. Similarly, Qur'an reading meant to transmit reward to a dead man's soul is against the Prophet's example. All such observances are of no use to the dead. Only scriptural channels can be beneficial to them and they are only two - prayer and charity. But only that charity counts which comes from the children of the dead and the Hadith too has specified it. Obviously, almsgiving by any other person than the offspring cannot be considered rightful or rewarding to the dead. For further detail, one can refer to Sheikh Al-Albani's Ahkam-ul-Janaiz.

949. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When a man dies, his deeds come to an end, except for three: A continuous charity, knowledge by which people derive benefit, pious son who prays for him.''
[Muslim].

Commentary: A thoughtful reflection of this Hadith will reveal that the three things are indeed man's own good deeds which somehow continue to exist even after his death. For example, places like a hospital, a mosque, a religious school and a well built by a man continue to operate like a trust as traces of his activity in earthly life. To quote the Qur'an:

"And We record that which they send before (them), and their traces [their footsteps and walking on the earth with their legs to the mosques for the five compulsory congregational prayers, Jihad (holy fighting in Allah's Cause) and all other good and evil they did, and that which they leave behind].'' (36:12)

So long as they exist and people benefit from them, the dead person will keep receiving his due reward. The same is pertinent to the spread of knowledge of Islamic disciplines to people's moral uplift. For instance, if during his lifetime he wrote books based on Qur'an and Hadith, advocated the cause of Islam, instructed lots of pupils in Islamic teachings, it will be counted as an unending activity on his part. To quote a Hadath: "The one who called people to adopt the Right Path will receive reward in the same measure as did those who had the good fortune to follow him.'' Besides, this Hadith tells us that, after his death, man will receive reward by the prayers of his virtuous children, and other Ahadith too confirm it. This clears the issue of sending the fruit of good works to the welfare of a dead person's soul. Charity or the continual charity from the part of a dead person himself, beneficial (religious) knowledge and prayer are acts of Sunnah under this rule. With the exception of these, all other deeds do not benefit the dead. However, if the dead person was under obligation to perform Hajj or had missed obligatory or vowed fasts, his heirs are commanded by the Prophet (PBUH) to observe them on his behalf. Because this is like a debt payable by the dead person and his heirs are under obligation to discharge it for him. Yet, this rule is inapplicable to other forms of physical worship.


Praising the Deceased

Chapter 163
Praising the Deceased

950. Anas (May Allah be pleased with him) reported: Some Companions happened to pass by a funeral procession (bier) and they praised him (the deceased). The Prophet (PBUH) said, "He will certainly enter it.'' Then they passed by another funeral procession and they spoke ill of the deceased. The Prophet (PBUH) said, "He will certainly enter it.'' `Umar bin Al-Khattab (May Allah be pleased with him) said: "(O Messenger of Allah,) what do you mean by `He will certainly enter it?'' He (PBUH) replied, "You praised the first person, so he will enter Jannah; and you spoke ill of the second person, so he will enter Hell. You are Allah's witnesses on earth.''
[Al-Bukhari and Muslim].

Commentary: The remarks of true believers reflect their righteousness and integrity of character. If they bear witness to the purity of heart of a man, he is sure to go to Jannah. And if they comment on the evil-mindedness of somebody, he is likely to be consigned to Hell-fire. Indeed, a believer never utters anything out of malice or self-conceit. There are some Ahadith which forbid us to speak ill of dead people. This rule applies to the true believers only. The Shari`ah argument is against it. However, we are allowed to talk about the misdeeds of the infidels and people who commit sins openly, disregarding the Shari`ah so that others may abstain from imitating a bad example.

951. Abul-Aswad (May Allah be pleased with him) reported: I came to Al-Madinah, and while I was sitting beside `Umar bin Al-Khattab, a funeral procession passed by. The people praised the deceased, and `Umar bin Al-Khattab said: "He will certainly enter it.'' Then another funeral procession passed by and the people praised the deceased. `Umar bin Al-Khattab (May Allah be pleased with him) said: "He will certainly enter it.'' A third funeral procession passed by and the people spoke ill of the deceased. He said: "He will certainly enter it.'' I (Abul-Aswad) asked: "O Amir Al-Mu'minin (i.e., Leader of the Believers)! What do you mean by `He will certainly enter it'?'' He replied: "I said the same as was said by the Prophet (PBUH). He (PBUH) said, `If four persons testify the righteousness of a Muslim, Allah will grant him Jannah.' We asked: `If three persons testify his righteousness?' He (PBUH) replied, `Even three'. Then we asked: `If two?' He (PBUH) replied, `Even two.' We did not ask him (regarding the testimony) of one.''
[Al-Bukhari].


Superiority of one who is Bereaved of his Infants

Chapter 164
Superiority of one who is Bereaved of his Infants

952. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Any Muslim who loses three children before they reach the age of maturity, will be granted Jannah by Allah, the Exalted, out of His Mercy for them.''
[Al-Bukhari and Muslim].

Commentary: Only that man who, patiently endures the loss of his children and expects reward from Allah, will enjoy this privilege. Allah will have mercy on such people and admit them into Jannah owing to His Mercy towards these innocent children.

953. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A Muslim whose three children die (in infancy) will not be touched by the Fire (of Hell) except for the fulfillment of Allah's Oath.''
[Al-Bukhari and Muslim].

[Allah's Oath here refers to His Ayah: "There is not one of you but will cross over it (Hell).'' (19:71) And the crossing will be across the `Bridge' set over the Hell.]

Commentary: On the Day of Resurrection all humans, believers and disbelievers, will have to cross the ``Sirat or Bridge'' set over the Hell. Believers will cross it in the twinkling of an eye according to their respective deeds done in the world. Some will cross it with the speed of lightning and the air, some like birds and some like fine horses, and others like riding-animals. All of them will cross the Bridge, some harmed and some unharmed. Some will fall into Hell but will later be removed from it through the Prophet's intercession. However, the infidels will not be able to cross it and all of them will land in Hell. The believer who loses three children and patiently endures this affliction, and anticipates Allah's reward in the Hereafter, will also be bound to cross the Bridge in deference to the Divine determination.

954. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: A woman came to the Messenger of Allah (PBUH) and said: "O Messenger of Allah! Only men benefit from your talks, so please fix a day for us, to teach us the knowledge which Allah has taught you.'' The Messenger of Allah (PBUH) fixed a day and directed them to assemble. When they gathered, the Prophet (PBUH) went to them and taught them what Allah had taught him. He (PBUH) then said, "Any woman of you whose three children die (in infancy) they will be a guard for her against Fire (of Hell).'' One of the women asked: "What if she loses two?'' The Messenger of Allah (PBUH) replied, "Even two.''
[Al-Bukhari and Muslim].

Commentary: Islam requires us to do all that we can to impart moral instruction and the knowledge of Islamic sciences to women. If a woman herself has received Islamic education and possesses the outlook of a true Muslim, the child's upbringing will automatically be fashioned on Islamic lines. The younger generation's aversion to Islam and its aloofness from Islamic manners can be referred in the first place to mother's lack of Islamic education. In fact, the Muslim women essentially need to be grounded in Islamic sciences so as to guide their children.


Weeping while Passing by the Graves of the Infidals

Chapter 165
Weeping while Passing by the Graves of the Infidals

955. Ibn `Umar (May Allah be pleased with them) reported: When the Messenger of Allah (PBUH) and his Companions reached Al-Hijr, the dwellings of the Thamud people, he admonished his Companions (saying), "Do not pass by these people who are being tormented, without weeping, lest the punishment should befall you as it had befallen them.''
[Al-Bukhari and Muslim].

Another narration is: Ibn `Umar (May Allah be pleased with them) said: When the Messenger of Allah (PBUH) passed near Al-Hijr, he said, "Do not enter without weeping, the dwellings of those who wronged themselves, lest the same chastisement should fall upon you as it had fallen upon them.'' Messenger of Allah (PBUH) then covered his head and sped up until he crossed the valley of the tormented people.

Commentary: The Thamud were the people to whose guidance Allah sent Prophet Salih. They lived between Al-Madinah and Syria. In 10 A.H. when the Prophet (PBUH) went to the Syrian border for the Tabuk expedition, he also passed through this ruined territory. This Hadith is related to the address which he gave to his Companions on the occasion. Here is an instruction that when we happen to pass through the territory of a nation destroyed in the past as a result of Divine wrath, we are advised to quicken one's pace. That is why we have been commanded to avoid the company of the corrupt and the wrongdoers, lest we meet their bad end, too. As the Qur'an says:

"And incline not toward those who do wrong, lest the Fire should touch you.'' (11:113)

May Allah save us from it!


Book Seven: The Book of Etiquette of Traveling

  • Chapter 166 : The Desirability of setting on a Journey on Thursday in the Early part of the Day
  • Chapter 167 : The Desirability of undertaking a Journey in a Group and appointing a Leader
  • Chapter 168 : Etiquette of Staying, Riding, Encamping at night and sleeping during the Journey and other matters relating to the Journey
  • Chapter 169 : Helping a Companion
  • Chapter 170 : Supplication at the time of Riding
  • Chapter 171 : Glorification of Allah by a Traveler while Ascending and Descending
  • Chapter 172 : Desirability of Supplications during the Journey
  • Chapter 173 : Supplication if one Fears (Harm)
  • Chapter 174 : Supplication on Alighting at a Halt
  • Chapter 175 : Desirability of returning Home soon after the Accomplishment of a Task
  • Chapter 176 : Desirability of returning Home by Day
  • Chapter 177 : Supplication at the time of returning Home and on seeing one's Hometown
  • Chapter 178 : Desirability of Entering the Mosque near one's Home upon returning from a Journey for offering two Rak'ah Prayer
  • Chapter 179 : Prohibiting Woman from Traveling Alone


The Desirability of setting on a Journey on Thursday in the Early part of the Day

Chapter 166
The Desirability of setting on a Journey on Thursday in the Early part of the Day

956. Ka`b bin Malik (May Allah be pleased with him) reported: The Prophet (PBUH) set out on Thursday for the expedition of Tabuk. He liked to set out on a journey on Thursdays.
[Al-Bukhari and Muslim]

957. Sakhr bin Wada`ah Al-Ghamidi (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "O Allah! Bless my people in the early part of the day (morning). Whenever he dispatched a detachment or an army-unit, he would dispatch it at the beginning of the day (soon after dawn). The narrator, Sakhr (May Allah be pleased with him) was a merchant, and he used to send off his merchandise at the beginning of the day. So his trade flourished and he made a good fortune.
[At-Tirmidhi and Abu Dawud].

Commentary: The two Ahadith mentioned above point out the desirability to set off on a journey, business trip, Jihad or anything like that.


The Desirability of undertaking a Journey in a Group and appointing a Leader

Chapter 167
The Desirability of undertaking a Journey in a Group and appointing a Leader

958. Ibn `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "Were people to know of what I know about the dangers of travelling alone, no rider would travel alone at night.''
[Al-Bukhari].

Commentary: Lonely travelling, whatever its form, is inadvisable at night and can cause many inconveniences. These inconveniences include deprivation of performing congregational prayers, feelings of loneliness and isolation and facing unexpected situations and damages. But the real reasons behind this prohibition, only Allah knows.

959. `Amr bin Shu`aib (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A single rider is (accompanied with) Satan and two riders are (accompanied with) two Satans. Three riders form a group.''
[At-Tirmidhi and Abu Dawud].

Commentary: The Hadith tells us that at least three travelling companions are preferable, because if they are only two, one may drop due to some emergency and the other will remain alone. One or two riders (travellers) have been described in the Hadith as "accompanied with Satan'' and this means that they can hardly escape the devil. However, in case of three, they will remain immune from satanic insinuations.

960. Abu Sa`id Al-Khudri and Abu Hurairah (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "When three persons set out on a journey, they should appoint one of them as their leader.''
[Abu Dawud].

Commentary: Choosing anyone as leader means that a journey should be undertaken under his guidance and instructions. This has many benefits. The person to be appointed as a leader over a group of travellers, should fulfill certain important conditions, including the fact that he should be the most knowledgeable in religious matters and travelling conditions.

961. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The best number of companions is four; the best detachment is four hundred and the best army is four thousand; and twelve thousand men will not be defeated as a result of smallness of number.''
[At-Tirmidhi and Abu Dawud].

Commentary: An army of twelve thousand soldiers, if endowed with strong faith and resolve, is enough to face even an army of large size. It cannot be defeated merely on the basis of number. Some other factors accounting for its defeat may not be ruled out, but it will not be overpowered for its small number.


Etiquette of Staying, Riding, Encamping at night and sleeping during the Journey and other matters relating to the Journey

Chapter 168
Etiquette of Staying, Riding, Encamping at night and sleeping during the Journey and other matters relating to the Journey

962. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said: "When you travel through green and lush land, give the camels their due from the ground, and when you travel through a dry and barren land, make them walk quickly lest their strength falters. When you encamp at night, keep away from the roads, for beasts pass there and they are the resort of insects at night.''
[Muslim].

Commentary: The Prophet (PBUH) commanded us to take care of the animal's food. If grass or fodder will not be available on the way, we should make our animal run faster so as to reach our destination before it is exhausted. There is another instruction for us. In case we happen to stop at night for rest, we should camp away from roads. This will ensure our safety as well as save others from inconvenience.

963. Abu Qatadah (May Allah be pleased with him) reported: When the Messenger of Allah (PBUH) encamped at night during a journey, he would lie down on his right side, and when he stayed a little before dawn he would raise his forearm and place his head on the palm of his hand.
[Muslim].

Commentary: This Hadith tells us that we should be fully regardful of the performance of prayer, particularly during a journey. We must make sure we perform prayer at the right time.

964. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Keep to travelling by night because the earth is folded (traversed more easily) during the night.''
[Abu Dawud].

Commentary: According to this Hadith, we should preferably travel at night, particularly late at night. After having slept in the first part of night, one feels invigorated and fresh enough to restart one's journey.

965. Abu Tha`labah Al-Khushani (May Allah be pleased with him) reported: Whenever the people encamped during the journey, they would disperse in the mountain passes and valleys. (When) the Messenger of Allah (PBUH) noticed this he said, "Your act of scattering in the mountain passes and valleys is from Satan.'' Afterwards the Companions kept close together whenever they encamped.
[Abu Dawud].

Commentary: This Hadith teaches us not to encamp during a journey but in the company of others in order to create an atmosphere of intimacy and cooperation.

966. Sahl bin `Amr known as Ibn Al-Hanzaliyyah reported: The Messenger of Allah (PBUH) happened to pass by a camel whose belly was sticking to its back (because of hunger), whereupon he said, "Fear Allah in respect of these dumb (animals). Ride them while they are fit, and slaughter them and eat their meat when they are fit.''
[Abu Dawud].

Commentary: This Hadith lays emphasis on taking care of animals. Because if they are hungry or you overload them, they will not be able to speak out their suffering to you in human language. You are, therefore, supposed to take care of their food and other requirements by yourself. In case you fail in your duty to them, Allah will take you to task. Moreover, eating the flesh of sick and lean animals is unhygienic and can endanger health. Whereas, the flesh of a healthy and robust animal gives energy and strength to human body.

967. Abu Ja`far `Abdullah bin Ja`far (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) made me ride behind him one day and confided something to me which I shall never disclose to anyone. (`Abdullah added:) He ((PBUH) preferred to screen himself from others when responding to the call of nature, either behind a wall or the trunk of a date-palm.
[Muslim].

Al-Barqani added: The Messenger of Allah (PBUH) entered an orchid belonging to an Ansari and saw there a camel. When it saw him, it began to groan and its eyes shed tears. The Messenger of Allah (PBUH) approached it and patted it on the hump and the base of its head until it quieted down. Then he (PBUH) asked, "Who is the owner of this camel? To whom does it belong?'' An Ansari youth stepped forward and said: "It is mine O Messenger of Allah!'' He said, "Do you not fear Allah in respect of this beast which Allah has placed in your possession? This camel is complaining to me that you starve it and put it to toil.''
[Abu Dawud].

Commentary: The Prophet (PBUH) must have divulged to the Companion something confidential for which he promised secrecy. Otherwise, anything concerning the Shari`ah should not be concealed. Second, if an animal has the capacity to carry two men, the rider can let another person sit behind him. Third, to give scanty food to an animal and to get the maximum out of it amounts to injustice. Islam disapproves this act. Animals should be fed to their fill and the amount of work to be done by them must also be not beyond their capacity. In this Hadith, there is a mention of the Prophet's miracle that a camel recognized him. He heard the camel's complaint and also understood it.

968. Anas (May Allah be pleased with him) reported: When we encamped, we would not offer (voluntary) prayers until we had unsaddled our beasts.
[Abu Dawud].

Commentary: It was the usual practice of the Companions that whenever they halted at some place to take rest during their journey, they would first of all unload their animals to give them comfort and relaxation. Then, they would perform voluntary Salat. This Hadith also throws light on the excellence of voluntary Salat in a journey.


Helping a Companion

Chapter 169
Helping a Companion

969. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: While we were travelling with the Messenger of Allah (PBUH), a rider came and began to stare on the right and on the left. The Messenger of Allah (PBUH) said, "He who has an extra mount should hand it over to one who has none, and he who possesses surplus provision, should give it to him who is without provision.'' He named various kinds of possessions until we began to think (realize) that none of us had any right to anything surplus.
[Muslim].

Commentary: Nowadays, there is a great fanfare of money-lending institutions such as cooperative societies, the financing companies and insurance companies which are apparently helpful in resolving the financial crises of people. But all are rooted in interest system which is rejected outright by Islam for its exploitative nature. These so-called cooperative institutions are indeed like blood-sucking leeches which ruin man. Islam, on the contrary, has given us a positive, simple and man-orientated formula of mutual cooperation. It teaches us that what can be spared should be given to those who need it. This obviates the chances of hoarding as well as the concentration of wealth in a few hands. No doubt, it is a moral instruction. But if Muslims, called as a single body, develop a true sense and awareness of it, wonderful results can accrue from it on a large social scale. What is more, the sublimity of man's Faith and moral behaviour stands on it. One who is indifferent to the perfection of Faith and morality may set it aside. But a man who rates Faith above everything can hardly afford to avoid putting this moral advice into practice.

970. Jabir (May Allah be pleased with him) reported: When the Messenger of Allah (PBUH) made up his mind to go in an expedition, he would say to us, "O Muhajirin and the Ansar! There are among you such people who have no property and no kinsfolk. Let everyone of you take along with him two or three men. None of us had a spare animal we took rides by turn.'' So I took two or three men with me and I rode my camel by turn equally with them.
[Abu Dawud].

Commentary: Firstly, this Hadith describes the Companions' condition in the early phase of Islam. Everybody participating in Jihad did not have an animal and so was the condition in respect of weapons and food. But in spite of all that, the Companions' zeal for Jihad was great. Secondly, it presents the picture of mutual cooperation which the Companions extended to one another. From all these considerations, emerges their distinctive place in history.

971. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to lag behind while travelling and urge the weak to walk quickly. He used to take up someone behind him and make supplication for him.
[Abu Dawud].

Commentary: This Hadith tells us that the leader of a group (or Amir) should, during a journey, remain in the rear instead of the vanguard so that he may prop up the weak people and provide succour to the resourceless ones. Furthermore, he is presumed to pray for such people as the blessing of his prayer is likely to make up their deficiencies.


Supplication at the time of Riding

Chapter 170
Supplication at the time of Riding

Allah, the Exalted, says:

"... and has appointed for you ships and cattle on which you ride. In order that you may mount on their backs, and then may remember the Favour of your Rubb when you mount thereon, and say: `Glory to Him Who has subjected this to us, and we could never have it (by our efforts). And verily, to Our Rubb we indeed are to return!''' (43:12-14)

972. Ibn `Umar (May Allah be pleased with them) reported: Whenever the Messenger of Allah (PBUH) mounted his camel for setting out on a journey, he would recite: "Allahu Akbar (Allah is Greatest),'' thrice. Then he (PBUH) would supplicate: "Subhanal-ladhi sakh-khara lana hadha, wa ma kunna lahu muqrinin, wa inna ila Rabbina lamunqalibun. Allahumma inna nas'aluka fi safarina hadh al-birra wat-taqwa, wa minal-`amali ma tarda. Allahumma hawwin `alaina safarana hadha, watwi `anna bu`dahu. Allahumma Antas-Sahibu fissafari, wal-Khalifatu fil-ahli. Allahumma inni a`udhu bika min wa`ta'is-safari, wa kaabatil-manzari, wa su'il-munqalabi fil-mali wal-ahli wal-waladi (Far removed from imperfection is the One Who has made this subservient to us, for we have no power to subjugate it, and certainly to our Rubb shall we return. O Allah, we ask You during this journey of ours for righteousness, piety and such deeds as are pleasing to You. O Allah, make easy for us this journey of ours and make the distance short for us. O Allah, You are our Companion during the journey and the Guardian of the family and the property in our absence. O Allah, I seek refuge in You from the hardships of travelling, unhappiness connected with ghastly scenes and evil turns in property and family).'' When he returned, he recited this supplication making addition of these words: "Ayibuna, ta'ibuna, `abiduna, li-Rabbina hamidun (We are those who return; those who repent; those who worship and those who praise our Rubb).''
[Muslim].

Commentary: This is a very comprehensive prayer. Man is not safe from dangers during a journey and in his absence, safety of his household may worry him, too. In this prayer, Allah is entreated to ensure the safety of the two in most effective words. And none can harm that person who comes under the Watch and Protection of Allah. This prayer should be recited upon starting on a journey as well as returning from it.

973. `Abdullah bin Sarjis (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) proceeded on a journey, he would seek refuge in Allah from the hardships of the journey, and against deviation after guidance, and against the supplication of the oppressed, and occurrences of unpleasant events in the family and property. He would say: "Allahumma inni a`udhu bika min wa`tha'is-safari, wa kaabatil-munqalabi, wal-hauri ba`dal-kauni, wa da`watil-mazlumi, wa su'il-manzari fil-ahli wal-mal.''
[Muslim].

Commentary: The Prophet (PBUH) sought Divine refuge against the supplication of the oppressed because Allah immediately responds to it. It is, therefore, imperative that if a man has wronged anybody, he should recompense his wrongdoing before embarking on a journey because the malediction of the wronged may invoke Divine wrath exposing the wrongdoer to a risky and troublesome journey.

974. `Ali bin Rabi`ah reported: In my presence, a beast was brought to `Ali bin Abu Talib (May Allah be pleased with him) for riding. When he put his foot in the stirrup, he said: "Bismillah (With the Name of Allah).'' When he had settled himself on its back he recited: "Al-hamdu lillahil-ladhi sakh-khara lana hadha, wa ma kunna lahu muqrinin, wa inna ila Rabbina lamunqalibun. (All praise belongs to Allah Who has made this subservient to us, for we had not the strength to overpower it; and to our Rubb shall we return).'' He then recited thrice: "Alhamdu lillah (Praise be to Allah),'' and then three times: "Allahu Abkar (Allah is Greatest).'' Then he said: "Subhanaka inni zalamtu nafsi faghfir li, innahu la yaghfirudh-dhunuba illa Anta (You are far removed from imperfection I have wronged myself, so forgive me, because none but You can forgive sins).'' Then he smiled. It was asked: "Why have you smiled, O Amir Al-Mu'minin (Leader of the Believers)?'' He replied: "I saw the Messenger of Allah (PBUH) doing as I have done. I (i.e., Ali) asked him (the Messenger of Allah (PBUH)) the reason for smiling. He (PBUH) said, `Your Rubb, Glorious is He, is pleased when His slave seeks His forgiveness. He (the slave) has firm faith that none except Allah Alone can forgive sins)'.''
[Abu Dawud and At-Tirmidhi].

Commentary: After putting his foot into the stirrup, the rider should say: "Bismillah (With the Name of Allah).'' When he sits firm on the animal, he should recite the prayers mentioned in this Hadith and utter the Glorification and Magnification of Allah - "Al-hamdu lillah (Praise be to Allah)'' and "Allahu Akbar (Allah is Greatest).'' Moreover, this Hadith sheds light on the tremendous and matchless fervour of the Companions to follow the Prophet (PBUH). This Du`a is not restricted to riding an animal, but includes all means of transportation, such as the plane, the train and the car.


Glorification of Allah by a Traveler while Ascending and Descending

Chapter 171
Glorification of Allah by a Traveler while Ascending and Descending

975. Jabir (May Allah be pleased with him) reported: When we ascended (a height) we would proclaim: "Allahu Akbar (Allah is Greatest),'' and when we descended (from the height) we would proclaim: "Subhan Allah (Allah is free from imperfection).'''
[Al-Bukhari].

976. Ibn `Umar (May Allah be pleased with them) reported: Whenever the Prophet (PBUH) and his army ascended a height, they would proclaim: "Allahu Akbar (Allah is Greatest),'' and when they climbed down, they would proclaim: "Subhan Allah (Allah is free from imperfection).''
[Abu Dawud].

Commentary: While climbing up some height, superiority complex may creep into man's head. He should, therefore, pronounce Divine greatness saying that Allah is the Greatest of all, the Most High, and all creatures are low and humble and subordinate to Him. On climbing down we should say: "Subhan Allah (Allah is free from imperfection).

977. Ibn `Umar (May Allah be pleased with them) reported: Whenever the Prophet (PBUH) returned from Hajj or `Umrah and ascended a height or hill, he would recite thrice: "Allahu Akbar (Allah is Greatest).'' Then he would say, "La ilaha ill-allahu wahdahu la sharika lahu, lahul-mulku, wa lahul-hamdu, wa Huwa `ala kulli shay'in Qadeer. Ayibuna ta'ibuna `abiduna li-Rabbina hamidun. Sadaq-Allahu wa`dahu, wa nasara `abdahu, wa hazamal-ahzaba wahdahu [None has the right to be worshipped but Allah, Who has no partner, to Whom the sovereignty belongs, to Whom all praise is due, and Who is Able to do all things. We are those who return (in safety), feel penitence, worship Allah, prostrate before our Rubb and praise Him. Allah has fulfilled His Promise, helped His slave (i.e., Muhammad (PBUH)) and He Alone vanquished the Clans].''
[Al-Bukhari and Muslim].

978. Abu Hurairah (May Allah be pleased with him) reported: A man said: "O Messenger of Allah (PBUH), I intend to set out on a journey, so counsel me.'' He (PBUH) said, "Fear Allah, and ascending towards the raised ground, you should recite: "Allahu Akbar (Allah is Greatest).'' When the man turned away, he (PBUH) said, "O Allah! Shorten the distance for him and make the journey easy for him.'' [At-Tirmidhi].

Commentary: Prior to setting out on a journey, a believer may ask pious people to supplicate for him. They, are required to pray sincerely for his safety, advise him, among other things, on religious matters not to be forgetful of the obedience and remembrance of Allah during the journey.

979. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: We accompanied the Prophet (PBUH) in a journey, and when we climbed up a height, we proclaimed aloud: "La ilaha illallah (There is no true god except Allah)'' and "Allahu Akbar (Allah is Greatest).'' The Prophet (PBUH) admonished us saying, "O people, take it easy. He Whom you are calling is not deaf or absent. He is with you (i.e., by His Knowledge), He is Hearing and He is Near.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that in the pronouncement of the fundamental testification of Islam: "La ilaha illallah (there is no true god except Allah)'' (Tahlil) - and His Magnification: "Allahu Akbar (Allah is Greatest)'' (Takbir) - the voices of the Companions became a bit louder during a journey. The Prophet (PBUH) disapproved of it and commanded them not to put themselves to hardship by remembering Allah in a loud voice, and directed to do that calmly in a dignified, low voice.


Desirability of Supplications during the Journey

Chapter 172
Desirability of Supplications during the Journey

980. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Three supplications are answered without doubt. The supplication of the oppressed, the supplication of the traveller, and the supplication of the parent for his son.''
[At-Tirmidhi and Abu Dawud].

Commentary: This Hadith mentions two dimensions of supplications. First, the supplication of an oppressed person will be in favour of the one who will come to his help and redress his complaint, whereas the oppressor will be hit by his supplication. Second, Allah also answers the father's supplication for his disobedient and impudent son; and the mother's supplication is even more effective than that of the father's because, as compared to him, she has more rights over them. Man should, therefore, restrain himself from disobeying parents, so that he may escape in both cases the supplication which is not rejected by Allah.


Supplication if one Fears (Harm)

Chapter 173
Supplication if one Fears (Harm)

981. Abu Musa Al-Ashari (May Allah be pleased with him) reported: When the Messenger of Allah (PBUH), feared mischief from a people, he would supplicate: "Allahumma inna naj`aluka fi nuhurihim, wa na`udhu bika min shururihim (O Allah! We ask You to face them, and seek Your Protection against their evil.''
[Abu Dawud and An-Nasa'i].

Commentary: Allah's Help, we are told, is a protection against all perils. Through this prayer we seek His Help with the conviction that the deceptions and designs of the infidels will turn back upon them.


Supplication on Alighting at a Halt

Chapter 174
Supplication on Alighting at a Halt

982. Khaulah bint Hakim (May Allah be pleased with her) reported: I heard the Messenger of Allah (PBUH) saying, "Whosoever alights somewhere and says: `A`udhu bikalimat-illahit-tammati min sharri ma khalaqa (I seek refuge with the Perfect Words of Allah from the evil of what He has created),' nothing will harm him until he leaves that place.''
[Muslim].

Commentary: Wherever and whenever we stay, be it at night or in the day time, for a short or long duration, we should recite this supplication.

983. Ibn `Umar (May Allah be pleased with them) reported: Whenever the Messenger of Allah (PBUH) set out on a journey, he would say by nightfall: "Ya ardu, Rabbi wa Rabbuk-illahu, a`udhu billahi min sharriki wa sharri ma fiki, wa sharri ma khuliqa fiki, wa sharri ma yadibbu `alaiki; a`udhu billahi min sharri asadin wa aswadin, wa minal-hayyati wal-`aqrabi, wa min sakinil-baladi, wa min walidin wa ma walad [O land, my Rubb and your Rubb is Allah, I seek refuge in Him from your evils, the evils of what you contain, the evils of what has been created in you, and the evils of what walks upon you. I seek refuge in Allah from lions, black serpents, scorpions and from the inhabitants of the place, and from the parent (i.e., Satan) and his offspring who inhabit a settlement (i.e., helpers from amongst the devils)].''
[Abu Dawud].

Commentary: This prayer teaches us to seek Allah's Protection against all animals and poisonous insects of the earth. Among earth dwellers are also included jinn. In the dark of night one may encounter harm from all such creatures. We are recommended to recite this prayer more at night, than during the day because harm is more likely to take place at night; and whoever recites this prayer with the firm belief that Allah will protect him against all the evils mentioned in the Hadith, Allah will surely protect him.


Desirability of returning Home soon after the Accomplishment of a Task

Chapter 175
Desirability of returning Home soon after the Accomplishment of a Task

984. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Travelling is a torment because it deprives a traveller of his food, drink and sleep. So when one of you has accomplished his purpose of journey, let him return home quickly.''
[Al-Bukhari and Muslim].

Commentary: Travel has been called a tribulation for two reasons. First, man misses his family, relatives and friends. Second, he also suffers its hardships and strains. He should, therefore, return home when the object of the journey is achieved.


Desirability of returning Home by Day

Chapter 176
Desirability of returning Home by Day

985. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When one of you stays away (from his family) for a long period of time, let him not surprise his family by night.''

In another narration, Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) prohibited us from coming back to our family at night.
[Al-Bukhari and Muslim].

986. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) would not come (back) to his family by night. He used to come in the morning or in the evening (before dark).
[Al-Bukhari and Muslim].

Commentary: When someone returns from a journey at night, he should better avoid joining his family. But this undesirable act in the sight of the Shari`ah is operative only in the case he arrives home without informing his family. By family, here is meant wife. However, there is nothing wrong with coming home with prior notification. Yet, if such a contact is not feasible, one's arrival at home at night will be considered as undesirable. But one can do so if necessity so demands.


Supplication at the time of returning Home and on seeing one's Hometown

Chapter 177
Supplication at the time of returning Home and on seeing one's Hometown

987. Anas (May Allah be pleased with him) reported: We returned with the Prophet (PBUH) from a journey; and when we entered the suburbs of Al-Madinah, he (PBUH) said: "Ayibuna, ta'ibuna, `abiduna, li-Rabbina hamidun (We are returning in safety, turning to our Rubb, worshipping Him and praising Him).'' He (PBUH) continued repeating these words till we entered Al-Madinah.
[Muslim].

Commentary: When one returns from a journey and sees his town's highlights, he should start reciting the invocation mentioned in this Hadith till he enters the city. These words express gratitude to Allah for safe return to one's hometown; they also express repentance, obedience and determination to worship Allah.


Desirability of Entering the Mosque near one's Home upon returning from a Journey for offering two Rak'ah Prayer

Chapter 178
Desirability of Entering the Mosque near one's Home upon returning from a Journey for offering two Rak'ah Prayer

988. Ka`b bin Malik (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) returned from a journey, he would proceed straight to the mosque and perform two Rak`ah of (optional) prayer.
[Al-Bukhari and Muslim].

Commentary: The performance of two Rak`ah of optional prayer is an expression of gratitude to Allah for the safe return. Naturally, one feels happy on such an occasion.


Prohibiting Woman from Traveling Alone

Chapter 179
Prohibiting Woman from Traveling Alone

989. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "It is not permissible for a woman who believes in Allah and the Last Day to make a journey of one day and night unless she is accompanied by a Mahram (husband or any other relative to whom she is prohibited to marry).''
[Al-Bukhari and Muslim].

Commentary: This Hadith offers four points. First, it mentions a twenty-four hour journey. `Ulama', therefore, say that the time limit matters little and the real point is the length of distance to be called journey. A woman is not allowed to travel unless she is accompanied by her husband or a Mahram.

Second, Hajj is obligatory on her provided she has no financial problem. If a woman has no husband or Mahram, Hajj is not obligatory on her. Neither can she go for Hajj with a group of women, whether for Hajj or any other purpose.

Third, the term Mahram, apart from husband, applies to all of her male siblingss whom she cannot marry; these include the father, the son, the brother, the nephew, the son-in-law and the foster-father. She cannot travel with anybody but with any of these.

Fourth, when she goes out, she should wear a Jilbab (an outer gown) dress so that no part of her body should be visible. Moreover, perfume must not be used by her, wearing perfume in public by women is tantamount to fornication, nor should the jingling of her ornaments be audible to others.

990. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said, "No man must not be alone with a woman except in the presence of her (Mahram). No woman should travel except in company of a (Mahram).'' A man said: "O Messenger of Allah! I have been enrolled for such and such expedition, and my wife left for Hajj.'' He (PBUH) said to him, "Go and perform Hajj with your wife.''
[Al-Bukhari and Muslim].

Commentary: This Hadih proves that under no circumstance woman may travel alone. The Shari`ah strictly bans a meeting of this kind between two opposite sexes. Even if nothing objectionable happens, a mischievous person may exploit this situation and talk about them slanderously. Families disregardful of Hijab provide instances of illicit relationship between a man and a woman related to each other.


Book Eight: The Book of Virtues

  • Chapter 180 : The Excellence of Reciting the Qur'an
  • Chapter 181 : Warning against forgetting the Qur'an
  • Chapter 182 : The Merit of Recitation of the Noble Qur'an in a Pleasant Voice
  • Chapter 183 : Inducement towards the Recitation of some Special verses and Surah of the Noble Qur'an
  • Chapter 184 : Desirability of Assembling for the Recitation of the Noble Qur'an
  • Chapter 185 : The Merits of Ablutions (Wudu')
  • Chapter 186 : The Excellence of Adhan
  • Chapter 187 : The Excellence of As-Salat (The Prayer)
  • Chapter 188 : Excellence of the Morning (Fajr) and 'Asr Prayers
  • Chapter 189 : The Excellence of Proceeding towards the Mosque Walking
  • Chapter 190 : The Excellence of waiting for As-Salat (The Prayer)
  • Chapter 191 : The Excellence of Performing Salat (Prayers) in Congregation
  • Chapter 192 : Urging to Observe 'Isha' and Fajr Prayers in Congregation
  • Chapter 193 : Strict Orders for Observance of Obligatory Salat
  • Chapter 194 : The Excellence of Standing in the First Row (In Salat)
  • Chapter 195 : The Excellence of Optional Prayers (Sunnah Mu'akkadah) along with the Obligatory Prayers
  • Chapter 196 : Emphasis on Performing two Rak'ah Sunnah before Dawn (Fajr) Prayer
  • Chapter 197 : Briefness to be Adopted in Performing the two Rak'ah Sunnah before Fajr Prayer, their time and the Surah to recite in them
  • Chapter 198 : Desirability of Lying down on one's right side after the Sunnah of Fajr Prayer
  • Chapter 199 : Sunnah of Zuhr Prayer
  • Chapter 200 : Sunnah of the 'Asr Prayer
  • Chapter 201 : Sunnah of the Maghrib Prayer
  • Chapter 202 : Sunnah of the 'Isha' Prayer
  • Chapter 203 : Sunnah of Friday Prayer
  • Chapter 204 : Desirability of offering Nawfil (Voluntary or Optional) Prayers at Home
  • Chapter 205 : Witr Prayer, its Time and Ruling
  • Chapter 206 : Merit of the (Optional) Duha (Forenoon) Prayer
  • Chapter 207 : Time for the Duha (Forenoon Optional) Prayer
  • Chapter 208 : Inducement to Perform Tahiyyat-ul-Masjid (Upon Entering the Mosque)
  • Chapter 209 : The Excellence of Performing two Rak'ah of Voluntary Prayer after Ablution
  • Chapter 210 : The Excellence of Friday Prayer
  • Chapter 211 : The Desirability of Prostrating out of Gratitude
  • Chapter 212 : Excellence of Standing in Prayer at Night
  • Chapter 213 : The Excellence of Optional (Tawawih) Prayer during Ramadan
  • Chapter 214 : The Superiority of Lailat-ul-Qadr (the Night of Decree)
  • Chapter 215 : The Excellence of using Miswak (Tooth-Stick)
  • Chapter 216 : The Excellence and Obligation of the Payment of Zakat
  • Chapter 217 : The Excellence of Observing Saum (Fasts) during Ramadan
  • Chapter 218 : The Excellence of Spending out Charity during Ramadan
  • Chapter 219 : The Prohibition of Observing Saum (Fasting) after the Middle of Sha'ban
  • Chapter 220 : Supplication at the Sight of the Crescent (At the outset of Every Lunar Month)
  • Chapter 221 : Merit of Suhur (Predawn meal in Ramadan) and the Excellence of Delaying having it till before Dawn
  • Chapter 222 : The Superiority of Hastening to Break the Fast, and the supplication to say upon Breaking it
  • Chapter 223 : Safeguarding As-Saum (The Fast)
  • Chapter 224 : Matters relating to As-Saum (Fasting)
  • Chapter 225 : The Excellence of Observing Saum (Fasting) in the months of Muharram and Sha'ban and the Secred Months
  • Chapter 226 : The Excellence of As-Saum (The Fast) during the first ten Days of Dhul-Hijjah
  • Chapter 227 : The Excellence of Observing Saum on the Day of 'Arafah, 'Ashura' and Tasu'a (i.e., 9th of Muharram)
  • Chapter 228 : The Desirability of Fasting six Days in the Month of Shawwal
  • Chapter 229 : The Desirability of Observing Saum (Fasting) on Monday and Thursday
  • Chapter 230 : The Desirability of Observing Three Days of Fasting in Every Month
  • Chapter 231 : The Merit of Providing something to the Person Observing Saum (Fasting) for breaking the Fast


The Excellence of Reciting the Qur'an

Chapter 180
The Excellence of Reciting the Qur'an

991. Abu Umamah (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "Read the Qur'an, for it will come as an intercessor for its reciters on the Day of Resurrection.''
[Muslim].

Commentary: This Hadith tells the excellence of reciting the Qur'an and acting upon its injunctions. Intercession (in this Hadath) means that the Qur'an will be endowed with the power of speech by Allah and it will request Allah to forgive the sins of its reciters who acted upon its teachings. Allah will accept the request of the Qur'an, as signified in other Ahadith.

992. An-Nawwas bin Sam`an (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "The Qur'an and its people who applied it, will be brought on the Day of Resurrection preceded with Surat Al-Baqarah and Surat Al-`Imran arguing on behalf of those who applied them.''
[Muslim].

Commentary: This Hadith means that on the Day of Requital, the Qur'an, with Surat Al-Baqarah and Al-`Imran in the forefront, will intercede before Allah for those who used to recite and act upon them in the life of the world.

993. `Uthman bin `Affan (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The best amongst you is the one who learns the Qur'an and teaches it.''
[Al-Bukhari].

994. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) said, "The one who is proficient in the recitation of the Qur'an will be with the honourable and obedient scribes (angels) and he who recites the Qur'an and finds it difficult to recite, doing his best to recite it in the best way possible, will have a double reward.''
[Al-Bukhari and Muslim].

Commentary: Proficient here means one who reads the Qur'an in accordance with the rules of "Ilm At-Tajwid'' (the science of the recitation of the Qur'an) as is evidenced from the words of Imam Bukhari's narration and the title given to the chapter.

This Hadith also highlights the merit of the reader of the Qur'an who does not know `Ilm At-Tajwid, and for that reason cannot read it fluently. But in spite of this, he reads it with great effort. He will be given double reward, one for the difficulty encountered in reciting it, and another for reading it. Safratun translated in the Hadith as scribes (angels) mean the angels that convey the Wahy (Revelation) to the Messenger of Allah. Imam Bukhari has taken it to mean "one who makes reconciliation''. The angels who bring Wahy and chastisement from Allah.

995. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The believer who recites the Qur'an is like a citron whose fragrance is sweet and whose taste is delicious. A believer who does not recite the Qur'an is like a date-fruit which has no fragrance but has a sweet taste. The hypocrite who recites the Qur'an is like a colocynth whose fragrance is so sweet, but its taste is bitter. The hypocrite who does not recite the Qur'an is like basil which has no fragrance and its taste is bitter.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that a believer who recites the Qur'an and acts upon it, Allah will grant him a high rank. He is loved by Allah and also enjoys public esteem. The believer who does not recite it but acts upon its teachings is also loved by Allah and people. The hypocrite who recites the Qur'an to have a good show has an evil and dark mind. Last of all comes that hypocrite who does not recite the Qur'an and has a dark mind and appearance.

996. `Umar bin Al-Khattab (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Verily, Allah elevates some people with this Qur'an and abases others.''
[Muslim].

Commentary: Only such people will be elevated who act upon the teachings of the Qur'an and abstain from what is forbidden by Allah. The Muslims of the early centuries of Islam were blessed with great honour by Allah because they loved and applied the Qur'an. Because of this meaningful attachment with the Qur'an, they made great achievements in religious and worldly spheres. Those who neglected the teachings of Islam will be disgraced and humiliated. May Allah guide and enable us to re-establish our contact with the Qur'an so that we can regain our past glory. Exaltation and humiliation mentioned in the Hadith is bound to happen in both this life and the Hereafter.

997. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said: "Envy is justified in regard to two types of persons only: a man whom Allah has given knowledge of the Qur'an, and so he recites it during the night and during the day; and a man whom Allah has given wealth and so he spends from it during the night and during the day.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has been quoted before at two places (see Hadith No. 572). It has been repeated here to bring into prominence the merit of reciting the Qur'an. Refer to the Commentary on Hadith No. 544.

998. Al-Bara' bin `Azib (May Allah be pleased with them) reported: A man was reciting Surat Al-Kahf, and a horse was tied with two ropes beside him. As he was reciting, a cloud overshadowed him, and as it began to come nearer and nearer, the horse began to trample voilently. The man came to the Messenger of Allah (PBUH) in the morning and mentioned the incident to him. He (PBUH) said, "That was tranquillity which descended as a result of the recitation of the Qur'an.''

Commentary: This Hadith brings out two points. Firstly, the excellence of Surat Al-Kahf (The Cave, No. 18). Secondly, the descending of tranquillity from Allah on the pious persons. The appearance of a cloud for the tranquillity of heart on the recitation of the Qur'an is a supernatural event (miracle) to which a pious man does not make any contribution. It entirely depends on the Will of Allah.

999. Ibn Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whoever recites a letter from the Book of Allah, he will be credited with a good deed, and a good deed gets a ten-fold reward. I do not say that Alif-Lam-Mim is one letter, but Alif is a letter, Lam is a letter and Mim is a letter.''
[At-Tirmidhi].

Commentary: This Hadith urges us to recite the Qur'an and also mentions the great reward for reciting it.

1000. Ibn `Abbas (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "He who does not memorize any part from the Qur'an he is like the ruined house.''
[At-Tirmidhi].

Commentary: This Hadith means that the heart of that Muslim is devoid of grace of spiritualism and Grace of Allah who does not remember by heart any portion of the Qur'an, in the same way as a deserted house is deprived of inhabitants and Blessings of Allah. What we learn from this is that every Muslim must remember some portion of the Qur'an so that he is safe from the admonition mentioned in this Hadith.

1001. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The one who was devoted to the the Qur'an will be told on the Day of Resurrection: `Recite and ascend (in ranks) as you used to recite when you were in the world. Your rank will be at the last Ayah you recite.'''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith mentions the merit of those who commit the Qur'an (whole or part thereof) to memory (Huffaz). The word `ascend' here means to rise in ranks in the Jannah. The more one remembers the Qur'an, the more clear and distinct is his recitation of it, the higher would be the status that he will go on attaining through its blessings. Thus, this Hadith provides inducement for the remembrance of the Qur'an and tells us that its frequent recitation is a means to attain higher ranks in Jannah.


Warning against forgetting the Qur'an

Chapter 181
Warning against forgetting the Qur'an

1002. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Read the Qur'an regularly. By the One in Whose Hand Muhammad's soul is, it escapes from memory faster than a camel does from its tying ropes.''
[Al-Bukhari and Muslim].

Commentary: To safeguard the Qur'an means to recite it regularly, because if one fails to do so, he tends to forget it quickly. In the absence of regular recitation, one is bound to forget it more quickly than a camel breaks loose bound with. The breaking loose by the camel to liberate itself is a simile for the quick process of forgetting.

1003. Ibn `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said: "The parable of one who knows the Qur'an by heart is as the parable of an owner of hobbled camel. If he remains vigilant, he will retain it; and if he neglects it, it will go away.''
[Al-Bukhari and Muslim].

Commentary: This Hadith repeats the subject mentioned above. The person who memorizes the entire Qur'an or a portion of it, if he recites it regularly, he will retain it; otherwise, it will start slipping from his memory.


The Merit of Recitation of the Noble Qur'an in a Pleasant Voice

Chapter 182
The Merit of Recitation of the Noble Qur'an in a Pleasant Voice

1004. AbU Hurairah (May Allah be pleased with him) reported: I heard the Messenger of AllAh (PBUH) saying, "Allah does not listen so attentively to anything as He listens to the recitation of the Qur'an by a Prophet who recites well with a melodious and audible voice.''
[Al-Bukhari and Muslim].

Commentary: "Allah does not listen so attentively'' has two- fold meanings. First, Allah's acceptance and pleasure. Second, His attribute of Hearing. One must have to believe in it although we can neither describe it nor compare it with anything else.

The word "Ghina'' is ordinarily used for singing but here it means the recitation which is done in accordance with the principles of Tajwid and in a beautiful voice.

Thus, this Hadith induces us to recite the Qur'an properly with nice feeling and voice.

1005. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to him, "You have been given a Mizmar (sweet melodious voice) out of the Mazamir of Prophet Dawud (David).''
[Al-Bukhari and Muslim].

Commentary: Mizmar means flute but here it stands for tune and sweet voice. In the phrase Al-Dawud (PBUH), translated here `the family of Dawud,' the word Al is superfluous and what is in fact meant is Prophet Dawud. In any case, sweet voice is a gift of Allah Who grants it to whom He likes. Lucky indeed are those who are granted this gift and they go about using it to invite people to the religion of Allah.

1006. Al-Bara' bin `Azib (May Allah be pleased with them) reported: I heard the Prophet (PBUH) reciting Surat Wat-Teen Waz-Zaitun (Chapter 95) during the `Isha' prayer. I have never heard anyone reciting it in a more beautiful voice than his.
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that, like other virtues and qualities, the Prophet (PBUH) was also granted a sweet voice by Allah.

1007. Abu Lubabah Bashir bin `Abdul-Mundhir (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who does not recite the Qur'an in a pleasant tone is not of us.''
[Abu Dawud].

Commentary: The words "is not of us'' mean that he is not following the way of the Prophet (PBUH) with regard to the recitation of the Qur'an. This Hadith also induces us to recite the Qur'an with a sweet and touching voice because the recitation of the Qur'an in this manner enhances its effect.

1008. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said to me, "Recite the Qur'an to me.'' I said: "O Messenger of Allah! Shall I recite it to you when it was revealed to you?'' He (PBUH) said, "I like to hear it from others.'' Then I began to recite Surat An-Nisa'. When I reached the Ayah: `How will it be when We shall bring a witness from every people and bring you as a witness against them?' (Having heard it) he said, "Enough! Enough!'' When I looked at him, I found his eyes were overflowing with tears.
[Al-Bukhari and Muslim].

Commentary: This Hadith has been mentioned earlier. It is repeated here for the reason that it has an aspect of honour for the people who are blessed with knowledge and grace. Moreover, it stresses the need to hear the recitation of the Qur'an from those who recite it beautifully in order to contemplate over it, as was done by the Prophet (PBUH) himself.


Book Nine: The Book of I'tikaf

  • Chapter 232 : I`tikaf (Seclusion in the Mosque) in the Month of Ramadan


Book Ten: The Book of Hajj

  • Chapter 233 : The Obligation of Hajj (Pilgrimage) and its Excellence


The Obligation of Hajj (Pilgrimage) and its Excellence

Chapter 233
The Obligation of Hajj (Pilgrimage) and its Excellence

Allah, the Exalted, says:

"And Hajj (pilgrimage to Makkah) to the House (Ka`bah) is a duty that mankind owes to Allah, those who can afford the expenses (for one's conveyance, provision and residence); and whoever disbelieves [i.e., denies Hajj (pilgrimage to Makkah), then he is a disbeliever of Allah], then Allah stands not in need of any of the `Alamin (mankind, jinn and all that exists).'' (3:97)

1271. Ibn `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "(The superstructure of) Islam is based on five (pillars), testifying the fact that La ilaha illallah wa anna Muhammad-ar-Rasul-ullah [there is no true god except Allah, and Muhammad ((PBUH)) is the Messenger of Allah], establishing As-Salat (the prayers), paying Zakat (poor due), the pilgrimage to the House [of Allah (Ka`bah)], and the Saum (fasting) during the month of Ramadan.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has been mentioned earlier. Here it has been repeated in support of the obligation of the fourth pillar of Islam. Thus, Hajj is compulsory for a person who fulfills the qualifications required for it and has the means for it.

1272. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) delivered a Khutbah and said, "O people! Hajj (pilgrimage to the House of Allah) has been made incumbent upon you, so perform Hajj.'' A man inquired: "O Messenger of Allah, is it prescribed every year?'' He (PBUH) remained silent till the man repeated it thrice. Then he (PBUH) said, "Had I replied in the affirmative, it would have surely become obligatory, and you would not have been able to fulfill it.'' Afterwards he said, "Do not ask me so long as I do not impose anything upon you, because those who were before you were destroyed on account of their frequent questioning and their disagreement with their Prophets. So when I order you to do something, do it as far as you can; and when I forbid you from doing anything, eschew it.''
[Muslim].

Commentary: This Hadith brings out the following points:

1. Hajj is compulsory once in a lifetime for those who have the means for it.

2. Unnecessary questioning is disliked.

3. Those who believe in Allah and His Prophet (PBUH) are required to do what they are ordained and abstain from what they are forbidden.

1273. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) was asked: "Which deed is the best?'' He (PBUH) replied, "Faith in Allah and His Messenger.'' Then he was asked: "What is next?'' He replied, "Jihad (holy fighting) in the Cause of Allah.'' Then he was asked, "What is after that?'' He (PBUH) replied, "Hajj Mabrur (an accepted pilgrimage).''
[Al-Bukhari and Muslim].

Commentary: This Hadith points out the fact that Hajj is one of the most prominent religious acts, provided it is done sincerely and keeping oneself away from sins. Some people have interpreted the word "Hajj Mabrur'' as an accepted Hajj. They say that the sign of an accepted Hajj is that one becomes a true worshipper of Allah, which he was previously not.

1274. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whoever performs Hajj (pilgrimage) and does not have sexual relations (with his wife), nor commits sin, nor disputes unjustly (during Hajj), then he returns from Hajj as pure and free from sins as on the day on which his mother gave birth to him.''
[Al-Bukhari and Muslim].

Commentary: The true meanings of "Rafath'' sexual intercourse but it also signifies obscene and frivolous talk and the expression of sexual desire to one's wife. Since coition with one's wife is forbidden during Hajj, so conversation with her on this subject or talking for amusement is also disliked. "Fisq'' means disobedience of Allah and quarrelling with people. One must avoid both of them during Hajj. The Hajj which is performed with all these restrictions, has the merit that one is totally purged of sins. But this purification is from sins which come in the category of minor sins and which relate to the Rights of Allah. Major sins relating to the Rights of Allah and lapses in respect of the rights of people are not pardoned without sincere repentance and compensation to the aggrieved.

1275. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "(The performance of) `Umrah is an expiation for the sins committed between it and the previous `Umrah; and the reward of Hajj Mabrur (i.e., one accepted) is nothing but Jannah.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that the merit of `Umrah is that it is an expiation for sins. But this, too, is an expiation for minor sins. `Umrah includes assuming Ihram, circumambulation of Ka`bah, going between As-Safa and Al-Marwah and Halq or Taqsir (shaving of head or cutting hair). Whether or not `Umrah is an obligation like Hajj is arguable among the `Ulama'. Some people, like Imam As-Shafi`i, hold that it is obligatory; others like the followers of the Hanafi school of thought regard it Sunnah Mu`akkadah; still others think it to be voluntary. Imam Al-Bukhari is inclined to the first view which is also endorsed by sayings of some Companions of the Prophet (PBUH) about which some Muhaddithun (scholars of Hadith) have even claimed that these sayings are Mausul, the chain of narrators reaches up to the Prophet (PBUH). (For further details, please see Fath Al-Bari.) Otherwise, the view that it is non-obligatory is preferable.

1276. `Aishah (May Allah be pleased with her) reported: I said: "O Messenger of Allah! We consider Jihad as the best deed, should we not then go for Jihad?'' The Messenger of Allah (PBUH) said, "The best Jihad for you women is Hajj Mabrur (i.e., one accepted by Allah).''
[Al-Bukhari].

Commentary: In ordinary circumstances, Hajj is the best of Jihad for women because in Islam, politics, economy, government, military affairs etc., come in the purview of men and men alone. Women are exempted from all such matters. However, in case of war, if the need arises, women can be engaged for supply of food, first-aid of the wounded etc., on the internal front, provided they can do such works without crossing the bounds of the Islamic-type veil. But imparting military training to women and dispatching them to war front are sheer imitations of the western nations for which there is no scope in the teachings of Islam. This Hadith also confirms this view.

1277. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) said, "There is no day on which Allah sets free more slaves from Hell than He does on the Day of `Arafah.''
[Muslim].

Commentary: Almighty Allah emancipates most of His slaves, both men and women from the Hell-fire on this great day. Millions of pilgrims, who by virtue of their sincere repentance, try to seek the Pleasure of Allah certainly stand to earn Allah's Pardon for their sins and thereby emancipation from the Hell-fire. May Allah grant us this grace of His.

1278. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said, "(The performance of) `Umrah during Ramadan is equal to Hajj (pilgrimage).'' Or said, "Equal to the performance of Hajj with me.''
[Al-Bukhari and Muslim].

Commentary: "Equal to the performance of Hajj'' means the return and reward to which Hajj is eligible. It does not mean that it will serve as a substitute for Hajj and absolve one from the need to perform it. This distinction of `Umrah in the month of Ramadan is perhaps for the reason, that in this way two acts of worship are combined at one time.

1279. Ibn `Abbas (May Allah be pleased with them) reported: A woman came to the Messenger of Allah (PBUH) and said, "Allah's obligation upon His slaves has become obligatory on my father in his old age. My father is very old and incapable of riding. May I perform Hajj on his behalf?'' He (PBUH) said, "Yes.''
[Al-Bukhari and Muslim].

Commentary: "Hajj has become obligatory in old age'' means that when Allah has made Hajj obligatory, at that time, her father had attained old age, or he came to possess the means in his old age which made him liable for Hajj, but he is not capable of undertaking the journey because of his poor health. In such cases, the Prophet (PBUH) has granted them permission for Hajj by representation. But we learn from other Ahadith that Hajj by representation can only be done through such a person who has already performed Hajj. Similarly, if a person of means dies without performing Hajj, it is essential that Hajj is performed on his behalf; otherwise, he will be answerable for this omission. This formula does not apply to parents who have died in poverty because they were not liable for it. If someone does it for the sake of reward, he will be hopefully granted the reward of voluntary Hajj.

1280. Laqit bin `Amir (May Allah be pleased with him) reported: I came to the Prophet (PBUH) and said: "My father is a very old man and does not have strength to perform Hajj (pilgrimage) or `Umrah or to undertake the journey.'' The Prophet (PBUH) said, "Perform Hajj and `Umrah on behalf of your father.''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith also stresses permission of Hajj through representative where a person is not capable of doing it. But it is essential that the representative agent must have already performed Hajj.

1281. As-Sai'b bin Yazid (May Allah be pleased with him) reported: I was seven years old when I was taken to perform Hajj (pilgrimage). This was during the time the Messenger of Allah (PBUH) performed the Hajjat-ul-Wada` (Farewell Pilgrimage).

[Al-Bukhari].

Commentary: This Hadith points out the fact that it is permissible to take children to Hajj. The reward of their Hajj will be given to their parents. But when after attaining maturity the child becomes liable for Hajj, it will be necessary for him to perform it again because the one he has performed in childhood, will not be sufficient for him. The reason behind taking children to Hajj is to teach them how to perform this obligation.

1282. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) came across a caravan at Ar-Rauha' and asked who the people in the caravan were. They replied that they were Muslims. They asked: "Who are you?'' He (PBUH) said, "I am the Messenger of Allah.'' Then a woman lifted up a boy to him and asked: "Would this child be credited with having performed the Hajj (pilgrimage)?'' Whereupon he (PBUH) said, "Yes, and you will have a reward.''
[Muslim].

1283. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) performed the pilgrimage on an unsaddled camel which also carried his provisions (i.e., his Zamilah).
[Al-Bukhari].

Commentary: "Zamilah'' is a mount like a horse, mule etc., on which luggage is loaded while travelling. What it means here is that the Prophet (PBUH) travelled for Hajj on such a mount on which he kept his provision for the journey also. In other words, it was his Zamilah as well. This incident happened during Hajjat-ul-Wada` (Farewell Pilgrimage). This Hadith shows the Prophet's total humility and humbleness and his disregard for the life of the world.

1284. Ibn `Abbas (May Allah be pleased with them) reported: Ukaz, Mijannah and Dhul-Majaz were markets during the pre-Islamic period. The Companions disliked trading there till the following Ayat of the Noble Qur'an were revealed: "There is no sin on you if you seek the Bounty of your Rubb (during pilgrimage by trading)...'' (2:198)
[Al-Bukhari].

Commentary: The Companions of the Prophet (PBUH) considered trade and commerce during the months of Hajj as sinful because they thought that trade had a sort of resemblance with the bazaars which were arranged on the occasion of Hajj in the pre-Islamic period. Through the Ayah quoted in this Hadith, Almighty Allah removed their misunderstanding. Therefore, trade and commerce on this occasion do not violate the Hajj and `Umrah. This is however, only a permission. If one wants to earn reward in the Hereafter through his utmost devotion to Allah, it is more meritorious to avoid commercial activities and wholeheartedly concentrate on the remembrance of Allah and His worship.


Book Eleven: The Book of Jihad

  • Chapter 234 : Obligation of Jihad
  • Chapter 235 : Martyrdom without Fighting
  • Chapter 236 : The Merit of Emancipation of Slaves
  • Chapter 237 : The Excellence of Kind Attitude towards Slaves
  • Chapter 238 : The Merit of the Dutiful Slave
  • Chapter 239 : The Excellence of Worship in the time of Tribulations
  • Chapter 240 : Excellence of Fair Bargaining and Matters Relation to it


Obligation of Jihad

Chapter 234
Obligation of Jihad

Allah, the Exalted, says:

"And fight against the Mushrikun (polytheists, pagans, idolaters, disbelievers in the Oneness of Allah) collectively as they fight against you collectively. But know that Allah is with those who are Al-Muttaqun (the pious).'' (9:36)

"Jihad (holy fighting in Allah's Cause) is ordained for you (Muslims) though you dislike it, and it may be that you dislike a thing which is good for you and that you like a thing which is bad for you. Allah knows but you do not know.'' (2:216)

"March forth, whether you are light (being healthy, young and wealthy) or heavy (being ill, old and poor), and strive hard with your wealth and your lives in the Cause of Allah'' (9:41)

"Verily, Allah has purchased of the believers their lives and their properties for (the price) that theirs shall be the Jannah. They fight in Allah's Cause, so they kill (others) and are killed. It is a promise in truth which is binding on Him in the Taurat (Torah) and the Injeel (Gospel) and the Qur'an. And who is truer to his covenant than Allah? Then rejoice in the bargain which you have concluded. That is the supreme success.'' (9:111)

"Not equal are those of the believers who sit (at home), except those who are disabled (by injury or are blind or lame), and those who strive hard and fight in the Cause of Allah with their wealth and their lives. Allah has preferred in grades those who strive hard and fight with their wealth and their lives above those who sit (at home). Unto each, Allah has promised good (Jannah), but Allah has preferred those who strive hard and fight, above those who sit (at home) by a huge reward. Degrees of (higher) grades from Him, and forgiveness and mercy. And Allah is Ever Oft-Forgiving, Most Merciful.'' (4:95, 96)

"O you who believe! Shall I guide you to a trade that will save you from a painful torment? That you believe in Allah and His Messenger (Muhammad (PBUH)), and that you strive hard and fight in the Cause of Allah with your wealth and your lives: that will be better for you, if you but know! (If you do so) He will forgive you your sins, and admit you into Gardens under which rivers flow, and pleasant dwellings in `Adn (Eden) Jannah; that is indeed the great success. And also (He will give you) another (blessing) which you love: help from Allah (against your enemies) and a near victory. And give glad tidings (O Muhammad (PBUH)) to the believers.'' (61:10-13)

The Qur'anic Ayat relating to the subject under study are many. The Ahadith are also many; these include the following:

1285. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) was asked, "Which deed is the best?'' He (PBUH) replied, "Faith in Allah and His Messenger.'' He (PBUH) was asked, "What is next?'' He (PBUH) replied, "Jihad (holy fighting) in the Cause of Allah.'' Then he was asked: "What is after that (in goodness)?'' He (PBUH) replied, "Hajj Mabrur (which is accepted by Allah).''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. See Hadith No. 1274. Different acts have been regarded more meritorious in different Ahadith. For this reason, some scholars have performed the justification that the word mun "whoever" is the keynote in such cases. That is, such and such acts come in the category of eminent acts or they have been mentioned with reference to circumstances and time or place. For instance, at certain times or at certain places or for certain persons, performing Salat in the early prescribed hours is more meritorious, or Hajj through representative or Jihad is more meritorious, etc.

Some scholars are of the opinion that the eminence of different acts has been stressed keeping the person addressed in view.

Linguistically, the word "Hajj'' means `journey to a place one respects'. Technically, it means `journey to Makkah in order to perform the pilgrimage rites.' The word "Mabrur'' is from "Birr'' meaning obedience, piety, but it signifies here an act which is done sincerely without committing a sin.

1286. Ibn Mas`ud (May Allah be pleased with him) reported: I asked the Messenger of Allah (PBUH): "Which action is dearest to Allah?'' He (PBUH) replied, "Performing As-Salat (the prayer) at its earliest fixed time.'' I asked, "What is next (in goodness)?'' He (PBUH) said, "Kindness towards parents.'' I asked, "What is next (in goodness)?'' He (PBUH) said, "To participate in Jihad in the Cause of Allah.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. See Commentary on Hadith No. 314. Imam Al-Qurtubi says that the Prophet (PBUH) mentioned these three deeds in particular because they are a sign of other acts of obedience: He who does not perform a Salat at its prescribed time, without a valid reason, and delays it beyond its time fully knowing that it is a light but highly rewarding work, is bound to neglect the other good deeds. One who does not treat his parents nicely, in spite of the fact that he knows that they have the greatest rights over him, is bound to treat others in a less proper manner. One who does not wage Jihad against the infidels, although he is fully aware that they are avowed enemies of Islam, he is bound to give up fighting against people who are guilty of sins and impious acts.

1287. Abu Dharr (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) was asked: "Which deed is the best?'' He (PBUH) replied, "Faith in Allah and Jihad (fighting, struggle) in the Cause of Allah.''
[Al-Bukhari and Muslim].

1288. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Verily! Setting out in the early morning or in the evening in order to fight in Allah's way is better than the world and what it contains.''
[Al-Bukhari and Muslim].

Commentary: The Hadith points out the superiority of fighting in the way of Allah. The moment one fights for Allah's sake, be it in the early morning or the evening, is better than the world and all that is in it. The reason is that the world as well as what it possesses is transitory while the Hereafter is everlasting and eternal. Can anything that is temporary be a match for what is eternal?

1289. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: A man came to the Messenger of Allah (PBUH) and said, "Who is the best among men?'' He (PBUH) replied, "A believer who strives in the way of Allah with his wealth and life.'' The man asked again, "Who is next to him (in excellence)?'' He (PBUH) said, "Next to him is a man who is engaged in worshipping his Rubb in a mountain valley, leaving the people secure from his mischief.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. See Commentary on Hadith No. 598. It brings into focus the excellence of fighting Jihad with one's wealth and life for the sake of Allah.

1290. Sahl bin Sa`d (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Observing Ribat (e.g., guarding the Islamic frontier for the sake of Allah) for a single day is far better than the world and all that it contains. A place in Jannah as small as the whip of your horse is far better than the world and all that it contains. An endeavour (fighting) in the Cause of Allah in the evening or in the morning is far better than the world and all that it contains.''
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the excellence of observing Ribat and fighting in the way of Allah. It also highlights the insignificance of this world and the great reward in the Hereafter which can be attained through Jihad.

1291. Salman (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) as saying, "Observing Ribat in the way of Allah for a day and a night is far better than observing Saum (fasting) for a whole month and standing in Salat (prayer) in all its nights. If a person dies (while performing this duty), he will go on receiving his reward for his meritorious deeds perpetually, and he will be saved from Al-Fattan.''
[Muslim].

Commentary: Good deeds of a Muslim who dies or is martyred on the frontier will perpetuate and will be credited to his account till the Day of Resurrection; and like all other martyrs, sustenance will be provided to him even after his death. As Allah says: `Think not of those as dead who are killed in the way of Allah. Nay, they are alive, with their Rubb, and they have provision.'' (3:169)

"Al-Fattan'' here means the interrogation in the grave which the two angels Munkir and Nakir will conduct. Some religious scholars said that observing Ribat serves the purpose of safeguarding religion and Islamic territories, while fastings benefit only the person who performs it. It is a great trial which everyone has to pass through. But one who is a Mu'min (righteous Muslim) goes through it easily by the Grace of Allah, and he will answer all the questions correctly.

1292. Fadalah bin `Ubaid (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The actions of every dead person come to a halt with his death except the one who is on the frontier in Allah's way (i.e., observing Ribat). This latter's deeds will be made to go on increasing for him till the Day of Resurrection, and he will be secure from the trials in the grave.''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith also mentions the merits of Jihad, especially of defending the frontiers (i.e., Ribat), as is mentioned in the preceding Ahadith.

1293. `Uthman (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying: "Spending a day on the frontier in Allah's way is better than one thousand days in any other place.''
[At-Tirmidhi].

1294. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Allah guarantees that he who goes out to fight in His way believing in Him and affirming the truth of His Messenger, will either be admitted to Jannah or will be brought back to his home (safely) from where he has set out, with whatever reward or share of booty he may have gained. By Him in Whose Hand Muhammad's soul is, if a person is wounded in the way of Allah, he will come on the Day of Resurrection with his wound in the same condition as it was on the day when he received it; its colour will be the colour of blood but its smell will be the smell of musk. By Him in Whose Hand Muhammad's soul is, if it were not to be too hard upon the Muslims, I would not lag behind any expedition to fight in the Cause of Allah, but I have neither abundant means to provide them conveyance (horses) nor all other Muslims have it, and it will be hard on them to remain behind when I go forth (for Jihad). By Him in Whose Hand Muhammad's soul is, I love to fight in the way of Allah and get killed, to fight again and get killed and to fight again and get killed.''
[Muslim].

Commentary:
1. Besides the merit of Jihad, this Hadith mentions the distinction of that Mu'min (righteous Muslim) who is wounded on the battlefield. It tells us that he will be so resurrected on the Day of Resurrection as if he was wounded on that day. Blood will be dripping from his body which will be emitting the fragrance of musk. This condition will show the distinction and majesty of the Mujahid (warrior in the way of Allah) on the Day of Judgement.

2. It also mentions the kindness and mercy which the Prophet (PBUH) cherished for his Ummah.

3. It also mentions the Prophet's passion for Jihad which is evident from the repeated expression of his desire for martyrdom - in fact an endless series of life for performing it again and again for the sake of Allah. A similar desire is also made by other martyrs. They pray to Allah that they be restored to life so that they can lay down their life again and again for His sake.

1295. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whoever is wounded while fighting in the way of Allah, will come on the Day of Resurrection with blood oozing from his wound having the colour of blood but with the fragrance of musk.''
[Al-Bukhari and Muslim].

1296. Muadh (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Jannah becomes incumbent for a Muslim who fights for the Cause of Allah for a period as long as the time between two consecutive turns of milking a she-camel. He who receives a wound or a bruise in the Cause of Allah will appear on the Day of Resurrection as fresh as possible, its colour will be the colour of saffron and its fragrance will be that of musk.''
[At-Tirmidhi and Abu Dawud].

Commentary: "Fawaq'' is the period that intervenes between two consecutive turns of milking a she-camel. It is a very short interval and is an allusion to a very short period that one may spend in Jihad. Even Jihad for such a short time is so meritorious that his entitlement to Jannah is ensured by it, provided the Mujahid is sincere in his intention and his past conduct is free from major sins and encroachment on the rights of others.

1297. Abu Hurairah (May Allah be pleased with him) reported: One of the Prophet's Companions came upon a valley containing a rivulet of fresh water and was delighted by it. He reflected: `I wish to withdraw from people and settle in this valley; but I won't do so without the permission of the Messenger of Allah (PBUH).' This was mentioned to the Messenger of Allah (PBUH) and he said (to the man), "Do not do that, for when any of you remains in Allah's way, it is better for him than performing Salat (prayer) in his house for seventy years. Do you not wish that Allah should forgive you and admit you to Jannah? Fight in Allah's way, for he who fights in Allah's Cause as long as the time between two consecutive turns of milking a she-camel, will be surely admitted to Jannah.''
[At-Tirmidhi].

Commentary: This Hadith brings out two important points:

First, Jihad is far superior than voluntary Salat. This is perfectly true because the benefit of Salat is restricted to the one who performs it while the benefits of Jihad reach a vast number of people because it is to safeguard the religion, raise the flag of Islam high and safeguard the Islamic territories. But it is only possible when there is a general proclamation for Jihad and there is such a severe fight that it is not permissible for anyone to stay behind; that is to say, it becomes obligatory. In the ordinary circumstances, when a general proclamation for Jihad is not made, the voluntary Salat, is the best of all acts of worship. Second, the Companions of the Prophet (PBUH) did not do anything without the permission of the Prophet (PBUH).

1298. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) was asked: "What other good deed could be an equivalent of Jihad in the way of Allah?'' He (PBUH) replied, "You do not have the strength to do it.'' (The narrator said:) The question was repeated twice or thrice, but every time he (PBUH) answered, "You do not have the strength to do it.'' Then he (PBUH) said, "One who goes out for Jihad in the Cause of Allah is like a person who observes Saum (fasting), stands in Salat (prayer) constantly, recites the Ayat of the Qur'an and does not exhibit any lassitude in fasting and prayer until the participant of Jihad in the way of Allah returns.''
[Al-Bukhari and Muslim].

Commentary: "Alqanit'' signifies one who makes recitation of the Ayat of the Noble Qur'an with the fear of Allah and humility, or is submissive and obedient to the Commands of Allah. The example cited here means that so long a Mujahid is engaged in Jihad, he is like a person who keeps himself occupied in Salat at night and observes Saum in the day time. The action of such a person can be equal in reward to the conduct of a Mujahid. Thus, in special situations Jihad is the most meritorious act. A worshipper cannot attain that reward for his worship which a Mujahid achieves in Jihad.

1299. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The best life is that of the man who holds his horse's rein in Allah's way and flies on its back to the places from whence he hears a war cry or the clatter of arms, seeking martyrdom or slaughter on the battlefield; or that of a person who goes to stay on the top of the hill or in a valley, and there he performs Salat (prayer), pays the Zakat and worships his Rubb till death overtakes him. He has no concern with the affairs of anyone except the doing of good.''
[Muslim].

Commentary: This Hadith has already been mentioned. See Commentary on Hadith No. 609. Besides highlighting the distinction of the Mujahid, this Hadith mentions the excellence of that person who leaves the cities when they are plagued with mischief and retreats to the valleys or hills and protects his Faith by flock-keeping and devotes himself to the obedience of Allah, adherence to His Commands and His worship. One of his outstanding qualities is that he does what is beneficial to the people and he does nothing which causes harm to anyone.

1300. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "In Jannah there are a hundred grades which Allah has prepared for those who fight in His Cause; and the distance between any two of those grades is like the distance between the heaven and the earth.''
[Al-Bukhari].

Commentary: This Hadith also tells us about the distinction of Mujahid in the Hereafter and their elevation to high position.

1301. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "If anyone is pleased with Allah as his Rubb, with Islam as his religion and with Muhammad (PBUH) as (Allah's) Messenger, surely, he will be entitled to enter Jannah.'' Abu Sa`id was delighted with this and requested the Messenger of Allah (PBUH) to repeat it. He (PBUH) repeated it again and then said, "There is also another act by which Allah will elevate the position of a (pious believing) slave in Jannah to a grade one hundred degrees higher. And the distance between any two grades is equal to the distance between heaven and earth.'' He asked the Messenger of Allah (PBUH) what it was and he ((PBUH)) replied, "Jihad in the way of Allah; Jihad in the way of Allah.''
[Muslim].

Commentary: We learn from this Hadith that the people who will be sent to Jannah will be ranked there differently according to this merits of their deeds. There will be innumerable positions in Jannah and Mujahid will have a hundred of them.

1302. Abu Bakr bin Abu Musa Al-Ash`ari reported: I heard my father saying in the presence of the enemy: The Messenger of Allah (PBUH) said, "The gates of Jannah are under the shades of the swords.'' A man with a shaggy appearance got up and said, "O Abu Musa! Did you hear the Messenger of Allah (PBUH) say that in person?'' Abu Musa replied in the affirmative; so he returned to his companions and said: "I tender you farewell greetings.'' Then he broke the scabbard of his sword and threw it away. He rushed towards the enemy with his sword and fought with it till he was martyred.
[Muslim].

Commentary: Besides highlighting the distinction of Jihad, this Hadith tells us about the Companions' passion for Jihad and ardent love for Allah and His Prophet (PBUH). It also tells about their firm faith in what was ordained by Allah and His Prophet (PBUH). In fact, it was this certitude which inclined them more to the Hereafter rather than this world.

1303. Abu `Abs `Abdur-Rahman bin Jabr (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "It will not happen that the feet soiled with dust while (doing Jihad) in the way of Allah, will be touched by the fire (of Hell).''
[Al-Bukhari].

Commentary: "Feet soiled with dust'' means participation in Jihad. That is to say, a person takes part in Jihad and yet goes to Hell is altogether impossible. What it signifies is that Jihad is a means of expiation of sins and that it guarantees the admission into Jannah, provided he is not guilty of major sins. This exception is confirmed by other Ahadith.

1304. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "No one who weeps out of Fear of Allah will enter Hell until milk recedes to the udder, and the dust endured while striving in the Cause of Allah and the smoke of Hell will never subsist together.''
[At-Tirmidhi].

Commentary: This Hadith makes use of a metaphor to stress the impossible. One who weeps for Fear of Allah and one who is covered with the dust of the battlefield in the course of Jihad, will in no case enter Hell until the milk drawn from udder goes back to it. The dust of the battlefield of Jihad and the smoke of Hell cannot combine at one place. The mixing of the two is utterly impossible. However, this will apply only if one's `Aqeedah is correct and one's intention is correct (i.e., one participates in Jihad with the intention to please Allah Alone)

1305. Ibn `Abbas (May Allah be pleased with them) reported: I heard the Messenger of Allah (PBUH) saying, "Two eyes will never be touched by the fire of Hell; an eye which weeps out of Fear of Allah and an eye which spends the night in guarding in the Cause of Allah .''
[At-Tirmidhi].

Commentary: This Hadith tells us about the eminence of the person who weeps out of Fear of Allah and also brings into prominence the distinction of the Mujahid who keeps a vigil during Jihad.

1306. Zaid bin Khalid (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who equips a Ghazi (fighter) in the way of Allah is as if he has taken part in the fighting himself; and he who looks after the dependants of a Ghazi in his absence, is as if he has taken part in the fighting himself.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us about the mutual help of the Muslims and the reward of their cooperation with one another. To provide the needs of Jihad of a Mujahid and to arrange for the protection, supervision and requirements of the family of a Mujahid during his absence from home due to Jihad is as good as participation in Jihad. Those who help the Mujahid in this manner will have the same reward to which the Mujahid is entitled.

1307. Abu Umamah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The best of charities is to provide canopy in the Cause of Allah, to pay wages to a servant in the way of Allah, and to provide a camel in the way of Allah (to be used by a Mujahid).''
[At-Tirmidhi].

Commentary: Here, the word canopy (tent) stands for a covered canopy tent which can provide a Mujahid with shade for peace and comfort, and "pay wages'' means to provide a servant who can help and serve him. "Fahl'' literally means camel and "Taruqah'' is that young she-camel which can bear offspring, that is a young healthy she-camel which can be of service to the Mujahid. What all this means is that such work is highly meritorious which can provide a Mujahid with comfort, power and food. Allah holds promise of a rich reward for it.

1308. Anas (May Allah be pleased with him) reported: A young man from the Aslam tribe said: "O Messenger of Allah! I would very much like to fight in the way of Allah but I do not have anything with which to equip myself for fighting.'' The Messenger of Allah (PBUH) said, "Go to so-and-so, for he had equipped himself (for fighting) but he fell ill.'' So, he (the young man) went to him and said: "The Messenger of Allah (PBUH) sends you his greetings and says that you should hand over to me the equipment that you have procured.'' The man said to his wife: "Give him the equipment which I have collected for myself and do not withhold anything from him. By Allah! Allah won't bless something you withheld (in this respect).''
[Muslim].

Commentary: This Hadith also stresses the fact that if a person is unable to take part in Jihad due to illness, for example, he should then provide such material to a Mujahid which is helpful for him in Jihad. If he does so, he will be eligible to the same reward which is due on Jihad. This would also be a source of increase and growth in his possessions. On the basis of this argument it has been stated that one should always intend to expend his possession on something noble. He who does not get the opportunity to expend it on what he had intended should direct that material towards some other noble purpose.

1309. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) sent an expedition to Banu Lahyan and said, "One man from every two should join the fighting force, and the reward will be shared amongst them equally.''
[Muslim].

Another narration in Muslim is: The Messenger of Allah (PBUH) said, "Let one of every two men go forth'', and added: "Whoever stays behind (and looks well after the family and the property of those who have joined the expedition) will get half the reward of the warrior.''

Commentary: "The reward will be shared amongst them equally'' or "will get half the reward'' signifies one and the same thing. Some people might mistakenly think that these two narrations of Sahih Muslim apparently contradict each other because they imply that he who takes part in Jihad and he who provides material to a Mujahid or looks after the family of a Mujahid in his absence from home would get equal reward. For this reason, some people have taken the word "half'' as superfluous thinking that some narrator has added it in the text on his own. But Al-Hafiz Ibn Hajar is of the opinion that after the acceptance of the credibility of this Hadith and the proofs furnished in this regard, it is unfair to ascribe addition of any word to the narrator. Its correct interpretation seems to be that when the total reward of it will be evenly distributed between the two, each of them will get the same amount of reward. Hence there is no contradiction in these two Ahadith.

This Hadith also tells us that Jihad is not an express obligation; and if one of the two persons takes part in Jihad, it will suffice for the other also. What can be inferred from this is that the others should take part in Jihad in such a manner that those who have wealth, should arrange for the military requirements of the Mujahidun and look after their families, and in case any Mujahid is martyred, they should provide financial help to his family if it does not have sufficient means for a respectable living. Similarly, people in other walks of life should also take part in Jihad in every possible manner.

1310. Al-Bara (May Allah be pleased with him) reported: A man equipped with arms came to the Prophet (PBUH) and asked: "O Messenger of Allah! Should I go and fight or should I embrace Islam first?'' He (PBUH) replied, "Enter in the fold of Islam and then fight.'' He embraced Islam and fought until he was killed. Thereupon the Messenger of Allah (PBUH) said, "He accepted Islam for a short time but was rewarded much.''
[Al-Bukhari and Muslim].

Commentary: Sometimes Almighty Allah awards with His Grace and Mercy abundant reward even on small virtues. This Hadith also makes it absolutely clear that a person becomes eligible for reward for his good deeds after embracing the Faith. In the absence of Faith no virtue is acceptable to Allah.

1311. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "No one who has entered Jannah will desire to return to this world even if he should be given all that the world contains, except a martyr. For he will yearn that he should return to the world and be killed ten times on account of the dignity that he will experience by virtue of his martyrdom.''

Another narration is: "On account of the excellence and distinction, he will experience as a result of martyrdom.''
[Al-Bukhari and Muslim].

Commentary: The distinction and high status which a martyr will get by virtue of his martyrdom will be such that he will desire to return to the world again and again to lay down his life for the sake of Allah. Except for the martyr, nobody else from the people in Jannah will desire to return to this world for any worldly thing.

1312. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "Allah forgives every sin of a martyr, except his debt.''
[Muslim].

Another narration in Muslim is: The Messenger of Allah (PBUH) said, "Being martyred in the Cause of Allah expiates for everything, except debt.''

Commentary: We learn from this Hadith that the rights of people will not be forgiven even by martyrdom, nor would major sins be pardoned. For the forgiveness of major sins one has to make sincere repentance.

1313. Abu Qatadah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) stood up among his Companions and said, "Jihad in the way of Allah and belief in Allah (with all His Attributes) are the most meritorious of actions.'' A man stood up and said: "O Messenger of Allah! Inform me if I am killed in the way of Allah, will my sins be blotted out?'' The Messenger of Allah (PBUH) said, "Yes, in case you are killed in the way of Allah and you remained patient, hopeful of reward, and advancing forward without retracing back (i.e., while fighting).'' Then he said, "What was your question?'' He inquired again: "Inform me, if I am killed in the way of Allah, will all my sins be blotted out?'' The Messenger of Allah (PBUH) replied, "If you remained patient, hopeful of reward and always fought without turning your back upon enemy, everything, except debt, will be forgiven. Jibril has told me this.''
[Muslim].

Commentary: This Hadith tells us about the great merit and reward of martyrdom that it makes up for the shortcomings of the martyrs. This is, however, subject to four conditions which have been mentioned in the Hadith.

The rights of people, such as debt, will not be forgiven. Similarly, major sins will not be pardoned without sincere repentance. Some scholars are of the opinion that debt here means such debt which one does not pay in spite of the fact that he is able to pay it. Such debts which a debtor intends to pay but their payment has been delayed due to the lack of means for it and he dies before paying them, will be hopefully forgiven by the Grace and Mercy of Allah. There are other Ahadith which lend support to this view.

1314. Jabir (May Allah be pleased with him) reported: A man asked the Messenger of Allah (PBUH): "Tell me where I will be if I am killed while fighting in the way of Allah?'' He (PBUH) replied, "In Jannah.'' The man threw away the few dates which he had in his hand, jumped into the battlefield and fought on till he was killed.
[Muslim]

Commentary: Sincere intention is bound to be rewarded by Jannah. Such people can be safely given the glad tidings of Jannah.

1315. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) and his Companions reached Badr before the polytheists, and when they arrived, he (PBUH) directed: "Let no one of you advance ahead of me.'' When the polytheists came near, the Messenger of Allah (PBUH) said, "Now stand up and proceed towards Jannah which is as wide as are the heavens and the earth.'' `Umair bin Al-Humam (May Allah be pleased with him) asked: "Is Jannah as wide as are the heaven and the earth?'' The Messenger of Allah (PBUH) replied in the affirmative. `Umair remarked: "Great!'' The Messenger of Allah (PBUH) asked him what had urged him to say so. He replied: "Nothing, O Messenger of Allah! But hope that I might become one of the inhabitants of Jannah.'' The Messenger of Allah (PBUH) said, "You will definitely be among them.'' `Umair then took some dates out of his quiver and began to eat them, but after a short time he said: "If I survive till I eat my dates, it will mean a long life.'' So he threw away the dates which he had with him and then fought with the enemy till he was killed.
[Muslim].

Commentary: This Hadith brings out the following three points:

1. The importance of the obedience of the leader. Soldiers should wait for the orders of their commander, and should not take any step without his orders.

2. In order to infuse the true spirit of Jihad among the soldiers, they should be told and reminded about the blessings of Jannah so that they fight with enthusiasm and valour for attaining it.

3. The Hadith manifests the love of the Companions of the Prophet (PBUH) for the Hereafter which overwhelmed their interests in the attractions of the life of the world.

1316. Anas (May Allah be pleased with him) reported: Some people came to the Prophet (PBUH) and said to him: "Send with us some men who may teach us the Qur'an and the Sunnah.'' He (PBUH) sent seventy men from the Ansar. They were called Al-Qurra` (the reciters) and among them was my maternal uncle, Haram. They used to recite the Qur'an, ponder over its meaning and learn (its wisdom) at night. In the day, they used to bring water and pour it in pitchers in the mosque, then they would collect wood and sell it; and with the sale proceeds, they would buy food for the people of As-Suffah and the needy. The Prophet (PBUH) sent the reciters with these people but these (treacherous people) fell upon them and killed them before they reached their destination. (While dying) they supplicated: "O Allah convey from us the news to our Prophet that we have met You (in a way), that we are pleased with You and You are pleased with us.'' (The narrator said:) A man attacked Haram from behind and smote him with a spear which pierced him. Whereupon Haram said: "By the Rubb of Ka`bah, I have met with success. The Messenger of Allah (PBUH) said to his Companions, "Your brethren have been slain and they were saying: "O Allah! Convey from us to our Prophet the news that we have met You (in a way) that we are pleased with You and You are pleased with us.''
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions the following three points:

1. Through conspiracy infidels took with them seventy Ansari Companions of the Prophet (PBUH) , who were distinguished for studying and teaching the Noble Qur'an, and martyred them in their region. This tragic incident goes to prove that the Prophet (PBUH) did not have the knowledge of the Unseen. Had he possessed this knowledge, he would not have sent his Companions with the infidels. When the Companions of the Prophet (PBUH) realized that they were trapped and there was no chance of their survival, they prayed to Allah to convey their message to the Prophet (PBUH). Their prayer was answered by Allah Who conveyed their message by means of Wahy (Revelation) to the Prophet (PBUH). On learning it through Wahy, he (PBUH) informed this tragic incident to his Companions.

2. "As-Suffah'' is a terrace in which people stayed, they had neither any permanent source of income nor any free public kitchen nor was there any arrangement for the supply of their food from individuals. They depended entirely on the Grace of Allah.

Every now and then they received some Sadaqah or gift and they all shared it. Some of them would collect firewood and through its sale, raised some money to purchase food for themselves and their Companions.

3. The task of invitation to Islam and dissemination of its teachings is an arduous one. People who undertake this task have to face bitter criticism from their friends and foes, and one has sometimes to lose one's life in this mission. But this is a mission of the Prophets and it should be undertaken by the savants as they are truly worthy of it.

1317. Anas (May Allah be pleased with him) reported: My uncle Anas bin An-Nadr (May Allah be pleased with him) was absent from the battle of Badr. He said: "O Messenger of Allah! I was absent from the first battle you fought against the pagans. (By Allah!) if Allah gives me a chance to fight against the pagans, no doubt, Allah will see how (bravely) I will fight.'' On the Day of Uhud, when the Muslims turned their backs and fled, he said, "O Allah! I apologize to You for what these (i.e., his companions) have done, and I denounce what these (i.e., the pagans) have done.'' Then he advanced and Sa`d bin Mu'adh met him. He said: "O Sa`d bin Mu'adh! By the Rubb of An-Nadr, Jannah! I am smelling its aroma coming from before (the mountain of) Uhud,'' Later on, Sa`d said: "O Messenger of Allah! I cannot achieve or do what he (i.e., Anas bin An-Nadr) did. We found more than eighty wounds by swords, spears and arrows on his body. We found him dead and his body was mutilated so badly that none except his sister could recognise him by his finger.'' We used to think that the following Ayah was revealed concerning him and other men of his sort: "Among the believers are men who have been true to their covenant with Allah (i.e., they have gone out for Jihad, and showed not their backs to the disbelievers), of them some have fulfilled their obligations (i.e., have been martyred).'' (33:23).

Commentary: This Hadith has been mentioned earlier. It was clarified there by Imam An-Nawawi that the word "Layarayann-Allahu'' has been mentioned in two forms. The translation given above accords with its first form. In its second form, it means "Allah will manifest to the people what I will do''. Through these words Anas bin Nadr expressed, in very cautious words, his determination to fight chivalrously but refrained from making any claim or pretension. Here, we have a lesson that if one intends to do a good deed, he should not make any tall claims about it but do it with his utmost effort when it is time to do it. Almighty Allah will certainly make it manifest to the people. On the contrary, if one does it for name and fame, the deed will go waste because then it will be suffused with hypocrisy rather than sincerity. For further notes please see the Commentary on Hadith No. 109.

1318. Samurah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Last night two men (angels) came to me (in a dream) and made me ascend a tree and then admitted me into a nice and excellent house, the like of which I have never seen before. One of them said: `This house is the house of martyrs'.''
[Al-Bukhari].

Commentary: The Prophet (PBUH) was shown in the dream the high status of martyrs. What he observed in the dreams was true because the dreams of the Prophets are true.

The two men who appeared in his dream were the angels, Jibril (Gabriel) and Mika'il. On the behest of Almighty Allah, angels can take the form of men.

1319. Anas (May Allah be pleased with him) reported: Umm Ar-Rubaiy`i bint Al-Bara', who was the mother of Harithah bin Suraqah, came to the Prophet (PBUH) and said: "O Messenger of Allah! Will you not tell me about Harithah? (He was killed in the battle of Badr). If he is in Jannah I shall show endurance, but if he has met another fate, I may exert myself in weeping for him.'' He (PBUH) replied, "O mother of Harithah, in in the gardens of Jannah there are many ranks, and your son has attained Al-Firdaus, the highest.''
[Al-Bukhari].

Commentary: Jannat-ul-Firdaus is the highest portion of Jannah. The allocation of this portion to the martyrs is a proof that Jihad is very much liked by Allah. It occurs in Ahadith that when someone prays to Allah, he should always pray for Jannat-ul-Firdaus.

1320. Jabir bin `Abdullah (May Allah be pleased with them) reported: The dead body of my father, who was mutilated by the enemy, was brought and placed before the Prophet (PBUH). I got up to uncover his face but the people stopped me, and the Prophet (PBUH) said, "The angels continue to cover him with their wings.''
[Al-Bukhari and Muslim].

Commentary: Many of the Companions of the Prophet (PBUH) were treated by the infidels in the battle of Uhud in a beastly manner out of sheer spite and vengeance. But Islam has strictly forbidden its followers from doing any such thing to its enemies. This Hadith mentions the distinction of `Abdullah which he received by virtue of his martyrdom. He was martyred in the battle of Uhud and his dead body was badly mutilated by the enemies. The Hadith also mentions the honour which martyrs receive from the angels that surround their bodies with their wings

1321. Sahl bin Hunaif (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who supplicates Allah sincerely for martyrdom, Allah will elevate him to the station of the martyrs, even if he dies on his bed.''
[Muslim].

Commentary: This Hadith has already been mentioned. See the Commentary on Hadith No. 57.

1322. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who supplicates sincerely for martyrdom, it will be granted to him even though he is not killed on the battlefield.''
[Muslim].

Commentary: This Hadith tells us the benefit and reward of good intention. It induces one to cherish good intentions and wish for noble deeds. Even if one is not able to fulfill some of them, he will get their reward. For this reason, every Muslim should wish for martyrdom so that he can attain this distinction.

1323. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The martyr experiences no more pain in being slain than one of you experiences from the stinging of an ant.''
[At-Tirmidhi].

Commentary: This Hadith tells us how convenient martyrdom has been made by Allah. One who is martyred, feels as much pain in martyrdom as a person ordinarily feels with the sting of an ant.

1324. `Abdullah bin Abu Aufa (May Allah be pleased with them) reported: On one occasion the Messenger of Allah (PBUH) was confronting the enemy. He waited until the sun had declined. Then he stood up to address the people and said, "O people! Do not wish for an encounter with the enemy. Pray to Allah to grant you safety; (but) when you encounter them, show patience, and know that Jannah is under the shades of the swords.'' Then he (PBUH) said: "Allahumma munzilal-kitab, wa mujriyas-sahab, wa hazimal-Ahzab, ihzimhum wansurna alaihim (O Allah, Revealer of the Book, Disperser of the clouds, Defeater of the Confederates, put our enemy to rout and support us against them).''
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith has already been mentioned, and we learn from it that it is better to start war in the afternoon because this was the practice of the Prophet (PBUH).

2. The desire for war is prohibited, but when war becomes inevitable, one should not show his back to the enemy; rather, one should fight to the best of his ability and be steadfast in it.

3. Along with steadfastness and patience in fighting, one should also pray for victory because all powers lie with Allah and no one can gain victory without His Will.

The Hadith also mentions a supplication which one should make when he encounters the enemy.

1325. Sahl bin Sa`d (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Supplications at two times are never turned down (or said, "Are seldom turned down''), a supplication after the Adhan has been proclaimed, and a supplication during the battle combating the enemy.''
[Abu Dawud].

1326. Anas (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) set out to participate in Jihad, he would supplicate: "Allahumma Anta `adudi wa nasiri, bika ahulu, wa bika asulu, wa bika uqatilu (O Allah, You are my Supporter and my Helper. With Your help I get strength, and with Your help I bounce upon the enemy and defeat it, and with Your help I fight).''
[Abu Dawud and At-Tirmidhi].

Commentary: Along with the physical resources for war, one should also pray for victory, and for that, it is essential that one submits to Allah, remembers Him and seeks His Help. Prayer is a great source of strength and support for a Muslim and he must make full use of it. The Hadith also teaches us what to say when one sets out for Jihad.

1327. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: When the Prophet (PBUH) had any fear of an enemy, he used to supplicate: "Allahumma inna naj`aluka fi nuhurihim, wa na`udhu bika min shururihim (O Allah! We put You in front of them, and we seek refuge in You from their evils).''
[Ahmad and Abu Dawud].

Commentary: When one is gripped with fear, he should recite the prayer quoted in the text of this Hadith. Since Allah is the One Who saves from an enemy, one should therefore, pray to Him and beseech His Help.

1328. Ibn `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "There is goodness in the forelocks of horses till the Day of Resurrection.''
[Al-Bukhari and Muslim]

Commentary: The "Khair'', auspiciousness attributed to horses in the Hadith is for those horses which are employed in Jihad, because what Khair, in fact, signifies is return and reward, but war booty is also included in it. From this angle, the breeding of horses is a highly commendable act. The importance of horses for war in the past, needs no elucidation. Even in the present-day world, when the style of war has altogether changed and numerous dangerous weapons have been invented, horses are still playing an important role in the war.

1329. `Urwah Al-Bariqi (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Goodness is tied to the foreheads of horses until the Day of Resurrection, i.e., reward (in the Hereafter) and spoils.''
[Al-Bukhari and Muslim].

Commentary: Return and reward is a belated gain while booty is an immediate gain.

1330. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who keeps a horse for Jihad purposes, having faith in Allah and relying on His Promise, will find that its fodder, drink, droppings and urine will all be credited to him in his Scales on the Day of Resurrection.''
[Al-Bukhari].

Commentary: Thus, this Hadith performs an inducement for horse-breeding for the purpose of Jihad. It is a highly rewarding act because one will be rewarded for whatever he would spend on them and whatever is excreted or discharged by them.

1331. Abu Mas`ud (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) with a she-camel wearing a nose-string and said: "This is (a gift) in the Cause of Allah.'' The Messenger of Allah (PBUH) replied, "You will have in return for it on the Day of Resurrection seven hundred she-camels and every one of them will be wearing a nose-string.''
[Muslim].

Commentary: This Hadith mentions the reward which will be given on the Day of Resurrection on virtues. Every virtue will be given at least a ten-fold reward but it will go to the extent of seven hundred times or more. Thus, this Hadith has glad tidings of a reward of seven hundred times of a good action.

1332. `Uqbah bin `Amir Al-Juhani (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying from the pulpit, "Prepare to meet them (the enemy) with as much strength as you can afford. Verily! Strength is in archery, strength is in archery, strength is in archery.''
[Muslim].

Commentary: In accordance with the conditions of his times, the Prophet (PBUH) ordained the Muslims to acquire every possible power and keep it ready for war. Elucidating his order on this point, he stated that by power he meant archery and then he repeated this word three times to stress its importance. He did it because the art of archery had fundamental importance in war at that time. In the present-day world, archery has lost its value as it has been replaced by other inventions like tanks, guns, missiles, atom bombs, etc. Similar is the case of devices which are used in air and naval war, and all these military wares have superb importance in modern warfare. In the present-day context, the injunction of the Noble Qur'an to acquire power means manufacturing and possession of all these devices. It is incumbent on the Muslims that they equip themselves with all this material and show no carelessness in this regard. In modern times, Muslims have badly neglected this field with the result that non-Muslims have more knowledge of modern warfare and by dint of that they are dominating the world and making a claim of their supremacy all over the world. Unless Muslims pursue the Qur'anic injunctions on this score and acquire greater or equal or at least similar measure and style of power, as is possessed by the non-Muslims, they will not be able to check the onslaught of their enemies, and to defeat them. It is incumbent upon the Muslims to overpower the might and power of the infidels for the glorification of Islam.

1333. `Uqbah bin `Amir Juhani (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "Lands shall be laid open to you, and Allah will suffice you (against your enemies), but none of you should neglect practicing his skill in archery.''
[Muslim].

Commentary: Muslims have been informed through this Hadith that gates of conquest of many regions will be opened on them in future. Almighty Allah will favour them with special help; and because of this help enemies will not be able to cause any harm to them. But it is essential that they should not slack in acquiring the material resources required for war, nor neglect military preparations and exercises. Modern military weapons and new style of warfare have now taken the place of archery, and Muslims should master all of them.

1334. `Uqbah bin `Amir Al-Juhani (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who learnt archery and then neglected it, is not from us.'' (Or said,) "He has been guilty of disobedience (to Messenger of Allah).''
[Muslim].

Commentary: This Hadith also stresses the importance of the art of archery to the extent that if a Muslim forgets it after learning without a valid reason, he is excluded from the followers of the Prophet (PBUH). Now this exhortation applies with equal force to modern military weapons, and if the present-day Muslims lose their command in handling these weapons, they will be exposed to the consequences of which they have been warned in this Hadith, because their training in this field is essential for upholding the Word of Allah and defending the Muslims. If the Muslims lose proficiency in it after acquiring it, they will be guilty of neglecting a very important Islamic obligation.

1335. `Uqbah bin `Amir Al-Juhani (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "Allah will admit three persons to Jannah for one arrow; the maker who has a good motive in making it, the one who shoots it, and the one who hands it up for shooting. So shoot and ride, but I like your shooting (more) than your riding. He who gives up archery after becoming adept in it for lack of interest, neglects a (great) blessing.'' (Or said,) "One who does so is ungrateful.''
[Abu Dawud].

Commentary: This Hadith also highlights the importance and merit of preparation for war against the enemy. Arrow has been used here as a symbol. In modern times, a Muslim who manufactures war weapons with the intention that he will use them for Jihad, will get a reward for it along with all those who in some way co-operate with him in manufacturing them. Instead of archery and horse-riding, Muslims should now get the training of handling modern military weapons and they should beware of forgetting it because if they forget after learning it, the warning contained in this Hadith will also apply to them.

1336. Salamah bin Al-Akwa (May Allah be pleased with him) reported: The Prophet (PBUH) happened to pass by a group of people who were having a shooting match. (Upon seeing them, he (PBUH)) said, "Shoot, O sons of (Prophet) Isma`il, for your father was an archer.''
[Al-Bukhari].

Commentary: Arabs are also called Banu Isma`il because they are the descendants of Prophet Ibrahim's son, Isma`il. This is the reason that Prophet Ibrahim is reckoned an ancestor of the Prophet (PBUH) for his being his descendant.

1337. `Amr bin `Abasah (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying: "He who shoots an arrow for the sake of Allah, will have a reward equal to the emancipation of a slave.''
[Abu Dawud and At-Tirmidhi].

1338. Abu Yahya Khuraim bin Fatik (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who makes a contribution in Allah's way, will have his reward seven hundred times recorded to his credit.''
[At-Tirmidhi].

1339. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Every slave of Allah who observes Saum (fasting) for a day in the Cause of Allah, Allah will keep his face from Hell-fire at a distance of seventy years.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. The above mentioned Ahadith give the glad tidings to those who spend in the way of Allah and strive in His Cause. This means that every endeavour in the Jihad has truthful reward.

1340. Abu Umamah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who observes Saum (fasting) for a day in the Cause of Allah, Allah will keep his face from Hell-fire at a distance equivalent to that between heaven and the earth.''
[At-Tirmidhi].

1341. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who dies without having fought in the Cause of Allah or without having thought of doing so, will die with one characteristic of hypocrisy in him.''
[Muslim].

Commentary: It is a different matter that one may not get a chance to take part in Jihad, but it would be a hypocritical attitude if one does not ever think that if an opportunity ever comes in his way, he will certainly go for Jihad in the way of Allah against the infidels. The reason to that is that, to stay back at home at the time of Jihad was a habit of the hypocrites. In the light of this, Imam Al-Qurtubi has stated the principle that if one is not capable of doing some virtuous deeds, he should then make a resolve that whenever he will be capable of it, he will do that deed, so that his intention takes the place of his act. He who neither performs a good deed nor aspires for it, has a hypocritical disposition. This is specially true of a Muslim who does not even aspire to take part in Jihad. Such a Muslim develops a resemblance with hypocrites.

1342. Jabir (May Allah be pleased with him) reported: We accompanied the Prophet (PBUH) in an expedition when he (PBUH) said, "Some people have remained behind us in Al-Madinah, and we never cross a valley but they are with us. They share the reward with us because they have been held back by valid excuse.''

In another narration the wordings are: "...by any genuine excuse.''

In another narration the wordings are: "They are your partners in reward.''
[Al-Bukhari].

Commentary: This Hadith has already been mentioned, and we learn from it that a person who does not have the energy to take part in Jihad, his sincere intention to spend his wealth in the way of Allah and to lay down his life for His sake is enough for him, because by virtue of his intention, he will share the reward of Jihad with the Mujahidun.

1343. Abu Musa (May Allah be pleased with him) reported: A bedouin came to the Prophet (PBUH) and said: "O Messenger of Allah! One man fights for booty, another fights to win fame, and the third fights for show off.'' Another narration is: "One fights for displaying his valour, another fights out of his family pride.'' Another narration is: "One fights out of rage.'' He asked: "Which of them is fighting in the Cause of Allah?'' The Messenger of Allah (PBUH) said, "The one who fights so that Word of Allah (Islam) be exalted, is the one who fights in the Cause of Allah.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that one who fights for any worldly interest is not a Mujahid. Only he is a Mujahid who fights for the religion of Allah and to win His Pleasure alone.

1344. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "A detachment of soldiers, large or small, who fights in the way of Allah, gets its share of booty and returns safe and sound, receives in advance two-thirds of its reward (only one-third remaining to its credit will be received in the Hereafter). And a troop of soldiers, large or small, that returns disappointed and is afflicted by misery, will receive its full reward (in the Hereafter).''
[Muslim].

Commentary: This Hadith means that the Mujahidun who return safe and sound from the battlefield and get their share of booty are inferior in reward to those who are martyred or wounded in Jihad and do not get any share from the booty. We have a saying of the Companions of the Prophet (PBUH) that "Many of us passed away and were martyred in such a situation that they did not get in this world any share from their reward, but there are many others whose fruits have ripened and they are picking them.''

1345. Abu Umamah (May Allah be pleased with him) reported: A man sought permission from the Messenger of Allah (PBUH) to travel in the land. He (PBUH) said to him, "Travel for my people is Jihad in the Cause of Allah, glory be to Him.''
[Abu Dawud].

Commentary: This Hadith does not mean that touring the world is prohibited in Islam. What this Hadith really means is that when the situation calls for Jihad then the foremost priority of a Muslim should be Jihad. In such an event his passion for touring the world should yield to the spirit of Jihad against the infidels and then he must with his full force fight against the enemy. Tourism for the fun of it is disliked by Islam. However, if the purpose of touring the world is to witness the Signs of Allah, sad end of heretic communities, realities and secrets of the universe to gain knowledge of Allah's, creations, then touring is both praiseworthy and desirable, and this reason has been stressed in the Noble Qur'an at many places.

1346. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The return from an expedition is an act as meritorious as fighting.''
[Abu Dawud].

Commentary: When a Mujahid returns from the battlefield, he gets reward at that also, because there he attends the duties which are devolved on him by his family. Moreover, after his return, he again starts full preparation for going to Jihad again, collects arms for this purpose and recuperates his energy. Thus, so far his intention and readiness are concerned, he is in a state of Jihad even when he is at home and he will be entitled to reward which is due on Jihad.

1347. As-Sa'ib bin Yazid (May Allah be pleased with him) reported: When the Prophet (PBUH) returned from the battle of Tabuk, people went out from Al-Madinah to meet him and I also met him with other children at Thaniyah-tul-Wada`.
[Abu Dawud].

Commentary: There is justification for the reception of those who return from Jihad, but it should be without any formality and expense. The fashion now in vogue for reception on such occasions is that people are induced to make illumination, decoration, display fireworks, let off guns and other similar useless things, and national wealth is rashly spent on them. Such things are forbidden by Islam and also go against the interests of the nation and the country. Instead of wasting wealth on such useless things, it should be spent on things which are beneficial to the country and the nation.

1348. Abu Umamah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who neither takes part in fighting nor equips a warrior nor looks after his (the warrior's) family, will be afflicted by severe calamities before the Day of Resurrection.''
[Abu Dawud].

Commentary: This Hadith means that one who neither takes part in Jihad nor provides arms to a Mujahid nor looks after the families of the Mujahidun during their absence, is guilty of crimes for which he is punished in this world by Allah. It is, therefore, the duty of the Muslim Ummah that it should in no way neglect the obligation of Jihad and all its requirements; otherwise it will suffer punishment in this world and in the next.

1349. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Fight the polytheists with your wealth, lives and tongues.''
[Abu Dawud].

Commentary: This Hadith mentions three categories of Jihad, namely Jihad with wealth, Jihad with one's life and Jihad by speech. One should make Jihad as is warranted by the situation one is confronted with. That is, where a Muslim is required to sacrifice his life, he must sacrifice his life; where he is required to sacrifice his wealth, he should spend wealth; and where he is required to make Jihad by means of his speech, he should do it by speech. One should not hesitate to spend for the sake of Allah what is required by the situation.

1350. An-Nu`man bin Muqarrin (May Allah be pleased with him) reported: I was with the Messenger of Allah (PBUH) when I witnessed that if he did not begin fighting in the early part of the day, he would postpone fighting till the sun had declined, the blowing of the breeze had blown and the victory from Allah had come.
[Abu Dawud and At-Tirmidhi].

Commentary: We learn from this Hadith that war should either be started early in the morning or in the afternoon when the sun begins to decline. The reason behind this is that a Muslim is fresh in the early morning while the enemy is generally careless. In the latter case, if war is started when sun begins to decline, every kind of movement becomes easy and the help from Allah also descends at that time. This is the significance of starting war at these times.

1351. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Do not wish for an encounter with the enemy. Pray to Allah to grant you safety; (but) when you encounter them, show patience.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. See Hadith No. 1325 and its commentary.

1352. Abu Hurairah and Jabir (May Allah be pleased with them) reported: The Prophet (PBUH) said, "War is deception.''
[Al-Bukhari and Muslim].

Commentary: "Khad`ah'' means deception, i.e., employing a strategy which causes misunderstanding to the enemy, and one's real intent does not become evident to them. This is permissible in Islam in the state of war.

The Ahadith mentioned in this chapter make the importance of Jihad and the reason for so much stress on it abundantly clear. These also show how great a crime it is to ignore it. It is very unfortunate indeed that present-day Muslims are guilty of renouncing Jihad in every part of the world. May Allah help us to overcome this negligence.


Martyrdom without Fighting

Chapter 235
Martyrdom without Fighting

1353. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The martyrs are of five kinds: One who dies of plague; one who dies of disease of his belly; the drowned; one who dies under the debris (of construction, etc.), and one who dies while fighting in the way of Allah.''
[Al-Bukhari and Muslim].

Commentary: The Hadith mentioned four categories of people, besides those who were slain on the battlefield, whom Allah will, by His Special Grace, give on the Day of Judgement an award similar to martyrs on condition that they are true believers and practising Muslims. In some other Ahadith, certain other persons have also been mentioned who will be given the status of martyrs by Allah. There is no contradiction in these Ahadith for the reason that first of all the Prophet (PBUH) was told about five categories of martyrs which were disclosed by him. Subsequently Almighty Allah added some more people to them which were also mentioned by him. The real Shaheed is one who voluntarily gives his life for the sake of Allah provided that he wholeheartedly fights on the battlefield.

1354. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whom do you reckon to be martyr amongst you?'' The Companions replied: "The one who is killed in Allah's way.'' He said, "In that case, the martyrs among my people would be few.'' The Companions asked: "O Messenger of Allah! Then who are the martyrs?'' He replied, "He who is killed in the way of Allah is a martyr; he who dies naturally in the Cause of Allah is a martyr; he who dies of plague is a martyr; and he who dies of a belly disease is a martyr; and he who is drowned is a martyr.''
[Muslim].

This Hadith shows the care Allah has for this Ummah, which is the best Ummah of mankind. (Editor's Note)

Commentary: "He who dies naturally in the Cause of Allah'', here signifies such a person who does not die because of his being killed in the war by sword, lance, bullet, etc., but meets the death on account of some other causes while going for Jihad such as falling from the horse, or who dies while defending his family or property, or defending other Muslims against attackers or robbers, etc. Such a person will also be a martyr.

1355. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "He who is killed while defending his property is a martyr.''
[Al-Bukhari and Muslim].

Commentary: The Hadith highlights the fact that whoever gets killed in an effort to protect his property is a martyr.

1356. Sa`id bin Zaid bin `Amr bin Nufail (May Allah be pleased with him) reported, one of the ten Companions who were given the glad tidings of entering Jannah reported: I heard the Messenger of Allah (PBUH) saying: "He who dies while defending his property is a martyr; he who dies in defence of his own life is a martyr; and he who dies on defense of his faith is a martyr, he who dies in defence of his family is a martyr.''
[Abu Dawud and At-Tirmidhi].

Commentary: Those ten Companions of the Prophet (PBUH) whom he gave the glad tidings of entering Jannah are known as "Al-Asharatul-Mubashsharuna bil-Jannah". They are Abu Bakr As-Siddiq, `Umar bin Al-Khattab, `Uthman bin `Affan, `Ali bin Abu Talib, Talhah bin Ubaidullah, Zubair bin Al-`Awwam, `Abdur-Rahman bin `Auf, Sa`d bin Abu Waqqas, Abu `Ubaidah bin Al-Jarrah and the narrator of this Hadith, i.e., Sa`id bin Zaid, may Allah be pleased with all of them. The Prophet (PBUH) also foretold that some other people will enter Jannah, but these ten people are called Al-Asharatul-Mubashsharuna bil-Jannah for the reason that the prophecy about these ten people was made at one time, in a single Hadith. This Hadith includes the names of some other people also who will be given the reward of martyrdom.

1357. Abu Hurairah (May Allah be pleased with him) reported: A man came to the Messenger of Allah (PBUH) and asked, "O Messenger of Allah! What shall I do if someone comes to me with the intention of taking away my property?'' He replied, "Do not hand over it to him.'' The man asked, "What shall I do if he fights me?'' The Messenger of Allah (PBUH) said, "Then fight him.'' "What will be my position in the Hereafter if he has killed me?'' The Messenger of Allah (PBUH) replied, "In that case you are a martyr.'' The man asked: "What if I killed him?'' The Messenger of Allah (PBUH) replied, "He will be in the Hell-fire.''
[Muslim].

Commentary: We learn from this Hadith that in the course of struggling to protect one's life and property, it is quite fair to kill a dacoit, robber or plunderer. Such a killing is not deemed a sin. In case he is a Muslim, he will go to Jannah after suffering the punishment of his attacking a Muslim. But if he regards the act of attacking Muslims and encroaching upon their property lawful, he will be in Hell forever. It should be borne in mind that if a person dies while struggling to protect his life and property, he will be granted the status of a martyr, with the difference that a martyr of this kind will be given bath and funeral prayer because he is a martyr by Divine order not by his own will and desire. He who is martyred in Jihad at the battlefield is exempted from bath and the funeral prayer.


The Merit of Emancipation of Slaves

Chapter 236
The Merit of Emancipation of Slaves

Allah, the Exalted, says:

"But he has not attempted to pass on the path that is steep (i.e., the path which will lead to goodness and success). And what will make you know the path that is steep? (It is) freeing a neck (slave).'' (90:11-13)

1358. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who sets free a Muslim slave, Allah will deliver from the fire of Hell every limb of his body in return for every limb of the slave's body, even his private parts.''
[Al-Bukhari and Muslim].

Commentary: It was the result of such instructions that the Companions of the Prophet (PBUH) did their best for the liberation of slaves. Abu Bakr As-Siddiq (May Allah be pleased with him) bought many slaves and set them free. `Abdur-Rahman bin `Auf released as many as thirty thousand slaves. `Abdullah bin `Umar liberated more than a thousand of them. It is stated that some Companions of the Prophet (PBUH) released eight thousand slaves within one day. May Allah be pleased with all of them. (Ibn `Allan and Nuzhat Al-Muttaqin).

1359. Abu Dharr (May Allah be pleased with him) reported: I asked the Messenger of Allah (PBUH), "Which deed is most excellent?'' He replied, "Faith in Allah and Jihad in His path.'' I then asked, "Which slaves are most excellent (to set free)?'' He replied, "Those who are held in high esteem by their people and whose value is higher.''
[Al-Bukhari and Muslim].

Commentary: It is evident that a slave who is more valuable in the eyes of his master will be difficult to part with, whether he is purchased to set free or liberated on one's own accord. Hence, it will be more meritorious to free such a slave than ordinary ones. This conduct furnishes the principle that the reward of sacrificing something for Allah goes with its quality. The more precious the thing sacrificed, the greater its reward will be. The Qur'an expressly states:

"By no means shall you attain Al-Birr - piety, righteousness - here it means Allah's reward, i.e., Jannah), unless you spend (in Allah's Cause) of that which you love.'' (3:92).

The institution of slavery is now finished, but its other forms do exist, i.e., debtor, guarantor, prisoners, etc. To liberate these from their burden is a meritorious act, and all these forms are covered by the Quranic phrase "freeing a neck'' (slave, etc.).


The Excellence of Kind Attitude towards Slaves

Chapter 237
The Excellence of Kind Attitude towards Slaves

Allah, the Exalted, says:

"Worship Allah and join none with Him (in worship); and do good to parents, kinsfolk, orphans, Al-Masakin (the poor), the neighbour who is near of kin, the neighbour who is a stranger, the companion by your side, the wayfarer (you meet), and those (slaves) whom your right hands possess.'' (4:36)

1360. Al-Ma`rur bin Suwaid (May Allah be pleased with him) reported: I saw Abu Dharr (May Allah be pleased with him) wearing a nice gown, and his slave was also wearing one similar to it. I asked him about it, and he said that he had exchanged harsh words with a person during the lifetime of the Messenger of Allah (PBUH) and put him to shame by making a reference to his mother. That person came to the Messenger of Allah (PBUH) and made mention of that to him. Thereupon the Messenger of Allah said, "You are a person who has remnants of the `Days of Ignorance' in you. Your slaves are your brothers. Allah has placed them under your authority. He who has his brother under him, should feed him from whatever he eats, and dress him with whatever he wears, and do not burden them (assign burdensome task to them) beyond their capacity; and if you burden them then help them.''
[Al-Bukhari and Muslim].

Commentary:
1. This Hadith enjoins good treatment of the slaves and contains the elucidation that one should give them the same food and clothes which one has for oneself, or one should give them such wages that they can have the same food and clothes which he has for himself because as far as religion and humanity are concerned, the slaves have the status of one's brother, and their human needs are not different from the needs of their masters. This order also applies to labourers who work in factories, shops and homes. They should be given wages for their work on the strict consideration that they are also human beings and brothers - as if they are members of one's family. It is regrettable indeed that these teachings of Islam have been reglected in the Islamic countries. Not to speak of treating them as brothers, the factory owners, shopkeepers and capitalists of these countries are not prepared to treat them as human beings. The result is that while these employers are rolling in luxury, they do not give to their employees even such wages which can suffice for their human needs. May Allah grant them the ability to act upon the teachings of their religion.

2. It is equally important that the employees and labourers should not be burdened with such heavy work which they are unable to bear. If the employees are ever given any such work, the employers must share such work with them.

3. Pride on one's own ancestory and condemnation of others on this account are remnants of the Age of Ignorance which were rooted out by Islam. Muslims should keep themselves away from such vainglorious thoughts. It is a pity that this evil of the pre-Islamic age has now been adopted again by Muslims. We find it very common in the present-day Muslim societies.

4. By issuing the instruction mentioned in this Hadith, Islam has arranged to establish equality in the true sense of the word. Islam does not make any claim of uniting the labour class and weaker segments of the society for confrontation with the capitalists because this breeds class hatred which ruins the peace and progress of the society. Instead of creating enmity, Islam fosters brotherhood between the employer and employed, the master and the slave, the ruler and the ruled. It also exhorts them to be sympathetic and helpful to each other. By stressing the rights of people, it teaches both classes to love and respect each other. This is the reason why in Islam the merit for distinction is not wealth and abundance but Faith and fear of Allah alone which even the poorest of the poor can possess and which may be missing even in the richest of the rich in society.

1361. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When your servant brings food for you and you do not seat him with you, you should at least give him a morsel or two out of it because he has prepared it himself.''
[Al-Bukhari].

Commentary: The sense of equality of people inculcated by Islam warrants that if a servant brings meal to his master, this latter should make him sit by his side to take the meal with him. If this is not possible for a reason or another, then he should give some portion of the meal to the servant. He must not eat up the whole meal himself or leave for him only the leftovers. Alas! we should adopt the teachings of our religion.


The Merit of the Dutiful Slave

Chapter 238
The Merit of the Dutiful Slave

1362. Ibn `Umar (May Allah be pleased with them) reported: I heard the Messenger of Allah (PBUH) saying, "When a slave is sincere to his master and worships Allah well, He will have a double reward.''
[Al-Bukhari and Muslim].

Commentary: Looking to the welfare of the master mean that the slave serves his master honestly and takes good care of his possessions. Worship of Allah here means obedience of Islamic injunctions and obligations. A slave who is loyal to his master and adheres to religious injunctions stands to earn a double reward.

1363. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The faithful and diligent slave will have a double reward.'' (Abu Hurairah added:) By Him in Whose Hand the soul of Abu Hurairah is! but for Jihad in the Cause of Allah, and Hajj and kindness to my mother, I would have preferred to die as a slave.
[Al-Bukhari and Muslim].

Commentary: "Muslih'' translated here as "faithful'' is that slave who is a well-wisher of his master and a devout worshipper of Allah. When a person is a slave he can neither take part in Jihad on his own nor perform Hajj nor serve his parents because he is bound by the will of his master. What Abu Hurairah has stated here is that had it not been of the excellence of Jihad, Hajj and righteousness to the parents, he would have liked to be a slave because then he would have got double reward promised by the Prophet (PBUH).

1364. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A slave who worships his Rubb (Allah) well and discharges efficiently and faithfully the duties which are assigned to him by his master, will have a double reward.''
[Al-Bukhari].

Commentary: In this Hadith the services of the master, his obedience and loyalty are subject to the condition that in all these matters the slave does not go against the Divine injunctions. That is, he obeys only such orders of his master which do not incur the disobedience of Allah because in that case obedience of anyone is forbidden. In fact, the disobedience of unlawful orders is essential.

1365. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Three kinds of people will have a double reward: A man from the People of the Book who believes in his Prophet and (also) believes in Muhammad; a slave who discharges properly the duties towards Allah and towards his master; and a man who possesses a slave-girl and teaches her manners, educates her well, and frees her and then marries her.''
[Al-Bukhari and Muslim].

Commentary:
1. Ahlul-Kitab means the people of the Scriptures, that is the Jews and the Christians. This Hadith has an inducement for them that if they embrace Islam, they will be entitled to a double reward.

2. Similarly, a sincere and well-wishing slave will also be entitled to a double reward because, on the one side, he obeys his master and bears all the trouble that is involved in his obedience, and on the other side, he also does justice to the worship of Allah.

3. Muslims have been enjoined to impart proper education and training to their slaves, especially their slave-girls. In the latter case, they have been advised to liberate and marry them with all the essentials of marriage. That is, they should be given a dower and all other rights to which wives are entitled. There is a double reward for all these types of people.


The Excellence of Worship in the time of Tribulations

Chapter 239
The Excellence of Worship in the time of Tribulations

1366. Ma`qil bin Yasar (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The reward of worship performed at a time of trials is equal in reward to an emigration to me.''
[Muslim].

Commentary: When turmoil is rampant and society is plagued with evils, the worship and obedience of Allah becomes very difficult. The reason being that in such a situation evils are widespread and therefore everyone easily inclines to them. In such circumstances, worship of Allah and compliance of His Orders are merits of great eminence and their reward have been likened to the reward of going for Hijrah (Emigration) to Al-Madinah at that time when this migration was Wajib (obligatory). Emigration was at that time obligatory and to bid farewell to home, property, business and homeland was sacrifice of the highest order. But this sacrifice was worth its reward. A similar reward is promised to those who will be obedient to Allah and worship Him in an age of mischief. A believer should avoid taking part in turmoil and occupy himself worshipping Allah instead. (Editor's Note)


Excellence of Fair Bargaining and Matters Relation to it

Chapter 240
Excellence of Fair Bargaining and Matters Relation to it

Allah, the Exalted, says:

"And whatever you do of good deeds, truly, Allah knows it well.'' (2:215)

"And O my people! Give full measure and weight in justice and reduce not the things that are due to the people.'' (11:85)

"Woe to Al-Mutaffifun (those who give less in measure and weight). Those who, when they have to receive by measure from men, demand full measure. And when they have to give by measure or weight to (other) men, give less than due. Do they not think that they will be resurrected (for reckoning). On a Great Day? The Day when (all) mankind will stand before the Rubb of the `Alamin (mankind, jinn and all that exists)?'' (83:1-6)

1367. Abu Hurairah (May Allah be pleased with him) reported: A man demanded of the Prophet (PBUH) for repayment of a loan and was harsh to him. His Companions were about to attack him, but he (PBUH) said, "Leave him, as the creditor is entitled to make a demand. Give him a camel of the same age as the camel that is due to him.'' They said: "We find a better camel senior to it in age.'' He (PBUH) said, "Then buy it and give it to him; verily the best of you is the one who is the best in discharging his obligations (repayment of loans).''
[Al-Bukhari and Muslim].

Commentary:
1. It is stated that the lender was Zaid bin Shu`bah Al-Kinani who had not yet embraced Islam and that accounts for his not showing due regard to the Prophet (PBUH), and for his being stern in his demand. The Prophet (PBUH) advised his Companions that it is well for the affluent to demand his loan in a polite manner; but if someone does not show politeness in it, his rudeness should be ignored because he who has a rightful claim, can tend to anger although he should not cross the limits laid down by Shari`ah in this respect.

2. At the time of repayment of loan, it is Mustahabb (desirable) for the debtor to pay with his own pleasure something more than due to the lender; but if the lender demands more, this extra money will be deemed interest Riba (or usury) which is neither lawful to receive nor to pay.

1368. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "May Allah show mercy to a man who adopts a kind attitude when he sells, buys and demands for the repayment of loans.''
[Al-Bukhari].

Commentary: "Adopts a kind attitude when he sells, buys, and demands for the repayment of loans'' means that the buyer purchases in such a manner that the seller does not suffer any loss, and the seller sells his goods in such a way that the buyer does not feel any irritation. This also means that he feels so liberal that if the buyer wants to return what he has purchased he should accept it. Another meaning of this is that while making a purchase the customer pays more than the due price and the seller gives more goods than are due against the price that he receives. Moreover, if one has to get his claim from someone, he should do it in a polite manner. In no case should one cross the limits of civility. If the debtor is poor, he should be given more time for the repayment of his debt, or the loan should be remitted, as it will be in accordance with the Qur'anic instruction that "If you remit by way of charity, that is better for you.'' (2:280)

1369. Abu Qatadah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who likes Allah to deliver him from the calamities of the Day of Resurrection, let him either give respite to a debtor or grant him remission (of loans) in straitened circumstances.''
[Muslim].

Commentary: One meaning of the word "Falyunaffis'' is to defer demanding payment of the amount from the one who may be in straitened circumstances, until such a time when he has sufficient means to pay his debts. Another meaning is to relieve the debtor of the trouble he is in by giving him some money so that he can settle his debt with it. Such sympathetic attitude will save that person from the tensions of the Day of Judgement when everyone will be tense with worries and anxieties.

1370. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "There was a person who used to loan money to the people and he used to say to his servant: `When an insolvent person comes to you, show him leniency so that Allah may forbear our faults.' So when he met Allah (i.e., when he died), Allah forgave him.''
[Al-Bukhari and Muslim].

Commentary: "Show him leniency'' implies three things in the present context - polite dealing, extension in the period of payment and remittance of debt. All these qualities are desirable and praiseworthy in Shari`ah. The incident reported in this Hadith relates to some person of a community of the ancient times, but it is such an illustrious example that it was liked by the Prophet (PBUH) because he recommended it to his followers through his advice and practice. This action is certainly a means of winning the Pleasure of Allah as well.

1371. Abu Mas`ud Al-Badri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A person from amongst the people who lived before you was called to account by Allah on the Day of Resurrection. No good deeds were found in his credit except that he being a rich man had (financial) dealings with people and had commanded his servants to show leniency to those who were in straitened circumstances. Upon this Allah, the Exalted, and Majestic said: `I am more entitled to this attribute, so waive (his faults).'''
[Muslim].

Commentary: "Was called to account by Allah on the Day of Resurrection'' is in the nature of a news of the Day of Judgement which was revealed to the Prophet (PBUH) and which he quoted as an illustration. What it signifies is that on the Day of Resurrection, Almighty Allah will deal with such people generously and forgive their sins because forgiveness depends on the quality of actions done by a person in this world.

1372. Hudhaifah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A slave of Allah whom He had endowed with wealth, will be brought before Him. Allah will ask him: `What did you do in the world?' (They cannot conceal anything from Allah.) He will say: `O my Rubb, You endowed me with Your wealth; I used to enter into transactions with people and it was my nature to be lenient to the insolvent ones. I used to give respite to those who were in straitened circumstances.' Whereupon Allah will say: `I am more entitled than you to do this. So forgive my slave'.'' `Uqbah bin `Amir and Abu Mas`ud Al-Ansari (May Allah be pleased with them) said, "Thus we heard it from the Messenger of Allah (PBUH).''
[Muslim].

1373. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who gives respite to someone who is in straitened circumstances, or grants him remission, Allah will shelter him in the shade of His Throne, on the Day of Resurrection, when there will be no shade except its shade.''
[At-Tirmidhi].

Commentary: On the Day of Resurrection, the sun will come very close to people's heads who will then be badly sweating to the extent that sweat will reach up to their ankles, or knees or shoulders; some will be totally overwhelmed with their sweat (depending on their sins). Those people who will have the privilege of getting in the shade of the Throne will be then very lucky indeed. Among such lucky people, there will be a person who used not only to give loans to the poor and the needy but also gave them convenience in the payment of their debts or would forgive a part of the loan or all of it. This Hadith has food for thought for the affluent. Nowadays people usually lend money to people of their own status and do not like to give loan to the poor because they think that it is difficult to recover from them. As far as remitting a loan is concerned, we have totally forgotten this precept. In any case, to refuse loan to a poor, when a person is in a position to lend money to him, is hateful. To lend money to a needy and then to show him leniency in its payment or to remit it altogether is a praiseworthy act, the best reward for which will be given to him on the Day of Resurrection. May Allah enable us to be generous to the poor on this account.

1374. Jabir (May Allah be pleased with him) reported: The Prophet (PBUH) purchased a camel from me and weighed more than its price.
[Al-Bukhari and Muslim].

Commentary: In the era of the Prophet (PBUH), and for a long time afterwards, all business transactions were made by means of dirham and dinar - the former was a gold coin while the latter was a silver one. The price of the camel which was settled in gold or silver was paid by the Prophet (PBUH) in weight, and he paid it in excess of the agreed amount.

1375. Abu Safwan Suwaid bin Qais (May Allah be pleased with him) reported: Makhramah Al-`Abdi and I procured some drapery from Hajar and brought them to Makkah. The Prophet (PBUH) came and bargained with us for some trousers and we sold them to him. We had a person who weighed the cloth in order to fix the price. The Prophet (PBUH) said to him, "Weigh and add a little to it.''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith highlights the desirability on part of the customer of paying in excess of the agreed price. The seller is induced to give more than the agreed (quality/weight/number of goods etc.) against the settled price. This is a step ahead of justice - that is Ihsan, which has very salutary effects on society. On the contrary, if people are in the habit of encroaching up others' rights, it will doubtless create jealousy and enmity, which are ruinous to the society.


Book Twelve: The Book of Knowledge

  • Chapter 241 : Virtues of Knowledge which is Learnt and Taught for the sake of Allah


Virtues of Knowledge which is Learnt and Taught for the sake of Allah

Chapter 241
Virtues of Knowledge which is Learnt and Taught for the sake of Allah

Allah, the Exalted, says:

"And say: `My Rubb! Increase me in knowledge.'' (20:114)

"Are those who know equal to those who know not?''' (39:9)

"Allah will exalt in degree those of you who believe, and those who have been granted knowledge.'' (58:11)

"It is only those who have knowledge among His slaves that fear Allah.'' (35:28)

1376. Mu`awiyah (May Allah be pleased with him) reported: The Messenger of Allah said, "When Allah wishes good for someone, He bestows upon him the understanding of Deen.''
[Al-Bukhari and Muslim].

Commentary: Knowledge and understanding of Deen (religion) here stands for the understanding of the Qur'an and Hadith, religious injunctions, and knowledge of the lawful and the unlawful. This Hadith highlights the excellence of knowledge and the fact that it is a sign of Allah's Help to the person who possesses it and acts upon it.

1377. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Envy is permitted only in two cases: A man whom Allah gives wealth, and he disposes of it rightfully, and a man to whom Allah gives knowledge which he applies and teaches it.''
[Al-Bukhari and Muslim].

Commentary: According to Imam An-Nawawi's explanation, the word Hasad (jealousy) is used in the sense of Ghibtah i.e., envy. In Islam, jealousy is forbidden and is held unlawful. The reason being that one who is jealous wants that the person, who possesses the quality of which he is jealous, be deprived of that quality. Envy is permissible for the reason that when one seems that a person has been graced by Allah with certain gifts and qualities, he also desires to be blessed with those gifts. In the latter case, he does not grumble and grieve but eagerly prays to Allah for those gifts. `Knowledge' here stands for the knowledge of the Qur'an and Hadith because this knowledge alone is beneficial for man, and it is through this knowledge that correct judgements can be made among the people. This Hadith has an inducement for acquiring useful knowledge along with wealth to spend in the ways ordained by Allah.

1378. Abu Musa (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The guidance and knowledge with which Allah has sent me are like abundant rain which fell on a land. A fertile part of it absorbed the water and brought forth profuse herbage and pasture; and solid ground patches which retained the water by which Allah has benefited people, who drank from it, irrigated their crops and sowed their seeds; and another sandy plane which could neither retain the water nor produce herbage. Such is the similitude of the person who becomes well-versed in the religion of Allah and receives benefit from the Message entrusted to me by Allah, so he himself has learned and taught it to others; such is also the similitude of the person who has stubbornly and ignorantly rejected Allah's Guidance with which I have been sent.''
[Al-Bukhari and Muslim]

Commentary: This Hadith has already been mentioned, and is repeated here to highlight the eminence of knowledge and to induce Muslims to gain it. We learn from this Hadith that there are three categories of people. First, those who acquire knowledge of the Qur'an and Hadith, act upon it and also impart it to others. Such people benefit from this knowledge themselves and extend this benefit to others also. By virtue of this quality they are the best of all. Second, those people who acquire knowledge and impart it to others, but do not fulfill the requirements of that knowledge. Such people are inferior in rank to the people of the first category and can be taken to task for their omissions. Third, those who shun the knowledge of the Qur'an and Hadith. Neither they study and hear the two themselves for their own benefit, nor do they acquire knowledge to impart it to others for their benefit. This is the worst category of people. Every Muslim should try to be in the first category of the people.

1379. Sahl bin Sa`d (May Allah be pleased with him) reported: The Prophet (PBUH) said to `Ali (May Allah be pleased with him), "By Allah, if a single person is guided by Allah through you, it will be better for you than a whole lot of red camels.''

[Al-Bukhari and Muslim].

Commentary: "Better for you than red camels'' is an allegory for every thing that is better than anything else. Red camels used to be precious in Arabia, and their reference here is to highlight the value of guidance. Thus, this Hadith brings into prominence the importance of calling people towards Allah. But before calling others to the path of Allah, one must himself know it, and for this purpose, the knowledge of the Qur'an and Hadith is essential because one cannot provide any guidance in this respect without this knowledge.

1380. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Prophet (PBUH) said, "Convey from me even an Ayah of the Qur'an; relate traditions from Banu Israel, and there is no restriction on that; but he who deliberately forges a lie against me let him have his abode in the Hell.''
[Al-Bukhari].

Commentary: This Hadith contains the following three important points:

1. It stresses the importance of acquiring knowledge of the Qur'an and Hadith and imparting it to others. No matter whether one has more or less knowledge, he must communicate it to others. There is no justification to presume that preaching or inviting to the Message of Allah is the duty of religious scholars and those who are well-versed in this sphere. In fact, it is a duty upon every Muslim, so much so that if a person knows even a single Verse of the Qur'an, that is to say if he knows only one injunction of Allah, he is duty bound to communicate it to other people.

2. It allows the communication of Jewish Traditions but this permission is subject to the condition that such Traditions are not against the elucidations of the Qur'an and Hadith.

3. There is a stern warning on attributing any false saying to the Prophet (PBUH). This demands strict scrutiny of Ahadith. If a Hadith does not have a reliable authority or whose chain of narrators has a false link or a person of doubtful integrity, that is to say if it is weak, then it is a serious offense to quote it as a Hadith of the Prophet (PBUH). There are various grades of weakness, and this requires deep knowledge of the narrators and principles of Hadith to know them since scholars who are expert in this discipline are few and far. The safest course for ordinary scholars is to refrain from stating such Ahadith which are weak, no matter whether the weakness is serious or slight. The reason is that although the majority of Muhaddithun consider the slightly weak Ahadith acceptable but they cannot be identified by everybody. Thus, every Hadith which is marked as weak should not be mentioned. In the present age Sheikh Nasiruddin Al-Albani has done a very remarkable work in this field. He has separated the weak Ahadith found in the four famous volumes of Ahadith (Sunnan Abu Dawud, At-Tirmidhi, An-Nasa'i and Ibn Majah) from the authentic and prepared separate volumes of authentic and weak Ahadith. This work of Al-Albani has made it easy for the ordinary `Ulama' to identify the weak Ahadith. Only a man of Sheikh Al-Albani's calibre can do research on it. The ordinary `Ulama' and religious scholars of the Muslims are heavily indebted to him for this great work and they should keep it in view before mentioning any Hadith. They should mention only the authentic Ahadith and refrain from quoting the weak ones. It is wrong to ignore this work on the ground that Sheikh Al-Albani is not the last word on the subject. There can be a possibility of error in his work because it is after all a human effort, but it will be very unfair to regard his effort of no account merely because of a possible error. It is regrettable indeed that only because of this possible error many people refuse to accept even the correctness of the Sahihain. (i.e., Sahih Al-Bukhari and Sahih Muslim). Should we then accept their view? No, certainly not. So there is no sense in not making use of Sheikh Al-Albani's matchless contribution. As Muhaddithun have done a great service to the Muslim Ummah by collecting and compiling the Ahadith, similarly in the style of Muhaddithun, and in keeping with the principles laid down by them, the research carried out to separate the authentic Ahadith from the weak is in fact an effort to complete their mission. In this age, Almighty Allah has bestowed this honour on Sheikh Al-Albani. May Allah protect him, give him the best of the reward and give him a long life.

We now revert to the subject under discussion and say that no such saying and practice should be attributed to the Prophet (PBUH) the authenticity of which is doubtful. On this principle, weak Ahadith, should not be mentioned. It is very unfortunate indeed that in spite of such a stern warning, many of our `Ulama' are not careful in this matter. Not to speak of weak Ahadith, they do not hesitate to mention even Ahadith Maudu`ah forged Ahadith) only to adorn their speech. May Allah guide them to the Right Path. In fact, there is a class of religious scholars who try to refute the authentic Ahadith and validate the weak ones only to add credence to their own juristic school. May Allah save us from such evils.

1381. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Allah makes the way to Jannah easy for him who treads the path in search of knowledge.''
[Muslim].

Commentary: This Hadith has already been mentioned in full. See the Commentary on Hadith No. 247. A part of it which relates to the eminence of knowledge has been reproduced here. In this Hadith, knowledge means the knowledge of the religion, that is to say the correct knowledge of the Qur'an and Hadith which is acquired without any prejudice of any juristic school. Otherwise juristic prejudice can turn knowledge into great obstruction. May Allah bestow His Mercy on us.

1382. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who calls others to follow the Right Guidance will have a reward equal to the reward of those who follow him, without their reward being diminished in any respect on that account.''
[Muslim].

Commentary: This Hadith has already been mentioned. This Hadith has glad tidings for those who learn the knowledge of religion, teach it and impart it to others.

1383. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When a man dies, his deeds come to an end except for three things: Sadaqah Jariyah (ceaseless charity); a knowledge which is beneficial, or a virtuous decendant who prays for him (for the deceased).''
[Muslim].

Commentary: "His deeds come to an end'' means that he does not any longer receive the return and reward on his actions. But there are three categories of actions on which he receives reward even after his death. First, Sadaqah Jariyah such as building a mosque, or a hospital, or digging a well. As long as people will benefit from these, he will receive a reward for them. Second, "knowledge which is beneficial'' means to impart knowledge to others or to propagate knowledge by means of one's books. As long as this medium of teaching will continue and his books will be studied and people will benefit from them, he will receive a reward for it. Third, virtuous descendants. Training of children on the right lines is essential so that after a person's death they continue to pray for him. The prayer of children in favour of parents is highly useful.

1384. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The world, with all that it contains, is accursed except for the remembrance of Allah that which pleases Allah; and the religious scholars and seekers of knowledge.''
[At-Tirmidhi].

Commentary: This Hadith has already been mentioned. It does not mean that this world, and whatever is in it, is really cursed. What it in fact means is that such things of this world are cursed which make a person negligent of the remembrance of Allah; or it is cursed for those who in their whole life do not remember Allah. This Hadith has been mentioned in the present chapter, which relates to knowledge for the reason that acquisition of knowledge is essential to know that such and such work will be a source of winning the Pleasure of Allah and such and such act will incur His displeasure. This is the reason the teacher and the learner have been included in the exemptions from the curse.

1385. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who goes forth in search of knowledge is considered as struggling in the Cause of Allah until he returns.''
[At-Tirmidhi].

Commentary: In this Hadith the acquisition of knowledge has been equated with Jihad for the sake of Allah. Sheikh Al-Albani has regarded this Hadith weak in his "Takhriju Fiqh As-Sunnah''.

1386. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A believer never satisfies doing good until he reaches Jannah.''
[At-Tirmidhi].

Commentary: According to this Hadith, it is a quality of a Muslim that he is very much concerned about acquiring virtues and doing good, and he is never tired of struggling for them and live by them so much so that in this struggle he reaches the end of his life. By mentioning this Hadith in Kitab-ul-`Ilm it has been made evident that the best of the virtues is learning and teaching of religious knowledge because it is actually this knowledge which enables a person to distinguish between good and evil.

1387. Abu Umamah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The superiority of the learned over the devout worshipper is like my superiority over the most inferior amongst you (in good deeds).'' He went on to say, "Allah, His angels, the dwellers of the heaven and the earth, and even the ant in its hole and the fish (in water) supplicate in favour of those who teach people knowledge.''
[At-Tirmidhi].

Commentary: `Alim (learned person) here means scholar of the Qur'an and Hadith, who adheres to Faraid and Sunnah and remains busy in learning and imparting knowledge. `Abid (devout worshipper) is one who spends most of his time in the worship of Allah. The benefit of his voluntary prayer and remembrance of Allah is restricted to his own self while the benefit of knowledge of the scholar reaches others also. Hence, of the two, the latter is far superior.

If Salat is mentioned with reference to Allah, it denotes "Allah's Grace with Mercy;'' if it is mentioned with reference to the angels, it denotes "to pray for forgiveness;'' and if it is mentioned with reference to other creatures - men, animals, etc., - then it means prayer and supplication. Thus, Allah graces that person with His Mercy who teach people the beneficial knowledge, i.e., the knowledge of Islam; angels pray to Allah to forgive his (or her) sins; and other creatures pray for his (or her) well-being. In this way, this Hadith stresses the distinction of religious scholars and highlights the esteem in which they are held by Allah, His angels and His other creatures.

1388. Abud-Darda (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who follows a path in quest of knowledge, Allah will make the path of Jannah easy to him. The angels lower their wings over the seeker of knowledge, being pleased with what he does. The inhabitants of the heavens and the earth and even the fish in the depth of the oceans seek forgiveness for him. The superiority of the learned man over the devout worshipper is like that of the full moon to the rest of the stars (i.e., in brightness). The learned are the heirs of the Prophets who bequeath neither dinar nor dirham but only that of knowledge; and he who acquires it, has in fact acquired an abundant portion.''
[Abu Dawud and At-Tirmidhi].

Commentary: Like the preceding Ahadith, this Hadith also mentions the eminence of learning religious knowledge, and respecting and honouring `Ulama'.

1389. Ibn Mas`ud (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "May Allah freshen the affairs of a person who hears something from us and communicates it to others exactly as he has heard it (i.e., both the meaning and the words). Many a recepient of knowledge understands it better than the one who has heard it.''
[At-Tirmidhi].

Commentary: Besides mentioning the eminence of knowledge, this Hadith contains inducement for preaching and inviting people towards the path of Allah. It also urges us to communicate knowledge exactly as we have heard it, without changing anything in the least.

1390. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who is asked about knowledge (of religion) and conceals it, will be bridled with a bridle of fire on the Day of Resurrection.''
[Abu Dawud and At-Tirmidhi].

Commentary: We learn from this Hadith that to withhold guidance in the matter of religion from anybody who seeks it, is a grave sin which is threatened with Hell. Unfortunately, the religious scholars who are shackled in religious prejudices and terribly lack interest in juristic matters have developed a habit of concealing religious knowledge from people. In fact, this grave sin has become so alarming that any further delay to eradicate it will prove ruinous for us. May Allah grant us true guidance.

1391. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah(PBUH) said, "He who does not acquire knowledge with the sole intention of seeking the Pleasure of Allah but for worldly gain, will not smell the fragrance of Jannah on the Day of Resurrection.''
[Abu Dawud].

Commentary: This Hadith has an inducement for acquiring knowledge for the Pleasure of Allah alone. If a religious scholar acquires it to make it a means of worldly gains, then it turns to such a serious crime that such a scholar will not even smell the fragrance of Jannah (i.e., he will not enter it along with the saved). May Allah save us from it. However, if a scholar gains wealth and worldly gains through it without any intention, then it is altogether a different matter. In that case, it is not harmful for him as long as he uses it in a manner pleasing to Allah.

1392. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: I heard the Messenger of Allah (PBUH) saying: "Verily, Allah does not take away knowledge by snatching it from the people, but He takes it away by taking away (the lives of) the religious scholars till none of the scholars stays alive. Then the people will take ignorant ones as their leaders, who, when asked to deliver religious verdicts, will issue them without knowledge, the result being that they will go astray and will lead others astray.''
[Al-Bukhari and Muslim].

Commentary: It is a sign of the nearness of the Day of Judgement that the world will be deprived of genuine religious scholars, and illiterate people will become leaders who will have neither the knowledge of the Qur'an nor that of the Hadith. Despite their ignorance of the Qur'an and the Hadith, they will be called Mujtahid (jurist entitled to independent reasoning) and Imam (leader) and will mislead people with their legal opinions and self-created problems. Besides urging us to acquire religious knowledge with a view to producing more scholars in the society, this Hadith also warns us against the ignorant self-styled `Ulama'. It also warns us against entrusting religious leadership to them.


Book Thirteen: The Book of Praise and Gratitude to Allah

  • Chapter 242 : The Obligation of Gratitude


The Obligation of Gratitude

Chapter 242
The Obligation of Gratitude

Allah the Exalted says:

"Therefore, remember Me (by praying, glorifying). I will remember you, and be grateful to Me (for My countless Favours on you) and never be ungrateful to Me.'' (2:152)

"If you give thanks (by accepting Faith and worshipping none but Allah), I will give you more (of My Blessings).'' (14:7)

"And say: `All the praises and thanks be to Allah.''' (17:111)

"And the close of their request will be: `Al-hamdu lillahi Rabbil-`alamin [All the praise is due to Allah, the Rubb of `Alamin (mankind, jinn and all that exists)].''' (10:10)

1393. Abu Hurairah (May Allah be pleased with him) reported: On the Night of Al-Isra (the Night of Ascension) the Prophet (PBUH) was presented with two drinking vessels: one full of wine and the other one full of milk. He looked at them. Then he took the vessel which was full of milk. Thereupon Jibril (Gabriel) said: "Al-hamdu lillah (praise be to Allah) Who has guided you to that, which is in accord with Fitrah (i.e., Islamic Monotheism; pure nature of Islam). Had you selected wine, your people would have gone astray.''
[Muslim].

Commentary: This Hadith highlights the following points:

1. Islam is a religion which matches with the pure nature. Every sensible person accepts it instinctively.

2. One who is endowed with the capacity and aptitude to do good should praise Allah.

3. Wine is the root of all evils and for this reason has been regarded the "Mother of Vices''.

4. To take good omen from agreeable signs is Mustahabb (desirable).

1394. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Any matter of importance which is not begun with Al-hamdu lillah (praise be to Allah) remains defective.''
[Abu Dawud].

Commentary: There is another Hadith to the effect that every important work which is not started with the invocation "Bismillah'' is devoid of Allah's Grace. Sheikh Al-Albani's opinion about these two Ahadith is that their text is confused and its authority is weak. He has, however, regarded it as acceptable "Mursal'' (Ahadith narrated by a student of a Companion deleting the Companion's name). (For details please see Irwa-ul-Ghalil, vol. I, 1,2). In any case, it is desirable to begin every good work with the Glorious Name of Allah and His Praise.

1395. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When a slave's child dies, Allah the Most High asks His angels, `Have you taken out the life of the child of My slave?" They reply in the affirmative. He then asks, `Have you taken the fruit of his heart?' They reply in the affirmative. Thereupon he asks, `What has My slave said?' They say: `He has praised You and said: Inna lillahi wa inna ilaihi raji`un (We belong to Allah and to Him we shall be returned). Allah says: `Build a house for My slave in Jannah and name it as Bait-ul-Hamd (the House of Praise).'''
[At-Tirmidhi].

Commentary: This Hadith points out the eminence of patience and the merit of praising Allah in the event of a calamity, especially on the death of one's own child. Rather than weeping and wailing, one should submit himself to the Will of Allah and show perseverance. Such attitude of patience and resignation is highly meritorious and has great reward.

1396. Anas bin Malik (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Allah is pleased with His slave who says: `Al-hamdu lillah (praise be to Allah)' when he takes a morsel of food and drinks a draught of water.''
[Muslim].

Commentary: This Hadith has already been mentioned. "Aklah'' means to take a meal at one time, whether in the morning, the evening or at any other time. Similarly "Sharba'' means to drink water at any time. What the Hadith means is that to praise Allah on eating and drinking every time is a source of Allah's Pleasure, no matter whether the quantity one consumes is small or large.


Book Fourteen: The Book of Supplicating Allah to Exalt the Mention of Allah's Messenger (phuh)

  • Chapter 243 : The Obligation of Supplicating Allah to Exalt His Mention and its Excellence, and its Manner


The Obligation of Supplicating Allah to Exalt His Mention and its Excellence, and its Manner

Chapter 243
The Obligation of Supplicating Allah to Exalt His Mention and its Excellence, and its Manner

Allah, the Exalted, says:

"Allah exalts the mention of His Messenger (PBUH) and His angels supplicate Him to do so. O you who believe! supplicate Allah to exalt his mention and to grant him safety and security.

1397. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: I heard the Messenger of Allah (PBUH) saying: "Whoever supplicates Allah to exalt my mention, Allah will exalt his mention ten times.''
[Muslim].

Commentary: Recitation of Salat upon the Prophet (PBUH) means the recitation of benediction. Such as the one recited in Salat "O Allah, have mercy on Muhammad...)'' It is a prayer for mercy and exaltation of the Prophet (PBUH) which is highly meritorious. (At-Tirmidhi, Hadith Hasan).

1398. Ibn Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said: "The people who will be nearest to me on the Day of Resurrection will be those who supplicate Allah more often for me.''
[At-Tirmidhi].

Commentary: "Nearest to me'' signifies "those who are most entitled to my intercession''. Thus, this Hadith has also an inducement for very frequent recitation of Salat on the Prophet (PBUH).

1399. Aus bin Aus (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Among the best of your days is Friday; so supplicate Allah more often for me in it , for your supplications will be displayed to me.'' He was asked: "O Messenger of Allah! How will our blessings be displayed to you when your decayed body will have mixed with the earth?'' He (PBUH) replied, "Allah has prohibited the earth from consuming the bodies of the Prophets.''
[Abu Dawud].

Commentary: That "Allah has prohibited the earth from consuming the bodies of the Prophets'' means that the earth does not consume them. That "their Salat (salutations) will be presented to him'' indicates that angels present the salutation performed to him, as is elucidated in other Ahadith. Moreover, his soul is then returned to him and he answers the salutations also. (In the opinion of Muhaddithun, the Hadith relating to the return of the soul comes in the category of "Hadith Hasan'', i.e., it is acceptable).

1400. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "May his nose soil with dust in whose presence mention is made of me and he does not supplicate for me.''
[At-Tirmidhi].

Commentary: "May his nose soil with dust'' means to suffer humiliation and disgrace. That is "may such person be humiliated and disgraced who hears my name and does not invoke Allah's blessings upon me.'' Those who merely kiss thumbs of their hands can also be the addressee of this saying because they do not supplicate Allah for the Prophet (PBUH) while what is in fact ordained is salutation, and not kissing of thumbs. The latter gesture has not been ordained in any Hadith. Some religious scholars regard the salutation obligatory while others hold that it desirable.

1401. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Do not make my grave a place of festivity, and supplicate Allah for me, for your supplication reaches me wherever you are.''
[Abu Dawud].

Commentary: "Do not make my grave a place of festivity'' means do not gather there as people do on the festival of `Eid. Unfortunately, a fraction of heretics consider such festivities laudable. When the Prophet (PBUH) did not like such gatherings on his own grave, how can it be permissible on the death anniversaries of other people? Some people misinterpret this Hadith and contend that what it means is that `You should not come to my grave once in a while but very frequently'' although its real meaning is that which we have just mentioned. The next sentence confirms this contention. There is no need for frequent gathering for the reason that wherever a Muslim may be, the salutations which he performs to the Prophet (PBUH) will be conveyed to him through the angels. Every Muslim has a desire to visit the Prophet's grave, and there cannot be any doubt about its desirability, but there is no need to undertake journey for paying homage and salutation only. In fact, the real intention of going to Al-Madinah should be to visit Prophet's Mosque which will include visiting his grave. This is the real meaning of this Hadith. There is another Hadith which prohibits undertaking a journey to any mosque except the three which have been marked by the Prophet (PBUH).

1402. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whenever someone greets me, Allah returns the soul to my body (in the grave) and I return his greeting.''
[Abu Dawud].

Commentary: We learn from this Hadith that the Prophet (PBUH) is alive in his grave and he answers the salutation offered by a Muslim. But this life of his is the life of Barzakh (an intervening state between death and the Day of Resurrection, and whoever dies, enters it) the reality of which is not known to us. Thus, it is wrong to say that the life of the Prophet (PBUH) is like worldly life or more vigorous than it. Such a claim is baseless because it is not confirmed by the Qur'an and Hadith. Were he to be alive the way he was in his lifetime, there would have been no need for "the returning of the soul to his body'' and he would be able to answer the salutations without it. As far this ambiguity is concerned, when countless Muslims are always offering salutations to the Prophet (PBUH) how does the return of the soul takes place after such short intervals? Such questions arise due to the lack of certitude in the Omnipotence of Allah. When the Prophet (PBUH) stated that his soul is returned to him then we should have absolute faith in his statement because Allah is Capable of doing every thing. What is its nature and form, it is not known to us, nor can we know it. Thus, the question of the return of soul in the grave should be considered similar to the ambiguous Ayat of the Qur'an in which every Muslim is required to have blind faith but their secret is known to Allah Alone.

This Hadith has an inducement for offering more and more supplications for the Prophet (PBUH) so that the devotee is blessed with the maximum reward in the form of the Prophet's response to his salutations. It is certainly a great blessing which a Muslim should try every nerve to achieve.

1403. `Ali (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The miser is the one in whose presence I am mentioned but he does not supplicate for me.''
[At-Tirmidhi].

Commentary: "Miser'' means to deny someone his right. If a Muslim does not supplicate for him upon hearing his name, then such a person is a miser beyond doubt. Thus, we learn that one must recite Salat when he hears the name of the Prophet (PBUH). It is sufficient to say May Allah render him from evil and exalt his mention) for this purpose.

1404. Fadalah bin `Ubaid (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) heard some one supplicating after his prayer without praising Allah and without supplicating Allah for the Prophet (PBUH). With regard to him, the Messenger of Allah (PBUH) said, "This man rushed.'' Then he called him and said, "When any one of you have performed Salat (prayer) and wants to supplicate, let him praise Allah first then glorify Him in the beginning and then he should supplicate Allah for me. Then he may supplicate for whatever he likes.''
[Abu Dawud and At-Tirmidhi].

Commentary: "Fi salatihi" means that after the Salat or at the end of Salat, he heard someone invoking Allah. Similarly, "idha salla ahadukum'' means when one completes the Salat and invokes Allah. In any case, it is necessary to praise Allah and supplicate Him for the Prophet (PBUH) before invoking Allah.

1405. Abu Muhammad Ka`b bin `Ujrah (May Allah be pleased with him) reported: The Prophet (PBUH) came to us and we asked him, "O Messenger of Allah, we already know how to greet you (i.e., say As-salamu `alaikum), but how should we supplicate for you?'' He (PBUH) said, "Say: `Allahumma salli `ala Muhammadin, wa `ala `ali Muhammadin, kama sallaita `ala `ali Ibrahima, innaka Hamidum Majid. Allahumma barik `ala Muhammadin, wa `ala `ali Muhammadin, kama barakta `ala `ali Ibrahima, innaka Hamidum Majid [O Allah, exalt the mention of Muhammad and the family of Muhammad as you exalted the family of Ibrahim. You are Praised and Glorious. O Allah, bless Muhammad and the family of Muhammad as You blessed the family of Ibrahim. You are Praised and Glorious.'''
[Al-Bukhari and Muslim].

Commentary: In this Hadith, the Salam means the supplication which is recited in At-Tashahhud. The Companions of the Prophet (PBUH) used to recite it in At-Tashahhud in the manner taught by him. When Almighty Allah ordained Muslims to supplicate for the Prophet (PBUH), it raised the question in their minds as to the wordings of the benediction (as they already knew how to greet him). They asked the Prophet (PBUH) and he taught it. Invoking Allah's blessings upon the Prophet (PBUH) should be done in the manner which he (PBUH) has taught us, because in doing so we get the reward of following the guidance of the Prophet (PBUH).

1406. Abu Mas`ud Al-Badri (May Allah be pleased with him) reported: We were sitting in the company of Sa`d bin `Ubadah (May Allah be pleased with him), when the Messenger of Allah (PBUH) came to us. Bashir bin Sa`d said: "O Messenger of Allah! Allah has commanded us to supplicate for you, but how should we do that?'' The Messenger of Allah (PBUH) kept silent. We were much perturbed over his silence and we wished he did not asked him this question. The Messenger of Allah (PBUH) said, "Say: `O Allah, exalt the mention of Muhammad and the family of Muhammad as you exalted the family of Ibrahim. And bless Muhammad and the family of Muhammad as You blessed the family of Ibrahim. You are the Praised, the Glorified,' and the method of greeting (i.e., Salam) is as you know.''
[Muslim].

Commentary: In this Hadith, the Prophet (PBUH) has showed us that the manner of offering Salam was the same as the one mentioned in the previous Hadith. "Al'' means the wives of the Prophet (PBUH) and those of his relatives who were from Banu Hashim and Banu `Abdul-Muttalib and had embraced Islam. Some scholars are of the opinion that it is general and applies to all his followers.

This Hadith also teaches us that if one does not have knowledge of a religious matter, he must seek guidance from the knowledgeable scholars of Islam about it, rather than going by his opinion. Knowledgeable persons (scholars) here means persons who are well-versed in the Qur'an and Hadith and can answer questions in the light of them, and not from the sayings of others or from their own intelligence.

1407. Abu Humaid As-Sa`idi (May Allah be pleased with him) reported: The Companions of the Messenger of Allah (PBUH) said: "O Messenger of Allah! How should we supplicate for you?'' He (PBUH) replied, "Say: `Allahumma salli `ala Muhammadin wa `ala azwajihi wa dhurriyyatihi, kama sallaita `ala Ibrahima; wa barik `ala Muhammadin wa `ala azwajihi wa dhurriyyatihi, kama barakta `ala Ibrahima, innaka Hamidum-Majid (O Allah sent Your Salat (O Allah, exalt the mention of Muhammad and his wives and offspring as You exalted the mention of the family of Ibrahim, and bless Muhammad and the wives and the offspring of Muhammad as you blessed the family of Ibrahim. You are the Praised, the Glorious'.''
[Al-Bukhari and Muslim].

Commentary: "Azwaj'' is the plural of "Zauj'' that is a pair. This is the reason that in Arabic it applies to both, masculine as well as feminine. Man is the Zauj of woman and woman is the Zauj of a man. In any case, here it means the Prophet's wives who are eleven in number. Two of them had died during the lifetime of the Prophet (PBUH) and nine survived after him. Islam does not permit more than four wives to a Muslim but the Prophet (PBUH) was given the exclusive permission for numerous considerations which have been discussed by religious scholars at length.

This Hadith also refutes the opinion of those who do not include his pious wives in the category of his "Al''. The progeny of the Prophet (PBUH) includes his male and female children and their descendants. But after his death none except Fatimah (May Allah be pleased with her) and her children remained alive. In short, his "Al'' includes his wives and progeny.


Book Fifteen: The Book of the Remembrance of Allah

  • Chapter 244 : The Excellence of the Remembrance of Allah
  • Chapter 245 : Remembrance of Allah in all Conditions
  • Chapter 246 : Supplication at the time of going to Bed and Waking up
  • Chapter 247 : The Excellence of Gathering in which Allah is Remembered
  • Chapter 248 : Remembrance of Allah in the Morning and in the Evening
  • Chapter 249 : Supplication before going to Bed


The Excellence of the Remembrance of Allah

Chapter 244
The Excellence of the Remembrance of Allah

Allah, the Exalted, says:

"And the remembering (praising) of (you by) Allah (in front of the angels) is greater indeed [than your remembering (praising) of Allah in prayers]'' (29:45)

"Therefore remember Me (by praying, glorifying). I will remember you.'' (2:152)

"And remember your Rubb by your tongue and within yourself, humbly and with fear and without loudness in words, in the mornings and in the afternoons, and be not of those who are neglectful.'' (7:205)

"And remember Allah much, that you may be successful.'' (62:10)

"Verily, the Muslims (those who submit to Allah in Islam) men and women... (up to)... And the men and the women who remember Allah much with their hearts and tongues. Allah has prepared for them forgiveness and a great reward (i.e., Jannah).'' (33:35)

"O you who believe! Remember Allah with much remembrance. And glorify His Praises morning and afternoon [the early morning (Fajr) and `Asr prayers].'' (33:41,42)

1408. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "There are two statements that are light for the tongue to remember, heavy in the Scales and are dear to the Merciful: `Subhan-Allahi wa bihamdihi, Subhan-Allahil-Azim [Glory be to Allah and His is the praise, (and) Allah, the Greatest is free from imperfection)'.''
[Al-Bukhari and Muslim].

Commentary: This Hadith affirms that man's actions carry weight. On the Day of Judgement, his actions will be cast into the Balance. At that time Allah will endow these actions with weight, or according to some scholars, those records which register man's actions will be weighed. This is quite possible for the reason that Almighty Allah is Capable of weighing things without even their physical form. This discussion apart, when actions will be cast into the Balance, the formula mentioned in the Hadith, the utterance of which is very easy, will prove weighty. Every Muslim should make it a practice to repeat them frequently.

1409. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The uttering of the words: "Subhan-Allah (Allah is free from imperfection), Al-hamdu lillah (all praise is due to Allah), La ilaha illallah (there is no true god except Allah) and Allahu Akbar (Allah is the Greatest)' is dearer to me than anything over which the sun rises.''
[Muslim].

Commentary: This Hadith hightlights the fact that the formulas which mention the Praise and Glory of Allah, His Majesty and Oneness are liked by the Prophet (PBUH) more than anything in the world, because this is one of the virtues which will survive and will be rewarded, while the world and all that it has will perish.

1410. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who utters a hundred times in a day these words: `La ilaha illallahu, wahdahu la sharika lahu, lahul-mulku wa lahul-hamdu, wa Huwa `ala kulli sha'in Qadir (there is no true god except Allah. He is One and He has no partner with Him; His is the sovereignty and His is the praise, and He is Omnipotent),' he will have a reward equivalent to that for emancipating ten slaves, a hundred good deeds will be recorded to his credit, hundred of his sins will be blotted out from his scroll, and he will be safeguarded against the devil on that day till the evening; and no one will exceed him in doing more excellent good deeds except someone who has recited these words more often than him. And he who utters: `Subhan-Allahi wa bihamdihi (Allah is free from imperfection and His is the praise)' one hundred times a day, his sins will be obliterated even if they are equal to the extent of the foam of the ocean.''
[Al-Bukhari and Muslim].

Commentary: Here sins mean minor sins and those which do not relate to the rights of people. This point has already been elaborated in the preceding Ahadith.

1411. Abu Ayyub Al-Ansari (May Allah be pleased with him) reported: The Prophet (PBUH) said: "He who utters ten times: `La ilaha illallahu, wahdahu la sharika lahu, lahulmulku wa lahulhamdu, wa Huwa `ala kulli sha'in Qadir (there is no true god except Allah. He is One and He has no partner with Him. His is the sovereignty and His is the praise, and He is Omnipotent),' he will have a reward equal to that for freeing four slaves from the progeny of Prophet Isma`il.''
[Al-Bukhari and Muslim].

Commentary: "Slaves from the progeny of Isma`il'' is a simile for very precious slaves. That is, it has the same reward to which the emancipation of four very precious slaves is eligible.

1412. Abu Dharr (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me, "Shall I tell you the expression that is most loved by Allah?'' It is `Subhan-Allahi wa bihamdihi' (Allah is free from imperfection and His is the praise)'.''
[Muslim].

1413. Abu Malik Al-Ash`ari (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Wudu' is half of Salat, and the expression: `Subhan-Allah (Allah is free from imperfection)' fills the Balance, and the expression: `Al-hamdu lillah (praise be to Allah)' fills the space between the heavens and the earth.''
[Muslim].

Commentary: "Tuhur'' is purification or Wudu', while "Tahur'' is water or something which is used for purification. According to some scholars, `Faith'' means Salat. This is also the sense in which it has been used in the Qur'an: "And Allah would never make your Faith to be lost (i.e., your prayers).'' [2:143]. Thus when Salat is the Faith, the purification is a prerequisite for Salat. Salat is not valid without purification. Some scholars are of the opinion that Faith here means Faith in general, as the Shari`ah defines it: To sincerely accept and believe in all that the Prophet (PBUH) came with, i.e., sincere acceptance of Allah and His Prophet (PBUH).

"Purification is half of the Faith'' means the acceptance that purification is the most important article of Faith. It is like the saying of the Prophet (PBUH) that "Hajj is `Arafah'', which means that `Arafat (the place where the pilgrims stay on the 9th day of Dhul-Hijjah) is the most important element of the Hajj. Thus, this Hadith stresses the importance and merits of purification and offers an inducement for it. It also mentions the eminence of the invocations mentioned in the Hadith by saying that if they are given a form, they will fill the space between the heavens and the earth. In other words, it is a description of the infinite vastness of the Mercy and Grace of Allah.

1414. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: A bedouin came to the Messenger of Allah (PBUH) and said to him, "Teach me a few words to recite frequently.'' He (PBUH) said, "Say: "La ilaha illallahu wahdahu la sharika lahu; Allahu Akbar kabiran, wal-hamdu lillahi kathiran, wa subhan-Allahi Rabbil-`alamin; wa la hawla wa la quwwata illa billahil-`Azizil-Hakim (there is no true god except Allah the One and He has no partner with Him; Allah is the Greatest and greatness is for Him. All praise is due to Him. Allah, the Rubb of the worlds is free from imperfection; there is no might and power but that of Allah, the All-Powerful and the All-Wise.)''' The bedouin said: "All of these for my Rubb. But what is for me?'' Thereupon he (Messenger of Allah (PBUH)) said, "You should say: `Allahummaghfir li, warhamni, wahdini, warzuqni (O Allah! Grant me pardon, have mercy upon me, direct me to righteousness and provide me subsistence)'.''
[Muslim].

1415. Thauban (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) concluded his prayer, he would beg forgiveness from Allah thrice and then would recite: "Allahumma Antas-Salamu, wa minkas-salamu, tabarakta ya Dhal-Jalali wal-Ikram (O Allah, You are the Grantor of security, and security comes from You. You are Blessing, O You Who have majesty and nobility)!'' (Imam) Al-Awza`i, one of the narrators of this Hadith, was asked: "How forgiveness is to be sought?'' He answered: "The Messenger of Allah (PBUH) used to say: `Astaghfirullah! Astaghfirullah! (I beseech Allah for forgiveness, I beseech Allah for forgiveness)'.''
[Muslim].

1416. Al-Mughirah bin Shu`bah (May Allah be pleased with him) reported: Messenger of Allah (PBUH) used to say at the conclusion of prayer: "La ilaha illallahu wahdahu la sharika lahu, lahul-mulku, wa lahul-hamdu, wa Huwa `ala kulli shai'in Qadir. Allahumma la mani`a lima a'tayta, wa la mu`tiya lima mana`ta, wa la yanfa`u dhal-jaddi, minkal-jaddu (there is no true god except Allah. He is One and He has no partner with Him, His is the sovereignty and His is the praise, and He is Omnipotent. O Allah! None can deny that which You bestow and none can bestow that which You hold back; and the greatness of the great will be of no avail to them against You).''
[Al-Bukhari and Muslim].

Commentary: "Al-Jaddu'' means good luck and richness. That is, good fortune and prosperity will not be of any avail before Allah. What will really benefit a person before Him are Faith and virtuous deeds. The prayer quoted in this Hadith makes a special mention of His Oneness.

1417. It has been reported that `Abdullah bin Zubair (May Allah be pleased with them) used to recite after Taslim at the conclusion of every Salat (prayer): "La ilaha illallahu wahdahu la sharika lahu, lahul-mulku, wa lahul-hamdu, wa Huwa `ala kulli shai'in Qadir. La hawla wa la quwwata illa billah. La ilaha illallahu, wa la na`budu illa iyyahu, Lahun-ni`matu, wa lahul-fadlu, wa lahuth-thana'ul-hasan. La ilaha ilallahu, mukhlisina, lahud-dina, wa lau karihal-kafirun (there is no true god except Allah; He is One. To Him belongs the dominion and to Him is all praise, and He is Powerful over all things. There is no power and might except with (the help of) Allah. There is no God but Allah and we worship none except Him, to Him belongs the bounty and to Him belongs the grace, and to Him belongs all excellent praise; there is no deity but Allah. We reserve our devotion exclusively for Him though the disbelievers may detest it).'' Ibn Az-Zubair said: The Messenger of Allah (PBUH) used to celebrate Allah's Greatness in those terms after every Salat (prayer).
[Muslim].

Commentary: The invocation mentioned in this Hadith is ordained by the Prophet (PBUH) and was his practice. To recite Shahadah repeatedly after Salat and to offer benediction and salutations to the Prophet (PBUH) collectively is a self-invented formula and is not consonant with the practice of the Prophet (PBUH). It is, therefore, a heresy and will have no merit. Every Muslim has to follow only the preachings and practice of the Prophet (PBUH).

1418. Abu Hurairah (May Allah be pleased with him) reported: The poor Emigrants came to the Messenger of Allah (PBUH) and said: "The wealthy have gone with the highest ranks and lasting bliss.'' He asked: "How is that?'' They replied: "They offer Salat (prayer) as we offer it; they observe fast as we do; (and as they are wealthy) they perform Hajj and `Umrah, and go for Jihad, and they spend in charity but we cannot, and they free the slaves but we are unable to do so.'' The Messenger of Allah (PBUH) said, "Shall I not teach you something with which you may overtake those who surpassed you and with which you will surpass those who will come after you? None will excel you unless he who does which you do.'' They said: "Yes, please do, O Messenger of Allah'' He (PBUH) said, "You should recite: Tasbih (Allah is free from imperfection), Takbir (Allah is Greatest), Tahmid (Praise be to Allah) thirty-three times after each Salat.''
[Al-Bukhari and Muslim].

Abu Salih, the subnarrator of the Hadith said, when Abu Hurairah (May Allah be pleased with him) was asked about the manner of reciting Tasbih, Tahmid and Takbir, he said, "Recite: "Subhan-Allah, wal-hamdulillah, wallahu Akbar', till all are recited thirty-three times.

Commentary: This Hadith has already been mentioned, but with a slightly different wording with reference to Sahih Muslim. The elaboration made by Abu Salih apparently seems to indicate that all the three words should be recited in combination while other religious scholars have shown preference for reciting them separately. The purpose is, however, attained in either way. There does arise one question here: Should one recite each of these words thirty-three times or in all for thirty-three times? The wording of the Hadith does not make this clear. Other Ahadith, (which will follow soon) make it clear that each of these words is to be recited for thirty-three times. This is how their aggregate will come to ninety-nine. The Hadith that follows makes this point lear.

1419. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who recites after every prayer: Subhan-Allah (Allah is free from imperfection) thirty-three times; Al-hamdu lillah (praise be to Allah) thirty-three times; Allahu Akbar (Allah is Greatest) thirty-three times; and completes the hundred with: La ilaha illallahu, wahdahu la sharika lahu, lahul-mulku wa lahul-hamdu, wa Huwa `ala kulli shai'in Qadir (there is no true god except Allah. He is One and He has no partner with Him. His is the sovereignty and His is the praise, and He is Omnipotent), will have all his sins pardoned even if they may be as large as the foam on the surface of the sea.''
[Muslim].

1420. Ka`b bin `Ujrah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "There are some words, the reciters of which will never be disappointed. These are: Tasbih [saying `Subhan-Allah' (Allah is free from imperfection)], thirty-three times, Tahmid [saying `Al-hamdu lillah' (praise be to Allah)] thirty-three times and Takbir [saying `Allahu Akbar' (Allah is Greatest)] thirty-four times; and these should be recited after the conclusion of every prescribed prayer.''
[Muslim]

Commentary: "Muaqqibat'' means the words of Praise and Glorification of Allah which are recited after Salat. This Hadith says that the words "Allahu Akbar'' should be recited thirty-four times.

1421. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to seek (Allah's) protection after prayers in these words: "Alla-humma inni a`udhu bika minal-jubni wal-bukhl, wa a`udhu bika min an uradda ila ardhalil-`umur, wa a`udhu bika min fitnatid-dunya, wa a`udhu bika min fitnatil-qabr (O Allah, I seek refuge with You from cowardice, miserliness and from being sent back to a feeble age; and, seek refuge with You from the trials of this life and those of the grave).''
[Al-Bukhari].

Commentary: Some religious scholars are of the opinion that it is better to observe reciting this Du`a after concluding prayers, and that it is better to combine both. Some scholars say that the Prophet (PBUH) used to recite this Du`a just before Taslim, while he used to recite the Du`a mentioned earlier after Taslim.

1422. Mu`adh (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) took hold of my hand and said, "O Mu`adh! By Allah I love you, so I advise you to never forget to recite after every prayer: "Allahumma a`inni ala dhikrika, wa shukrika, wa husni `ibadatika (O Allah, help me remember You, to be grateful to You, and to worship You in an excellent manner).''
[Abu Dawud].

Commentary: This Hadith stresses the fact that one should seek the Help of Allah for His remembrance, thanksgiving and worship, because one cannot do anything without His Help and Support. It also shows the superiority of Mu`adh (May Allah be pleased with him) and the Prophet's love for him.

1423. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When anyone of you has done his Tashahhud during Salat (prayer), he should seek refuge in Allah against four things and say: "Allahumma inni a`udhu bika min `adhabi jahannam, wa min `adhabil-qabr, wa min fitnatil-mahya wal-mamat, wa min sharri fitnatil-masihid-dajjal (O Allah! I seek refuge in You from the torment of Hell, from the torment of the grave, from the trials of life and death, and from the mischief of Al-Masih Ad-Dajjal (Antichrist).''
[Muslim].

Commentary: "Trials of life'' means ordeals which one has to face in life and which can harm his Faith and body. "The trials of death'' means the troubles which one has to face before death. "Masih'' means Mumsuh-ul-`Ain, one who is squint. Ad-Dajjal (deceiver, impostor) refers to that man with a squint who will appear before the Day of Judgement. This is why he is called Al-Masih Ad-Dajjal. He will make claim of godhood and in order to test the Faith of people, Allah will get some supernatural works done from him. The pious ones would, however, recognize him and will save themselves from his trap. This will be a great trial indeed and one must seek refuge with Allah from it.

1424. `Ali (May Allah be pleased with him) reported: When the Messenger of Allah (PBUH) was in Salat (prayer), he used to supplicate towards the end of prayer after Tashahhud and before the concluding salutations: "Allahum-maghfir li ma qaddamtu wa ma akh-khartu, wa ma asrartu, wa ma a`lantu, wa ma asraftu, wa ma Anta a`lamu bihi minni. Antal-Muqqadimu, wa Antal-Mu'akh-khiru. La ilaha illa Anta (O Allah! Forgive my former and latter sins, which I have done secretly and those which I have done openly, and that I have wronged others, and those defaults of mine about which You have better knowledge than I have. You Alone can send whomever You will to Jannah, and You Alone can send whomever You will to Hell-fire. None has the right to be worshipped but You.''
[Muslim].

1425. `Aishah (May Allah be pleased with her) reported: The Prophet (PBUH) used to recite frequently in his bowing and prostration: "Subhanak-Allahumma, Rabbana wa bihamdika. Allahum-maghfir li (O Allah! You are free from imperfection and I begin with praising You. Forgive my sins).''
[Al-Bukhari and Muslim].

1426. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) used to recite in his bowing and prostration: "Subbuhun Quddusun, Rabbul-mala'ikati war-ruh [You are the Most Glorious. The Most Holy. You the Rubb of the angels and of Jibril
[Muslim].

Commentary: "Subbuh'' and "Quddus'' are two attributive Names of Allah which denote His Perfect Purity and Uniqueness. "Ar-Ruh'' means Jibril (Gabriel). Although he, too, comes in the category of angels but his special mention is made here to emphasize his majesty and honour. In short, the recitation of the prayers mentioned in this Hadith is in keeping with the practice of the Prophet (PBUH).

1427. Ibn `Abbas (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said: "Glorify your Lord in Ruku` (bowing posture) and exert yourself in supplication in prostration. Thus your supplications are liable to be accepted.''
[Muslim].

1428. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A slave becomes nearest to his Rubb when he is in prostration. So increase supplications while prostrating.''
[Muslim].

Commentary: Both the Ahadith mentioned above, evidently show that there is greater possibility of acceptance of an invocation which is made in prostration. Therefore, one must do it in the voulntary Salat.

1429. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to say in his prostration: Allahum-maghfir li dhanbi kullahu: diqqahu wa jillahu, wa `awwalahu wa akhirahu, wa alaniyatahu wa sirrahu (O Allah! Forgive all my sins, the small and the great, first and the last, the open and the secret).''
[Muslim].

Commentary: Although the Prophet (PBUH) was innocent and free of sins, he used to pray for the forgiveness of his shortcomings out of his gratitude to Allah's Might and Majesty. Thus, this Hadith has a great lesson for us. In spite of being innocent, he was always fearful of the Wrath of Allah, while we, despite being embodiments of sins, are fearless of Allah.

1430. `Aishah (May Allah be pleased with her) reported: One night I missed the Messenger of Allah (PBUH) from his bed. I searched for him. When I found him he was in bowing or prostrating posture and was reciting: Subhanaka wa bi hamdika. La ilaha illa Anta (You are free from imperfection and I begin praising You. There is no true god except You).''

Another narration is: My hand fell over his feet while he was in prostration with his feet erect. He was supplicating: "Allahumma inni a`udhu biridaka min sakhatika, wa bi-mu`afatika min `uqubatika, wa a`udhu bika minka, la uhsi thana'an `alaika, Anta kama athnaita `ala Nafsika (O Allah! I seek protection against Your Wrath in Your Pleasure. I seek protection in Your Pardon against Your chastisement, I am not capable of enumerating praise of You. You are as You have lauded Yourself).''

1431. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: We were with the Messenger of Allah (PBUH) when he asked, "Is anyone of you unable to earn a thousand good deeds?'' One of those present asked: "How can one earn thousand good deeds in a day?'' He (PBUH) replied, "By saying: Subhan Allah a hundred times, then one thousand good deeds will be recorded for him or one thousand sins will be blotted out from his record.''
[Muslim].

Commentary: One thousand good deeds in return for saying the word "Subhan-Allah'' is a minimum reward under the promise that says i.e., ten-fold reward would be given for each good deed. The words "Au yuhattu'' is open to disagreement among the religious scholars. Some of them have mentioned it with "Au'' which means one gets one thousand good deeds or a thousand sins are forgiven; while others have mentioned this Hadith with the word "Wa yuhattu'', that is, one is given a thousand virtues and a similar number of sins are pardoned.

1432. Abu Dharr (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Every morning charity is due from every joint bone of the body of every one of you. Every utterance of Allah's Glorification (i.e., Subhan-Allah) is an act of charity, and every utterance of praise of Him (i.e., Al-hamdu lillah) is an act of charity, and every utterance of profession of Faith (i.e., La ilaha illallah) is an act of charity, and every utterance of His Greatness (i.e., Allahu Akbar) is an act of charity; and enjoining good is an act of charity and forbidding what is disreputable is an act of charity; and two Rak`ah prayer which one offers in the forenoon (Ad-Duha) will suffice for all this.''
[Muslim].

Commentary: This Hadith has already been mentioned. See Hadith No. 118. It brings into prominence the distinction of the two Rak`ah of Ad-Duha as it is a means to express one's gratitude to Allah for 360 joints in one's body. Similarly, the Praise and Glorification of Allah, the declaration of His Oneness, enjoining good and forbidding vices are all Sadaqah of man's body.

1433. Juwairiyah bint Al-Harith (May Allah be pleased with her) reported, the Mother of the Believers: The Prophet (PBUH) came out from my apartment in the morning as I was busy in performing the dawn prayer. He came back in the forenoon and found me sitting there. The Prophet (PBUH) said, "Are you still in the same position as I left you.'' I replied in the affirmative. Thereupon the Prophet said, "I recited four words three times after I had left you. If these are to be weighed against all you have recited since morning, these will be heavier. These are: Subhan-Allahi wa bihamdihi, `adada khalqihi, wa rida nafsihi, wa zinatah `arshihi, wa midada kalimatihi [Allah is free from imperfection and I begin with His praise, as many times as the number of His creatures, in accordance with His Good Pleasure, equal to the weight of His Throne and equal to the ink that may be used in recording the words (for His Praise)].''
[Muslim].

Commentary: The recitation of the words quoted in this Hadith is highly meritorious and rewarding because they are full of Praise and Glorification of Allah.

1434. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The similitude of one who remembers his Rubb and one who does not remember Him, is like that of the living and the dead.''
[Al-Bukhari and Muslim].

Commentary: Lack of remembrance of Allah is akin to death. When a person dies, he is unable to do anything. Similarly, a person who does not remember Allah goes so far from Him that he cannot do anything which can benefit him.

1435. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Allah the Exalted says: `I am as my slave expects me to be, and I am with him when he remembers Me. If he remembers Me inwardly, I will remember him inwardly, and if he remembers Me in an assembly, I will remember him in a better assembly (i.e., in the assembly of angels).''
[Al-Bukhari and Muslim].

Commentary: "I am as my slave expects me to be'' means that one should have the conviction that He accepts repentance, grants pardon, relieves people of their tensions and emancipates them from their troubles. Along with this conviction one should do good deeds which please Allah and avoid such deeds which have been prohibited by Him. With this conduct, one should hope for the best from Allah. This approach is similar to that of a cultivator who ploughs his land, sows the seed, waters it, takes every possible care of it and then cherishes hope for a good crop. It can also be linked to the endeavours of a person who intends to become a scholar, or a physician or an engineer. The first and foremost requirement to pursue his ambition is to study the books through which he can gain the required knowledge. For every work one intends to do, one has to first make a foundation and then acquire the means essential for it. It is only then that one can hope to achieve one's aim.

Similar is the case of associating good hopes with Allah. Unless a person does not furnish the foundation of Faith and good deeds for it, it will be unwise to associate good hopes with Allah. A slave who rather than serving his master runs away or annoys him and still hopes that his master being so kind will not take him to task for his excesses would be called stupid by the people. The same is true of Allah, who is certainly the Most Compassionate, the Most Merciful and Forgiving. But for whom is He so? The answer is for His faithful and obedient slaves and not for those who are followers of Satan. For Satan and his followers, Allah's Decision is that: "I will fill Hell with you (Iblis) and those of them (mankind) that follow you, together.'' (38:85).

1436. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The Mufarridun have gone ahead.'' He was asked, "Who are the Mufarridun?'' He (PBUH) replied, "Those men and women who frequently celebrate the remembrance of Allah.''
[Muslim].

Commentary: This Hadith highlights the following two points: First, the eminence of plentiful remembrance of Allah. People who have this quality will be ahead of others in reward on the Day of Judgement. Second, people who remember Allah and are obedient to Him, be they men or women, will be rewarded equally. In the matter of reward no distinction will be made on the basis of their gender.

1437. Jabir (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "The best way to celebrate the remembrance of Allah is to say: La ilaha illallah (there is no true god except Allah).''
[At-Tirmidhi].

Commentary: Since the Shahadah is the basis of Islam, its repetition in abundance has the greatest eminence. Some religious scholars regard only La ilaha illallah as eminent, while others hold that the second part of it (Muhammad is the Messenger of Allah) is also included in it. Thus, in their opinion both these parts of the Shahadah should be recited together.

1438. `Abdullah bin Busr (May Allah be pleased with him) reported: One of the Companions said, "O Messenger of Allah. There are many injunctions of Islam for me. So tell me something to which I may hold fast.'' He said, "Keep your tongue wet with the remembrance of Allah.''
[At-Tirmidhi].

Commentary: Shara'i` is the plural of Shari`ah Shari`ah is in the sense of Mashru`ah, that is the Divine injunctions. These Divine injunctions are of various kinds, i.e., some of them are obligatory, some desirable and some voluntary. The obligatory ones are compulsory and their compliance is indispensable. What is termed as Mustahabbat (desirables) are also highly important for gaining the Pleasure of Allah. Similarly, voluntary acts are a means of getting close to Allah. Ordinary people are sometimes puzzled by the abundance of the latter and want to adhere to the first two, that is obligations and what comes in the category of desirables. A desire to this effect is mentioned in this Hadith. The Prophet (PBUH) answered the query in this matter by saying to the inquirer, "Keep your tongue wet with the remembrance of Allah.'' Keeping the tongue wet with the remembrance of Allah here means its abundant recitation. In other words, one should make the remembrance of Allah a permanent feature. If one is not able to do many voulntary good works, which some people find difficult, the remembrance of Allah will make up the deficiency in that regard.

1439. Jabir (May Allah be pleased with him) reported: The Prophet (PBUH) said, "For him who says: `Subhan-Allahi wa bi hamdihi (Allah is free from imperfection, and I begin with praising Him, and to Him),' a palm-tree will be planted in Jannah.''
[At-Tirmidhi].

Commentary: Jannah is so vast that we cannot even imagine its vastness. The planting of trees in return for the Praise and Glorification of Allah is, therefore, neither something difficult nor surprising. So, there should not be any hesitation in accepting it as a fact. Some people take it is as a metaphor for a plentiful reward.

1440. Ibn Mas`ud (May Allah be pleased with him) reported: Messenger of Allah (PBUH) said, "I met Ibrahim (PBUH) on the Night of Ascension (Al-Asra), and he said to me: `O Muhammad, convey my greetings to your Ummah, and tell them that Jannah has a vast plain of pure soil and sweet water. It is a plain levelled land. The plants grow there by uttering: Subhan-Allah, Al-hamdu lillah, La ilaha illallah and Allahu Akbar (Allah is free from imperfection; praise be to Allah; there is no true god except Allah; and Allah is Greatest).''
[At-Tirmidhi].

Commentary: Qi`an is the plural of Qa` which means plain levelled land that does not have any tree. Trees grow on the plain land of Jannah in return for remembrance and Glorification of Allah. The more one remembers Allah, the greater is the number of trees which grow on the piece of land that will be awarded to him.

1441. Abud-Darda (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Shall I not inform you of the best of your actions which are the purest to your Rubb, which exalt you to the high ranks, which are more efficacious than spending gold and silver (in charity), and better for you than you should encounter your enemies whom you will smite their necks and they will smite your necks?'' They said, "Certainly.'' He (PBUH) said, "Remembrance of Allah the Exalted.''
[At-Tirmidhi].

Commentary: This Hadith also tells us about the eminence of remembrance of Allah, as the basis of every good deed is remembrance of Allah and expression of one's devotion and obedience to Him. Without these two, even the greatest virtue is useless and is of no value. Thus, we must always bear it in mind that remembrance of Allah is superior to everything else.

1442. Sa`d bin Abu Waqqas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) and I went to see a woman. She had date-stones or pebbles in front of her, and she was counting and reciting Tasbih. [`Subhan-Allah' (Allah is free from imperfection)]. He said, "Shall I not inform you of what is easier or better than this for you?'' You should say: `Subhan-Allahi `adada ma khalaqa fis-sama', wa subhan-Allahi `adada ma khalaqa fil-ardi, wa subhan-Allahi `adada ma baina dhalika, wa subhan-Allahi `adada ma Huwa Khaliqun, wallahu Akbaru mithla dhalika, wal-hamdu lillahi mithla dhalika, wa la ilaha illallahu mithla dhalika, wa la hawla wa la quwwata illa billahi mithla dhalika (Subhan-Allah, equal to the number of what He created in the heaven; and Subhan-Allah, equal to the number of His creatures in the earth; and Subhan-Allah, equal to the number in between them; and Subhan-Allah equal to the number of those He will create).' Then say: `Allahu Akbar' (Allah is Greatest) in the same way. Then say: `Al-hamdu lillah' (praise be to Allah) in the same way. Then say: `La ilaha illallah' (there is no true god except Allah) in the same way. Then say: `La hawla wa la quwwata illa billah' (there is no change of a condition nor power except by Allah) in the same manner.''
[At-Tirmidhi].

Commentary: Sheikh Al-Albani has accepted this Hadith as Hasan because of the defect in its authority. He has stated that the original narration of it is without any reference to gravels and stones (of fruits) and that is "Sahih'' and has been mentioned by Imam Muslim in his Sahih with reference to Jawairiyah (May Allah be pleased with her). (See Riyad-us-Saliheen, edited by Sheikh Al-Albani).

1443. Abu Musa (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me, "Shall I not guide you to a treasure from the treasures of Jannah?'' I said: "Yes, O Messenger of Allah!'' Thereupon he (PBUH) said, "(Recite) `La hawla wa la quwwata illa billah' (There is no change of a condition nor power except by Allah).''
[Al-Bukhari and Muslim].

Commentary: In this Hadith the invocation "La hawla wa la quwwata illa billah'' has been regarded a treasure of Jannah or one of the most precious stores of Jannah. The reason for its high eminence seems to be that through it, one makes a confession of his utter weakness and helplessness and attributes all power and authority to Allah, and this is very much liked by Allah. This statement is an outright admission that man has no power and if he can prevent himself from any mischief or do any good deed, it is only by the Will of Allah and His Permission.


Remembrance of Allah in all Conditions

Chapter 245
Remembrance of Allah in all Conditions

Allah, the Exalted, says:

"Verily! In the creation of the heavens and the earth, and in the alternation of night and day, there are indeed signs for men of understanding. Those who remember Allah (always, and in prayers) standing, sitting, and lying down on their sides..'' (3:190,191)

1444. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) used to remember Allah at all times.
[Muslim].

Commentary: Such religious scholars take support from this Hadith who hold that the recitation of the Qur'an is permissible in a state of Janabah (resulting from coition) and menses. Imam Al-Bukhari is also included among those who hold this view. They say that the words "at all times'' clearly means that. The Prophet (PBUH) used to remember Allah (which includes the recitation of the Qur'an also) no matter whether he was in a state of minor or major pollution. For this reason, Sheikh Al-Albani has objected Imam An-Nawawi's mentioning these two exceptions (pollution resulting from coition and menses) in the relevant title, and has stated that there is no Hadith in support of these exceptions. In fact, the Hadith narrated by `A ishah (May Allah be pleased with her) contradicts this view. In the opinion of this school of thought, the Ahadith which prohibit the remembrance of Allah when a person is in the state of Janabah are weak in authority and are open to discussion. Thus, such Ahadith do not prove the prohibition. In the opinion of the second school of thought, which holds the opposite view, such Ahadith carry weight despite being weak in authority, because their weakness is not serious. Some of them even believe that such Ahadith come to the level of Hadith Hasan. So far logic is concerned, the viewpoint of the first school carries more weight but the reverence of the Qur'an also calls for caution. The best way to create conformity between the two views is that in inevitable situations one may go by the first view but in the ordinary circumstances it is better to follow the second view. Allah Alone knows what is right.

1445. Ibn `Abbas (May Allah be pleased with them) reported: The Prophet (PBUH) said, "If anyone intends to have (sexual intercourse) with his wife, he should say: "Bismillah! Allahumma janibnash-Shaitana, wa jannibish-Shaitana ma razaqtana (In the Name of Allah, O Allah! Keep us away from Satan and keep Satan away from what You have bestowed upon us);' and if Allah has ordained a child for them, Satan will never harm him.''
[Al-Bukhari and Muslim].

Commentary: One should recite the prayer mentioned in this Hadith before one cohabits with his wife. This will save him and his offspring from the evil effect of Satan. But it must be borne in mind that this prayer is to be recited before the intercourse and not during it.


Supplication at the time of going to Bed and Waking up

Chapter 246
Supplication at the time of going to Bed and Waking up

1446. Hudhaifah and Abu Dharr (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) went to bed, he would supplicate: "Bismika-Allahumma amut wa ahya (With Your Name, O Allah, I die and return to life)''; and when he woke up, he would supplicate thus: "Al-hamdu lillahilladhi ahyana ba`da ma amatana, wa ilaihin-nushur (All praise belongs to Allah Who has restored us back to life after causing us to die; and to Him shall we return).''
[Al-Bukhari].

Commentary: The greatest benefit of such Du`a is that one always remembers Allah and keeps Him all the time in mind.


The Excellence of Gathering in which Allah is Remembered

Chapter 247
The Excellence of Gathering in which Allah is Remembered

Allah, the Exalted, says:

"And keep yourself (O Muhammad (PBUH)) patiently with those who call on their Rubb (i.e., your companions who remember their Rubb with glorification, praising in prayers, and other righteous deeds) morning and afternoon, seeking His Face; and let not your eyes overlook them.'' (18:28)

1447. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Allah, the Exalted, has teams of angels who go about on the roads seeking those who remember Allah. When they find some people remembering Allah they call to one another and say, `Come to what you are looking for;' and they surround them with their wings till the space between them and the lowest sky is fully covered. Allah, the Exalted and Glorious, asks them (although He is best informed about every thing): `What are my slave saying?' They say: `They are glorifying Your Tasbih, Tahmid, Takbir, Tamjid, (i.e., they were declaring Your Perfectness, praising, remembering the Greatness and Majesty of Allah).' He asks: `Have they seen Me?' They reply, `No, indeed, they have not seen You.' He asks: `How would they act if they were to see Me?' Thereupon they reply: `If they were to see You, they would engage more earnestly in worshipping and glorifying You and would extol You more.' He would say: `What do they beg of Me?' They say, `They beg You for Your Jannah.' Allah says, `Have they seen My Jannah?' They say, `No, our Rubb.' He says: `How would they act if they were to see My Jannah?' They reply, `Were they to see it, they would more intensely eager for it.' They (the angels) say, `They seek Your Protection.' He asks, `Against what do they seek My Protection?' They (the angels) say, `Our Rubb, from the fire of Hell.' (He, the Rubb) says, `Have they seen the fire of Hell?' They say, `No. By Your Honour, they have not seen it.' He says: `How would they act if they were to see My Fire?' They say: `If they were to see it, they would more earnest in being away from it and fearing it. They beg of Your forgiveness.' He says: `I call you to witness that I hereby grant pardon to them and confer upon them what they ask for; and grant them protection against what they seek protection from.' One of the angels says: `Our Rubb, there is amongst them such and such slave who does not belong to the assembly of those who are participating in Your remembrance. He passed by them and sat down with them.' He says: `I also grant him pardon because they are the people by virtue of whom their associates will not be unfortunate'.''
[Al-Bukhari and Muslim].

(The narration in Muslim is also the same with minor changes in wordings).

Commentary: What kind of circles and gatherings of remembrance of Allah are referred to here? Obviously not those in which Allah is remembered in the ways invented by the participants themselves, i.e., repetition of the slogans "Allah-Hu'', "Haq-Allah'', etc.,which have not been mentioned in any Hadith. The repetition of any specific word, in a specific manner and in a peculiar surrounding (such as by putting the lights off) - this manner of conducting the remembrance of Allah is also not evident from the practice of the Prophet (PBUH) and his Companions. The circles and gatherings mentioned in this Hadith are those in which, the Prophet's Sunnah is fully observed. The words such as Subhan-Allah, Al-hamdu lillah, La ilaha illallah, Allahu Akbar etc., are recited and Praise and Glorification of Allah are done after Salat. The groups are quietly engaged in the remembrance of Allah, and those who attend the sermons and speeches delivered in mosques on Friday also come in this category of meetings and gatherings as these are ordained in Islam. This Hadith also highlights the distinction of Muslims who are engaged in the remembrance of Allah and the Du`a they recite on the suggested times and occasions.

1448. Abu Hurairah and Abu Sa`id Al-Khudri (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "When a group of people assemble for the remembrance of Allah, the angels surround them (with their wings), (Allah's) mercy envelops them, Sakinah, or tranquillity descends upon them and Allah makes a mention of them before those who are near Him.''
[Muslim].

Commentary: This Hadith also highlights the merits of remembrance of Allah and the high grades of the people indulging in it.

1449. Abu Waqid Al-Harith bin `Auf (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) was sitting in the mosque with his Companions when three people came to him. Two of them stepped forward to the Messenger of Allah (PBUH) and the third went away. Those two men stood by the side of Messenger of Allah (PBUH). One of them found a space in the circle and he filled it, while the other one sat behind him. When the Messenger of Allah (PBUH) finished, he said, "Shall I not inform you about these three people? One of them sought refuge with Allah and Allah gave him refuge; the second one felt shy and Allah showed kindness to his shyness (and so he was accommodated in that meeting), and the last one averted, and so Allah turned away His Attention from him.''
[Al-Bukhari and Muslim].

Commentary: This Hadith highlights the following three points:

1. The inducement for participation in the meetings held for the remembrance of Allah.

2. The merit of avoiding anything that causes inconvenience to people and distinction of those who are bashful.

3. The condemnation and evil consequences of avoiding, without any genuine reason, the meetings or gatherings which are held to remember Allah or to disseminate religious knowledge.

1450. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: Mu`awiyah (May Allah be pleased with him) came to an assembly in the mosque and asked them: "What has made you sit together?'' They replied, "We are sitting here to remember Allah.'' He said, "I adjure you by Allah to tell me whether nothing else has made you to sit together.'' They replied: "By Allah! We are sitting only to remember Allah.'' Then he said, "I did not adjure you because I suspected you. No one of my rank in the eyes of the Messenger of Allah (PBUH) is the narrator of so few traditions as I am. The fact is that the Messenger of Allah (PBUH) went out to a circle of his Companions and said, `What has made you sit there?' When they replied that they are sitting together to remember Allah and to praise Him for guiding them to Islam and bestowing favours on them, he (PBUH) said, `I adjure you by Allah to tell me that nothing else has made you sit together.' On their reply that there was certainly no other purpose, he (PBUH) said, `I did not adjure you because I suspected you, but Jibril (Gabriel) came to me and told me that Allah was talking proudly of you to the angels.'''

[Muslim].

Commentary: This Hadith, like those preceding it, mentions the merits of the meetings which are held for the remembrance of Allah as well as the distinction of those who participate in them.


Remembrance of Allah in the Morning and in the Evening

Chapter 248
Remembrance of Allah in the Morning and in the Evening

Allah, the Exalted, says:

"And remember your Rubb by your tongue and within yourself, humbly and with fear and without loudness in words in the mornings, and in the afternoons and be not of those who are neglectful.'' (7:205)

"And declare the perfectness of your Rubb before the rising of the sun, and before its setting.'' (20:130)

"And declare the perfectness of your Rubb and praise Him in the `Ashi (i.e., the time period after the midnoon till sunset) and in the Ibkar (i.e., the time period from early morning or sunrise till before midnoon).'' (40:55)

"In houses (mosques) which Allah has ordered to be raised (to be cleaned, and to be honoured), in them His Name is mentioned in the mornings and in the afternoons or the evenings. Men whom neither trade nor sale diverts from the remembrance of Allah (with heart and tongue).'' (24:36,37)

"Verily, We made the mountains to declare the Perfectness of Allah with him [Dawud (David)] in the `Ashi (i.e., after the midday till sunset) and Ishraq (i.e., after the sunrise till midday).'' (38:18)

1451. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who recites in the morning and in the evening the statement: `Subhan-Allahi wa bihamdihi (Allah is free from imperfection and I begin with praising Him)' one hundred times, will not be surpassed on the Day of Resurrection by anyone with better deeds than one who utters the same words or utters more of these words.''
[Muslim].

1452. Abu Hurairah (May Allah be pleased with him) reported: A man came to the Prophet (PBUH) and said, "What a trouble I suffered from a scorpion which stung me last night!'' He (PBUH) said, "Had you said in the evening: `A`udhu bikalimatillahit-tammati min sharri ma khalaqa (I seek the protection of Allah's Perfect Words from the evil of whatever He has created),' it would not have harmed you.''
[Muslim].

Commentary: Kalimat means the Words of Allah, His Decisions and His Power. At-Tamat being free from every defect and shortcoming. Thus, it means "I seek the protection of Allah, by means of faultless Words, Decisions and Power of Allah, from the mischief of every living being''. It is the best prayer for protection from dangerous animals, insects and people.

1453. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) used to say in the morning: "Allahumma bika asbahna, wa bika amsaina, wa bika nahya, wa bika namutu, wa ilaikan-nushur (O Allah! With Your Power we have come to the morning, with Your Power we come to the evening, with Your Power we live, and we die, and to You will we return).'' In the evening he would say: "Allahumma bika amsaina, wa bika nahya, wa bika namutu, wa ilaikan-nushur (O Allah! With Your Power, we have come to the evening, by You do we live, by You do we die, and to You is the return).''
[At-Tirmidhi and Abu Dawud].

1454. Abu Hurairah (May Allah be pleased with him) reported: Abu Bakr asked, "O Messenger of Allah! Teach me some words so that I may recite them in the morning and in the evening.'' The Messenger of Allah (PBUH) said, "Recite these words: `Allahumma fatiras-samawati wal-ardi, `alimal-ghaibi wash-shahadati, Rabba kulli shai'in wa malikahu. Ash-hadu an la ilaha illa Anta, a`udhu bika min sharri nafsi, wa sharrish-Shaitani wa shirkihi (O Allah! Creator of the heavens and the earth! Knower of the hidden and the exposed! Rubb of everything and every one. I bear witness that none has the right to be worshipped but You. I seek Your Protection from the evil of my own self from the evil of Satan and from the evil of Shirk to which he calls).''' The Messenger of Allah (PBUH) added: "Recite these words in the morning and the evening and when you go to bed.''
[Abu Dawud and At-Tirmidhi].

1455. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: When it was evening, the Prophet (PBUH) used to supplicate: "Amsaina wa amsal-mulku lillah, wal-hamdu lillah. La `ilaha illallahu wahdahu la sharika lahu (We have entered upon evening and the whole kingdom of Allah, too, has entered upon evening. Praise is due to Allah. There is none who has the right to be worshiped but Allah, the One who has no partner with Him).'' He (the narrator) said: I think that he (PBUH) used to follow the recitation with these words: "Lahul-mulku, wa lahul-hamdu, wa Huwa `ala kulli shi'in Qadir. Rabbi as'aluka khaira ma fi hadhihil-lailati, wa khaira ma ba`daha; wa a`udhu bika min sharri ma fi hadhihil-lailati, wa sharri ma ba`daha; Rabbi a`udhu bika minal-kasali, wa su'il-kibari; Rabbi a`udhu bika min `adhabin fin-nari, wa `adhabin fil-qabri (His is the sovereignty and to Him is all praise due, and He is Omnipotent. My Rubb, I beg of you good that lies in this night and good that follows it, and I seek refuge in You from the evil that lies in this night and from the evil of that which follows it. My Rubb! I seek refuge in You from lethargy and the misery of old age. O Allah! I seek Your Protection from the torment of Hell-fire and the punishment of the grave).'' When it was morning, he (PBUH) would recite the same, replacing the words: "We have entered upon evening and the whole kingdom of Allah, too, has entered upon evening'' with "We have entered upon morning and the whole kingdom of Allah entered upon morning.'' (Replace the words "Amsaina, amsa, hadhihil-lailati, ma ba`daha with Asbahna, asbaha, hadhal-yaumi, ma ba`dahu, respectively.)
[Muslim].

Commentary: It is desirable to recite the invocations cited in the Hadith in the morning and the evening and also when one goes to bed and awakes. The purpose is that the concept of Allah's Providence and Divinity remains alive all the time in one's mind. With these words one seeks Allah's Protection in life and the Hereafter from things which are harmful. One also begs for his safety and guidance in this life and the Hereafter. This Hadith fully expresses one's recognition of Allah's Godhood and Lordship.

1456. `Abdullah bin Khubaib (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me, "Recite Surat Al-Ikhlas and Al-Mu`awwidhatain (Surat Al-Falaq and Surat An-Nas) three times at dawn and dusk. It will suffice you in all respects.''
[Abu Dawud and At-Tirmidhi].

Commentary: "Recite Surat Al-Ikhlas and Al-Mu`awwidhatain (Surat Al-Falaq and Surat An-Nas) three times at dawn and dusk. It will suffice you in all respects'' means that then one would not need any other recitation for the remembrance of Allah. Moreover, by virtue of these three Surah, Allah will protect the reciter from every dangerous thing. In other Ahadith, it is stated that after lying in the bed, the Prophet (PBUH) used to recite these Surah, then blow on his hands and rub them over his body to the extent he could.

1457. `Uthman bin `Affan (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who recites three times every morning and evening: `Bismillahil-ladhi la yadurru ma`as-mihi shai'un fil-ardi wa la fis-sama'i, wa Huwas-Sami`ul-`Alim (In the Name of Allah with Whose Name there is protection against every kind of harm in the earth or in the heaven, and He is the All-Hearing and All-Knowing),' nothing will harm him.''
[Abu Dawud and At-Tirmidhi].

Commentary: The prayer cited in this Hadith means that "I seek the Protection of Allah by means of which one can save himself from every vice, whether it is an animal or man, a jinn or Satan because He is Aware of everyone's condition and Capable of hearing everybody's petition. He who comes in His Protection none can harm him, except that which He wills.''


Supplication before going to Bed

Chapter 249
Supplication before going to Bed

Allah, the Exalted, says:

"Verily! In the creation of the heavens and the earth, and in the alternation of night and day, there are indeed signs for men of understanding. Those who remember Allah (always, and in prayers) standing, sitting, and lying down on their sides, and think deeply about the creation of the heavens and the earth.'' (3:190,191)

1458. Hudhaifah and Abu Dharr (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to supplicate when he went to bed at night: "Bismik-Allahumma ahya wa amut (With Your Name, O Allah, I expire and return to life).''
[Al-Bukhari].

Commentary: Every person sleeps at night and gets up in the morning. Thus, in a way, sleep is death and reawakening is gaining life again. This life and death, like the literal life and death, lie in the Hands of Allah. The prayer cited in this Hadith engraves this concept in mind and when one recalls it every night it remains alive in his mind that "this life is for Allah and I am alive with His Will. Whenever He wills, the light of my life will be extinguished. Therefore, I should spend these few days of life lent to me by Him in accordance with His Will and not in His disobedience''.

1459. `Ali (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me and to Fatimah (May Allah be pleased with her) (Ali's wife and the Prophet's daughter), "When you go to bed, recite: Takbir (Allahu Akbar) thirty-three times and Tasbih (Subhan-Allah) thirty-three times and Tahmid (Al-hamdu lillah) thirty-three times.''

Another narration is: The Messenger of Allah (PBUH) said, "Recite Tasbih thirty-four times.''

Another narration is: The Messenger of Allah(PBUH) said, "Recite Takbir thirty-four times.''
[Al-Bukhari and Muslim].

Commentary: It is apparent from the difference in the narrations of this Hadith that the aggregate of the wordings has to be one hundred. For this purpose, one of these invocations should be recited thirty-four times. It will be quite in order if one recites either of the three for thirty-four times because the Ahadith on the subject say this number for any of them. In this connection two Ahadith have been mentioned by Imam An-Nawawi and the reciting of "Al-hamdu lillah'' thirty-four times occurs in An-Nasa'i. This formula of Glorification, Praise and Elevation of Allah's Name is to be recited after every obligatory Salat and before going to bed.

1460. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When any of you goes to bed, he should shake off (or dust off) his bedsheet because he does not know what might have fallen on it after he had left it. Then he should recite: `Bismika Rabbi wada`tu janbi, wa bika arfa`uhu, in amsakta nafsi farhamha, wa in arsaltaha fahfazha bima tahfazu bihi `ibadakas-salihin [With Your Name, my Rubb, I place my side (upon the bed) and with Your Grace I will raise it up. If You withhold my soul (cause me to die), have mercy on it but if You let it go (let me live), guard it against which You guarded Your pious slaves].'''
[Al-Bukhari and Muslim].

Commentary: This Hadith calls our attention to a very important matter that before going to bed, we must shake off our bed-sheet, mattresses, etc., because it is quite possible that some poisonous insect might have passed over it in our absence and the effects left by it may prove harmful to us. One should recite this prayer after shaking off the bed-sheet, mattresses, etc.

1461. `A ishah (May Allah be pleased with her) reported: Whenever the Messenger of Allah (PBUH) went to bed, he would blow upon his hands recite Al-Mu`awwidhat; and pass his hands over his body.
[Al-Bukhari and Muslim].

Commentary: "Al-Mu`awwidhat'' the Surah which give protection) are the three Surah of the Qur'an which have been mentioned in this Hadith. They are so named because the request for granting of protection is made to Allah by means of them. The last two Surah of the Qur'an, that is Surat Al-Falaq and Surat An-Nas, are called "Al-Mu`awwidhatain'' which means "Two Surah which give protection''. One must recite these Surah of the Qur'an before going to sleep so that one may, on the one hand, follow the practice of the Prophet (PBUH), and on the other one, finds the Protection of Allah.

1462. Al-Bara` bin `Azib (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "Whenever you intend to go to bed, perform Wudu' as is done for Salat (prayer); and then lie down on the right side and recite: `Allahumma aslamtu nafsi ilaika, wa fawwadtu amri ilaika, wal-ja'tu zahri ilaika, raghbatan wa rahbatan ilaika, la malja'a wa la manja minka illa ilaika, amantu bikitabik-alladhi anzalta, wa binabiyyik-alladhi arsalta [O Allah! I have submitted myself to You. I have turned my face to You, entrusted my affairs to You and relied completely on You out of desire for and fear of You (expecting Your reward and fearing Your punishment). There is no resort and no deliverer from (hardships) except You. I affirm my faith in Your Book which You have revealed, and in Your Prophet whom You have sent].' If you die during the night, you will die in the true religion. Let these words be your last words at night.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned. See Hadith No. 80. It points out the desirability of performing Wudu' before going to bed and reciting this Du`a which show the genuine worship and complete submission to Allah.]

1463. Anas (May Allah be pleased with him) reported: Whenever the Prophet (PBUH) went to his bed, he would say: "Al-hamdu lillah-illadhi at`amana wa saqana, wa kafana wa awana, fakam mimman la kafiya lahu wa la mu'wiya (Praise is due to Allah Who has fed us, provided us drink, satisfied us and gave us protection. Many are those who have no one to provide for them, or give them shelter).''
[Muslim].

Commentary: This Hadith impresses upon us that Almighty Allah is sufficient for mankind. That is, He saves us from our enemies, gives us sustenance, and provides us facilities of residence and living. Due thanks should be addressed to Him alone.

1464. Hudhaifah (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) intended to go to sleep, he would place his right hand under his (right) cheek and supplicate: "Allahumma qini `adhabaka yauma tab`athu `ibadaka (O Allah! Guard me against Your punishment on the Day when You will resurrect Your slaves).''
[At-Tirmidhi].

In a narration in Abu Dawud, Hafsah (May Allah be pleased with her) said: Before going to sleep the Messenger of Allah (PBUH) would recite this Du`a three times.

Commentary: This Hadith has a warning that one should never be unmindful of Allah's Wrath. In fact, one should always seek Allah's Protection and do such virtuous deeds which please Him so that one may be saved from the Divine retribution on the Day of Judgement.


Book Sixteen: The Book of Du'a (Supplications)

  • Chapter 250 : Issues regarding Supplications, their Virtues and Supplications of the Prophet (pbuh)
  • Chapter 251 : The Excellence of Supplicating in one's Absence
  • Chapter 252 : Some Verdicts Pertaining to Supplications
  • Chapter 253 : Superiority of Auliya' and their Marvels


Issues regarding Supplications, their Virtues and Supplications of the Prophet (pbuh)

Chapter 250
Issues regarding Supplications, their Virtues and Supplications of the Prophet (pbuh)

Allah, the Exalted, says:

"And your Rubb said: `Invoke Me, [i.e., believe in My Oneness (Islamic Monotheism)] (and ask Me for anything) I will respond to your (invocation).''' (40:60)

"Invoke your Rubb with humility and in secret. He likes not the aggressors.'' (7:55)

"And when My slaves ask you (O Muhammad (PBUH)) concerning Me, then (answer them), I am indeed near (to them by My Knowledge). I respond to the invocations of the supplicant when he calls on Me (without any mediator or intercessor).'' (2:186)

"Is not He (better than your gods) Who responds to the distressed one, when he calls on Him, and Who removes the evil?'' (27:62)

1465. An-Nu`man bin Bashir (May Allah be pleased with them) reported: The Prophet (PBUH) said, "Du`a (supplication) is worship.''
[Abu Dawud].

Commentary: What is prayer but an expression of one's humbleness and helplessness before Allah. The expression of one's weakness, inferiority and lowliness before the Infinite Power and Might of Allah is in fact the essence of worshipping Him. For this reason, prayer has been regarded as the essence of worship. Thus, prayer is reserved for Him Alone and it should not be addressed to anyone else in any case. Al-Qadi `Iyad said that Du`a is that act of worship which alone deserves to be referred to as `Ibadah, or worship, because when one observes it, one in fact shows drawing near to Allah, utter dedication to Him and rejection of all that He does not like and approve.

1466. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) liked comprehensive supplications or (Al-Jawami` - i.e., supplications with very few words but comprehensive in meanings), and discarded others.
[Abu Dawud].

1467. Anas (May Allah be pleased with him) reported: The supplication most often recited by the Prophet (PBUH) was: "Allahumma atina fid-dunya hasanatan, wa fil-akhirati hasanatan, wa qina `adhab-annar (O our Rubb! give us in this world that which is good and in the Hereafter that which is good, and save us from the punishment of the Fire).'''
[Al-Bukhari and Muslim].

In the narration of Muslim it is added that whenever Anas supplicated, he used to beseech Allah with this Du`a.

Commentary: It is desirable to recite this Du`a which is mentioned in the Qur'an (2:201) and which comprehends all that is good both in this life and the Hereafter. The Prophet (PBUH) made it a habit to recite this Du`a, and the Companions were eager to follow him in all his words and actions.

1468. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) used to supplicate: "Allahumma inni as'alukal-huda, wat-tuqa, wal-`afafa, wal-ghina (O Allah! I beseech You for guidance, piety, chastity and contentment).''
[Muslim].

Commentary: "Guidance'' means guidance towards virtue which one needs at every step. The ability to do good and steadfastness on the Right Path is also covered by the term guidance. To comply with the Orders of Allah and to prevent oneself from what He has forbidden is Taqwa (fear of Allah), the importance of which needs no elaboration. `Affaf is prevention from sins. It also means evasion from seeking help from others. Ghina means riches which makes one independent of others so much so that all one's hopes are centered on Allah Alone. The prayer quoted in this Hadith is very comprehensive indeed.

1469. Tariq bin Ashyam (May Allah be pleased with him) reported: Whenever a man entered the fold of Islam, the Prophet (PBUH) would show him how to perform Salat and then direct him to supplicate: "Allahumm-aghfir li, warhamni, wa-hdini, wa `afini, warzuqni (O Allah! Forgive me, have mercy on me, guide me, guard me against harm and provide me with sustenance and salvation).'''
[Muslim].

In another narration Tariq said: A man came to the Prophet (PBUH) and said to him: "O Messenger of Allah! What shall I say if I want to pray to my Rubb?'' He (PBUH) said, "Say: `Allahumma-ghfir li, warhamni, wa `afini, warzuqni (O Allah! Forgive me, have mercy on me, protect me and provide me with sustenance).' Surely, this supplication is better for you in this life and in the Hereafter.''

1470. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) supplicated: "Allahumma musarrifal-qulubi, sarrif qulubana `ala ta`atika (O Allah! Controller of the hearts, direct our hearts to Your obedience).''
[Muslim].

Commentary: This is a very important prayer because through it one seeks steadfastness in virtue. Everybody's heart is always open to troubles, turmoil and ordeals and he is drifting from one situation to the other. If he is not supported by Allah, he can deviate from the Right Path at any moment. For this reason, he has been required to pray to Allah to save his heart from turning towards evils and keep it towards Allah, because it is He Alone Who is Capable of controlling hearts.

1471. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Seek refuge in Allah against the turmoils, attacks of misfortunes, and evil of judgement and joys of the enemies.''
[Al-Bukhari and Muslim].

Commentary: The trouble of a trial which is unbearable for a person and from which he does not have the power to rid himself is called (juhd al-bala'), translated here as `turmoils'. Some people are of the opinion that it is synonymous with poverty combined with abundant children. But Al-Hafiz Ibn Hajar is of the view that it is only one of the several kinds of "Troubles of a Trial.'' "Ash-Shaqa' is the opposite of good fortune, that is, to pray for protection from misfortune. No Decision of Allah is wrong but some of His Decisions may be harmful for certain people while others are beneficial for them. This means that their goodness or badness is related to persons. What it signifies is that one should pray to Allah to keep one safe from such decisions which are harmful for him. "Shamatat'' the pleasure that one's enemy feels on one's trouble. In other words, it is prayed that Allah may protect one from any such trouble which is pleasing to one's enemy, because when a person is in trouble, his enemies feel pleasure over it. In this Hadith, one sentence was added by Abu Sufyan and during his old age he did not remember which one it was. But we learn from other Ahadith that it was "the pleasure of enemies''. (Ibn `Allan). This Hadith also shows the honesty and integrity of the narrators of Ahadith. They were honest to the extent that if a few words of supplication were added to a Hadith by its narrators, they would point it out. Some scholars have regarded these words an addition in the Hadith by its narrator, who is otherwise reliable, but it is not a problem of "addition of authority'' because in that case, the addition is the saying of the Prophet (PBUH) which is mentioned by one narrator and omitted by another. But here it is quite different as the narrator of the Hadith himself is pointing out the addition made by him. Such additional words are technically called "Mudraj''

1472. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to say: "Allahumm-aslih li diniyalladhi huwa `ismatu amri, wa aslih li dunyaya-llati fiha ma`ashi, wa aslih li akhirati-llati fiha ma`adi, waj`alil-hayata ziyadatan li fi kulli khair, waj`alil-mauta rahatan li min kulli sharrin (O Allah, make my religion easy for me by virtue of which my affairs are protected, set right for me my world where my life exists, make good for me my Hereafter which is my resort to which I have to return, and make my life prone to perform all types of good, and make death a comfort for me from every evil).''
[Muslim].

Commentary: This is a very comprehensive prayer which simply means: "O Allah! Help me spend all my life in complete devotion to You, doing what You like and avoiding what You dislike.''

1473. `Ali (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said to me, "Recite: `Allahumma-hdini wa saddidni (O Allah! Direct me to the Right Path and make me adhere to the Straight Path).'' Another narration is: `Allahumma inni as'aluk-alhuda was-sadad (I beg You for guidance and uprightness).''
[Muslim].

Commentary: "As-Sadad'' means correctness and uprightness. Here, it signifies "please grant me the ability to do everything in a correct manner'', that is in accordance with the practice of the Prophet (PBUH). Some scholars of Hadith have interpreted it as steadfastness and moderation. Both interpretations accord well with its original meanings.

1474. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to supplicate: "Allahumma inni a`udhu bika minal-ajzi wal-kasali, wal-jubni wal-harami, wal-bukhli, wa a`udhu bika min `adhabil-qabri, wa a`udhu bika min fitnatil-mahya wal-mamat [O Allah! I seek refuge in You from helplessness (to do good), indolence, cowardice, senility, and miserliness; and I seek Your Protection against the torment of the grave and the trials of life and death].'' Another narration adds: "wa dala`id-daini wa ghalabatir-rijal (And from the burden of indebtedness and the tyranny of men).''
[Muslim].

1475. Abu Bakr As-Siddiq (May Allah be pleased with him) reported: I requested the Messenger of Allah (PBUH) to teach me a supplication which I could recite in my Salat (prayer). Thereupon he said, "Recite: `Allahumma inni zalamtu nafsi zulman kathiran, wa la yaghfirudh-dhunuba illa Anta, faghfir li maghfiratan min `indika, warhamni, innaka Antal-Ghafur-ur-Rahim (O Allah! I have considerably wronged myself. There is none to forgive the sins but You. So grant me pardon and have mercy on me. You are the Most Forgiving, the Most Compassionate).'''
[Al-Bukhari and Muslim].

Commentary: It is desirable to recite this prayer in Salat after Tashahhud and before Taslim. One can also recite it at all other times also.

1476. Abu Musa (May Allah be pleased with him) reported: The Prophet (PBUH) used to supplicate: "Allahumm-aghfir li khati'ati, wajahli, wa israfi fi amri, wa ma Anta a`lamu bihi minni. Allahumm-aghfir li jiddi wa hazli, wa khata'i wa `amdi, wa kullu dhalika `indi. Allahumm-aghfir li ma qaddamtu wa ma akhkhartu, wa ma asrartu, wa ma a`lantu, wa ma Anta a`lamu bihi minni. Antal-Muqaddimu, wa Antal-Mu'akhkhiru; wa Anta `ala kulli shai'in Qadir (O Allah! Forgive my errors, ignorance and immoderation in my affairs. You are better aware of my faults than myself. O Allah! Forgive my faults which I committed in seriousness or in fun deliberately or inadvertently. O Allah! Grant me pardon for those sins which I committed in the past and I may commit in future, which I committed in privacy or in public and all those sins of which You are better aware than me. You Alone can send whomever You will to Jannah, and You Alone can send whomever You will to Hell-fire and You are Omnipotent).''
[Al-Bukhari and Muslim].

Commentary: The Prophet (PBUH) was sinless but still he prayed earnestly to Allah for the forgiveness of his shortcomings. In fact, he did so to educate his followers. This prayer is an expression of one's utter humbleness and sincere repentance of sins.

1477. `Aishah (May Allah be pleased with her) reported: The Prophet (PBUH) used to supplicate (in these words): "Allahumma inni audhu bika min sharri ma `amiltu, wa min sharri ma lam a`mal (O Allah! I seek refuge in You from the evil of that which I have done and the evil of that which I have not done).''
[Muslim].

Commentary: This prayer is also very comprehensive. Sometimes a person does a virtuous deed but it is tainted with slight hypocrisy or pride. It is an element which destroys even the most virtuous deeds. It is this mischief against which Allah's Protection has been sought through this prayer.

1478. `Abdullah bin `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) used to supplicate thus: "Allahumma inni a`udhu bika min zawali ni`matika, wa tahawwuli `afiyatika, wa fuja'ati niqmatika, wa jami`i sakhatika (O Allah! I seek refuge in You against the declining of Your Favours, passing of safety, the suddenness of Your punishment and all that which displeases You).''
[Muslim].

Commentary: This is also a very comprehensive prayer. Allah has blessed man with innumerable gifts. One becomes conscious of them when one is deprived of any of them, hence it is said that the value of a blessing is realized at its loss. For eyes, ears, tongue, health, property, children and such countless blessings, we owe gratitude to Allah. In the prayer cited in this Hadith, one entreats Allah not to deprive of any blessing given to him. `Afiyah means safe from disease, grief and troubles. "Passing of the safety (`Afiyah)'' signifies the change from a state of good health to a state of illness and weakness or that one is overtaken by troubles and afflictions.

1479. Zaid bin Arqam (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) would supplicate: "Allahumma inni a`udhu bika minal-`ajzi wal-kasali, wal-bukhli wal-harami, wa `adhabil-qabri. Allahumma ati nafsi taqwaha, wa zakkiha Anta khairu man zakkaha, Anta waliyyuha wa maulaha. Allahumma inni a`udhu bika min `ilmin la yanfau`, wa min qalbin la yakhsha`u, wa min nafsin la tashba`u, wa min da`watin la yustajabu laha` [O Allah! I seek refuge in You from the inability (to do good), indolence, cowardice, miserliness, decrepitude and torment of the grave. O Allah! Grant me the sense of piety and purify my soul as You are the Best to purify it. You are its Guardian and its Protecting Friend. O Allah! I seek refuge in You from the knowledge which is not beneficial, and from a heart which does not fear (You), and from desire which is not satisfied, and from prayer which is not answered].''
[Muslim].

Commentary: This Hadith contains the prayer for fear of Allah, beneficial knowledge (that is, the knowledge of the Qur'an and Hadith), patience and contentment.

1480. Ibn `Abbas (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) used to supplicate: "Allahumma laka aslamtu, wa bika amantu, wa `alaika tawakkaltu, wa ilaika anabtu, wa bika khasamtu, wa ilaika hakamtu. Faghfir li ma qaddamtu, wa ma akh-khartu, wa ma asrartu wa ma a`lantu, Antal-Muqaddimu, wa Antal-Mu`akhkhiru, la ilaha illa Anta (O Allah! to You I submit, in You I affirm my faith, in You I repose my trust, to You I turn in repentance and with Your Help I contend my adversaries and from You I seek judgement. O Allah! Grant me forgiveness for the faults which I made in past and those ones I may commit in the future, those which I committed secretly or openly. You Alone send whomever You will to Jannah, and You Alone send whomever You will to Hell-fire. There is none worthy of worship except You).'' Another narration adds: "La hawla wa la quwwata illa billah (There is no strength to resist evil and no power to do good except through Allah).''
[Al-Bukhari and Muslim].

Commentary: The prayer mentioned in this Hadith is, in fact, a Muslim's declaration to turn in every matter to Allah, and to care about His Pleasure and His Orders regarding every act. It is also a declaration to befriend people for His sake and to show enmity towards people for Him alone. May Allah give every Muslim the ability to make this prayer and to act according to the declaration that he makes through it.

1481. `Aishah (May Allah be pleased with her) reported: The Prophet (PBUH) used to supplicate: "Allahumma inni a`udhu bika min fitnatin-nari, wa `adhabin-nari, wa min sharril-ghina wal-faqri (O Allah! I seek refuge in You from the trials and the torment of the Fire and from the evils of wealth and poverty).''
[Abu Dawud and At-Tirmidhi].

Commentary: "The evils of wealth'' signify that one becomes so captivated by wealth that in his struggle to acquire it, he fails to discriminate between the lawful and the unlawful, or one may become proud and arrogant on account of his riches. The evils of poverty that one loses hope of Allah's Mercy and Compassion, or shows resentment against his fate and the Will of Allah, or deviates from the principles and requirements of integrity and honesty.

1482. Ziyad bin `Ilaqah reported: My uncle Qutbah bin Malik (May Allah be pleased with him) said that the Prophet (PBUH) used to supplicate: "Allahumma inni a`udhu bika min munkaratil-akhlaqi, wal-a`mali, wal-ahwa`i (O Allah! I seek refuge in You from undesirable manners, deeds, and aspirations).''
[At-Tirmidhi].

Commentary: The prayer is recited to seek Allah's Help in shunning bad manners and observing good manners and righteous deeds.

1483. Shakal bin Humaid (May Allah be pleased with him) reported: I asked: "O Messenger of Allah, teach me a prayer.'' He (PBUH) said, "Say: Allahumma inni a`udhu bika min sharri sam`i, wa min sharri basari, wa min sharri lisani, wa min sharri qalbi, wa min sharri maniyyi (O Allah! I seek refuge in You from the evils of my hearing, the evils of my seeing, the evils of my tongue; the evils of my heart and the evils of passions).''
[Abu Dawud and At-Tirmidhi].

Commentary: The evil mischief of ears lies in lending them to lies, calumnies, backbiting and other forbidden things (music etc.), or closing the ears to the truth. The mischief of eyes lies in finding faults with people, looking at what is forbidden to look at, and ignoring the Signs of Allah scattered everywhere in the universe. The mischief of the heart lies in occupying one's heart with the love of anyone else other than Allah. "Mani'' (semen) is that sticky fluid which comes out of the male organ after sexual gratification. Here it means the sexual organs. The mischief of these lie in using them in a sinful act. One is advised to safeguard one's ears, eyes, heart, sexual organs, and all the organs of one's body against their improper use in order to gain the Pleasure of Allah. One will be accountable for all these things on the Day of Judgement.

1484. Anas (May Allah be pleased with him) reported: The Prophet (PBUH) used to supplicate: "Allahumma inni a`udhu bika minal-barasi, wal-jununi, wal-judhami, wa sayyi'il-asqami' (O Allah! I seek refuge in You from leucoderma, insanity, leprosy and evil diseases).''
[Abu Dawud].

Commentary: Leucoderma is a disease which gives rise to the appearance of white spots on the skin of body. Leprosy is a disease which renders one's organs invalid. Madness is mental disorder. All these are very dangerous diseases. The Prophet (PBUH) has sought Allah's Protection against these and other diseases like paralysis, diabetes, facial paralysis, cancer, blindness, etc. May Allah save us from all such diseases.

1485. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) used to supplicate: "Allahumma inni a`udhu bika minal-ju`i, fa-innahu bi'sad-daji`u; wa a`udhu bika minal-khiyanati, fa-innaha bi'satil-bitanah' [O Allah! I seek refuge in You from hunger; surely, it is the worst companion. And I seek refuge in You from treachery; surely, it is a bad inner trait].''
[Abu Dawud].

1486. `Ali (May Allah be pleased with him) reported: A slave who had made a contract with his master to pay for his freedom, came to me and said: "I am unable to fulfill my obligation, so help me.'' He said to him: "Shall I not teach you a supplication which the Messenger of Allah (PBUH) taught me? It will surely prove so effective that if you have a debt as large as a huge mountain, Allah will surely pay it for you. Say: `Allahumm-akfini bihalalika `an haramika, wa aghnini bifadlika `amman siwaka (O Allah! Grant me enough of what You make lawful so that I may dispense with what You make unlawful, and enable me by Your Grace to dispense with all but You).''
[At-Tirmidhi].

Commentary: It is important to recite this Du`a in order to seek Allah's Help in paying one's debts and in avoiding to beg of people.

1487. `Imran bin Husain (May Allah be pleased with them) reported: The Prophet (PBUH) taught my father two statements to recite in his Du`a. These are: "Allahumma al-himni rushdi, wa a`idhni min sharri nafsi (O Allah! Inspire in me guidance and deliver me from the evils within myself).''
[At-Tirmidhi].

Commentary: "Al-Hidayah'' (guidance) means the ability to do good deeds. It is an indication of the right course for every action. "Deliver me from the evils within myself'' refers to the desires of the baser self which ruin both the worldly and religious life.

1488. Abul-Fadl Al-`Abbas bin `Abdul-Muttalib (May Allah be pleased with him) reported: I asked the Messenger of Allah (PBUH) to teach me a supplication. He (PBUH) said, "Beg Allah for safety (from all evils in this world and in the Hereafter).'' I waited for some days and then I went to him again and asked him: "O Messenger of Allah Teach me to supplicate something from Allah.'' He said to me, "O Al-`Abbas, the uncle of Messenger of Allah! Beseech Allah to give you safety (Al-a'fiyah ) in this life and in the Hereafter.''
[At-Tirmidhi].

Commentary: The prayer for "Al-a' fiyah'' includes peace and safety of one's religion and one's welfare in this world as well as in the Hereafter. This is also a very comprehensive prayer.

1489. Shahr bin Haushab reported: I asked Umm Salamah (May Allah be pleased with her), "O Mother of the Believers! Which supplication did the Messenger of Allah (PBUH) make frequently when he was in your house?'' She said: "He (PBUH) supplicated frequently: `Ya muqallibal-qulubi, thabbit qalbi `ala dinika (O Controller of the hearts make my heart steadfast in Your religion).''
[At-Tirmidhi].

Commentary: Steadfastness in religion is the conduct of great men, which cannot be acquired without the special Grace of Allah. There occur many turns in a person's life when he becomes slack or negligent in religious matters or when he deviates from the course prescribed by religion. This prayer has outstanding importance for such people who are faced with such a situation. They should recite this prayer very frequently. In fact they should make its recitation a permanent feature.

1490. Abud-Darda' (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "One of Prophet Dawud's supplications was: `Allahumma inni as'aluka hubbaka, wa hubba man yuhibbuka, wal-`amalalladhi yuballighuni hubbaka. Allahumm-aj`al hubbaka ahabba ilayya min nafsi, wa ahli, wa minal-ma'il-baridi (O Allah! I ask You for Your Love, the love of those who love You, and deeds which will cause me to attain Your Love. O Allah! Make Your Love dearer to me than myself, my family and the cold water).'''
[At-Tirmidhi].

Commentary: This Hadith contains an inducement for the Love of Allah and highlights the importance of those who are devoted to Allah and their good deeds because it is the virtuous deeds which are a means of attaining the Love of Allah and His Nearness.

1491. Anas (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Recite frequently: `Ya Dhal-Jalali wal-Ikram! (O You, Possessor of glory and honour).'''
[At-Tirmidhi].

Commentary: This Hadith tells us that one should make abundant use of the words `Ya-Dhal-Jalali wal-Ikram' in his prayer because these words contain the Praise of Allah and mention His Perfect Attributes. Some have said that Al-Jalal and Al-Ikram are Allah's Greatest Name.

1492. Abu Umamah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) made many supplications which we did not memorize. We said to him: "O Messenger of Allah! You have made many supplications of which we do not remember anything.'' He said, "Shall I tell you a comprehensive prayer? Say: `Allahumma inni as'aluka min khairi ma sa'alaka minhu nabiyyuka Muhammadun sallallahu `alaihi wa sallam. Wa `a`udhu bika min sharri mas-ta`adha minhu nabiyyuka Muhammadun sallallahu `alaihi wa sallam. Wa Antal-Musta`anu, wa `alaikal-balaghu, wa la hawla wa la quwwata illa billah (O Allah, I beg to You the good which Your Prophet Muhammad (PBUH) begged of You; and I seek refuge in You from the evil where from Your Prophet Muhammad (PBUH) sought refuge. You are the One from Whom help is sought and Your is the responsibility to communicate (the truth). There is no power or strength except with Allah the Exalted, the Great.'''
[At-Tirmidhi]

Commentary: For those who do not remember many prayers, or cannot remember them, this is the best supplication to make. This shows part of Allah's Mercy upon his slaves and part of the easiness of practising Islam.

1493. Ibn Mas`ud (May Allah be pleased with him) reported: One of the supplications of the Messenger of Allah (PBUH) was: "Allahumma inni as'aluka mujibati rahmatika, wa `aza'ima maghfiratika, was-salamata min kulli ithmin, wal-ghanimata min kulli birrin, wal-fawza bil-jannati, wannajata mina-nar (O Allah! I beg You for that which incites Your Mercy and the means of Your forgiveness, safety from every sin, the benefit from every good deed, success in attaining Jannah and deliverance from Fire).''
[Al-Hakim].

Commentary: Sheikh Al-Albani has regarded the Hadith as "Da`if'' (weak). One can, however, pray with the words quoted in this Hadith because these words contain prayer for Allah's Mercy and forgiveness, attainment of Jannah and protection from Hell. May Allah accept this prayer.


The Excellence of Supplicating in one's Absence

Chapter 251
The Excellence of Supplicating in one's Absence

Allah, the Exalted, says:

"And those who came after them say: `Our Rubb! Forgive us and our brethren who have preceded us in Faith.''' (59:10)

"And ask forgiveness for your sin, and also for (the sin of) believing men and believing women''. (47:19)

"Our Rubb! Forgive me and my parents, and (all) the believers on the Day when the reckoning will be established.'' (14: 41)

1494. Abud-Darda' (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "Whenever a Muslim supplicates for his (Muslim) brother in his absence, the angels say: `May the same be for you too'.''
[Muslim].

Commentary: This Hadith makes it evident that one who prays for someone in his absence also stands to benefit from it because the angel appointed for the task of praying for those who pray for others will pray for him, saying, "O Allah! Grant him also the same which he has asked for others.''

1495. Abud-Darda' (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The supplication of a Muslim for his (Muslim) brother in his absence will certainly be answered. Everytime he makes a supplication for good for his brother, the angel appointed for this particular task says: `A meen! May it be for you, too'.''
[Muslim].


Some Verdicts Pertaining to Supplications

Chapter 252
Some Verdicts Pertaining to Supplications

1496. Usamah bin Zaid (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "He who is favoured by another and says to his benefactor: `Jazak-Allah khairan (may Allah reward you well)' indeed praised (the benefactor) satisfactorily.''
[At-Tirmidhi].

Commentary: If one is unable to return someone's kindness with kindness, he should say, "Jazak-Allahu khairan (may Allah reward you well).'' This means: "I am unable to reciprocate your kindness. May Allah grant you the best reward for it.'' Obviously there is no match for the reward that one gets from Allah. For this reason the Prophet (PBUH) said that it was the best of the praise for a benefactor.

1497. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Do not invoke curses on yourself or on your children or on your possessions lest you should happen to do it at a moment when the supplications are accepted, and your prayer might be granted.''
[Muslim].

Commentary: Almighty Allah always listens to everyone's prayer but He has fixed certain times when He grants more prayers addressed to Him. Therefore, one should never curse oneself or one's own children or one's own business, etc., lest this is done at the time when prayers are accepted by Allah and then one has to regret it all his life.

1498. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A slave becomes nearest to his Rubb when he is in prostration. So increase supplications in prostrations.''
[Muslim].

Commentary: This Hadith points out the exellence of supplicating while prostrating in Salat, as one gets closer to Allah in this position.

1499. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH), "The supplication of every one of you will be granted if he does not get impatient and say (for example): `I supplicated my Rubb but my prayer has not been granted'.''
[Al-Bukhari and Muslim].

The narration of Muslim is: "The supplication of a slave continues to be granted as long as he does not supplicate for a sinful thing or for something that would cut off the ties of kinship and he does not grow impatient.'' It was said: "O Messenger of Allah! What does growing impatient mean?'' He (PBUH) said, "It is one's saying: `I supplicated again and again but I do not think that my prayer will be answered.' Then he becomes frustrated (in such circumstances) and gives up supplication altogether.''

Commentary: We learn from this Hadith that one should continue beseeching Allah without ever thinking that in spite of praying for a long time, his prayer has not been granted. One should never allow frustration to overcome in his mind. If a person's supplication is not granted for a long time, there would be certainly some good for him in that delay the reason of which is known to Allah Alone. It is, therefore, essential that he should never cease to pray whether his prayer is granted or not. Persistence in prayer is certainly beneficial to him.

1500. Abu Umamah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) was asked: "At what time does the supplication find the greatest response?'' He (PBUH) replied, "A supplication made during the middle of the last part of the night and after the conclusion of the obligatory prayers.''
[At-Tirmidhi].

Commentary: "Al-'Akhir'' is the characteristic of "Jauf'' and in the present context it means the late hours of night. "Jauf'' can also mean here "middle'', that is in the later-half of the night.

In other words, if the night is divided between two equal parts then it (Jauf) would be the middle of the second part. In either case it is the time of the night which in other Ahadith has been termed as the third part of the night. It is the time when Almighty Allah comes to descend on the sky of this world.

Prayers are also granted by Allah after the obligatory Salat.

1501. `Ubadah bin As-Samit (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Whenever a Muslim supplicates Allah, He accepts his supplication or averts any similar kind of trouble from him until he prays for something sinful or something that may break the ties of kinship.'' Upon this someone of the Companions said: "Then we shall supplicate plenty.'' The Messenger of Allah (PBUH) said, "Allah is more plentiful (in responding).''
[At-Tirmidhi].

Commentary: We learn from this Hadith that prayer (supplication) is beneficial to us in any case, because Almighty Allah either grants the prayer we make, or if the supplication is not being accepted, He removes some future trouble that was destined for us, or He grants us in full in the Hereafter.

A Muslim should never feel shy of praying to Allah. In fact, he should persistently pray because there is no end to His Treasures.

1502. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) used to say when he was in distress: "La ilaha illallahul-Azimul-Halim. La ilaha illallahu Rabbul-`Arshil-`Azim. La ilaha illallahu Rabbus-samawati, wa Rabbul-ardi, wa Rabbul-`Arshil-Karim. (None has the right to be worshipped but Allah the Incomparably Great, the Compassionate. None has the right to be worshipped but Allah the Rubb of the Mighty Throne. None has the right to be worshipped but Allah the Rubb of the heavens, the Rubb of the earth, and the Rubb of the Honourable Throne).''
[Al-Bukhari and Muslim].

Commentary: The only medicine in a time of distress is the remembrance of Allah Whose Help alone should be sought. This Du`a contains words which glorify Allah and exalt Him far above all else. It is desirable to recite these words when one is in distress as this is exactly what the Prophet (PBUH) used to recite in such situations.


Superiority of Auliya' and their Marvels

Chapter 253
Superiority of Auliya' and their Marvels

Allah, the Exalted, says:

"No doubt! Verily, the Auliya' of Allah [i.e., those who believe in the Oneness of Allah and fear Allah much (abstain from all kinds of sins and evil deeds which He has forbidden), and love Allah much (perform all kinds of good deeds which He has ordained)], no fear shall come upon them nor shall they grieve. Those who believed (in the Oneness of Allah - Islamic Monotheism), and used to fear Allah much (by abstaining from evil deeds and sins and by doing righteous deeds). For them are glad tidings, in the life of the present world (i.e., through a righteous dream seen by the person himself or shown to others), and in the Hereafter. No change can there be in the Words of Allah. This is indeed the supreme success.'' (10: 62-64)

"And shake the trunk of date-palm towards you, it will let fall fresh ripe-dates upon you. So eat and drink.'' (19: 25,26)

"Every time he (Zakariya) entered Al-Mihrab to (visit) her, he found her supplied with sustenance. He said: `O Maryam (Mary)! From where have you got this?' She said, `This is from Allah.' Verily, Allah provides sustenance to whom He wills, without limit.'' (3:37)

"(The young men said to one another): `And when you withdraw from them, and that which they worship, except Allah, then seek refuge in the Cave; your Rubb will open a way for you from His Mercy and will make easy for you your affair (i.e., will give you what you will need of provision, dwelling). And you might have seen the sun, when it rose, declining to the right from their Cave, and when it set, turning away from them to the left...'' (18:16,17)

1503. `Abdur-Rahman bin Abu Bakr (May Allah be pleased with them) reported: The Companions of As-Suffah were poor people. The Prophet (PBUH) said, "Whoever has food enough for two people, should take a third one (from among them), and whoever has food enough for four persons, should take a fifth or sixth (or said something similar).'' Abu Bakr (May Allah be pleased with him) took three people with him while Messenger of Allah (PBUH) took ten. Abu Bakr (May Allah be pleased with him) took his supper with the Prophet (PBUH) and stayed there till he offered the `Isha' prayers. After a part of the night had passed, he returned to his house. His wife said to him: "What has detained you from your guests?'' He said: "Have you not served supper to them?'' She said: "They refused to take supper until you come.'' [Abdur-Rahman (Abu Bakr's son) or the servants] presented the meal to them but they refused to eat. I (the narrator) hid myself out of fear. Abu Bakr (May Allah be pleased with him) (my father) rebuked me. Then he said to them: "Please eat. By Allah! I will never eat the meal.'' `Abdur-Rahman added: Whenever we took a morsel of the meal, the meal grew from underneath more than that morsel we had till everybody ate to his satisfaction; yet the remaining food was more than what was in the beginning. On seeing this, Abu Bakr (May Allah be pleased with him) called his wife and said: "O sister of Banu Firas! What is this?'' She said: "O pleasure of my eyes! The food has increased thrice in quantity.'' Then Abu Bakr (May Allah be pleased with him) started eating. He said: "My oath not to take the meal was because of Satan.'' He took a morsel handful from it and carried the rest to the Prophet (PBUH). That food remained with him. In those days there was a treaty between us and the pagans and when the period of that treaty elapsed, he (PBUH) divided us into twelve groups and every group was headed by a man. Allah knows how many men were under the command of each leader. Anyhow, all of them ate of that meal.
[Al-Bukhari and Muslim].

There are some more narrations in both Al-Bukhari and Muslim with very minor differences in wordings and in details.

Commentary: We learn the following points from this Hadith:

1. It is permissible to take students of religious schools home for meals, as was the practice in certain areas in the past.

2. A father can admonish his children for disciplinary purposes.

3. If a better situation develops, one can break his vow and go for the new and better choice. It is, however, necessary to expiate for breaking the vow.

4. This Hadith affirms miracles. This is evident from the fact that a small quantity of food was so blessed by Allah that all the members of the family, guests, the Prophet (PBUH) and twelve "Arif'' (leader) along with their companions took that food. (Gist of the text of Hadith from Fath Al-Bari, Kitab Al-Manaq.)

1504. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "There were Muhaddithun (the recipients of Divine inspiration) among the nations before you. If there is any of such Muhaddith among my followers, he must be `Umar.''
[Al-Bukhari].

In Muslim, this Hadith is narrated by `Aishah (May Allah be pleased with her), and in both these narrations Ibn Wahb has said that the meaning of Muhaddithun is recipients of Divine inspiration.

Commentary: "Mulhamun'' [persons endowed with inspiration]; in other words, things are put in their hearts by Allah, it was done in the case of the mother of Prophet Musa. It was put in her mind by Allah that if she felt any fear, she should then trust the child to the sea. Maryam (Mary) also used to receive inspiration, which is also a form of marvel. This Hadith evidently shows the distinction of `Umar (May Allah be pleased with him).

1505. Jabir bin Samurah (May Allah be pleased with them) said: The inhabitants of Kufah complained to `Umar (May Allah be pleased with him) against Sa`d bin Abu Waqqas (May Allah be pleased with him) and `Umar (May Allah be pleased with him) appointed `Ammar (May Allah be pleased with him) as Governor of Kufah in his place. Their complaint was that he did not even conduct As-Salat (the prayers) properly. `Umar (May Allah be pleased with him) sent for Sa`d and said to him: "O Abu Ishaq, the people claim that you do not offer the Salat properly.'' Sa`d replied: "By Allah! I observe Salat according to the Salat of the Messenger of Allah (PBUH), and I make no decrease in it. I prolong Qiyam (standing) in the first two Rak`ah in Maghrib and `Isha' prayers and shorten in the last ones.'' `Umar (May Allah be pleased with him) said: "This is what I thought of you, O Abu Ishaq!'' Then he sent with him a man (or some men) to Kufah to investigate the matter about him (from the people of Kufah). The inquiry was conducted in every mosque and all the people in these mosques praised him; but in the mosque of the Banu `Abs, a man, with the name of Usamah bin Qatadah and surname Abu Sa`dah, stood up and said, "Sa`d bin Abu Waqqas did not participate in Jihad and he did not distribute the spoils equitably and did not judge justly.'' On this Sa`d said: "I shall make three supplications in respect of him: O Allah! If this slave of Yours is a liar and seeker of notoriety, please prolong his life and lengthen his period of adversity and afflict him with trials.'' (And so did it happen.) Thereafter, when the man was asked about his condition he would say, "I am an old man afflicted with trials and overtaken by the curses of Sa`d.''

`Abdul-Malik bin `Umair (a subnarrator) said: I saw this man with eyebrows hung over his eyes as a result of his old age and he walked aimlessly, following young girls and winking at them.
[Al-Bukhari and Muslim].

Commentary: This Hadith brings out the following four points:

1. The distinction of Sa`d bin Abu Waqqas (May Allah be pleased with him) and the fact that his prayers were granted by Allah.

2. The principle that if inquiry is conducted against anybody, one should inquire the opinion of the righteous and worthy people about the person against whom complaint is made.

3. Government officials can be dismissed in the interest of public good, as `Umar (May Allah be pleased with him) dismissed Sa`d bin Abu Waqqas although the complaints made against him were false, but `Umar thought it wise to dismiss him so that no one amongst his subject would show hatred towards him.

4. This Hadith also proves the correctness of marvels. The acceptance of the prayer of Sa`d bin Abu Waqqas is an instance of it.

1506. `Urwah bin Az-Zubair (May Allah be pleased with him) reported: Arwa bint Aus brought a suit against Sa`id bin Zaid bin `Amr bin Nufail (May Allah be pleased with him). She complained to Marwan bin Al-Hakam that he had wrongfully taken possession of a portion of her land. Sa`id said: "How can I take a portion out of her land while I have heard a denunciation from the Messenger of Allah (PBUH).'' Marwan asked him: "What did you hear from the Messenger of Allah?'' He said, "I heard the Messenger of Allah (PBUH) saying, `He who takes a span of land unjustly will be made to wear seven earths round his neck on the Day of Ressurection'.'' Marwan said to him: "I don't seek proof from you after this.'' Sa`id supplicated: "O Allah! If she is a liar, deprive her of her eye sight and cause her to die in her land.'' `Urwah said: "She did not die till she became blind. While she was walking in her land (concerning which the dispute arose) she fell down into a pit and died.''
[Al-Bukhari and Muslim].

In another narration of Muslim, Muhammad bin Zaid bin `Abdullah bin `Umar said that he had seen Arwa blind, feeling for on the walls with her hand and saying: "I am ruined by the curse of Sa`id.'' Later she fell in a well in the same disputed land and died.

Commentary: Sa`id bin Zaid was an eminent Companion of the Prophet (PBUH) and had the honour of being one from the group of Al-`Ashratul-Mubashsharuna bil-Jannah Marwan bin Al-Hakam (May Allah be pleased with him) was governor of Al-Madinah during the caliphate of Mu`awiyah, and the incident quoted in this Hadith relates to that particular period. After Mu`awiyah bin Yazid, he remained caliph for some months.

This Hadith brings into prominence the following points:

1. The distinction of Sa`id bin Zaid and the marvel which came about with the acceptance of his prayer by Allah.

2. One should always save oneself from the curse of the pious people because the punishment can occur in this very life.

1507. Jabir bin `Abdullah (May Allah be pleased with them) said: My father called me on the evening before (the battle of) Uhud and said: "I perceive that I shall be among the first from among the Companions of the Prophet (PBUH) to be martyred, and after him you are the dearest to me. I am under the burden of debt. Pay it and treat your sisters well.'' Next morning he was among the first to be killed, so I buried him along with another in the same grave. Thereafter, I did not like that I should leave him with another in the grave. So I dug up his corpse after six months and he was in the same condition in which he was on the day when I buried him, except that there was a scratch on his ear. Then I buried him in a separate grave.
[Al-Bukhari].

Commentary: This Hadith highlights the following five points:

1. The Companions' love for the Prophet (PBUH) exceeded everything else, even one's own life and children.

2. The Companions' ardent desire for martyrdom.

3. The sixth sense of Jabir's father that he would be honoured with martyrdom.

4. The miracle that his dead body remained intact and did not decompose even after the period of six months.

5. The justification to exhume a dead body, in case of need. This permission is subject to the condition that much time has not passed since the burial of the deceased.

1508. Anas (May Allah be pleased with him) reported: Two Companions of the Prophet (PBUH) left his home in a very dark night with something like lights in front of them; when they separated, each of them had one light in front of him till they arrived home.
[Al-Bukhari].

Other narrations reported in Al-Bukhari say that the two men were Usaid bin Hudhair and `Abbad bin Bishr (May Allah be pleased with them).

Commentary: What was akin to light? Some people say it was their walking sticks which gave a shining effect in darkness and showed them their way. Some say that it was the light of the Prophethood. Thus, it was a marvel of the Companions and a miracle of the Prophet (PBUH).

1509. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) sent an espionage mission of ten men under the leadership of `Asim bin Thabit Al-Ansari (May Allah be pleased with him). They proceeded till they reached Al-Had'ah, a place between `Usfan and Makkah and the news of their arrival reached a section of the tribe of Hudhail, called Banu Lihyan. About one hundred men, who were all archers, hurried to follow their tracks. When `A sim and his companions came to know of their pursuers, they took refuge in a safe place. The infidels encircled them and said to them: "Come down and surrender, and we promise and guarantee you that we will not kill anyone of you.'' `Asim bin Thabit (May Allah be pleased with him) said: "By Allah! I will not come down to be under the protection of disbelievers. O Allah! convey this news to our Prophet (PBUH).'' Then the infidels shot arrows at them till they killed `Asim. Three men came down relying on their promise and covenant. They were Khubaib, Zaid bin Ad-Dathinah and another man. When the disbelievers captured them, they tied them up with the strings of their bows. The third of the captives said: "This is the beginning of first betrayal. By Allah! I will not go with you. I have a good example in these (martyrs).'' So they dragged him and tried to compel him to accompany them, but he refused. At last they killed him. They took Khubaib and Zaid bin Ad-Dathina with them and sold them as slaves in Makkah. This incident took place after the battle of Badr.

Khubaib was bought by the sons of Al-Harith bin `Amir bin Naufal bin `Abd Manaf. It was Khubaib who had killed Al-Harith in the battle of Badr. Khubaib remained a prisoner with those people for a few days till the sons of Al-Harith resolved to kill him.

When Khubaib (May Allah be pleased with him) got wind of this plot, he borrowed a razor from one of Al-Harith's daughters in order to remove his pubic hair. Her little son crawled towards Khubaib because of her carelessness. Later on, she saw her son on his thigh and the razor was in his hand. She got scared so much that Khubaib noticed the agitation on her face and said: "Are you afraid that I will kill him? No, I will never do that.'' She later remarked (after Al-Khubaib got martyred): "By Allah! I never saw a prisoner better than Khubaib.'' She added: "By Allah! I saw him once eating of a bunch of grapes in his hand while he was chained and there was no such fruit at that time in Makkah. Probably it was a boon which Allah bestowed upon Khubaib.''

When they took him out of the Haram of Makkah to kill him outside its boundaries, Khubaib requested them to let him offer two Rak`ah of voluntary prayer. They allowed him and he offered two Rak`ah prayer. Then he said: "Had I not apprehended that you would think that I was afraid of death, I would have prolonged the prayer. O Allah! Count their number; slay them one by one and spare not one of them.'' He then recited these poetic verses:

`I do not care how they kill me as long as I get martyred in the Cause of Allah as a Muslim. I received my death for Allah's sake. If Allah so desires, He will bless, the amputated limbs of the torn body.'

Then the son of Al-Harith killed him. It was Khubaib who set the tradition for any Muslim sentenced to death in captivity to offer two Rak`ah of voluntary prayer. On that day the Messenger of Allah (PBUH) informed his Companions of the martyrdom of Khubaib. Later on, when some disbelievers from Quraish were informed that `Asim had been martyred, they sent some people to fetch a significant part of his body to ascertain his death. (This was because) `Asim had killed one of their chiefs. So Allah sent a swarm of wasps, resembling a shady cloud, to hover over the body of `Asim and to shield him from their messengers, and thus they could not cut off anything from his body.
[Al-Bukhari].

Commentary: "Raht'' means a group or party. Some people say it consisted of six persons - `Asim bin Thabit, Marthad bin Abu Marthad, Khubaib bin `Adi, Zaid bin Ad-Dathina, `Abdullah bin Tariq and Khalid bin Bukair (May Allah be pleased with him) Some say that it comprised ten persons. Allah knows better.

The incident reported in this Hadith has many miracles and marvels. For instance, according to his prayer, the news of his assassination was conveyed by Allah through Wahy to the Prophet (PBUH) on the very day when he was martyred and he (PBUH) informed his Companions about it.

Second, Allah provided Khubaib with grapes when they were out of season during his imprisonment.

Third, Allah sent wasps for the safety of `Asim's corpse.

Fourth, his enemies met with the evil end which he had imprecated for them.

This Hadith brings forth the following six points:

1. If one's enemy shows strictness and oppression, then he should not accept the offer of protection from them even if he is killed as a result of this. One can, however, try to save his life if he sees some signs of leniency in the enemy's attitude.

2. The matchless perseverance and steadfastness of the Companions of the Prophet (PBUH) and their patience on the tyrannies perpetrated on them by their enemies.

3. Even in the worst of circumstances, the Companion of the Prophet (PBUH) (i.e., Khubaib) maintained the best standard of morality and did not harm the enemy's child in any way.

4. If the enemy is bent upon killing, then it is permissible to request them for permission to offer two Rak`ah of voluntary Salat because this act of Khubaib (May Allah be pleased with him) was upheld by the Prophet (PBUH).

5. It is lawful to imprecate for oppressors and disbelievers.

There are many Ahadith on the validity of marvels and miracles which have been mentioned in the present book in different chapters. The following instances can be quoted in this respect:

1. The incident of the boy who used to visit a priest and a magician. (See the Chapter on Patience).

2. The story of Juraij (which occurs in the Chapter on Sincerity).

3. The story of the men of the cave, the entrance of which was closed with a huge stone. (The Chapter on Generosity).

4. The story of the man who had heard the voice from the clouds ordering them to shower rain on a particular garden (the Chapter on Generosity).

Many other incidents also come in this category which are supported by evidence and are well-known. Allah is Capable of doing everything.

1510. Ibn `Umar (May Allah be pleased with them) reported: I never heard `Umar (May Allah be pleased with him) relating anything that he conceived it to be so-and-so, but that it proved to be as he had conceived it.''

[Al-Bukhari].

Commentary: This Hadith tells us about the distinction of `Umar (May Allah be pleased with him) and confirms the marvels which Allah manifested through him. Almighty Allah had endowed him with abundant sagacity and intelligence. For this reason, the Prophet (PBUH) stated that if there would ever be a man in his Ummah who will be gifted with inspiration, this man would be `Umar (May Allah be pleased with him).


Book Seventeen: The Book of the Prohibited Actions

  • Chapter 254 : The Prohibition of Backbiting and the Commandment of Guarding one's Tongue
  • Chapter 255 : Prohibition of Listening to Backbiting
  • Chapter 256 : Some cases where it is permissible to Backbite
  • Chapter 257 : Prohibition of Calumny
  • Chapter 258 : Prohibition of Carrying tales of the Officers
  • Chapter 259 : Condemnation of Double-faced People
  • Chapter 260 : Condemnation and Prohibition of Falsehood
  • Chapter 261 : Falsehood that is Permissible
  • Chapter 262 : Ascertainment of what one Hears and Narrates
  • Chapter 263 : Prohibition of Giving False Testimony
  • Chapter 264 : Prohibition of Cursing one Particular Man or Animal
  • Chapter 265 : Justification of Cursing the Wrongdoers without Specifying one of them
  • Chapter 266 : Prohibition of Reviling a Muslim without any cause
  • Chapter 267 : Prohibition of Abusing the Deceased without a valid Legal reason approved by Shari'ah
  • Chapter 268 : Prohibition of Maligning
  • Chapter 269 : Prohibition of Nursing Rancor and Enmity
  • Chapter 270 : Prohibition of Envy
  • Chapter 271 : Prohibition of Spying on Muslims and to be Inquisitive about Others
  • Chapter 272 : Prohibition of Suspicion
  • Chapter 273 : Prohibition of Despising Muslims
  • Chapter 274 : Prohibition of Rejoicing over another's Trouble
  • Chapter 275 : Prohibition of Deriding one's Lineage
  • Chapter 276 : Prohibition of Deceiving others
  • Chapter 277 : Prohibition of the Treachery and Breaking one's Covenant
  • Chapter 278 : Prohibition of Recounting of Favors
  • Chapter 279 : Prohibition of Arrogance and Oppression
  • Chapter 280 : Prohibition of Breaking ties and Relationships
  • Chapter 281 : Prohibition of two Holding Secret Counsel to the Exclusion of Conversing together a Third
  • Chapter 282 : Prohibition of Cruelty
  • Chapter 283 : Prohibition of Chastisement with Fire
  • Chapter 284 : Prohibition of Procrastinating by a Rich Person to Fulfill his Obligation
  • Chapter 285 : Undesirability of giving a Gift and then ask back for it
  • Chapter 286 : Prohibition of devouring the Property of an Orphan
  • Chapter 287 : Prohibition of taking Ar-Riba (The Usury)
  • Chapter 288 : Prohibition of Show-off
  • Chapter 289 : Things not to be Considered as Showing off
  • Chapter 290 : Prohibition of gazing at women and Beardless Handsome Boys except in Exigency
  • Chapter 291 : Prohibition of Meeting a non-Mahram Woman in Seclusion
  • Chapter 292 : Prohibition for Men and Women apeing one another
  • Chapter 293 : Prohibition of following the Manners of Satan and Disbelievers
  • Chapter 294 : Forbidding to Dye Hair Black
  • Chapter 295 : On Prohibition of Shaving a part of Head
  • Chapter 296 : Prohibition of Wearing False Hair, Tattooing and Filling of Teeth
  • Chapter 297 : Prohibition of Plucking Grey Hairs
  • Chapter 298 : Prohibition of using the right hand for cleaning after toilet without a valid reason
  • Chapter 299 : Undesirability of Wearing one Shoe or Sock
  • Chapter 300 : Prohibition of Leaving the Fire Burning
  • Chapter 301 : Prohibition of putting oneself to Undue Hardship
  • Chapter 302 : Prohibition of Bewailing the Deceased
  • Chapter 303 : Prohibition of Consultation with Soothsayers
  • Chapter 304 : Forbiddance of Believing in Ill Omens
  • Chapter 305 : Prohibition of Drawing Portraits
  • Chapter 306 : Prohibition of Keeping a Dog except as a Watchdog or Hunting Dog
  • Chapter 307 : Undesirability of Hanging Bells round the Necks of Animals
  • Chapter 308 : Undesirability of Riding a Camel which eats Animals' waste
  • Chapter 309 : Prohibition of Spitting in the Mosque
  • Chapter 310 : Undesirability of Quarrelling or Raising voices in the Mosque
  • Chapter 311 : Undesirability of Entering the Mosque after Eating raw Onion or Garlic
  • Chapter 312 : Undesirability of Sitting with Erected Legs during Friday Sermon
  • Chapter 313 : Prohibition of having a Hair cut or paring one's nail during the first ten days of Dhul-Hijjah for one who intends to Sacrifice an Animal
  • Chapter 314 : Prohibition of Swearing in the name of anything besides Allah
  • Chapter 315 : Illegality of Swearing Falsely
  • Chapter 316 : Desirability of Expiating the Oath taken by a Person who afterwards Breaks it for a better Alternative
  • Chapter 317 : Expiation of Oaths
  • Chapter 318 : Abomination of Swearing in Transaction
  • Chapter 319 : About Begging in the Name of Allah
  • Chapter 320 : Prohibition of Addressing somebody as 'The King of Kings'
  • Chapter 321 : Prohibition of Conferring a Title of Honor upon a Sinner, a Hypocrite, and the Like
  • Chapter 322 : Undesirability of Reviling Fever
  • Chapter 323 : Prohibition of Reviling the Wind
  • Chapter 324 : Undesirability of Reviling the Rooster
  • Chapter 325 : Prohibition of Attributing Rain to the Stars
  • Chapter 326 : Prohibition of Calling a Muslim an Infidel
  • Chapter 327 : Prohibition of Obscenity
  • Chapter 328 : Undesirability of Pretentiousness and Exaggeration during Conversation
  • Chapter 329 : Abomination of Self-Condemnation
  • Chapter 330 : Undesirability of Calling Grapes 'Al-Karm'
  • Chapter 331 : Prohibition of Describing the Charms of a Woman to a man without a valid reason approved by the Shari'ah
  • Chapter 332 : Abomination of saying- "Forgive me if you wish, O Allah!"
  • Chapter 333 : Abomination of saying- "What Allah Wills and so-and-so Wills"
  • Chapter 334 : Abomination of Holding Conversation after 'Isha' (Night) Prayer
  • Chapter 335 : Prohibition of Refusal by a Woman when her Husband calls her to his Bed
  • Chapter 336 : Prohibition of Observing an Optional Saum (Fast) by a Woman without the Permission of her Husband
  • Chapter 337 : Prohibition of raising one's Head before the Imam
  • Chapter 338 : Prohibition of Placing the hands on the sides during As-Salat (The Prayer)
  • Chapter 339 : Abomination of Joining As-Salat (The Prayer) when the Food is ready or when one is in desperate need to answer the call of Nature
  • Chapter 340 : Prohibition of raising one's Eyes towards the sky during As-Salat (The Prayer)
  • Chapter 341 : Undesirability of Glancing in one Direction of the other during Prayer
  • Chapter 342 : Prohibition of facing the Graves during Salat (Prayer)
  • Chapter 343 : Prohibition of passing in front of a Worshipper while he is offering Salat (Prayer)
  • Chapter 344 : Undesirability of offering optional Prayer after the announcement of Iqamah
  • Chapter 345 : Abomination of Selecting Friday for Fasting
  • Chapter 346 : Prohibition of Extending Fast beyond one Day
  • Chapter 347 : Prohibition of Sitting on the Graves
  • Chapter 348 : Prohibition of Plastering and Building over the Graves
  • Chapter 349 : Prohibition for a Slave to run away from his Master
  • Chapter 350 : Undesirability of Intercession in Hudud
  • Chapter 351 : Prohibition of Relieving Nature on the Paths
  • Chapter 352 : Prohibition of Urinating into Stagnant Water
  • Chapter 353 : Prohibition of giving preference to Children over one another in giving Gifts, etc.
  • Chapter 354 : Prohibition of Mourning beyond Three Days (For Women)
  • Chapter 355 : Prohibition of Malpractices in Commerce
  • Chapter 356 : Prohibition of Squandering Wealth
  • Chapter 357 : Prohibition of Pointing with a Weapon at another Brother in Faith
  • Chapter 358 : Undesirability of Leaving the Mosque without offering Salat (Prayer) after the Adhan has been Proclaimed
  • Chapter 359 : Undesirability of Rejecting the Gift of Perfume
  • Chapter 360 : Undesirability of Praising a Person in his Presence
  • Chapter 361 : Undesirability of departing from or coming to a Place stricken by a Epidemic
  • Chapter 362 : Prohibition of Magic
  • Chapter 363 : Prohibition of Carrying the Qur'an into the Land of Enemy
  • Chapter 364 : Prohibition of using Utensils made of Gold and Silver
  • Chapter 365 : Prohibition of Wearing Saffron-Colored Dress
  • Chapter 366 : Prohibition of observing silence from Dawn till Night
  • Chapter 367 : Prohibition of attributing wrong Fatherhood
  • Chapter 368 : Prohibition of doing that which Allah and His Messenger have Prohibited
  • Chapter 369 : Expiation for the violation of Commandments of Allah


The Prohibition of Backbiting and the Commandment of Guarding one's Tongue

Chapter 254
The Prohibition of Backbiting and the Commandment of Guarding one's Tongue

Allah, the Exalted, says:

"And backbite not one another. Would one of you like to eat the flesh of his dead brother? You would hate it (so hate backbiting). And fear Allah. Verily, Allah is the One Who forgives and accepts repentance, Most Merciful.'' (49:12)

"And follow not (O man, i.e., say not or do not or witness not) that of which you have no knowledge. Verily, the hearing, and the sight, and the heart, of each of those ones will be questioned (by Allah).'' (17:36)

"Not a word does he (or she) utter, but there is a watcher by him ready (to record it).'' (50:18)

1511. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "He who believes in Allah and the Last Day must either speak good or remain silent.''
[Muslim].

1512. Abu Musa Al-Ash`ari (May Allah be pleased with him) reported: I asked the Messenger of Allah (PBUH): "Who is the most excellent among the Muslims?'' He said, "One from whose tongue and hands the other Muslims are secure.''
[Al-Bukhari and Muslim].

1513. Sahl bin Sa`d (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Whosoever gives me a guarantee to safeguard what is between his jaws and what is between his legs, I shall guarantee him Jannah.''
[Al-Bukhari].

Commentary: What is between the jaws and what is between the legs refers to the tongue and the sexual organs, respectively. The Prophet (PBUH) has given the assurance of Jannah to every Muslim who protects these two parts of the body. Protection here means their use permitted by the Islamic Shari`ah. They should be guarded against every act that is prohibited by the Shari`ah.

1514. Abu Hurairah (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "A person utters a word thoughtlessly (i.e., without thinking about its being good or not) and, as a result of this, he will fall down into the fire of Hell deeper than the distance between the east and the west.''
[Al-Bukhari and Muslim].

Commentary: This Hadith shows the disadvantages which can be caused by the improper use of the tongue. It is, therefore, essential that one should think before he speaks.

1515. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A man utters a word pleasing to Allah without considering it of any significance for which Allah exalts his ranks (in Jannah); another one speaks a word displeasing to Allah without considering it of any importance, and for this reason he will sink down into Hell.''
[Al-Bukhari].

1516. Abu 'Abdur-Rahman Bilal bin Al-Harith Al-Muzani (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A man speaks a good word without knowing its worth, Allah records for him His Good Pleasure till the day he will meet Him; and a man utters an evil word without realizing its importance, Allah records for him His displeasure till the day he will meet Him.''
[Imam Malik and At-Tirmidhi].

Commentary: This Hadith tells us a fact which can be observed in our everyday life. Sometimes a person utters a good sentence which pleases an individual and he reforms himself or holds himself from doing something wrong. Such a sentence or utterance is highly rewarded by Allah. Similarly, sometime a person utters a mischievous sentence, the ruinous effects of which he does not realize. This utterance hurts someone's feelings and leads him to sin and evil. Almighty Allah is displeased with such a person. The lesson that this Hadith has for us is that one should strictly guard his speech and weigh his words to avoid Allah's Wrath.

1517. Sufyan bin `Abdullah (May Allah be pleased with him) reported: I asked: "O Messenger of Allah! Tell me, of something to which I may remain steadfast.'' He (PBUH) said, "Say: My Rubb is Allah and then remain steadfast.'' Then I said: "O Messenger of Allah! What do you fear most about me?'' He took hold of his own tongue and said: "This.''
[At-Tirmidhi].

Commentary: Faith in Allah and all His Attributes is the basis of all virtuous deeds. No act or deed is acceptable by Allah without this faith, "and then remain steadfast'' means to comply with what Allah has ordained and to keep away from what He has forbidden so that one can win over His Pleasure. Every Muslim is required to guard his speech strictly because even the slightest carelessness on this account can cause Allah's displeasure.

1518. Ibn `Umar (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "Do not indulge in excessive talk except when remembering Allah. Excessive talking without the Remembrance of Allah hardens the heart; and those who are the farthest from Allah are those whose hearts are hard.''
[At-Tirmidhi]

Commentary: The hardening of the heart is a condition where one neither learns any lesson from Allah's Signs nor does one accept anyone's good advice and religious preaching. If one indulges in idle talk rather than the remembrance of Allah, his heart becomes hardened, which is a sign of being far from Allah's Mercy. One should therefore occupy himself with the remembrance of Allah.

1519. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He whom Allah saves from the evil of that which is between his jaws and the evil of that which is between his legs will enter Jannah.''
[At-Tirmidhi].

1520. 'Uqbah bin `Amir (May Allah be pleased with him) said: I asked the Messenger of Allah (PBUH), "How can salvation be achieved?'' He replied, "Control your tongue, keep to your house, and weep over your sins.''
[At-Tirmidhi].

Commentary: It is better for one to spends his surplus time at home in the remembrance of Allah, the recitation of the Qur'an and the performance of acts of obedience, if one feels unable to benefit others or if one fears that he, as well as his religion will not be safe if one mixes with others. Allah greatly likes it that one repents of his own sins and weeps over them.

1521. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Prophet (PBUH) said, "When the son of Adam gets up in the morning, all the limbs humble themselves before the tongue and say: `Fear Allah for our sake because we are with you: (i.e., we will be rewarded or punished as a result of what you do) if you are straight, we will be straight; and if you are crooked, we will become crooked.'''
[At-Tirmidhi].

Commentary: This Hadith shows the importance of guarding one's tongue against that which is prohibited. Even the slightest carelessness on the part of the tongue can make all the organs suffer for it.

Crookedness of the tongue means the careless use of the tongue which lands the whole body in trouble; and keeping the tongue straight means keeping oneself safe from all kinds of troubles and ordeals.

1522. Mu`adh bin Jabal (May Allah be pleased with him) reported: I asked the Messenger of Allah (PBUH): "Inform me of an act which will cause me to enter Jannah and keep me far from Hell.'' He (PBUH) replied, "You have asked me about a matter of great importance, but it is easy for one for whom Allah makes it easy.'' He added, "Worship Allah, associate nothing with Him in worship, offer As-Salat (the prayer), pay the Zakat, observe Saum (fasting) during Ramadan and perform Hajj (pilgrimage) to the House of Allah, if you can afford it.'' He (PBUH) further said, "Shall I not guide you to the gates of goodness? Fasting is a screen (from Hell), charity extinguishes (i.e., removes) the sins as water extinguishes fire, and standing in prayers by a slave of Allah during the last third part of the night.'' Then he recited: "Their sides forsake their beds, to invoke their Rubb in fear and hope, and they spend (in charity in Allah's Cause) out of what We have bestowed on them. No person knows what is kept hidden for them of joy as a reward for what they used to do.'' (32:17,18) Then he added, "Shall I tell you of the root of the matter, its pillar and its highest point?'' I replied: "Yes! Certainly, O Prophet of Allah.'' He said, "The root of this matter (foundation) is Islam, its pillar (mainstay is) As-Salat (the prayer) and its highest point is Jihad (fighting in the Cause of Allah).'' Then he asked, "Shall I tell you of that which holds all these things?'' I said: "Yes, O Messenger of Allah.'' So he took hold of his tongue and said, "Keep this in control.'' I asked: "O Messenger of Allah! Shall we really be accounted for what we talk about?'' He replied, "May your mother lose you! People will be thrown on their faces into the Hell on account of their tongues.''

Commentary: Besides describing Articles of Islam, this Hadith mentions the dangers which lie in the careless use of the tongue. All good actions can go waste if one does not guard his speech. One should, therefore, guard his tongue against that which Allah has made prohibited.

1523. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do you know what is backbiting?'' The Companions said: "Allah and His Messenger know better.'' Thereupon he said, "Backbiting is talking about your (Muslim) brother in a manner which he dislikes.'' It was said to him: "What if my (Muslim) brother is as I say.'' He said, "If he is actually as you say, then that is backbiting; but if that is not in him, that is slandering.''
[Muslim].

Commentary: This Hadith elaborates the meaning of backbiting and calumny and points out the difference between the two along with the evils of each one of them. Both these evils are mischief of the tongue and entail great troubles. May Allah save us from both.

1524. Abu Bakrah (May Allah be pleased with him) said: Delivering the sermon during the Farewell Pilgrimage on the day of Sacrifice at Mina, the Messenger of Allah (PBUH) said, "Verily your blood, your property and your honour are as sacred and inviolable as the sanctity of this day of yours, in this month of yours and in this town of yours. Verily! I have conveyed this message to you.''
[Al-Bukhari and Muslim]

Commentary: This Hadith tells us that the tenth day of the month of Dhul-Hijjah, and the city of Makkah are sacred. Similar is the case of blood, property and honour of a Muslim to another Muslim. In other words, a Muslim should neither kill another without any lawful reason nor should he usurp his property nor should he disgrace him. Since backbiting is also a kind of tyranny which defames a person, it should be strictly avoided.

1525. `Aishah (May Allah be pleased with her) said: I said to the Prophet (PBUH): "Such and such thing of Safiyyah (May Allah be pleased with her) is sufficient for you.'' (She means to say that she was a woman with a short stature). He said, "You have indeed uttered a word which would pollute the sea if it were mixed in it.'' She further said: I imitated a person before him and he said, "I do not like that I should imitate someone even (if I am paid) in return such and such.''
[Abu Dawud and At-Tirmidhi].

Commentary: In Arabic, the word "Muhakat'' is often used for imitating someone's defect or deformity, etc. Every imitation of this kind also amounts to backbiting. This is the reason the Prophet (PBUH) used the analogy stated in this Hadith when `Aishah (May Allah be pleased with her) said that Safiyyah (May Allah be pleased with her) was short-statured. Imam An-Nawawi regarded this analogy as based on Wahy and supported his contention by the Verse of the Qur'an: "Nor does he speak of (his own) desire. It is only a Revelation revealed.''

Thus, it is evident from this Hadith that to speak of somebody in a scornful manner, or ridicule someone's physical defect, or to imitate someone's deformity, or talk disparagingly about someone, is a great offense which should be avoided by every Muslim.

1526. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "During the Mi`raj (the Night of Ascension), I saw a group of people who were scratching their chests and faces with their copper nails. I asked, `Who are these people, O Jibril?' Jibril replied: `These are the people who ate flesh of others (by backbiting) and trampled people's honour.'''
[Abu Dawud].

Commentary: "These are the people who ate flesh of others'' is a metaphor for backbiting. "To trample people's honour'' is akin to harming their goodwill and honour. The punishment for these things mentioned in Hadith makes their seriousness obvious.

1527. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said: "The blood, honour and property of a Muslim is inviolable for another Muslim.''
[Muslim].

Commentary: This Hadith also makes it clear that a Muslim is bound to protect his blood, wealth and honour and it is not lawful for any Muslim to attack another Muslim's honour and property. Nor is it lawful for him to kill another Muslim without a valid reason.


Prohibition of Listening to Backbiting

Chapter 255
Prohibition of Listening to Backbiting

Allah, the Exalted, says:

"And when they hear Al-Laghw (dirty, false, evil vain talk) they withdraw from it.'' (28:55)

"And those who turn away from Al-Laghw (dirty, false, evil vain talk, falsehood, and all that Allah has forbidden).'' (23:3)

"Verily, the hearing, and the sight, and the heart, of each of those ones will be questioned (by Allah).'' (17:36)

"And when you (Muhammad (PBUH)) see those who engage in a false conversation about Our Verses (of the Qur'an) by mocking at them, stay away from them till they turn to another topic. And if Shaitan (Satan) causes you to forget, then after the remembrance sit not you in the company of those people who are the Zalimun (polytheists and wrongdoers).'' (6:68)

1528. Abud-Darda' (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who defends the honour of his (Muslim) brother, Allah will secure his face against the Fire on the Day of Resurrection.''
[At-Tirmidhi].

Commentary: If someone says something disgraceful against a Muslim, one must defend his Muslim brother (or sister, for that matter) and say that what has been stated about him or her is wrong and that he (or she) is free from the accusation made against him (or her).

1529. `Itban bin Malik (May Allah be pleased with him) said in his long Hadith cited in the Chapter entitled `Hope' reported: When the Prophet (PBUH) stood up to offer As-Salat (the prayer) he asked, "Where is Malik bin Ad-Dukhshum?'' A man replied: "He is a hypocrite. He does not love Allah and His Messenger.'' The Prophet (PBUH) said, "Do not say that. Do you not know that he said: La ilaha illallah (there is no true god except Allah),' seeking His Pleasure. Allah has made the fire of Hell unlawful for him who affirms that none has the right to be worshipped but Allah.''
[Al-Bukhari and Muslim].

Commentary: "Allah has made the fire of Hell unlawful'' means that a Muslim will not abide in Hell for ever. The reason is that if a Muslim has committed some major sin and Allah has not pardoned it, then he will certainly suffer its punishment in Hell. He will stay there as long as Allah will. However, he will be later on shifted to Jannah. This Hadith also leads us to the conclusion that the backbiting of a Muslim is forbidden. See the explanation of this Hadith under Hadith No. 418.

1530. Ka`b bin Malik (May Allah be pleased with him) said in his long story about his repentance: The Prophet (PBUH) was sitting among the people in Tabuk. He (PBUH) said, "What happened to Ka`b bin Malik?'' A person from the tribe of Banu Salamah said: "O Messenger of Allah! the embellishment of his cloak and an appreciation of his sides have allured him, and he was thus detained.'' Mu`adh bin Jabal (May Allah be pleased with him) said: "Woe be upon you! You have passed indecent remarks. O Messenger of Allah! by Allah, we know nothing about him but good.'' The Messenger of Allah (PBUH) remained silent.
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned in detail in the Chapter on Repentance. Here it is repeated to show how important it is to defend a Muslim when someone accuses him in his absence. In the presence of the Prophet (PBUH) a person expressed misgivings about Ka`b bin Malik that his obsession (for fine dress) had prevented him from coming to the battlefield. Mu`adh immediately defended him saying that there was no justification for such misgivings. The Prophet's silence endorsed the stand taken by Mu`adh (May Allah be pleased with him). This goes to prove that if a Muslim brother or sister is disgraced in his or her absence in a gathering, then it is incumbent on others to defend his or her honour.


Some cases where it is permissible to Backbite

Chapter 256
Some cases where it is permissible to Backbite

[Backbiting is permissible only for valid reasons approved by Shari`ah. These reasons are as follows:]

1. It is permissible for an oppressed person to speak before the judge or someone in a similar position of authority to help him or her establish his or her rights by telling him `so-and-so wronged me and has done such and such to me' etc.

2. It is permissible to seek somebody's assistance in forbidding evil and helping someone change his or her immoral conduct. One can say to the person who can offer such assistance, `so-and-so does such and such evil deeds. Can you exhort him?' etc. This is permissible as long as one intends to forbid evil. If, however, one intends something else apart from this, then this act becomes unlawful.

3. One who seeks legal verdict on a certain matter may point out the defaults of another person or relate something else. One in this case can say to the Mufti (religious scholar who issues verdicts): "My father or brother (for example) treated me unjustly. Can I get my right established?'' etc. This is permissible to say only if need be, but it is better to say `What do you think of someone who did such and such?' This does not mean, however, that naming the person in question is not permissible, Hadith No. 1536 makes this point clear.

4. One who criticizes those who openly commit acts of disobedience, such as drinking wine, gambling, engaging in immoral habits, fornication, hypocrisy, and making mischief.

5. It is permissible to call into question the narrators of Hadith, and witnesses in the court when the need arises. It is also permissible to mention the bad qualities of somebody for marriage purposes in case an advice is sought. Also, if one has noticed that a "seeker of knowledge'' frequently goes to the gatherings of an innovator in religion and one fears that this "seeker of knowledge'' may be affected by this so-called scholar, then he must in this case give counsel to the "seeker of knowledge'' by telling him about the "innovator,'' etc.

6. It is permissible to use names such as "Al-a`mash'' which means `the blear-eyed' to talk about people who are known by such names for the sake of identification and not for disparaging people and underestimating them. To identify them without resorting to such names is however better.

1531. `Aishah (May Allah be pleased with her) said: A man sought permission for audience with the Prophet (PBUH). He said, "Give him permission but he is a bad member of his tribe.''
[Al-Bukhari and Muslim].

Commentary: Imam Al-Bukhari has obviously justified the backbiting of wicked people to save people from being deceived from their appearance. If people are not informed of the real conduct of such persons, their religious as well as worldly life will be exposed to a grave danger. For this reason, the backbiting of wicked persons for the purpose of warning others is permissible.

1532. `Aishah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) said, "I do not think that so-and-so understands anything of our Faith.''
[Al-Bukhari]

Al-Bukhari said: Al-Laith bin Sa`d, who is one of the narrators of this Hadith, said: The two men mentioned by the Prophet (PBUH) in this Hadith were hypocrites (i.e., they revealed Faith and concealed disbelief).

Commentary: Hypocrites are also people of mischievous and doubtful conduct. It is, therefore, not only permissible but necessary to make people aware of their real position so that people become cautious about them and their religious and worldly life may remain safe from their machinations.

1533. Fatimah bint Qais (May Allah be pleased with her) said: I came to the Prophet (PBUH) and said to him: "Muawiyah and Abul-Jahm sent me a proposal of marriage.'' The Messenger of Allah (PBUH) said, "Muawiyah is destitute and he has no property, and Abul-Jahm is very hard on women.''
[Bukhari and Muslim].

Commentary: We learn from this Hadith that it is permissible to mention the true facts, virtues and vices without equivocation, about the parties who intend to enter into wedlock provided one does it for their welfare.

1534. Zaid bin Al-Arqam (May Allah be pleased with him) said: We set out on a journey along with the Messenger of Allah (PBUH) and we faced many hardships. `Abdullah bin Ubaiy (the chief of the hypocrites at Al-Madinah) said to his friends: "Do not spend on those who are with the Messenger of Allah (PBUH) until they desert him.'' He also said: "If we return to Al-Madinah, the more honourable (meaning himself, i.e., Abdullah bin Ubaiy) will drive out therefrom the meaner (meaning Messenger of Allah (PBUH)).'' I went to the Messenger of Allah (PBUH) and informed him about that and he sent someone to `Abdullah bin Ubaiy. He asked him whether he had said that or not. Abdullah took an oath that he had not done anything of that sort and said that it was Zaid who carried a false tale to the Messenger of Allah (PBUH). Zaid said: I was so much perturbed because of this until this Verse was revealed verifying my statement:

"When the hypocrites come to you (O Muhammad (PBUH)), they say: `We bear witness that you are indeed the Messenger of Allah.' Allah knows that you are indeed His Messenger, and Allah bears witness that the hypocrites are liars indeed.'' (63:1) Then the Messenger of Allah (PBUH) called the hypocrites in order to seek forgiveness for them from Allah, but they turned away their heads.
[Al-Bukhari and Muslim].

Commentary: `Abdullah bin Ubaiy was the chief of the hypocrites at Al-Madinah. In the journey mentioned in this Hadith, which was undertaken in connection with the war with Banu Al-Mustaliq, he had used improper words against the Prophet (PBUH) and Muslims, which were overheard by Zaid bin Al-Arqam (May Allah be pleased with him). The latter informed the Prophet (PBUH) about this occurrence. This incident goes to prove that exposing the designs and conspiracies of hypocrites does not form backbiting. In fact, it is essential to keep people informed about them in the interest of Islam and Muslims.

1535. `Aishah (May Allah be pleased with her) said: Hind, the wife of Abu Sufyan, said to the Prophet (PBUH): Abu Sufyan is a niggardly man and does not give me and my children adequate provisions for maintenance unless I take something from his possession without his knowledge. The Prophet (PBUH) said to her, "Take from his possessions on a reasonable basis that much which may suffice for you and your children.''
[Al-Bukhari and Muslim].

Commentary: Hind was the mother of Mu`awiyah (May Allah be pleased with him). Along with her husband, Abu Sufyan, she embraced Islam in the year of conquest of Makkah.

We learn from this Hadith that:

1. In order to know religious injunctions, husband and wife can mention each other's shortcomings before a Mufti (a religious scholar who is in a position to issue verdicts on religious matters).

2. If a husband does not give his wife enough money to cover the domestic expenses, then it is permissible for his wife to take some of his money without his permission, provided the amount thus taken is for essential expenses not for superfluous matters.


Prohibition of Calumny

Chapter 257
Prohibition of Calumny

Allah, the Exalted, says:

"A slanderer, going about with calumnies.'' (68:11)

"Not a word does he (or she) utter, but there is a watcher by him ready (to record it).'' (50:18)

1536. Hudhaifah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The person who goes about with calumnies will never enter Jannah.''
[Al-Bukhari and Muslim].

Commentary: A person who thinks that talebearing is lawful, and practices it to create conflict and quarrel among people despite the fact that he knows it is unanimously forbidden, will never go to Jannah. A person who considers it unlawful but does it out of sheer human weakness, will in the first instance go to Hell, if Allah does not pardon him for it. He will then be shifted to Jannah after suffering punishment for it.

1537. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) passed by two graves and said, "Both of them (the persons in these graves) are being tortured, and they are not being tortured for a cardinal sin. But indeed they are great sins. One of them used not to save himself from being soiled with his urine, and the other one used to go about with calumnies (among the people to rouse hostilities, e.g., one goes to a person and tells him that so-and-so says about him such and such evil things).''
[Al-Bukhari and Muslim].

Commentary:
1. "La yastatiru min baulihi'' has another meaning, namely: "he does not pass urine in privacy but does it shamelessly in the presence of other people.'' Obviously shamelessness is also a sin. Talebearing, carelessness in saving oneself from splash of urine drops, and lack of observance of privacy are sins which are liable to punishment.

2. The Hadith also proves punishment in the grave.

1538. Ibn Mas`ud (May Allah be pleased with him) said: The Prophet (PBUH) said, "Shall I tell you what `Al-`Adhu' (falsehood and slandering) is? It is calumny which is committed among the people.''
[Muslim].

Commentary: We learn from this Hadith that calumny, lying, falsehood and slandering are major sins because they cause conflict and dissension in society. A Muslim must keep himself free from such evils.


Prohibition of Carrying tales of the Officers

Chapter 258
Prohibition of Carrying tales of the Officers

Allah, the Exalted, says:

"... Do not help one another in sin and transgression.'' (5:2)

1539. Ibn Mas`ud (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "None of my Companions should convey to me anything regarding another because I desire to meet everyone of you with a clean heart.''
[Abu Dawud and At-Tirmidhi].

Commentary: `Should not convey to me anything' here signifies anything undesirable or which is harmful for the person concerned. Thus, this Hadith stresses that defects of people should not be unnecessarily reported to those who are at the helm of affairs, as is evident from the caption given to this chapter by Imam An-Nawawi.


Condemnation of Double-faced People

Chapter 259
Condemnation of Double-faced People

Allah, the Exalted, says:

"They may hide (their crimes) from men, but they cannot hide (them) from Allah; for He is with them (by His Knowledge), when they plot by night in words that He does not approve. And Allah ever encompasses what they do.'' (4:108)

1540. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "People are like ores. Those who were excellent in the Days of Ignorance are excellent in Islam provided they acquire the knowledge and understanding of the religion. You will find the best people in it (Islam) those who had a deep hatred (for leadership). You will find the worst among the people a double-faced person who appears to some people with one face and to others with another face.''
[Al-Bukhari and Muslim].

Commentary:
1. "Like ores'' here signifies origin or source which will be a means of honour for them. That is, the tribes which were distinguished for nobility in the pre-Islamic period will also be distinguished after embracing Islam. There will be no reduction in their prestige and honour provided they attain true understanding of religion and adhere to its teachings.

2. Such people who do not have any desire for office and position are most suitable for holding the reins of government. They serve the interest of public better because, being aware to their responsibilities, they honestly endeavour to fulfill the trust reposed in them. They keep the boundaries marked by Allah and prefer the interests of the nation and their own country.

3. A "double-faced person'' is one who makes a group believe that he is their supporter and well-wisher, but when he goes to the opposite group, he tries to make them believe that he is entirely with them. The best among people is one who goes to every group and earnestly tries to reform it.

1541. Muhammad bin Zaid reported: Some people said to my grandfather, 'Abdullah bin 'Umar (May Allah be pleased with them): We visit our rulers and tell them things contrary to what we say when we leave them. `Abdullah bin `Umar (May Allah be pleased with them) replied: "In the days of the Messenger of Allah (PBUH), we counted this act as an act of hypocrisy.''
[Al-Bukhari].

Commentary: This Hadith points out that to praise the rulers in their presence and to condemn them in their absence amounts to practical hypocrisy because what one has in his heart does not find expression in his speech, and what one expresses in his words does not agree with what one has in his heart. The conduct of a true Muslim should be that if a ruler is noble, just and pious, he should admire him even in his presence (when there arises a need for it, and not for the sake of flattering him) and he should also praise him in his absence. If the ruler is bad, he should warn him of the evil consequences of his bad conduct to his face, and the same attitude should be maintained when he is not present because this is the well-meaning attitude which has been ordained to every Muslim. Against this, the attitude of the first kind is a mark of hypocrisy which has been strongly condemned in the preceding Hadith.


Condemnation and Prohibition of Falsehood

Chapter 260
Condemnation and Prohibition of Falsehood

Allah, the Exalted, says:

"And follow not (O man, i.e., say not or do not or witness not) that of which you have no knowledge.'' (17:36)

"Not a word does he (or she) utter, but there is a watcher by him ready (to record it).'' (50:18)

1542. Ibn Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Truth leads to piety and piety leads to Jannah. A man persists in speaking the truth till he is recorded with Allah as a truthful man. Falsehood leads to transgression and transgression leads to the Hell-fire. A man continues to speak falsehood till he is recorded with Allah as a great liar.''
[Al-Bukhari and Muslim].

Commentary:
1. Whatever attitude one adopts becomes his special trait and then he becomes known by it. Therefore, one should always adopt virtues and good conduct so that he may attain a high esteem with Allah and be also remembered well by people.

2. Truth is the way to salvation while falsehood is the way to destruction.

1543. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) said: The Prophet (PBUH) said, "Whosoever possesses these four characteristics, is a sheer hypocrite; and anyone who possesses one of them, possesses a characteristic of hypocrisy till he gives it up. (These are:) When he talks, he tells a lie; when he makes a covenant, he acts treacherously; and when he quarrels, he utters foul language.''
[Al-Bukhari and Muslim].

Commentary: Nowadays we do not find hypocrisy of Belief among Muslims generally, but practical hypocrisy is very common. The reason is that their majority has most of the signs of hypocrisy which this Hadith makes clear. See Hadith No. 690.

1544. Ibn `Abbas (May Allah be pleased with them) said: The Prophet (PBUH) said, "He who narrates a dream which he has not seen will be put to trouble to join into a knot two barley seeds which he will not be able to do; and he who seeks to listen to the talk of a people (secretly) will have molten lead poured into his ears on the Day of Resurrection; and he who makes a picture (of people or other creatures with a soul, such as animals and insects) will be (severely punished), and he will be asked to infuse spirit therein, which he will not be able to do.''
[Al-Bukhari].

Commentary:

1. "Hulm'' means a bad dream but here it has been used in the sense of a dream, irrespective of its being good or bad. This Hadith has a severe warning for inventing a dream. Such persons are in the habit of inventing dreams who have either a lust for fame or want to impress people with their piety.

2. Listening to the talk of others secretly is also condemned.

3. The making of paintings of people or other creatures with a soul entails severe punishment.

1545. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) as saying: "The worst of lies is to pretend to have seen something which he has not seen.''
[Al-Bukhari].

Commentary: This Hadith strongly condemns falsehood, whether it relates to a dream or to the real world. It is a great sin in both cases.

1546. Sumurah bin Jundub (May Allah be pleased with him) said: The Messenger of Allah (PBUH) very often used to ask his Companions, "Do any one of you has seen a dream?'' So dreams would be narrated to him by those whom Allah willed to relate. One day he (PBUH) said, "Last night I had a vision in which two men (angels) came to me and woke me up and said to me, `Proceed!' I set out with them and we came across a man lying down, and behold, another man was standing over his head, holding a big rock. Behold, he was throwing the rock at the man's head, smashing it. When he struck him, the stone rolled away and he went after it to get it, and no sooner had he returned to this man, his head was healed and restored to its former condition. The thrower (of the rock) then did the same as he had done before. I said to my two companions, `Subhan-Allah! Who are these?' They said: `Proceed, proceed.' So we proceeded and came to a man lying in a prone position and another man standing over his head with an iron hook, and behold, he would put the hook in one side of the man's mouth and tear off that side of his face to the back (of the neck), and similarly tear his nose from front to back, and his eyes from front to back. Then he turned to the other side of the man's face and did just as he has done with the first side. He had hardly completed that (second) side when the first returned to its normal state. I said to my two companions, `Subhan-Allah! Who are these?' They said, `Proceed, proceed.' So we proceeded and came across something like a Tannur (a kind of baking oven, a pit usually clay-lined for baking bread).'' I (the narrator) think the Prophet (PBUH) said, "In that oven there was much noise and voices.'' The Prophet (PBUH) added, "We looked into it and found naked men and women, and behold, a flame of fire was reaching to them from underneath, and when it reached them they cried loudly. I asked, `Who are these?' They said to me, `Proceed, proceed.' And so we proceeded and came across a river.'' I (the narrator) think he said, "-- red like blood.'' The Prophet (PBUH) added, "And behold, in the river there was a man swimming, and on the bank there was a man who had collected many stones. Behold, while the other man was swimming, he went near him. The former opened his mouth and the latter (on the bank) threw a stone into his mouth whereupon he went swimming again. Then again he (the former) returned to him (the latter), and every time the former returned, he opened his mouth, and the latter threw a stone into his mouth, (and so on) the performance was repeated. I asked my two companions, `Who are these?' They replied, `Proceed, proceed.' And we proceeded till we came to a man with a repulsive appearance, the most repulsive appearance you ever saw a man having! Beside him there was a fire, and he was kindling it and running around it. I asked my two companions, `Who is this (man).' They said to me, `Proceed, proceed!' So we proceeded till we reached a garden of deep green dense vegetation, having all sorts of spring colours. In the midst of the garden there was a very tall man, and I could hardly see his head because of his great height, and around him there were children in such a large number as I have never seen! I said to my two companions, `Who is this?' They replied, `Proceed, proceed.' So we proceeded till we came to a majestic, huge garden, greater and better than any garden I have ever seen! My two companions said to me, `Ascend up' and I ascended up.'' The Prophet (PBUH) added, "So we ascended till we reached a city built of gold and silver bricks, and we went to its gate and asked (the gatekeeper) to open the gate, and it was opened; and we entered the city and found in it men with one side of their bodies as handsome as the most handsome person you have ever seen, and the other side as ugly as the ugliest person you have ever seen! My two companions ordered those men to throw themselves into the river. Behold, there was a river flowing across (the city), and its water was like milk in whiteness. Those men went and threw themselves in it and then returned to us after the ugliness (of their bodies) had disappeared, and they came in the best shape.'' The Prophet (PBUH) further added, "My two companions said to me: `This place is the `Adn Jannah, and that is your place.' I raised up my sight, and behold, there I saw a palace like a white cloud! My two companions said to me, `That palace is your place,' I said to them, `May Allah bless you both! Let me enter it.' They replied, `As for now, you will not enter it, but you shall enter it (one day).' I said to them, `I have seen many wonders tonight. What does all that mean which I have seen?' They replied, `We will inform you: As for the first man you came upon, whose head was being smashed with the rock, he is the symbol of the one who studies the Qur'an and then neither recites it nor acts on its orders, and sleeps, neglecting the enjoined prayers. As for the man you came upon, whose sides of mouth, nostrils and eyes were torn off from front to back, he is the symbol of the man who goes out of his house in the morning and tells lies that are spread all over the world. And those naked men and women whom you saw in a construction resembling an oven, they are the adulterers and the adulteresses. And the man who was given a stone to swallow is the eater of Ar-Riba (usury), and the bad-looking man whom you saw near the fire, kindling it and going around it, is Malik, the gatekeeper of Hell, and the tall man you saw in the garden is (Prophet) Abraham, and the children around him are those who died upon Al-Fitrah (the Islamic Faith of Monotheism).''' The narrator added: Some Muslims asked the Prophet (PBUH) , "O Messenger of Allah! What about the children of Al-Mushrikun (i.e., polytheists, pagans, idolaters, and disbelievers in the Oneness of Allah and in His Messenger Muhammad (PBUH))?'' The Prophet (PBUH) replied, "And also the children of Al-Mushrikun.'' The Prophet (PBUH) added: "My two companions added, `The men you saw half handsome and half ugly were these people who had mixed an act that was good with another that was bad, but Allah forgave them'.''

Another narration of Al-Bukhari is: The Messenger of Allah (PBUH) said, "One night two men came to me and took me to a blessed land.'' (The Messenger of Allah (PBUH) told of the same incident as above) and said, "After a while of walking we came upon a pit like an oven, narrow at the top and wide at the bottom with fire raging in it. When the flames rose up (the people in it) also rose up till they were about to come out; and when the fire subsided they, too, would go down with it. In it were naked men and women.'' (The remainder of the Hadith is the same as the above Hadith except that at the end of it, the Messenger of Allah said: "We came upon a river of blood in the middle of which there was a man standing, and at the bank of the river there was a man with plenty of stones before him...'' In this narration we also find: "They made me climb the tree and they made me enter an abode so beautiful the like of which I have never seen before. There (I saw) old men and youth.'' In this narration we also find: "`The first house you entered was the abode of the believers in general, and the other house was the abode of the martyrs. I am Jibril (Gabriel), and this is Mika'il. Raise your head.' I looked up and saw something like clouds. They said to me, `That is your abode.' I said, `Shall I enter it?' They said, `You have not completed your term of life yet. When you do, you will certainly enter it.'''
[Al-Bukhari]

Commentary: This Hadith has the following points:

1. Manifestation through dream of punishment of various evils, i.e., forgetting the Qur'an after having memorized it, not practising the teachings of the Qur'an, violating the precepts of the Qur'an after attaining their knowledge, slackness in offering obligatory Salat, lying, immoral acts, usury, etc. Strict warnings have been issued against all these evils, and the punishment to which they are liable have been mentioned in this Hadith. May Allah save us from them.

2. This Hadith also mentions the unique status of Prophet (PBUH) and the distinguished place of martyrs.

3. We also learn from this Hadith that Allah has made Hell for punishment and Jannah for reward. Muhammad (PBUH), the Last Prophet of Allah, was made to witness many scenes which demonstrated the retribution and reward of deeds done by people in their earthly life.


Falsehood that is Permissible

Chapter 261
Falsehood that is Permissible

The learned compiler of this book has put forth some arguments to prove that it is lawful to tell a lie under the stress of circumstances. An example of this is the case of a Muslim who hides himself or his money from a tyrant who is bent on killing him or taking his money from him. If one knows the whereabouts of this Muslim or his money and is asked about it, it is permissible to lie in this case to save a Muslim's life or his property, but it is better to give an equivocal answer, that is one which is not clear or definite in meaning, and that can be interpreted in more than one way in order to shun lying altogether. The sum and substance of discussion has been derived from the narration ascribed to Umm Kulthum (May Allah be pleased with her). She said: The Messenger of Allah (PBUH) said, "A liar is not the one who tries to bring about a reconciliation between the people and speaks good to avert dispute or to convey good.''
[Al-Bukhari].

It may be concluded that falsehood is permissible in the following three cases:

(i) While fighting Jihad in the Cause of Allah.

(ii) To conciliate between people.

(iii) For the husband to please his wife and the wife to please her husband.


Ascertainment of what one Hears and Narrates

Chapter 262
Ascertainment of what one Hears and Narrates

Allah, the Exalted, says:

"And follow not (O man, i.e., say not or do not or witness not) that of which you have no knowledge.'' (17:36)

"Not a word does he (or she) utter, but there is a watcher by him ready (to record it).'' (50:18)

1547. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "It is enough for a man to prove himself a liar when he goes on narrating whatever he hears.''
[Muslim].

Commentary: We learn from this Hadith that it is not fair to accept everything one hears as true without verifying it. Nor it is right to communicate it to others because it is quite possible that what one has heard is untrue and by communicating it to others, he adds it to his own lies. It is, therefore, necessary that one should make sure that what he is communicating to others is true.

1548. Samurah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "He who relates from me something which he deems false is one of the liars.''
[Muslim]

Commentary: In some of the narrations of this Hadith, the word used is "Kadhibain'' which means "two liars'' One is that person who tells a lie and attributes his statement to the Prophet (PBUH). The second is that person who conveys it to others. Thus, this Hadith has a stern warning for those `Ulama' and preachers who feel no hesitation in relating false and fabricated Ahadith.

1549. Asma' (May Allah be pleased with her) reported: A woman came to the Messenger of Allah (PBUH) and said: "I have a co-wife. "Is there any harm for me if I give her the false impression of getting something from my husband which he has not in fact given me?'' The Messenger of Allah (PBUH) said, "The one who creates a false impression of receiving what one has not been given is like one who wears two garments of falsehood.''
[Al-Bukhari and Muslim].

Commentary: Some people disguise themselves as pious to create a false impression of their piety; some put up the appearance of scholars to establish their scholarship; and some take to highly expensive clothes to give the impression of being rich. Since these things are fabricated and false, they constitute great sins. One should live as one really is. Similarly, the second wife should not invent false stories to give wrong impression of herself to the other wife. Nor should make false claims of greater love and attention of the husband only to incite the jealousy of the other one while the real position is far from that. In fact, even if this is so, she should not expose the weakness of the husband so that the feelings of his other wife are not injured.


Prohibition of Giving False Testimony

Chapter 263
Prohibition of Giving False Testimony

Allah, the Exalted, says:

"And shun lying speech (false statements).'' (22:30)

"And follow not (O man, i.e., say not or do not or witness not) that of which you have no knowledge.'' (17:36)

"Not a word does he (or she) utter, but there is a watcher by him ready (to record it).'' (50:18)

"Verily, your Rubb is Ever Watchful (over them).'' (89:14)

"And those who do not witness falsehood...'' (25:72)

1550. Abu Bakrah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Shall I not inform you of one of the gravest of the cardinal sins?'' We said: "Yes, O Messenger of Allah!'' He (PBUH) said, "To join others as partners with Allah in worship and to be undutiful to one's parents.'' The Messenger of Allah (PBUH) sat up from his reclining position (in order to stress the importance of what he was going to say) and added, "I warn you making a false statement and giving a false testimony. I warn you against making a false statement and giving a false testimony.'' The Messenger of Allah (PBUH) kept on repeating this (warning) till we wished he should stop.
[Al-Bukhari and Muslim]

Commentary: The contents of this Hadith make the gravity of making a false statement abundantly clear. How unfortunate indeed it is that, like other major sins, the evil of giving false testimony is very common among the present-day Muslims. May Allah prevent us from it.


Prohibition of Cursing one Particular Man or Animal

Chapter 264
Prohibition of Cursing one Particular Man or Animal

1551. Abu Zaid Thabit bin Ad-Dahhak Al-Ansari (May Allah be pleased with him( (he is one of those who gave their pledge of allegiance to the Messenger of Allah (PBUH) under the Tree) said: The Messenger of Allah (PBUH) said, "He who swears by a religion other than that of Islam, is like what he has professed. He who kills himself with something, will be tormented with it on the Day of Resurrection. A person is not bound to fulfill a vow about something which he does not possess. Cursing a believer is like murdering him.''
[Al-Bukhari and Muslim].

Commentary: "He who swears by a religion other than that of Islam'' here means either of the two things stated here. For instance, if a person says: "If I do such and such, then I am a Christian or a Jew.'' Now if he really intends to embrace Christianity or Judaism, he will immediately become so because his intention to be a Kafir (disbeliever) is Kufr (infidelity) in itself. But if the vow is meant to deny the adoption of other religions and is intended to express his firm resolution to live as a Muslim to the last even then such a vow is undesirable and is a sin for which one must seek Allah's forgiveness.

The last sentence of this Hadith evidently shows that to curse a Muslim is forbidden because it is akin to killing him.

1552. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said: "It does not befit a Siddiq (righteous Muslim) to frequently curse others.''
[Muslim]

Commentary: Taunts, curses and abusive language are contrary to perfect Faith and fidelity.

1553. Abud-Darda' (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Those who frequently resort to cursing (people) would neither be accepted as witnesses nor as intercessors on the Day of Resurrection.''
[Muslim].

Commentary: The habit of taunting and cursing makes a man sinful. Such a person has no value with Allah, and his testimony and intercession will not be considered on the Day of Judgement.

1554. Samurah bin Jundub (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not curse one another, invoking Curse of Allah or Wrath of Allah or the fire of Hell.''
[Abu Dawud and At-Tirmidhi].

Commentary: We learn from this Hadith that Muslims should neither curse nor imprecate each other. For instance they are forbidden to say "May the Curse of Allah be upon you'' or "I wish you to burn in Hell-fire'' etc., etc.

1555. Ibn Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "A true believer is not involved in taunting, or frequently cursing (others) or in indecency or abusing.''
[At-Tirmidhi].

Commentary: This Hadith tells us the virtues of a Mu'min (true Muslim). Taunting here means to disgrace someone with reference to his lineage or by means of backbiting and slander. La`in is a person who is given to frequently cursing others, reproaching and using abusive language. (Fahish) is one who commits through word or practice immodesty. Badhiy is a person with a loose tongue. This word is also used for an impudent and abusive person. This Hadith strongly criticizes these vices.

1556. Abud-Darda' (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "When a person curses somebody or something, the curse goes up to heaven and the gates of heaven get closed. Then it comes down to the earth and its gates get closed. Then it turns right and left, and if it does not find an entrance to go anywhere, it returns to the person or thing that was cursed; if he or it deserves to be cursed; otherwise it returns to the person who uttered it.''
[Abu Dawud].

Commentary: Al-La`nah (curse) means deprivation of Allah's Mercy. We learn from this Hadith that the act of cursing is such that one who does it can become himself a victim of it. One should, therefore, abstain from cursing.

1557. `Imran bin Husain (May Allah be pleased with him) said: We were with the Messenger of Allah (PBUH) on a journey and there was a woman from the Ansar riding a she-camel. She abused and invoked curse upon it. The Messenger of Allah (PBUH) heard it and said, "Off load the she-camel and set it free because it has been cursed.''
[Muslim].

Commentary: This Hadith teaches us not to curse animals. It also teaches us to treat them nicely and be patient with them..

1558. Abu Barzah Nadlah bin `Ubaid Al-Aslami (May Allah be pleased with him) said: A young woman was riding a she-camel on which there was the luggage of people. Suddenly she saw the Prophet (PBUH). The pass of the mountain became narrow for her people (because of fear). The young woman said to the she-camel: "Go ahead.'' When it did not move, she said, "O Allah! Curse it.'' The Prophet (PBUH) said, "The she-camel that has been cursed should not accompany us.''
[Muslim].

Commentary: Some people have taken this Hadith to mean that the she-camel cursed by the young woman was abandoned there and it was neither used for transport nor conveyance, as was the practice in the pre-Islamic period with she-camels which were let loose for free pasture for the polytheists' false gods, and nothing was allowed to be carried on them. Such she-camels were called as "As-Sa'ibah'' There is no justification for such interpretation because the she-camel was not set absolutely free like As-Sa'ibah. All that was done was that because of the curse, it was considered unworthy of the entourage company of the Prophet (PBUH). Except for this bar, it was valid for all other purposes. Thus, this Hadith proves that it is not permissible to associate with people who are given to sins and heresies in religion because they have been cursed. When one is not permitted to keep an animal which has been cursed, how can one possibly keep company with people who commit acts as a result of which they have been cursed.


Justification of Cursing the Wrongdoers without Specifying one of them

Chapter 265
Justification of Cursing the Wrongdoers without Specifying one of them

Allah, the Exalted, says:

"No doubt! the Curse of Allah is on the Zalimun (polytheists, wrongdoers, oppressors).'' (11:18)

"Then a crier will proclaim between them: `The Curse of Allah is on the Zalimun (polytheists and wrongdoers).''' (7:44)

It has been authentically reported that the Messenger of Allah said, "Curse of Allah is upon those women who wear false hair, and those women who prepare such.'' And he (PBUH) said, "Curse of Allah is upon the one who eats Riba (usury).'' And he also cursed the painters of pictures of living objects. And he (PBUH) said, "Curse of Allah is upon him who make changes in land boundaries (to deprive others).'' He (PBUH) also said, "Curse of Allah is upon the thief who steals (even) an egg.'' He also said, "Curse of Allah is upon the one who curses his parents.'' And: "Curse of Allah is upon the one who sacrifices an animal for other than Allah.'' And he (PBUH) said, "Who invents heresies in religion here (Al-Madinah), and upon those who supported him, is the Curse of Allah and the angels and all the people.'' And he (PBUH) said, "O Allah! Curse be upon Ri`l, Dhakwan and Usaiyyah, the three tribes of Arab who are disobedient to Allah and His Messenger.'' He also said, "Curse of Allah is upon the Jews who turned the graves of their Prophets into places of worship.'' And he (PBUH) cursed those men who imitate women and those women who imitate men.

All these Ahadith are authentic, and are reported by Al-Bukhari or Muslim or by them both. These Ahadith will be cited under their respective chapters, In sha' Allah.


Prohibition of Reviling a Muslim without any cause

Chapter 266
Prohibition of Reviling a Muslim without any cause

Allah, the Exalted, says:

"And those who annoy believing men and women undeservedly, bear on themselves the crime of slander and plain sin.'' (33:58)

1559. Ibn Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Reviling a Muslim is Fusuq (disobedience of Allah) and killing him is (tantamount to) disbelief.''
[Al-Bukhari and Muslim].

Commentary: "Killing him is (tantamount) to disbelief'' means that in terms of sin and prohibition, it is akin to Kufr. This Hadith makes the severity of this crime abundantly clear.

1560. Abu Dharr (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "When any Muslim accuses another Muslim of sin or of disbelief, the reproach rebounds upon the one who utters it, if the other person is not deserving of it.''
[Al-Bukhari].

Commentary: What this Hadith stresses is that one should never say about a Muslim that he is sinful (Fasiq) or disbeliever (Kafir) when he is not so. The reason is that in that case, one who says it, will be held Fasiq or Kafir. One should, therefore, strictly refrain from uttering such statements.

1561. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "When two persons indulge in abusing each other, the beginner will be the sinner so long as the oppressed does not transgress the limits.''
[Muslim].

Commentary: This Hadith tells us that if a Muslim abuses another and says unfair things about him and in return the recipient also abuses him and says unfair things to the same extent, then the entire burden of sin of abusing would lie with the person who initiated the quarrel. But if the one who is wronged, exceeds the limits in revenge, then he will also be guilty to the degree of his excess. Thus, this Hadith shows that although revenge is permissible in Islam, it is better to forgive and bear the excess with patience. The reason behind this is that in revenge, one usually exceeds the limits and becomes an aggressor. Allah says: "And verily, whosoever shows patience and forgives, that would truly be from the things recommended by Allah.'' (42:43).

1562. Abu Hurairah (May Allah be pleased with him) said: A drunkard was brought to the Prophet (PBUH). He said, "Give him a beating.'' Then some beat him with their hands, some with their shoes, and some with (a folded) piece of cloth. When he left, someone said to him: "May Allah disgrace you!'' The Prophet (PBUH) said, "Do not help Satan overcome him by uttering such words.''
[Al-Bukhari].

Commentary: We learn from this Hadith that imprecation against a sinner helps Satan because he is avowed to disgrace and humiliate Muslims before Allah. When a Muslim curses another Muslim and imprecates for his humiliation and disgrace, he in fact tries to accomplish the mission of Satan because in doing so Satan will have achieved his objective. Therefore, one should not curse a fellow Muslim even if he or she is a sinner. In fact, one should pray to Allah for his or her guidance.

1563. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "He who accuses his slave of Zina will receive the punishment (Hadd) of slander on the Day of Resurrection, unless the accusation of Zina was true.''
[Al-Bukhari and Muslim].

Commentary: On the Day of Judgement, the masters of slaves and slave-girls will be exposed to Hadd-ul-Qadfi (Hadd for accusing someone of adultery) for the reason that they perpetrate all kinds of oppressions on their captives and their grievances are not redressed. On the Day of Judgement, when Almighty Allah dispenses justice without any prejudice and favour, He will also do full justice to this oppressed class and those masters, who somehow escaped the punishment on this account in this world. Thus, this Hadith has a stern warning for those masters who are carried away by their might and authority and perpetrate oppression on their servants and slaves.


Prohibition of Abusing the Deceased without a valid Legal reason approved by Shari'ah

Chapter 267
Prohibition of Abusing the Deceased without a valid Legal reason approved by Shari'ah

1564. `Aishah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) said, "Do not abuse the dead, because they have attained that which they had forwarded (i.e., their deeds, good or bad).''
[Al-Bukhari].

Commentary: We learn from this Hadith that we should not censure or condemn the deceased because they have reached their end and they are receiving in the Hereafter return for whatever deeds they did in their life. There is no harm, however, in abusing the disbelievers who died in a state of Kufr.


Prohibition of Maligning

Chapter 268
Prohibition of Maligning

Allah, the Exalted, says:

"And those who annoy believing men and women undeservedly, bear on themselves the crime of slander and plain sin.'' (33:58)

1565. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "A (true) Muslim is one from whose tongue and hand the Muslims are safe; and a Muhajir (Emigrant) is he who leaves the deeds which Allah has prohibited.''
[Al-Bukhari and Muslim].

Commentary: Everyone who professes Tauhid and acknowledges the Prophethood of Muhammad (PBUH), is a Muslim, but a perfect Muslim is one who has attained that high level where he does not harm any Muslim with his hand and tongue (speech). Similarly, an Emigrant is the one who abandons his homeland and relatives and goes to a place where he can easily practise the religion of Allah. But such a person is also an Emigrant who renounces all such things which are forbidden by Allah, because emigration means abandoning, whether it is abandoning of homeland or sins.

1566. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "He who desires to be rescued from the fire of Hell and to enter Jannah, should die in a state of complete belief in Allah and the Last Day, and should do unto others what he wishes to be done unto him.''
[Muslim].

Commentary: This Hadith is part of a long Hadith which has already been mentioned. See Hadith No.

668. It stresses steadfastness in Faith and virtuous deeds because the time of death is not known to anyone. Since one can die at any moment, one should never be unmindful of the obligations of Faith and good deeds so that he embraces death in a state of perfect Faith. This Hadith has the same meanings which are contained in the Verse 102 of the Surat Al-`Imran exhorting the Muslims thus: "And die not except in a state of Islam [(as Muslim) with complete submission to Allah].''

Every Muslim should treat people as nicely as he himself desires to be treated by others.


Prohibition of Nursing Rancor and Enmity

Chapter 269
Prohibition of Nursing Rancor and Enmity

Allah, the Exalted, says:

"The believers are nothing else than brothers (in Islamic religion).'' (49:10)

"... humble towards the believers, stern towards the disbelievers ...'' (5:54)

"Muhammad (PBUH) is the Messenger of Allah, and those who are with him are severe against disbelievers, and merciful among themselves.'' (48:29)

1567. Anas bin Malik (May Allah be pleased with him) said: The Prophet (PBUH) said, "Do not harbour grudge against one another, nor jealousy, nor enmity; and do not show your backs to one another; and become as fellow brothers and slaves of Allah. It is not lawful for a Muslim to avoid speaking with his brother beyond three days.''
[Al-Bukhari and Muslim].

Commentary: "Do not harbour grudge against one another'' means that one should not say or do any thing which is likely to create ill-will and hatred in others. "Nor jealousy'' signifies that if a Muslim is granted any blessing by Allah, one should not wish that he be deprived of it. "Do not show your backs to one another'' means that if you come across one another, exchange salutations rather than avoid each other. Since all such things create conflict and dissension, these are strictly forbidden in Islam. Muslims are required to resume their conversation and contacts after a maximum period of three days. Any breach beyond this period is prohibited.

1568. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The gates of Jannah are opened on Mondays and Thursdays, and then every slave (of Allah) is granted forgiveness if he does not associate anything with Allah in worship. But the person in whose heart there is rancour against his (Muslim) brother, they will not be pardoned and with regard to them it will be said twice: `Hold both of them until they are reconciled with each other.'''
[Muslim].

Commentary: We learn from this Hadith that mutual enmity, grudge and malice are bound to deprive a man from Jannah in the Hereafter.


Prohibition of Envy

Chapter 270
Prohibition of Envy

Allah, the Exalted, says:

"Or do they envy men (Muhammad (PBUH) and his followers) for what Allah has given them of His Bounty?'' (4:54)

1569. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Beware of envy because envy consumes (destroys) the virtues just as the fire consumes the firewood,'' or he said "grass.''
[Abu Dawud].

Commentary: Envy is one of the major sins which are bound to destroy virtues as fast as the fire burns the wood and dry grass to ashes.


Prohibition of Spying on Muslims and to be Inquisitive about Others

Chapter 271
Prohibition of Spying on Muslims and to be Inquisitive about Others

Allah, the Exalted, says:

"And spy not.'' (49:12)

"And those who annoy believing men and women undeservedly, bear on themselves the crime of slander and plain sin.'' (33:58)

1570. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Beware of suspicion, for suspicion is the worst of false tales. Do not look for other's faults. Do not spy one another, and do not practise Najsh (means to offer a high price for something in order to allure another customer who is interested in the thing). Do not be jealous of one another and do not nurse enmity against one another. Do not sever ties with one another. Become the slaves of Allah, and be brothers to one another as He commanded. A Muslim is the brother of a Muslim. He should neither oppress him nor humiliate him. The piety is here! The piety is here!'' While saying so he pointed towards his chest. "It is enough evil for a Muslim to look down upon his Muslim brother. All things of a Muslim are inviolable for his brother in Faith: his blood, his wealth and his honour. Verily, Allah does not look to your bodies nor to your faces but He looks to your hearts and your deeds.''

Another narration is: "Do not feel envy against one another; do not nurse enmity; do not spy on one another and do not cheat one another. Be Allah's slaves, brethren to one another.''

Another narration is: "Do not have estranged relations with one another. Do not nurse enmity and do not feel envy against one another. O Allah's worshippers! Be brothers!''

Another narration is: "Do not estrange mutual relations and do not intervene into the transaction which is likely to be settled with another person.''
[Muslim].

Commentary: "Beware of suspicion'' means such suspicion about a Muslim for which no apparent evidence is available. Similar is the case of that thought which emerges in one's mind without any logic. "Najsh'' means to give higher bid in auction only to deceive others. Thus, it is a false bid which is not at all intended for purchasing the thing which is being auctioned. The instructions given to the Muslims in this Hadith are meant to secure the honour of Muslims. Since, doubt without any reason, and search for defects and weaknesses go against the security of a Muslim's honour, Islam has strictly forbidden Muslims from them. Another purpose for forbidding such things is to consolidate Muslim brotherhood. For this reason, they have been forbidden from oppression, leaving their Muslim brothers in lurch, considering others humble, and from taking pride in worldly possessions. In fact, the life, property, and honour of a Muslim have been declared unlawful for all other Muslims. Increase in a bid without any intention of buying the thing being auctioned and bargain over a bargain have also been prohibited because they also create ill-will and enmity.

1571. Muawiyah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "If you find faults with Muslims, you will corrupt them.''
[Abu Dawud].

Commentary: If a Muslim looks for the defects of another and hunts for his weaknesses, other Muslims will also adopt the same attitude towards him, and this situation will create dissension and conflict in society. This also will make them fall prey to sins and make them persistent in committing them. For this reason, spying and finding faults with Muslims has been prohibited by Shari`ah.

1572. It has been reported that a man was brought before Abdullah bin Mas`ud (May Allah be pleased with him) because his beard was giving out smell of wine. Ibn Mas`ud said: "We have been prohibited from spying (on Muslims) and finding faults (with them). But we can take to task only and only if the sin is overt.
[Abu Dawud].

Commentary:
1. In this Hadith we find a model conduct of the Companions of the Prophet (PBUH) which was taught to them by Islam. The Companions of the Prophet (PBUH) were certainly strict followers of the commands and prohibitions of Islam.

2. A Hadd or Ta`zir (punishment) is not enforced on mere suspicion. A solid evidence is essential for both of them.


Prohibition of Suspicion

Chapter 272
Prohibition of Suspicion

Allah, the Exalted, says:

"O you who believe! Avoid much suspicions, indeed some suspicions are sins.'' (49:12)

1573. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Beware of suspicion, for suspicion is the worst of false tales.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned (No. 15). It warns us against suspicions about other Muslims as this involves telling lies about them, which is strictly forbidden. This is the reason why it is referred to as the worst of false tales. We also learn from this Hadith that the orders and punishments of Shari`ah are enforced on certainty, not on speculations and conjectures.


Prohibition of Despising Muslims

Chapter 273
Prohibition of Despising Muslims

Allah, the Exalted, says:

"O you who believe! Let not a group scoff at another group; it may be that the latter are better than the former. Nor let (some) women scoff at other women; it may be that the latter are better than the former. Nor defame one another, nor insult one another by nicknames. How bad is it to insult one's brother after having Faith [i.e., to call your Muslim brother (a faithful believer) as: `O sinner', or `O wicked']. And whosoever does not repent, then such are indeed Zalimun (wrongdoers).'' (49:11)

"Woe to every slanderer and backbiter.'' (105:1)

1574. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is enough evil for a Muslim to look down upon his (Muslim) brother.''
[Muslim].

Commentary: This Hadith has already been mentioned (Hadith No. 1571). Its meanings are evident and need no elaboration.

1575. Ibn Mas`ud (May Allah be pleased with him) said: The Prophet (PBUH) said, "The haughty, even with pride equal to a mustard seed in his heart, will not enter Jannah.'' A man enquired: "What about that a person likes fine dress and fine shoes?'' He said: "Allah is Beautiful and likes beauty. Pride amounts to disclaiming truth out of self-esteem, and despising people .''
[Muslim].

Commentary: This Hadith has already been mentioned (Hadith No. 216). Imam An-Nawawi has interpreted the words "Batar-ul-Haq'' as "Daf`-ul-Haq'' that is to evade the truth and return it to the person who says it, which practically means evasion. To dress well does not come in the category of pride, as people generally consider it. In fact, pride constitutes what is mentioned in this Hadith.

1576. Jundub bin `Abdullah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Once someone said: `By Allah! Allah will not forgive such and such (a person).' Thereupon Allah, the Exalted and the Glorious, said: `Who is he who takes an oath in My Name that I will not grant pardon to so-and-so? I have granted pardon to so-and-so and rendered your good deeds fruitless.'''
[Muslim].

Commentary: Some people become self-conceited as a result of their excessive worship to the point that they start disparaging and making low estimates of their fellow Muslims and their deeds, little knowing that Allah, Glorious is He, is of vast forgiveness. They do not realize that if Allah so wills, He can destroy all their deeds and consign them to Hell and send the other people who have been disparaged and underestimated to Jannah. Therefore, one should never become proud of his piety nor should one consider others of little value or good deeds, as only Allah Alone knows what is inside our hearts.


Prohibition of Rejoicing over another's Trouble

Chapter 274
Prohibition of Rejoicing over another's Trouble

Allah, the Exalted, says:

"The believers are nothing else than brothers (in Islamic religion).'' (49:10)

"Verily, those who like that (the crime of) illegal sexual intercourse should be propagated among those who believe, they will have a painful torment in this world and in the Hereafter.'' (24:19)

1577. Wathilah bin Al-Asqa` (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not express pleasure at the misfortune of a (Muslim) brother lest Allah should bestow mercy upon him and make you suffer from a misfortune.''
[At-Tirmidhi].

Commentary: A true believer is one who feels unhappy to see Muslims suffering, and rejoices on the happiness of his other fellows in Faith. It is contrary to the conduct of a true believer to rejoice over the trouble of another Muslim as this attitude is very much disliked by Allah. There is every possibility that Allah may punish such a person in this world and relieve the one who is in trouble. See also Hadith No. 1571.


Prohibition of Deriding one's Lineage

Chapter 275
Prohibition of Deriding one's Lineage

Allah, the Exalted, says:

"And those who annoy believing men and women undeservedly, bear on themselves the crime of slander and plain sin.'' (33:58)

1578. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Two matters are signs of disbelief on the part of those who indulge in them: Defaming and speaking evil of a person's lineage, and wailing over the dead.''
[Muslim].

Commentary: Both the sins mentioned in this Hadith are such that if a Muslim thinks them lawful and still commits them he will become a Kafir. To defame someone's lineage means to disgrace or humiliate somebody by saying to him or to her: "Your father belongs to such and such profession'' or "Your mother is such and such / so-and-so'' or "You are a weaver, blacksmith, laundrer, cobbler, etc.''

Mourning and wailing means expressing qualities of a deceased person through weeping, crying and lamenting loudly. Imam An-Nawawi said that such qualities are attributes and acts of the disbelievers and practices of the pre-Islamic period, or Jahiliyyah.


Prohibition of Deceiving others

Chapter 276
Prohibition of Deceiving others

Allah, the Exalted, says:

"And those who annoy believing men and women undeservedly, bear on themselves the crime of slander and plain sin.'' (33:58)

1579. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who takes up arms against us is none of us; and he who cheats us is none of us.''
[Muslim].

Another narration of Muslim is: The Messenger of Allah (PBUH) happened to pass by a heap of corn. He thrust his hand in that (heap) and his fingers felt wetness. He said to the owner of that heap of corn, "What is this?'' He replied: "O Messenger of Allah! These have been drenched by rainfall.'' He remarked, "Why did you not place this (the drenched part of the heap) over the corn so that people might see it? He who deceives is not of us.''

Commentary:
1. To take arms here signifies to revolt against the Muslim community (and a Muslim government, for that matter) or draw a sword, gun, etc., to kill a Muslim - a common practice in the present-day terrorism.

2. Forgery and deceit have two different forms; one is implied and other is physical and visible. In the former, falsehood is given a veneer of truth. The latter is concealment of some defect, adulteration of some inferior quality merchandise in a superior one, addition of something to increase weight or volume or a substance by unfair means and other malpractices.

3. "He is none of us'' means "He is not following the way of Muslims'' or "His conduct is unlike that of Muslims.'' It is therefore, necessary for every Muslim to abstain from such evils.

1580. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not practise Najsh (to cheat).''
[Muslim].

Commentary: This Hadith has already been mentioned (Hadith No. 1591). Najsh means to offer a high price for something in order to allure another customer who is interested in the thing. If a person has no intention of purchasing a thing which is being auctioned, one should not give a higher bid for it because its genuine customer will be deceived by it, and he will purchase it at a higher price. This is also a form of deceit which must be strictly avoided.

1581. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) prohibited the practice of Najsh.
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that one should not make an offer of a higher price if one has no intention of buying it because that will be a fraud. For this reason this practice has been forbidden.

1582. Ibn `Umar (May Allah be pleased with them) said: A man mentioned to the Messenger of Allah (PBUH) that he was often deceived in dealings. The Messenger of Allah (PBUH) said to him, "When you enter into a transaction you should say: "There should be no deception.'''
[Al-Bukhari and Muslim].

Commentary: The words mentioned in the Hadith for the customer are meant to protect his right, implying that if there is something amiss in the bargain, he will have the right to return the commodity purchased by him. The seller will have to respect this right of the buyer.

1583. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who deceives another's wife or his slave is none of us.''
[Abu Dawud].

Commentary: To incite or provoke someone's wife or slave against her husband or his master or to create hatred between the two is a great crime, because a Muslim is required to create peace and accord amongst people. It is against his conduct to foment dissension and discord between them.


Prohibition of the Treachery and Breaking one's Covenant

Chapter 277
Prohibition of the Treachery and Breaking one's Covenant

Allah, the Exalted, says:

"O you who believe! Fulfill (your) obligations.'' (5:1)

"And fulfill (every) covenant. Verily! The covenant will be questioned about.'' (17:34)

1584. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "Whosoever possesses these four characteristics is a sheer hypocrite; and anyone who possesses one of them possesses a characteristic of hypocrisy till he gives it up. These are: when he is entrusted with something, he proves dishonest; when he speaks, he tells a lie; when he makes a covenant, he proves treacherous; and when he quarrels, he behaves in very imprudent, evil, insulting manner.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already been mentioned (Hadith No. 1544). The traits mentioned in this Hadith are peculiar to hypocrites and every Muslim is required to abstain from them. Excellence of character is riveted with Faith. The nobility of character is invariably reflected in Faith, and where there is no Faith there will be little excellence of character.

1585. Ibn Mas`ud, Ibn `Umar and Anas (May Allah be pleased with them) said: The Prophet (PBUH) said, "For every one who breaks his covenant, there will be a (huge) flag on the Day of Resurrection and it will be said: `This flag proclaims a breach of covenant by so-and-so.'''
[Al-Bukhari and Muslim].

Commentary: "Ghadr'" means breach of oath and its disregard. On the Day of Judgement, a person with such a quality will be given a (huge) flag which will be a sign of his lack of sincerity to his words.

1586. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Prophet (PBUH) said, "Every one who breaks a covenant will have a flag by his buttocks on the Day of Resurrection. It will be raised higher according to the nature of his breach. Behold, there will be no greater a sin with respect to breaking the covenant than that of a ruler who breaks his covenant with the Muslim masses.''
[Muslim].

Commentary: This Hadith clearly shows that breach of covenant is forbidden in Islam, especially on the part of a ruler because (a) he is in a position to honour his covenant, and (b) his evil can affect the whole Muslim community.

It was a custom in the Pre-Islamic Period of Ignorance in Arabia to fix flags on poles for those who were guilty of breach of oath to humiliate and defame them. Almighty Allah has mentioned the punishment of flags on the Day of Resurrection for such people who break their covenant so that people can easily understand its nature. What a humiliation that will be!

* Placing the flag by his bottom signifies humiliation and disgrace because flags are usually carried in front of the bearer not behind. (Editor's Note)

1587. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Allah, the Exalted, says: `I will contend on the Day of Resurrection against three (types of) people: One who makes a covenant in My Name and then breaks it; one who sells a free man as a slave and devours his price; and one who hires a workman and having taken full work from him, does not pay him his wages.'''
[Al-Bukhari].

Commentary: This Hadith highlights the importance of fulfillment of promise, the prohibition of the sale of a free person, and the payment of due wages to the labourers.


Prohibition of Recounting of Favors

Chapter 278
Prohibition of Recounting of Favors

Allah, the Exalted, says:

"O you who believe! Do not render in vain your Sadaqah (charity) by reminders of your generosity or by injury.'' (2:264)

"Those who spend their wealth in the Cause of Allah, and do not follow up their gifts with reminders of their generosity or with injury.'' (2:262)

1588. Abu Dharr (May Allah be pleased with him) said: The Prophet (PBUH) observed: "There are three (types of) people to whom Allah will neither speak on the Day of Resurrection nor look at them nor purify them, and they will have a painful chastisement.'' The Messenger of Allah (PBUH) repeated it three times. Abu Dharr (May Allah be pleased with him) remarked: "They are ruined. Who are they, O Messenger of Allah?'' Upon this, the Messenger of Allah (PBUH) said, "One who lets down his lower garments (below his ankels) out of arrogance, one who boasts of his favours done to another; and who sells his goods by taking a false oath.''
[Muslim].

Commentary: The Hadith makes it evident that it is forbidden for a man to let his lower-body garment go beyond his ankles out of arrogance. The Hadith also makes it clear that it is forbidden to take a false oath with a view to sell one's goods. Messenger of Allah (PBUH) also said in a Hadith reported by Al-Bukhari:"Taking a false oath) helps one sell one's goods well but takes away Allah's blessings from it.''


Prohibition of Arrogance and Oppression

Chapter 279
Prohibition of Arrogance and Oppression

Allah, the Exalted, says:

"So ascribe not purity to yourselves. He knows best him who fears Allah and keeps his duty to Him [i.e., those who are Al-Muttaqun (the pious)].'' (53:32)

"The way (of blame) is only against those who oppress men and wrongly rebel in the earth without justification; for such there will be a painful torment.'' (42:42)

1589. `Iyad bin Himar (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Verily, Allah has revealed to me that you should adopt humility. So that no one may wrong another and no one may be disdainful and haughty towards another.''
[Muslim].

Commentary: Anyone whom Allah has granted wealth or authority, beauty or splendour, should take it as Allah's Gift. He should take to adopt humility and humbleness and express his gratitude for it to Allah. He should benefit people with the gifts bestowed upon him by Allah and not make them a means of pride and oppression.

1590. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "When a person says: `People have been ruined, he is the one to be ruined the most.'''
[Muslim]

In another version: "He himself is the most ruined among them.''

Commentary: This Hadith prohibits a Muslim from saying the statement in the Hadith or something similar to it out of arrogance and pride. There is no harm, however, if one says it in view of the bad state of affairs to which Muslims have been reduced as a result of, for example, neglecting the teachings of Islam. Of the religious scholars, who hold this view, are Imam Malik bin Anas, Imam Al-Khattabi, Al-Humaidi and others. This point has been made clear in Imam An-Nawawi's Al-Adhkar.


Prohibition of Breaking ties and Relationships

Chapter 280
Prohibition of Breaking ties and Relationships

Allah, the Exalted, says:

"The believers are nothing else than brothers (in Islamic religion). So make reconciliation between your brothers.'' (49:10)

"But do not help one another in sin and transgression.'' (5:2)

1591. Anas bin Malik (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not desert (stop talking to) one another, do not nurse hatred towards one another, do not be jealous of one another, and become as fellow brothers and slaves of Allah. It is not lawful for a Muslim to stop talking to his brother (Muslim) for more than three days.''
[Al-Bukhari and Muslim]

Commentary: "Hijran'' means to terminate contacts and speech. All the things mentioned in this Hadith are prohibited for the reason that they go against the spirit of Muslim brotherhood. Muslims are ordained to maintain the bond of Islamic fraternity.

1592. Abu Ayyub Al-Ansari (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is not lawful for a Muslim to desert (stop talking to) his brother beyond three nights, the one turning one way and the other turning to the other way when they meet, the better of the two is one who is the first to greet the other.''
[Al-Bukhari and Muslim].

Commentary:
1. Since Islam is a religion based on the nature of man, it has a suitable concession in all his natural affairs. When there occurs a dispute between two Muslims then unpleasantness and contraction of mind are bound to result from it. In such a situation they naturally do not like to speak or maintain contact with each other. Islamic Shari`ah has acknowledged the validity of this reaction and granted permission to the party to suspend speech for three days. Since longevity of suspension of contact leads to severe hatred and animosity which increases dissension in society, creates obstruction in family relations and injures the bond of friendship, Muslims have been ordered not to let this temporary unpleasantness and turbidity go beyond a period of three days.

2. By highlighting the merit of Salam (salutation), this Hadith has prescribed an easy way for resuming the relations because Salam increases mutual love and paves the way for conversation and reconciliation.

1593. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "People's deeds are presented before Allah on Mondays and Thursdays, and then every slave (of Allah) is granted forgiveness (of minor sins) if he does not associate anything with Allah in worship. But the person in whose heart there is rancour against his brother, will not be pardoned. With regard to them, it is said twice: `Hold these two until they are reconciled'.''
[Muslim].

Commentary: To entertain enmity without any major lawful reason is akin to inviting the displeasure of Allah. May Allah save us from it.

1594. Jabir (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) as saying, "The Satan has despaired of being worshipped by those who engage in prayer in the Arabian Peninsula but (has not lost hope) in creating dissension among them.''
[Muslim].

Commentary:
1. This Hadith is one of the proofs of Prophethood of Muhammad (PBUH). His prophecy has come true that Muslims will fight among themselves and, as a result of mutual conflicts, sever links with one another; and this situation will arise as a result of the mischief, provocation and evil suggestions made by Satan.

2. One of the benefits of Salat is to maintain and strengthen the feeling of brotherhood and fraternity between Muslims..

1595. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is not lawful for a Muslim to forsake his (Muslim) brother beyond three days; and whosoever does so for more than three days, and then dies, will certainly enter the Hell.''
[Abu Dawud].

Commentary: Such a Muslim who persistently forsakes his Muslim brother for more than three days (i.e., he does not greet him and talk to him) and dies in this state, will certainly be punished in Hell along with other Muslims who violate such Divine injunctions. After suffering the punishment in Hell, he will be sent to Jannah because it is only the Kuffar (infidels) who would remain in Hell for ever. It does not, however, mean that a Muslim is at liberty to do what he wishes and he will not be sent to Hell even temporarily for punishment. Such an impression is a gross misunderstanding. This applies to women as well.

1596. Abu Khirash Hadrad bin Abu Hadrad Al-Aslami (May Allah be pleased with him) said: I heard the Prophet (PBUH) saying, "Whosoever forsakes his brother for a year is like one who sheds his blood.''
[Abu Dawud].

Commentary: This Hadith strongly condemns those Muslims who forsake their brothers and sisters in Faith. Since those who are forsaken, have to suffer mental torture, this act has been regarded equivalent in gravity to killing.

1597. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is not permissible for a believer to forsake his (Muslim) brother for more than three days. If three days have passed, he should meet him and greet him; and if other responds to it they will both share the reward; but if he does not respond, he will bear his sin and the one who (has taken the initiative to) greet (the other) will be absolved of the sin of forsaking (one's brother in Faith).''
[Abu Dawud].

Commentary:
1. Contact and speech with people should be for the Pleasure of Allah only. For instance, if somebody is a heretic in religion, or commits sins openly, and in spite of the advice given to him, he does not mend his way, a Muslim can renounce contact with him for the sake of Allah. Such renunciation is permissible. In fact, it is desirable so that he may learn a lesson from it and may change himself. But severing contacts merely for worldly grievances is not permissible.

2. After three days, one who should take the initiative in giving Salam is more superior than the other. If the second party does not respond and perpetuates malice and enmity, he will be sinful and the former will be absolved of the sin of rupturing contact.


Prohibition of two Holding Secret Counsel to the Exclusion of Conversing together a Third

Chapter 281
Prohibition of two Holding Secret Counsel to the Exclusion of Conversing together a Third

Allah, the Exalted, says:

"Secret counsels (conspiracies) are only from Shaitan (Satan).'' (58:10)

1598. Ibn `Umar (May Allah be pleased with them) said: the Messenger of Allah (PBUH) said, "In the presence of three people, two should not hold secret counsel, to the exclusion of the third.''
[Al-Bukhari and Muslim].

In Abu Dawud, Abu Salih related: I asked Ibn `Umar: "What if there are four people.'' He said, "There is no harm in that.''

Malik reported in Al-Muwatta that `Abdullah bin Dinar related: Ibn `Umar and I were together in Khalid bin `Uqbah's house which was situated in the market place. A man came to consult Ibn `Umar. None besides me was present. Ibn `Umar called another man in and we became four and said to me and the man he had called: Move away a bit because I have heard the Messenger of Allah (PBUH) saying, "The two people should not hold secret counsel together excluding the third.''

Commentary: This Hadith teaches us certain etiquettes of society. Ibn `Umar (May Allah be pleased with them) called the fourth person so that he (Ibn `Umar) could hear the conversation of the man who wanted to speak to him in isolation. He asked the other two to move to a distance so that they could not overhear what the person in question wanted to say to him. Thus, we learn that in the presence of more than one person, two can speak to each other in confidence. If there are four people, three of them are not permitted to speak in confidence leaving the fourth alone. Moreover, this prohibition is for lawful matters only because in unlawful matters such private conversation is altogether forbidden, even if there is no third person. The Noble Qur'an ordains:

"O you who believe! When you hold secret counsel, do it not for sin and wrong and disobedience to the Messenger, but do it for righteousness and self-restraint; and fear Allah, to Whom you shall be brought back.'' (V.58:9)

1599. Ibn Mas`ud (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "When three of you are together, two of you must not converse privately ignoring the third till the number increases, lest the third should be grieved.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us that holding private counsel has been prohibited for the reason that it hurts the feelings of the Muslim who is ignored; and to hurt the feelings of a Muslim is a great sin indeed. Allah says: "And those who annoy believing men and women undeservedly, bear on themselves the crime of slander and plain sin.'' (33:58) Whispering of the two is permissible when all the three mix up in a crowd. Then the two can speak to each other in confidence.


Prohibition of Cruelty

Chapter 282
Prohibition of Cruelty

Allah, the Exalted, says:

"And do good to parents, kinsfolk, orphans, Al-Masakin (the poor), the neighbour who is near of kin, the neighbour who is a stranger, the companion by your side, the wayfarer (you meet), and those (slaves) whom your right hands possess. Verily, Allah does not like such as are proud and boastful.'' (4:36)

1600. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "A woman was punished in Hell because of a cat which she had confined until it died. She did not give it to eat or to drink when it was confined, nor did she free it so that it might eat the vermin of the earth.''
[Al-Bukhari and Muslim]

Commentary: It is necessary for the Muslim to treat animals kindly and tenderly. Harshness to them is unlawful.

1601. Ibn `Umar (May Allah be pleased with them) reported: I happened to pass by some lads of the Quraish who had tied a bird at which they have been shooting arrows. Every arrow that they missed came into the possession of the owner of the bird. No sooner had they seen Ibn `Umar, they dispersed. Thereupon, Ibn `Umar said: "Who has done this? May Allah curse him who has done so. Verily, the Messenger of Allah (PBUH) has cursed anyone who makes a live thing the target (of one's marksmanship).''
[Al-Bukhari and Muslim].

Commentary: It is a major sin to pin down a living being to make it a target. One who does it is a cursed person.

1602. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) forbade animals being tied (as targets).
[Al-Bukhari and Muslim].

Commentary: The right way of doing it is that rather than first capturing it and making it a target of arrows and bullets, it should be captured and slaughtered with a very sharp knife so that the victim does not feel much pain while giving its life.

1603. Abu Ali Suwaid bin Muqarrin (May Allah be pleased with him) said: I was the seventh child of Banu Muqarrin and we had only one slave-girl. When the youngest of us once happened to slap her (on the face) the Messenger of Allah (PBUH) ordered us to set her free.
[Muslim].

Commentary: It is a serious crime to beat one's servant or slave. The expiation of this sin is to set the servant or slave free. One is, however, allowed to discipline one's servants in a suitable manner in which punishment does not exceed the nature of offense committed on their part.

1604. Abu Mas`ud Al-Badri (May Allah be pleased with him) said: I was beating my slave with a whip when I heard a voice behind me which said: "Abu Mas`ud! Bear in mind...'' I did not recognize the voice for the intense anger I was in. Abu Mas`ud added: As he came near me, I found that he was the Messenger of Allah (PBUH) who was saying, "Abu Mas`ud! Bear in mind that Allah has more dominance upon you than you have upon your slave.'' Then I said: "I will never beat any slave in future.''

Another narration is: The whip dropped from my hand in awe of the Prophet (PBUH).

Still another narration is: I said: "He is free for the sake of Allah.'' He (PBUH) said, "If you had not done this, you would have been singed by the Fire.''
[Muslim].

Commentary:
1. This Hadith has a stern warning for those who punish their slaves and servants without reason or far more than what they deserve.

2. This Hadith also gives a hint of the aura of awe and majesty that characterized the person of the Prophet (PBUH). It also shows the readiness of the Companions to mend their ways and obey the Prophet's commands.

1605. Ibn `Umar (May Allah be pleased with them) reported: The Prophet (PBUH) said, "The expiation for beating or slapping a slave on the face for something he has not done is to set him free.''
[Muslim].

Commentary: Al-Qadi `Iyad says that there is consensus on the point that setting the slave free is desirable, not obligatory. Such liberation of the slave, however, is not equal in reward to setting him free without any consideration.

1606. It has been narrated that Hisham bin Hakim bin Hizam (May Allah be pleased with them) happened to pass by some (non-Arab) farmers of Syria who had been made to stand in the sun, and olive oil was poured on their heads. He said: "What is the matter?'' He was told that they had been detained for the non-payment of Jizyah. (Another narration says that they were being tortured for not having paid Al-Kharaj). Thereupon Hisham said: "I bear testimony to the fact that I heard the Messenger of Allah (PBUH) saying, `Allah will torment those who torment people in the world.''' Then he proceeded towards their Amir and reported this Hadith to him. The Amir then issued orders for their release.
[Muslim].

Commentary:
1. "Al-Kharaj'' is that tax which is charged on the produce yielded by land which is in the possession of non-Muslims in a Muslim State, while the revenue that is recovered from the Muslims on the lands held by them is called "Al-Ushr''. "Jizyah'' is that annual fee which is charged from the non-Muslims for the safety and security provided to their life, property and honour by a Muslim State. Muslims pay Zakat and non-Muslims pay Jizyah.

2. "Adhab'' torment is that particular punishment which Allah will inflict upon the inhabitants of Hell. If anyone gives a similar punishment to anybody in this world, he will be punished by Allah in the Hereafter for it, because He does not like anyone to do so. To make someone stand in a sizzling hot day and pour oil over his head is one type of tormenting people. For this reason, Hisham bin Hakim (May Allah be pleased with them) mentioned this Hadith to the Governor to warn him and make him abolish the punishment.

3. We also learn from this Hadith that it is incumbent on every Muslim to enjoin good on people and forbid them from doing evil.

4. Tyrants should be warned against their tyrannies so that they abstain from them.

1607. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) saw an ass which had been branded on the face. He disapproved of it. Upon this Ibn `Abbas (May Allah be pleased with them) said, "By Allah, I shall not brand (the animal) but on a part at a distance from the face.'' Ibn `Abbas (May Allah be pleased with them) then commanded branding on the hips; he was the first person to brand the animals on hips.
[Muslim].

Commentary: We learn from this Hadith that if an animal is to be branded for identification, it should not be branded on the face. The Hadith also points out the superiority of Ibn `Abbas (May Allah be pleased with them) and his obedience to the Prophet's command not to brand an animal on the face.

1608. Ibn `Abbas (May Allah be pleased with them) said: An ass with a brand on the face happened to pass before the Prophet (PBUH). Thereupon he said, "May Allah curse the one who has branded it (on the face).''
[Muslim].

Another narration in Muslim is: "The Messenger of Allah (PBUH) prohibited us from hitting across the face and branding on the face (of an animal).''

Commentary: Since face is the most sensitive and delicate part of the body, Muslims are strictly forbidden from causing even the slightest harm to it, no matter whether it is mankind or animal. Although, it is permissible to beat one's wife, children and slaves etc., for discipline but there is a stern warning that they should not be hit on the face.


Prohibition of Chastisement with Fire

Chapter 283
Prohibition of Chastisement with Fire

1609. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) sent us on an expedition and said to us, "If you find so-and-so (he named two persons belonging to the Quraish) commit them to the fire.'' When we were on the verge of departure, he said to us, "I ordered you to burn so-and-so, but it is Allah Alone Who punishes with the fire. So if you find them put them to death.''
[Al-Bukhari].

Commentary: The Prophet (PBUH) has clearly stated that no one is to be burnt in any case, not even an enemy.

1610. Ibn Mas`ud (May Allah be pleased with him) reported: We were with the Messenger of Allah (PBUH) in a journey when he drew apart (to relieve nature). In his absence, we saw a red bird which had two young ones with it. We caught them and the red mother bird came, beating the earth with its wings. In the meantime the Prophet (PBUH) returned and said, "Who has put this bird to distress on account of its young? Return them to her.'' He (PBUH) also noticed a mound of ants which we had burnt up. He asked, "Who has set fire to this?'' We replied: "We have done so.'' He (PBUH) said, "None can chastise with fire except the Rubb of the fire.''
[Abu Dawud].

Commentary:
1. To catch nestlings of a bird and torment them or to burn the holes of insects along with their inmates is forbidden. One can, however, burn their vacant holes.

2. If somebody has burnt a person to death, it is not permissible to kill him in return by burning. If the heirs of the victim want to kill him in the same way under Al-Qisas (the law of equality in punishment) they can do so; otherwise he can be put to the sword.


Prohibition of Procrastinating by a Rich Person to Fulfill his Obligation

Chapter 284
Prohibition of Procrastinating by a Rich Person to Fulfill his Obligation

Allah, the Exalted, says:

"Verily, Allah commands that you should render back the trusts to those, to whom they are due.'' (4:58)

"Then if one of you entrust the other, let the one who is entrusted discharge his trust (faithfully).'' (2:283)

1611. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is an act of oppression on the part of a person to procrastinate in fulfilling his obligation; if the repayment of a debt due to any of you is undertaken by a rich person, you should agree to the substitution.''
[Al-Bukhari and Muslim].

Commentary:
1. Evasion or procrastination in the payment of debt, when a person is in a position to make its payment immediately, is prohibited.

2. If for the settlement of dispute, a rich man is entrusted to the lender for recovery of his debt, the lender should accept this decision. Thus, this Hadith induces one for an amicable way of settling disputes.


Undesirability of giving a Gift and then ask back for it

Chapter 285
Undesirability of giving a Gift and then ask back for it

1612. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "He who gives something (to someone) as a gift and then gets it back (from him or her) is like a dog which eats its own vomit.''

Another narration is: "He who gets back his charity is like a dog which vomits and then returns to that and eats it.''
[Al-Bukhari and Muslim].

Commentary: The evil and abomination of taking back a gift (Hibah) is evident from the fact that one who does it has been considered akin to a dog, and what is taken back to vomit, which is extremely repulsive. Religious scholars are, however, of the opinion that this injunction is for the strangers (non-relatives). If a person gives something as a gift to his children or grandchildren, this order will not apply to him. It is permissible for him to take it back.

1613. `Umar bin Al-Khattab (May Allah be pleased with him) said: I donated a horse in the way of Allah. Its new possessor did not treat it properly. I made my mind to buy it because I thought that he would sell it at a cheap price (now that it became weak and emaciated). I asked the Prophet (PBUH) about it, whereupon he said, "Do not buy it and do not get back your charity, for one who gets back the charity is like a dog that eats its own vomit.''
[Al-Bukhari and Muslim]

Commentary: We learn from this Hadith that even to purchase something which one has already given in charity is not permissible.


Prohibition of devouring the Property of an Orphan

Chapter 286
Prohibition of devouring the Property of an Orphan

Allah, the Exalted, says:

"Verily, those who unjustly eat up the property of orphans, they eat up only fire into their bellies, and they will be burnt in the blazing Fire!'' (4:10)

"And come not near to the orphan's property, except to improve it.'' (6:152)

"And they ask you concerning orphans. Say: `The best thing is to work honestly in their property, and if you mix your affairs with theirs, then they are your brothers. And Allah knows him who means mischief (e.g., to swallow their property) from him who means good (e.g., to save their property).'' (2:220)

1614. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Keep away from the seven fatalities.'' It was asked: "What are they, O Messenger of Allah?'' He (PBUH) replied, "Associating anything with Allah in worship (i.e., committing an act of Shirk), sorcery, killing of one whom Allah has declared inviolable without a just cause, devouring the property of an orphan, the eating of usury (Riba), fleeing from the battlefield and accusing chaste believing women, who never even think of anything touching their chastity.''
[Al-Bukhari and Muslim].

Commentary: All the sins mentioned in the Hadith are major sins but Shirk is the greatest of all. The reason behind this is that it will never be pardoned, and one who commits it, will abide in Hell for all eternity. So far as the other major sins are concerned with Allah, He may forgive them if He so wills; otherwise one who is guilty of such sins will have to suffer the torments of Hell. He will, however, be sent to Jannah after suffering the punishment if he is a Muslim.


Prohibition of taking Ar-Riba (The Usury)

Chapter 287
Prohibition of taking Ar-Riba (The Usury)

Allah, the Exalted, says:

"Those who eat Ar-Riba (the usury) will not stand (on the Day of Resurrection) except like the standing of a person beaten by Shaitan (Satan) leading him to insanity. That is because they say: `Trading is only like Ar-Riba, whereas Allah has permitted trading and forbidden Ar-Riba. So whosoever receives an admonition from his Rubb and stops eating Ar-Riba, shall not be punished for the past; his case is for Allah (to judge); but whoever returns (to Ar-Riba), such are the dwellers of the Fire - they will abide therein. Allah will destroy Ar-Riba and will give increase for Sadaqat (deeds of charity, alms). And Allah likes not the disbelievers, sinners. Truly, those who believe, and do deeds of righteousness, and perform As-Salat (Iqamat-As-Salat), and give Zakat, they will have their reward with their Rubb. On them shall be no fear, nor shall they grieve. O you who believe! Be afraid of Allah and give up what remains (due to you) from Ar-Riba (from now onward).'' (2:275-279)

Ahadith on the subject are many, including Hadith No. 1615.

1615. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) cursed the one who accepts Ar-Riba (the usury) and the one who pays it.
[Muslim].

The narration in At-Tirmidhi adds: And the one who records it, and the two persons who stand witness to it.

Commentary: Both the parties, that is the one who charges interest and the one who pays it, are equally guilty in the matter of usury (or Riba). This Hadith highlights the intensity of unlawfulness of Ar-Riba, or what has come to be called nowadays interest which can be judged from the fact that not only the person who charges it and the one who pays it are cursed but even those who write the documents and bear witness to the transaction are condemned although the latter two have no active part in the deal. They have been condemned for their mere co-operation in the matter of interest. Thus, we learn that even co-operation in the deal in which interest is involved is an invitation to the Curse and Wrath of Allah. The reason for such severity in the matter of interest is that Islam wants to create a society which is founded on fraternity, sympathy, selflessness and sacrifice. If someone is in need of money, the rich should fulfill his needs for the sake of Allah's Pleasure or give him a loan without interest. As against the Islamic system, this system of interest is based on selfishness, exploitation and suppression. In the interest-ridden societies, the affluent ones are not inclined to co-operate with the needy for the sake of Allah. All they are concerned with is their own interest. Their lust and greed are not reduced in the slightest measure even after draining the last drop of the blood of the poor. This is the reason why Shari`ah has forbidden interest of every kind and regarded it unlawful, no matter whether the loan is for the personal need or commercial requirements.

Some people say that there did not exist any practice of commercial loan in Arabia at that time and people used to borrow money for their personal needs only. On the basis of this plea, they say that the interest which has been forbidden by Islam relates to the latter form. For this reason, they hold that interest lawful which is charged on loan taken for industry and commerce. They contend that since the borrowers in industrial and commercial sectors make huge profits from such loans, how does it become unlawful if they pay the lender a small fixed annual amount against it? In their opinion, it is a right of the lender which should be paid to him on his wealth. But such arguments are totally wrong for two major reasons:

First, the assumption that there was no practice of commercial loans in Arabia is altogether baseless. Commercial loan was certainly in vogue in the Arab society and there is no point in debating this fact.

Second, nobody can say with certainty that the amount invested by a person in business will yield profit without fail because we see it every day that sometimes huge investments made in business and industry result in colossal loss, but the lending agency does not bother about it at all and it recovers from the borrower every penny of his loan and interest. Is this not the height of tyranny and selfishness? If it is supposed that there is no loss, even then the interest on loan substantially contributes to the increase in prices of goods. Whatever interest an industrialist pays on loan is added to the cost of his goods, which ultimately increases their prices and in turn adversely affects the purchasing capacity of the customers - the masses. This is the reason why Islam has closed this largest source of exploitation, suppression and tyranny by declaring every kind of interest unlawful.

It is very sad indeed that in emulating the western societies, Muslims have also founded their economy on the system of interest. The westernized rulers of the Muslim countries are not making any effort to emancipate their countries from this curse, nor do the people of these countries now have any passion to save themselves from it. In fact, a large majority of them borrow and lend money on interest through the bank without any regard to the Islamic injunctions in this respect.

Given below are some points for the consideration of those Muslims who want to protect their Faith and religion and save themselves from the curse of interest.

The word used for interest in the Qur'an is Ar-Riba which means excess. In Shari`ah, it is the measure of excess in one thing when two things are exchanged in some bargain; or in the case of a loan, an increased amount of the loan at the time of its payment. Ar-Riba is of two kinds:

First, Riba Al-Fadl: To take more in exchange of one commodity in the event of barter of two similar commodities.

Second, Riba An-Nasi'ah: To take a larger return of one thing while two identical things are bartered. But in this case the larger return is effected after a fixed period of time.

In Islamic jurisprudence, assets are of two types. One type is of commodities and the other is of the mode of price for exchanging commodities called Thaman Then every type has a class of varieties. For example, food grains are a type of assets and rice, wheat, etc., are its varieties. Similarly, silver, gold, etc., are varieties of the second type of assets. Coins, currency notes, company shares, etc., can also be considered varieties of this type in contemporary life.

This Hadith has injunctions in respect of both types of assets. Six things mentioned in the Hadith are gold, silver, wheat, barley, dates and salt. Some religious scholars have restricted the matters relating to interest to these six things only and do not regard increase or decrease in other things as usury, while going by analogy the majority of scholars and jurists have included other things also in this list. (For instance, all the food grains whether they are calculated in terms of weight or measure, or which have - like gold and silver - the quality of being Thaman, or according to some scholars and jurists which are capable of being stored).

Thus, to sum up, these two types of assets have four varieties:

1. Commodities which are sold by weight.

2. Commodities which are sold by measure.

3. Commodities which can be stored.

4. Commodities which are used as Thaman in sale and purchase.

In all such matters the position of interest-bearing and interest-free things would be as under:

1. When commodities to be exchanged are of the same `type' and `variety,' any increase or decrease in them will be unlawful, as will be their sale on credit; for example, exchange of wheat with wheat and rice with rice. It is essential that these things are equal in measure and/or weight, and are in actual possession.

2. If two things to be exchanged are of the same `type' but of a different `variety,' any increase or decrease in them is permissible. Their sale on credit is, however, not lawful. For instance, the exchange of one kilogram of silver with two grams of gold, or the barter of one kilo barley with half a kilo wheat, or the exchange of one dinar with four riyals. If such a bargain is on cash basis it will be fair, but any credit in this case is not correct.

3. When the two things to be exchanged are not of the same `type' and are also different in `variety,' then any increase or decrease in them is permissible and their sale on credit is also allowed. For example, exchange of one kilogramme of wheat with a gram of gold, bargain of one kilogramme of dates with ten Tola (about 116 grams) silver. Any increase or decrease in them is permissible, as is their sale on credit


Prohibition of Show-off

Chapter 288
Prohibition of Show-off

Allah, the Exalted, says:

"And they were commanded not, but that they should worship Allah, and worship none but Him Alone (abstaining from ascribing partners to Him).'' (98:5)

"Do not render in vain your Sadaqah (charity) by reminders of your generosity or by injury, like him who spends his wealth to be seen of men.'' (2:264)

"... and to be seen of men, and they do not remember Allah but little.'' (4:142)

1616. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Almighty Allah says, `I am the One Who is most free from want of partners. He who does a thing for the sake of someone else beside Me, I discard him and his polytheism..''
[Muslim].

Commentary: "He who does a thing for the sake of someone else beside Me'' here means to do something virtuous for mere show for worldly benefit, or to gain the reputation of being pious. "I discard him and his polytheism'' means that "I nullify his good deeds and deprive him of the reward.'' In this Hadith any virtue done for the sake of mere show has been likened to Shirk to make its viciousness and harm obvious.

However, this is Ash-Shirk Al-Asghar, and those who commit it will not be forbidden access to Jannah. They will, after the punishment in Hell, ultimately enter Jannah. Whereas, those who are guilty of Ash-Shirk Al-Akbar and sheer Shirk will abide in Hell forever.

1617. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "The first to be judged on the Day of Resurrection will be a man who had died as a martyr. He will be brought forward. Allah will remind him of the favours He had bestowed upon him and the man will acknowledge them. Then He will ask him: `What did you do to express gratitude for it?' The man will reply: `I fought for Your Cause till I was martyred.' Allah will say: `You have lied. You fought so that people might call you courageous; and they have done so.' Command will then be issued about him and he will be dragged on his face and thrown into Hell. Next a man who had acquired and imparted knowledge and read the Qur'an will be brought forward, Allah will remind him of the favours He had bestowed upon him and the man will acknowledge them. Then He will ask him: `What did you do to express gratitude for it?' The man will reply: `I acquired knowledge and taught it, and read the Qur'an for Your sake.' Allah will say to him: `You have lied. You acquired knowledge so that people might call you a learned (man), and you read the Qur'an so that they might call you a reciter, and they have done so.' Command will then be issued about him, and he will be dragged on his face and thrown into Hell. Next a man whom Allah had made affluent and to whom Allah had given plenty of wealth, will be brought forward, Allah will remind him of the favours He had bestowed upon him and the man will acknowledge them. He will ask him: `What did you do to express gratitude for it?' The man will reply: `I did not neglect any of the ways You liked wealth to be spend liberally for Your sake'. Allah will say to him: `You have lied. You did it so that people might call you generous, and they have done so.' Command will then be issued about him and he will be dragged on his face and thrown into Hell.''
[Muslim].

Commentary: We learn from this Hadith that:

1. Almighty Allah will first of all bring the show-offs to account for their pretentions.

2. No virtue will be accepted without Ikhlas (sincerity), no matter how great it may be. A pretender who does good deeds for mere show will be consigned to Hell rather than being rewarded with Jannah.

1618. `Abdullah bin `Umar (May Allah be pleased with them) said: Some people told me, "We visit our rulers and we tell them things contrary to those which we say when we depart from them.'' `Abdullah bin `Umar (May Allah be pleased with them) replied: "In the era of the Messenger of Allah (PBUH) we considered this to be an act of hypocrisy.''
[Al-Bukhari].

Commentary: This Hadith has already been mentioned (Hadith No. 1542) with a variation of wording in the other version. In any case, we learn from this Hadith that flattering the rulers, falsely praising them and telling lies before them to win their pleasure constitute hypocrisy, which is a great offence. Such hypocrisy prevents them from knowing the true state of affairs. What sincerity and well-wishing demand is that the real state of affairs is placed before them so that they come to know the true condition of their subjects.

1619. Jundub (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who so acts to show off, Allah will disgrace him on the Day of Resurrection, and he who does good deeds so that people (may hold him in high esteem), Allah will expose his hidden evil intentions before the people on the Day of Resurrection.''
[Al-Bukhari and Muslim].

Commentary: This Hadith shows the consequences of different acts of show-off and informs us that such acts will be a cause of humiliation and disgrace on the Day of Judgement.

1620. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "A person who acquires (religious) knowledge, which is (normally) acquired to gain the Pleasure of Allah, (for the sole reason) to secure worldly comforts will not even smell the fragrance of Jannah on the Day of Resurrection (i.e., will not enter Jannah).''
[Abu Dawud].

Commentary: It is an act of great virtue to acquire religious knowledge provided it is attained for the Pleasure of Allah. If one acquires it for worldly gains, he will be in fact committing a grave sin for which he will not even smell the fragrance of Jannah, that is to say in the first instance because after suffering the punishment for it in Hell, he will be sent to Jannah when Allah will so desire it.


Things not to be Considered as Showing off

Chapter 289
Things not to be Considered as Showing off

1621. Abu Dharr (May Allah be pleased with him) said: The Messenger of Allah (PBUH) was asked: "Tell us about a person who does some good deed and people praise him, will this be considered as showing off?'' He replied, "This is the glad tidings which a believer receives (in this life).''
[Muslim].

Commentary: We learn from this Hadith that if a person does a virtuous act to please Allah (i.e., not with the intention to show off) and people praise him for it, then there is nothing wrong with it. In fact, such praise is the glad tidings which he receives in this world. Expression of such good opinion about him by the public is akin to a declaration that Allah is pleased with him. Sincere admiration and praise of someone by the public is not a disqualification. It is, in fact, an evidence of his virtuous conduct and its recognition by Allah.


Prohibition of gazing at women and Beardless Handsome Boys except in Exigency

Chapter 290
Prohibition of gazing at women and Beardless Handsome Boys except in Exigency

Allah, the Exalted, says:

"Tell the believing men to lower their gaze (from looking at forbidden things).'' (24:30)

"Verily, the hearing, and the sight, and the heart, of each of those ones will be questioned (by Allah).'' (17:36)

"Allah knows the fraud of the eyes, and all that the breasts conceal.'' (40:19)

"Verily, your Rubb is Ever Watchful (over them).'' (89:14)

1622. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Allah has written the very portion of Zina which a man will indulge in. There will be no escape from it. The Zina of the eye is the (lustful) look, the Zina of the ears is the listening (to voluptuous songs or talk), the Zina of the tongue is (the licentious) speech, the Zina of the hand is the (lustful) grip, the Zina of the feet is the walking (to the place where he intends to commit Zina), the heart yearns and desires and the private parts approve all that or disapprove it.''
[Al-Bukhari and Muslim].

This is the wording in Muslim; Al-Bukhari wording is a bit short.

Commentary: Seeing, listening, walking, etc., are means of committing the sin of fornication and adultery, but they have been termed so metaphorically so that every Muslim saves himself from them. If he does not try to save himself from them, his desires will find support from the private parts of his body; that is, he will incline to immoral acts. If he keeps himself away from the means of fornication and adultery, his private parts will crush his desires, that is to say he will be saved from immoral acts. This is the reason it is said that one should avoid glances, smiles, salutation, conversation, promises and then meetings which occur by stages on one's way to fornication and adultery.

1623. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Prophet (PBUH) said, "Avoid sitting on roadsides.'' His Companions said: "O Messenger of Allah (PBUH), there is no other alternative but to sit there to talk.'' Thereupon the Messenger of Allah (PBUH) said, "If you have to sit at all, then fulfill the rights of the road.'' They asked: "What are their rights?'' Thereupon he said, "Lowering the gaze (so that you may not stare at unlawful things); refraining from doing some harm to others, responding to greeting (i.e., saying `Wa`alaikumus-salam' to one another) and commanding the good and forbidding the evil.''
[Al-Bukhari and Muslim].

Commentary: Since roads, streets, lanes and all thoroughfares are the common property of public, it is unfair to use them for private meetings and gatherings because such assemblies create inconvenience for people, especially women, who hesitate appearing before men. But if for some unavoidable reasons, one has to sit on them, then he should do such things there which should on the one side, save one from committing sins (like glazing at women who pass from there), and on the other, one should take care of the public welfare and make use of his presence for preaching religion.

1624. Abu Talhah Zaid bin Sahl (May Allah be pleased with him) said: We were sitting and talking on a platform in front of our house when the Messenger of Allah (PBUH) stopped by us and said, "Why do you sit on roads? Avoid sitting in them.'' We replied: "We sit there intending no harm. We only sit and discuss (religious) knowledge and talk.'' He said, "If you have to sit, you should fulfill the rights of the road: Lower your gaze, respond to greetings and talk in a good manner.''
[Muslim].

Commentary: This Hadith also tells us that we should avoid sitting over passages which are used by the public. If at all one has to use them, then one must observe the Islamic etiquette mentioned in the Hadith.

1625. Jarir bin `Abdullah (May Allah be pleased with him) said: I asked the Messenger of Allah (PBUH) about (the Islamic ruling on) accidental glance (i.e., at a woman one is not Islamically allowed to look at) and he ordered me to turn my eyes away.
[Muslim].

Commentary: If one suddenly sees a woman who is not a Mahram, he must at once turn away his glance from her. One should not gaze at her because then his intention is also included in his look which is a sin and constitutes the fornication of the eye. Some religious scholars have also forbidden looking at beardless handsome boys in the same way as is the case with women whom one is not allowed to see.

1626. Umm Salamah (May Allah be pleased with her) said: I was with the Messenger of Allah (PBUH) along with Maimunah (May Allah be pleased with him) when Ibn Umm Maktum (May Allah be pleased with him) (who was blind) came to visit him. (This incident took place after the order of Hijab). The Prophet (PBUH) told us to hide ourselves from him (i.e., observe Hijab). We said: "O Messenger of Allah (PBUH), he is blind and is unable to see us, nor does he know us.'' He replied; "Are you also blind and unable to see him?''
[Abu Dawud and At-Tirmidhi].

Commentary: One of the subnarrator of this Hadith is An-Nabhan, the freed slave of Umm Salamah (May Allah be pleased with him)u, who is Majhul (unknown). (This is the opinion of Sheikh Al-Albani). Thus this Hadith is not correct. Against this there is a reliable Hadith according to which the Prophet (PBUH) ordered Fatimah bint Qais (May Allah be pleased with her) to spend her `Iddah (probation observed on divorce or death of the husband) in the house of `Abdullah bin Umm Maktum and said that "Since he is blind, you will be in a position to your veil there.'' Thus it is clear that keeping the veil from the blind is not ordained in Islam.

1627. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "A man must not look at a man's private parts nor must a woman look at a woman's private parts; neither should two men lie naked under one cover, nor should two women lie naked under the same cover.''
[Muslim].

Commentary: This Hadith tells us how Islam has closed all doors of immodesty and obscenity. When Islam does not allow a man to sleep without any clothes on with another man, and also does not permit a woman to sleep without any clothes on with another woman, how can it possibly let the gents and ladies mix freely? Free mixing of men and women is a common evil in the West and is now being projected through television in Muslim countries. May Allah guide Muslims to the Straight Path!.


Prohibition of Meeting a non-Mahram Woman in Seclusion

Chapter 291
Prohibition of Meeting a non-Mahram Woman in Seclusion

Allah, the Exalted, says:

"And when you ask (his wives) for anything you want, ask them from behind a screen.'' (33:53)

1628. `Uqbah bin `Amir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Avoid (entering a place) in which are women (uncovered or simply to mix with them in seclusion).'' A man from the Ansar said, "Tell me about the brother of a woman's husband.'' He replied, "The brother of a woman's husband is death.''
[Al-Bukhari and Muslim].

Commentary: This Hadith tells us an extremely important point in respect of the veil about which the majority of Muslims are unaware or negligent. The point that it tells us that a woman must observe the veil from the real brothers, cousins etc., of her husband because their visits in her home are very frequent and there may occur several occasions when they come across each other alone. For this reason, there are greater chances of mischief with them. This explains why the husband's male relatives have been regarded as "death'', that is from the religious point of view they are fatal. In other words, if they commit the mischief, it will prove fatal because in an Islamic state this crime is punishable by Rajm (stoning to death). This can also be fatal in another way. If the husband begins to suspect that his wife has illicit relations with someone else, he might kill her or divorce her out of his sense of honour. Even in case of divorce, her life will become desolate. Another meaning of it can be that one should be as much afraid of meeting such women in seclusion with whom any kind of contact is not permissible as one is afraid of death.

When a woman is required to observe the veil from the real brothers of her husband, why would it not be essential to observe the veil from the husband's friends. Slackness in this matter is also very common nowadays. Although the dangerous consequences of this fashion come to our notice everyday through newspapers, people do not learn any lesson from them, and the fashion of non-observance of the veil is spreading fast like an epidemic. May Allah save us from this evil!

1629. Ibn Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "No one of you should meet a woman in privacy unless she is accompanied by a Mahram (i.e., a relative within the prohibited degrees).''
[Al-Bukhari and Muslim].

Commentary: This Hadith strictly prohibits Muslims from meeting a non-Mahram woman in seclusion without her Mahram, in order to avoid the temptation to commit the sin of adultery and fornication.

1630. Buraidah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The sanctity of the wives of Mujahidun (i.e., those who strive hard and fight in the way of Allah) for those who remain at home (i.e., those who do not go to the battlefield to fight Jihad) is like the sanctity of their own mothers. Anyone who remains behind to look after the family of a Mujahid and betrays his trust, will be made to stand on the Day of Resurrection before the Mujahid who will take away from his meritorious deeds whatever he likes till he is satisfied.'' The Messenger of Allah (PBUH) turned toward us and said, "Now, what do you think (i.e., will he leave anything with him)?''
[Muslim].

Commentary: The protection and supervision of the families of those Mujahidun who go to Jihad, is an act of high merit, and if someone violates the trust reposed in him, he will be committing a grave sin indeed. Such breach of trust shakes the very structure of mutual cooperation which has a singular importance in Islam. This Hadith considers the act of those who violate the Mujahidun's trust by molesting their wives in any way, taking advantage of their absence, as a very grave sin, because Mujahidun defend the Faith and strive hard to raise the flag of Islam high. Those who commit such a grave sin will be deprived of their virtuous deeds on the Day of Judgement.


Prohibition for Men and Women apeing one another

Chapter 292
Prohibition for Men and Women apeing one another

1631. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) cursed those men who ape women. He also cursed the hermaphrodite of men.

Another narration is: The Messenger of Allah (PBUH) cursed men who copy women and cursed women who copy men.
[Al-Bukhari].

Commentary: Mukhannath (hermaphrodite) is a man who dresses himself like a woman and has an effeminate gait and carriage, while Mutarajjilah is a woman who dresses herself like a man and adopts a masculine style. What we learn from this Hadith is that men and women should stick to their natural qualities and characteristics and strictly avoid the imitation of the opposite sex in appearance as well as conduct. Those who violate their nature have been strongly cursed. Women who are influenced by western philosophies and thoughts and try to adopt all those professions which are special for men, fall in this category. Allah has not entrusted them with those responsibilities which are marked for men only. It is a pity that out of sheer imprudence and blind imitation of the West, Muslim women are now adopting the western lifestyle in all walks of life. Such blind imitation has led many astray and is bound to bring Allah's Wrath upon the transgressors.

1632. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) cursed a man who puts on the dress of women, and a woman who puts on the dress of men.
[Abu Dawud].

Commentary: We learn from this Hadith that men's wearing of such clothes, in design and colour, which are special for women such as silken clothes, etc., is forbidden in Islam. Similar is the case of women. They are also prohibited to dress themselves in clothes which are special to men, i.e., shirts, trousers, coat of masculine fashion, etc. This prohibition is very stern as such a manner of dress comes in the category of major sins and has been cursed by the Prophet (PBUH).

1633. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "There are two types of people who will be punished in Hell and whom I have not seen: men having whips like the tails of cows and they will be beating people with them, and, women who will be dressed but appear to be naked, inviting to evil; and they themselves will be inclined to it. Their heads will appear like the humps of the Bactrian camel inclined to one side. They will not enter Jannah and they will not smell its fragrance which is perceptible from such and such a distance.''
[Muslim].

Commentary: This Hadith has the following three important points:

1. It has a warning for those who oppress people. Flogging in Hadd and Qisas does not come in the category of oppression because oppression in the real sense is perpetrated when whipping is done as a means of tyranny and cruelty.

2. It has a stern warning for those women who go about without wearing the Islamic-type veil and take to adornment to display their charms, which is the habit of immoral women. Such women also adorn their hair in different styles and lure men with their coquetry and amorous playfulness. They are shameless and also make others likewise, shameless.

This Hadith is one of the signs of the Prophethood of Muhammad (PBUH), the last of the Prophets of Allah, because the evils which he had prophesied in this Hadith have been fulfilled. Muslim women have adopted all these evils and shameless fashions without any fear of punishment in the Hereafter. May Allah relieve us from these evils.


Prohibition of following the Manners of Satan and Disbelievers

Chapter 293
Prohibition of following the Manners of Satan and Disbelievers

1634. Jabir (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) as saying: "Do not eat with your left hand, because Satan eats and drinks with his left hand.''
[Muslim].

1635. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "No person should eat and drink with his left hand for Satan eats with his left hand and drinks with his left hand.''
[Muslim].

Commentary: It is a pity that in imitation of Europeans, many Muslims now eat and drink with their left hand and thus please Satan.

1636. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) as saying: "Jews and Christians do not dye their hair, so act differently from them.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that the Prophet (PBUH) has advised the Muslims to dye the hair of their head and beard with yellow or red colour. They have been forbidden from dying the hair with black colour, as will be explained in the coming Ahadith.

Some religious scholars have regarded this as something desirable. Therefore, it is not necessary to dye the hair of head and beard. But this is certainly better. Since any resemblance with the Jews and Christians is unlawful, not dying the hair will create a resemblance with them. Therefore, in such a situation the colouring will be necessary, otherwise it will be Mustahabb, that is to say desirable.


Forbidding to Dye Hair Black

Chapter 294
Forbidding to Dye Hair Black

1637. Jabir (May Allah be pleased with him) said: Abu Quhafah, father of Abu Bakr (May Allah be pleased with them) was presented to the Messenger of Allah (PBUH) on the day of the conquest of Makkah and his head and beard were snow white. The Messenger of Allah (PBUH) said, "Change it (i.e., dye it and avoid black colour).''
[Muslim].

Commentary: Abu Quhafah was the Kunyah (nick-name) of Abu Bakr's father. His real name was Usman bin `Amir. He had embraced Islam on the day Makkah was conquered by the Muslims. "Saghamah'' is a herb which grows in mountains and is completely white. Since Abu Quhafah's hair were gray, the Prophet (PBUH) ordered him to dye them but forbade him from turning them black. Thus, we learn that except for inevitable circumstances, dying the hair of head and beard in black is prohibited.


On Prohibition of Shaving a part of Head

Chapter 295
On Prohibition of Shaving a part of Head

1638. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) forbade shaving a part of the head.
[Al-Bukhari and Muslim].

1639. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) saw a boy, some portion of whose head was shaved and some of it was left out. He prohibited them from that and said, "Shave the whole of it or leave the whole of it.''
[Muslim].

Commentary: This order of Prophet (PBUH) was based on the reason that that hair-style was then in vogue among the Jews and Christian priests and ascetics. This style was also popular with the group which was given to mischief and disobedience. This is, however, permissible in exceptional circumstances. In any case, either one should shave the hair completely or keep them in such a style that there is no resemblance with women.

1640. `Abdullah bin Ja`far (May Allah be pleased with them) said: The Prophet (PBUH) gave respite for three days to the family of Ja`far (after his martydom). Then he came and said, "Don't weep for my brother after this day.'' He said, "Bring all of my nephews to me.'' We were accordingly brought as if we were chickens. Then he said, "Call for me a barber.'' He directed him to shave our heads which he did.
[Abu Dawud].

Commentary: Ja`far was the cousin of the Prophet (PBUH) and he was martyred in the battle of Mu'tah. Although martyrdom is an honour but even then the bereaved family does feel the shock of the loss. For this reason, the Prophet (PBUH) permitted them to give vent to their grief for three days. It should not, however, be taken to mean that he allowed them to lament and wail, because that is prohibited. What he actually allowed them was the natural weeping which does occur when people come for condolence and speak of the deceased. Such expression of grief is permissible after a period of three days also.

Therefore, what the Prophet (PBUH) had advised them was not in the nature of unlawful but natural. The children of the deceased called themselves "chickens'' as they were greatly enervated by the tragedy. This Hadith has been mentioned here to confirm the validity of shaving the hair of the head, especially of children, although keeping bobbed hair is more meritorious because the Prophet (PBUH) himself did so. Bobbed hair are cut short and allowed to hang loosely.

1641. `Ali (May Allah be pleased with him) said: The Messenger of Allah (PBUH) prohibited a woman from shaving her head.
[An-Nasa'i].

Commentary: This Hadith is also included in At-Tirmidhi but Sheikh Al-Albani has regarded it "Da`if'' (weak). Please see Ahadith Ad-Da`ifah. However, in order to avoid resemblance with men, this prohibition for women will stand. If it is required on medical ground then it will be permissible.


Prohibition of Wearing False Hair, Tattooing and Filling of Teeth

Chapter 296
Prohibition of Wearing False Hair, Tattooing and Filling of Teeth

Allah, the Exalted, says:

"They (all those who worship others than Allah) invoke nothing but female deities besides Him (Allah), and they invoke nothing but Shaitan (Satan), a persistent rebel! Allah cursed him. And he [Shaitan (Satan)] said: `I will take an appointed portion of your slaves. Verily, I will mislead them, and surely, I will arouse in them false desires; and certainly, I will order them to slit the ears of cattle, and indeed I will order them to change the nature created by Allah'...'' (4:117-119)

1642. Asma' (May Allah be pleased with her) said: A woman came to the Prophet (PBUH) and said: "O Messenger of Allah! I have a daughter who had an attack of small pox and her hair fell off. Now I want to celebrate her marriage. Can I get her a wig?'' Thereupon the Prophet (PBUH) said, "Allah has cursed the maker and wearer of a wig.''
[Al-Bukhari and Muslim].

Commentary: This Hadith mentions women of three kinds, namely:

1. One who patches or joins the hair.

2. One who desires to have such hair.

3. One whose hair are taken to mix with the hair of another woman.

All the three of them have been cursed. Such artificial hair are called wig. `Beauty Parlours' are very active in prompting the use of wigs and other shameful fashions. May Allah save us from such evils.

Almost the same Hadith has been related from `Aishah (May Allah be pleased with her).

1643. Humaid bin `Abdur-Rahman (May Allah be pleased wth him) said: I saw Mu`awiyah (May Allah be pleased with him) during the Hajj (pilgrimage) standing on the pulpit. He took from the guard a bunch of hair, and said: "O people of Al-Madinah! Where are your scholars? (Why do they do not prohibit you) I heard the Prophet (PBUH) prohibiting from using this (false hair) and saying, `The people of Bani Israel were ruined when their women wore such hair.'''
[Al-Bukhari and Muslim]

Commentary:
1. In his sermon Muawiyah was referring to the evils which have been mentioned in the previous Hadith. Thus, we learn that if men see any mischief spreading in the society, they must take notice of it and try to prevent the public from it. They should also call the attention of the `Ulama' to that mischief so that they too raise voice against it.

2. To keep silent over the spread of evils among people is akin to inviting destruction and the Wrath of Allah on society.

3. There is a stern warning for present-day Muslims also because women today have generally discarded their veil and taken to display their charm and beauty like prostitutes. These and numerous other evils rampant in Muslim society are far more vulgar and dangerous than the evil of using wigs and keeping shameful hair styles. To make matters worse, the Muslim masses are silent over this immoral parade of evils, and the `Ulama' also hesitate to criticize these evils openly in their speeches and sermons.

1644. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) cursed the maker and wearer of a wig and the tattooer and the one who is tattooed.

[Al-Bukhari and Muslim].

Commentary: Al-Washimah is a woman who practises Al-Washm Al-Washm was performed (in the past) by piercing needle in some part of the body for drawing blood and then filling the cavity caused by it with antimony, indigo, etc., to make the spot green or black. This is called tattooing. In the Arab society of the Prophet's time, this fashion was very popular among women for enhancing their charms and beauty in the same way as the fashion of patching someone's hair with his own. Al-Mustaushima is a woman who asks some women for tattooing and/or a woman who marks tattoos on the skin of another woman.

As this act amounts to changing the natural appearance of a person, both women, that is the one who subjects her body to tattooing and the one who makes this operation, are cursed. Such fashions are in vogue in this age also. Plucking the eyelashes and filling them with colours and other material of make up, or like Hindu women, making mark between the eyebrows with cinnabar etc., fall in the category of such fashions. Such means of make up which are practised nowadays by women and on which huge amounts of money are wasted are the things which have been cursed. Muslim women should, therefore, avoid such evils as they are ruinous for religion as well as worldly life.

Similar is the case of nail polish. In the opinion of some religious scholars, this act invalidates Wudu'. Women are now also in the habit of keeping long nails on which nail polish is applied to give an effect of beastly claws. All such vile fashions have been borrowed by oriental societies from the class of shameless women of the West, and Muslim women have also adopted them. We must strictly abstain from them because they tend to create resemblance to the non-Muslims, which is unlawful and is rated as a major sin.

1645. Ibn Mas`ud (May Allah be pleased with him) said: Allah has cursed those women who practise tattooing and those women who have themselves tattooed, and those women who get their hair removed from their eyebrows and faces (except the beard and the mustache), and those who make artificial spaces between their teeth for beauty, whereby they change Allah's creation. A woman started to argue with him, saying: "What is all this?'' He replied: "Why should I not curse those whom the Messenger of Allah (PBUH) cursed and who are cursed in Allah's Book? Allah, the Exalted, has said in His Book:

"And whatsoever the Messenger (Muhammad (PBUH)) gives you, take it; and whatsoever he forbids you, abstain (from it).'' (59:7)
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that any effort to bring about a change in one's natural appearance is unlawful. Al-Washm (tattooing), Al-Washr (slimming the teeth), At-Tafalluj (to create gaps between the teeth), An-Nams (the plucking of eyelashes) etc., come in the category of forbidden and unlawful fashions. It should be mentioned here that the use of henna is permissible because it does not bring about any such change which is forbidden. The use of henna is permissible subject to the condition that woman should not make its display before any man who is not a Mahram (Mahram is a person with whom it is basically not lawful to contract marriage).


Prohibition of Plucking Grey Hairs

Chapter 297
Prohibition of Plucking Grey Hairs

1646. Reported `Amr bin Shu`aib, on the authority of his father and grandfather that the Prophet (PBUH) said, "Do not pluck out grey hair, for they are the Muslim's light on the Day of Resurrection.''
[Abu Dawud, At-Tirmidhi and An-Nasa'i].

Commentary: Plucking of gray hair, usually a sign of old age, should be avoided because besides the benefit which one gets from them in the Afterlife, they are a means of respect in this world.

1647. `Aishah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) said, "He who does something contrary to our way (i.e., Islam) will have it rejected.''
[Muslim].

Commentary: "Contrary to our way'' means such acts which have neither been allowed or justified nor can be justified by any principle of Shari`ah. Thus, this Hadith makes it abundantly clear that all heresies and violations of Shari`ah will not be accepted by Allah. Every Muslim is required to be a faithful follower of Divine orders rather than a heretic and a rebel.


Prohibition of using the right hand for cleaning after toilet without a valid reason

Chapter 298
Prohibition of using the right hand for cleaning after toilet without a valid reason

1648. Abu Qatadah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Do not touch your private parts with your right hand while urinating, nor for washing or cleaning (your private parts); and do not breathe into the drinking vessel from which you drink.''
[Al-Bukhari and Muslim].

Commentary: Muslims are required to take food and do other such things with their right hand. They have been ordained to do all the other essential but not much liked acts with their left hand. This demarcation has been done to highlight the distinctive position of the right hand. It is regrettable indeed that some Muslims nowadays use the left hand for eating. It is a sign that their righteous nature is spoiled and that they have totally ignored the Divine injunctions. May Allah help us observe the Divine orders.


Undesirability of Wearing one Shoe or Sock

Chapter 299
Undesirability of Wearing one Shoe or Sock

1649. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "None of you should walk wearing one shoe; you should either wear them both or take them off both.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that it is undesirable to wear one shoe in one foot and leave the other foot uncovered because one does not look respectable in this condition, and cannot keep a balance in his gait. This is also bound to be exposed to ridicule.

1650. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "When the lace of one of the shoes of any one of you is cut off, he should not walk with the other until he has got the lace repaired.''
[Muslim].

Commentary: The shoe-laces used in Arabia at the time of the Prophet (PBUH) were different from the ones which are used in modern times. The shoes were then so designed that they could not be used without laces. It was like a strap which kept the shoe tied to the foot, and if it was broken one could not use the footwear at all. For this reason, it was ordained by the Prophet (PBUH) that one should first get the strap repaired and then use the pair of his shoes. If this was not done, one would be then wearing one shoe and leaving his other foot bare. There is no harm, however, if one has to do this under some compulsion.

1651. Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) forbade a person wearing (tying up) his shoe while standing.
[Abu Dawud with a good Isnad].

Commentary: We learn from this Hadith that it is undesirable to put on one's shoes (or socks, etc.) in the standing position. Some religious scholars are of the opinion that this is more of an advice than an order. By prescribing the manners of wearing one's shoes, it has been illustrated that the Islamic teachings cover all spheres of life.


Prohibition of Leaving the Fire Burning

Chapter 300
Prohibition of Leaving the Fire Burning

1652. Ibn `Umar (May Allah be pleased with them) said: The Prophet (PBUH) said, "Do not keep the fire burning in your homes when you go to bed.''
[Al-Bukhari and Muslim].

1653. Abu Musa Al-Ash`ari (May Allah be pleased with him) said: A house in Al-Madinah was burnt with its occupants inside it one night. When this was reported to the Messenger of Allah (PBUH) he said, "Fire is your enemy. So, put it out before going to bed.''
[Al-Bukhari and Muslim].

1654. Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Cover up the (kitchen) containers (i.e., pots, pans, etc.), tie up the mouth of the water-skin, lock up the doors and extinguish the lamps, because Satan can neither untie the water-skin nor open the door nor uncover the containers. If one can cover the cooking pot even by placing a piece of wood across it, and pronounce the Name of Allah on it, let him do it. A mouse can sometimes cause a house to burn along its dwellers.''
[Muslim]

Commentary:
1 The Ahadith mentioned above stress the fact that one must put out the fire before going to bed, no matter whether this fire is in the form of a lamp, a fireplace, or a heater. Experience shows that leaving the fire alive sometime proves very dangerous. Leaving the utensils, water-skins, pitchers etc., uncovered must also be avoided to prevent them from dirt and insects which can cause harm. Similarly, doors and windows should also be kept closed while one is sleeping in order to guard the house against thieves and robbers.

2. One must recite the Name of Allah, that is to say Bismillah, before using and keeping things.


Prohibition of putting oneself to Undue Hardship

Chapter 301
Prohibition of putting oneself to Undue Hardship

Allah, the Exalted, says:
"Say (O Muhammad (PBUH)): `No wage do I ask of you for this (the Qur'an), nor am I one of the Mutakallifun (those who pretend and fabricate things which do not exist).''' (38:86)

1655. `Umar (May Allah be pleased with him) said: We have been forbidden to go into excess.
[Al-Bukhari].

Commentary: Affectation and artificiality are also different forms of formality which some people exercise in their speech, dress and manners. To make unusual effort in hospitality and preparation of several dishes for meals also come in the category of formality which is greatly disliked. Unfortunately, present-day Muslims have made it a habit to spend lavishly on these extravagances. May Allah grant us guidance to adhere to the religious injunctions in all matters of life.

1656. Masruq (May Allah be pleased with him) said: We visited `Abdullah bin Mas`ud (May Allah be pleased with him) and he said to us: O people! He who has the knowledge of any matter may convey it to the others. And he who has no knowledge, thereof, should say: "Allahu a`lam (Allah knows better).'' It is a part and parcel of knowledge that a man who has no knowledge of a matter should say: "Allah knows better.'' Allah said to His Prophet (PBUH):
"Say (O Muhammad (PBUH)): `No wage do I ask of you for this (the Qur'an), nor am I one of the Mutakallifun (those who pretend and fabricate things which do not exist).''' (38:86)
[Al-Bukhari].

Commentary: If one does not know about something, he should not say anything about it by way of conjecture, speculation and guesswork because this is also pretension which is forbidden. When religious scholars are asked about anything which they do not know, they should confess their ignorance. Such a confession is also a mark of scholarship. In other words, they should abstain from giving verdict about any matter without making a thorough study and research on it.


Prohibition of Bewailing the Deceased

Chapter 302
Prohibition of Bewailing the Deceased

1657. `Umar bin Al-Khattab (May Allah be pleased with him) said: The Prophet (PBUH) said, "The deceased is tortured in his grave for bewailing over him.''
[Al-Bukhari and Muslim].

Commentary: "Bewailing'' is wailing over the dead. It is weeping loudly for the deceased describing his noble qualities or the problems created by his death. Wailing causes trouble to the deceased if he willed his heirs to do so, or in his own life he behaved in the same manner and his family members were following his style of mourning at his death. But if the deceased had forbidden his relatives from wailing over his death and they do it despite his warning against doing so, then the deceased will not suffer any torment on their wailing because his intention and training have no connection with it. The Qur'anic injunction in this matter is absolutely clear:

"No one laden with burdens can bear another's burden.'' (17:15).

1658. Ibn Mas`ud (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who (on befalling a calamity) slaps his cheeks, tears his clothes and follows the ways and traditions of the Days of Ignorance is none of us.''
[Al-Bukhari and Muslim].

Commentary: "He is none of us'' here signifies that he is not following the ways of Muslims. "The ways and traditions of the Days of Ignorance'' means here wailing, i.e., `Alas! my lion, my moon, my support, one whose death has rendered his children orphan etc., etc.' This is a grave sin and there is a stern warning that one who does it, is in danger of losing his Faith because by doing so one, in fact, expresses resentment against Allah's Command.

1659. Abu Burdah (May Allah be pleased with him) reported: (My father) Abu Musa got seriously ill and lost his consciousness. His head was in the lap of a woman of the family and she began to wail. When Abu Musa recovered his consciousness, he said: "I am innocent of those from whom Messenger of Allah (PBUH) is innocent. Verily, the Messenger of Allah (PBUH) declared himself free of (the responsibility) for a woman who wails, shaves her head and tears up her clothes.''
[Al-Bukhari and Muslim].

Commentary: This Hadith also tells us about the passion of the Companions to follow the saying and practice of the Prophet (PBUH).

1660. Al-Mughirah bin Shu`bah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "He who allows (others) to wail over his death, will be punished for it on the Day of Resurrection.''
[Al-Bukhari and Muslim].

Commentary: The torment mentioned in this Hadith will be inflicted on the Day of Judgement upon that person who willed his heirs to wail on his death or who had brought up his family in such a manner that they were apt to wail about the death of their close relatives.

1661. Umm `Atiyyah (May Allah be pleased with her) said: At the time of giving the pledge of allegiance, the Messenger of Allah (PBUH) took from us an oath that we would not wail.
[Al-Bukhari and Muslim].

Commentary: Wailing is a bad habit of Jahiliyyah which a Muslim must avoid.

1662. An-Nu`man bin Bashir (May Allah be pleased with them) said: When `Abdullah bin Rawahah (May Allah be pleased with him) became unconscious, his sister began to weep and shout: "Alas! For the mountain among men. Alas! for such and such (mentioning his virtuous qualities).'' When he recovered his consciousness, he said: "I was asked (disapprovingly, by the angels) about everything you said concerning me whether I am as you said.''
[Al-Bukhari].

Commentary: We learn from this Hadith that one can be taken to task for bewailing somebody's death, especially for such qualities which are attributed to him by the mourners. Angels would rebuke and question him about the validity of the praise. Since the deceased did not possess those qualities, the wailing becomes a cause of reproach and reproof of the mourner.

1663. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) visited Sa`d bin `Ubadah during his illness. He was accompanied by `Abdur-Rahman bin `Auf, Sa`d bin Abu Waqqas and `Abdullah bin Mas`ud (May Allah be pleased with them). When they entered his house, they found him unconscious. The Messenger of Allah asked, "Has he died?'' They replied: "No, O Messenger of Allah.'' Hearing this the Messenger of Allah (PBUH) began to weep. When his Companions saw this, they also began to weep too. He said, "Listen attentively: Allah does not punish for the shedding of tears or the grief of the heart, but takes to task or show mercy because of the utterances of this (and he pointed to his tongue).''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that grief and tears which occur involuntarily are not forbidden because they are quite natural, but if one starts crying and bewailing on such occasions, he will be sinful. The only permissible way of expressing one's grief in words is to say "Inna lillahi wa inna ilaihi raji`un'' which means "Truly! To Allah we belong and truly, to Him we shall return.'' (2:156).

To visit the sick is a meritorious act as well as a right of a Muslim upon another Muslim. Depending upon the occasion, one is also recommended to offer sincere advice and Islamic teachings.

1664. Abu Malik Al-Ash`ari (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "If the wailing woman does not repent before she dies, she will be made to stand on the Day of Resurrection wearing a garment of pitch and a garment of scabies (Allah knows the nature thereof).''
[Muslim].

Commentary: We learn from this Hadith that wailing is a major sin and if one does not make sincere repentance for it, Allah does not grant pardon for it, one will be made to suffer a torment of its own kind.

1665. Asid bin Abu Usaid reported: A woman who had taken a pledge of allegiance at the hand of the Messenger of Allah (PBUH) said: "Among the matters in respect of which we gave the Messenger of Allah (PBUH) the pledge not to disobey him in any Ma`ruf [i.e., all that Islam ordains (V:60:12)] was that we should not slap our faces, bewail, tear our clothes up and tear out our hair (in grief).''
[Abu Dawud].

Commentary: The modes of expressing grief mentioned in this Hadith were in vogue in the Arab society of the Period of Ignorance. Muslim women are strictly forbidden from them and they must abstain from them.

1666. Abu Musa (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "If anyone dies and the mourner gets up and says: `Alas! For the mountain among men. Alas! For the chief ...' and such like, Allah will put two angels in charge of him who will beat on the breast and ask him (disapproving): `Were you like that?' ''
[At-Tirmidhi].

1667. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Two things are signs of disbelief on the part of those who indulge in them: Slandering one's lineage and wailing over the dead.''
[Muslim].

Commentary: This Hadith has already been mentioned before [see the Hadith under Chapter 275]. Both the evils pointed out here are those sins which invite Allah's Wrath and will certainly take one out of the fold of Islam if one considers them lawful. Hence a person who practices them, revives the evils of the infidels. May Allah save us from such evils.


Prohibition of Consultation with Soothsayers

Chapter 303
Prohibition of Consultation with Soothsayers

1668. `Aishah (May Allah be pleased with her) said: Some people asked the Messenger of Allah (PBUH) about soothsayers. He (PBUH) said, "They are of no account.'' Upon this they said to him, "O Messenger of Allah! But they sometimes make true predictions.'' Thereupon the Messenger of Allah (PBUH) said, "That is a word pertaining to truth which a jinn snatches (from the angels) and whispers into the ears of his friend (the soothsayers) who will then mix more than a hundred lies with it.''
[Al-Bukhari and Muslim].

The narration in Al-Bukhari is: "The angels descend in the clouds and mention matters which has been decreed in heaven; Satan steals a hearing (listens to it stealthily) and communicates it to the soothsayers who tell along with it a hundred lies.''

Commentary: Kahin (soothsayer), Munajjim (astrologer) and Arraf (foreteller) have similar characteristics but with a slight difference. All of them make predictions about the future. Kahin would overhear some jinn and disclose the secret to people which would sometimes prove true, because the jinn's source of information was Satan who sometimes stole away some information from the angels. But after the annunciation of the Prophet (PBUH) it was made impossible for jinns and satans to overhear anything in the skies. Moreover, Kahin and others of his ilk would make predictions on the basis of certain signs and circumstantial evidence which could go wrong or right. This is so even to this day. Astrological prediction is also a form of foretelling but this is often wrong. Al-`Irafah, or what is known to be as divination is also an indication of some future occurrence on the basis of certain causes and events. All the three occult arts supplement each other and also take the help of similar other things. In other words, these are all different forms of soothsaying. Geomancy also tries to tell about the invisible future. At-Tarq is the art of taking omen by striking birds with gravel on their wings or by throwing barley, etc., before them. In the latter formula, if a bird flies towards the right side, it would be a good omen; and if it goes towards the left it will be a bad one. All such things are unlawful and have been strictly forbidden by Islam. If anything predicted by these means comes by chance true, it does not furnish any justification for their validity.

1669. Narrated Safiyyah, daughter of Abu `Ubaid, on the authority of some of the wives of the Prophet (PBUH) who said, "He who goes to one who claims to tell about matters of the Unseen and believes in him, his Salat (prayers) will not be accepted for forty days.''
[Muslim].

Commentary: We learn from this Hadith that visiting soothsayers and astrologers for the purpose of knowing from them what lies hidden in future is such a great offense that he who does it, loses all merits of his forty days Salat. Some people try to detect the culprits involved in a theft case through the so-called fortunetellers or seek their advice in matters relating to business, marriage etc. All such things are unlawful because Allah Alone knows the invisible world.

1670. Qabisah bin Al-Mukhariq (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "The practice of `Iyafah, the interpretation of omens from the flight of birds, the practice of divination by drawing lines on the ground and taking evil omens are all practices of Al-Jibt (the idol, the diviner, or sorcerer).''
[Abu Dawud].

Commentary: Iyafah is an occult practice in which the practitioner rapidly draws lines on the soft ground in the presence of his client in such a manner that the lines cannot be counted then he effaces the lines in pairs. If at the end of the exercise two lines are left on the ground, it is taken as a good omen; if it is a single line, it is a bad omen. Some people have also described certain other forms of this occult formula. In any case, it was one of the formulas practised by the soothsayers of the Period of Ignorance. This practice, like others of this kind, was prohibited and Muslims were made to understand that such things could neither benefit nor harm anyone, and were mere tricks and frauds; and any reliance on them was absolute superstition and heresy. How sad it is that a large number of Muslims of the present age have faith in such occult practices and believe in superstitions. May Allah grant us guidance and save us from such evils. Al-Jibt covers a wide meanings. It means anything worshipped other than the true God (Allah), i.e., all false deities, be they an idol, Satan, graves, stars, angels, saints, Jesus the son of Mary, etc.

1671. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "He who acquires a branch of the knowledge of astrology, learns a branch of magic (of which he acquires more as long as) he continues to do so.''
[Abu Dawud].

Commentary: In this Hadith, astrology has been regarded a part of magic. In Islam the learning of magic has been held equivalent to infidelity. Thus, it is evident that in Islam, astrology and soothsaying are highly dangerous, and learning them is a great sin. Astrology here stands for that pseudo-science on the basis of which future events are predicted with reference to the movements of stars. There is another science called astronomy by means of which timings of sunrise and sunset are calculated. This branch of science, however, is a genuine science because it is based on experiment and observation.

1672. Mu`awiyah bin Al-Hakam (May Allah be pleased with him) reported: I said: "O Messenger of Allah, I have recently emerged from ignorance and Allah has favoured me with Islam. There are still some men among us who visit the soothsayers to consult them (on matters relating to the future).'' He (PBUH) replied, "Do not visit them.'' I said: "There are some men who are guided by omens.'' He replied, "These are the ideas which come up in their minds but you should not be influenced by them (i.e., these things) should not prevent them from pursuing their works.'' I said: "There are some men who practise divination by drawing lines on the ground.'' The Messenger of Allah (PBUH) replied, "There was a Prophet who drew lines, the line which agrees with the line drawn by that Prophet would be correct.''
[Muslim].

Commentary:
1. This Hadith has already appeared earlier [Hadith No 701]. "These are the ideas which come up in their minds'' means that sometimes something appears and one's mind at once takes it as a bad omen. This is something instinctive and natural and one is not accountable for it. But if one acts in accordance with that omen then what he does is wrong and is, therefore, forbidden. For this reason, the Prophet (PBUH) said, "(i.e., these things) should not prevent them from pursuing their works.''

2. The drawing of a line mentioned in this Hadith is different from the drawing of lines in `Iyafah mentioned earlier. Moreover, that was an act of a Prophet which was done by him in the light of Wahy sent to him by Allah and, therefore, was certainly correct. But now, nobody possesses that knowledge and cannot, therefore, be adopted. The statement of the Prophet (PBUH) that: "The line which agrees with the line drawn by that Prophet would be correct'' was by way of elucidation. It does not mean that that act can also be done by anyone today, for how can it be done without knowing its principles. How did that Prophet of Allah draw that line? What were its principles? Since that knowledge has passed away with that Prophet, it is now no longer valid, nor would it be fruitful.

Who was the Prophet who did it? Some people say it was Prophet Daniyal (Daniel), while other think it was Prophet Idris. Allah Alone knows the truth.

1673. Abu Mas`ud Al-Badri (May Allah be pleased with him) said: The Messenger of Allah (PBUH) prohibited the price of a dog, the earning of an prostitute, and the money given to a soothsayer.
[Al-Bukhari and Muslim].

Commentary:
1. "Prohibition of the price of dog'' signifies that the sale and purchase of dogs is forbidden. This a general order which applies to dog of every kind, whether it is for hunting or protection of farms (which is permissible) or is a tamed one. The reason being that dog is an absolutely unclean animal no matter what breed it is. Some `Ulama' are of the opinion that the sale and purchase of such dog which one intends to keep for lawful needs such as hunting and protecting farms is permissible. So far as reasoning is concerned, the views of the majority of `Ulama' are quite strong because we find absolute prohibition of dogs in this Hadith.

The earning of a vile woman has been called `Dower' in the Hadith because of its evident form, otherwise it is unlawful and nobody accepts its justification. Similar is the case of soothsayers, astrologers, fortunetellers and all those who fool people by telling them about future and thus swindle money from them. Their income is also unlawful.

2. It is also unlawful to make any payment to such swindlers because when it is not lawful for them to make money in this manner, how can we consider the money given to them lawful?


Forbiddance of Believing in Ill Omens

Chapter 304
Forbiddance of Believing in Ill Omens

1674. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Not the transmission of disease of one person to another and no evil omen, but I am pleased with good omens.'' He was asked: "What is good omen?'' He replied, "A good word.''
[Al-Bukhari and Muslim].

Commentary:
1. The phrase "Not the transmission of disease of one person to another'' either negates the idea that disease can travel from one person to another or it signifies that one should not attribute the illness of one person to the illness of another. The right approach is that one should think that a person falls ill with the Will of Allah. This does not mean that this Hadith denies the infectious character of certain diseases but it attempts to correct one's belief, namely that if Allah wills something, it will certainly occur. Thus, this Hadith proves that even in infectious diseases it is not the disease itself which is the real cause but the Preordainment and Will of Allah.

2. Similar is the case of bad omens. These have no significance at all. If any suspicion crosses one's mind by seeing something, he should neither attach any importance to it nor act what the suspicion demands. Good omen is permissible for the reason that it inclines one to associate good hopes with Allah, which is a highly commendable tendency. Thus, it also induces one to always utter something nice and to listen to what is nice so that in both cases it occasions good omens. One should always abstain from saying what is repulsive to the listeners and tends to be a bad omen.

1675. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "There is no infection and no evil omen; but if there is anything (that may be a source of trouble) then it could be a house, a horse, and a woman.''
[Al-Bukhari and Muslim].

Commentary: This Hadith means that nothing is ominous by itself. It is, however, true that because of their certain characteristics, certain things become ominous (troublesome) for certain persons. For example, if one has a small house or bad neighbours, he does not feel happy and peaceful in it. If one's wife is sterile or rude or abusive or immoral, etc., such a woman is ominous for him, that is, she is a source of trouble and tension rather than that of happiness for him. If one has a horse which is not used for Jihad, or is so ill-natured that it neither goes well ordinarily or with whipping, nor does it behave when left to its own will, then it has an ominousness in the sense that it does not serve the purpose of the master.

1676. Buraidah (May Allah be pleased with him) said: The Prophet never took ill omens.
[Abu Dawud].

Commentary: In pursuance of the teachings and practices of the Prophet (PBUH), one should abstain from taking a bad omen. If some suspicion arises in one's mind which is ominous then he must not do what it impels.

1677. `Urwah bin `Amir (May Allah be pleased with him) said: When talking of omens was mentioned in the presence of the Messenger of Allah (PBUH) he said, "The best type of omen is the good omen.'' He added, "A Muslim should not refrain from anything because of an omen.'' He (PBUH) told them, "When any of you sees anything which he dislikes, he should say: `Allahuma la ya'ti bil-hasanati illa Anta, wa la yadfa`us-sayyi'ati illa Anta, wa la hawla wa la quwwata illa Bika (O Allah ! You Alone bring good things; You Alone avert evil things, and there is no might or power but in You).'''
[Abu Dawud with Sahih Isnad].

Commentary:
1. Tiyarah means taking omen. This applies to good as well as bad omens. Muslims are required to take good omen only. For this reason, when a Muslim resolves to do something good then a bad omen should not impede his way because he believes that it is Allah Alone who brings about every thing. He should also pray to Allah for the removal of mischief.

2. When such things from which people usually take a bad omen create suspicions in one's mind, then it is Mustahabb (desirable) to recite the prayer mentioned in this Hadith. Thus, what we learn from this Hadith is that if a Muslim comes across something repulsive, he should pray to Allah for something auspicious. He should also pray to Allah for granting him the power and ability to abstain from evils.


Prohibition of Drawing Portraits

Chapter 305
Prohibition of Drawing Portraits

1678. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "Those who draw pictures will be punished on the Day of Resurrection; and it will be said to them: `Breathe soul into what you have created.'''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that drawing pictures of humans, animals and all those things that have a soul in them is a great sin and is liable to heavy punishment. However, one will not be taken to task for such pictures which are made compulsory by the Government, i.e., identity cards, passports, domicile certificates etc., because one cannot exercise his own will in such matters, but this exemption is subject to the condition that he does not exceed the compulsory requirement.

1679. `Aishah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) visited me after returning from a journey, and I had a shelf with a thin cloth curtain hanging over it and on which there were portraits. When he saw it, the colour of his face changed (because of anger) and he said, "O `Aishah! the most grievous torment from Allah on the Day of Resurrection will be for those who imitate (Allah) in the act of His creation.'' `Aishah said: We tore it into pieces and made a cushion or two cushions out of that.
[Al-Bukhari and Muslim].

Commentary: This Hadith has already appeared earlier [Hadith No. 650]. We learn from it that the act of drawing (pictures of humans, animals and things that have a soul in them) or photography and hanging of pictures (of such things) for display or decoration in homes is a great sin. It is, however, permissible that sheets bearing such pictures are cut into pieces for making such things which are not sacred and people go on trampling them, as was done by `Aishah (May Allah be pleased with her) that she made pillow covers of these pieces.

1680. Ibn `Abbas (May Allah be pleased with them) said: I heard the Messenger of Allah (PBUH) saying, "Every painter will go to Hell, and for every portrait he has made, there will be appointed one who will chastise him in the Hell.'' Ibn `Abbas said: If you have to do it, draw pictures of trees and other inanimate things.
[Al-Bukhari and Muslim].

Commentary: A painter will be punished for his paintings according to the number of his products. The greater the number of paintings he has produced, the more would be the punishment. Thus, there is a great warning for those who make films and photographs on marriages and functions because they make photographs of hundreds or thousands of persons at a time. If, in spite of knowing that this act is unlawful in Shari`ah, they do it on account of slackness on their part, they shall have to suffer heavy punishment for it in Hell. If they think that it is permissible in Islam, while it is forbidden, they would be regarded infidels and abide in Hell. It is absolutely wrong to think that this prohibition applies only to the painters or sculptors and that photographs taken by a camera is not a picture but a mere reflection and, therefore, one is exempted from their prohibition. Whether a picture is made by hand or camera or video, it is a picture and its maker is warned with Hell. May Allah save us from it. However, pictures of natural scenery which are lifeless are permissible.

1681. Ibn `Abbas (May Allah be pleased with them) said: I heard the Messenger of Allah (PBUH) saying, "Whosoever makes a picture, will be punished on the Day of Resurrection, and will be asked to infuse soul therein, which he will not be able to do.''
[Al-Bukhari and Muslim].

Commentary: One who makes a picture by any means, will be ordered to put life into it. This order will be in the nature of reproach and reproof because none can do it. Obviously one will not be able to do it and will thus be awarded stern punishment.

1682. Ibn Mas`ud (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "Those who will receive the most severe punishment from Allah on the Day of Resurrection will be painters (of living objects).''
[Al-Bukhari and Muslim].

1683. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The Almighty Allah said: `Who is more an oppressor than him who goes to create like My creation? Let him make an ant or a grain of corn or a grain of barley.'''
[Al-Bukhari and Muslim].

Commentary: This Hadith has a stern warning for photographers and video-makers who try to imitate the Creative Attribute of Allah.

1684. Abu Talhah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The angels do not enter a house in which there is a dog or a portrait.''
[Al-Bukhari and Muslim].

Commentary: Angels here means angels of mercy whose visit is a blessing for homes, because the angels who supervise us and record our deeds are with us all the time.

1685. Ibn `Umar (May Allah be pleased with them) said: Jibril (Gabriel) promised to visit the Messenger of Allah (PBUH) but delayed and this grieved him very much. When he came out of his house, Jibril met him. The Messenger of Allah (PBUH) asked him about the reason of delay, and he replied: "We do not enter a house in which there is a dog or a portrait.''

[Al-Bukhari].

1686. `Aishah (May Allah be pleased with her) said: Jibril (Gabriel) (PBUH) made a promise with the Messenger of Allah (PBUH) to come at a definite hour; that hour came but he did not visit him. There was a staff in the hand of the Messenger of Allah (PBUH). He threw it from his hand and said, "Never does Allah back out of His Promise, nor do His messengers.'' Then he noticed a puppy under his bed and said, "O `Aishah, when did this dog enter?'' She said: "By Allah, I don't know.'' He then commanded that it should be turned out. No sooner than had they expelled it, Jibril came and the Messenger of Allah (PBUH) said to him, "You promised to visit me. I waited for you but you did not come.'' Whereupon he said: "The dog kept me from coming. We do not enter a house in which there is a dog or a picture.''
[Muslim].

Commentary: This Hadith has an elaboration of the preceding Hadith and tells us that a puppy had entered the house of the Prophet (PBUH) and he did not know about it. The presence of the puppy in the house obstructed the visit of Jibril (Gabriel). It is a pity that now many Muslims keep dogs in their houses in imitation of the Europeans and also display in their showcases photographs of animals, or their own family members, or pictures of their deceased parents, or their mentor, or some saint for the sake of blessing, little knowing that such pictures deprive one of the Blessings of Allah rather than bestowing it upon them.

1687. Abul-Haiyaj Haiyan bin Husain said: `Ali bin Abu Talib (May Allah be pleased with him) said to me: "Shall I not send you to do a task that the Messenger of Allah (PBUH) had assigned to me? Spare no portrait unwiped out, and leave not a high grave unlevelled.''
[Muslim].

Commentary: Drawing pictures and raising graves over the height of a span are forbidden and their removal is the responsibility of Muslim rulers. An Islamic state neither allows pictures, nor does it permit permanent structures over graves, nor graves over a span's height.

"Leave not a high grave unlevelled'' does not mean levelling them to the ground. What it really means is that these should be reduced to the permissible height.


Prohibition of Keeping a Dog except as a Watchdog or Hunting Dog

Chapter 306
Prohibition of Keeping a Dog except as a Watchdog or Hunting Dog

1688. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "He who keeps a dog other than one for guarding the fields or herds or hunting, will lose two Qirat every day out of his rewards.''
[Al-Bukhari and Muslim].

1689. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who keeps a dog, will lose out of his good deeds equal to one Qirat every day, except one who keeps it for guarding the fields or the herd.''
[Al-Bukhari and Muslim].

In a narration of Muslim, the Messenger of Allah (PBUH) is reported to have said: "He who keeps a dog for any reason other than to guard his property (lands) or his flock of sheep, his good deeds equal to two Qirat will be deducted every day.''

Commentary:
1. We learn from these Ahadith that it is permissible to keep dogs for hunting and security of herds and farms but not for any other purpose. If anyone does so, he will be losing a Qirat or two from his rewards everyday. Why did the Prophet (PBUH) use the words Qirat or two Qirat? Some scholars say that at first the Prophet (PBUH) said one and subsequently increased the number. Some scholars hold that the difference of one and two relates to urban and rural areas. The inhabitants of cities would be losing two Qirat from their rewards daily, while in case of villagers this loss will be one Qirat only, because they stand in greater need of dogs.

2. Why does the reduction in reward take place? In response to this question, it has been stated that it is very difficult to escape from the filth of dogs and sometimes it adversely effects even Salat and reduces their reward. Some scholars say that since dogs are apt to bark on guests and beggars and scare them, the tension caused by this affects the reward of the host. Allah Alone knows the truth of the matter.

What is Qirat? It is differently interpreted. There is a Qirat which is mentioned in the funeral prayer. This is equal to the Uhud mountain. Does it signify the same here? Some scholars answer this question in the affirmative while others hold that in the funeral prayer it occurs with reference to Allah's Mercy and Grace but here it relates to His Wrath. As the former is far greater than the latter, the word cannot have the same significance in both contexts.


Undesirability of Hanging Bells round the Necks of Animals

Chapter 307
Undesirability of Hanging Bells round the Necks of Animals

1690. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Angels do not accompany the travellers who have with them a dog or a bell.''
[Muslim].

Commentary: "Dog'' here stands for that dog which is prohibited to keep. Dogs kept for the purpose of hunting and security do not fall in this category. Angels signify angels of mercy; otherwise we are attended all the time by the angels who record our deeds for us. Bell in this context refers to the bell which is placed in the neck of animals and rings when they move.

1691. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "The bell is one of the musical instruments of Satan.''
[Muslim].

Commentary: Mazamir is the plural of Mizmar meaning musical instrument. It covers the lute, the plectrum and other musical instruments. All these are used by Satan to lead the people astray. Nowadays these articles have become alarmingly common. The matter does not end here. The public mentality is so distorted that they take music as food of the soul. (We seek the Refuge of Allah from it). It can be true of those whose souls are overpowered by Satan because one who lives in filth is so used to it that one cannot live without it. May Allah protect us from such satanic occupations.


Undesirability of Riding a Camel which eats Animals' waste

Chapter 308
Undesirability of Riding a Camel which eats Animals' waste

1692. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) prohibited riding a camel which eats dung, or animal or human waste.
[Abu Dawud].

Commentary: Al-Jallalah means an animal which usually eats filthy things including human excrement. This filth becomes a part of his body and it stinks. When such animals are disgusting for riding, they would be obviously unlawful for food. It is, however, necessary that the Al-Jallalah should have the characteristic mentioned in the Hadith because ordinarily almost every animal does eat a little amount of filth but with the difference that it is not common food, nor does it become a part of its body. In any case, it should be borne in mind that Islam has stressed purity and cleanliness and warned against filth.


Prohibition of Spitting in the Mosque

Chapter 309
Prohibition of Spitting in the Mosque

1693. Anas bin Malik (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Spitting in the mosque is a sin, and its expiation is that the spittle should be buried in earth.''
[Al-Bukhari and Muslim].

Commentary: To atone for spitting in the mosque, one should bury the spittle in earth, but this applies when the floor of the mosque is covered with earth; as this is not the case today, one should wipe the spittle off or wash it off with clean water.

1694. `Aishah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) saw spittle or snot or sputum, sticking to the wall towards Qiblah and scratched it off.
[Al-Bukhari and Muslim].

Commentary: The narrator of this Hadith has expressed doubt about the exact nature of the filth, whether it was spittle, or phlegm or something else. Whatever it was, apparently it was dry. The Prophet (PBUH) scraped or rubbed it out and thus gave an important lesson of cleanliness to his Ummah.

1695. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is not proper to use the mosque for urinating or easing oneself. They are merely built for the remembrance of Allah and the recitation of the Qur'an'', or as he stated.
[Muslim].

Commentary:
1. The Prophet (PBUH) said this on the urination of a bedouin in the mosque. He made him understand very politely and prudently that mosques are meant for worship, remembrance of Allah, recitation of the Qur'an and similar other acts of piety, and one should not do any thing that violates their sanctity.

2. The narrator has added the words "or as he stated''. It was a practice with the narrators of Ahadith to say these words by way of care to cover the risk of any change in the Hadith wording.


Undesirability of Quarrelling or Raising voices in the Mosque

Chapter 310
Undesirability of Quarrelling or Raising voices in the Mosque

1696. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "If anyone hears a man inquiring in the mosque about something he has lost, he should say: `La raddaha Allahu `alaika (May Allah not restore it to you),' for mosques are not built for this purpose.''
[Muslim]

1697. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah said, "When you see someone buying or selling in the mosque, say to him: `La arbaha-Allahu tijarataka (May Allah not make your bargain profitable)!' When you see someone announcing something lost in it, say: `May Allah not restore it to you!'''
[At-Tirmidhi].

1698. Buraidah (May Allah be pleased with him) said: A man announced (the loss of his camel) in the mosque, uttering these words: "Has any one seen my red camel?'' Upon this the Messenger of Allah (PBUH) said, "May it not be restored to you! The mosques are built for what they are meant to be (i.e., prayer, remembrance of Allah, acquiring knowledge, etc.).''
[Muslim].

1699. `Amr bin Shu`aib on the authority of his grandfather (May Allah be pleased with him) said: The Messenger of Allah (PBUH) prohibited (us) from buying and selling in the mosque; (he also prohibited us from) making announcement in it about something lost and from reciting poems in it.
[Abu Dawud and At-Tirmidhi].

Commentary:
1. Some `Ulama' have stated that the prohibition in the above stated Ahadith is in the nature of aversion and disgust if the acts mentioned in the Hadith do not lead to disturbing those engaged in worship (be it Salat, recitation of the Qur'an or similar good acts) in the mosque. If they do disturb the worshippers, then the prohibition would be absolute.

2. Recitation of such poems is prohibited which relate to love stories and romantic tales. There is no harm in reciting such poems in mosques which relate to the Oneness of Allah, obedience of His Prophet (PBUH), and other subjects meant for the reformation of Muslims.

3. It is permissible to talk about the problems of Muslims and any other issues which are concerned with the welfare of community at large.

4. It is prohibited to hold Qawwali (singing spiritual topics) in mosques because it is accompanied by music and musical instruments. The verses recited in Qawwali are largely based on exaggeration and go beyond the limits prescribed by the Shari`ah. Such things unnecessarily pacify the sentiments of the public and incline them to inaction. It is a pity that many people regard Qawwali permissible, which is sheer ignorance.

1700. As-Sa`ib bin Yazid (May Allah be pleased with him) said: While I was in the mosque, someone threw a pebble at me, and when I looked up, I saw that it was `Umar bin Al-Khattab, who said: "Go and call me these two men.'' I brought them and `Umar (May Allah be pleased with him) asked them: "Where are you from?'' On their replying that they belonged to At-Taif, he said: "Had you been the inhabitants of Al-Madinah, I would have given you a beating for raising your voices in the mosque of the Messenger of Allah (PBUH).''
[Al-Bukhari].

Commentary: The action of `Umar (May Allah be pleased with him) mentioned in the Hadith tells us that to speak loudly in the mosque amounts to desecrating it, which is a punishable offense.

2. If one is able of it, he must stop people from acts which amount to denial of Divine injunctions and contravene the Shari`ah.


Undesirability of Entering the Mosque after Eating raw Onion or Garlic

Chapter 311
Undesirability of Entering the Mosque after Eating raw Onion or Garlic

1701. Ibn `Umar (May Allah be pleased with them) said: The Prophet (PBUH) said, "He who has eaten garlic should not come to our mosque.''
[Al-Bukhari and Muslim].

The narration in Muslim is: "He who has eaten garlic should not come to our mosques.''

1702. Anas (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who has eaten from this plant (i.e., garlic) should not approach us and should not offer Salat (prayer) along with us.''
[Al-Bukhari and Muslim].

1703. Jabir (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who has eaten garlic or onion should keep away from us or our mosques.''
[Al-Bukhari and Muslim].

The narration in Muslim is: "He who has eaten onion or garlic or leek should not approach our mosque, because the angels are also offended by the strong smells) that offend the children of Adam.''
[Muslim].

Commentary: It is not permissible to eat raw onions, garlic or anything with a strong offending smell before going to the mosque. It is permissible, however, to eat them after their strong odour has vanished as a result of cooking or boiling. Since their odour vanishes after cooking, their use is permissible in cooked form.

1704. It has been narrated that `Umar (May Allah be pleased with him) said in the sermon of Friday prayer: "O you people! You eat garlic and onion. I think the odour of these to be very offensive. I saw that if the Messenger of Allah (PBUH) happened to find a man with such offensive odour in the mosque, he would order him to be taken out of the mosque and sent to Al-Baqi`. He who wants to eat any of these, should cook them till their odour dies out.
[Muslim].

Commentary: Khabith generally means impure, base and wicked, but it is also used in the sense of Haram (unlawful), that is for eatables which are forbidden or which have an unpleasant and disgusting smell. Garlic, onion etc., are Khabith in their raw form and Muslims have been prohibited from going to the mosque after eating them. One can, however, eat them in their cooked form. One can also use them when the time to go to mosque for Salat is not very near. We also learn from this Hadith that one should not eat any such odorous thing when he has to go to the mosque or Madrasah or any congregation for some religious purpose because it will be repulsive for the people present there. Their eating is, however, permissible even in their raw form, if one is not going to the mosque for Salat.

2. We also learn from this Hadith that mosques should be kept free from every kind of filth and odorous things. There is no justification for the construction of toilets in the premises of mosque. Mosques which have toilets within their compounds must be divested of the toilets to purge them of the unclean environments.


Undesirability of Sitting with Erected Legs during Friday Sermon

Chapter 312
Undesirability of Sitting with Erected Legs during Friday Sermon

1705. Mu`adh bin Anas Al-Juhani (May Allah be pleased with him) said: The Prophet (PBUH) forbade (us) from sitting with our legs drawn up to our belly (Ihtiba') during the Friday Khutbah (religious talk before the prayer).
[Abu Dawud and At-Tirmidhi].

Commentary: Habut is the root word of Ihtiba' which means to sit in such a position that the two knees are joined by means of the hand or some cloth with one's belly. To sit in this style during the Friday sermon is not desirable because it causes drowsiness which in turn interrupts the sermon. It must be remembered that listening to the Friday sermon is obligatory and drowsiness during the course of the sermon is likely to disturb it and can also spoil Wudu' which is a prerequisite for the validation of Salat.


Prohibition of having a Hair cut or paring one's nail during the first ten days of Dhul-Hijjah for one who intends to Sacrifice an Animal

Chapter 313
Prohibition of having a Hair cut or paring one's nail during the first ten days of Dhul-Hijjah for one who intends to Sacrifice an Animal

1706. Umm Salamah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) said, "When anyone of you intends to sacrifice the animal and enter in the month of Dhul-Hijjah, he should not get his hair cut or nails pared till he has offered his sacrifice.''
[Muslim].

Commentary: According to this Hadith, one who intends to sacrifice animal on `Eid Al-Adha, should abstain from paring nails, having a hair cut, and shaving the armpits and the private parts so that his sacrifice is in accordance with the Sunnah. One should have a hair cut on the tenth of Dhul-Hijjah after having offered the sacrifice. Some Ahadith tell us that if a person who does not sacrifice an animal on `Eid Al-Adha but pares his nails and has his hair cut on the tenth Dhul-Hijjah will be given by Allah the reward of sacrifice.


Prohibition of Swearing in the name of anything besides Allah

Chapter 314
Prohibition of Swearing in the name of anything besides Allah

1707. Ibn `Umar (May Allah be pleased with them) said: The Prophet (PBUH) said, "Allah has prohibited you from taking an oath by your fathers. He who must take an oath, may do so by swearing in the Name of Allah or he should remain silent.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that taking the oath of one's ancestors is prohibited. In the forthcoming Ahadith one is also forbidden from taking the oath of false gods and devils.

1708. `Abdur-Rahman bin Samurah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Swear neither by the name of Taghut (i.e., false deities, false leaders, etc.) nor by your fathers.''
[Muslim].

1709. Buraidah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who swears by Amanah (trust) is not one of us.''
[Abu Dawud with authentic Isnad].

Commentary: The oath of Amanah means to say "By Amanah'' as one says "By Allah''. This is prohibited for the reason that one can take the oath of Allah or any of His Attributes. Amanah is one of the Commandments of Allah and an obligation prescribed by Him, like Salat, Saum, Hajj etc. In this way, the Commandments of Allah assume the resemblance of His Glorious Names and Attributes, which is not correct.

1710. Buraidah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "If anyone swears that in such and such case he will be free from Islam and afterwards he turns out to be a liar, he will be as he has sworn; but if he is speaking the truth, he will not revert safely to Islam.''
[Abu Dawud].

Commentary: What this Hadith tells us is that if someone says "If I do such and such thing, I will be a Kafir'', now, if he really meant that if he did that he will adopt Kufr, then he will at once become a Kafir. But if he meant that he will strictly adhere to Islam and never take the way of Kufr, he will not become a Kafir but the style in which he said it was certainly wrong. Therefore, he must make repentance and beg forgiveness from Allah for it. It will be better if he recites again Kalimahtush-Shahadah to renew his Faith.

1711. Ibn `Umar (May Allah be pleased with them) said: I heard a man saying: "No, by the Ka`bah.'' I admonished him: "Do not swear by any thing besides Allah, for I heard the Messenger of Allah (PBUH) saying, `He who swears by anyone or anything other than Allah, has indeed committed an act of Kufr or Shirk'.''
[At-Tirmidhi].

[Some `Ulama' are of the opinion that the words of the Prophet (PBUH) that "He who swears by anyone or anything other than Allah has indeed committed an act of Kufr or Shirk,'' are in the nature of extreme admonition. And in fact, it is not Shirk. The same applies to the saying of the Prophet (PBUH), who said, "showing off is Shirk.'']

Commentary: Imam An-Nawawi has regarded the saying "showing off is Shirk'' as Hadith is not narrated in these words. It is, however, true that what the Prophet (PBUH) has stated about the evil and sinfulness of showing off implies that it is also a (minor) Shirk. For instance he stated that "He who kept fast or offered Salat for mere show, has indeed committed Shirk.'' In any case, to take oath of anyone other than Allah is strictly forbidden. It is, therefore, necessary to abstain from swearing by other than Allah. Unfortunately, such oaths are very common and people do not realize that they are prohibited and unlawful.


Illegality of Swearing Falsely

Chapter 315
Illegality of Swearing Falsely

1712. Ibn Mas`ud (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who takes oath to acquire the property of a Muslim unjustly will meet Allah and He will be angry with him'' then he recited:
"Verily, those who purchase a small gain at the cost of Allah's Covenant and their oaths, they shall have no portion in the Hereafter. Neither will Allah speak to them nor look at them on the Day of Resurrection nor will He purify them, and they shall have a painful torment.'' (3:77)
[Al-Bukhari and Muslim].

1713. Abu Umamah Iyas bin Tha`labah Al-Harithi (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who misappropriates the right of a Muslim by taking a false oath, Allah will condemn him to the fire of Hell and will forbid Jannah for him.'' A person asked: "O Messenger of Allah, even if it is something insignificant?'' He replied, "Yes, even if it is the twig of the Arak tree.''
[Muslim].

1714. `Abdullah bin `Amr bin Al-As (May Allah be pleased with them) said: The Prophet (PBUH) said, "Of the major sins are: Associating anything in worship with Allah, disobedience to the parents, killing without justification and taking a false oath (intentionally).''
[Al-Bukhari].

Another narration is: A bedouin came to the Prophet (PBUH) and asked him: "O Messenger of Allah, what are the cardinal sins?'' He (PBUH) replied, "Associating anything with Allah in worship.'' The man asked: "(What is) next?'' The Messenger of Allah (PBUH) replied, "Al-Yamin Al-Ghamus.'' He asked: "What do you mean by Al-Yamin Al-Ghamus?'' The Messenger of Allah (PBUH) replied, "Swearing falsely to usurp the property of a Muslim.''

Commentary: "Ghamus'' means to drown. A false oath drowns one in sin. For this reason, it is called Al-Yamin Al-Ghumus, the oath that drowns one in sin. Is it open to expiation? Some religious scholars believe that it is, while others think it is not, because in their opinion it is a lie which is employed to deprive somebody of his wealth and property. For this reason, they say that in such case one should beg pardon from Allah and arrange to restore the wealth and property to the victim. This seems to be the more appropriate course for it because mere repentance cannot remit this sin. It is necessary to rectify the wrong and compensate the victim.


Desirability of Expiating the Oath taken by a Person who afterwards Breaks it for a better Alternative

Chapter 316
Desirability of Expiating the Oath taken by a Person who afterwards Breaks it for a better Alternative

1715. `Abdur-Rahman bin Samurah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said to me, "When you take an oath and consider something else to be better than it, make expiation for your oath and choose the better alternative.''
[Al-Bukhari and Muslim].

Commentary: What we learn from this Hadith is that if a person has taken an oath to do something but subsequently realizes that it is better to forego the oath, he should expiate for the oath rather than sticking to it because it is easier to expiate for the oath than to suffer a loss, be it in religion or otherwise.

1716. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "When you swear an oath and consider something else to be better than it, make expiation for your oath and do the thing that is better.''
[Muslim].

1717. Abu Musa (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Verily, I swear by Allah, if Allah wills, I shall not swear to do something but that if I consider something else to be better than it, then I shall make expiation for my oath and adopt the thing that is better.''
[Al-Bukhari and Muslim].

1718. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Persistence in respect of his oath about his family is more sinful with Allah than the payment of its expiation prescribed by Allah.''
[Al-Bukhari and Muslim].

Commentary:
1. "Ahl'' means wife, children and other members of one's family. For example, if a man takes an oath regarding some matter relating to his wife, although the act he has forbidden himself is better for him, it will be sinful to stick to the oath. Far less than this sin would be the breaking of the oath to normalize his relation with his wife and children. The essence of all these Ahadith is that if one comes to realize that, after taking an oath, his oath was wrong, then he must break the oath and do what he had vowed not to do. There are different forms of breaking the oaths. For instance, if one has taken an oath that he will drink alcohol, it will be obligatory for him to break his oath. Or if one takes an oath to not to do a thing which is desirable, or taken an oath to do something which is not desirable, then it will be desirable to break the oath. Similarly, if one takes an oath to not to do something permissible then the act of breaking the oath will also come in the category of permissible.

2. The expiation of an oath is necessary. This can be done by means of feeding ten poor persons, or by providing clothes to a similar number of persons, or by setting a slave free. If one does not have the capacity to do any of the three acts, then he should observe fast for three days..

3. If, in spite of realizing that the act one has vowed not to do is better, one still sticks to his oath, he would be then more sinful.

4. The teachings and practices of the Prophet (PBUH) tell us that to adopt the better course is preferable to sticking to the oath.


Expiation of Oaths

Chapter 317
Expiation of Oaths

Allah, the Exalted, says:

"Allah will not punish you for what is unintentional in your oaths, but He will punish you for your deliberate oaths; for its expiation (a deliberate oath) feed ten Masakin (poor persons), on a scale of the average of that with which you feed your own families, or clothe them or manumit a slave. But whosoever cannot afford (that), then he should observe fast for three days. That is the expiation for the oaths when you have sworn. And protect your oaths (i.e., do not swear much).'' (5:89)

1719. `Aishah (May Allah be pleased with her) reported: The Ayah: "Allah will not punish you for what is unintentional in your oaths ...'' was revealed in respect of those persons who are in the habit of repeating: `No, by Allah'; and `Yes, by Allah.'
[Al-Bukhari].

Commentary:
1. From the previous as well as present chapter we learn that there are three kinds of oaths:

First, false oath (Al-Yamin Al-Ghamus).

Second, absurd (Laghw) oath, which is neither sinful nor is there any expiation for its violation.

Third, Al-Mu`aqqadah. It is an oath which one takes wholeheartedly for doing or not doing anything. It is liable for expiation if one violates it. Its expiation is mentioned in this Hadith.

2. What will be the quantity of the average food that is to be served to the ten person by way of expiation? We do not find any elaboration of this in any Hadith. Some `Ulama' have stated that it means meals of the day and night. Some scholars have taken support of a Hadith and suggested that it should be one Mudd (about half kilogram) per head because this is the quantity which the Prophet (PBUH) prescribed as expiation for sexual intercourse with one's wife during fasting. The expiation prescribed by him was 15 Sa` dates which were to be divided among sixty poor fellows. Since one Sa` consists of four Mudd, the quantity of food, without curry, for ten persons would be six kilograms. (Ibn Kathir). This means that it would be six kilograms of flour, or rice, or dates etc. Thus, even if ten poor persons are served with an average meal, it would be a substantial quantity. Allah Alone knows what is correct.


Abomination of Swearing in Transaction

Chapter 318
Abomination of Swearing in Transaction

1720. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "Swearing produces a ready sale for a commodity, but blots out the blessing.''
[Al-Bukhari and Muslim].

Commentary: What is meant here is that if a person takes an oath while offering a merchandise, he may succeed in selling a large quantity of it, but this is not a fair means of business because it increases the sale but robs the business of its blessings. Therefore, even if a person is perfectly right in his statement in respect of his merchandise, he should not take an oath to influence his customers.

1721. Abu Qatadah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "Beware of excessive swearing in sale, because it may promote trade but this practice will eliminate the blessing.''
[Muslim].

Commentary: This Hadith also mentions the same thing which has been stated in the preceding Hadith. It has food for thought that when oath robs the deal of its blessing, even if one's oath is perfectly true, how great a sin those commit who take false oaths to sell their goods! May Allah save us from committing this sin.


About Begging in the Name of Allah

Chapter 319
About Begging in the Name of Allah

1722. Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "No one should ask in the Face of Allah for anything except Jannah.''
[Abu Dawud].

Commentary: Sheikh Al-Albani has stated with regard to this Hadith the following points:

First, this Hadith is weak in authority.

Second, even if its authority is taken to be correct, then begging in the Name of Allah for worldly needs is prohibited; but how can the begging of good of the Hereafter, guidance and the path to Jannah becomes prohibited?

Nevertheless, begging in the Name of Allah for worldly gains is disapproved.

1723. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "Grant shelter to him who begs for it in the Name of Allah, give to him who begs in the Name of Allah, accept the invitation of him who invites you, and requite him who does a favour to you, but if you are unable to requite him, go on praying for him till you are sure that you have requited him adequately.''
[Abu Dawud and An-Nasa'i].

Commentary: The following points are clear from this Hadith:

First, supplicating for safety and asking in the Name of Allah is endorsed.

Second, if a person begs in the Name of Allah, he should not be turned down. He must be given something to honour the Name of Allah. However, if one is sure that the petitioner is a professional beggar and does not stand in need of what he is begging, then it is better to turn him down in order to discourage the evil of begging in the society.

Third, one should return kindness, with kindness but if one is unable to do so then one should wholeheartedly pray for the benefactor because this is also a form of returning a kindness.

Fourth, one must accept invitation to a feast provided it is free from all things forbidden by Islam.


Prohibition of Addressing somebody as 'The King of Kings'

Chapter 320
Prohibition of Addressing somebody as 'The King of Kings'

1724. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "The most disgraceful man near Allah is a man who calls himself (or likes others to call him) Malikul-Amlak (i.e., king of kings).''
[Al-Bukhari and Muslim].

Commentary: Allah appreciates humility and humbleness and abhors pride and haughtiness. To arrogate to oneself the title of `The king of kings' reflects pride and not humility and is, therefore, forbidden. Moreover, this is an Exclusive Attribute of Allah and it is unjust to associate it with any one else.


Prohibition of Conferring a Title of Honor upon a Sinner, a Hypocrite, and the Like

Chapter 321
Prohibition of Conferring a Title of Honor upon a Sinner, a Hypocrite, and the Like

1725. Buraidah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not address a hypocrite with the title of chief, (or similar titles of respect) for even if he deserves this title you will invite Allah's Wrath by using it for him.''
[Abu Dawud].

Commentary: A sinner does not deserve any respect. His respect amounts to inviting the Wrath of Allah. Hypocrites, innovators in religion, disbelievers, polytheists, atheists, heretics and those who disobey Allah and His Prophet (PBUH) fall in this category, and none of them deserve any respect. It is the Muslims, the pious and those who are faithful to Allah and His Prophet (PBUH) who are worthy of respect.


Undesirability of Reviling Fever

Chapter 322
Undesirability of Reviling Fever

1726. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) visited Umm Sa'ib (or Umm Musaiyyab) and asked her, "What ails you O Umm Sa'ib (or Umm Musaiyyab)? You are shivering.'' She replied: "It is a fever, may Allah not bless it!'' He said to her, "Do not revile fever, for it cleanses out the sins of the sons of Adam in the same way that a furnace removes the dirt of iron.''
[Muslim].

Commentary: We learn from this Hadith that as diseases are means of expiation of sins, one should not condemn them. More so for the person that they are a part of fate - the Will of Allah. However, there is no harm in taking necessary measures to overcome them because Shari'ah makes it obligatory to do so..


Prohibition of Reviling the Wind

Chapter 323
Prohibition of Reviling the Wind

1727. Abul-Mundhir Ubaiy bin Ka`b (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not revile the wind. When you experience something abominable (about it), supplicate: `Allahumma inna nas'aluka min khairi hadhihir-rihi, wa khairi ma fiha, wa khairi ma umirat bihi. Wa na`udhu bika min sharri hadhihir-rihi, wa sharri ma fiha, wa sharri ma umirat bihi. (O Allah, we beg of You the good of this wind and the good of that which it contains and the good of that which it has been commanded; and we seek refuge in you from the evil of this wind and the evil of that which it contains and the evil of that which it has been commanded).''
[At-Tirmidhi].

1728. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "The wind is the Blessing of Allah. Sometimes it brings His Mercy and sometimes it brings His Chastisement. When you experience it, do not revile it but beg of Allah its good; and seek Allah's Refuge against its evil.''
[Abu Dawud with good Isnad].

1729. `Aishah (May Allah be pleased with her) said: Whenever the wind blew strongly, The Prophet (PBUH) would say: "Allahumma inni as'aluka khairaha, wa khaira ma fiha, wa khaira ma ursilat bihi. Wa a`udhu bika min sharriha, wa sharri ma fiha, wa sharri ma ursilat bihi. (O Allah, I beg of You its good and the good of that which it contains and the good of the purpose for which it has been sent; and I seek Your Refuge from its evil and the evil of that which it contains and the evil of the purpose for which it has been sent).''
[Muslim].

Commentary: Like His innumerable other gifts, the wind is a free gift of Allah, which is essential for man's health and sustenance. But if Allah wills, He can turn it into a means of destruction and ruin. Therefore, one should pray to Allah to enable him to benefit from its good effects and save him from bad ones.


Undesirability of Reviling the Rooster

Chapter 324
Undesirability of Reviling the Rooster

1730. Zaid bin Khalid Al-Juhani (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not revile the rooster for it wakes you up for prayer.''
[Abu Dawud].

Commentary: This Hadith is self-evident. The utility of the cock is not realized much nowadays as Adhan is amplified through loud-speakers. Before the invention of loudspeakers, the voice of Mu'adhdhin could go to a short distance only and it was cock's crow which used to awaken the Muslims for Tahajjud and Fajr prayers. Thus, we learn from this Hadith that whosoever cooperates in virtue, should be respected. One should also induce people to virtue and cooperate with them in good deeds so that one is well rewarded for it by Allah.


Prohibition of Attributing Rain to the Stars

Chapter 325
Prohibition of Attributing Rain to the Stars

1731. Zaid bin Khalid (May Allah be pleased with him) said: The Messenger of Allah (PBUH) led the Fajr prayer at Al-Hudaibiyyah after a rainfall during the night. At the conclusion of prayer, he turned towards the people and said, "Do you know what your Rubb has said?'' They replied: "Allah and His Messenger know better.'' Upon this he remarked, "He has said: `Some of My slaves have entered the morning as My believers and some as unbelievers. He who said: We have had a rainfall due to the Grace and Mercy of Allah, believes in Me and disbelieves in the stars; and he who said: We have had a rainfall due to the rising of such and such star, disbelieves in Me and affirms his faith in the stars.'''
[Al-Bukhari and Muslim].

Commentary:
1. Since Allah is the Real Creator and Maker of all things and events, these should without any exception be attributed to Him Alone. If a reference is made to the cause or causes which occasion an incident or event, it is permissible but to ascribe them entirely to some factor or factors is the conduct of polytheists and amounts to Shirk and Kufr.

2. People of the Period of Ignorance used to ascribe the rain which occurred at the appearance or setting of some star, to that star and would thus accept it as the real cause of it. In this Hadith, such ascription has been regarded as Kufr and Shirk.


Prohibition of Calling a Muslim an Infidel

Chapter 326
Prohibition of Calling a Muslim an Infidel

1732. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "When a person calls his brother (in Islam) a disbeliever, one of them will certainly deserve the title. If the addressee is so as he has asserted, the disbelief of the man is confirmed, but if it is untrue, then it will revert to him.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that to call a Muslim a Kafir is strictly prohibited because if the one who has been called as such does not have the traits which makes him a Kafir, then the one who says it will be held Kafir.

1733. Abu Dharr (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "If somebody accuses another of disbelief or calls him the enemy of Allah, such an accusation will revert to him (the accuser) if the accused is innocent.''
[Al-Bukhari and Muslim].

Commentary: This Hadith also tells us that to call without reason any Muslim a Kafir or enemy of Allah is strictly prohibited.


Prohibition of Obscenity

Chapter 327
Prohibition of Obscenity

1734. Ibn Mas`ud (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "A true believer does not taunt or curse or abuse or talk indecently.''
[At-Tirmidhi].

Commentary: We learn from this Hadith that in order for one to be a perfect believer, it is not enough to possess all the moral qualities but one must also keep oneself away from moral evils.

1735. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Indecency does not leave anything untainted and decency does not leave anything ungraced and embellished.''
[At-Tirmidhi].

Commentary: This Hadith induces us to abandon indencency and adopt decency.


Undesirability of Pretentiousness and Exaggeration during Conversation

Chapter 328
Undesirability of Pretentiousness and Exaggeration during Conversation

1736. Ibn Mas`ud (May Allah be pleased with him) said: The Prophet (PBUH) said, "Ruined are Al-Mutanatti`un.'' He repeated this thrice.
[Muslim].

Commentary: Mutanatti`un are those people who are in the habit of making unnecessary and unreasonably fine distinctions, exaggeration, artificial and eloquent speech in simple matters. We learn from this Hadith that in all matters one should adopt simplicity and avoid exaggeration no matter whether in speech or action.

1737. `Abdullah bin `Amr bin Al-As (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "Verily, Allah dislikes an eloquent person who rolls his tongue as a cow rolls its tongue (while eating).''
[Abu Dawud and At-Tirmidhi].

Commentary: The person referred to in this Hadith is one who speaks with affection to display his eloquence.

1738. Jabir bin `Abdullah (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "The dearest and the closest of you to me on the Day of Resurrection will be those who are the best in behaviour; and the most hateful and the farthest from me on the Day of Resurrection will be the talkative and the most pretentious and the most rhetorical.''
[At-Tirmidhi].

Commentary: Ath-Thartharun (most voluble) is the plural of Tharthar which comes from the word Thartharah, meaning to speak repeatedly in an artificial manner. Mutashaddiqun (loud-mouthed) is the plural of Mutashaddiq, which means a person who speaks loudly to display his eloquence. Mutafaihiqun is the plural of Mutafaihiq which is from the word Fihq, meaning to fill. This Hadith is a reference to those people who speak in a loud and lofty manner. All these characteristics of speech are indicative of artificiality and affectation which are condemned by Shari`ah, and people having these defects will be far away from the Prophet (PBUH) and will face the Wrath of Allah. Islam likes simple, polite and natural style of conversation. In fact, all moral virtues will be a means of the nearness of the Prophet (PBUH) and the Pleasure of Allah. May Allah enable us to adopt these virtues.


Abomination of Self-Condemnation

Chapter 329
Abomination of Self-Condemnation

1739. `Aishah (May Allah be pleased with her) said: The Prophet (PBUH) said, "None of you should say: `My soul has become evil.' He should say: `My soul is in bad shape.'''
[Al-Bukhari and Muslim].

Commentary: Khabusatu and Laqisatu are synonymous but the former has appearance of greater sinfulness. Imam Al-Khattabi says that this is a guidance for speaking in a proper manner. One should always use a decent word and abstain from impolite language.


Undesirability of Calling Grapes 'Al-Karm'

Chapter 330
Undesirability of Calling Grapes 'Al-Karm'

1740. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "None of you should use the word Al-Karm for grapes, for Al-Karm is a Muslim (worthy of respect).''
[Al-Bukhari and Muslim]

Another narration is: "Verily, Al-Karm is the heart of a true believer.''

Another narration is: "People have named grapes as Al-Karm; verily, only the heart of a believer is Al-Karm.''

Commentary: We learn from this Hadith that all the derivatives from the word Al-Karm can be used legitimately for Muslims only because Muslim is Karim. It is, therefore, wrong to call grapes as Karm.

1741. Wa'il bin Hujr (May Allah be pleased with him) said: The Prophet (PBUH) said, "Do not say Al-Karm when talking about grapes but say Al-`Inab or Al-Habalah.''
[Muslim].

Commentary: Al-Habalah or Habilah means grapevine. It is undesirable (Makruh) to refer to the grapes as Al-Karm, which also means grapes in Arabic, for it is the true Muslim who deserves to be called with a name which is derived from the word Al-Karm.


Prohibition of Describing the Charms of a Woman to a man without a valid reason approved by the Shari'ah

Chapter 331
Prohibition of Describing the Charms of a Woman to a man without a valid reason approved by the Shari'ah

1742. Ibn Mas`ud (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "No woman should touch another woman's body and then describe the details of her figure to her husband in such a manner as if he was looking at her.''
[Al-Bukhari].

Commentary: "Mubashirah'' means "meeting of two bodies'' and here it signifies that one should not see another person's body. Here, it is used in its literal as well as metaphorical sense. What it really means is that neither a woman should see the body of any other woman nor should she touch her own body with the body of some other woman, for if she does so, she will come to know the physical qualities of the other woman which she may disclose to her husband. Such disclosures may induce her husband to mischief and eventually ruin her own life. One is allowed, however, to disclose a woman's charms to a man who intends to marry her.


Abomination of saying: "Forgive me if you wish, O Allah!"

Chapter 332
Abomination of saying: "Forgive me if you wish, O Allah!"

1743. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "You must not supplicate: `O Allah! forgive me if You wish; O Allah bestow mercy on me if You wish.' But beg from Allah with certitude for no one has the power to compel Allah.''
[Al-Bukhari and Muslim]

Another narration of Muslim is: "A supplication should be made in full confidence and one should persistently express his desire (before Allah) in his supplication, for no bounty is too great for Allah to bestow (upon his slaves).''

Commentary: "Beg from Allah with certitude'' means that one should not pray with `ifs' and `buts' but should make a definite prayer and insist upon it. "For no bounty is too great for Allah'' means that Allah has absolute power to answer our prayers, whether they relate to religious or worldly matters.

1744. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "When one of you supplicates, let him be decisive and he should not say: `O Allah, bestow upon me such and such if You wish', because no one has the power to compel Him.''
[Al-Bukhari and Muslim].

Commentary: One should pray to Allah will full confidence that He will answer his prayers. One should also persist in praying and never give in to despair.


Abomination of saying: "What Allah Wills and so-and-so Wills"

Chapter 333
Abomination of saying: "What Allah Wills and so-and-so Wills"

1745. Hudhaifah bin Yaman (May Allah be pleased with him) said: The Prophet (PBUH) said, "Say not: `What Allah wills and so-and-so wills', but say: `What Allah wills, and then what so-and-so wills.'''
[Abu Dawud with authentic Isnad].

Commentary: The first form mentioned in this Hadith is prohibited for the reason that it combines the will of someone with the Will of Allah, which is utterly wrong and against the factual position. In the second form, the Will of Allah comes first, which is the correct position, and the will of someone else comes later which is subject to the Will of Allah. The later form is quite fair.

It is as if someone says to a person, "I have only Allah's Support and yours''. In this statement Allah and man (the person addressed) are given the same status, which is most unfair and unjust. It would, however, be all right to say "We have the support of Allah and then yours'', because this statement does not have any trace of Shirk, which the former statement has.


Abomination of Holding Conversation after 'Isha' (Night) Prayer

Chapter 334
Abomination of Holding Conversation after 'Isha' (Night) Prayer

1746. Abu Barzah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) disliked going to bed before the `Isha' (night) prayer and indulging in conversation after it.''
[Al-Bukhari and Muslim].

Commentary: The prohibition of going to bed before `Isha' prayer is that if one sleeps late at night, it becomes difficult for him to get up for Tahajjud prayer or Fajr prayer. Moreover, if a person goes to sleep soon after `Isha' prayer, all his activities of the day will end at `Isha', which is the most meritorious act. It should also be borne in mind that when holding a conversation which is disliked or forbidden at other times becomes even more so at this particular time (i.e., after `Isha' prayer). Imam An-Nawawi's contention that things like academic discussion, talking to a guest, discussing the lives of the pious etc., are not only permissible but desirable, is also subject to the condition that such an activity does not involve the risk of losing the Fajr prayer. If one spends so much time in such activities that he is likely to miss the Fajr prayer, then the permission to hold academic discussion becomes doubtful.

1747. Ibn `Umar (May Allah be pleased with them) said: Once, towards the end of his life, the Messenger of Allah (PBUH) concluded the `Isha' (night) prayer and said, "After one hundred years from tonight none of the people on the surface of the earth will survive.''
[Al-Bukhari and Muslim].

Commentary: The Prophet (PBUH) had made a prophecy that none of the people who were alive on that night would live beyond the end of the century. `None of the people on the surface of the earth will survive' has been interpreted as "those who had seen him and known him would not stay alive after a hundred years of his death from that night. This was true, for the last Companion of the Prophet, Abu Tufail Amir bin Wa'ilah, died in 110 A.H., i.e., exactly one hundred years after the Prophet's prophecy.

1748. Anas (May Allah be pleased with him) said: Once the Prophet (PBUH) delayed the `Isha' (night) prayer till midnight. He (PBUH) turned to us after the prayer and said, "All the people slept after offering their prayers, but you who waited, will be accounted as if you were engaged in your prayer throughout the period.''

[Al-Bukhari].

Commentary: We learn the following three points from this Hadith: First: `Isha' prayer can be deferred till midnight.

Second: It is permissible to keep awake for it to offer it in congregation. It is also permissible to engage in a beneficial activity after `Isha' prayer involving such important matters as acquiring teaching knowledge or even spending time with one's wife or guest.

Third: The period spent in waiting will be treated as time spent in Salat and its reward will also be greater in similar proportions.


Prohibition of Refusal by a Woman when her Husband calls her to his Bed

Chapter 335
Prohibition of Refusal by a Woman when her Husband calls her to his Bed

1749. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "If a man calls his wife to his bed and she refuses, and thus he spends the night angry with her, the angels continue cursing her till the morning.''
[Al-Bukhari and Muslim].

Commentary: It is incumbent on every women to respond to her husband's invitation to his bed for sexual intercourse. It would be a different matter if she has a lawful reason for it, such as observing an obligatory act of worship, like fasting during the month of Ramadan, illness, menses, etc. In such events she would be obviously unable to comply with the wish of her husband. But in the absence of any lawful reason, she would be condemned by the angels. This is emphasized on women for the reason that a husband should not ignore his wife and turn to some other women. If a woman fails to satisfy the sexual urge of her husband, he can go astray. It is, therefore, necessary that she should not show any slackness in complying with her husband's wishes.


Prohibition of Observing an Optional Saum (Fast) by a Woman without the Permission of her Husband

Chapter 336
Prohibition of Observing an Optional Saum (Fast) by a Woman without the Permission of her Husband

1750. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is not lawful for a woman to observe an optional Saum (fast) without the permission of her husband when he is at home. Nor should she allow anyone to enter his house without his permission.''
[Al-Bukhari and Muslim].

Commentary: Fasting here signifies voluntary fasting. Similar is the case of other voluntary prayers, i.e., voluntary Salat, recitation, etc. It is not permissible to do such acts without the permission of the husband if he is present. It should be borne in mind that a women is not permitted to let even her natural relations (who are Mahram) come in her home in the absence of her husband. She can, however, allow such persons to come about whom her husband has given express permission or in respect of whom he keeps silent.


Prohibition of raising one's Head before the Imam

Chapter 337
Prohibition of raising one's Head before the Imam

1751. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Does he who raises up his head before the Imam not fear that Allah will make his head that of a donkey or make his appearance similar to that of donkey?''
[Al-Bukhari and Muslim].

Commentary: This Hadith has a stern warning for those who take precedence over the Imam in the course of Salat. The faces of such will be turned by Allah into those of donkeys, and that is least difficult for Him. Sheikh Ibn Hajar Al-Haithami mentioned in his Al-Mu`jam that some people's faces have really been turned into those of donkeys. It is, therefore, essential for everyone who offers Salat in congregation, to follow the actions of Imam in Salat. To do anything before the Imam in the course of Salat, is a great sin and some scholars hold that such Salat is valid but the one who does so will be deemed sinful. Imam Ibn Hanbal, however, regards this Salat as invalid.


Prohibition of Placing the hands on the sides during As-Salat (The Prayer)

Chapter 338
Prohibition of Placing the hands on the sides during As-Salat (The Prayer)

1752. Abu Hurairah (May Allah be pleased with him) said: We are prohibited from placing the hand on the side during As-Salat (the prayer).
[Al-Bukhari and Muslim].

Commentary: There are two sides of everyone, the left and the right. Since keeping hands on one of them is a sign of arrogance, this is prohibited in Salat. At-Tabarani and Al-Baihaqi have reported a Hadith in which Messenger of Allah (PBUH) said: "Placing the hands on the sides during Salat, is an act of the dwellers of the Fire.'' One can, however, do so only if there is such a pain that he is compelled to place the hands there.


Abomination of Joining As-Salat (The Prayer) when the Food is ready or when one is in desperate need to answer the call of Nature

Chapter 339
Abomination of Joining As-Salat (The Prayer) when the Food is ready or when one is in desperate need to answer the call of Nature

1753. `Aishah (May Allah be pleased with her) said: I heard the Messenger of Allah (PBUH) saying, "No Salat (prayer) should be performed when the food has been served, nor should it be performed when a person is in need of relieving himself.''
[Muslim].

Commentary: We learn from this Hadith that one should not offer Salat when he is hungry and the food has been served or has to answer the call of nature. The reason behind is that if one offers Salat in that condition, he will not be able to do it with full concentration. Similarly, if one has to answer the call of nature, he should first do so and then offer Salat.


Prohibition of raising one's Eyes towards the sky during As-Salat (The Prayer)

Chapter 340
Prohibition of raising one's Eyes towards the sky during As-Salat (The Prayer)

1754. Anas bin Malik (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "How is it that some people raise their eyes towards the sky during As-Salat (the prayer)?'' He stressed (this point) and added, "People must refrain from raising their eyes towards heaven in Salat (prayer), or else their sights will certainly be snatched away.''
[Al-Bukhari].

Commentary: Looking towards the sky during prayer disturbs the concentration in Salat and there is a stern warning against this bad habit. One can, however, do so after Salat, i.e., during one's supplications.


Undesirability of Glancing in one Direction of the other during Prayer

Chapter 341
Undesirability of Glancing in one Direction of the other during Prayer

1755. `Aishah (May Allah be pleased with her) said: I asked the Messenger of Allah (PBUH) about random looks in Salat (prayer), and he replied, "It is something which Satan snatches from the slave's Salat.''
[Al-Bukhari].

Commentary: "Pouncing'' or "snatching'' means to take away something swiftly from someone while he is not alert. When a person looks here and there in the course of Salat and does not concentrate on it, Satan avails this opportunity and spoils his Salat.

1756. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said to me, "Beware of looking around in Salat (prayer), because random looks in Salat are a cause of destruction. If there should be no help from it, it is permissible in the voluntary and not in obligatory Salat.''
[At-Tirmidhi].

Commentary: In the chain of transmitters [i.e., Sanad] of this Hadith, we find `Ali bin Zaid bin Jad`an who is known to be Da`if (i.e., weak). If this narration is not reliable, then seeing here and there even in voluntary Salat is not permissible. However, if at all looking is inevitable, one can slightly turn his face because if one turns the whole body, his Salat would become invalid as he would not be facing the Qiblah which is essential for Salat.


Prohibition of facing the Graves during Salat (Prayer)

Chapter 342
Prohibition of facing the Graves during Salat (Prayer)

1757. Abu Marthad Kannaz bin Husain (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying: "Do not offer Salat (prayer) facing the graves and do not sit on them.''
[Muslim].

Commentary:

1. It is prohibited to face the graves while offering Salat. Its reason seems to be that it creates a resemblance to polytheists. Moreover, it has a trace of reverence for someone other than Allah, which takes one towards Shirk.

2. It is forbidden for Muslims to sit on the graves because it is disrespect of man whom Allah has honoured.

Therefore Muslims should avoid both practices mentioned above. Imam An-Nawawi said: Our companions (the scholars) said that it is Makruh (undesirable) to plaster the grave; while sitting, leaning against it or resting on it is Haram (forbidden).


Prohibition of passing in front of a Worshipper while he is offering Salat (Prayer)

Chapter 343
Prohibition of passing in front of a Worshipper while he is offering Salat (Prayer)

1758. Abul-Juhaim `Abdullah bin Al-Harith (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "If the person who passes in front of a praying person, realizes the enormity of the sinfulness of this act, it will have been better for him to wait forty than to pass in front of him.''
[Al-Bukhari and Muslim].

[The narrator was not sure whether the Prophet (PBUH) said forty days, months or years.]

Commentary: We learn from this Hadith that it is a great sin to pass before a person who is offering Salat. People should also take care that they do not offer Salat without placing a Sutrah in front of them. A Sutrah refers to anything that a person sets up in front of him; this could be a stick, another person praying in front of him or even a line which he can draw on the ground. The distance between the person offering his Salat and the Sutrah should not be more than approximately one meter and a half. If the distance is longer than this, then it is not unlawful to pass before someone offering Salat.


Undesirability of offering optional Prayer after the announcement of Iqamah

Chapter 344
Undesirability of offering optional Prayer after the announcement of Iqamah

1759. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "When the Iqamah is called, no prayer should be performed except the obligatory prayer.''
[Muslim].

Commentary: When the Iqamah has been announced (prescribed recitation at the commencement of Salat when offered in congregation, after the worshippers have taken up that position), it is not permissible to offer any other prayer - whether it is Sunnah or Nafl. If a person has already started any, he should break it to join the congregation. He should offer the Salat which he terminated after the obligatory Salat offered in congregation. It is against this Hadith to continue Nafl Salat or Sunnah when the worshippers have taken the position to offer Salat in congregation and Iqamah has been called. Some scholars are of the opinion that one can continue the performance of Fajr Sunnah, even after the congregational Salat has started. They have taken the plea that if there is no risk of losing the first Rak`ah, it is permissible to continue the Sunnah of Fajr prayer. Their plea is against the present Hadith. It is a common feature to see the worshippers offering Sunnah during the course of Fajr prayer offered in congregation. Thus in practice, the Sunnah of the Fajr prayer are continued regardless of this stipulation. In any case, this practice is totally against the injunctions contained in this Hadith.


Abomination of Selecting Friday for Fasting

Chapter 345
Abomination of Selecting Friday for Fasting

1760. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "Do not choose the Friday night among all other nights for standing in (Tahajjud) prayer, and do not choose Friday among all other days for Saum (fasting) except that one you have accustomed to.''
[Muslim].

Commentary: It is undesirable to fix Jumu`ah for voluntary fast. One can, however, observe fasting if Friday occurs in his routine of fasts, i.e., if one observes fast on alternate days and Jumu`ah occurs on the day when he observes fast, or if one observes the fast of the Day of `Arafah, or the Day of `Ashura', and Friday occurs on that day, or if Friday occurs during the Ayyam Al-Beid, or Friday occurs when one is observing fasts of Nadhr (fasts one has vowed for). There is no harm in observing fast on Friday in all such cases but its special observance on Friday is not recommended.

1761. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) as saying: "None of you should observe fast on Friday except that he should observe fast either one day before it or one day after it.''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith that we can fast on Friday if we fast, along with it, on Thursday or Saturday, i.e., either one day before or after it.

1762. Muhammad bin `Abbad (May Allah be pleased with him) said: I asked Jabir (May Allah be pleased with him). Did the Prophet (PBUH) prohibit fasting on Friday?'' He said, "Yes.''
[Al-Bukhari and Muslim].

1763. Juwairiyah bint Al-Harith (May Allah be pleased with her), the Mother of the Believers, said that the Prophet (PBUH) visited her on a Friday and she was observing fast. He asked, "Did you observe fast yesterday?'' She said, "No.'' He asked, "Do you intend to observe fast tomorrow?'' She said, "No.'' He said, "In that case, give up your fast today.''
[Al-Bukhari].

Commentary: We learn from this Hadith that if someone is keeping fast on Friday and has not fasted the day before, nor does he intend to fast the following day, i.e., Saturday, it is permissible for him to break his fast.


Prohibition of Extending Fast beyond one Day

Chapter 346
Prohibition of Extending Fast beyond one Day

1764. Abu Hurairah and `Aishah (May Allah be pleased with them) said: The Prophet (PBUH) prohibited observing continuous voluntary fasts beyond one day.
[Al-Bukhari and Muslim].

1765. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) prohibited observing continuous fasts beyond one day. The Companions submitted: "But you do it.'' He replied, "I am not like you. I am given to eat and to drink (from Allah).''
[Al-Bukhari and Muslim].

Commentary:
1. Through this Hadith we learn that in certain matters the Prophet (PBUH) had some specific injunctions which were obligatory for him but not for his Ummah. Such things were permissible for him but not for his followers. All these things are called his special distinctions. It is not permissible for Muslims to follow such practices. One of these things is Saum Al-Wisal, which means to observe fast for several days at a stretch without taking any food. Since Allah had granted him special power and patience, he could observe fast continuously for days. As his followers are not endowed with that energy and patience, they are not permitted to do so.

2. "I am not like you'' does not mean that "I am not a man like you,'' because such an interpretation goes against a categorical statement of the Qur'an to the effect that "I am a man like you''. What the statement "I am not like you'' really means is "you do not possess that special power which has been granted to me.''

3. "I am given to eat and to drink'' signifies that Allah (SWT) provides him with the strength and energy which he can derive from food and drink without necessarily having them.


Prohibition of Sitting on the Graves

Chapter 347
Prohibition of Sitting on the Graves

1766. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "It is much better for one of you to sit on a live coal, which will burn his clothes and get to his skin than to sit on a grave.''
[Muslim].

Commentary: To sit on the grave is strictly prohibited [see Hadith No. 1758]. Ibn Hajar Al-Haithami and others, however, regard this act to be only Makruh (undesirable) and maintain that the warning contained in the Hadith is for those people who sit on them for urinating or defecating. The Hadith also elucidates the fact that graves should be respected and that glorifying the people in them by plastering them or building over them is not permissible.


Prohibition of Plastering and Building over the Graves

Chapter 348
Prohibition of Plastering and Building over the Graves

1767. Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) forbade that the graves should be plastered (made into permanent structures), used as sitting places (for the people) or building over them.
[Muslim].

Commentary: We learn the following points from this Hadith:
1. The construction of permanent graves is sheer extravagance because they do not benefit the dead. This act is `disliked' and reaches the level of prohibition when graves are ornamented and embellished.

2. Sitting on the graves is a disliked act, as has been made clear in the previous Hadith.

3. It is such a respect for the dead which inclines people to Shirk. Construction of dome etc., over the graves have also the same effect.


Prohibition for a Slave to run away from his Master

Chapter 349
Prohibition for a Slave to run away from his Master

1768. Jarir bin Abdullah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "If a slave runs away from his master, his responsibility to him is absolved.''
[Muslim].

1769. Jarir bin Abdullah (May Allah be pleased with him) said: The Prophet (PBUH) said, "When the slave runs away from his master, his Salat (prayer) will not be accepted.''
[Muslim].

Another narration is: "He is guilty of disbelief (i.e., in case he believes in the lawfulness of doing so).''

Commentary: The institution of slavery does not exist in the modern world, but if it exists anywhere or a situation arises in which it re-emerges, the principle stated in this Hadith will be applicable. The Hadith also makes it clear that if someone has expressed his commitment to serve somebody, he should not back out. It also urges us to show gratefulness to one's benefactors and to reciprocate the good, one receives.


Undesirability of Intercession in Hudud

Chapter 350
Undesirability of Intercession in Hudud

Allah, the Exalted, says:

"The woman and the man guilty of illegal sexual intercourse, flog each of them with a hundred stripes. Let not pity withhold you in their case, in a punishment prescribed by Allah, if you believe in Allah and the Last Day.'' (24:2)

1770. `Aishah (May Allah be pleased with her) reported: The Quraish were anxious about a woman from Banu Makhzum who had committed theft and asked : "Who will speak to the Messenger of Allah (PBUH) about her?'' Then they said: "No one will be bold enough to do so except Usamah bin Zaid, the (Companion who was) dearly loved by the Messenger of Allah (PBUH).'' So Usamah (May Allah be pleased with him) spoke to him and the Messenger of Allah (PBUH) (angrily) said, "Are you interceding regarding one of the punishments prescribed by Allah?'' He then got up and delivered an address in which he said, "Indeed what destroyed the people before you was just that when a person of high rank among them committed a theft, they spared him; but if the same crime was done by a poor person they inflicted the prescribed punishment on him. I swear by Allah that if Fatimah daughter of Muhammad should steal, I would have her hand cut off.''
[Al-Bukhari and Muslim].

In another narration `Aishah (May Allah be pleased with her) said: (Upon hearing the intercession of Usamah), the face of the Messenger of Allah (PBUH) changed color (because of anger) and he said, "Do you dare to intercede in matters prescribed by Allah?'' Usamah pleaded: "O Messenger of Allah! Pray for my forgiveness.'' `Aishah (May Allah be pleased with her) added: Thereafter the Messenger of Allah (PBUH) gave orders to have that woman's hand cut off.

Commentary:
1. Hadd is the punishment fixed by Shari`ah and which no one has the authority to increase or decrease. For instance, theft is punishable by the cutting of the hand; the punishment of adultery is a hundred stripes or Rajm (stoning to death); the punishment of drinking of intoxicants is forty stripes etc.

2. Nobody has the right to intercede or make any recommendation in this matter.

3. There is no distinction of male or female in the matter of these punishments (Hudud). Whoever commits a crime which is punishable by Hadd, whether that person is male or female, will be liable for punishment prescribed under Hadd - the punishment, the limits of which have been defined in the Qur'an and Hadith.

4. No one is exempted from Hadd, no matter how great he is, because there is no distinction of great or small in the matter of Hadd.

5. We must learn a lesson from the history of past nations so that we can save ourselves from such misdeeds which caused their ruin.

6. This Hadith brings into prominence the distinction and eminence of Usamah and his position in the eyes of the Prophet (PBUH).


Prohibition of Relieving Nature on the Paths

Chapter 351
Prohibition of Relieving Nature on the Paths

Allah, the Exalted, says:

"And those who annoy believing men and women undeservedly, they bear (on themselves) the crime of slander and plain sin.'' (33:58)

1771. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Avoid two habits which provoke cursing.'' The Companions said: "What are those things which provoke cursing?'' He said, "Relieving on the thoroughfares or under the shades where people take shelter and rest.''
[Muslim].

Commentary: We learn from this Hadith that a Muslim must avoid all such things which cause inconvenience to other Muslims. If one uses the places mentioned in this Hadith as toilet, this would not only cause inconvenience to the public but may also cause an epidemic. It is also necessary to avoid such things for the sake of cleanliness. Some religious scholars are of the opinion that this act is deemed to be a major sin, as it brings people's curses upon the one who practices it.


Prohibition of Urinating into Stagnant Water

Chapter 352
Prohibition of Urinating into Stagnant Water

1772. Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) forbade urinating into stagnant water.
[Muslim].

Commentary: "Stagnant water'' means water which is not flowing, like the water in a pond or a tank. When urination is prohibited at such places, defecating would be more sternly prohibited. One must also avoid throwing filth in it.

How vast and comprehensive the injunctions of Islam are, and how thoroughly Islam has grasped the problems of people, is something unique in the realm of religion. No other world religion can match it in this respect. It is very unfortunate indeed that in spite of having such perfect and complete religion, the Muslims are far away from practising its noble teachings. May Allah enable us to become true followers of Islam.


Prohibition of giving preference to Children over one another in giving Gifts, etc.

Chapter 353
Prohibition of giving preference to Children over one another in giving Gifts, etc.

1773. An-Nu`man bin Bashir (May Allah be pleased with them) said: My father took me to the Messenger of Allah (PBUH) and said to him: "I have gifted one of my slaves to this son of mine.'' The Messenger of Allah (PBUH) said, "Have you given such gift to every son of yours?'' He replied, "No.'' Thereupon he said, "Take this gift back.''

Another narration is: The Messenger of Allah (PBUH) said, "Be mindful of your obligation to Allah and do justice in respect of your children.'' My father came back and revoked his gift.

Another narration is: The Messenger of Allah (PBUH) asked, "Have you other children besides this one?'' He said, "Yes.'' The Messenger of Allah (PBUH) asked, "Have you awarded a gift like this to all of them.'' He said, "No.'' The Messenger of Allah (PBUH) said, "I am not going to bear witness to this act of injustice.''

Another narration is: The Messenger of Allah (PBUH) asked, "Do you not except goodness from all of them as you except from him?'' He said, "Yes, of course.'' The Messenger of Allah (PBUH) said, "Then don't do this (i.e., do not give a gift to one son only).''
[Al-Bukhari and Muslim].

Commentary: We learn from this Hadith the following important points:

1. In every matter, one should consult scholars and experts of Shari`ah. This was the practice of the Companions (May Allah be pleased with them).

2. Parents should deal with all their children with equity and justice. Preferential treatment with any child affects them adversely. Obviously injustice creates tension for parents as well as children and eventually family ties are broken.

3. This Hadith is also advanced by those `Ulama' in support of their contention that if a person wants to distribute his property among his children during his lifetime, he should not make any discrimination among his male and female children and should give an equal share to all of them.


Prohibition of Mourning beyond Three Days (For Women)

Chapter 354
Prohibition of Mourning beyond Three Days (For Women)

1774. Zainab bint Abu Salamah (May Allah be pleased with them) said: I went to Umm Habibah (May Allah be pleased with her) the wife of the Prophet (PBUH), when her father Abu Sufyan bin Harb (May Allah be pleased with him) died. Umm Habibah (May Allah be pleased with her) sent for a yellow coloured perfume or something else like it, and she applied it to a slave-girl and then rubbed it on her own cheeks and said: "By Allah, I have no need for perfume, I heard the Messenger of Allah (PBUH) saying from the pulpit, `It is not permissible for a woman who believes in Allah and the Last Day to mourn for the dead beyond three days, except for the death of her husband; in which case the period of mourning is of four months and ten days.''' Zainab said: I then visited Zainab, daughter of Jahsh (May Allah be pleased with her) when her brother died; she sent for perfume and applied it and then said: "Beware! By Allah, I don't feel any need of perfume but I heard the Messenger of Allah (PBUH) saying from the pulpit, `It is not permissible for a woman who believes in Allah and the Last Day to mourn the dead beyond three days except in case of her husband (for whom the period is) four months and ten days.'''
[Al-Bukhari and Muslim]

Commentary: The period of mourning the husband's death is four months and ten days while ordinarily it is three days only (for others). The reasons behind mourning the dead husband is: Firstly, the purification of womb. Secondly, it is a mark of respect for the relation and love between husband and wife. The scent which was used in the two incidents reported in this Hadith occurred after the stipulated period of mourning in ordinary cases - that is three days. After the expiry of the mourning period, the woman is allowed to resume her routine. The Hadith mentions the man's right over his wife after his death; it also shows the importance of conjugal ties in Islam.


Prohibition of Malpractices in Commerce

Chapter 355
Prohibition of Malpractices in Commerce

1775. Anas bin Malik (May Allah be pleased with him) said: The Messenger of Allah (PBUH) forbade that a person in the city should make a deal on behalf of a villager on commission even if he is his real brother.''
[Al-Bukhari and Muslim]

Commentary: "Al-Hadir'' means one who lives in the city, while "Al-Badi'' means a villager or a desert dweller. "He should not make a deal'' here signifies that the urbanite should not go to the villager and propose to him leave his goods with him for sale and he would send him the sale proceeds of the goods piecemeal as they sell. In the opinion of some `Ulama' this is prohibited if the merchandise is valuable and the villager is not aware of its real worth and the urbanite wants to exploit his ignorance. But, on the contrary, if the proposal is for the welfare of the villager and the urbanite merely wants the owner to receive its due price then the offer is admissible. The first proposition is prohibited because that will cause a loss to the villager; the second is permissible as it is a well-meaning offer.

"A person in the city should not make a deal on behalf of a villager'' has been interpreted by `Abdullah bin `Abbas (May Allah be pleased with them) to mean that he should not work as a broker for a villager because in that case he will be interested to sell it on a higher price in order to have a better commission in the deal, which will unnecessarily raise its cost.

On one side, the purchase of goods coming from outside has been prohibited before its arrival on the market so that nobody can exploit the ignorance of the outsiders, and on the other side, villagers are enjoined to sell their goods themselves so that the commission of the broker does not increase the price of the goods. If an urbanite sells the merchandise of any villager on a fair price without charging any commission then this is permissible, as is confirmed by Ahadith. If the people living in cities charge each other commission on the purchase or sale of their goods this is permissible.

1776. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "Do not meet the merchandise till they arrive in the market.''
[Al-Bukhari and Muslim].

Commentary: "Do not meet the merchandise'' signifies "Do not meet trade caravans in transit.'' The purpose being that those who bring food grains from villages, should not suffer any loss because of their ignorance of the market conditions. But if someone does it with a good intention then this is permissible.

1777. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "The caravans carrying merchandise should not be met on the way to purchase from them; a man in the city should not sell for a man of the desert.''

Tawus asked him (Ibn `Abbas): "What do these words really imply?'' He said: "He should not work as an agent on his behalf.''
[Al-Bukhari and Muslim].

Commentary: This Hadith makes it clear that no one should work as a broker to exploit the ignorance of villagers who bring their merchandise in the market. But if one does it with a good intention then this is permissible. Nowadays different forms of brokerage are in vogue in our markets out of which some are permissible and some are prohibited.

1778. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) forbade that a man in the city should be the commission agent of a man from the desert and prohibited the practice of Najsh (i.e., offering a high price for something in order to allure another customer who is interested in the thing); and that a man should make an offer while the offer of his brother is pending; or that he should make a proposal of marriage while that of his brother is pending; or that a woman should try that a sister of hers might be divorced so that she might take her place.

Another narration is: The Messenger of Allah (PBUH) forbade the people from meeting the caravan on the way for entering into business transaction with them; and the selling of the goods by a dweller of the city on behalf of a man of the desert; and the seeking by a woman the divorce of her sister (from her husband); and the practice of Najsh and leaving the animals unmilked (for sometime for the purpose of accumulation of milk to deceive the buyer).
[Al-Bukhari and Muslim].

Commentary: "Litakfa ma fi ina'iha'' means that "Whatever is in her vessel is overturned.'' This is a figurative expression meaning "She would marry her (Muslim sister's) husband when he divorces her present wife.''

"Leaving the animals unmilked'' means that a saleable cattle is not milked for two or three times to create an impression that the cattle is rich in milk, which is not the true case. This is also prohibited. Other points mentioned in this Hadith have been discussed earlier.

1779. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "A person should not enter into a transaction when his (Muslim) brother has already negotiated, nor should he make a proposal of marriage when that of his brother is pending, except with the permission of the latter.''
[Al-Bukhari and Muslim]

Commentary: We learn from this Hadith that if a man knows that such and such person has asked some woman for marriage and she has accepted the proposal then he should not make an offer of marriage to her. But if the matter has ended and the first proposal permits him to try his luck then he can make a proposal to her for marriage. On the same analogy, it is prohibited for a woman to send a proposal of marriage to a man with whom some woman is already negotiating or has already negotiated.

1780. `Uqbah bin `Amir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "A Mu'min is the brother of another Mu'min; and thus it is not permissible for a Mu'min to make an offer while the offer of his brother is pending, nor should he make a proposal of marriage while that of his brother is pending till he withdraws his proposal.''
[Muslim].

Commentary: All the acts prohibited in the Ahadith cited above are such that they can cause or increase ill-will and enmity among people. For this reason, all these things have been forbidden by Islam to obviate all possibilities of dissension and discord and bring about mutual affection, fraternity and accord.


Prohibition of Squandering Wealth

Chapter 356
Prohibition of Squandering Wealth

1781. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Verily, Allah likes three things for you and disapproves three things for you. He likes that you should worship Him Alone, not to associate anything with Him (in worship) and to hold fast to the Rope of Allah and not to be divided among yourselves; and He disapproves for you irrelevant talk, persistent questioning and the squandering of the wealth.''
[Muslim].

Commentary: This Hadith has already been mentioned [Hadith No. 342]. Although the initial portion is missing there and three things which have been disliked are mentioned in its text. Beside stressing Tauhid, holding fast to the Rope of Allah and unity (which are greatly liked by Allah), this Hadith forbids unnecessary debate, hair-splitting and extravagance as all the three are disliked by Allah.

Wealth has a great importance in man's life since it is the very source of sustenance and basis of his livelihood, its wastage is akin to cutting the branch of the tree on which one is sitting.

1782. Warrad, the scribe of Al-Mughirah bin Shu`bah (May Allah be pleased with him) said: Al-Mughirah bin Shu`bah dictated a letter to me addressed to Mu`awiyah (May Allah be pleased with him) that the Prophet (PBUH) used to supplicate at the end of each obligatory Salat (prescribed prayer): "La ilaha illallahu, wahadahu la sharika lahu, lahul-mulku, wa lahul-hamdu, wa Huwa `ala kulli shai'in Qadir. Allahumma la mani`a lima a`taita, wa la mu`tiya lima mana`ta, wa la yanfa`u dhal-jaddi mink-al-jaddu. (There is no true god except Allah, the One, Who has no partner. His is the sovereignty and His is the praise, and He is Able to do everything. O Allah! Nobody can withhold what You give; and nobody can give what You withhold; and the high status of a person is of no avail against Your Will).'' He also wrote to him that the Prophet (PBUH) used to forbid irrelevant talk, wasteful expenditure, persistent questioning, disobedience of parents (especially mothers), infanticide of daughters by burying them alive, depriving others of their rights and acquisition of property wrongfully.
[Al-Bukhari and Muslim].

Commentary: The matters mentioned in this Hadith have been discussed in detail before. What this Hadith specially brings out is that the custom or writing or dictating Ahadith existed even during the age of the Companions. In this respect that was the first period of the compilation of Ahadith. Thus, it is wrong to say that there did not exist any system of recording Hadith in the days of the Companions.


Prohibition of Pointing with a Weapon at another Brother in Faith

Chapter 357
Prohibition of Pointing with a Weapon at another Brother in Faith

1783. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "None of you should point at his brother with a weapon because he does not know that Satan may make it lose from his hand and, as a result, he may fall into a pit of Hell-fire (by accidentally killing him).''
[Al-Bukhari and Muslim].

The narration in Muslim is: Abul-Qasim (i.e., the Messenger of Allah) (PBUH) said, "He who points at his (Muslim) brother with a weapon is cursed by the angels even if the other person should be his real brother.''

Commentary: "Silah'' is that weapon which is used in war for attack and defense, i.e., sword, gun, pistol, lance, etc. To point any such weapon towards a Muslim or Dhimmi, even to frighten him, is forbidden. It is very unfortunate that, contrary to the teachings of Islam, display and use of weapons are very common nowadays so much so that the fashion of air fire festivities is gaining increasing popularity in Muslim society. This fashion is totally against the teachings of Islam and its dangerous consequences are witnessed everyday. May Allah grant us guidance to follow the Right Path.

1784. Jabir (May Allah be pleased with him) said: The Messenger of Allah (PBUH) prohibited from presenting a drawn sword to another.''
[Abu Dawud and At-Tirmidhi].

Commentary: If a naked sword drops from one's hand, it can injure one's hand, foot or any part of the body. Similar is the case of a sharp knife or any other similar weapon and tool. One should never give it to anyone from its blade side. When we study such things, we are really wonderstruck to see the care which Islam has taken to respect humanity.


Undesirability of Leaving the Mosque without offering Salat (Prayer) after the Adhan has been Proclaimed

Chapter 358
Undesirability of Leaving the Mosque without offering Salat (Prayer) after the Adhan has been Proclaimed

1785. Abu Sha`tha' said: We were sitting with Abu Hurairah (May Allah be pleased with him) in the mosque when the Mu'adhdhin proclaimed the Adhan. A man stood up in the mosque and started walking out. Abu Hurairah (May Allah be pleased with him) stared at him till he went out of the mosque. Upon this Abu Hurairah (May Allah be pleased with him) said: Indeed, this man has disobeyed Abul-Qasim (PBUH).
[Muslim].

Commentary: We learn from this Hadith that after hearing Adhan, one should not leave the mosque without offering the obligatory Salat connected with it, unless one has a very genuine reason for doing so.


Undesirability of Rejecting the Gift of Perfume

Chapter 359
Undesirability of Rejecting the Gift of Perfume

1786. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who is presented with a flower of sweet basil should not reject it, because it is light in weight and pleasant in odour.''
[Muslim].

1787. Anas bin Malik (May Allah be pleased with him) reported: The Prophet (PBUH) never refused a gift of perfume.
[Al-Bukhari].

Commentary: We learn the following points from this Hadith:

1. A gift of perfume or something similar to it should be accepted.

2. The fondness of the Prophet (PBUH) for perfume. The fact that he never refused this gift is enough to illustrate his penchant for it.

3. The desirability of the use of perfume.


Undesirability of Praising a Person in his Presence

Chapter 360
Undesirability of Praising a Person in his Presence

1788. Abu Musa Al-Ash`ari (May Allah be pleased with him) said: The Prophet (PBUH) heard a person lauding another person or praising him too much. Thereupon he said, "You killed the man,'' or he said, "You ruined the man.''
[Al-Bukhari and Muslim].

1789. Abu Bakrah (May Allah be pleased with him) reported: Mention of a man was made to the Prophet (PBUH) and someone praised him whereupon he (PBUH) said, "Woe be to you! You have broken the neck of your friend!'' He repeated this several times and added, "If one of you has to praise his friend at all, he should say: `I reckon him to be such and such and Allah knows him well', if you think him to be so-and-so, you will be accountable to Allah because no one can testify the purity of others against Allah.''
[Al-Bukhari and Muslim].

Commentary: This Hadith prohibits us from praising anyone in his face. If at all one has to praise someone, he should say that "In my opinion he is such and such,'' provided he really thinks as he says. The reason for this is that it is Allah Alone Who knows him thoroughly and none can claim to be innocent before Him.

1790. Hammam bin Al- Harith (May Allah be pleased with him) reported: A person began to praise `Uthman (May Allah be pleased with him), and Al-Miqdad (May Allah be pleased with him) sat upon his knees and began to throw pebbles upon the flatterer's face. `Uthman (May Allah be pleased with him) said: "What is the matter with you?'' He said: "Verily, the Messenger of Allah (PBUH) said, `When you see those who shower undue praises upon others throw dust upon their faces.'''
[Muslim].

Commentary: The purpose of this Hadith seems to be that one should neither pay serious attention to one who praises nor reward him for it. If one can throw grit in his face, that should also be done. One should at least avoid such persons who are in the habit of praising people unnecessarily.

Imam An-Nawawi has stated that these Ahadith are in prohibition of praise while there are many in favour of it. `Ulama' are of the opinion that the two points of view can be reconciled. If the one who is praised has perfect Faith and confidence and is endowed with the gift of knowledge by Allah and has control over his self and thereby he is not likely to go astray by praise, then praising him is neither unlawful nor disgusting. But if he is vulnerable to praise then praising him in his presence is abhorred. Ahadith in prohibition of praise support this point of view. While one of the Ahadith, which are in favour of praise, relates to the occasion when the Prophet (May Allah be pleased with him) said to Abu Bakr As-Siddiq (May Allah be pleased with him): "I hope that you will also be among them,'' that is "You will be one of hose who will be called from every gate of Jannah.'' (See, Sahih Al-Bukhari, Kitab Fada'il As-Sahabah). Another Hadith on the issue relates to the event when the Prophet (PBUH) said to Abu Bakr (May Allah be pleased with him): "You are not one of them.'' What it signified was that "You are not one of those who keep their trousers below their ankles out of sheer pride.'' (See, Sahih Al-Bukhari, Manaqib Abu Bakr). He said to `Umar (May Allah be pleased with him): "When Satan sees you going on some way, he leaves it and proceeds to some other direction.'' (Al-Bukhari, Manaqib `Umar)


Undesirability of departing from or coming to a Place stricken by a Epidemic

Chapter 361
Undesirability of departing from or coming to a Place stricken by a Epidemic

Allah, the Exalted, says:

"Wheresoever you may be, death will overtake you even if you are in fortresses built up strong and high!'' (4:78)

"And do not throw yourselves into destruction.'' (2:195)

1791. Ibn `Abbas (May Allah be pleased with them) reported: `Umar bin Al-Khattab (May Allah be pleased with him) set out for Ash-Sham (the region comprising Syria, Palestine, Lebanon and Jordan). As he reached at Sargh (a town by the side of Hijaz) he came across the governor of Al-Ajnad, Abu `Ubaidah bin Al-Jarrah (May Allah be pleased with him) and his companions. They informed him that an had broken out in Syria. Ibn `Abbas relates: `Umar (May Allah be pleased with him) said to me: "Call to me the earliest Muhajirun (Emigrants).'' So I called them. He sought their advice and told them that an epidemic had broken out in Ash-Sham. There was a difference of opinion whether they should proceed further or retreat to their homes in such a situation. Some of them said: "You have set forth to fight the enemy, and therefore you should not go back;'' whereas some of them said: "As you have along with you many eminent Companions of Messenger of Allah (PBUH), we would not advice you to set forth to the place of the plague (and thus expose them deliberately to a danger).'' `Umar (May Allah be pleased with him) said: "You can now go away.'' He said: "Call to me the Ansar (the Helpers).'' So I called them to him, and he consulted them and they differed in their opinions as well. He said: "Now, you may go.'' He again said: "Call the old (wise people) of the Quraish who had emigrated before the conquest of Makkah.'' I called them. `Umar (May Allah be pleased with him) consulted them in this issue and not even two persons among them differed in the opinions. They said: "We think that you should go back along with the people and do not take them to this scourge. `Umar (May Allah be pleased with him) made an announcement to the people, saying: "In the morning I intend to go back, and I want you to do the same.'' Abu 'Ubaidah bin Al-Jarrah (May Allah be pleased with him) said: "Are you going to run away from the Divine Decree?'' Thereupon `Umar (May Allah be pleased with him) said: "O Abu 'Ubaidah ! Had it been someone else to say this.'' ('Umar (May Allah be pleased with him) did not like to differ with him). He said: "Yes, we are running from the Divine Decree to the Divine Decree. What do you think if you have camels and you happen to get down a valley having two sides, one of them covered with foliage and the other being barren, will you not act according to the Divine Decree if you graze them in vegetative land? In case you graze them in the barren land, even then you will be doing so according to the Divine Decree.

There happened to come `Abdur-Rahman bin `Auf who had been absent for some of his needs. He said: I have knowledge about it. I heard the Messenger of Allah (PBUH) saying, "If you get wind of the outbreak of plague in a land, you should not enter it; but if it spreads in the land where you are, you should not depart from it.'' Thereupon `Umar bin Khattab (May Allah be pleased with him) praised Allah and went back.
[Al-Bukhari and Muslim].

Commentary: "Ajnad'' stands for five regions of Syria: Palestine, Jordan, Damascus, Hims and Qansarin. (An-Nawawi).

'Umar (May Allah be pleased with him) praised Allah for the reason that his own Ijtihad was in accordance with the Hadith of the Prophet (PBUH). The opinion given by the groups of Ansar and Muhajirun before this Ijtihad was also based on some principles of Shari`ah: those who had advised not to return had evinced submission to the Will of Allah and their absolute trust in Him, and the other group which had preferred the way of precaution had suggested to avoid any such action which could prove harmful.

Although such precautionary measures could not save them from the Divine Decree, they decided to take all possible precautions because this is what is ordained by Allah. In fact, this was the basis of the Ijtihad made by `Umar, the veracity of which was proved by the Hadith of the Prophet (PBUH). This Hadith confirmed the point of view of Imam An-Nawawi. Thus, this Hadith highlights the following four important points:

1. The test of validity of any decision is its correspondence with Shari`ah.

2. The desirability of mutual consultation.

3. The power of the Imam to depart from the advice of the consultative body.

4. The responsibility of the Imam to make every possible effort for the security of his subjects.

1792. Usamah bin Zaid (May Allah be pleased with him) said: The Prophet (PBUH) said, "If you get wind of the outbreak of plague in a land, do not enter it; and if it breaks out in a land in which you are, do not leave it.''
[Al-Bukhari and Muslim].


Prohibition of Magic

Chapter 362
Prohibition of Magic

Allah, the Exalted, says:

"Sulaiman (Solomon) did not disbelieve, but the Shayatin (devils) disbelieved, teaching men magic.'' (2:102)

1793. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Avoid the seven destructive things.'' It was asked: (by those present): "What are they, O Messenger of Allah?'' He replied, "Associating anyone or anything with Allah in worship; practising sorcery, killing of someone without a just cause whom Allah has forbidden, devouring the property of an orphan, eating of usury, fleeing from the battlefield and slandering chaste women who never even think of anything touching chastity and are good believers.''
[Al-Bukhari and Muslim].

Commentary: This Hadith has already appeared earlier. All the acts mentioned in it are unlawful. The teaching, learning and practising of magic are all unlawful, and Imam An-Nawawi has quoted this Hadith here to prove the prohibition of magic in Islam.


Prohibition of Carrying the Qur'an into the Land of Enemy

Chapter 363
Prohibition of Carrying the Qur'an into the Land of Enemy

1794. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) forbade travelling to the land of the enemy carrying the Qur'an.
[Al-Bukhari and Muslim].

Commentary: This prohibition is out of fear that the disbelievers might abase and demean the Qur'an and will not give it due respect. It is, however, permissible to take it to places where there is no such fear.


Prohibition of using Utensils made of Gold and Silver

Chapter 364
Prohibition of using Utensils made of Gold and Silver

1795. Umm Salamah (May Allah be pleased with her) said: The Messenger of Allah (PBUH) said, "Whosoever drinks in utensils of silver, in fact, kindles in his belly the fire of Hell.''
[Al-Bukhari and Muslim].

The narration of Muslim is: "Verily, the person who eats or drinks in utensils made of gold and silver.''

1796. Hudhaifah (May Allah be pleased with him) reported: The Prophet (PBUH) prohibited us from wearing silk or Dibaj and from drinking out of gold and silver vessels and said, "These are meant for them (non-Muslims) in this world and for you in the Hereafter.''

In another narration Hudhaifah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Do not wear silk and Dibaj, nor eat or drink from utensils made of gold and silver.''
[Al-Bukhari and Muslim].

Commentary: Dibaj is a kind of silk. Some say that thick silk is called Dibaj. Others say that it is the type of cloth in which some of the lengthwise and breadthwise threads are of pure silk, while the rest of the cloth is made of cotton.

1797. Anas bin Sirin (May Allah be pleased with him) said: I was with Anas bin Malik (May Allah be pleased with him) in the company of some Magians when Faludhaj (a sweet made of flour and honey) was brought in a silver utensil, and Anas did not take it. The man was told to change the utensil. So he changed the utensil and when he brought it to Anas, he took it.
[Al-Baihaqi].

Commentary: From the above narrations, it is clear that the use of utensils made of gold or silver is forbidden in Islam for eating, drinking and for all other purposes. However, medical use of golden or silver wire is not forbidden, e.g., the use of golden wire in securing teeth, or fixing a tooth partly made of gold.

Eating and drinking in utensils of precious metals (in which platinum may also be included) is forbidden as it is a show of pride and exhibition of richness. All such actions are against the basic teachings of Islam. Precious metals should not be used for decoration either.

1. However, women may use precious metals as ornaments, since according to some narrations there is exemption for the fair sex in this matter. Still some scholars maintain that the chain of such narrations is weak, so they do not allow their use in the ornaments of women as well. Sheikh Al-Albani has discussed this matter in detail in Adab Az-Zafaf and he does not agree with the opinion of these other scholars.

2. Silken dress is also forbidden for men and, similarly all types of dresses resembling silk are forbidden for them, which are a speciality of women. They are forbidden as creating likeness and resemblance to women. The reason behind this is that the softness and delicacy found in silk is against manliness.

3. The prohibition of these things reflects the temperament and disposition of Islam. Islam encourages simplicity and piety in eating, drinking, dress and living; and forbids luxury and ease that creates resemblance and likeness with the disbelievers. Alas! Present-day Muslims have adopted ease and luxury and made it the criterion of nobility and are following in the footsteps of the disbelievers. Everyone is busy day and night to attain the western standard of living by hook or by crook. May Allah lead them on the Right Path.


Prohibition of Wearing Saffron-Colored Dress

Chapter 365
Prohibition of Wearing Saffron-Colored Dress

1798. Anas (May Allah be pleased with him) said: The Prophet (PBUH) prohibited men from wearing saffron-dyed clothes.
[Al-Bukhari and Muslim].

1799. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) said: The Prophet (PBUH) saw me dressed in two saffron-coloured garments and asked, "Has your mother commanded you to wear these?'' I asked him, "Shall I wash them out?'' He replied, "You had better set them to fire.''

Another narration is: "These are garments of the disbelievers. So do not wear them.''
[Muslim].

Commentary: Saffron and safflower are plants with a bright orange-yellow colour. Their use is forbidden because this colour is generally used by women and disbelievers, and men should show no resemblance to women and disbelievers in their dress.


Prohibition of observing silence from Dawn till Night

Chapter 366
Prohibition of observing silence from Dawn till Night

1800. `Ali (May Allah be pleased with him) said: I have retained in my memory the saying of the Messenger of Allah (PBUH) that: "No one is considered an orphan after he has attained the age of maturity; and it is unlawful to remain silent from dawn till night.''
[Abu Dawud with Hasan (good) Isnad].

1801. Qais bin Abu Hazim ¨(May Allah be pleased with him)(c) said: Abu Bakr (May Allah be pleased with him) came upon a woman named Zainab from the Ahmas tribe and noticed that she was observing total silence. He said: "What has happened to her? Why does she not speak?'' People informed him that she had sworn to remain silent. He then said to her: "You should speak, it is not permissible (to observe silence), for it is an act of the Days of Ignorance (Jahiliyyah).'' (After hearing this) she started speaking.
[Al-Bukhari].

Commentary:
1. From the above narrations it becomes clear that one can not be called an orphan when maturity is attained. The proof of maturity is night discharge and not any particular age. The age of maturity may differ in different countries according to the climate and individual body development. So night discharge has been fixed as the condition and criterion or sign of maturity. Night discharge means ejaculation of semen during sleep.

2. During the pre-Islamic period, keeping quiet was also considered as a sort of worship or devotion to God. Islam does not allow such ascetic ceremonies and extravagance. So such actions are forbidden. Further it has been stressed that instead of keeping quiet one should engage in good actions, such as enjoining good, forbidding evil, entertaining a guest, remembering Allah and glorifying Him. However, it is better to keep quiet rather than telling lies, indulging in indecent talk or backbiting.


Prohibition of attributing wrong Fatherhood

Chapter 367
Prohibition of attributing wrong Fatherhood

1802. Sa`d bin Abu Waqqas (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who (falsely) attributes his fatherhood to anyone besides his real father, knowing that he is not his father, will be forbidden to enter Jannah.''
[Al-Bukhari and Muslim].

1803. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Do not turn away from your fathers, for he who turns away from his father, will be guilty of committing an act of disbelief.''
[Al-Bukhari and Muslim]

Commentary: To attribute one's fatherhood to someone other than one's real father due to the latter's poverty or in order to live a life of ease and comfort under the care of the person to whom one wishes to attribute his fatherhood, knowing that it is not lawful, is an act of Kufr (disbelief). If someone, however, does so without considering this unlawful act to be lawful, will in fact, be committing a major sin for which he will be punished in Hell-fire. This Hadith stresses the importance of safeguarding one's lineage and that of fulfilling the fathers' rights over their children.

1804. Yazid bin Sharik bin Tariq (May Allah be pleased with him) said: I saw `Ali (May Allah be pleased with him) giving a Khutbah (sermon) from the pulpit and I heard him saying: "By Allah, we have no book to read except Allah's Book and what is written in this scroll. He unrolled the scroll which showed a list of what sort of camels to be given as blood-money, and other legal matters relating to killing game in the sanctuary of Makkah and the expiation thereof. In it was also written: The Messenger of Allah (PBUH) said: `Al-Madinah is a sanctuary from `Air to Thaur (mountains). He who innovates in this territory new ideas in Islam, commits a sin therein, or shelters the innovators, will incur the Curse of Allah, the angels, and all the people, and Allah will accept from him neither repentance nor a ransom on the Day of Resurrection. The asylum (pledge of protection) granted by any Muslim (even of the) lowest status is to be honoured and respected by all other Muslims, and whoever betrays a Muslim in this respect (by violating the pledge) will incur the Curse of Allah, the angels, and all the people; and Allah will accept from him neither repentance nor a ransom on the Day of Resurrection. Whoever attributes his fatherhood to someone other than his (real) father, and takes someone else as his master other than his (real) master without his permission, will incur the Curse of Allah, the angels and all the people, and Allah will accept from him neither repentance nor a ransom on the Day of Resurrection.''
[Al-Bukhari and Muslim].

Commentary: Air is a small mountain near Al-Madinah and Thaur is also a small mountain behind the famous Mount Uhud. The area between these two mountains is the forbidden area. It means that like the Haram of Makkah, no game should be killed, no trees or plants of this area should be cut and no disbeliever or polytheists should enter its boundary. The words "a'dl" and "sarf" translated here as 'repentance' and 'ransom' respectively also mean obligatory and voluntary (Nafl) acts of worship.

It has been established here that any act of disobedience or sin committed in Al-Madinah becomes a greater sin than if it is committed anywhere else. This Hadith also establishes that the claim that `Ali (May Allah be pleased with him) was given some specific knowledge of Khilafah (caliphate), which was not given to anybody else is also false. The Hadith also makes it clear that attributing one's fatherhood to someone other than his real father is a grave sin.

1805. Abu Dharr (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying: "A person who attributes his fatherhood to anyone other than his real father, knowing that he is not his father, commits an act of disbelief. And he who makes a claim of anything which in fact does not belong to him, is none of us. He should make his abode in Hell, and he who labels anyone as disbeliever or calls him the enemy of Allah and he is in fact not so, his charge will revert to him.''
[Al-Bukhari and Muslim].

Commentary: These particular sins mentioned in the Hadith are great and are strictly forbidden. Every Muslim should remain away from them. May Allah save us all from these sins.


Prohibition of doing that which Allah and His Messenger have Prohibited

Chapter 368
Prohibition of doing that which Allah and His Messenger have Prohibited

Allah, the Exalted, says:

"And let those who oppose the Messenger's commandment (i.e., his Sunnah legal ways, orders, acts of worship, statements) (among the sects) beware, lest some Fitnah (disbelief, trials, afflictions, earthquakes, killing, overpowered by a tyrant) should befall them or a painful torment be inflicted on them.'' (24:63)

"And Allah warns you against Himself (His punishment).'' (3:30)

"Verily, (O Muhammad (PBUH)) the Grip (punishment) of your Rubb is severe.'' (85:12)

"Such is the Seizure of your Rubb when He seizes the (population of) towns while they are doing wrong. Verily, His Seizure is painful and severe.'' (11:102)

1806. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Allah, the Exalted, becomes angry, and His Anger is provoked when a person does what Allah has declared unlawful.''
[Al-Bukhari and Muslim].

Commentary: This Hadith warns us against committing sins and all that Allah has forbidden in order to avoid exciting the anger of Allah.


Expiation for the violation of Commandments of Allah

Chapter 369
Expiation for the violation of Commandments of Allah

Allah, the Exalted, says:

"And if an evil whisper from Shaitan (Satan) tries to turn you away (O Muhammad (PBUH)) (from doing good), then seek refuge in Allah.'' (41:36)

"Verily, those who are Al-Muttaqun (the pious), when an evil thought comes to them from Shaitan (Satan), they remember (Allah), and (indeed) they then see (aright).'' (7:201)

"And those who, when they have committed Fahishah or wronged themselves with evil, remember Allah and ask forgiveness for their sins; - and none can forgive sins but Allah - and do not persist in what (wrong) they have done, while they know. For such, the reward is forgiveness from their Rubb, and Gardens with rivers flowing underneath (Jannah), wherein they shall abide forever. How excellent is this reward for the doers (who do righteous deeds according to Allah's Orders)!'' (3:135,136)

"And all of you beg Allah to forgive you all, O believers, that you may be successful.'' (24:31)

1807. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "He who takes an oath and involuntarily says: `By Al-Lat and Al-`Uzza' should at once affirm: `La ilaha illallah (there is no true god except Allah)', and he who says to his companion: `Come let's gamble' should make expiation by giving something in charity.''
[Al-Bukhari and Muslim].

Commentary: Al-Lat and Al-`Uzza were the idols of the polytheists of Arabia. To take oath or swear by them or by anything else besides Allah is an act of disbelief which takes one out of the fold of religion.

If any person swears by anything or anybody else other than Allah, he should recite "La ilaha illa Allah" and refresh and re-establish his belief in Allah. Similarly, if someone indulges in other sins, then he should repent and give in charity according to his resources. The reason is, as Allah (SWT) says: "Verily, the good deeds remove the evil deeds (i.e., small sins).'' (11:114).


Book Eighteen: The Book of Miscellaneous Adadith of Significant values

  • Chapter 370 : Ahadith about Dajjal and Portents of the Hour


Ahadith about Dajjal and Portents of the Hour

Chapter 370
Ahadith about Dajjal and Portents of the Hour

1808. An-Nawwas bin Sam`an (May Allah be pleased with him) reported: One morning the Messenger of Allah (PBUH) made a mention of Dajjal, and he described him to be insignificant and at the same time described him so significant that we thought he was on the date-palm trees (i.e., nearby). When we went to him (the Prophet (PBUH)) in the evening, he perceived the sign of fear on our faces. He said, "What is the matter with you?'' We said: "O Messenger of Allah, you talked about Dajjal this morning raising your voice and lowering it until we thought he was hiding in the palm-trees grove: He said: "Something other than Dajjal make worry about you. If he appears while I am with you, I will defend you against him. But if he appears after I die, then everyone of you is his own defender. Allah is the One Who remains after me to guide every Muslim. Dajjal will be a young man with very curly hair with one eye protruding (with which he cannot see). I compare (his appearance) to that of Al-`Uzza bin Qatan. He who amongst you survives to see him, should recite over him the opening Ayat of Surat Al-Kahf (i.e., Surat 18: Verses 1-8). He will appear on the way between Syria and Iraq and will spread mischief right and left. O slaves of Allah! Remain adhered to the truth.'' We asked: "O Messenger of Allah! How long will he stay on the earth?'' He said, "For forty days. One day will be like a year, one day like a month, one day like a week and the rest of the days will be like your days.'' We said: "O Messenger of Allah! Will one day's Salat (prayer) suffice for the Salat of that day which will be equal to one year?'' Thereupon he said, "No, but you must make an estimate of time and then offer Salat.'' We said: "O Messenger of Allah! How quickly will he walk upon the earth?'' Thereupon he said, "Like cloud driven by the wind (i.e., very quickly). He will come to the people and call them to his obedience and they will affirm their faith in him and respond to him. He will then give command to the sky and it will send its rain upon the earth and he will then send his command to the earth and it will grow vegetation. Then in the evening their pasturing animals will come to them with their humps very high and their udders full of milk and their flanks stretched. He will then come to another people and invite them, but they will reject him and he will leave them, in barren lands and without any goods and chattels! He would then walk through the waste land and say to it: `Bring forth your treasures', and the treasures will come out and follow him like swarms of bees. He will then call a person brimming with youth and strike him with the sword and cut him into two pieces and make these pieces lie at a distance, which is generally between the archer and his target. He will then call that young man and he will come forward, laughing, with his face gleaming out of joy; and it will be at this very time that Allah will send `Isa (Jesus), son of Maryam (Mary) who will descend at the white minaret in the eastern side of Damascus, wearing two garments lightly dyed and placing his hands on the wings of two angels. When he will lower his head, there would fall drops of water from his head, and when he will raise it up, drops like pearls would scatter from it. Every disbeliever who will find his (i.e., `Isa's) smell will die and his smell will reach as far as he will be able to see. He will then search for Dajjal until he will catch hold of him at the gate of Ludd (village near Jerusalem), and will kill him. Then the people, whom Allah will have protected, will come to `Isa son of Maryam, and he will wipe their faces and will inform them of their ranks in Jannah, and it will be under such conditions that Allah will reveal to `Isa these words: `I have brought forth from amongst my slaves such people against whom none will be able to fight, so take these people safely to the mountain.' And then Allah will send Ya'juj and Ma'juj (Gog and Magog people) and they will sworn down from every slope. The first of them will pass the Lake Tabariyah (near the Dead Sea in Palestine) and drink all its water. And when the last of them will pass, he will say: `There was once water there.' Prophet `Isa (PBUH) and his companions will then be so much hard-pressed that the head of an ox will be dearer to them than one hundred dinar, and `Isa along with his companions, will make supplication to Allah, Who will send insects which will attack their (Ya'juj and Ma'juj people) neck until they all will perish like a single person. Prophet, `¦sa and his companions will then come down and they will not find in the earth as much space as a single span which would not be filled with their corpses and their stench. Prophet `Isa and his companions will then again beseech Allah, Who will send birds whose necks will be like those of Bactrian camels, and they will carry them and throw them where Allah will desire. Then Allah will send down rain which will spare no house in the city or in the countryside. It would wash away the earth until it appears like a mirror. Then the earth will be told to bring forth its fruit and restore its blessings; and as a result of this, there will grow such a big pomegranate that a group of people will eat from it and seek shelter under its skin. Milk will be so blessed that the milk of one she-camel will suffice for a large company and the cow will give so much milk, that it will suffice for a whole tribe. The sheep will give so much milk that the whole family will be able to drink out of that, and at that time Allah will send a pleasant wind which will soothe people even under their armpits, and will take the life of every Muslim and true believer, and only the wicked will survive. They will commit adultery in public like asses and the Resurrection Day will be held.''
[Muslim].

Commentary: In the above statement we find details about the signs of the Day of Resurrection, the appearance of Dajjal (Antichrist), the coming of Prophet `Isa - son of Maryam, and the appearance of Gog and Magog people. We also find all the important events which will happen during these times. Here, we also note the havoc of Dajjal and the destruction of Gog and Magog people. Then finally the killing of them by the efforts of Prophet `Isa and his prayers.

1809. Rib`i bin Hirash (May Allah be pleased with him) said: I accompanied Abu Mas`ud Al-Ansari to Hudaifah bin Al-Yaman (May Allah be pleased with them). Abu Mas`ud said to him: "Tell us what you heard from the Messenger of Allah (PBUH) about Dajjal (the Antichrist).'' Hudaifah said: He (PBUH) said, "Dajjal will appear, and with him will be water and fire. That which people consider to be water will in fact be a burning fire, and that which people will consider to be fire will in fact be cool and sweet water. He who from amongst you happens to face him, should jump into that which he sees as fire for that will be nice and sweet water.'' Abu Mas`ud said: "I have also heard this from the Messenger of Allah (PBUH).''
[Al-Bukhari and Muslim]

1810. `Abdullah bin `Amr bin Al-`As (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "Dajjal (the Antichrist) will appear in my Ummah and he will stay in the world for forty. I do not know whether this will be forty days or forty months or forty years. Allah will then send (Prophet) `Isa (Jesus), son of Maryam (Mary). `Isa will pursue him and slaughter him. Then people will survive for seven years (i.e., after the demise of `Isa) in the state that there will be no rancour between two persons. Then Allah will send a cool breeze from the side of Ash-Sham. None will remain upon the face of the earth having the smallest particle of good or Faith in him but he will die, so much so that even if someone amongst you will enter the innermost part of a mountain, this breeze will reach that place also and will cause him to die. Only the wicked people will survive and they will be as fast as birds (i.e., to commit evil) and as ferocious towards one another as wild beasts. They will never appreciate the good, nor condemn evil. Then Shaitan (Satan) will come to them in the garb of a man and will say: `Will you not obey me?' They will say: `What do you order us to do?' He will command them to worship idols. They will have abundance of sustenance and will lead comfortable lives. Then the Trumpet will be blown. Every one hearing it, will turn his neck towards it and will raise it. The first one to hear that Trumpet will be a man who will be busy repairing the basin for his camels. He will become unconscious. Allah will send, or will cause to send, rain which will be like dew and there will grow out of it (like wild growth) the bodies of the people. Then the second Trumpet will be blown and they will stand up and begin to look around. Then it will be said: `O people! Go to your Rubb.' Then there will be a command: `Make them stand there.' After it they will be called to account. Then it will be said: `Separate from them the share of the Fire.' It will be asked: `How much?' It will be said: `Nine hundred and ninety-nine out of every thousand.' That will be the Day which will make children hoary-headed men because of its terror and that will be the Day when the Shin will be uncovered.''
[Muslim].

Commentary: The question arises as to what is the meaning of the phrase - the Shin will be uncovered - at this place? Some people say that it refers to the calamities and troubles of the Day of Judgement. But according to a reliable narration, it refers to an act of Allah of uncovering His Shin in a way which befits His Majesty. As believers, we must confirm Allah's all Qualities which He has stated in the Qur'an or mentioned through His Messenger (PBUH) without changing them or ignoring them completely or twisting their meanings or giving resemblance to any of the created things. What is meant by the uncovering of the Shin of Allah is something we can neither understand nor describe. We can only believe in it without understanding the real explanation of it, in the same way we believe in the Eye or Ear of Allah. We should believe in all these things as mentioned in the Qur'an and Hadith without trying to go into the explanation. This is the view of Ahlus-Sunnah wal-Jama`ah to which we should stick. (See Tafsir Ahsan-ul-Bayan)

Then all the Muslims will prostrate before Him. However, those people who used to pray and prostrate before Him in their worldly lives only for showing off or for gaining good reputation, will not be able to prostrate before Him on this occasion. Their spines will become stiff like a wooden board and it would become impossible for them to bend. (Sahih Al-Bukhari, Tafsir Surat An-Nur and Al-Qalam).

1811. Anas bin Malik (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "There will be no land which will not be trampled by Dajjal (the Antichrist) but Makkah and Al-Madinah; and there will be no passage leading to them which will not be guarded by the angels, arranged in rows. Dajjal will appear in a barren place adjacent to Al-Madinah and the city will be shaken three times. Allah will expel from it every disbeliever and hypocrite.''
[Muslim].

1812. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Dajjal (the Antichrist) will be followed by seventy thousand Jews of Isfahan and will be dressed in robes of green coloured satin.''
[Muslim].

Commentary: Isfahan is a city in Persia (Iran). Tailasan green sheet (is the dress of the Sheikhs of the non-Arab nations).

1813. Umm Sharik (May Allah be pleased with her) reported: I heard the Prophet (PBUH) saying, "People will run away from Dajjal (the Antichrist) seeking shelter in the mountains.''
[Muslim].

1814. `Imran bin Hussain (May Allah be pleased with them) reported: I heard the Messenger of Allah (PBUH) saying, "Between time of the creation of Adam and the Resurrection Day, there is nothing greater than the mischief of Dajjal (the Antichrist).''
[Muslim].

1815. Abu Sa`id Al-Khudri (May Allah be pleased with him) reported: I heard the Prophet (PBUH) saying, "Dajjal (the Antichrist) will come forth and a person from amongst the believers will go towards him and the armed watchmen of Dajjal will meet him and they will say to him: `Where do you intend to go?' He will say: `I intend to go to this one who has appeared.' They will say to him: `Don't you believe in our lord (meaning Dajjal)?' He will say: `There (i.e., we know Him to be Allah, Alone, without any partners) is nothing hidden about our Rubb.' Some of them will say: `Let us kill him', but some others will say: `Has your lord (Dajjal) not forbidden you to kill anyone without his consent?' So they will take him to Dajjal. When the believer will see him, he will say: `O people! This is Dajjal about whom the Messenger of Allah (PBUH) has informed us.' Dajjal will have him laid on his stomach and have his head. He will be struck on his back and on his stomach. Dajjal will ask him: `Don't you believe in me?' He will say: `You are the false Messiah.' He will then give his order to have him sawn with a saw into two from the parting of his hair up to his legs. After that Dajjal will walk between the two halves and will say to him: `Stand up', and he will stand on his feet. He will then say to him: `Don't you believe in me?' The person will say: `It has added to my insight that you are Dajjal'. He will add: `O people! He will not be able to behave with anyone amongst people in such a manner after me.' Dajjal will try to kill him. The space between his neck and collarbone will turn into copper and he will find no way to kill him. So he will catch hold of him by his hand and feet and throw him into (what appears to be the fire). The people will think that he has been thrown into the fire whereas he will be thrown into Jannah.'' The Messenger of Allah (PBUH) added, "He will be the most eminent amongst the people with regard to martyrdom near the Rubb of the worlds.''
[Muslim]

Commentary: In this narration we find the description of a believer's steadfastness and forbearance and his final martyrdom while facing the wickedness and temptation of the mischief of Dajjal, i.e., Antichrist.

Here, we find that the part of his neck will turn into copper which could either happen in reality or, according to another interpretation, that he (Dajjal) will not be able to kill him. Allah knows better, as Allah can do whatever He likes, or it may just be a statement like a parable or a simile and some people think that this refers to the fact that Dajjal will not be able to cut his neck. But it is better to consider it in terms of reality.

1816. Al-Mughirah bin Shu`bah (May Allah be pleased with him) said: No one asked the Messenger of Allah (PBUH) more about Dajjal than I asked him. He said to me, "He will not harm you.'' I said: "O Messenger of Allah, it is reported that he will have with him a mountain of bread and a river full of water.'' Thereupon he said, "He (Dajjal) is far too worthless and insignificant near Allah (to let him deceive the believers).''
[Al-Bukhari and Muslim].

Commentary: The last part of the Hadith means that, although Dajjal will have great resources and methods of misleading people, the true believers will not be deceived by his tricks; on the contrary, they will increase in Faith (as what the Prophet (PBUH) said about Dajjal is true).

1817. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "There has not been a Prophet who has not warned his Ummah of that one-eyed liar (Dajjal). Behold, he is blind in one eye and your Rubb (Allah) is not blind. On his forehead are the letters: (K.F.R.) (meaning Kafir- disbeliever).''
[Al-Bukhari and Muslim].

1818. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Let me tell you something about Dajjal (the Antichrist) which no Prophet had told his people. He is blind (in one eye) and will bring with him something like Jannah and Hell; but what he calls Jannah will be in fact Hell.''
[Al-Bukhari and Muslim].

1819. `Abdullah bin `Umar (May Allah be pleased with them) said: One day the Messenger of Allah (PBUH) mentioned Al-Masih Dajjal (the Antichrist) in the presence of the people and said, "Verily, Allah is not one-eyed but Al-Masih Ad-Dajjal is blind in the right eye which looks like a swollen grape.''
[Al-Bukhari and Muslim]

Commentary: All these narrations about the mischief of Dajjal are correct and have been narrated through reliable narrators, and all scholars agree on their being true. They have been reported by Al-Bukhari and Muslim, whose narrations are unanimously accepted by the `Ulama'.

The second coming of the Prophet 'Isa (Jesus) from the heavens is proved on the basis of such reliable and true narrations that none can contradict them. Before the Day of Resurrection all these things will happen, and it is essential to believe in them.

Dajjal would be a descendant of the Jews, and he will be called Dajjal because of his mischief. The meaning of Dajjal is `one who greatly resorts to fraud and deception'.

Allah will also give him some extraordinary powers to test the belief of the Muslims. Dajjal will claim to be the lord of the world. A large portion of the Jews will be with him. He has also been named as Al-Masih Ad-Dajjal in some narrations. Jesus, son of Mary (Peace be upon them) will have the honour of killing him.

1820. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah(PBUH) said, "The Last Hour will not come until the Muslims fight against the Jews, until a Jew will hide himself behind a stone or a tree, and the stone or the tree will say: `O Muslim, there is a Jew behind me. Come and kill him,' but Al-Gharqad tree will not say so, for it is the tree of the Jews.''
[Al-Bukhari and Muslim].

Commentary: Gharqad is a thorny plant which is well-known in the area of Palestine. Allah can bestow the power of speech to whatever thing He likes. When Allah wills, He will give mastery to the Muslims. He will help them even by means of plants and stones which will assist the Muslims against the Jews by informing them about the whereabouts of the Jews.

The Jews have predominance over the Muslims in spite of the fact that they are a minority. But according to this true narration, the situation will definitely change before the Day of Resurrection, and the Muslims will dominate the Jews. Allah is the Master and Rubb of everything.

1821. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "By Him in Whose Hand my soul is, the world will not come to an end until a man passes by a grave and will lie over it saying, `Would that I were in this grave (i.e., dead)!' Not he will say so because of religious reasons but because of widespread mischief and severe trials of this world.''
[Al-Bukhari and Muslim].

Commentary: There would be such disasters and agony in the world that people will prefer death to life under such conditions. This situation will arise before the Day of Resurrection, and the Day of Judgement will dawn on such wicked people.

1822. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The Hour will not come to pass before the River Euphrates dries up to unveil the mountain of gold, for which people will fight. Ninety-nine out of one hundred will die (in the fighting) and every man amongst them will say: `Perhaps I may be the only one to remain alive.'''

Another narration is: "The time is near when the River Euphrates will dry up to unveil a treasure of gold. Whosoever may be alive at that time, should not take anything of it.''
[Al-Bukhari and Muslim]

Commentary: The word "Yahsir" means unveil or uncover, i.e., the river will dry up and gold will be discovered underneath its bottom when Allah would like to do so. This will also surely take place before the Day of Judgement. When this incident will take place, only those people would remain safe who will be free from worldly greed and will not try to get this gold.

1823. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "People will desert Al-Madinah in spite of it being in better condition except for wild beasts and birds. The Last Hour will happen upon two shepherds of the tribe of Muzainah. They will enter Al-Madinah driving their sheep but will find it full of wild beasts and would turn away. When they will arrive at the hill named Thaniyyat-ul-Wada` they will fall on their faces.''
[Al-Bukhari and Muslim].

Commentary: According to some scholars like Al-Qadi `Iyad, this prophecy has already been fulfilled, when the caliphate was shifted from Al-Madinah to Syria and Mesopotamia, although Al-Madinah was superior to these places in every way, worldly or otherwise, scholars were in abundance and the people were well off. However, others say that the prophecy has not been fulfilled yet, and that it will be fulfilled shortly before the Day of Judgement; they hold this view because the conditions described in the narration have not taken place. This second view seems to be more correct.

1824. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Prophet (PBUH) said, "From your caliphs there will be one in the Last Days who will distribute wealth without counting it.''
[Muslim].

Commentary: Here the abundance of wealth during the time of a caliph has been prophesied. This also refers to the last days of the world.

1825. Abu Musa Al-Ash`ari (May Allah be pleased with him) said: The Prophet (PBUH) said, "A time will come when a man will go about with alms from his gold and will not find anyone to receive it. One man will be seen being followed by forty women dependant upon him on account of the scarcity of men and excess of women.''
[Muslim].

Commentary: This Hadith also reveals one of the prophecies of the Prophet (PBUH) which have not been fulfilled yet. One of them is that wealth will be abundant and females will greatly exceed the males in number. This may happen due to wars, when more males will be killed, or the birth rate of females may exceed that of the males.

1826. Abu Hurairah (May Allah be pleased with him) reported: The Prophet (PBUH) said, "A man bought a piece of land from another man, and the buyer found a jar filled with gold in the land. The buyer said to the seller: `Take your gold, as I bought only the land from you and not the gold.' The owner of the land said: `I sold you the land with everything in it.' So both of them took their case before a third man who asked: `Have you any children?' One of them said: `I have a boy.' The other said, `I have a girl.' The man said: `Marry the girl to the boy and spend the money on them; and whatever remains give it in charity.'''
[Al-Bukhari and Muslim].

Commentary: This is the story of some people from the past, in which exemplary honesty, piety and the will to abstain from the doubtful property has been described. But as far as the law of Shari`ah is concerned, it appears that in the transaction of land, any buried treasure will not be included in the sale. It will be considered quite separately and apart from the sale of the land. If the previous owner says that the treasure belongs to him and he forgot to take it out, then it will be considered as his property and not the property of the buyer of the land. But if he shows ignorance about it, then it will be considered under the title of "Rikaz". In such a case, one-fifth of it goes to the public treasury and the rest to the owner of the land. Rikaz refers to any buried treasure which is discovered in any land.

1827. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "There were two women, each had her child with her. A wolf came and took away the child of one of them. One woman said to her companion: `The wolf has taken your son.' The other said: `It has taken your son.' So both of them took the dispute to Prophet Dawud (David) (PBUH) who judged that the boy should be given to the older lady. Then they went to Prophet Sulaiman (Solomon) (PBUH) son of Dawud and put the case before him. Prophet Sulaiman said: `Give me a knife so that I may cut the child into two and give one half to each of you.' The younger woman said: `Do not do so; may Allah bless you! He is her child.' On that Prophet Sulaiman decided the case in favour of the younger woman.''
[Al-Bukhari and Muslim].

Commentary: Prophet Sulaiman (Solomon) (PBUH) went to the depth of the matter by wisdom bestowed by Allah and the power of decision using a device or a trick as a method of discovering the truth. He used this trick to discover the truth and not to evade it. Such a trick is not forbidden in the law and there is no doubt in its being permitted. However, those tricks which are used to avoid the law are a great sin for which the Jews are well-known. May Allah save us from such things.

1828. Mirdas Al-Aslami (May Allah be pleased with him) said: The Prophet (PBUH) said, "The pious men will depart one after another, the dregs of people, like the sediment of barley or dates will remain; Allah will not raise them in value and esteem.''
[Al-Bukhari].

Commentary: The Hadith shows that the demise of the pious people is one of the signs of the nearness of the Day of Resurrection. It also shows that during the last days near the Day of Resurrection, pious persons will not remain and only the wicked people will inhabit the earth and the Day of Judgement will dawn on such bad people.

1829. Rifa`ah bin Rafi` Az-Zuraqi (May Allah be pleased with him) said: Jibril (Gabriel) came to the Prophet (PBUH) and asked him: "How do you estimate among you those who participated in the battle of Badr?'' He replied, "They were the best of Muslims'' (or he may have said something similar to that). Jibril said: "The same is the case with the angels who were at Badr.''
[Al-Bukhari].

Commentary: The Hadith highlights the superiority of those Companions, as well those angels, who participated in the battle of Badr against the forces of Kufr. The Qur'an confirms the fact that the angels fought along with Muslims in this historic battle.

1830. Ibn `Umar (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "If Allah afflicts punishment upon a nation, it befalls the whole population indiscriminately and then they will be resurrected and judged according to their deeds.''
[Al-Bukhari and Muslim].

Commentary: When Allah's punishment comes to pass, it does not distinguish between the upright and the wicked. However, the pious people will be saved from punishment after their death while the wicked ones will be punished in the Hell. May Allah save us from all types of punishments.

1831. Jabir (May Allah be pleased with him) said: There was a trunk of a date-palm tree upon which the Prophet (PBUH) used to recline while delivering Khutbah (sermon). When a pulpit was placed in the mosque, we heard the trunk crying out like a pregnant she-camel. the Prophet (PBUH) came down from the pulpit and put his hand on the trunk and it became quiet.

Another narration is: The Prophet (PBUH) used to stand by a tree or a date-palm on Friday (to give the Khutbah). Then an Ansari woman or man said, "O Messenger of Allah! Shall we make a pulpit for you?'' He replied, "If you wish.'' So they made a pulpit for him and when it was Friday, the Prophet (PBUH) sat on the pulpit [to deliver the Khutbah (sermon)] and the trunk of the date-palm on which he used to recline cried out as if it would split asunder.

Another narration is: It cried like a child and the Prophet (PBUH) descended (from the pulpit) and embraced it while it continued moaning like a child being quietened. The Prophet (PBUH) said, "It was crying for (missing) what it used to hear of Dhikr near it.''
[Al-Bukhari].

Commentary: Ibn Hajar said that there is evidence in this Hadith that Allah can endow inanimate objects with a special sense or feeling like that of animals. The Hadith also shows one of the numerous miracles of the Messenger of Allah (PBUH).

1832. Abu Tha`labah Al-Khushani (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Allah, the Exalted, has laid down certain duties which you should not neglect, and has put certain limits which you should not transgress, and has kept silent about other matters out of mercy for you and not out of forgetfulness, so do not seek to investigate them.''
[Ad-Daraqutni and others]

Commentary: According to Sheikh Al-Albani there is a break in the chain of this narration. He has given the details about it in his book. But some other scholars have declared it in the category of Hasan narrations. Even Imam An-Nawawi has termed it as Hasan. For details refer to Mustadrak Al-Hakim, Vol. 4: P. 115; Majma` Az-Zawaid, Vol. 7: P.75; Tirmidhi: Chapter relating to Dress, No. 1726; Ibn Majah: Book of Food: Chapter: Eating of Cheese and Butter No:3367; As-Sunan Al-Kubra by Al Baihaqi: Book of Sacrifice, Chapter: What has been said about hyena and fox.

According to Imam As-Sam`ani, this Hadith is very important, as the details of important things have been given here. Whosoever leads his life accordingly, will surely succeed in this life and the Hereafter.

1833. `Abdullah bin Abu `Aufa (May Allah be pleased with them) said: We accompanied the Messenger of Allah (PBUH) in seven expeditions, and we ate locusts.
[Al-Bukhari and Muslim].

Commentary: Locust is a type of insect that flies in huge groups, destroying all the plants and crops. This Hadith highlights the permissibility of eating locusts.

1834. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "A believer should not be stung twice from the same hole.''
[Al-Bukhari and Muslim].

Commentary: This Hadith makes it clear that if a Muslim faces a loss from some place, he should remain careful lest he may be deceived again and again.

1835. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "There are three (types of) people with whom Allah will neither speak on the Day of Resurrection nor purify them (from sins) and there will be a painful chastisement for them: A person who has spare water in a desert and he refuses to give it to the traveller; a person who sells a commodity to another person after the afternoon prayer and swears by Allah that he has bought it at such and such price, and the buyer pays him accordingly though in reality it was not true; and a person who pledges allegiance to an Imam (leader) just for some worldly benefit, and then if the Imam bestows on him (something out of that) he fulfills his allegiance, and if does not give him, he does not fulfill it.''
[Al-Bukhari and Muslim].

1836. Abu Hurairah (May Allah be pleased with him) said: The Prophet (PBUH) said, "Between the two Blowing of the Trumpet there will be an interval of forty.'' The people said, "O Abu Hurairah! Do you mean forty days?'' He said, "I cannot say anything.'' They said, "Do you mean forty years?'' He said, "I cannot say anything.'' They said, "Do you mean forty months?'' He said, "I cannot say anything. The Prophet added: `Everything of the human body will perish except the last coccyx bone (end part of the spinal cord), and from that bone Allah will reconstruct the whole body. Then Allah will send down water from the sky and people will grow like green vegetables'.''
[Al-Bukhari and Muslim].

Commentary:
1. When Israfil blows the Trumpet the first time, by Allah's Leave, all those who are in the heavens and on earth will swoon away, except him whom Allah will. This will be the first Blowing. Then, it will be blown a second time, they will become alive and will emerge from their graves. These Blowings are known as the `Blowings of Fainting and Rising'. As regard the interval between these two Blowings, the narrator of the narration, Abu Hurairah (May Allah be pleased with him), could not say anything when he was asked about it; as he himself did not know it. But in other narrations the interval has been mentioned as forty years.

2. The earth eats away the whole body of humans except the bodies of the Prophets. However, only the end part of the spinal cord remains intact. How it remains intact is known to Allah, but from it mankind will be created again.

3. Bodies will rise from the earth as vegetation springs out from the earth after the rainfall.

1837. Abu Hurairah (May Allah be pleased with him) reported: Once the Prophet (PBUH) was speaking to us when, a bedouin came and asked him: "When will the Last Day be?'' The Messenger of Allah (PBUH) continued his talk. Some of those present thought that he had heard him but disliked the interruption and the other said that he had not hear him. When the Messenger of Allah (PBUH) concluded his speech he asked, "Where is the one who inquired about the Last Day?'' The man replied: "Here I am.'' The Messenger of Allah (PBUH) replied, "When the practice of honouring a trust is lost, expect the Last Day.'' He asked: "How could it be lost?'' He replied, "When the government is entrusted to the undeserving people, then wait for the Last Day.''
[Al-Bukhari].

Commentary: Here a very important sign of the nearness of the Day of Judgement has been mentioned: The affairs of the world will be in the hands of wicked and undeserving people. The sinners and wicked people will become the leaders of the world. The preaching pulpits would also be occupied by people who would be greedy and ignorant.They will be devoid of piety and abstinence.

1838. Abu Hurairah (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "Your leaders will lead you in Salat (prayer). If they conduct it properly, you and they will be rewarded; but if they make mistakes you will earn the reward and they will be held responsible (for the mistakes).''
[Al-Bukhari].

Commentary: In this narration, there is a mention of one of the signs of the nearness of the Day of Judgement: Muslims will be led in their prayers as well as worldly affairs by ignorant, undeserving rulers. Whoever offers prayers with them and behind them according to the Sunnah, then both of them will get the reward. Otherwise the reward will be established with the followers and the burden of the mistakes will be placed on the rulers' shoulders.

1839. Abu Hurairah (May Allah be pleased with him) said in the interpretation of the Ayah reported: "You are the best of peoples ever raised up for (the benefit of) mankind...'' (3:110): The best for mankind are those who bring them with chains round their necks till they embrace Islam (and thereby save them from the eternal punishment in the Hell-fire, and make them enter Jannah in the Hereafter).''
[Al-Bukhari].

Commentary: This is in a way the explanation of the concerned Verse of the Qur'an. Abu Hurairah (May Allah be pleased with him) says: In this Verse those fighters have been named as the best of the Ummah who fight with the infidels whom they take prisoners and they ultimately accept Islam. Hence, they become a means of acceptance of Faith to them, and are entitled to more rewards from Allah.

1840. Abu Hurairah (May Allah be pleased with him) said: the Prophet (PBUH) said, "Allah marvels at those people who enter Jannah in chains.''
[Al-Bukhari].

Commentary: The meaning of this Hadith is also the same as the Hadith mentioned before it. This means that after taking captives, the Muslims inform them about the teachings of Islam so that after accepting Islam they may deserve Jannah, which is the ultimate success. Allah says, "And whoever is removed away from the Fire and admitted to Jannah, he indeed is successful.'' (3:185) This Hadith urges Muslims to call to Islam, it also urges those Mujahidun to invite their prisoners to Islam to save them from the chastisement of the Hell-fire.

1841. Abu Hurairah (May Allah be pleased with him) said: the Prophet (PBUH) said, "The dearest parts on the face of the earth near Allah are its mosques, and the most hated parts near Allah are its markets.''
[Muslim].

Commentary: The superiority of the mosques is self evident. People pray and worship Allah in the mosques and recitation of Qur'an goes on there. While in the market places people forget to remember Allah and indulge in such forbidden acts as fraud, lies and gossip. In fact, it is not the place itself which is disliked but the bad things which are bound to happen in it, they are not the places of choice and are not liked.

1842. Salman Al-Farisi (May Allah be pleased with him) said: The Prophet (PBUH) said, "Do not, if you can help, be the first to enter the market and the last to leave it because it is an arena of Satan and the standard of Satan is set there.''
[Muslim].

There are other narrations with some variation in the wordings.

Commentary: It is disliked (Makruh) to frequently visit the markets, where there is overwhelming influence of the Satan. The more one goes there, the more will one be influenced by the temptations of the devil.

1843. `Asim Al-Ahwal said: `Abdullah bin Sarjis (May Allah be pleased with him) said to the Messenger of Allah (PBUH): "O Messenger of Allah! May Allah forgive all your sins!'' The Messenger of Allah (PBUH) said, "And yours also.'' `Asim reported: I asked `Abdullah: "Did the Messenger of Allah (PBUH) seek forgiveness for you?'' He replied: "Yes, and for you also.'' Then he recited the Verse: "Seek forgiveness for your sins and for the believing men and the believing women.'' (47:19)
[Muslim].

Commentary: Although the Prophet (PBUH) is free from sins, it is permissible, as a token of Allah's honour and care for him, to pray for his greater salvation and blessings. It is also in a way a method of paying respects to him. The Hadith also shows the noble character of the Prophet (PBUH) who used to reciprocate compliments and good deeds.

1844. Abu Mas`ud Al-Ansari (May Allah be pleased with him) said: The Prophet (PBUH) said, "One of the admonitions of the previous Prophets which has been conveyed to people is that if you have no modesty, you can do whatever you like.''
[Al-Bukhari].

Commentary: This does not mean that doing everything is allowed for a shameless person. It is like giving an information that when a person loses the feeling of shame, then he does not mind doing anything. For this reasons the western nations intend to finish the feeling of shame and remorse among the Muslims, which is a landmark and a criterion of Islam. They want to do away with this criterion so that Muslims may indulge in shameless things happily. Unfortunately, the western people are succeeding in their designs and the Islamic social life is also tending to be shameless like its western counterpart.

1845. Ibn Mas`ud (May Allah be pleased with him) reported: The Prophet (PBUH) said, "The first matter concerning which people will be judged on the Day of Resurrection will be the matter of blood.''
[Al-Bukhari and Muslim]

Commentary: In another Hadith, it has been stated that on the Day of Judgement, the first thing about which people will be questioned will be As-Salat (the five daily prayers). There is no contradiction in the two narrations. Among the duties of Allah, the first thing to be reckoned would be As-Salat; while among the mutual right of humans, the first thing to be decided would be murder. From this narration the value of human life becomes very significant.

1846. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) said, "Angels were created from light, jinns were created from a smokeless flame of fire, and `Adam was created from that which you have been told (i.e., sounding clay like the clay of pottery).''
[Muslim].

Commentary: The angels are the creation of Allah which He created from light. Their bodies are so subtle that they can assume any form they like. The jinn are also an unperceptible creation of Allah. They have also been bestowed with such powers as are not possessed by humans. Satan also belongs to the jinn. Man has been created from sounding clay. The Hadith states the Great and the Perfect Powers of Allah that He can create whatever He likes from whatever He likes, and He can do whatever He wishes.

1847. `Aishah (May Allah be pleased with her) said: The conduct of the Prophet (PBUH) was entirely according to the Qur'an.
[Muslim in a long Hadith].

Commentary: This Hadith shows that the life of the Prophet (PBUH) and all modes of his actions were on the pattern given in the Qur'an. In his life we can observe the perfection of obedience to all the commands of the Qur'an. In fact, he was a living example of the Qur'an.

1848. `Aishah (May Allah be pleased with her) reported: The Messenger of Allah (PBUH) said, "He who loves to meet Allah, Allah loves to meet him; and he who dislikes to meet Allah, Allah abhors to meet him.'' I (`Aishah) said: "O Messenger of Allah! So far as the feelings of aversion against death is concerned, we all have this feeling.'' Thereupon he said, "I do not mean that. What I meant is that when a (true) believer is given the glad tidings of the Mercy of Allah, His Pleasures and His Jannah (at the time of death), he loves to meet Allah, and Allah also loves to meet him. When a disbeliever is given the news of the Torment of Allah and His Wrath (at the time of death), he dislikes to meet Allah and Allah also abhors to meet him.''
[Muslim].

Commentary: The glad tidings of Jannah are given to the believers and the bad news of punishment are given to the disbelievers at the time of death. So a believer starts longing to meet Allah as a result of the good news he receives at that time, and the disbeliever begins to wish that he may not die and, therefore, avoid Allah's punishment as a result of the bad news he receives at that time.

1849. Safiyyah bint Huyai (May Allah be pleased with him), the Mother of the Believers, said: I came to visit the Prophet (PBUH) while he was in the state of I`tikaf [(seclusion) in the mosque during the last ten days of Ramadan]. After having talked to him, I got up to return. The Prophet (PBUH) also got up with me and accompanied me a part of the way. At that moment two Ansari man passed by. When they saw him they quickened their pace. The Prophet (PBUH) said to them, "Do not hurry. She is Safiyyah, daughter of Huyai, my wife.'' They said: "Subhan Allah (Allah is free from imperfection)! O Messenger of Allah! (You are far away from any suspicion).'' The Messenger of Allah (PBUH) said, "Satan circulates in a person like blood (in the blood streams). I apprehended lest Satan should drop some evil thoughts in your minds.''
[Al-Bukhari and Muslim].

Commentary: Even just a passing thought of some thing undesirable about the Prophet (PBUH) is dangerous for belief. In order to put an end to this evil suspicion, he stopped the two Companions and explained to them the situation. This was done lest the devil may create some doubt in the mind of the two Companions. The conclusion is that, if at any place there is some far fetched chance of creation of bad opinion about somebody, then it is necessary to give an explanation lest some doubt may arise in some body's mind. This is particularly essential for `Ulama', who should remain aloof from such occasions and places, lest the people may start doubting their integrity and piety.

1850. Al-`Abbas bin `Abdul-Muttalib (May Allah be pleased with him) said: I was in the company of the Messenger of Allah (PBUH) on the day of (the battle of) Hunain. Abu Sufyan bin Al-Harith and I did not leave the Messenger of Allah (PBUH) throughout the battle. The Messenger of Allah (PBUH) was riding on his white mule. When the Muslims had an encounter with the pagans, Muslims took to their heels. The Messenger of Allah (PBUH) began to urge his mule towards the disbelievers, holding the bridle of his mule. I was trying to restrain it from going very fast, and Abu Sufyan was holding the stirrup of the mule of the Messenger of Allah (PBUH). The Messenger of Allah (PBUH) said, "O Abbas! Call out the People of As-Samurah [i.e., those people who had made the covenant under the tree (i.e., Bai`ah Ridwan)].'' `Abbas called out at the top of his voice: "Where are the People of As-Samurah.'' `Abbas said: As soon as they heard my voice, they rushed towards the Prophet (PBUH) like a cow turning towards her calf. They were shouting: "Here we are.'' Soon they began to fight the infidels. Then there was a call for Ansar. Those who called out to them shouted: "O you the people of Ansar! O you the people of Ansar!'' They ended their call at Banu Al-Harith bin Al-Khazraj. The Messenger of Allah (PBUH) who was riding on his mule looked at their fight with his neck stretched forward and he said, "This is the time when the fight is raging hot.'' Then the Messenger of Allah (PBUH) took pebbles and threw them in the face of the disbelievers. He said, "By the Rubb of Muhammad, the disbelievers will be defeated.'' I continued to watch until I found that their force was subdued and they began to retreat.
[Muslim].

Commentary:
1. Here is the factual proof of the bravery and greatness of the Prophet (PBUH). We see that initially when the Companions were perturbed and they scattered here and there, he alone continued his march towards the enemy. He did not feel even the slightest fear or worry. In the end his steadfastness compelled others to return and fight the enemy.

2. In fact, they had not receded far. They had got confused for a while. The reason for this confusion was the continuous and sudden volley of arrows which was quite unexpected for them. However, at the call of Al-`Abbas (May Allah be pleased with him) they at once turned back to fight. Had they gone far off, their sudden re-organisation and collecting again would not have been possible.

3. Here is the proof of a miracle of the Prophet (PBUH) as well; the throwing of few pebbles from his side caused the defeat of the enemy.

4. Here, the Muslims were taught a lesson that the real power in the battlefield is the strength of Belief and the Help of Allah. The position of the armaments and other things is secondary. So, one should not depend on these means and resources alone. Otherwise, one will certainly face defeat in spite of large number of soldiers and better means, as happened initially in the battle of Hunain. The trust should be on Allah and His Special Help. His Will alone is the deciding factor in every matter.

1851. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "O people! Allah is Pure and, therefore, accepts only that which is pure. Allah has commanded the believers as He has commanded His Messengers by saying: `O Messengers! Eat of the good things, and do good deeds.' (23:51) And He said: `O you who believe (in the Oneness of Allah - Islamic Monotheism)! Eat of the lawful things that We have provided you...''' (2:172). Then he (PBUH) made a mention of the person who travels for a long period of time, his hair are dishevelled and covered with dust. He lifts his hand towards the sky and thus makes the supplication: `My Rubb! My Rubb!' But his food is unlawful, his drink is unlawful, his clothes are unlawful and his nourishment is unlawful, how can, then his supplication be accepted?''
[Muslim].

Commentary: For the grant of prayer, honest earning is essential. Allah accepts charity only if it has been earned in an honest way. Moreover, before any pious action, honest earning for living is essential; otherwise good actions will also go waste.

1852. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "There are three (types of) people whom Allah will neither speak to on the Day of Resurrection nor will He purify them (i.e., from their sins), nor will look upon them; and they will have a painful chastisement. These are: An old man who commits fornication; a king who is a great liar and a poor man who is proud.''
[Muslim]

Commentary: From here it can be concluded that if it is easy for someone to avoid a sin and he does not remain away from it, then he is a greater sinner than a person for whom it is comparatively difficult to avoid that sin.

1853. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Saihan (Oxus), Jaihan (Jaxartes), Al-Furat (Euphrates) and An-Nil (Nile) are all from the rivers of Jannah.''
[Muslim].

Commentary: This Hadith shows the superiority of these rivers. This superiority is manifested in the purity of their water and the spread of Islam all around them. Some scholars like Imam As-Suyuti take the meaning of this Hadith literally. In any case, only Allah knows their reality.

Saihan and Jaihan are two rivers in the country of Syria. These are different from Saihun and Jaihan in the territory of Khurasan (see Mu`jam Al-Buldan of Baladhri, 2/227; 3/333). Some maintain that Saihun is in India and Jaihun in Khurasan, the Euphrates and the Nile are well-known.

1854. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) took hold of my hand and said, "Allah, the Exalted and Glorious, created the earth on Saturday, the mountains on Sunday, the trees on Monday, the things entailing labour on Tuesday, light on Wednesday, He spread out animals of all kinds on Thursday, and created Adam in the afternoon on Friday, and it was the last hour of Friday between the afternoon and the night.''
[Muslim].

Commentary: What does "Day'' mean, and how long can it be? Its reality only Allah knows. We observe a day of 24 hours. However, the days of the formation of the universe are evidently different from our earthly days. According to the Arabic language, a day may mean just a moment, but also aeons of time. In the Qur'an also, Allah has mentioned that a `day' may be of one thousand or fifty thousand years. Al-Hafiz Ibn Kathir mentions in his Tafsir (1/69) that this is one of the Ahadith classified as Gharib (strange) in Sahih Muslim. Ibn Al-Madini, Al-Bukhari and many others have spoken about it, and have attributed to Ka`b Al-Ahbar; and it may be that Abu Hurairah heard it from Ka`b Al-Ahbar, but some narrators attributed it to the Prophet (PBUH). See Al-Bukhari's commentary in At-Tarikh Al-Kabir (1/413).

1855. Abu Sulaiman Khalid bin Al-Walid (May Allah be pleased with him) said: In the battle of Mu'tah, seven swords were broken in my hand, and all that remained with me was a Yemeni sword.
[Al-Bukhari].

Commentary: Mu'tah is a place near Syria. The battle which took place here is known as the battle of Mu'tah. This Hadith mentions the bravery and superiority of Khalid bin Al-Walid.

1856. `Amr bin `Al-`As (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "When a judge utilizes his skill of judgement and comes to a right decision, he will have a double reward, but when he uses his judgement and commits a mistake, he will have a single reward.''
[Al-Bukhari and Muslim]

Commentary: In such matters about which there is no clear command or instruction in the Qur'an and Sunnah, the problem is decided keeping in view similar and resembling cases. This mode of deciding about its being permitted or prohibited is called Ijtihad.

Evidently, this process can be employed by only such a person who has full command about the various branches of knowledge pertaining to Qur'an and Sunnah. Not every person can do it nor is supposed to do it. There is also a famous proverb that says: `Little knowledge is a dangerous thing.'

From here we conclude that the ruler, judge or a bureaucrat in a Muslim country should be a learned scholar, i.e., an `Alim well versed in Qur'an and Sunnah; so that he can interpret the laws of Islam with utmost care and in a befitting and sincere manner. He should do the job sincerely and with a pious intention. With such mode of work, he will be bestowed with reward in every case. However, if his interpretation is correct, he will receive a double reward.

1857. `Aishah (May Allah be pleased with her) said: The Prophet (PBUH) said, "Fever comes from the vehement raging of Hell, so cool it with water.''
[Al-Bukhari and Muslim].

Commentary: The treatment mentioned in the narration is quite correct. In many cases doctors also suggest that the patient should be cooled and the body temperature lowered by cold compress, i.e., placing cloth dipped in cold water on the body.

1858. `Aishah (May Allah be pleased with her) said: The Prophet (PBUH) said, "If a person dies without observing Saum (fasts), his Wali should make it up on his behalf.''
[Al-Bukhari and Muslim].

Commentary: Sheikh Al-Albani says that this fasting refers to fasting of vow and not the fasting of Ramadan.
Sheikh Al-Albani has particularized the narration by `Aishah (May Allah be pleased with her) with the help of the narration of Ibn `Abbas (May Allah be pleased with them), in which the fasting of vow is specifically mentioned. The reason is that in the bodily worship, acting on the behalf of others is not permitted. As one cannot act or perform any bodily worship on behalf of others, similarly it is not allowed to do so after somebody's death. However, if in any particular case, there is a ruling in the Qur'an or Sunnah then in that particular matter deputizing would be allowed. In such case the permission should be limited to that particular matter only. For example it is specifically mentioned in the Hadith that the Wali, i.e., the guardian or inheritor of the dead person can observe the fasting of vow taken by the deceased person to Allah. However, no offering of other bodily worship, such as Salat, will be permitted on behalf of the deceased person.

1859. `Auf bin Malik (May Allah be pleased with him) said: `Aishah (May Allah be pleased with her) as told that `Abdullah bin Az-Zubair (May Allah be pleased with them) had said in respect of selling of a gift which was presented to her: "By Allah! If `Aishah does not stop this kind of thing, I will declare her incompetent to administer her property.'' `Aishah (May Allah be pleased with her) asked: "Did He (`Abdullah bin Az-Zubair) say so?'' The people said: "Yes.'' `Aishah (May Allah be pleased with her) said: "I vow it before Allah that I will never speak to Ibn Az-Zubair.'' When this desertion lasted long, `Abdullah bin Az-Zubair sought intercession with her, but she said: "By Allah I will not accept the intercession of anyone for him, and I will not commit a sin of breaking my vow.'' When this state of affairs was prolonged, Ibn Az-Zubair felt it hard on him. He said to Al-Miswar bin Makhramah and `Abdur-Rahman bin Al-Aswad bin Yaghut: "I beseech you in the Name of Allah that you should take me to `Aishah because it is unlawful for her to vow to sever relations with me.'' So Al-Miswar and `Abdur-Rahman took him with them. They sought her permission, saying: "As-salamu `alaika wa rahmatullahi wa barakatuhu! Shall we come in?'' `Aishah (May Allah be pleased with her) said: "Come in,'' They asked: "All of us?'' She said: "All of you,'' not knowing that Ibn Az-Zubair was also with them. So, when they entered, Ibn Az-Zubair entered the screened place and got hold of `Aishah (May Allah be pleased with her), his aunt. He was requesting her to forgive him and wept. Al-Miswar and `Abdur-Rahman also pleaded on his behalf and requested her to speak to him and to accept his repentance. They said to her: "The Prophet (PBUH) forbade to cut off relationship because it is unlawful for any Muslim not to talk to his (Muslim) brother (or sister, for that matter) for more than three (days).'' So when they persisted in urging and reminding her of the superiority of having good relation with kith and kin, she began to weep, saying: "I have made a vow which is a matter of very serious nature.'' They persisted in their appeal till she spoke with `Abdullah bin Az-Zubair, and she freed forty slaves as an expiation for breaking her vow. Later on, whenever she remembered her vow, she would weep so much that her veil would become wet with tears.
[Al-Bukhari].

Commentary: `Abdullah bin Az-Zubair (May Allah be pleased with him) was the real nephew of `Aishah (May Allah be pleased with her). She had made a vow that she would not talk to her nephew. She thought that such an oath was permissible as her nephew (the then governor of Makkah) had shown his intention to put a ban on the spending of `Aishah (May Allah be pleased with her). In his opinion, she was spending very lavishly in charity. Later `Abdullah bin Az-Zubair (May Allah be pleased with him) realized his mistake and went to his aunt to seek forgiveness along with two persons as recommenders. After this, it was proper for her to break her oath and resume her relations with him. The expiation for breaking a vow is the same as that of breaking an oath, i.e., to feed ten indigent people on a scale of the average for the food of one's family, or cloth them, or give a slave his freedom. If one cannot afford any of these things, then he should fast for three days. (See Qur'an, 5:89) But `Aishah (May Allah be pleased with her), in her generosity, bought forty slaves and freed them.

1860. `Uqbah bin `Amir (May Allah be pleased with him) said: One day the Messenger of Allah (PBUH) went out and asked Allah's forgiveness for the martyrs of the battle of Uhud after eight years. It seemed that by so doing, he bid farewell to the living and the dead. He then came back, rose to the pulpit and said, "I shall be your precursor; I am a witness for you (before Allah), and I will be present before you at the River (Haud Al-Kauthar). By Allah I can see with my own eyes the Haud from this place. I am not afraid that you will associate anything with Allah in worship after (my demise), but I apprehend that you will vie with one another for the life of the world.'' The narrator said: It was the last time that I saw the Messenger of Allah (PBUH).
[Al-Bukhari and Muslim].

There are some more narrations with very minor changes in its wording.

Commentary: This Hadith highlights the following points:

1. Haud Al-Kauthar exists: Anas (May Allah be pleased with him) reported: When the Prophet (PBUH) was made to ascend to the heavens, he said (after his return), "I came upon a river (in Jannah) the banks of which were made of tents of hollow pearls. I asked Jibril (PBUH), `What is this (river)?' He replied, `This is the Kauthar.''' (Al-Bukhari, vol. 6, Hadith No. 488).

2. Warning against vying with one another for the world.

3. Permissibility of visiting the graves of the Muslims and praying for them.

1861. Abu Zaid `Amr bin Akhtab Al-Ansari (May Allah be pleased with him) said: The Messenger of Allah (PBUH) led us in the morning (Fajr) prayer and he ascended the pulpit and addressed us until it was the time for the Zuhr prayer. He then came down the pulpit and led us in Salat (prayer). Again he ascended the pulpit and addressed until it was the time for the `Asr prayer. He then again came down, led us in Salat and again ascended the pulpit and addressed us until sunset. He informed us of everything that lay hidden in the past and what will happen in the future; and the most learned amongst us is the one who has preserved it in his memory.
[Muslim].

Commentary: Future events refer to happenings and incidents which will occur near the end of the world prior to the Day of Resurrection.

1862. `Aishah (May Allah be pleased with her) said: The Prophet (PBUH) said, "He who vows to obey Allah, should obey Him. But he who vows to disobey Allah, should not disobey Him.''
[Al-Bukhari].

Commentary: This Hadith makes it clear that if someone vows to do a righteous deed, he should keep his vow; but if he vows to commit a sin, he should break his vow.

1863. Umm Sharik (May Allah be pleased with her) said: The Messenger of Allah (PBUH) ordered me to kill chameleon. He also said, "It blew (fire) on Prophet Ibrahim.
[Al-Bukhari and Muslim].

1864. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who kills a chameleon at the first blow, such and such number of good deeds will be awarded to him; whoever kills it at the second blow, such and such number of merits will be recorded for him. And if he kills it at the third blow, he will get such and such merits.''

Another narration is: The Messenger of Allah (PBUH) said, "If anyone kills a chameleon with the first blow, a hundred good deeds will be recorded for him; less than that will be recorded for him if he kills it at the second blow, and still less rewards will be recorded for him if he kills it at the third blow.''
[Muslim].

Commentary: Here, it is mentioned that the killing of a chameleon in one stroke is very commendable. Similar is the case of killing of other harmful insects and reptiles such as scorpions, and snakes. This shows that even a slight help in good or bad actions will be counted and rewarded or punished as the case may be. The matter of quantity is not so important, but the real thing is the intention and real motive. It could be that the chameleon did, in fact, blew fire on Ibrahim; or it could be that it simply refers to the chameleon's harmful nature to human beings. Allah knows better.

1865. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said: "A man (from amongst the people before you) said: `Indeed! I will give in charity.' So he took his Sadaqah out and placed it in a thief's hand. In the morning the people were talking (about this incident) and saying: `Sadaqah was given to a thief last night.' The man said: `O Allah! Praise be to You. I have given Sadaqah to a thief. Indeed, I will give in charity!' So he took his Sadaqah out and he placed it in a prostitute's hand. In the morning the people were talking (about this incident) and saying: `Sadaqah was given to a prostitute last night.' On hearing this, the man said: `Praise be to You, O Allah! I gave Sadaqah to a prostitute. Indeed, I will give in charity!' So he took his Sadaqah out and placed it in a rich man's hand. In the morning the people were talking (about this incident) and saying: `Sadaqah was given to a rich man last night.' The man said: `O Allah! Praise be to You (for helping me) give charity to a thief, a prostitute and a rich man.' Then he had a dream in which he was told that his Sadaqah to the thief might result in his refraining from his theft, his Sadaqah to the prostitute might help her abstain from her immorality, and his Sadaqah to the rich man might help him pay heed and spend from what Allah had bestowed upon him.''
[Al-Bukhari].

Commentary: If the intention of the person giving away something in charity is good, it will be accepted and rewarded by Allah even though it may be given to an undeserving person. However, it is better to give charity to deserving, pious people.

1866. Abu Hurairah (May Allah be pleased with him) reported: We accompanied the Messenger of Allah (PBUH) to a banquet. The meat of the forearm was presented to him as he was very fond of it. The Messenger of Allah (PBUH) ate a morsel of it and said, "I will be the master of all the people on the Day of Resurrection. Do you know why? Allah will gather all human beings, past and present generations on the same ground so that the announcer may be able to make them all hear his voice and the onlookers may be able to see all of them. The sun will come very close to the people, they will suffer such distress and trouble as they will not be able to bear. Then the people will say: `Do you see our (miserable) condition? You should look for someone who can intercede for you with your Rubb.' Some people will say to the others: `Go to your father, Adam.' So they will go to Adam and say to him: `You are the father of mankind; Allah created you with His Own Hand, and breathed into you of His spirit, ordered the angels to prostrate before you and He made you dwell in Jannah. So (please) intercede for us with your Rubb. Do you not see our (miserable) condition?' Adam will say: `Today my Rubb has become so angry as He has never been before, nor will He ever become angry after this. He forbade me to approach the tree, but I disobeyed Him. I am worried about myself. Go to someone else. Go to (Prophet) Nuh (Noah).' They will come to Nuh and will say to him: `O Nuh! You are the first of Messenger of Allah to the people on the earth, and Allah has named you a grateful slave. Please intercede for us with your Rubb. Do you not see our (miserable) condition?' He will say: `Today my Rubb his become so angry as He has never been before, nor will He become angry hereafter. I was granted the right to make one definitely accepted invocation. I availed of this opportunity and made it against my nation. I am worried about myself. Go to someone else. Go to (Prophet) Ibrahim (Abraham).' They will go to Ibrahim and say to him: `O Ibrahim, you are Messenger of Allah and His Khalil (the intimate friend of Allah) from among the people of the earth; so please intercede for us with your Rubb. Don't you see our (miserable) condition?' He will say to them: `Today my Rubb has become so angry as He has never been before; nor will he ever be so hereafter. I had told three lies. I am worried about myself. Go to someone else. Go to (Prophet) Musa (Moses).' The people will then go to Musa and say to him: `O Musa! You are Messenger of Allah and Allah gave you superiority above the others with His Message and with His direct Talk to you, so intercede for us with your Rubb. Do you not see our (miserable) condition?' Musa will say: `Today my Rubb has become so angry as he has never been before, nor will He ever be hereafter. I killed a man whom I had not been ordered to kill. I am worried about myself. Go to someone else. Go to (Prophet) `Isa (Jesus).' So they will go to `¦sa and say to him: `O `Isa! You are Messenger of Allah and His Word (i.e., "Be''-and he was) which he bestowed on Maryam (Mary) and a spirit created by Him; and you talked to the people while you were in the cradle. Please intercede for us with your Rubb. Do you not see our (miserable) condition?' `¦sa will say: `Today my Rubb has become so angry as He has never been before, nor will He ever be like this hereafter.' `Isa will not mention any sin, but will say: `I am worried about myself. Go to someone else. Go to Muhammad (PBUH).'''

Another narration is: The Messenger of Allah said, "They will come to me and say: `O Muhammad! You are the Messenger of Allah and the Last of Prophets, and Allah has forgiven your past and future sins. Please intercede for us with your Rubb. Do you not see our (miserable) condition?''' The Messenger of Allah (PBUH) added, "Then I will proceed under Allah's Throne and fall down in prostration before my Rubb. Then, He will bestow upon me knowledge of such praises and glorification to Him as He has never bestowed upon anybody else before me. Then I will be addressed: `O Muhammad! Raise your head. Ask, and your request will be granted. Intercede, and your intercession will be accepted.' So I will raise my head and say: `My followers, O my Rubb! My followers, O my Rubb! My followers, O my Rubb!' It will be said: `O Muhammad! Admit into Jannah such people as are not subjected to reckoning through the right gate of Jannah.' The rest of them will be admitted along with the rest of mankind through the various gates of Jannah.'' The Messenger of Allah (PBUH) further said, "By Him in Whose Hand my soul is! The distance between every two sides of the gates of Jannah is like the distance between Makkah and Hajar, or that between Makkah and Busra (Syria).''
[Al-Bukhari and Muslim]

Commentary:
1. Hajar is a town in Bahrain and Busra is a city in Harran which is situated in the south of Damascus. This means that each of the gates of the Jannah will be so broad that the distance between its two sides would be thousands of miles.

2. In this narration, the greatness and superiority of the Prophet (PBUH) has been described. On the Day of Resurrection when the great Prophets would not dare to speak or request leniency for mankind, only Muhammad (PBUH) would intercede for the people and request for mercy by the Permission of Allah. The first request which he will make would be that accountability may be started, so that the people may be freed as soon as possible from the hardships and troubles of the Day of Resurrection. This part of the Hadith has not been mentioned in this narration; but it has been described in other narrations. This would be a general request.

The second intercession will be for his own Ummah. This will take place in several stages. Here, the first stage has been mentioned. In this stage Allah will send those people to Jannah whose accountability would not be necessary.

Next stage would be when the sinners among the believers would have completed their period of punishment in Hell and then Allah will send them to Jannah upon the intercession of the Prophet (PBUH).

Other Prophets will seek to be excused from recommending or advocating because of some of their slips. The real reason for this attitude of theirs is that they are on such high pedestal of greatness and piety that even a slight slip of theirs which does come under the boundary of unworthiness would be felt by them to be very significant. This is just like the proverb which says that even the nice action of the pious ones are considered to be the blemishes and defects for the friends of Allah. Similar is the case with the Prophets, they excused themselves from advocating their case before Allah because of their insignificant slips.

3. Special reference may be made of the three statements of Prophet Ibrahim which were apparently not according to the outward facts, so they have been described as `not factual'. In reality they were not mis-statements, but only a way of convincing the people about the basic universal truth, and making them realize their misunderstanding. These three are mentioned in a long Hadith narrated on the authority of Abu Hurairah (May Allah be pleased with him): Ibrahim (PBUH) did not tell a lie except on three occasions. Twice for the sake of Allah when he said, "I am sick'' (37:89) and he said, "(I have not done this) but the big idol had done it.'' (21:63) (The third was) that while Ibrahim and Sarah (his wife) were going (on a journey) they passed by (the territory of) a tyrant from among the tyrants. Someone said to the tyrant, "This man (i.e., Ibrahim) is accompanied by a very charming lady.'' So, he sent for Ibrahim and asked him about Sarah, saying, "Who is this lady?'' Ibrahim said, "She is my sister.'' Ibrahim went to Sarah and said, "O Sarah! There are no believers on the surface of the earth except you and I. This man asked me about you and I told him that you are my sister. So do not contradict my statement...'' (Al-Bukhari, vol. 4, Hadith No. 578)

The idolaters invited Ibrahim to join them in their celebrations outside the city, but he refused, claiming that he was sick. When he was left alone, he came to their idols and broke them. When the idolaters questioned him, he claimed that he had not destroyed their idols but the chief idol had, which Ibrahim left undisturbed and on whose shoulder he had put an axe to lay the accusation on it. To conclude, Ibrahim, like all other Prophets is free from sins, but the three acts which he made in good faith were to guide his people to the truth and to save his wife from the evil of the then tyrant.

1867. Ibn `Abbas (May Allah be pleased with them) reported: Ibrahim (PBUH) brought his wife and her son Isma`il (PBUH), while she was suckling him, to a place near the Ka`bah under a tree on the spot of Zamzam, at the highest place in the mosque. In those days, there was no human being in Makkah, nor was there any water. So he made them sit over there and placed near them a leather bag containing some dates, and a small water-skin containing some water, and set out homeward. Isma`il's mother followed him saying: "O Ibrahim! Where are you going, leaving us in this valley where there is no person whose company we may enjoy, nor is there anything (to enjoy)?'' She repeated that to him many times, but he did not look back at her. Then she asked him: "Has Allah commanded you to do so?'' He said: "Yes.'' She said: "Then He will not neglect us.'' She returned while Ibrahim proceeded onwards. Having reached the Thaniya, where they could not see him, he faced Ka`bah, raised his both hands and supplicated: "O our Rubb! I have made some of my offspring to dwell in an uncultivable valley by Your Sacred House (the Ka`bah at Makkah) in order, O our Rubb, that they may perform As-Salat (Iqamat-as-Salat). So fill some hearts among men with love towards them, and (O Allah) provide them with fruits so that they may give thanks.'' (14:37).

Isma`il's mother went on suckling Isma`il and drinking from the water which she had. When the water in the water-skin had all been used up, she became thirsty and her child also became thirsty. She started looking at Isma`il, tossing in agony. She left him, for she could not endure looking at him, and found that the mountain of As-Safa was the nearest mountain to her on that land. She stood on it and started looking at the valley keenly so that she might see somebody, but she could not see anybody. Then she descended from As-Safa, and when she reached the valley, she tucked up her robe and ran in the valley like a person in distress and trouble till she crossed the valley and reached Al-Marwah mountain where she stood and started looking, expecting to see somebody, but she could not see anybody. She repeated that (running between As-Safa and Al-Marwah) seven times.'' Ibn `Abbas further related: The Prophet (PBUH) said, "This is the source of the tradition of the Sa`y - i.e., the going of people between the two mountains. When she reached Al-Marwah (for the last time), she heard a voice and she exclaimed: `Shshs!' (Silencing herself) and listened attentively. She heard the voice again and said: `O (whoever you may be) You have made me hear your voice; have you any succour for me?' And behold! She saw an angel at the place of Zamzam, digging the earth with his heel (or with his wing), till water flowed out from that place. She started to make something like of a basin around it, using her hands in this way and began to fill her water-skin with water with her hands, and the water was flowing out until she had scooped some of it.'' The Prophet (PBUH) further said, "May Allah bestow mercy on Isma'il's mother! Had she let the Zamzam flow without trying to control it (or had she not scooped in that water) while filling her water-skin, Zamzam would have been a stream flowing on the surface of the earth.'' The Prophet (PBUH) further added, "Then she drank (water) and suckled her child. The angel said to her: `Do not be afraid of being neglected, for this is the site on which the House of Allah will be built by this boy and his father, and Allah will never let neglected His people.' The House of Allah (the Ka`bah) at that time was on a high place resembling a hillock, and when torrents came, they flowed to its right and left. She continued living in that way till some people from the tribe of Jurhum passed by her and her child. As they were coming from through the way of Kada`, in the lower part of Makkah where they saw a bird that had a habit of flying around water and not leaving it. They said: `This bird must be flying over water, though we know that there is no water in this valley.' They sent one or two messengers who discovered the source of water, and returned to inform them of the water. So, they all came towards the water.'' The Prophet (PBUH) added, "Isma`il's mother was sitting near the water. They asked her: `Do you allow us to stay with you?' She replied: `Yes, but you will have no right to possess the water.' They agreed to that.'' The Prophet (PBUH) further said, "Isma`il's mother was pleased with the whole situation as she used to love the company of the people. So, they settled there, and later on they sent for their families who came and settled with them. The child (i.e., Isma`il) grew up and learnt Arabic from them (his virtues) caused them to love and admire him as he grew up, and when he reached the age of puberty, they gave him one of their daughters in marriage. After Isma`il's mother had died, Ibrahim came after Isma`il's marriage in order to see his family that he had left before, but he did not find Isma`il there. When he asked Isma`il's wife about him, she replied: `He has gone in search of our livelihood.' Then he asked her about their way of living and their condition, and she replied complaining to him: `We are living in hardship, misery and destitution.' He said: `When your husband returns, convey my salutations to him and tell him to change the threshold of the door of his house.' When Isma`il came, he seemed to have perceived something unusual. He asked his wife: `Did anyone visit you?' She replied: `Yes, an old man of such and such description came and asked me about you and I informed him, and he asked about our state of living, and, I told him that we were living in hardship and poverty.' Thereupon Isma`il said: `Did he advise you anything?' She replied: `Yes, he told me to convey his salutations to you and to change the threshold of your door.' Isma`il said: `That was my father, and he has ordered me to divorce you. Go back to your family.' So Isma`il divorced her and married another woman from amongst them (Jurhum). Then Ibrahim stayed away from them for a period as long as Allah wished, and called on them again but did not find Isma`il. So he came to Isma`il's wife and asked her about him. She said: `He has gone in search of our livelihood.' Ibrahim asked her about their sustenance and living: `How are you getting on?' She replied: `We are prosperous and well off.' Then she praised Allah, the Exalted. Ibrahim asked: `What kind of food do you eat?' She said: `Meat.' He said: `What do you drink?' She said: `Water.' He said, `O Allah! Bless their meat and water!''' The Prophet (PBUH) added, "At that time they did not have grain, and if they had grain, he would have also invoked Allah to bless it.'' The Prophet (PBUH) further said, "If somebody has only these two things as his sustenance, his health and disposition will be badly affected because these things do not suit him unless he lives in Makkah.'' The Prophet (PBUH) added, "Then Ibrahim said to Isma`il's wife, `When your husband comes, give my regards to him and tell him that he should keep firm the threshold of his door.' When Isma`il came back, he asked his wife: `Did anyone call on you?' She replied: `Yes, a good looking old man came to me.' She praised him and added: `He asked about you, and I informed him, and he asked about our livelihood and I told him that we were in good condition.' Isma`il asked her: `Did he give you a piece of advice?' She said: `Yes, he told me to convey his regards to you and ordered that you should keep firm the threshold of your door.' On that Isma`il said: `He was my father and you are the threshold of the door. He has ordered me to keep you with me.' Then Ibrahim stayed away from them for a period as long as Allah wished and called on them afterwards. He saw Isma`il under a tree near Zamzam, sharpening his arrows. When he saw Ibrahim, he rose up to welcome him, and they greeted each other as a father does with his son or a son does with his father. Ibrahim said: `O Isma`il! Allah has given me an order.' Isma`il said: `Do what your Rubb has commanded you to do.' Ibrahim asked: `Will you help me?' Isma`il said: `I will help you.' Ibrahim said: `Allah has ordered me to build a house here, pointing to a hillock higher than the land surrounding it.''' The Messenger of Allah (PBUH) added, "Then they raised the foundations of the House (i.e., Ka`bah). Isma`il brought the stones and Ibrahim was building (the house). When the walls became high, Isma`il brought stone and placed it for Ibrahim who stood over it and carried on building the House, while Isma`il was handing over the stones to him, both of them prayed: `O our Rubb! Accept this service from us! Verily, You are the All-Hearer and the All-Knower.'''
[Al-Bukhari].

There are some more narrations about this incident, some adding details and some with minor variations in the wordings.

Commentary:
1. In this narration, there is the historical background of walking briskly between the hills of As-Safa and Al-Marwah. This ritual of Hajj and `Umrah has been fixed as a remembrance of the incident about what Hajirah (May Allah be pleased with her) had to face and what she did in the difficult circumstances. In fact, she was so pious and obedient that she agreed to live in such wilderness where there was no sign of any human being far and wide. Secondly, there was no water to drink or food for subsistence.

For this act of piety, she was rewarded with two things; firstly, she was bestowed with an eternally flowing spring which proved for her at that moment a source of life, and people still benefit from it today. Secondly, her brisk movement and running between the two hills was made an important and compulsory ritual to be performed during Hajj and `Umrah. This ritual is to continue for all times till the Day of Resurrection.

2. Ka`bah was built by Prophet Ibrahim and Prophet Isma`il.

3. Thanking Allah under all circumstances is an act of praise and piety while the reverse of this attitude is disliked and considered reprehensible.

4. If a father asks his son to do something, then the child should respond to the father's request as long as he does not order him to disobey Allah.

1868. Sa`id bin Zaid (May Allah be pleased with him) reported: I heard the Messenger of Allah (PBUH) saying, "Truffle (edible fungus) is a species of Al-Manna and their water cures eye diseases.''
[Al-Bukhari and Muslim]

Commentary: Al-Manna is the famous kind of food which Allah bestowed upon Banu Israel. As-Salwa was a kind of bird resembling the quail. It was slaughtered and then eaten. Al-Manna was a sweet substance which appeared on the trees or stones. It was sweet like honey and after drying, it took the form of gum. According to others, it was honey or sweet water (Tafsir Ahsan-ul-Bayan). The truffle is similar to Al-Manna. This means that as Banu Israel were given food without toil, so we find truffle in nature without effort. The juice of truffle is useful in curing some diseases of the eye. This prescription was suggested by the Prophet (PBUH). It is surely beneficial.


Book Nineteen: The Book of Forgiveness

  • Chapter 371 : Seeking Forgiveness
  • Chapter 372 : Some of the Bounties which Allah has prepared for the Believers in Paradise


Seeking Forgiveness

Chapter 371
Seeking Forgiveness

Allah, the Exalted, says:

"And ask forgiveness for your sin...'' (47:19)

"And seek the forgiveness of Allah. Certainly, Allah is Ever Oft-Forgiving, Most Merciful.'' (4:106)

"And declare the freedom of your Rubb from imperfection beginning with His praise, and ask His forgiveness. Verily, He is the One Who accepts the repentance and Who forgives.'' (110:3)

"For Al-Muttaqun (the pious) there are Gardens (Jannah) with their Rubb, underneath which rivers flow. Therein (is their) eternal (home) and Azwajun Mutahharatun (purified mates or wives). And Allah will be pleased with them. And Allah is All-Seer of the (His) slaves. Those who say: `Our Rubb! We have indeed believed, so forgive us our sins and save us from the punishment of the Fire. (They are) those who are patient, those who are true (in Faith, words, and deeds), and obedient with sincere devotion in worship to Allah. Those who spend (give the Zakat and alms in the way of Allah) and those who pray and beg Allah's Pardon in the last hours of the night.'' (3:15-17)

"And whoever does evil or wrongs himself but afterwards seeks Allah's forgiveness, he will find Allah Oft-Forgiving, Most Merciful.'' (4:110)

"And Allah would not punish them while you (Muhammad (PBUH)) are amongst them, nor will He punish them while they seek (Allah's) forgiveness.'' (8:33)

"And those who, when they have committed Fahishah (illegal sexual intercourse) or wronged themselves with evil, remember Allah and ask forgiveness for their sins; - and none can forgive sins but Allah - and do not persist in what (wrong) they have done, while they know.'' (3:135)

The Qur'anic Ayat on the subject are many and well-known.

1869. Al-Agharr Al-Muzani (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Sometimes I perceive a veil over my heart, and I supplicate Allah for forgiveness a hundred times in a day.''
[Muslim].

Commentary: Ghain and Ghaim are two synonyms. They signify the spreading of the clouds. It refers in this Hadith to the fact that the Prophet (PBUH) was reciting the Names of Allah and remembering Him all the time. But sometimes due to being too busy in the affairs of the public or due to human needs, there was a pause in this eternal remembrance. Although such a pause was only momentary, this momentary pause was very much disliked by him; and considering it a slackness on his part, he prayed for forgiveness from Allah. In this there is an important lesson for us.

In spite of our many sins and negligence on our part, we do not turn to Allah and seek forgiveness; while, although our Prophet (PBUH) had all his past and future sins forgiven by Allah, he sought forgiveness very often.

1870. Abu Hurairah (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "I swear by Allah that I seek Allah's Pardon and turn to Him in repentance more than seventy times a day.''
[Al-Bukhari].

1871. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "By the One in Whose Hand my soul is! If you do not commit sins, Allah would replace you with a people who would commit sins and seek forgiveness from Allah; and Allah will certainly forgive them.''
[Muslim].

Commentary: This Hadith does not mean that Allah likes disobedience. But by this way of description, the aim is to emphasize the importance of seeking forgiveness from Allah. We know that every man commits sins. But Allah likes those people who, after committing a sin, do not stick to it, but right away seek forgiveness for their sins from Allah. They weep and express sorrow before Allah. By seeking forgiveness, a relationship with Allah is established between man and his Creator. So seeking forgiveness is a very good act.

1872. Ibn `Umar (May Allah be pleased with them) said: We counted Messenger's saying a hundred times during one single sitting: Rabb-ighfir li, wa tubb `alayya, innaka Antat-Tawwabur-Rahim. (My Rubb! Forgive me and pardon me. Indeed, You are the Oft-Returning with compassion and Ever Merciful.''
[Abu Dawud and At-Tirmidhi].

Commentary: This Hadith tells us about the etiquette of praying to Allah. We should use the Names of Allah befitting our prayers, i.e., the Names of Allah signifying those Attributes of Allah which have a special concern with the subject of our particular prayer, i.e., while seeking forgiveness, His Names concerning His Attributes of forgiveness and kindness should be used. On the other hand, while praying for worldly matters, we should mention His Qualities of charity and bestowing gifts etc.

1873. Ibn `Abbas (May Allah be pleased with them) said: The Messenger of Allah (PBUH) said, "If anyone constantly seeks pardon (from Allah), Allah will appoint for him a way out of every distress and a relief from every anxiety, and will provide sustenance for him from where he expects not.''
[Abu Dawud].

Commentary: The chain of this narration is weak. Refer to `The Book of Weak Narrations' by Al-Albani, Vol. I, page 142, No.705.

1874. Ibn Mas`ud (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "He who says: `Astaghfir ullah-alladhi la ilaha illa Huwal-Haiyul-Qayyumu, wa atubu ilaihi (I seek the forgiveness of Allah, there is no true god except Allah, the Ever-Living, the Self-Subsisting, and I turn to Him in repentance),' his sins will be forgiven even if he should have run away from the battlefield (while he was engaged in fighting for the Cause of Allah).''
[Abu Dawud, At-Tirmidhi and Al-Hakim (on conditions of Al-Bukhari and Muslim for accepting Hadith)].

Commentary: When we say that this narration fulfills the conditions of Al-Bukhari and Muslim; it means that its narrators are the narrators of Al-Bukhari and Muslim. Secondly, in this selection those conditions have also been kept in view, which are the landmark of Al-Bukhari and Muslim.

1875. Shaddad bin Aus (May Allah be pleased with him) said: The Prophet (PBUH) said, "The best supplication for seeking forgiveness (Syed-ul-Istighfar) is to say: `Allahumma Anta Rabbi, la ilaha illa Anta, khalaqtani wa ana `abduka, wa ana `ala `ahdika wa wa`dika mastata`tu, a`udhu bika min sharri ma sana`tu, abu'u laka bini`matika `alayya, wa abu'u bidhanbi faghfir li, fa innahu la yaghfirudh-dhunuba illa Anta. (O Allah! You are my Rubb. There is no true god except You. You have created me, and I am Your slave, and I hold to Your Covenant as far as I can. I seek refuge in You from the evil of what I have done. I acknowledge the favours that You have bestowed upon me, and I confess my sins. Pardon me, for none but You has the power to pardon).' He who supplicates in these terms during the day with firm belief in it and dies on the same day (before the evening), he will be one of the dwellers of Jannah; and if anyone supplicates in these terms during the night with firm belief in it and dies before the morning, he will be one of the dwellers of Jannah.''
[Al-Bukhari].

1876. Thauban (May Allah be pleased with him) reported: Whenever the Messenger of Allah (PBUH) finished his Salat (prayer), he would beg forgiveness three times [by saying, `Astaghfirullah' (3 times)] and then he would say: "Allahumma Antas-Salamu, wa minkas-Salamu, tabarakta ya Dhal-Jalali wal-Ikram. (O Allah! You are the Bestower of security and security comes from You; Blessed are You. O Possessor of glory and honour).'' Imam Al-Auza`i (one of the subnarrators) of this Hadith was asked: "How forgiveness should be sought?'' He replied: "I say: Astaghfirullah, Astaghfirullah (I seek forgiveness from Allah. I seek forgiveness from Allah).''
[Muslim].

Commentary: This Du`a' was a Sunnah of the Prophet (PBUH), and it is highly recommended to recite it after Salat.

1877. `Aishah (May Allah be pleased with her) reported: Prior to his demise, the Messenger of Allah (PBUH) used to supplicate frequently: Subhan Allahi wa bihamdihi; Astaghfirullaha wa atubu ilaihi (Allah is free from imperfection, and I begin with praising Him. I beg forgiveness from Allah and I turn to Him in repentance.''
[Al-Bukhari and Muslim].

Commentary: In general, asking of forgiveness all the time is necessary and commendable. But during the old age and the last days of one's life it is particularly very essential. In this way, the Sunnah of the Prophet (PBUH) would also be followed.

1878. Anas (May Allah be pleased with him) said: I heard the Messenger of Allah (PBUH) saying, "Allah, the Exalted, has said: `O son of Adam! I shall go on forgiving you so long as you pray to Me and aspire for My forgiveness whatever may be your sins. O son of Adam! I do not care even if your sins should pile up to the sky and should you beg pardon of Me, I would forgive you. O son of Adam! If you come to Me with an earthful of sins and meet Me, not associating anything with Me in worship, I will certainly grant you as much pardon as will fill the earth.'''
[At-Tirmidhi].

Commentary: In this narration, there is good news for the sinners who do not stick to sins but rather repent and ask forgiveness from Allah. However numerous their sins may be, Allah will forgive all their sins. But there is a condition which they should fulfill, namely that they do not persist in what wrong they have done (3:135), as with persistence and repeatedly committing the sin, the act of seeking forgiveness becomes a futile act.

1879. Ibn `Umar (May Allah be pleased with them) said: The Prophet (PBUH) said, "O women folk! You should give charity and be diligent in seeking Allah's forgiveness because I have seen (i.e., on the Night of the Ascension to the highest heavens) that dwellers of the Hell are women.'' A woman amongst them said: "Why is it that the majority of the dwellers of Hell are women?'' The Prophet (PBUH) replied, "You curse frequently and are ungrateful to your husbands. In spite of your lacking in wisdom and failing in religion, you are depriving the wisest of men of their intelligence.'' Upon this the woman asked: "What is the deficiency in our wisdom and in our religion?'' He (PBUH) replied, "Your lack of wisdom can be well judged from the fact that the evidence of two women is equal to that one man. You do not offer Salat (prayer) for some days and you do not fast (the whole of) Ramadan sometimes, it is a deficiency in religion.''
[Muslim].

Commentary:
1. In this narration, certain weaknesses of the female sex have been pointed out, which are natural and pertain to the woman's biology, psychology and embryology.

According to biologists, during and before menstruation, a female's thought process is affected. Similarly, her pulse and blood pressure are also altered. Females are also more prone to hysteria. For these reasons, the Qur'an has declared that when you have to appoint or choose witnesses among women, you should choose two in place of one man. Modern researches have proved this rule to be correct on the basis of biology, psychology and embryology.

Again we know that physically speaking, the female has been named as the weaker sex. For these reasons, females have been excused from earning their livelihood. For earning livelihood, one may have to go out and work hard. Women have been exempted from this duty because of their biological differences and other considerations of Shari`ah. Present-day women who are ignorant of Islam and modern researches are not prepared to accept these scientifically and religiously proved facts. The West claims equality between the sexes. But this equality has not been established so far. Today all the important posts are occupied by males and all the international policies are framed by them alone. Even matters pertaining to women are decided by them. They have mostly relegated them to the posts of workers, secretaries and stenographers for their sexual satisfaction and enjoyment. After a struggle for hundred years, their condition today proves that they are the weaker sex.

So, it is both beneficial and more respectful for her to limit herself to the sphere of action suggested for her by Islam. If she oversteps her sphere, she will certainly lose her female dignity and prestige, as has happened in the West. Her state and condition there is an eyeopener for all.

2. Women should request forgiveness from Allah very often and be generous in charity. They should not show ungratefulness to their husbands and should avoid backbiting and cursing others so that they may save themselves from Hell.


Some of the Bounties which Allah has prepared for the Believers in Paradise

Chapter 372
Some of the Bounties which Allah has prepared for the Believers in Paradise

Allah, the Exalted, says:

"Truly, the Muttaqun (the pious and righteous persons) will be amidst Gardens and water-springs (Jannah). (It will be said to them): `Enter therein (Jannah), in peace and security.' And We shall remove from their breasts any deep feeling of bitterness (that they may have). (So they will be like) brothers facing each other on thrones. No sense of fatigue shall touch them, nor shall they (ever) be asked to leave it.'' (15:45-48)

"(It will be said to the believers of Islamic Monotheism): `My slaves! No fear shall be on you this Day, nor shall you grieve. (You) who believed in Our Ayat (proofs, verses, lessons, signs, revelations, etc.) and were Muslims (i.e., who submit totally to Allah's Will, and believe in the Oneness of Allah). Enter Jannah, you and your wives, in happiness.' Trays of gold and cups will be passed round them; (there will be) therein all that inner-selves could desire, and all that eyes could delight in and you will abide therein forever. This is the Jannah which you have been made to inherit because of your deeds which you used to do (in the life of the world). Therein for you will be fruits in plenty, of which you will eat (as you desire).'' (43:68-73)

"Verily, the Muttaqun (the pious), will be in place of security (Jannah). Among Gardens and springs. Dressed in fine silk and (also) in thick silk, facing each other. So (it will be). And We shall marry them to Hur (fair females) with wide, lovely eyes. They will call therein for every kind of fruit in peace and security. They will never taste death therein except the first death (of this world), and He will save them from the torment of the blazing Fire. As a bounty from your Rubb! That will be the supreme success!'' (44:51-57)

"Verily, Al-Abrar (the pious and righteous) will be in Delight (Jannah). On thrones, looking (at all things). You will recognise in their faces the brightness of delight. They will be given to drink of pure sealed wine. The last thereof (that wine) will be the smell of musk, and for this let (all) those strive who want to strive (i.e., hasten earnestly to the obedience of Allah). It (that wine) will be mixed with Tasnim. A spring whereof drink those nearest to Allah.'' (83:22-28)

The Qur'anic Ayat on the subject are many and well-known.

1880. Jabir (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "The inhabitants of Jannah will eat and drink therein, but they will not have to pass excrement, to blow their noses or to urinate. Their food will be digested producing belch which will give out a smell like that of musk. They will be inspired to declare the freedom of Allah from imperfection and proclaim His Greatness as easily as you breathe.''
[Muslim].

Commentary: Belching the vapours of musk means that after meals one would not feel heaviness and acidity. On the other hand, the belch will give out scented air, and the food will be digested by it. There will be no excrement or urine there.

Secondly, recitation of Allah's Name will ever remain on their tongues without the least effort like the way we breathe, without any effort whatsoever. In other words the food in Jannah would be so light and fine that there would be no disagreeable urine excrement. On the other hand, there will only be fine smell like that of musk.

1881. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Allah, the Exalted, has said: `I have prepared for my righteous slaves what no eye has seen, no ear has heard, and the mind of no man has conceived.' If you wish, recite:

`No person knows what is kept hidden for them of joy as a reward for what they used to do.''' (32:17)
[Al-Bukhari and Muslim].

Commentary: About the gifts and pleasures of Jannah, here a Hadith has been stated in the Words of Allah. The subject matter is confirmed from the Verse of the Qur'an given in the text of the Hadith.

1882. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The first group (of people) to enter Jannah will be shining like the moon on a full-moon night. Then will come those who follow them who will be like the most shining planet in the sky. They will not stand in need of urinating or relieving of nature or of spitting or blowing their noses. Their combs will be of gold and their sweat will smell like musk; in their censers the aloes-wood will be used. Their wives will be large eyed maidens. All men will be alike in the form of their father `Adam, sixty cubits tall.''

Another narration is: The Messenger of Allah (PBUH) said, "Their utensils will be of gold, their perspiration will smell like musk; everyone of them will have two wives; the marrow of the bones of the wives' legs will be seen through the flesh out of excessive beauty. They (i.e., the people of Jannah) will neither have difference, nor enmity (hatred) amongst themselves; their hearts will be as if one heart, and they will be glorifying Allah in the morning and in the afternoon.''
[Al-Bukhari and Muslim].

Commentary:
1. The people in the Jannah would be similar in shape and height, etc. There would be no differences between them. It won't be that one person is beautiful and the other ugly or one is fair in colour and the other is black. This is one view. The other view is that they would be similar in being good mannered and the desirable and loving disposition. They will be on the highest pedestal of ethics, etiquette, politeness and morality. None of them would be immoral, discourteous or ill-tempered.

2. Everyone there would have two wives. They would either be from the houris or from the humans. The narration, which claims that every one would have seventy-two wives has a weak chain of narrators. However, in one narration of At-Tirmidhi which has been claimed to be Sahih, it is stated that a martyr would get seventy-two wives. (At-Tirmidhi, Chapter about the Superiority of Jihad). Then the saying, "One would get in the Jannah what he wants'' may also be considered and so the possibility of more than two wives cannot be denied.

3. Hur is the plural of Howra It means white and pink. So it is said that one would be bewildered to see their beauty. `Ein is the plural of `Aina' It means one having large eyes like a deer. In another narration it is said that if any one of them just peeps towards our earth, the whole space would be filled with scent and all the space would be lighted. Her sheet of cloth used to cover the head and the bosom would be so precious that its cost would exceed this whole material earth. (Sahih Al-Bukhari, Book of Jihad, Chapter about Houri).

1883. Al-Mughirah bin Shu`bah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Musa (Moses) (PBUH) asked his Rubb: `Who amongst the inhabitants of Jannah will be the lowest in rank?' He said: `It will be a person who will be admitted into Jannah last of all when all the dwellers of Jannah have entered Jannah. It will be said to him: Enter Jannah. But he will say: O my Rubb! How should I enter while the people have settled in their apartments and taken their shares? It will be said to him: Will you be satisfied and pleased if you have a kingdom like that of a monarch of the world? He will say: I will be content, my Rubb. Allah will say: For you is that, and like that and like that and like that and like that. He will say at the fifth time: I am well-pleased, my Rubb. Allah will say: It is for you and ten times more like it. You will have whatever your soul desires and whatever your eyes could delight in. He will say: I am well-pleased, my Rubb.' Musa (PBUH) said: `Who will be of the highest rank in Jannah.' Allah said: `They are those whom I chose and I established their honour with My Own Hand. I attest with My Seal that they will be blessed with such bounties as no eye has seen, no ear has heard and no human mind has perceived.'''
[Muslim].

Commentary: This Hadith highlights Allah's unbounded Mercy and Bounty upon His slaves in Jannah although they do not deserve all that.

1884. `Abdullah bin Mas`ud (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "I know of the last of the inhabitants of the Hell to be taken out from there and the last one to enter Jannah. He is a man who will come out of the Fire, crawling on all fours. Allah, the Rubb of glory and honour will say to him: `Go and enter Jannah.' He will go to it and think that it is full up. He will then come back and say: `O my Rubb, it is full up.' Allah will say to him: `Go and enter Jannah.' He will again go to it and think that it is full up. So he will turn back. Allah will again say: `Go and enter Jannah. For you have what is equal to ten times the world.' He will say: `Are You making fun of me while You are the King?'' At this I (i.e., the narrator) saw the Messenger of Allah (PBUH) laugh till his premolars were visible and he said, "Such man will be the last dweller of Jannah in its lowest rank.''
[Al-Bukhari and Muslim].

Commentary: The general habit of the Prophet (PBUH) was just to smile. But while telling about the gifts and honours about an ordinary person in Jannah, he could not help laughing in a manner that his molars became visible. The person on the lowest pedestal in Jannah will be given ten times better things and gifts that could he had on this earth. May Allah admit us into Jannah in His Mercy. Amin.

1885. Abu Musa (May Allah be pleased with him) said: The Prophet (PBUH) said, "In Jannah the believer will have a tent made of a single hollowed pearl of which the length will be sixty miles in the sky. The believer will have his wives with him and he will visit them and they will not be able to see one another.''
[Al-Bukhari and Muslim].

1886. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Prophet (PBUH) said, "There is a tree in Jannah that is so huge that if a rider of a swift horse has to cover its distance from one end to another in one hundred years, he will not be able to do so.''

Another narration from Abu Hurairah (May Allah be pleased with him) is: The Messenger of Allah (PBUH) said, "A rider will not be able to cross its (the tree's) shade even after travelling for one hundred years.''
[Al-Bukhari and Muslim]

Commentary: The horse referred to in the Hadith in described in the Arabic text as `Mudhammar' i.e., a specially trained and well-looked after horse. Such a horse is first fattened by supplying it with large quantities of food. Then slowly the quantity of food given to it is decreased and it is made to sweat in a hot room until it loses weight and thus, becomes fit for running.

The Arabic word "dhil" translated here as `shade,' in fact, refers to the expansiveness and vastness of the tree. It does not necessarily mean shade in the ordinary sense, as there will be no sun or heat there. Here the expansiveness and vastness of the trees of Jannah has been mentioned. Allah can do what He likes and create whatever He likes.

1887. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Prophet (PBUH) said, "The dwellers of Jannah will look at those in the upper abodes above them as you look at a shining star which remains in the eastern or western horizon; such will be the difference in superiority which some of them have over others.'' The Messenger of Allah (PBUH) was asked: "Will those be the dwellings of the Prophets which no one else will be able to reach?'' He (PBUH) replied, "Yes, but by Him in Whose Hand my soul is! men who believed in Allah and acknowledged the truthfulness of the Messengers will reach them.''
[Al-Bukhari and Muslim].

Commentary: In Jannah, people will have different grades according to the strength of their Belief and love of Allah. Some people will be on a position near that of the Prophets. May Allah grant us such lofty places. Amin.

1888. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "A space in Jannah equal to the distance between the middle and the end of a bow will be better than all that upon which the sun rises and sets.''
[Al-Bukhari and Muslim].

Commentary: Just a very small -- a wee bit of a place in the Jannah is better than the whole world, as this world would soon come to an end while Jannah will be eternal.

1889. Anas (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "In Jannah there is a market to which the people will come every Friday. The northern wind will blow and shower fragrance on their faces and clothes and, consequently, it will enhance their beauty and loveliness. They will then return to their wives who will also have increased in their beauty and loveliness, and their families will say to them: `We swear by Allah that you have been increased in beauty and loveliness since leaving us.' Thereupon they will reply: `We swear by Allah that you have also been increased in beauty and loveliness since we left you.'''
[Muslim].

Commentary: Bazaar refers to a place of gathering, where everything will be available, free of cost. Similarly, Jumu`ah means that people will gather there for a time period equal to that of Jumu`ah, as there will be no sun, nor night and day. Another speciality of Jannah is that the beauty and charm of men and women will go on increasing and so the love and affection between husbands and wives will also keep on progressing and increasing. It will be just the opposite of what happens here in this world.

1890. Sahl bin Sa`d (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The dwellers of Jannah will see the upper abodes of Jannah as you see the stars in the sky.''
[Al-Bukhari and Muslim].

Commentary: See the Commentary on Hadith No. 1887

1891. Sahl bin Sa`d (May Allah be pleased with him) said: I was in the company of the Prophet (PBUH). He gave a description of Jannah and concluded with these words, "There will be bounties which no eye has seen, no ear has heard and no human heart has ever perceived.'' He (PBUH) then recited this Verse:

"Their sides forsake their beds, to invoke their Rubb in fear and hope, and they spend (in charity in Allah's Cause) out of what We have bestowed on them. No person knows what is kept hidden for them of joy...'' (32:16,17)
[Al-Bukhari].

Commentary: The bliss of Jannah which has been mentioned in the narrations of the Prophet (PBUH) have also been alluded to in the above mentioned Ayat of the Noble Qur'an. That is why the Hadith is considered to be the authorized commentary of the Qur'an. It is commentary without which it is not possible to grasp the real meaning of the Qur'an.

1892. Abu Sa`id and Abu Hurairah (May Allah be pleased with them) reported: The Messenger of Allah (PBUH) said, "When the dwellers of Jannah enter Jannah, an announcer will call: (You have a promise from Allah that) you will live therein and you will never die; you will stay healthy therein and you will never fall ill; you will stay young and you will never become old; you will be under a constant bliss and you will never feel miserable.''
[Muslim].

Commentary: We live in this world according to our life span but we never know when this life may come to an end. Youth is a fleeting experience and with the passage of time it turns into old age. One cannot even be sure about the ease in this life. Any time one may land into hardships. In short, nothing is constant in this world.

In Jannah, however, everything will be permanent. Life will be without any danger of death, there will be health without any risk of disease. There will be happiness and bliss without any fear of aging. Everywhere there will be happiness, ease, comfort, enjoyment without any pain, worry, hardship or distress.

1893. Abu Hurairah (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "The lowest place of any of you in Jannah will be that Allah will tell him to express his wish. He will wish and wish again. Allah will then ask him: `Have you expressed your wish?' He will answer: `Yes, I have.' Allah will say: `You will have what you have wished for and the like thereof along with it.'''
[Muslim].

1894. Abu Sa`id Al-Khudri (May Allah be pleased with him) said: The Messenger of Allah (PBUH) said, "Allah, the Rubb of honour and glory, will say to the inhabitants of Jannah: `O inhabitants of Jannah!' They will respond: `Here we are! At Your service, O our Rubb. All good is in Your Hand!' He will ask them: `Are you pleased?' They will reply: `Why should we not be pleased, O Rubb, when You have given us what You have not given to any of Your creatures?' Allah will say: `Shall I not give you something better than that?' They will ask: `O Rubb! What can be better than that?' Allah will say: `I shall bestow My Pleasure upon you and I shall never be displeased with you.'''
[Al-Bukhari and Muslim].

Commentary: The declaration about Allah being pleased with the dwellers of Jannah will certainly be the greatest of the boons and rewards of Jannah.

1895. Jarir bin `Abdullah (May Allah be pleased with him) reported: We were sitting with the Messenger of Allah (PBUH) when he looked at the full moon and observed, "You shall see your Rubb in the Hereafter as you are seeing this moon; and you will not feel the slightest inconvenience in seeing Him.''
[Al-Bukhari and Muslim].

Commentary: Just as when we witness the moon there is no problem, no rush or troublesome gathering of people and no pushing of one another, the pious will see Allah without any trouble or difficulty. How shall we see Him, we cannot describe this even by any instance or parable. In Surat Ash-Shu`ra', Verse 11, it is said that there is nothing like Him. However, we cannot see Him in this world with these worldly eyes. The reason is that, as Imam Malik says, these eyes are just temporary and they cannot bear the Sight of Allah. This is why the research scholars claim that the Prophet (PBUH) did not actually see Allah during his journey to the heavens; he only talked to Allah by way of Revelation. The saying of `Aishah (May Allah be pleased with her) also proves this contention. However, it would be possible to see Allah in Jannah as everything there will be eternal and indestructible. Similar will be the case with the sight and eyes which will be provided to us there. Such eyes would have the power to see Allah.

1896. Suhaib (May Allah be pleased with him) reported: The Messenger of Allah (PBUH) said, "When the inhabitants of Jannah enter Jannah, Allah, the Glorious and Exalted, will say to them: `Do you wish me to give you anything more?' They will reply: `Have You not made our faces bright? Have You not brought us into Jannah and delivered us from the Hell?' And Allah will remove the Veil. The (dwellers of Jannah) will feel that they have not been awarded anything dearer to them than looking at their Rubb.''
[Muslim].

Allah, the Exalted, says:

"Verily, those who believe and do deeds of righteousness, their Rubb will guide them through their Faith; under them will flow rivers in the Gardens of Delight (Jannah). Their way of request therein will be Subhanaka Allahumma (Glory to You, O Allah!) and Salam (peace, safety from evil) will be their greetings therein (Jannah)! and the close of their request will be: Al-hamdu lillahi Rabbil-`Alamin [All the praises and thanks are to Allah, the Rubb of `Alamin (mankind, jinn and all that exists)].'' (10:9,10)